Discar e acessar : Dial-on-Demand Routing (DDR)

DDR de ISDN usando o encapsulamento HDLC

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Há duas maneiras diferentes de se usar o HDLC (High-Level Data Link Control) em ISDN:

  • Defina a interface física para executar o HDLC. Ou seja nenhum encapsulamento é definido desde que o HDLC é o encapsulamento padrão usado pelo software de Cisco IOS�. Este é o modo original de configurar HDLC com Dial-on-Demand Routing (DDR) e é discutido neste documento.

  • Use a interface do discador para vincular o protocolo que deseja (nesse exemplo, HDLC) a um discador específico. Este é o método mais novo e permite a uma interface física específica tratar protocolos múltiplos (por exemplo, Point-to-Point Protocol [PPP] e HDLC). Como o protocolo é configurado na interface do discador, a interface física não é restrita. Este método é conhecido como Encapsulamentos múltiplos dinâmicos e discutido em ISDN DDR Utilizando Encapsulamento HDLC com Vários Encapsulamentos Dinâmicos.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Os roteadores taxbol e goya são 2500 Series Routers usados em um ambiente de laboratório com as configurações apagadas.

  • O Cisco IOS Software Release 11.2(22) é utilizado em ambos os roteadores.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Por que utilizar o HDLC?

A razão pela qual um usuário exige o HDLC no ISDN não é óbvia, porque ele que tem muitas desvantagens em comparação ao PPP. A única finalidade é simplificar a configuração. Contudo, ele também simplifica o acesso ao roteador para todos os hackers. Como HDLC não oferece suporte a nenhum tipo de autenticação, a melhor proteção aqui seria verificar o número chamado com o comando isdn caller na interface. Consulte Configuração de Triagem CLI ou Autenticação ISDN e Retorno de Chamada com ID de Chamador para obter informações adicionais. A autenticação com base em CLID (Identificação de Linha Chamadora) admite que sua Telco fornece o número chamador nas mensagens de instalação ISDN. Contudo, como muitas Telcos não fornecem CLID, verifique com sua Telco antes que você configure a triagem baseada no CLID. Se o CLID não for fornecido pela Telco, todas as chamadas recebidas no roteador falharão.

Uma outra desvantagem do HDLC é que o roteador não instala um mapa dinâmico. Por isso, um mapa de discadores precisa ser configurado (em cada extremidade) para o peer HDLC.

Nota: Se somente um lado faz a chamada (por exemplo, um roteador sempre aceita a chamada e não faz discagem) certifique-se de que você inclua um nome para o peer remoto na instrução dialer map do lado receptor. Contudo, o nome pode ser um nome falsificado porque que o roteador não tem nenhuma maneira de autenticar o nome do peer para determinar se corresponde ao nome de mapa de discadores.

Por exemplo, esta é uma descrição e este número ISDN é 8130.

  ip address 172.16.1.6 255.255.255.252 
  isdn caller 8129 

  !--- This is to accept only calls from 8129. 

  dialer map ip 172.16.1.5 name bogus_to_accept_command

  !--- This is a dialer-map with a fake name. 

  dialer-group 1 

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos usados neste documento use a ferramenta de Consulta de comando.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/10369/bri_ddr_hdlcencap.gif

Configurações

goya
Current configuration:
!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname goya
!

isdn switch-type basic-net3 

!--- The switch-type used is basic-net3. If you are in the United States,  
!--- configure the correct switch-type (for example
!--- isdn switch-type basic-5ess). In the US, you also need to
!--- configure the spids under the Basic Rate Interface (BRI) interface.
  
! 
interface Ethernet0 
 ip address 10.1.1.1 255.255.255.0 
 no ip redirects 
! 
interface BRI0 

 !--- If you are in the US do not forget the SPID 
!--- (for example isdn spid1 01555.....) 

 description This ISDN number is 8129 
 ip address 172.16.1.5 255.255.255.252 
 dialer idle-timeout 60
 
!--- The idle is set to 60 seconds. 
 
  isdn caller 8130 
 
!--- Verify the incoming number since there is no authentication on HDLC. 

 dialer map ip 172.16.1.6 8130

 !--- This side is making the call to 8130.  

 dialer-group 1 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.1.6 
access-list 105 permit icmp any any

!--- This access-list is to debug ICMP only. 

dialer-list 1 protocol ip permit 
! 
line con 0 
 exec-timeout 0 0 
 transport input none 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 no login 
! 
end

traxbol
Current configuration: 
! 
version 11.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname traxbol 
! 

isdn switch-type basic-net3 

!--- The switch-type used here is basic-net3. If you are in the United States,  
!--- configure the correct switch-type (for example
!--- isdn switch-type basic-5ess). In the United States, you also need to
!--- configure the SPIDs under the BRI interface. 
  
! 
Interface Ethernet0 
 ip address 10.1.2.1 255.255.255.0 
 no ip redirects 
! 
interface BRI0 

 !--- If you are in the United States, do not forget the SPID 
!--- (for example isdn spid1 01555.....). 

 description This ISDN number is 8130 
 ip address 172.16.1.6 255.255.255.252 
 isdn caller 8129 

 !--- Verify the incoming number since there is no authentication on HDLC. 

 dialer map ip 172.16.1.5 name goya

 !--- This side will not make any calls, but "name goya" is added to complete the
 !--- command. This is because a static dialer map is necessary.

 dialer-group 1 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.1.5 
access-list 105 permit icmp any any

!--- This access-list is to debug ICMP only. 

dialer-list 1 protocol ip permit 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password ww 
 login 
! 
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração funciona adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show interfaces bri number- Especificar somente o número exibe o canal D para essa interface BRI.

    Comando Descrição
    número Número da interface. O valor é de 0 a 7 se o roteador tiver um NIM BRI de 8 portas, ou de 0 a 15 se o roteador tiver dois NIMs BRI de 8 portas. Os valores do número de interface variam, baseados na plataforma de hardware usada. O Cisco 3600 Series Router por exemplo, pode ter até 48 relações.

Como nenhum encapsulamento foi definido na configuração, por padrão é HDLC. Isso pode ser verificado com o comando show interface como mostrado aqui:

 goya#show interfaces bri 0 
  BRI0 is up, line protocol is up (spoofing) 
   Hardware is BRI 
   Description: This ISDN number is 8129 
   Internet address is 172.16.1.5/30 
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255 
   Encapsulation HDLC, loopback not set 
   
!--- HDLC is configured automatically
 
   Last input 00:00:00, output 00:00:00, output hang never 
   Last clearing of "show interface" counters never 
   Input queue: 0/75/0 (size/max/drops); Total output drops: 0 
   Queueing strategy: weighted fair 
   Output queue: 0/1000/64/0 (size/max total/threshold/drops)   
    Conversations  0/1/256 (active/max active/max total) 
    Reserved Conversations 0/0 (allocated/max allocated) 
    5 minute input rate 0 bits/sec, 0 packets/sec 
    5 minute output rate 0 bits/sec, 0 packets/sec 
      3933 packets input, 20462 bytes, 0 no buffer 
      Received 15 broadcasts, 0 runts, 0 giants, 0 throttles 
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
      3926 packets output, 26100 bytes, 0 underruns 
      0 output errors, 0 collisions, 10 interface resets 
      0 output buffer failures, 0 output buffers swapped out 
      7 carrier transitions

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • debug dialer

  • debug ip packet detail 105 — Usado para debugar os pacotes IP que são somente ICMP (consulte access-list 105 na configuração).

  • debug isdn q931 — Usado para ver o evento e pacotes ISDN Q.931.

  • debug serial interface — Usado para debugar o HDLC.

Exemplos de debugação de ambos os roteadores são mostrados aqui:

A saída de goya:

goya#debug dialer 
Dial on demand events debugging is on 
goya#debug ip packet detail 105 
IP packet debugging is on (detailed) for access list 105 
goya#debug isdn q931 
ISDN Q931 packets debugging is on

!--- Verify that the map is correctly configured. 

goya#show dialer map 
Static dialer map ip 172.16.1.6 name traxbol (8130) on BRI0 
goya#ping? 172.16.1.6 

!--- Ping to the remote destination. 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds: 
*Mar? 1 05:40:07.230: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), len 100, sending

!--- The Ping attempts to leave the router. 

*Mar? 1 05:40:07.234:???? ICMP type=8, code=0 
*Mar? 1 05:40:07.238: BRI0: Dialing cause ip (s=172.16.1.5, d=172.16.1.6) 
*Mar? 1 05:40:07.238: BRI0: Attempting to dial 8130 

!--- The dialer attempts the call. 

*Mar? 1 05:40:07.242: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100,
   encapsulation failed

!--- This is because the HDLC is not ready. 
!--- Therefore,  the encapsulation failed.
  
*Mar? 1 05:40:07.246:???? ICMP type=8, code=0 
 
*Mar? 1 05:40:07.258: ISDN BR0: TX ->? SETUP pd = 8? callref = 0x37 
*Mar? 1 05:40:07.258:???????? Bearer Capability i = 0x8890 
*Mar? 1 05:40:07.262:???????? Channel ID i = 0x83 
*Mar? 1 05:40:07.266:???????? Called Party Number i = 0x80, '8130' 
*Mar? 1 05:40:07.318: ISDN BR0: RX <-? CALL_PROC pd = 8? callref = 0xB7 
*Mar? 1 05:40:07.322:???????? Channel ID i = 0x89 
*Mar? 1 05:40:07.470: ISDN BR0: RX <-? CONNECT pd = 8? callref = 0xB7 
*Mar? 1 05:40:07.486: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 05:40:07.514: ISDN BR0: TX ->? CONNECT_ACK pd = 8? callref = 0x37

!--- The call is made.

*Mar? 1 05:40:07.!!!! 

!--- One ping packet was lost because the encapsulation was not ready. 

Success rate is 80 percent (4/5), round-trip min/avg/max = 52/58/76 ms 
goya#.518: dialer Protocol up for BR0:1 
*Mar? 1 05:40:07.526: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up 
*Mar? 1 05:40:09.230: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.234:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.278: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.278:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.282: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.286:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.330: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.334:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.338: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.338:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.406: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.410:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.414: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.418:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.462: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 

!--- Other four ping packets are successful.

*Mar? 1 05:40:09.466:???? ICMP type=0, code=0 
goya# 
*Mar? 1 05:40:13.674: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8130
   traxbol 
!? 

!--- View the dialer.

!
goya#show dialer 

BRI0 - dialer type = ISDN 
Dial String????? Successes?? Failures??? Last called?? Last status 
8130?????????????????? 299???????? 10??? 00:00:11?????? successful 
0 incoming call(s) have been screened. 
BRI0:1 - dialer type = ISDN 
Idle timer (60 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is data link layer up 

!--- The next two lines tell who triggered the call 
!--- and the time remaining before disconnect. 

Dial reason: ip (s=172.16.1.5, d=172.16.1.6) 
Time until disconnect 50 secs 
Connected to 8130 (traxbol) 

BRI0:2 - dialer type = ISDN 
Idle timer (60 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is idle 
goya# 
!

!--- View the HDLC.

!
goya#debug serial interface? 
Serial network interface debugging is on 
goya#ping 172.16.1.6
 Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/93/328 ms 
goya# 
*Mar? 1 06:35:03.266: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 06:35:03.814: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
*Mar? 1 06:35:04.822: BRI0:1: HDLC myseq 0, mineseen 0, yourseen 0, line up? 
*Mar? 1 06:35:09.846: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8130
   traxbol 
*Mar? 1 06:35:14.826: BRI0:1: HDLC myseq 1, mineseen 1*, yourseen 1, line up? 
*Mar? 1 06:35:24.838: BRI0:1: HDLC myseq 2, mineseen 2*, yourseen 2, line up? 
*Mar? 1 06:35:34.842: BRI0:1: HDLC myseq 3, mineseen 3*, yourseen 3, line up? 
*Mar? 1 06:35:44.846: BRI0:1: HDLC myseq 4, mineseen 4*, yourseen 4, line up? 
*Mar? 1 06:35:54.850: BRI0:1: HDLC myseq 5, mineseen 5*, yourseen 5, line up? 
*Mar? 1 06:36:03.862: %ISDN-6-DISCONNECT: Interface BRI0:1? disconnected from
   8130 traxbol, call lasted 60 seconds 
*Mar? 1 06:36:03.974: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down 
*Mar? 1 06:36:04.858: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to down 
goya#undebug all 
All possible debugging has been turned off 
goya# 

A saída de traxbol:

traxbol#debug dialer 
Dial on demand events debugging is on 
traxbol#debug ip packet detail 105 
IP packet debugging is on (detailed) for access list 105 
traxbol#debug isdn q931 
ISDN Q931 packets debugging is on 

!--- Verify that the map is correctly configured. 

traxbol#show dialer map 
Static dialer map ip 172.16.1.5 name goya (8129) on BRI0 
traxbol# 

!--- A call is received, notice that the calling party 
!--- matches the ISDN caller configuration.

*Mar? 1 05:40:30.898: ISDN BR0: RX <-? SETUP pd = 8? callref = 0x15 
*Mar? 1 05:40:30.898:???????? Bearer Capability i = 0x8890 
*Mar? 1 05:40:30.902:???????? Channel ID i = 0x89 
*Mar? 1 05:40:30.906:???????? Calling Party Number i = 0xA1, '8129' 
*Mar? 1 05:40:30.906:???????? Called Party Number i = 0xC1, '8130' 
*Mar? 1 05:40:30.918: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 05:40:30.954: ISDN BR0: TX ->? CONNECT pd = 8? callref = 0x95 
*Mar? 1 05:40:30.958: dialer Protocol up for BR0:1 
*Mar? 1 05:40:31.014: ISDN BR0: RX <-? CONNECT_ACK pd = 8? callref = 0x15 
*Mar? 1 05:40:31.018:???????? Channel ID i = 0x89 
*Mar? 1 05:40:31.862: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up 

!--- debug ip packet detail 105 shows the ICMPs on this router. 

*Mar? 1 05:40:32.794: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.798:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.802: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.802:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.850: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.854:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.854: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.858:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.926: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.930:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.930: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.934:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.982: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.982:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.986: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.990:???? ICMP type=0, code=0 
*Mar? 1 05:40:36.994: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8129 goya
! 

!--- On the dialer, the call is received.
!--- There is no dial reason. However, the idle has been using the
!--- default 120 seconds since nothing was configured. 
!--- The router GOYA closes
!--- the call earlier because the idle is set to 60 seconds on that side.

!
traxbol#show dialer 

BRI0 - dialer type = ISDN 

Dial String????? Successes?? Failures??? Last called?? Last status 
8129???????????????????? 0????????? 0??? never?????????????????? - 
10 incoming call(s) have been screened. 

BRI0:1 - dialer type = ISDN 
Idle timer (120 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is data link layer up 
Time until disconnect 103 secs 
Connected to 8129 (goya) 

BRI0:2 - dialer type = ISDN 
Idle timer (120 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is idle 
traxbol# 
!

!--- View the HDLC.

!
traxbol#debug serial interface 
Serial network interface debugging is on 
traxbol# 
*Mar? 1 06:35:26.674: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 06:35:26.698: Ser-Autodetect BR0:1: no autodetect configuration 
*Mar? 1 06:35:27.534: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
*Mar? 1 06:35:31.554: BRI0:1: HDLC myseq 0, mineseen 0*, yourseen 1, line up? 
*Mar? 1 06:35:33.578: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8129
   goya 
*Mar? 1 06:35:41.598: BRI0:1: HDLC myseq 1, mineseen 1*, yourseen 2, line up? 
*Mar? 1 06:35:51.702: BRI0:1: HDLC myseq 2, mineseen 2*, yourseen 3, line up? 
*Mar? 1 06:36:01.746: BRI0:1: HDLC myseq 3, mineseen 3*, yourseen 4, line up? 
*Mar? 1 06:36:11.790: BRI0:1: HDLC myseq 4, mineseen 4*, yourseen 5, line up? 
*Mar? 1 06:36:21.894: BRI0:1: HDLC myseq 5, mineseen 5*, yourseen 6, line up? 
*Mar? 1 06:36:27.510: %ISDN-6-DISCONNECT: Interface BRI0:1? disconnected from 8129
   goya, call lasted 60 seconds 
*Mar? 1 06:36:27.514: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down 
*Mar? 1 06:36:27.922: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to down 
traxbol#undebug all 
All possible debugging has been turned off 
traxbol# 

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10369