Discar e acessar : Conexões assíncronas

Conexão de roteadores back-to-back através das portas auxiliares (AUX)

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo mostra como conectar diretamente dois roteadores sem um modem ou outros dispositivos de Equipamento de comunicação de dados (DCE, data communications equipment) de comunicação de dados. Para obter mais informações sobre como configurar modems em portas console ou auxiliares (AUX), consulte Guia de Conexão Modem-Roteador ou Suporte à Tecnologia de Discagem de Acesso.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Nesta configuração, dois roteadores Cisco são conectados lado a lado por meio das portas auxiliares (AUX) assíncronas com a ajuda de um cabo de modem nulo (cabo de console (rollover)). As portas AUX dos dois roteadores são conectadas diretamente com a ajuda de um cabo de console (rollover) com Point-to-Point Protocol (PPP) em execução no link. As portas AUX são dispositivos de equipamento de terminal de dados (DTE) Você precisará de um cable de modem nulo (cabo de console (rollover)) para conectar DTE a dispositivos DTE.

Um cabo de rollover (modem nulo) liso de cetim (número de peça CAB-500RJ= ) geralmente é fornecido com cada roteador Cisco para permitir conectividade com o console RJ-45. Se a porta AUX for DB-25, utilize um adaptador RJ-45-para-DB-25 marcado com "terminal" com o cabo de modem nulo (cabo de console (rollover)).

Nota: Assegure-se de que o tamanho do cabo seja inferior a 50 pés devido às limitações de EIA/TIA-232 (conhecido anteriormente como RS-232).

Para obter mais informações sobre o cabeamento, consulte Guia de Cabeamento para Portas Console RJ-45 e AUX e cabos RJ-45.

Roteadores com portas DB-25 AUX

Para roteadores com uma porta AUX DB-25 (por exemplo, Cisco 4500, 7200 e 7500), você precisa de um cabo de modem nulo DB-25-para-DB-25. Este cabo pode ser adquirido na maioria das lojas de varejo de eletrônica.

Nota: Devido a pares de sinais incorretos, você NÃO pode utilizar um cabo RJ-45-para-RJ-45 com adaptadores RJ-45-para-DB-25 (número de peça CAB-25AS-MMOD) em ambas as extremidades.

Verifique se o cabo de modem nulo DB-25-para-DB-25 tem as conexões de pino indicadas na tabela 1.

Tabela 1 – Conexões de Pino do Cabo de Modem Nulo DB-25-para-DB-25

DB-25 DB-25
RxD 2 3 TXD
TxD 3 2 RxD
CTS 4 5 RTS
RTS 5 4 CTS
DTR 6 20 CD
DSR 8
CD 20 6 DTR
8 DSR
GND 7 7 GND

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/10365/auxback.gif

Configurações

Este documento utiliza as seguintes configurações:

  • Roteador 1

  • Roteador 2

Nota: Esta conexão foi configurada com endereços IP nas portas AUX para uma conexão permanente (dedicada).

Roteador 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Roteador 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Procedimento de Troubleshooting

Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

Conclua estes passos:

  1. Utilize o comando show line para determinar a interface assíncrona das portas AUX.

    Embora a maioria de Roteadores tem o porto auxiliar como o interface async 1, os servidores de acesso têm a interface de porto auxiliar após as linhas tty. Por exemplo, se seu roteador tiver 16 linhas assíncronas/de modem, a porta AUX será a linha 17. Nesse caso, a porta AUX deve ser configurada na interface assíncrona 17. Configure a porta AUX com base nas saídas show line. Aqui está um exemplo para verificar se a configuração de porta AUX está em interface Async1 nos roteadores:

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. Emita o comando show line aux 0.

  3. Verifique se todos os sinais estão ativos (por exemplo, CTS (Clear to Send, Limpar para Enviar), RTS (Request to Send, Solicitar para Enviar), DTR (data terminal ready, terminal de dados pronto) e CD (Carrier Detect, Detecção de Operadora)).

    Se nada aparecer ao lado deles, eles estarão ativados. Se aparecer um “No” (Não) ao lado deles (por exemplo, Não-CTS), isto significará que estão desativados. Se estiverem desativados, verifique a configuração em cada lado. Verifique se você tem a interface assíncrona e a linha da porta auxiliar (AUX) configurada (conforme mostrado acima).

    Nota: Se a saída de comando show line indicar que o DSR não está ativado (noDSR), você deverá verificar se cada extremidade no modem a cabo nulo DB-25-para-DB-25 tem pinos 6 e 8 presos fisicamente ao pino 20 no outro lado. Consulte a tabela 1 para obter os pinouts corretos.

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. Se a configuração estiver correta, substitua o cabo de rollover entre o roteador.

  5. Utilize os comandos shutdown e no shutdown na interface assíncrona para reiniciar a conexão.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Utilize estes comandos debug para verificar se o link é ativado corretamente.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • debug ppp negotiation — mostra informações sobre trocas e sobre o tráfego PPP durante a negociação dos componentes PPP, como o Link Control Protocol (LCP), a Autenticação e o Network Control Protocol (NCP). Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP e, em seguida, autenticará e, finalmente, negociará o NCP. Se CONFREQs forem enviados, mas nenhum CONFACK for recebido, verifique se o cabeamento está correto e se a linha correta está configurada (emita o comando interface async x para isso).

  • debug ppp authentication — exibe mensagens de protocolo de autenticação PPP (se a autenticação estiver configurada) e inclui intercâmbios de pacotes Challenge Handshake Authentication Protocol (CHAP) e Password Authentication Protocol (PAP). Nesta configuração, a autenticação não é configurada. Por isso, este comando debug não é necessário.

  • debug ppp error — mostra erros de protocolo e estatísticas de erros associados à negociação e à operação da conexão PPP.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10365