Discar e acessar : Conexões assíncronas

Configurando o dialout com o módulo de modem analógico NM-8AM ou NM-16AM

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como configurar a discagem usando um modem com o módulo de rede de modem analógico NM-AM. Nesta encenação, um roteador com o módulo de modem NM-8AM disca a relação da taxa principal (PRI) do roteador de site central.

Este documento supõe que você tem uma boa compreensão das várias edições associadas com as configurações de modem. Se você precisa mais informação nestas edições, refira por favor o guia de conexão de roteador de modem.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo:

  • Um Cisco 3640 Router com o cartão NM-8AM que executa o Software Release 12.1(5)T de Cisco IOS�.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/10316/dialout-nmam.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

Roteador1 (Cisco 3640)
Current configuration : 1676 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
enable password ww
!
username router2 password 0 ww

!--- username for remote router (Router 2) and shared secret
!--- shared secret(used for CHAP authentication) must be the same on both sides

ip subnet-zero
!
chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!--- chat script "async" used for the dialout connection

!
!
interface Ethernet2/0
 ip address 10.200.20.51 255.255.255.0
 half-duplex
!
interface Async104	

!--- async interface corresponding to the modem 
!--- This was determined using the show line command.

 ip address 10.10.0.2 255.255.255.252

!--- IP address of this async interface

 encapsulation ppp
 dialer in-band
 dialer wait-for-carrier-time 180
 dialer map ip 10.10.0.1 name router2 modem-script async 8214

!--- dialer map statements for the remote router 
!--- The name must match the one used by the remote router to identify itself.
!--- use modem chat script "async" for this connection

 dialer-group 1
!--- apply interesting traffic definition from dialer-list 1
 async mode dedicated

!--- Place the line into dedicated asynchronous network mode.
!--- This interface is now automatically configured for PPP connections.

 ppp authentication chap
!--- use chap authentication
!
ip classless
ip route 10.10.0.0 255.255.0.0 10.10.0.1

!--- Traffic for the 10.10.0.0/16 network uses a next hop of 10.10.0.1

ip route 10.10.0.1 255.255.255.255 Async104	

!--- the next hop for 10.10.0.1/32 (which is also the next hop for the 
!--- previous route) is interface Async104.

!
dialer-list 1 protocol ip permit

!--- All IP traffic is defined interesting.
!--- This is applied to Async104 using dialer-group 1.

!
!
line con 0
 exec-timeout 0 0
 password ww transport input none
line 33 38
line 97 103
 modem InOut transport input all
line 104		

!--- line interface configuration for Async 104

 modem InOut	

!--- allow incoming and outgoing modem calls on this line
	
 transport input all
 transport output lat pad v120 lapb-ta telnet rlogin udptn
 flowcontrol hardware
line aux 0
line vty 0 4
 password ww
 login
!
end

Neste 3600 chassis, o cartão NM-8AM é instalado no entalhe 3. que refere como as linhas assíncrono são numeradas nos Cisco 3600 Series Router documento, nós verifica que o entalhe 3 tem a linha 97 com o 128 reservado. Para determinar que interface assíncrona específica você deve configurar, use o comando show line encontrar as linhas disponíveis. Nesta configuração, note que somente as linhas 97-104 (8 linhas) estão disponíveis dentro dessa escala. Daqui, para configurar o primeiro modem no cartão configurar a linha 97 (e relação async97) quando o último modem for line/async104.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting de Conexão Analógica

Termine estas etapas a fim pesquisar defeitos a conexão dialout:

  1. Verifique a configuração de modem.

    Verifique a configuração do modem. Você deve verificar a configuração de linha que correspondem ao modem assim como o async da relação.

  2. Inverta o telnet ao modem e inicie uma discagem.

    Inverta o telnet para fora a porta ao modem, e use no comando set discar e conectar ao dispositivo remoto. Isso pode ser usado para verificar se o hardware do modem e o circuito do telefone estão funcionando. Neste exemplo, desde que a porta de modem está na linha 104, inverta o telnet à porta 2104 no roteador. Para obter mais informações sobre dos telnet reversos, refira o estabelecimento de uma sessão de Telnet reversa a um modem.

    router1#telnet 10.200.20.51 2104 
    Trying 10.200.20.51, 2104  ... Open
    User Access Verification
    Username: admin
    Password: 
    
    !--- Authentication performed by local router for the reverse telnet
    
    at
    OK
    atdt 81690
    
    !--- The modem dials (81690) and connects.
    !--- This takes approximately 30-45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connect speed and protocols that were negotiated
    
    User Access Verification
    Username: admin
    Password:
    
    !--- Authentication performed by remote router for the incoming call
     
    router2>
    
    !--- Remote router's prompt
    
    

    Você pode igualmente aplicar outro em comandos a fim verificar as configurações de modem. Refira no comando set e o sumário de registro para os módulos de rede de modem analógico para obter mais informações sobre do no comando disponível para os módulos de modem analógico.

  3. Ative chat script manualmente e inicie um seletor.

    Use o comando start-chat a fim ativar chat script e iniciar um seletor. O comando start-chat exige-o especificar chat script o nome do a ser ativado, o número de telefone a ser discados, e a interface de modem para discar para fora sobre.

  4. Verifique que há uma rota à interface assíncrona.

    Use o comando show ip route a fim verificar se haja uma rota à interface assíncrona. Se não há nenhuma rota, crie uma rota estática. Um exemplo é mostrado:

    ip route 10.10.0.1 255.255.255.255 Async104 
  5. Gere um sibilo destinado para a rede de próximo salto especificada em etapa 4.

    Um sibilo para o roteador remoto, que é especificado usando a rede de próximo salto de etapa 4, faz com que o roteador disque o dispositivo remoto.

    router1#ping 10.10.0.1
    

Refira pesquisando defeitos chamadas externas para obter mais informações sobre de como pesquisar defeitos sua conexão.

Erros comuns

  • Verifique que chat script o nome é idêntico a esse especificado na instrução de mapa de discador. Igualmente verifique que o número de telefone a ser discado está especificado corretamente.

  • Verifique para ver que o tráfego interessante está definido corretamente. O tráfego interessante é especificado com o comando dialer-list.

  • Assegure-se de que a definição de tráfego interessante esteja aplicada à interface assíncrona. Isto é feito usando o comando dialer-group, onde o número do grupo deve combinar a definição de tráfego interessante especificada com o comando dialer-list.

  • Verifique que o nome de usuário e senha para a autenticação PAP/CHAP está correto.

  • Verifique para certificar-se de que a instrução de mapa de discador tem o nome, o endereço IP de Um ou Mais Servidores Cisco ICM NT, e o número de telefone corretos a discar.

Comandos debug

Antes de emitir comandos de depuração, consulte Informações Importantes sobre Comandos de Depuração.

  • debug dialer – Para exibir as informações de depuração sobre os pacotes recebidos em uma interface de discador. Quando o roteamento por encomenda do seletor (DDR) é permitido na relação, a informação a respeito da causa de todo o atendimento (chamado a causa de discagem) está indicada igualmente. Para obter mais informações, consulte as informações sobre debug dialer na documentação Comandos debug.

  • debugar o modem - Para indicar a atividade de linha de modem, o controle do modem, e os mensagens de ativação do processo no roteador.

  • debugar o bate-papo - Para monitorar chat script a execução do quando discar async/POTS for iniciado. Consulte Tecnologia de Dial-up: Técnicas de Troubleshooting para obter mais informações.

  • debugar a negociação ppp - Ao Exibir informação no PPP trafique e trocas ao negociar os componentes de PPP que incluem o protocolo de controle de link (LCP), a autenticação, e o protocolo network control (NCP). Uma negociação de PPP bem-sucedida primeiramente abrirá o estado LCP, a seguir autentica, e negocia finalmente o NCP.

  • debugar a autenticação de PPP - Para indicar os mensagens de protocolo da autenticação de PPP, incluindo intercâmbios de pacotes do protocolo challenge authentication (RACHADURA) e trocas do protocolo password authentication (PAP).

Exemplo de debug

router1#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
Generic IP:
  ICMP packet debugging is on
PPP:
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
router1#
router1#ping 10.10.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.0.1, timeout is 2 seconds:
*Mar  1 00:22:58.663: As104 DDR: Dialing cause ip (s=10.10.0.2, d=10.10.0.1)

!--- Dialing reason is the ping for 10.10.10.1
!--- The dialout is using Async104.

*Mar  1 00:22:58.663: As104 DDR: Attempting to dial 8214

!--- Phone number to be dialed

*Mar  1 00:22:58.663: CHAT104: Attempting async line dialer script
*Mar  1 00:22:58.663: CHAT104: Dialing using Modem script: async & System script: none

!--- Use chat script named "async"

*Mar  1 00:22:58.663: CHAT104: process started
*Mar  1 00:22:58.667: CHAT104: Asserting DTR
*Mar  1 00:22:58.667: CHAT104: Chat script async started

!--- Chat-script "async" is started.

*Mar  1 00:22:58.667: CHAT104: Sending string: AT
*Mar  1 00:22:58.667: CHAT104: Expecting string: OK
*Mar  1 00:22:58.739: CHAT104: Completed match for expect: OK
*Mar  1 00:22:58.739: CHAT104: Sending string: ATDT\T<8214>
*Mar  1 00:22:58.739: CHAT104: Expecting string: CONNECT
*Mar  1 00:22:58.751: Modem 3/7 Mcom: in modem state 'Dialing/Answering'
*Mar  1 00:23:10.775: Modem 3/7 Mcom: in modem state 'Waiting for Carrier'
*Mar  1 00:23:21.903: Modem 3/7 Mcom: in modem state 'Connected'
*Mar  1 00:23:22.323: Modem 3/7 Mcom: CONNECT at 26400/24000(Tx/Rx), V34, LAPM, V42bis,
 Originate

!--- Connect speeds, protocols and so forth, and so on negotiated for the connection
!--- Note that the modem used is 3/7 which is equivalent to line 104.
!--- Refer to How Async Lines are Numbered in Cisco 3600 Series Routers.

*Mar  1 00:23:22.375: CHAT104: Completed match for expect: CONNECT
*Mar  1 00:23:22.375: CHAT104: Sending string: \c
*Mar  1 00:23:22.375: CHAT104: Chat script async finished, status = Success

!--- Chat script is successful. Notice the Expect/Send attributes and the time elapsed.

*Mar  1 00:23:22.375: Modem 3/7 Mcom: switching to PPP mode
*Mar  1 00:23:22.379: TTY104: no timer type 1 to destroy
*Mar  1 00:23:22.379: TTY104: no timer type 0 to destroy
*Mar  1 00:23:22.379: As104 IPCP: Install route to 10.10.0.1
*Mar  1 00:23:24.379: %LINK-3-UPDOWN: Interface Async104, changed state to up
*Mar  1 00:23:24.379: As104 DDR: Dialer statechange to up
*Mar  1 00:23:24.379: As104 DDR: Dialer call has been placed
*Mar  1 00:23:24.379: As104 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 00:23:24.379: As104 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar  1 00:23:24.379: Modem 3/7 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0
*Mar  1 00:23:24.379: As104 LCP: O CONFREQ [Closed] id 17 len 25
*Mar  1 00:23:24.379: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.379: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.379: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.379: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.379: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: I CONFREQ [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: O CONFACK [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.555: As104 LCP: I CONFACK [ACKsent] id 17 len 25
*Mar  1 00:23:24.555: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.555: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.559: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.559: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.559: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.559: As104 LCP: State is Open

!--- LCP negotiation is complete.

*Mar  1 00:23:24.559: Modem 3/7 Mcom: PPP escape map: Tx map = A0000, Rx map = 0
*Mar  1 00:23:24.559: As104 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

!--- Two-way PPP authentication begins.

*Mar  1 00:23:24.559: As104 CHAP: O CHALLENGE id 4 len 28 from "router1"
*Mar  1 00:23:24.691: As104 CHAP: I CHALLENGE id 1 len 28 from "router2"
*Mar  1 00:23:24.691: As104 CHAP: O RESPONSE id 1 len 28 from "router1"
*Mar  1 00:23:24.707: As104 CHAP: I RESPONSE id 4 len 28 from "router2"
*Mar  1 00:23:24.707: As104 CHAP: O SUCCESS id 4 len 4
*Mar  1 00:23:24.815: As104 CHAP: I SUCCESS id 1 len 4

!--- Incoming and outgoing CHAP authentication is successful.

*Mar  1 00:23:24.815: As104 PPP: Phase is UP [0 sess, 0 load]
*Mar  1 00:23:24.819: As104 IPCP: O CONFREQ [Closed] id 6 len 10
*Mar  1 00:23:24.819: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.835: As104 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:23:24.835: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.839: As104 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:23:24.839: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.931: As104 IPCP: I CONFACK [ACKsent] id 6 len 10
*Mar  1 00:23:24.931: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.931: As104 IPCP: State is Open

!--- IP Control Protocol (IPCP) negotiation is complete.

*Mar  1 00:23:24.931: As104 DDR: dialer protocol up
*Mar  1 00:23:25.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async104,
 changed state to up

!--- Interface is up.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10316