WAN : Frame Relay

Configurando backup de ISDN para enlaces de WAN usando rotas estáticas flutuantes

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Essa configuração de exemplo mostra como você pode fazer backup de um link de frame relay com Integrated Services Digital Network (ISDN) usando rotas flutuantes e Dial-on-Demand Routing (DDR).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo.

  • Cisco 2503 Routers

  • O Software Release 12.2(7b) de Cisco IOS� estava sendo executado em ambo o Roteadores

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Material de Suporte

Uma meta de implementação de links WAN é fornecer uma maneira de fazer backup do link, se ele falhar. O ISDN fornece frequentemente este backup. A Cisco fornece estratégias de backup que podem realizar a mesma funcionalidade, mas de várias maneiras diferentes. Se as informações de roteamento forem passadas pelo enlace do Frame Relay, uma rota estática flutuante pode ativar o enlace de backup se o enlace do Frame Relay parar de passar informações.

Nota: Este exemplo mostra um backup para o Frame Relay usando Rotas estáticas flutuantes. Contudo, você pode igualmente usar este backup do método todo o link MACILENTO.

As outras soluções podem empregar uma Interface de backup (veja configurar uma Interface de backup para uma subinterface) ou o Dialer Watch. Caso utilize o comando backup interface, as subinterfaces ponto a ponto são vantajosas porque as interfaces principal ou multiponto podem permanecer no estado ativa/ativa, mesmo se as Conexões virtuais permanentes (PVCs) forem desativadas com o frame relay.

Para obter mais informações sobre de configurar o backup de chamada DDR, refira o documento de Configuração e Troubleshooting de DDR Backup. Você pode igualmente referir as interfaces de avaliação de backup, as Rotas estáticas flutuantes, e o Dialer Watch do documento para o backup de chamada DDR para obter mais informações sobre dos vários métodos de backup de chamada DDR.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para encontrar a informação adicional nos comandos usados neste documento, use a ferramenta de consulta de comandos para IO.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/10214/fr_isdn_backup.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

Esta configuração foi testada com uso do Cisco IOS Software Release 12.2(7b), em 2500 Series Routers. O mesmo conceito de configuração seria aplicado a uma topologia de roteadores semelhante ou a outras versões do Cisco IOS.

Roteador1 (Cisco 2503 Router)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Um estático flutuante foi configurado para o roteador1. A Rota estática flutuante tem uma distância administrativa atribuída de 200. A rota para a mesma sub-rede será também aprendida no enlace do frame relay pelo Enhanced Interior Gateway Routing Protocol (EIGRP), que enfatiza a natureza adicional ou redundante da rota flutuante. A rota aprendida EIGRP será instalada na tabela de roteamento devido a sua distância administrativa mais baixa 90, comparada àquela da rota estática 200. No caso da falha do Link do Frame Relay, a rota de EIGRP desaparecerá da tabela de roteamento, a Rota estática flutuante é instalada. Um tráfego interessante para ser enviado na conexão ISDN ativa a linha. Quando a Conectividade é restaurada sobre o Frame Relay, a rota está aprendida outra vez com o EIGRP. Esta rota substitui a rota estática e direciona o tráfego novamente pelo circuito de frame relay.

O tráfego do protocolo de roteamento é marcado como sem interesse na lista de discadores de modo que não faça com que a linha de ISDN conecte ou permaneça conectada. Contudo, uma vez o link está acima, os pacotes EIGRP podem cruzar o link e os dois Roteadores podem trocar a informação de roteamento. A palavra-chave da transmissão foi incluída na instrução de mapa de discador para permitir a passagem do tráfego do protocolo de roteamento sobre o enlace de ISDN. Se você não quer o EIGRP trocar a informação de roteamento mesmo se o enlace de ISDN está acima, não inclua a palavra-chave da transmissão na instrução de mapa de discador.

O comando dialer load-threshold define uma carga que aciona a colocação de uma chamada simultânea no segundo canal B. O PPP (Protocolo ponto a ponto) de multilink foi configurado (ppp multilink), de modo que ambos os canais B da ISDN podem ser empacotados juntos, como uma interface de Acesso-Virtual, para aumentar a largura de banda.

Na configuração atual, apenas o Roteador 1 está configurado para fazer uma chamada. O Roteador 2 recebe chamadas do Roteador 1. Se você quer ambos os lados trazer acima o link, adicionar comandos dialer map e dialer load-threshold à configuração do roteador2.

Roteador2 (Cisco 2503 Router)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Alterações na Tabela de Roteamento

Nota: Os determinados comandos de exibição são apoiados pela ferramenta Output Interpreter, que permite que você ver uma análise do emissor de comando de execução;

Observe as tabelas de roteamento de Router1 abaixo. Observe que a rota estática flutuante substituiu a rota aprendida pelo EIGRP, depois que o Roteador2 tornou-se inalcançável por meio do link de Frame Relay.

Está mostrada abaixo a tabela de roteamento do roteador1, quando o Link do Frame Relay está acima.

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Quando a conectividade no link de frame relay é perdida, o Roteador 1 instala a rota flutuante em sua tabela de roteamento, como mostrado abaixo.

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Todo o tráfego interessante à rede 172.16.4.0/24 traz agora acima a conexão ISDN. Por exemplo, do roteador1, um sibilo a 172.16.4.1 traz acima o enlace de ISDN como mostrado abaixo.

Nota: Se você faz o protocolo de roteamento interessante, a seguir o tráfego periódico traz acima o link automaticamente. O downside deste é que o link permanecerá acima indefinidamente, possivelmente tendo por resultado altas cobranças de tarifa.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

Desde que a linha de ISDN está acima, o EIGRP começa agora exchaging a informação de roteamento sobre a conexão ISDN. Isto faz com que o roteador1 instale a rota de EIGRP em sua tabela de roteamento, apontando ao salto seguinte 172.16.3.2.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

O tráfego interessante é o tráfego que iniciará a chamada ISDN e é definido pelo comando dialer-list. Na configuração acima, a discador-lista aponta à lista de acesso número 100 que permite todos os pacotes IP exceto pacotes EIGRP. Este os meios, todos os pacotes IP, a não ser que pacotes EIGRP, podem trazer acima a conexão ISDN. Uma vez que a conexão é feita, todo o tráfego, incluindo o tráfego EIGRP, está permitido ir através do link. Mas se nenhum tráfego interessante cruza o enlace de ISDN para a duração do temporizador de ociosidade do discador, o link será derrubado e nenhuma rota de EIGRP será trocada. Neste momento, a Rota estática flutuante será instalada outra vez na tabela de roteamento Router1.

Troubleshooting

Para obter informações sobre de pesquisar defeitos a Rota estática flutuante refira o documento de Configuração e Troubleshooting de DDR Backup. Este documento endereça sintomas comuns como:

  • O link de backup não é discado quando o link principal vai para baixo.

  • Os seletores do link de backup mas não conectam ao outro lado.

  • O link de backup não é desativado quando o enlace principal se recupera.

  • O link de backup não é estável (por exemplo, bate) quando a interface principal está para baixo.

Para o Troubleshooting específico do Frame Relay refira configurar o Backup do Frame Relay

Os comandos seguintes podem ajudar a pesquisar defeitos o link de backup.:

Antes de tentar qualquer comando debug acima, consulte Informações importantes sobre comandos debug.

Saída de depurações

O tráfego do Routing Protocol (EIGRP) é marcado como não-interessante pelo comando dialer list, de modo que ele não ativará o enlace nem o manterá ativo. Contudo, quando o link é ativo, as atualizações de roteamento serão trocadas. O comando debug dialer packet pode verificar se o tráfego correto pode gerar um enlace. A saída é mostrada abaixo.

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

O tráfego interessante (ecos do Internet Control Message Protocol (ICMP) neste caso) restaurará o temporizador de ociosidade e manterá o link acima como abaixo. O tráfego não interessante foi aprovado, porém não manterá o enlace ativado se o temporizador ocioso expirar.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

Marcado embora como sem interesse, os pacotes EIGRP cruzam o enlace de ISDN, porque a conexão é feita já pelo tráfego interessante ICMP.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10214