Qualidade de Serviço (QoS) : Regulamentação QoS

Opção Qualidade de Serviço em interfaces do túnel GRE

12 Agosto 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Este as revisões de documento que o Qualidade de Serviço (QoS) caracteriza podem ser configuradas em interfaces de túnel usando o Generic Routing Encapsulation (GRE). Os túneis configurados com Segurança IP (IPsec) são fora do âmbito deste documento.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Visão geral de GRE

Antes de aprender sobre QoS nos túneis GRE, primeiro é necessário entender o formato de um pacote em túnel.

Uma interface de túnel é uma virtual ou uma interface lógica em um roteador que executa o software de Cisco IOS�. Ela cria um enlace virtual ponto-a-ponto entre dois Cisco routers em pontos remotos sobre uma inter-rede de IP.

O GRE é um protocolo de encapsulamento suportado pelo IOS e definido no RFC 1702.leavingcisco.com Os protocolos de tunelamento encapsulam pacotes dentro de um protocolo de transporte.

Uma interface de túnel apoia um encabeçamento para cada um destes:

  • Um protocolo passageiro ou encapsulado, como IP, AppleTalk, DECnet ou IPX.

  • Um protocolo do portador (GRE neste caso).

  • Um protocolo de transporte (neste caso, somente IP).

O formato de um pacote de túnel é ilustrado aqui:

http://www.cisco.com/c/dam/en/us/support/docs/quality-of-service-qos/qos-policing/10106-qostunnel-01.gif

Refira configurar interfaces lógica para obter mais informações sobre de configurar túneis GRE.

Cisco QoS para GRE Tunnels

Uma interface de túnel suporta diversos dos mesmos recursos de QoS que uma interface física. Estas seções descrevem as características de QoS apoiadas.

Modelagem

O Cisco IOS Software Release12.0(7)T introduziu o apoio para aplicar o Generic Traffic Shaping (GTS) diretamente na interface de túnel. O exemplo de configuração a seguir molda a interface de túnel em uma taxa de saída geral de 500 kbps. Refira configurar o Formatação de tráfego genérico para mais informação.

interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  traffic-shape rate 500000 125000 125000 1000 
  tunnel source 10.1.1.1 
  tunnel destination 10.2.2.2

O Cisco IOS Software Release 12.1(2)T adicionou o apoio para o modelagem baseada em classe usando a interface de linha de comando do QoS modular (MQC). O exemplo de configuração a seguir mostra como aplicar a mesma política de modelagem à interface do túnel com os comandos MQC. Refira configurar o modelagem baseada em classe para mais informação.

policy-map tunnel 
  class class-default 
    shape average 500000 125000 125000 
interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  service-policy output tunnel 
  tunnel source 130.1.35.1 
  tunnel destination 130.1.35.2

Vigilância

Quando uma interface torna-se congestionada e os pacotes entram na fila, é possível aplicar um método de enfileiramento para os pacotes que estão aguardando transmissão. As interfaces lógicas de Cisco IOS não suportam de forma inerente um estado de congestionamento e não suportam a aplicação direta de uma política de serviço que aplica um método de enfileiramento. Em lugar de, você precisa de aplicar uma política hierárquica como segue:

  1. Crie uma "política infantil" ou uma política de nível mais baixo que configure um mecanismo de enfileiramento, como o enfileiramento de baixa latência com o comando priority e o enfileiramento CBWFQ com o comando bandwidth. Refira o Tratamento de Congestionamento para mais informação.

    policy-map child 
     class voice 
      priority 512
  2. Crie uma política “principal” ou de alto nível com aplicação de molde com base em classe. Aplique a política infantil como um comando sob a política de parentes desde que o controle de admissão para a classe infantil é feito com base na taxa moldada para a classe do pai.

    policy-map tunnel 
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Aplique a política de parentes à interface de túnel.

    interface tunnel0 
       service-policy tunnel

O roteador imprime este mensagem de registro quando uma interface de túnel é configurada com uma política de serviços que aplique o Enfileiramento sem dar forma.

router(config)# interface tunnel1
router(config-if)# service-policy output child
 Class Based Weighted Fair Queueing not supported on this interface

As interfaces de túnel igualmente apoiam o class-based policing, mas não apoiam o Committed Access Rate (CAR).

Nota: As políticas de serviço não são suportadas em interfaces de túnel no 7500.

Evitando congestionamento

O Cisco IOS Software Release 11.3T introduziu a marcação do túnel GRE e o DSCP ou os valores de precedência IP, que configura o roteador para copiar os valores de bit de precedência IP do byte ToS ao túnel ou ao cabeçalho IP GRE que encapsulam o pacote interno. Anteriormente, esses bits estavam definidos como zero. Os roteadores intermediários entre os pontos finais do túnel podem usar os valores de precedência do IP a fim de classificar os pacotes para os recursos de QoS, como o Policy Routing, o WFQ e o Weighted Random Early Detection (WRED).

O comando qos pre-classify

Quando pacotes são encapsulados por cabeçalhos de túnel ou criptografia, os recursos de QoS não conseguem examinar os cabeçalhos originais dos pacotes nem classificar corretamente os pacotes. Os pacotes que percorrem o mesmo túnel possuem os mesmos cabeçalhos e por isso são tratados de forma idêntica quando a interface física está congestionada. Com a introdução do recurso VPNs (Qualidade de Serviço para Redes Virtuais Privadas), agora os pacotes podem ser classificados antes que ocorra o tunelamento e a criptografia.

Neste exemplo, o tunnel0 é o nome de túnel. O comando qos pre-classify habilita o recurso QoS para VPNs em tunnel0:

Router(config)# interface tunnel0
Router(config-if)# qos pre-classify

Nota:  O comando qos pre-classify pode ser usado a fim classificar o tráfego baseado em valores diferentes da Precedência IP ou do DSCP. Por exemplo, você pôde querer classificar os pacotes baseados no fluxo IP ou mergulhar a informação 3, tal como o endereço IP de origem e de destino para que este comando pode ser usado. O comando qos pre-classify é exigido somente se você classifica o tráfego no IP, no protocolo, ou na porta. Se a classificação é baseada no código DSCP, a seguir os qos PRE-classificam não estão exigidos.

Caracterizando o tráfego para políticas QoS

Ao configurar uma política de serviços, você primeiramente pôde precisar de caracterizar o tráfego que está atravessando o túnel. O Cisco IOS dá suporte à contabilização do Netflow e IP Cisco Express Forwarding (CEF) nas interfaces lógicas como túneis. Refira o guia das soluções dos serviços de Netflow para mais informação.

Onde aplico a política de serviços?

É possível aplicar uma política de serviço à interface do túnel ou à interface física subjacente. A decisão de onde aplicar a política depende dos objetivos de QoS. Isso depende também de qual cabeçalho você precisa usar para classificação.

  • Aplique a política à interface de túnel sem qos-preclassify se desejar classificar os pacotes com base no cabeçalho pré-túnel.

  • Aplique a política à interface física sem qos-preclassify quando você quer classificar os pacotes baseados no encabeçamento do cargo-túnel. Além disso, aplique a política à interface física quando você quiser modelar ou vigiar todo o tráfego pertencente a um túnel e a interface física suportar diversos túneis.

  • Aplique a política a uma interface física e permita-a qos-preclassify em uma interface de túnel quando você quer classificar os pacotes baseados no cabeçalho de pré-túnel.

Interfaces de túnel multiponto

O CBWFQ dentro do modelagem baseada em classe não é apoiado em uma interface multiponto. A identificação de bug Cisco CSCds87191 configura o roteador para imprimir uma mensagem de erro quando rejeitar a política.

Problemas conhecidos

Nas condições raras, aplicar uma serviço-política configurada com o comando shape conduz à utilização elevada da CPU e aos erros de alinhamento. A carga de CPU é causada registrando os erros de alinhamento, que são causados por sua vez pelo CEF que ajusta incorretamente a interface de saída e a informação de reescrita de adjacência. Esse problema afeta somente as plataformas não-RSP (de extremidade baixa) e as plataformas que utilizam switching CEF baseada em partícula. O problema é resolvido via identificações de erro Cisco CSCdu45504 e CSCuk30302. Você igualmente pode considerar estas ações alternativas:

  • Substitua o encapsulamento do GRE por um tunnel mode ipip.

  • Substitua o comando shape pelo comando police.

  • Configure a modelagem da interface física que suporta o túnel.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10106