Qualidade de Serviço (QoS) : Regulamentação QoS

Aplicando recursos de QoS para subinterfaces Ethernet

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Este documento descreve como aplicar o Class-Based Weighted Fair Queueing (CBWFQ) e outras características com base no software do Qualidade de Serviço (QoS) do½ do¿Â do Cisco IOSï em uma subinterface Ethernet. Uma subinterface Ethernet é uma interface lógica no Cisco IOS. Você pode usar a interface de linha de comando (CLI) de QoS modular (MQC) para criar e aplicar uma política de serviço a uma subinterface Ethernet.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco IOS Software 12.2(2)T

  • Cisco 2620 Router com um módulo de rede do Fast Ethernet

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Aplicando uma política de serviço

Em geral, a escolha de onde aplicar uma política depende dos recursos do QoS ativados pela política. Uma sub-interface de Ethernet suporta o seguinte:

  • Vigilância baseada em classe – Caso esteja aplicando uma política com o comando police à interface e à sub-interface, apenas o vigilante da sub-interface é ativado para o tráfego que corresponde à classe. Refira o Policiamento de tráfego para mais informação.

  • Class-based Marking — refira a visão geral de classificação para mais informação.

  • Modelagem baseada em classe — refira configurar o modelagem baseada em classe para mais informação.

  • enfileiramento Classe-baseado — Enfileirar-se é um caso especial de subinterfaces Ethernet. Veja o restante desta seção para mais informação.

Um roteador começa a enfileirar pacotes quando o número de pacotes que precisa de ser transmitido para fora uma relação excede a taxa de emissor dessa relação. Os pacotes em excesso são colocados em fila. Um método de enfileiramento pode ser aplicado aos pacotes que aguardam transmissão.

As interfaces lógicas do Cisco IOS não têm suporte inerente para um estado de congestionamento e não suportam a aplicação direta de uma política de serviços que inclua um método de enfileiramento. Em lugar de, você precisa primeiramente de aplicar dar forma à subinterface usando o Generic Traffic Shaping (GTS) ou o modelagem baseada em classe. Refira a vigilância e modelagem para mais informação.

O roteador imprime este mensagem de registro quando uma subinterface Ethernet é configurada com uma política de serviços que aplique o enfileiramento sem dar forma:

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

Note que a mesma regra aplica ao Gigabit Ethernet uma subinterface.

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

Ou seja você deve configurar uma política hierárquica com o comando shape a nível do pai. Utilize o comando bandwidth para CBWFQ ou o comando priority para fila de latência baixa (LLQ) em níveis mais baixos. O modelagem baseada em classe limita a taxa de emissor e (nós podemos supor) conduz a um estado congestionado na subinterface lógica. A subinterface do que aplicam a “pressão contrária,” e o Cisco IOS começa a enfileirar os pacotes adicionais que são mantidos pelo shaper.

Aplicando uma política hierárquica

Siga estes passos para aplicar uma política hierárquica.

  1. Crie uma política filho ou de nível mais baixo que configure um mecanismo de enfileiramento. No exemplo abaixo, nós configuramos o LLQ usando o comando priority e o CBWFQ usando o comando bandwidth. Refira a visão geral sobre Tratamento de Congestionamento para mais informação.

    policy-map child 
     class voice 
      priority 512
  2. Crie uma política pai ou de nível superior que se aplique à modelagem baseada em classe. Aplique a política infantil como um comando sob a política pai, já que o controle de admissão para a classe infantil é feito com base na taxa moldada para a classe pai.

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Aplique a política-pai à sub-interface.

    interface ethernet0/0.1
     service-policy parent 

Configurando o molde com base em classe

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Configuração

Roteador 2620A
hostname 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

  • show policy-map {policy name} - Indica a configuração de todas as classes para um mapa de política de servidor especificado.

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
  • show policy-map interface fast - Indica contadores compatíveis para todas as classes de um mapa de política de servidor especificado.

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any

Nota: O modelagem baseada em classe trabalha a nível da interface e subinterface. O Cisco IOS 12.2(2.5) apresenta a capacidade de configurar a modelagem nos principais endereços de interface e IP, nas subinterfaces.


Informações Relacionadas


Document ID: 10104