Qualidade de Serviço (QoS) : Gerenciamento da QoS de tráfego congestionado (enfileiramento)

Configurando o CBWFQ e o LLQ no MLPPP e nas interfaces do discador

18 Outubro 2014 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (2 Outubro 2014) | Feedback


Índice


Introdução

O comando service-policy normalmente se aplica ao mapa de política configurado com comandos do MQC (QoS CLI modular) para interface principal, sub-interface ou circuito virtual. Esse comando também pode ser aplicado a uma interface de modelo virtual, interface de multilink e uma interface de discador configurada com o encapsulamento de PPP (protocolo de ponto a ponto) e MLPPP (PPP de multilink). Tais interfaces resultam em uma interface de acesso virtual, onde ocorre a funcionalidade de enfileiramento. Este documento contém uma referência única para compreender configurações recomendadas e as advertências relacionadas para aplicar Class-Based Weighted Fair Queuing (CBWFQ) e o enfileiramento de latência baixa (LLQ) às relações do pacote MLPPP e às interfaces do discador.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Aplique o Enfileiramento às relações com uma variedade de larguras de banda

O RFC 1990leavingcisco.com define o Multilink PPP, que combina umas ou várias interfaces física em uma relação virtual do “pacote”. A largura de banda do bundle interface é igual à soma da largura de banda dos links componentes. Assim, o bundle interface tem um valor máximo de largura de banda que varie em um momento instantâneo a tempo.

Originalmente, os comandos de largura de banda e prioridade suportavam apenas um valor absoluto de kbps. Se você aplicar uma política de serviço com CBWFQ e LLQ a uma interface de conjunto, e a primeira interface ativa não suportar o valor absoluto de kbps, a política de serviço falhará no controle de admissão. O roteador removeu a política de serviços e imprimiu os Mensagens de Erro similares a esta saída:

May 18 17:32:34.766 MEST: CBWFQ: Not enough available bandwidth for all 
classes Available 48 (kbps) Needed 96 (kbps) 
May 18 17:32:34.766 MEST: CBWFQ: Removing service policy on Dialer100

Até à data do Software Release 12.2T de Cisco IOS®, o roteador tenta agora reaplicar a política quando detecta que uma interface adicional (tal como um segundo canal B BRI) está adicionada ao pacote. Uma abordagem melhor é configurar os comandos priority e bandwidth como uma porcentagem da largura de banda disponível. O uso de um valor da porcentagem configura o roteador para atribuir um volume relativo de largura de banda que ajuste enquanto o pacote contém uns ou vários enlaces membros. O Cisco IOS Software Release 12.2(2)T introduziu o suporte ao comando priority percentage nos Cisco 7500 series routers e outras plataformas. Para mais informação, refira o Enfileiramento da latência baixa com apoio do priority percentage.

CBWFQ e LLQ nas interfaces de discador

O Dial-on-Demand Routing (DDR) pode ser configurado em duas maneiras:

  • DDR anterior - Aplica os parâmetros de discagem e protocolo diretamente na interface física.

  • Perfis do discador - Aplica os parâmetros de discagem e protocolo dinamicamente a uma interface de discador que, por sua vez, liga-se a interfaces físicas. Por exemplo, uma interface de discador inclui uma ou mais strings de discagem para alcançar a estação remota, o tipo de autenticação PPP e o MLPPP.

O DDR anterior suportava originalmente apenas enfileiramento FIFO (primeiro a entrar, primeiro a sair) quando uma interface ISDN ou serial era configurada com MLPP. Esta limitação aplicou mesmo quando as duas extremidades da conexão não negociaram o MLPPP e usou a interface física como uma relação do NON-pacote que executasse o encapsulamento PPP. A weighted fair queuing (WFQ) tradicional através do comando fair-queue é suportada agora.

Se escolher configurar perfis de discador, tanto a interface do discador como as interfaces físicas subjacentes suportarão o comando service-policy. Se você aplica uma política na interface física, emita o comando show policy-map interface serial ou o comando do bri 0/0:1 (e bri0/0:2) da relação do mapa de política da mostra confirmar a configuração. O canal D, identificado nos IO como o BRI0/0, apoia a sinalização e não o tráfego de dados. Se você aplica uma política à interface do discador, emita o comando do seletor <0-255> da interface de enfileiramento da mostra confirmar a configuração.

Os Cisco IOS Software Releases 12.2(4) e 12.2(4)T introduziram o apoio para políticas de serviços Enfileiramento-baseadas nas interfaces de acesso virtual criadas de uma interface do discador configurada com o MLPPP. Em versões anteriores, os parâmetros de política de serviço não são copiados para a interface de acesso virtual clonada, onde o enfileiramento realmente ocorre. Esta saída ilustra estes sintomas:

Router#show policy interface dialer1
  Dialer1 
   Service-policy output: foo 

     Class-map: class-default (match-any) 
       0 packets, 0 bytes 
       5 minute offered rate 0 bps, drop rate 0 bps 
       Match: any 
       Weighted Fair Queueing 
         Flow Based Fair Queueing 
         Maximum Number of Hashed Queues 256 
         (total queued/total drops/no-buffer drops) 0/0/0 

Router#show policy interface virtual-access 2
 Router#

Nota: O Cisco IOS Software Release 12.2(8) e 12.2(8)T são recomendados evitar a identificação de bug Cisco CSCdu87408, que resolve recarregamentos de roteador como um efeito colateral raro desta configuração.

Esta configuração de exemplo mostra como aplicar o CBWFQ e o LLQ a uma interface do discador. Esta configuração conduz a:

  • Usa uma interface de discador para aplicar dinamicamente os parâmetros de protocolo da conexão às interfaces BRI do ISDN. A interface do discador seriam “limita” às relações do ISDN BRI.

  • Coloca duas interfaces BRI ISDN em um pacote de multilink.

  • Usa o dialer load-threshold load [de partida | de entrada | um ou outro] comando determinar quando o roteador precisar de ativar os canais B adicionais e de aumentar a largura de banda do bundle interface.

  • Cria uma interface de acesso virtual com o comando ppp multilink.

  • Aplica uma política de serviço com CBWFQ e LLQ na interface de acesso virtual por meio da interface do discador.

Configuração de exemplo
access-list 101 permit udp any any range 16384 32767
access-list 101 permit tcp any any eq 1720
!
access-list 102 permit tcp any any eq 23
! 
class-map voice
    match access-group 101

!--- Traffic that matches ACL 101 is classified as class voice.

class-map data
    match access-group 102

!--- Traffic that matches ACL 102 is classified as class data.

policy-map mlppp 
   class voice 
      priority percent 50 
   class data 
      bandwidth percent 25 
   class class-default 
     fair-queue 
!
interface BRI2/1  
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
! 
interface BRI2/2 
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
!  
interface Dialer2  
  ip unnumbered Loopback0  
  encapsulation ppp  
  dialer pool 1  
  dialer load-threshold 1 either  
  
!--- Load level (in either direction) for  
  !--- traffic at which additional connections  
  !--- are added to the MPPP bundle 
  !--- load level values that range from 1 (unloaded)  
  !--- to 255 (fully loaded).

  dialer string 6113 
  dialer string 6114  
  dialer-group 1  
  ppp authentication chap  
  ppp multilink  

!--- Allow MLPPP for the four BRI channels.

  service-policy output mlppp 
  
!--- Apply the service policy to the dialer interface.

LLQ eCBWFQ com MLPPP distribuído

A série Cisco 7500 utiliza uma arquitetura distribuída que assegura uma alta transferência de pacotes ao mover as decisões de encaminhamento de pacote do Processador do Switch de Rota (RSP) para os Processadores de Interface Versátil (VIPs). Esta arquitetura igualmente permite o desenvolvimento de serviços em grande escala do IP aprimorado, tais como QoS, espalhando a carga de processamento através dos processadores independentes múltiplos dos VIP.

Baseado no hardware da relação, o Cisco 7500 Series apoia dois formulários de QoS:

qos Habilidado Onde houver suporte Onde processado
Baseado em RSP Automaticamente nos processadores de interface legada. Legacy Interface Processors. Não podem mais ser habilitados nos VIPs. CPU de RSP
Baseado em VIP (distribuído) Automaticamente quando estes dois comandos forem configurados: VIPs CPU de VIP

Os mecanismos de QoS com base em VIP aplicados através do Modular QoS CLI (MQC) são introduzidos nestes três trens de Cisco IOS Software Release:

  • Cisco IOS Software Release 12.0(XE), que se transformou Cisco IOS Software Release 12.1(E)

  • Cisco IOS Software Release 12.0(9)S

  • Cisco IOS Software Release 12.1(5)T, que se transformou mainline e Cisco IOS Software Release 12.2T do Cisco IOS Software Release 12.2

O recurso de MLPPP distribuído permite combinar a largura de banda de várias interfaces T1/E1 de um VIP em uma interface de pacote. Para mais informação, refira o protocolo multilink point-to-point distribuído para Cisco 7500 Series Router. O Cisco IOS Software Release 12.2(13)T introduz o apoio para o MLPPP distribuído (dMLPPP) em adaptadores de porta não-canalizados, tais como o PA-4T+ e o PA-8T.

A Versão do Software Cisco IOS 12.2(8)T introduziu o suporte a LLQ distribuído e CBWFQ em conjuntos de interfaces dMLPPP em adaptadores de porta canalizados como PA-MC-xT1/E1 e PA-MC-xT3/E3. Como a versão não distribuída deste recurso, o dMLPPP usa um multienlace de interface para criar uma interface de acesso virtual em que a funcionalidade de enfileiramento entra em vigor. Refira novo e a informação alterada para o Cisco IOS Software Release 12.2T. Quando você aplica o Enfileiramento distribuído com dMLPPP, o Cisco IOS Software Release 12.2(10)T ou Mais Recente está recomendado a fim evitar a identificação de bug Cisco CSCdw47678.

Somente CBWFQ e LLQ como aplicado no comando de política de servidor é suportado com o dMLPPP/dLFI. Os recursos de enfileiramento do legado, tais como o enfileiramento considerável com o comando fair-queue, filas de prioridade com o comando priority-group, e Enfileiramento feito sob encomenda com o comando queue-list, não são apoiados.

O FlexWAN para o Cisco 7600 Series apoia o dLLQ em relações do NON-pacote. Não suporta dLLQ em interfaces de pacotes MLPPP. Este apoio está disponível com Cisco IOS Software Release 12.2S.

Esta configuração de exemplo aplica o dLLQ em um multilink da relação:

Configuração de exemplo do dLLQ em um bundle interface MLPPP
Interface 
! 
access-list 100 permit udp any any range 16384 32000
access-list 100 permit tcp any any eq 1720
access-list 101 permit tcp any any eq 80
access-list 102 permit tcp any any eq 23
!
class-map voip 
   match access-group 100
class-map data1
    match access-group 101
class-map data2 
    match access-group 102
!
policy-map llq-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15 
    class data2 
     bandwidth 15
    class class-default 
     fair-queue
!
policy-map set-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15
    class data2 
     bandwidth 15 
    class class-default 
     fair-queue
!
interface Serial5/0/0:0 
   no ip address 
   encapsulation ppp 
   keepalive 10 
   ppp chap hostname G2 
   ppp multilink 
   multilink-group 2 
!  
interface Serial5/1/0:0 
  no ip address 
  encapsulation ppp 
  keepalive 10 
  ppp chap hostname G2 
  ppp multilink 
  multilink-group 2 
!  
interface Multilink2 
  ip address 106.0.0.2 255.0.0.0 
  ppp multilink 
  service-policy output llq-policy 
  service-policy input set-policy 
  multilink-group 2

O Link Fragmentation and Interleaving (LFI) adiciona o ppp multilink fragment-delay e os comandos ppp multilink interleave a um virtual-molde da relação configurado com MLPPP e uma política de serviços. Esta configuração reduz o atraso nos links da velocidade mais lenta quebrando acima grandes datagramas e intercalando pacotes de tráfego de retardo baixo com os pacotes menores que resultam da datagrama fragmentado. Para mais informação, refira configurar a fragmentação do link e intercalá-la para o Frame Relay e os circuitos virtuais ATM.

O apoio introduzido Cisco IOS Software Release 12.2(8)T para LFI distribuído (dLFI) sobre-separou linhas de série no Cisco 7500 Series com VIP. Esta característica está igualmente disponível com os Catalyst 6500 Series Switch e os Cisco 7600 Series Router. Para obter informações sobre das liberações que apoiam o dLFI, refira a ferramenta de recurso de navegador (clientes registrados somente) e Release Note para os respectivos produtos. Para obter mais informações sobre desta característica, refira a fragmentação de link distribuído e a intercalação sobre linhas alugadas.

O FlexWAN para o Cisco 7600 Series com trem de Cisco IOS Software Release 12.1E não apoia o dLFI.

Depois que você configura o retardo de fragmentação máximo com o comando ppp multilink fragment-delay <msec>, a característica dLFI calcula o tamanho do fragmento real em interfaces serial separadas com o uso desta fórmula (onde a largura de banda está nos kbps):

fragment size = bandwidth x fragment-delay  / 8

Além, o tamanho do fragmento é calculado com base no enlace membro com a quantidade a menor da largura de banda. Por exemplo, em uma configuração com links membros de 64 k e 128 k, o tamanho da fragmentação é calculado com base no link de 64 k.

CBWFQ e LLQ com PPPoA e MLPPPoA

O Cisco IOS Software Versão 12.2(8) introduziu suporte para enfileiramento por VC nos circuitos virtuais ATM configurados com PPP genérico sobre encapsulamento ATM (PPPoA). Estas subseções dão-lhe os exemplos de configuração do Class-based Marking, policiando, e enfileirando-se.

1. Marcação baseada em classe

O comando service-policy pode ser anexado à interface de molde virtual ou ao ATM PVC para o Class-based Marking.

Neste exemplo, o mapa PEER2PEER da classe é definido, o mapa de política MARK_PEER2PEER é criado, e o padrão do dscp é configurado para a classe PEER2PEER; a serviço-política é anexada então ao molde virtual ou ao ATM PVC.

Router(config)#class-map PEER2PEER
Router(config-cmap)#match access-group 100
Router(config-cmap)#exit

Router(config)#policy-map MARK_PEER2PEER
Router(config-pmap)#class PEER2PEER
Router(config-pmap-c)#set dscp default
Router(config-pmap-c)#end


Attaching Service-policy to Virtual Template


Router(config-subif)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 1

Router(config)#interface Virtual-Template1
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output MARK_PEER2PEER 


Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#service-policy output MARK_PEER2PEER

2. Class-based policing:

O comando service-policy pode ser anexado à interface de molde virtual ou ao pvc ATM para o class-based policing.

Router(config)#policy-map POLICE_PEER2PEER
Router(config-pmap)#class PEER2PEERRouter(config-pmap-c)#police 8000 conform-action transmit exceed-action drop

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 2

Router(config)#interface Virtual-Template2
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output POLICE_PEER2PEER 



Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#service-policy output POLICE_PEER2PEER

3. Enfileiramento com base na classe:

Para o Enfileiramento com base na classe, isto é, a largura de banda, forma, prioridade, e aleatório-detecta, o comando service-policy pode ser anexado ao molde virtual ou ao ATM PVC.

Router(config)#policy-map QUEUE_PEER2PEER
 Router(config-pmap)#class PEER2PEER
 Router(config-pmap-c)#bandwidth 768

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 3

Router(config)#interface Virtual-Template3
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output QUEUE_PEER2PEER

Attaching Service-policy to ATM pvc 

Router(config)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#service-policy output QUEUE_PEER2PEER

Nota: Quando você usa uma combinação de Class-based Marking ou class-based policing e Enfileiramento com base na classe, o ordem de operação é este:

  1. O comando service-policy configurado na interface de molde virtual marca ou policia os pacotes.

  2. O comando service-policy no ATM PVC enfileira os pacotes.

Refira este exemplo:

policy-map MARK_PEER2PEER
  class PEER2PEER
   set dscp default
! 
 interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 1/100
  encapsulation aal5mux ppp Virtual-Template1
  service-policy output QUEUE_PEER2PEER
!
interface Virtual-Template1 
ip address negotiate
service-policy output MARK_PEER2PEER

Se você executa um Cisco IOS Software Release mais adiantado, você pode configurar em ATM VC com encapsulamento de MLPPPoA e aplicar uma política de serviços Enfileiramento-baseada à interface de molde virtual. Para mais informação, refira a fragmentação do link e a intercalação para o Frame Relay e os circuitos virtuais ATM e a vista geral dos mecanismos de eficiência de link.

O Cisco IOS Software Release 12.2(4)T3 introduz uma versão distribuída desta característica para o Cisco 7500 Series. Para obter mais informações sobre desta característica, refira a fragmentação de link distribuído e a intercalação para o ATM e o Frame Relay.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10102