Switches de LAN : VLAN

Criando VLANs de Ethernet em Switches Catalyst

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (17 Julho 2008) | Inglês (20 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece a informação básica em como criar os VLAN em Catalyst Switches que executam o OS do catalizador (CatOS) e o software do sistema de Cisco IOS�. Os exemplos de comando para cada seção utilizam um switch Catalyst de cada seção de configuração.

Pré-requisitos

Requisitos

A Cisco recomenda que você conheça as informações descritas nesta seção.

As VLANs são um mecanismo que permitem que os administradores de rede criem os domínios de transmissão lógicos que podem ser distribuídos em um único switch ou em vários, independente da proximidade física. Essa função é útil para reduzir o tamanho dos domínios de transmissão ou para permitir que grupos ou usuários sejam agrupados logicamente sem que precisem estar logicamente localizados no mesmo local.

Para criar VLANs, você deve decidir como configurar estes itens:

  • Qual nome de domínio VLAN Trunk Protocol (VTP) e modo VTP utilizar nesse switch

  • Quais portas no switch pertencem a qual VLAN

  • Se você precisa ter uma comunicação entre VLANs ou se serão isoladas

    Se você precisar de uma comunicação entre VLANs, deverá utilizar um dispositivo de roteamento de Camada 3, como um Cisco Router externo ou um módulo de roteador interno. Exemplos:

    • Placa WS-X4232 de Camada 3 para Switches Catalyst 4500/4000 com Superior Engines I e II

    • Route Switch Module (RSM) ou Route Switch Feature Card (RSFC) para Switches Catalyst 5500/5000

    • Multilayer Switch Module (MSM) ou Multilayer Switch Feature Card (MSFC) para Switches Catalyst 6500/6000

    Alguns dos switches têm suporte embutido no software e no hardware para fazer o roteamento entre VLANs. Com o roteamento entre VLANs, não é necessário nenhum dispositivo externo, módulo ou placa filha. A seguir, apresentaremos exemplos desses switches:

    • Catalyst 3550/3750/6500 com Supervisor Engine 720

    • Catalyst 4500/4000 com Supervisor Engines II+, III e IV

Consulte estes documentos para obter mais informações sobre a configuração do roteamento entre VLANs em um MSFC, RSM ou roteador externo:

Nota: Este documento leva em conta que você tenha a conectividade básica ao switch por meio da console ou pelo acesso Telnet. Consulte estes documentos para obter mais informações sobre como obter a conectividade básica aos switches:

Componentes Utilizados

As informações neste documento são baseadas nas seguintes versões de hardware e software:

  • Switch Catalyst 6009 que executa o software CatOS 5.5(x)

  • Switch Catalyst 3524XL que executa o Software Cisco IOS Release 12.0(5.x)XU

  • Switch Catalyst 4507 com Supervisor Engine IV (WS-X4515) que executa o Software Cisco IOS Release 12.1(13)EW1

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

As informações contidas neste documento também podem ser utilizadas com estes switches:

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diferença entre CatOS e software do sistema IOS

CatOS no Supervisor Engine e Cisco IOS Software no MSFC (Híbrido): uma imagem de catos pode ser usada como o software do sistema para executar o Supervisor Engine no Switches do Catalyst 6500/6000. Se o MSFC opcional está instalado, uma imagem de Cisco IOS Software separada é utilizada para executar o MSFC.

Cisco IOS Software em Supervisor Engine e MSFC (Nativo): uma única imagem do Cisco IOS Software pode ser usada como o software do sistema para executar o Supervisor Engine e o MSFC em switches Catalyst 6500/6000.

Nota: Consulte o Comparação dos Sistemas Operacionais Cisco Catalyst e Cisco IOS para o Switch Catalyst 6500 Series para obter mais informações.

Configure a VLAN em Switches Catalyst que Executam o CatOS

Crie VLANs e Portas

Siga as etapas nesta seção para criar uma VLAN.

Para criar uma VLAN, o switch deve estar no modo de servidor ou transparente do VTP. Se o switch for um servidor de VTP, será necessário definir um nome de domínio de VTP para poder adicionar qualquer VLAN.

  1. Defina um nome de domínio do VTP.

    Você deve defini-lo independente de:

    • O número de switches na rede, se um ou vários

    • Se você utiliza o VTP para propagar VLANs para outros switches na rede

    Esta é a configuração do VTP padrão no switch:

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Execute o comando set vtp para definir o nome de domínio e o modo.

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified

    Nota: Consulte Como Entender o Protocolo VLAN Trunk (VTP) para obter mais informações sobre o VTP.

  2. Execute o comando show vtp domain para verificar a configuração de VTP.

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Nota: Se você tiver a saída do comando show vtp domain do seu dispositivo Cisco, poderá utilizar o Output Interpreter (apenas clientes registrados) para exibir problemas potenciais e soluções.

  3. Depois de definir e verificar o domínio do VTP, comece a criar VLANs no switch.

    Como padrão, há apenas uma única VLAN para todas as portas. Essa VLAN é chamada de padrão. Você não pode renomear nem excluir a VLAN 1.

    Execute o comando show vlan para indicar os parâmetros para todas as VLANs configuradas no domínio administrativo.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    1. Execute o comando set vlan para criar VLANs.

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
    2. Execute o comando show vlan para verificar a configuração de VLAN.

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75      
      1002 fddi-default                     active    6       
      1003 token-ring-default               active    9       
      1004 fddinet-default                  active    7       
      1005 trnet-default                    active    8       
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Output suppressed.
      
      
    3. Se você desejar adicionar portas à VLAN, execute o comando set vlan vlan_number mod/ports.

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1

      Nota: Você também pode criar a VLAN e adicionar as portas a ela com todas as informações em um único comando.

      Por exemplo, se você quiser criar a terceira VLAN e atribuir as portas 3/13 a 3/15 a ela, execute este comando:

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
  4. Execute o comando show vlan para verificar a configuração de VLAN.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Output suppressed.
    
    

Remova as Portas ou VLANs

Para remover as portas de uma VLAN, execute o comando set vlan vlan_number mod/ports e coloque as portas em outra VLAN. Essa remoção é basicamente o que acontece quando você atribui uma porta a qualquer VLAN porque todas as portas pertencem inicialmente à VLAN 1.

Execute o comando clear vlan para excluir uma VLAN. As portas são desativadas porque elas continuam fazendo parte dessa VLAN, e a VLAN já não existe. O switch exibe um aviso e lhe dá a oportunidade de cancelar a solicitação atual.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Output suppressed.

Nota: As portas 3/13 a 3/15 não são exibidas na saída do comando show vlan porque a remoção da VLAN 3 as desativa. As portas não são exibidas até que você as adicione de volta a outra VLAN.

Dicas para Troubleshooting

Esta seção fornece dicas de troubleshooting para os problemas comuns que você pode encontrar ao criar VLAN em Switches Catalyst que executam o CatOS:

  • Se você criar uma VLAN quando não há nenhum nome de domínio do VTP definido, receberá esta mensagem de erro:

    Cannot add/modify VLANs on a VTP server without a domain name.

    Para corrigir isso, crie um nome de domínio do VTP no switch. A seção Crie VLANs e Portas fornece o procedimento.

  • Se você criar uma VLAN em um switch que esteja no modo de cliente do VTP, receberá esta mensagem de erro:

    Cannot add/modify VLANs on a VTP client.

    Nota: Um switch pode criar VLANs apenas se estiver no modo de servidor ou transparente do VTP. Consulte Como Entender o Protocolo VLAN Trunk (VTP) para obter mais informações sobre o VTP.

  • As portas estão no estado inactive na saída do comando show port mod/port. Esse estado significa que a VLAN à qual as portas pertenciam originalmente foi excluída, em geral, devido ao VTP. Você pode recriar essa VLAN ou corrigir a configuração do VIP, de modo que a VLAN seja restabelecida novamente no domínio no VTP. Este é um exemplo de saída do comando show port mod/port:

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Output suppressed.
    
    

    Se você tiver a saída do comando show-tech support do seu dispositivo Cisco, poderá utilizar o Output Interpreter (apenas clientes registrados) para exibir problemas potenciais e soluções.

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
  • As interfaces de VLAN criadas nos módulos de roteamento (RSM, RSFC, MSM ou MSFC) são ativadas apenas quando a VLAN correspondente está disponível no switch. Para que a interface de VLAN esteja inteiramente ativa, o que significa administrativamente ativa e o protocolo de linha ativo, assegure-se de que haja pelo menos uma porta como membro dessa VLAN, com um dispositivo ativo conectado à porta. Consulte a seção Requisitos deste documento para verificar as diretrizes de configuração.

Configure a VLAN em Switches Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 Series

Crie VLANs e Portas

Nota: A saída que você vir poderá diferir da saída do comando exibida nesta seção. A diferença depende do modelo de seu switch.

Siga estas etapas para criar uma VLAN.

  1. Decida se utilizará VTP em sua rede.

    Com VTP, você pode fazer alterações na configuração, de forma centralizada, em um único switch, e transmitir essas alterações automaticamente a todos os outros switches na rede. O modo do VTP padrão nos Switches Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 é o de servidor. Consulte Como Entender o Protocolo VLAN Trunk (VTP) para obter mais informações sobre o VTP.

    Nota: Execute o comando show vtp status para verificar o status de VTP em Switches XL Series.

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- This is the default mode.
    
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70 
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
  2. Depois de definir e verificar o domínio do VTP, comece a criar VLANs no switch.

    Como padrão, há apenas uma única VLAN para todas as portas. Essa VLAN é chamada de padrão. Você não pode renomear nem excluir a VLAN 1.

    Execute o comando show vlan para verificar a informação de VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

    Execute esse conjunto de comandos no modo privilegiado para criar um outro VLAN:

    3524XL#vlan database
    
    !--- You must enter into VLAN database in order to configure any VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- You can skip this command if the switch is already in server mode and you
    !--- want the switch to be in server mode.
    
    

    Nota: Um switch pode criar VLANs apenas se estiver no modo de servidor ou transparente do VTP. Consulte Como Entender o Protocolo VLAN Trunk (VTP) para obter mais informações sobre o VTP.

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- You must exit from the VLAN database in order for the changes 
    !--- to be committed.
    
    APPLY completed.
    Exiting....
    3524XL#

    Nota: O modo de VTP pode mudar do modo de cliente para o modo transparente se o switch experimentar captar ou transmitir um número maior de VLANs do que o suportado. Sempre verifique se os switches executados no modo de cliente oferecem suporte ao mesmo número de VLANs que os switches enviam no modo de servidor.

  3. Execute o comando show vlan para assegurar-se de que a VLAN foi criada.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
  4. Você pode adicionar portas (interfaces) à VLAN recém-criada.

    É necessário entrar no modo de configuração de interface para todas as interfaces que deseja adicionar à nova VLAN.

    Nota: Você pode atribuir as portas de um Switch Catalyst de Camada 2 a várias VLANs, mas o switch oferece suporte apenas a uma interface de VLAN de gerenciamento ativo por vez, e outras interfaces virtuais comutadas (SVIs) não efetuam "up/up" devido à funcionalidade da Camada 2. Assim sendo, o switch oferece suporte apenas a um endereço de Camada 3 de gerenciamento ativo. Em um Switch Catalyst de Camada 2, você pode executar o comando management opcional sob o novo SVI a fim de encerrar automaticamente a VLAN 1 e transferir o endereço IP para a nova VLAN.

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down    
    VLAN2                      20.0.0.2        YES manual up       up      
    FastEthernet0/1            unassigned      YES unset  up       up      
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Output suppressed.
    
    

    Execute esse conjunto de comandos no modo privilegiado a fim de adicionar uma interface particular à VLAN:

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/2 to VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/3 to VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- This saves the configuration.
    
    Building configuration...
  5. Execute o comando show vlan para verificar a configuração de VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Remova as Portas ou VLANs

Para remover as portas da VLAN, execute o comando no switchport access vlan vlan_number no modo de configuração da interface. Depois que a porta é removida de uma VLAN que não seja a VLAN 1 (a VLAN padrão), essa porta é adicionada automaticamente de volta à VLAN padrão.

Por exemplo, se você desejar remover a interface Fast Ethernet 0/2 de cisco_vlan_2 (VLAN 2), execute este conjunto de comandos no modo privilegiado:

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- These two commands remove interface Fast Ethernet 0/2 from VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Note: Fast Ethernet 0/2 is added back to the default VLAN.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Para excluir a VLAN, execute o comando no vlan vlan_number no modo de banco de dados de VLAN. As interfaces nessa VLAN permanecem parte dessa VLAN e são desativadas porque já não pertencem mais à VLAN.

Por exemplo, se você quiser excluir a cisco_vlan_2 do switch, execute este conjunto de comandos no modo privilegiado:

3524XL#vlan database

!--- This command enters you into the VLAN database mode.

3524XL(vlan)#no vlan 2

!--- This command removes the VLAN from the database.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Output suppressed.

Observe que a porta Fast Ethernet 0/3 não é exibida na saída do comando show vlan. A remoção da VLAN 2 desativa essa porta. A menos que você adicione a porta de volta a outra VLAN, ela não será exibida nem poderá ser utilizada.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Output suppressed.

Para tornar a interface utilizável, assegure-se de que ela pertença a alguma VLAN. No caso desta seção do documento, você deve adicionar a interface Fast Ethernet 0/3 à VLAN padrão (VLAN 1) para poder utilizar essa interface.

Se você tiver a saída do comando show-tech support do seu dispositivo Cisco, poderá utilizar o Output Interpreter (apenas clientes registrados) para exibir problemas potenciais e soluções.

Nota: No caso dos Switches Catalyst 3550, você ainda pode utilizar a interface sem a sua adição a uma VLAN. Contudo, você precisa tornar essa interface uma interface de Camada 3. Consulte a seção Configuração de Interfaces de Camada 3 do Configuração de Características da Interface para obter mais informações sobre interfaces de Camada 3 em Switches Catalyst 3550.

Configure uma Porta Multi-VLAN no Catalyst 2900XL/3500XL

Os recursos de porta Multi-VLAN em Switches Catalyst 2900XL/3500XL permitem que você configure uma única porta em duas ou mais VLANs. Essa característica permite que os usuários de VLANs diferentes acessem um servidor ou um roteador sem a implementação da capacidade de roteamento entre VLANs. Uma porta multi-VLAN realiza as funções normais de switching em todas as VLANs atribuídas. O tráfego de VLAN na porta multi-VLAN não é encapsulado enquanto está no entroncamento.

Nota: Estas são as limitações à implementação das características de porta multi-VLAN:

  • Você não pode configurar uma porta multi-VLAN quando um tronco estiver configurado no switch. Você pode conectar a porta multi-VLAN apenas a um roteador ou a um servidor. O switch faz automaticamente a transição para o modo transparente de VTP quando a característica de porta multi-VLAN está habilitado, desabilitando o VTP. Nenhuma configuração de VTP é necessária.

  • As características de porta multi-VLAN são suportados apenas em Switches Catalyst 2900XL/3500XL Series. Essa característica não é suportada em Switches Catalyst 4500/4000, 5500/5000, 6500/6000 Series nem em nenhum outro switch Catalyst.

  1. Determine qual porta configurar como uma porta multi-VLAN.

    Aqui, três VLANs são criadas em um Switch Catalyst 3512XL, e uma porta do switch é conectada a um roteador externo. Neste exemplo, é configurada a porta que é conectada ao roteador como uma porta multi-VLAN.

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active

    No exemplo, a porta Fast Ethernet 0/1 é conectada a um roteador externo. Para obter mais informações sobre como criar VLANs e atribuir portas a elas, consulte a seção Configure a VLAN em Switches Catalyst 2900XL, 3500XL, 2950, 2970 e 2940 Series deste documento.

  2. Configure a porta Fast Ethernet 0/1 no modo de multi-VLAN e adicione as VLANs designadas à porta multi-VLAN.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- This command changes the port Fast Ethernet 0/1 mode to multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- This command assigns VLANs 1, 2, and 3 to multi-VLAN port Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
     
    6-3512xl#
  3. Execute o comando show interface interface_id switchport e o comando show vlan para verificar a configuração.

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- The port is in multi-VLAN mode.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Note: Previously, port Fast Ethernet 0/1 was only in VLAN 1.
    !--- Now the port is assigned to multiple VLANs 1, 2, and 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
  4. Execute o comando ping do switch para o roteador a fim de verificar a operação da multi-VLAN.

    O comando ping recebe uma resposta do roteador cada vez que o endereço IP de gerenciamento é atribuído a qualquer uma das VLANs 1, 2 ou 3.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- The management IP address is assigned to VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- The management IP address is removed from VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- The management IP address is assigned to VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- The management IP address is removed from VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- The management IP address is assigned to VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Configure a VLAN em Switches Catalyst 3550, 3750, 4500/4000, e 6500/6000 que Executam o Software Cisco IOS

Crie VLANs e Portas

Esta seção utiliza o Switch Catalyst 4500 para comandos da configuração de exemplo, mas as tarefas de configuração também se aplicam a outros switches que executam a Camada 3 (ou o Software Cisco IOS). Esses outros switches incluem o Catalyst 3550, 3570 e 6500 Series que executam o Software Cisco IOS. Para criar uma VLAN, o switch deve estar no modo de servidor ou transparente do VTP. Se o switch for um servidor de VTP, será necessário definir um nome de domínio de VTP para poder adicionar qualquer VLAN. Você deve definir o VTP domain name independente de:

  • O número de switches na rede, se um ou vários

  • Se você utiliza o VTP para propagar VLANs para outros switches na rede

Consulte Como Entender e Configurar o VTP para obter mais informações sobre como configurar o VTP nos módulos do Software Catalyst 4500/4000 Cisco IOS com base em Supervisor Engine. Consulte o Guia de Configuração do Software da plataforma de switch em questão para obter informações sobre a configuração de VTP para outras plataformas de switch Catalyst. Consulte as Páginas do Suporte do Produto de LAN para localizar o Guia de Configuração do Software.

Você pode criar VLANs no modo de banco de dados de VLAN ou no modo de configuração global. É necessário criar as VLANs com números superiores a 1005 no modo de configuração global. O modo de VTP deve ser definido como transparente a fim de criar essas VLANs. As VLANs com números superiores a 1005 não são anunciadas pelo VTP. Além disso, essas VLANs são armazenadas no arquivo de configuração de switch e não no arquivo .DAT VLAN. O local padrão do arquivo .dat VLAN em Switches Catalyst 4000 com Supervisor Engine IV é o diretório cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Nota: Um Switch Catalyst 6500 que executa o Software Cisco IOS permite que você crie VLANs no modo de servidor sem um nome de domínio do VTP.

O comando show vtp status mostra as informações de VTP no switch.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. Execute o comando show vlan para verificar a informação de VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Output suppressed.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports 
    ------- --------- ----------------- ------------------------------------------
  2. Entre no modo correto, ou seja, o modo de banco de dados ou de configuração global.

    Execute o comando vlan database no modo privilegiado a fim de entrar no modo de banco de dados de VLAN.

    Switch#vlan database
    
    Switch(vlan)#
  3. Execute o comando vlan vlan_number a fim de configurar uma VLAN.

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.

    Nota: Para que a configuração entre em vigor, você pode executar o comando apply ou sair do modo de banco de dados de VLAN. Os métodos de saída de palavra-chave end e Ctrl-Z não funcionam no modo de banco de dados de VLAN. Execute o comando exit para sair do modo de banco de dados de VLAN.

    Execute estes comandos para executar a configuração de VLAN no modo de configuração global:

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
  4. Execute o comando show run para ver as VLANs com números superiores a 1005 na configuração de execução.

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Output suppressed.
    
    

No Software Cisco IOS, as interfaces estão no estado shutdown como padrão, ao contrário dos switches com base em CatOS. No CatOS, a porta irá se tornar ativa se detectar a presença de um link físico.

Como padrão, as interfaces do Software Cisco IOS são interfaces de Camada 2 em Switches Catalyst 3550, 3750 e 4500 Series. As interfaces são de Camada 3 em Switches Catalyst 6500/6000 Series. Você pode configurar a interface como uma interface de Camada 2 com o comando switchport no modo de configuração da interface. Você deve executar este comando antes de atribuir uma interface a uma VLAN, se a interface estiver no modo de Camada 3. O comando para atribuir uma interface a uma VLAN é switchport access vlan vlan_number .

Nota: Se a interface estiver configurada como uma interface de Camada 3, o que significa que o comando no switchport está configurado, você não poderá atribuir a interface a uma VLAN.

Para associar as portas a VLANs no Software Cisco IOS, esta configuração mínima é exigida:

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- This command is required if the interface is in Layer 3 mode.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Execute o comando show interface gigabitethernet module/interface switchport para verificar o status da interface de Camada 2.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Se a porta for configurada como um tronco, que é uma porta que pode carregar mais de uma VLAN, o comando switchport trunk native vlan poderá ser útil. O comando será útil se a VLAN nativa da interface foi alterada ou os seus padrões precisarem ser alterados. A VLAN nativa será a VLAN utilizada se a interface se transformar em uma interface de Camada 2. Se você não definir explicitamente uma VLAN nativa, a VLAN 1 se tornará a VLAN nativa como padrão. Lembre-se que um cabeçalho do Instituto de Engenharia Elétrica e Eletrônica (Institute of Electrical and Electronics Engineers) 802.1Q não é adicionado quando os dados são enviados na VLAN nativa. Assegure-se de que as portas do tronco nos dois dispositivos conectados tenham a mesma VLAN nativa. Um erro de correspondência nas VLANs nativas pode causar problemas de roteamento entre VLANs, entre outros problemas.

Esta mensagem é exibida quando há um erro de correspondência na VLAN nativa nos dois switch Cisco:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

Nesta mensagem de exemplo, a VLAN nativa é VLAN 2 em um dos switches, mas o switch vizinho tem a VLAN 1 nativa.

Execute o comando show interfaces module/interface trunk para ver a VLAN nativa, o encapsulamento e as informações da VLAN de entroncamento.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Se você utilizar a configuração padrão, a VLAN nativa será definida como VLAN 1. Para alterar a VLAN nativa na interface que é o entroncamento, execute o comando switchport trunk native vlan vlan_number.

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Execute esse comando para verificar:

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Atribua várias Portas a uma única VLAN

Você pode atribuir as várias interfaces em um switch a uma única VLAN. Execute estes comandos:

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

Nota: O comando interface range não é suportado em todas as releases do software. O comando interface range é suportado no Software Cisco IOS Release 12.1(13)EW e mais recente.

Remova VLANs

Para remover uma VLAN do banco de dados de VLAN, execute o comando no vlan vlan_number no modo de banco de dados de VLAN ou no modo de configuração global. Este exemplo utiliza o modo de banco de dados de VLAN para remover a VLAN 2.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

O modo de configuração global não registra nenhuma mensagem na console que indique a exclusão da VLAN. Contudo, você pode executar o comando show vlan para verificar a remoção da VLAN.

Renomeie VLANs

Para renomear uma VLAN do banco de dados de VLAN, execute o comando name vlan_name modo de banco de dados de VLAN ou no modo de configuração global.

Este exemplo utiliza o modo de banco de dados de VLAN para renomear a VLAN 3:

Switch#vlan database

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Switch(vlan)#apply

APPLY completed.

Este exemplo utiliza o modo de configuração global para renomear a VLAN 3:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Para verificar, execute o comando show vlan brief ou o show vlan-switch brief .

switch#show vlan brief

VLAN  Name                             Status    Ports
---- -------------------------------- --------- -----------
 3    CISCO                            active    Fa0/3

Nota: Quando você renomeia a VLAN, não é necessário remover a VLAN atribuída à porta utilizando o comando switchport access vlan vlan_number.

Como Isolar a Comunicação entre duas VLANs

Esta seção não discute VLANs privadas. As VLANs privadas fornecem o isolamento da Camada 2 entre portas dentro da mesma VLAN privada (VLAN isolada) ou entre as VLANs privadas (VLANs de comunidade).

Há dois cenários para quando você experimentar isolar duas VLANs.

Isolamento entre duas VLANs de Camada 2

Uma VLAN de Camada 2 é a VLAN criada no switch e não configurada com o comando interface vlan <vlan_number> . Os hosts nas diferentes VLANs de Camada 2 não podem se comunicar entre si.

Siga estas etapas para criar uma VLAN de Camada 2 e isolá-la das VLANs mais antigas:

  1. Crie a nova VLAN no banco de dados. Ao sair do modo de banco de dados de vlan, as alterações na configuração são aplicadas.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode in order to 
    !--- configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Assegure-se de que a VLAN tenha sido criada no banco de dados de vlan. A nova VLAN deve aparecer na saída do comando show vlan.

  3. Não defina um endereço IP para as VLANs recém-criadas.

  4. Configure interfaces físicas que conectem os clientes à VLAN correspondente.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. Atribua a cada host um endereço IP estático, uma máscara de sub-rede, e não defina um gateway padrão. Isso faz com que os hosts nas portas fa 2/1 e 2/2 não se comuniquem entre si. Dispositivos que pertencem a uma VLAN não alcançam nada além dos dispositivos dentro da mesma VLAN.

Isolamento entre duas VLANs de Camada 3

Quando você cria uma VLAN e designa um endereço IP com o comando interface vlan <vlan_number> , a VLAN se transforma em uma VLAN de Camada 3. Nos switches de Camada 3, os hosts entre as duas VLANs podem se comunicar entre si (se os hosts forem configurados com o gateway padrão como o endereço IP da interface de VLAN). Você pode utilizar ACLs para negar a comunicação entre as VLAN.

Esta seção mostra um exemplo de como isolar a comunicação entre uma VLAN de Camada 3 recém-criada e uma VLAN mais antiga.

Neste exemplo, o switch 3750 tem duas VLAN antigas (VLAN 1 e VLAN 2). A VLAN recém-criada é VLAN 5. VLAN 1, VLAN 2 e VLAN 5 são de Camada 3. As ACLs são executadas para impedir o tráfego de modo que a VLAN 1 e a VLAN 2 não possam se comunicar com a VLAN 5 e que a VLAN 5 não se comunique com a VLAN 1 e a VLAN 2.

  • VLAN 1 - 10.10.10.0 /24

  • VLAN 2 - 172.16.1.0 /24

  • VLAN 5 - 192.168.1.0 /24

  1. Crie a nova VLAN no banco de dados. Neste caso, a VLAN nova é VLAN 5. Ao sair do modo de banco de dados de vlan, as alterações na configuração são aplicadas.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode
    !--- in order to configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Assegure-se de que a VLAN tenha sido criada no banco de dados de vlan. Verifique a saída do comando show vlan.

  3. Defina um endereço IP para a VLAN recém-criada.

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. Configure interfaces físicas que conectem os clientes à VLAN correspondente.

    Switch(config)#interface fastEthernet 2/1 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    Você precisa configurar três listas de acesso, uma para cada VLAN.

    • Essa lista de acesso impede o tráfego que vem da VLAN 1 para a VLAN 5.

      
      !--- Some of the commands in this output are wrapped
      !--- to a second line due to spatial reasons.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny 
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • Essa lista de acesso impede o tráfego que vem da VLAN 2 para a VLAN 5.

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • Essa lista de acesso impede o tráfego que vem da VLAN 5 para as VLANs 1 e 2.

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    Assim que configuradas, aplique as listas de acesso às interfaces VLAN 1, VLAN 2 e VLAN 5.

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Como Configurar VLANs de Intervalo Estendido em um Switch Catalyst 6500 Series

Para configurar VLANs estendidas nos Switches Catalyst 6500 Series que executam o Cisco IOS, você precisa executar o comando spanning-tree extend system-id . Em seguida, a VLAN estendida deverá ser criada no modo de configuração e não no modo de banco de dados vlan.

Siga estas etapas para criar VLANs estendidas nos Switches Catalyst 6500 Series que executam o Cisco IOS:

  1. Console no switch:

    Switch>enable
    Switch#
  2. Entre no modo de configuração:

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
  3. Execute o comando spanning-tree extend system-id no modo de configuração:

    Switch(config)#spanning-tree extended system-id
    
  4. Execute o comando vtp mode transparent no modo de configuração:

    Switch(config)#vtp mode transparent
    
  5. Crie a VLAN no modo de configuração:

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. Saia do modo de configuração:

    Switch(config)#exit
    
  7. Execute o comando show vlan para verificar a informação de VLAN.

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    1311 VLAN1311                         active    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0   
    101  enet  100101     1500  -      -      -        -    -        0      0   
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   
    1311 enet  101311     1500  -      -      -        -    -        0      0   

Dicas para Troubleshooting

Esta seção fornece dicas de troubleshooting para os problemas comuns que você pode encontrar durante a criação de VLANs em Switches Catalyst que executam o Software Cisco IOS.

Em switches que executam o Software Cisco IOS, você pode utilizar o próprio switch para o roteamento entre VLANs, em vez de um roteador externo. Quando um SVI é criado, ele não cria automaticamente uma VLAN no banco de dados de Camada 2. Para que um SVI seja ativado, uma VLAN deve ser criada no modo de banco de dados de VLAN ou (em releases posteriores do Software Cisco IOS) no modo de configuração global. Para que o SVI esteja inteiramente ativo, o que significa administrativamente ativo e o protocolo de linha ativo, assegure-se de que haja pelo menos uma porta como membro dessa VLAN, com um dispositivo ativo conectado à porta.

Esse mesmo problema se aplica quando você copia configurações de outro switch ou restaura configurações com VLANs criadas no modo de banco de dados de VLAN. Você deve igualmente substituir o arquivo de base de dados de VLAN (vlan.dat), ou você deve recrear os VLAN, porque o procedimento na seção de CreateVLANs e de portas deste documento mostra. Se você copiar a configuração de um outro switch, o banco de dados de VLAN não será copiado.

Se a VLAN de Camada 2 não for criada no switch, as interfaces de SVI serão mostradas como UP/DOWN na saída do comando show ip interface brief quando a configuração for aplicada ao switch. Assegure-se de que todas as VLAN anteriores que foram criadas no modo de banco de dados de VLAN ou no modo de configuração global ainda existam depois que a configuração for copiada no switch.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Erro de Valor TLB Inconsistente em Switches IOS

O erro de valor TLB inconsistente ocorre quando você cria uma VLAN em um switch Cisco IOS que recebeu recentemente uma atualização de VTP de um switch CatOS ou que foi convertido do CatOS. Isso ocorre porque o CatOS e o Cisco IOS têm alguns valores padrão diferentes para o VLAN de ponte de transição. As VLANs de transição convertem a Interface de Dados Distribuídos por Fibra Óptica (FDDI) ou o Token Ring em Ethernet. A VLAN de ponte da transição (tb) para a VLAN 1, 1002 e 1003 são diferentes no CatOS e são 0 como padrão. As VLANs de ponte de transição padrão de fábrica em switches Cisco IOS são:

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

Um switch Cisco IOS que recebeu recentemente uma atualização de VTP de um switch CatOS ou que foi convertido do CatOS substitui os valores de tb padrão. Quando você tenta criar qualquer VLAN após isso, é gerada esta mensagem de erro:

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Como solução alternativa para esse problema, altere os valores padrão tb do switch Cisco IOS para a VLAN 1, 1002 e 1003 de forma que correspondam aos valores de CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Recupere o Arquivo vlan.dat em Switches IOS

Para Switches Cisco Catalyst que executam o software Cisco IOS, as informações de VLAN estão em um arquivo separado denominado vlan.dat. Se o arquivo vlan.dat foi excluído acidentalmente e o switch for recarregado, todas as VLANs que estavam disponíveis no switch serão perdidas. Até que o switch seja recarregado, as informações de VLAN estarão presentes no switch.

Siga estas etapas para recuperar o arquivo vlan.dat:

  1. Execute o comando show vlan para confirmar a disponibilidade das informações de VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
  2. Se o switch estiver no modo de Servidor de VTP ou Transparente, faça todas as alterações no banco de dados de VLAN.

    As alterações no banco de dados de VLAN podem ser qualquer uma destas:

    • Criar qualquer VLAN.

    • Excluir qualquer VLAN.

    • Alterar as propriedades de qualquer VLAN existente.

    Se o switch estiver no modo de Cliente do VTP, faça alterações no banco de dados de VLAN em qualquer Servidor VTP do mesmo domínio.

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#

    Depois de fazer qualquer alteração no banco de dados de VLAN, o switch cria automaticamente o arquivo vlan.dat.

  3. Execute o comando show flash: para verificar a criação do arquivo vlan.dat.

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)

Falha ao Criar VLANs em Intervalo Estendido

Erro 1

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

Portas de LAN de Camada 3, interfaces WAN e subinterfaces, bem como algumas características do software, como o RSPAN, utilizam VLANs internas no intervalo estendido. Você não pode utilizar uma VLAN de intervalo estendido que esteja atribuída para uso interno.

Para exibir as VLAN utilizadas internamente, execute o comando show vlan internal usage. Você pode configurar a alocação de VLAN interna ascendente (de 1006 em diante) ou a alocação de VLAN interna descendente (de 4094 para baixo).

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Enter the ascending keyword to allocate internal VLANs from 1006 and up. 
!--- Enter the descending keyword to allocate internal VLAN from 4094 and down.

Switch(config)#end 
Switch#reload

cuidado Cuidado: Você não precisa executar imediatamente o comando reload. Execute o comando reload durante um intervalo de manutenção planejada. A política da alocação de VLAN interna é aplicada apenas depois um recarregamento.

Se um recarregamento de dispositivo não for uma opção, como solução alternativa, você pode utilizar a Conversão VLAN. Em portas de tronco, você pode converter um número de VLAN um outro número de VLAN, o que transfere todo o tráfego recebido em uma VLAN para a outra VLAN. Consulte a seção Configuração da Conversão VLAN do Configuração de VLANs para obter mais informações.

Nota: Switches que executam o software da família de produtos Catalyst não oferecem suporte à configuração das VLANs 1006-1024. Se você configurar VLANs 1006-1024, assegure-se de que elas não se estendam a nenhum switch que execute o software da família de produtos Catalyst.

Erro 2

%Failed to commit extended VLAN(s) changes

Você pôde receber esta mensagem quando estiver tentando criar VLANs estendidas no modo de Servidor ou de Cliente de VTP.

Assegure-se de que o dispositivo (Switch ou Roteador) esteja no modo Transparente quando você criar VLANs de intervalo estendido. Consulte a seção Diretrizes de Protocolo de Entroncamento de VLAN do ID da VLAN Estendida para obter mais informações.

Falha ao Configurar a VLAN a partir de Startup-Config

SW-VLAN-4-BAD-STARTUP-VLAN-CONFIG-FILE: Failed to configure VLAN from 
startup-config. Fallback to use VLAN configuration file from non-volatile memory

Essa mensagem indica que o software da VLAN não usou a configuração de VLAN do arquivo de configuração de inicialização. A configuração da VLAN é armazenada no arquivo vlan.dat. O arquivo vlan.dat reside na memória permanente. Quando o módulo do Supervisor é substituído, o arquivo vlan.dat está vazio (0). Na inicialização, o switch compara o nome de domínio e o nome de VTP no arquivo de configuração de inicialização e no arquivo vlan.dat. Se os valores não corresponderem, o switch utilizará a configuração no arquivo vlan.dat.

Para executar um backup completo de sua configuração, o arquivo vlan.dat deve ser incluído no backup com a configuração. O administrador de rede deve carregar os arquivos vlan.dat e de configuração para restaurar a configuração completa.

Backup e Restauração do vlan.dat em Switches Cisco IOS

Para fazer backup do vlan.dat, siga este passo:

Copie o arquivo vlan.dat do NVRAM do dispositivo em um servidor TFTP ou em uma placa PCMCIA externa.

copy const_nvram:vlan.dat tftp:

Nota: O local da memória onde o arquivo vlan.dat é armazenado varia de dispositivo para dispositivo. Em Switches Cisco Catalyst 6500/6000 Series, é const_nvram:. Da mesma forma para Switches Catalyst 4500/4000, é cat4000_flash:. Refira a documentação de respectivos produtos antes de emitir o copycommand.

Siga estas etapas para recuperar o arquivo vlan.dat:

  1. Copie o arquivo vlan.dat no NVRAM do dispositivo em um servidor TFTP ou em uma placa PCMCIA externa.

    copy tftp: const_nvram:
  2. Recarregue o switch, porque vlan.dat é apenas leitura durante o processo de inicialização.

A Criação de VLAN Falha com Mensagem de Erro VLAN 1003 parent VLAN missing

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
VLAN 1003 parent VLAN missing
APPLY VLAN changes failed.
Switch(config)#end
Switch#

Um erro de configuração em um switch pode fazer com que as atualizações de configuração do VTP falhem. Na maioria dos casos, o problema é que a nova VLAN criada no switch de servidor VTP não é propagada para os switches de cliente do VTP, o que cria problemas de conectividade no host.

Uma causa comum desse problema é um erro de correspondência de versão de VTP entre os switches em um domínio de VTP. O VTP versão 1 e o VTP versão 2 não são interoperáveis nos dispositivos de rede no mesmo domínio de VTP. Um dispositivo de rede capacitado para VTP versão 2 pode funcionar com um dispositivo de rede que execute o VTP versão 1, contanto que o VTP versão 2 seja desabilitado no dispositivo de rede capacitado para o VTP versão 2. O VTP versão 2 é desabilitado como padrão. Cada dispositivo de rede no domínio de VTP deve utilizar a mesma versão de VTP. Verifique a versão do VTP que é executado em um switch. Se o VTP versão 2 estiver habilitado, desabilite-o para resolver esse problema.

Verifique se o switch está configurado corretamente para outros parâmetros de VTP:

  • Verifique se os switches estão conectados através dos links de tronco, porque os upgrades de VTP são transmitidos apenas por links de tronco.

  • Verifique se o nome de domínio de VTP é exatamente o mesmo nos switches apropriados. O nome diferencia maiúsculas e minúsculas. Os upgrades de VTP são transmitidos apenas entre switches no mesmo domínio de VTP.

  • Verifique se a senha de VTP é exatamente a mesma em todos os switches no domínio. A senha faz distinção entre maiúsculas e minúsculas. Se uma senha for configurada, ela deverá ser configurada em todos os switches no domínio, e a senha deverá ser a mesma.

Em caso de um problema da convergência de VTP, em que um cliente de VTP não atualize as informações da VLAN, a solução alternativa é forçar uma convergência de VTP pela criação e, em seguida, a remoção de uma VLAN fictícia no servidor VTP. Isso incrementa o número de revisão e força todos os clientes de VTP a atualizarem seu banco de dados de VLAN.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 10023