Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Configurando o NFAS com quarto T1s

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O Non-facility Associated Signaling (NFAS) de ISDN permite que um único canal D controle as várias Interfaces de Taxa Primária (PRIs, Primary Rate Interfaces). Você pode configurar um canal D de backup quando o canal D de NFAS principal falhar. Quando você configura os controladores de T1 canalizados para ISDN PRI, só precisa configurar o canal D de NFAS principal; sua configuração é distribuída a todos os membros do grupo de NFAS associado.

Usando um único canal D para controlar várias PRIs, um canal adicional em cada interface fica livre para levar o tráfego de dados. Toda falha grave do canal de sinalização D principal resulta em um switchover imediato para o canal D de backup sem desconectar os usuários atualmente conectados.

Nota: Se você configurar um canal D de backup, apenas 23 canais B poderão ser usados no controlador T1 de backup, porque o canal D do backup não estará disponível. Por isso, os T1s que não são principais nem de backup podem ter 24 canais B disponíveis. Nesta configuração, o controlador T1 4/0 é o principal e tem 23 canais B disponíveis, e o controlador T1 4/1 é o de backup e tem 23 canais B disponíveis. Os controladores T1 5/0 e 5/1 têm 24 canais B disponíveis cada um.

Pré-requisitos

Requisitos

Os pré-requisitos para NFAS são:

  • O NFAS é suportado apenas com um controlador de T1 canalizado e, em consequência, os controladores T1 também devem ser configurados para ISDN PRI antes de implementar o NFAS. Para obter mais informações sobre como configurar o ISDN, consulte a Página Suporte de ISDN.

  • O roteador configurado para NFAS deve ser conectado a um switch tipo 4ess, dms250, dms100 ou National ISDN.

    Nota: O NFAS não é suportado nos switches tipo primary-5ess. Consulte seu provedor de serviços ou sua Telco para determinar se o NFAS pode ser configurado para sua linha T1.

  • O NFAS deve ser configurado no switch ISDN da Telco.

  • Você deve usar o Software Release 11.3T ou Mais Recente de Cisco IOS�.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • A configuração a seguir foi testada com um roteador Cisco 7507 executando o Cisco IOS Software Release 12.0(5).

  • Essa configuração ilustra como instalar quatro membros de NFAS no mesmo grupo. A interface de NFAS principal é T1 4/0, e a de backup é T1 4/1. Os controladores T1 5/0 e 5/1 têm 24 canais B disponíveis

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Terminologia NFAS

Os termos de NFAS comumente usados são:

  • NFAS - Um serviço de ISDN que permita um único canal D às várias pris de controle. Usar um único canal D para controlar várias PRIs permite que um canal B em cada interface se encarregue de outro tráfego.

  • Interface de 24 canais B - Um grupo de canais PRI configurados para não ter nenhum canal D de NFAS; os 24 canais são canais B. Esse T1 específico usa o canal D configurado no controlador principal para sinalização.

  • Grupo de NFAS - Um grupo de canais PRI (o grupo de interfaces) sob controle de um único canal D. O grupo de canais pode incluir todos os canais ISDN em vários controladores T1.

    Nota: O NFAS pode ser configurado com membros em diferentes slots no roteador (por exemplo, os membros de NFAS não têm restrição para ficar no mesmo slot ou módulo). Além disso, em um único chassi, cinco grupos de NFAS são suportados. Nos casos em que T1s de vários provedores são usados, eles são normalmente agrupados por provedor.

  • Membro de NFAS - Uma PRI em um grupo de NFAS. Por exemplo, um grupo de NFAS pode incluir interfaces seriais 1/0:23, 1/1:23 e 2/0:23 se os controladores T1 1/0, 1/1 e 2/0 forem configurados em um grupo de NFAS. Para exibir os membros de todos os grupos de NFAS, use o comando show isdn nfas group privileged EXEC.

Comando necessário

Nota: Os comandos de configuração de ISDN PRI não aparecem neste documento. Veja a seção Informações Relacionadas para obter mais informações sobre a configuração de ISDN PRI.

pri-group timeslots 1-24 nfas_d function nfas_interface int_number nfas_group group_number

Esse comando de configuração de controlador atribui o controlador T1 ao grupo de NFAS e designa sua função dentro do grupo. Especifique os valores a seguir conforme apropriado:

  • function - A função a ser executada pelo timeslot 24, seja ele principal, de backup ou nenhum. Todo grupo de NFAS deve ter um principal. O roteador não exige um backup, mas a maioria das implementações de NFAS tem um canal D de backup. Entre em contato com sua telco para determinar se você deve configurar um canal D de backup para seu grupo de NFAS. O resto dos controladores pode ser configurado como nenhum, o que designa o 24º timeslot como um canal B.

    Nota: Configure os canais D principal e de backup exatamente como especificado por sua Telco. Um erro comum em uma configuração de NFAS é designar incorretamente o T1 principal e o de backup.

  • int_number - Um valor atribuído pelo provedor de serviços e usado para identificar a PRI exclusivamente. Os valores possíveis variam de 0 ao maior T1 disponível no roteador, menos um. Por exemplo, se o roteador tem 10 T1s, o número da interface de NFAS pode variar entre 0 e 9. As interface 0 deve ser atribuída ao canal D principal, e a interface 1 ao canal D de backup.

    Nota: Em determinados casos em que a configuração do NFAS não usa um canal D de backup, não use a palavra-chave nfas_interface 1, pois é reservada para o canal D de backup. Configure somente os nfas_interfaces 0, 2, 3, 4 etc.

    Nota: Ao configurar vários grupos de NFAS, a interface 0 deve ser atribuída a cada canal D principal, e a interface 1 a cada canal D de backup, contanto que estejam em um nfas_group diferente.

  • group_number - Identificador do grupo exclusivo no roteador. Vários grupos de NFAS podem existir no roteador. Cada grupo deve ser configurado com um controlador principal e secundário.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/9584/quadt1_nfas.gif

Configurações

Este documento utiliza as seguintes configurações:

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • status de ISDN da mostra - Certifique-se de que o roteador se está comunicando corretamente com o switch ISDN. Na saída, verifique se o status da camada 1 está ATIVO e se o estado de status da camada 2 = MULTIPLE_FRAME_ESTABLISHED é exibido.

  • comando show isdn nfas group privileged exec indicar os membros de grupo nfas especificado ou de todos os grupos NFAS.

  • mostre o serviço isdn - Comando privileged exec mostrar o estado e o estado do serviço de cada canal ISDN. Os canais D são indicados como reservados. Este comando pode ser usado para verificar se os canais individuais estão ocupados ou defeituosos.

  • show controller t1 – Exibe o status do controlador específico ao hardware do controlador. Exibe também informações para resolver problemas de camada física e camada de link de dados. Durante o funcionamento normal, a saída deve indicar que o controlador está ativado e que não há nenhum alarme.

Nota: Certifique-se de que a conexão T1 designada como preliminar pelo telco e em sua configuração de roteador está conectada à porta correta. Um erro comum é conectar a linha T1 (cabos) errada à porta T1 principal em seu roteador.

Exemplo de saída de show

Veja a seguir algumas saídas do comando show do roteador configurado com NFAS.

Veja um exemplo de saída do comando show isdn status:

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

Nota: A saída do show isdn status exibe somente informações relacionadas ao canal D para os controladores principal e de backup. Além disso, somente o canal D principal (Serial4/0:23) exibe ACTIVE e MULTIPLE FRAME ESTABLISHED. O status do canal D de backup (Serial4/1:23) aparece como DEACTIVATED e TEI_ASSIGNED.

A saída do show isdn status para Camada 1 e Camada 2 do T1 5/0 e 5/1 é designada como NOT APPLICABLE porque o 24º canal (Serial 5/0:23 e Serial 5/1:23) está sendo usado como um canal B.

Esta é a saída do comando show isdn nfas group:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

Nota: A saída do show isdn nfas group exibe os membros do grupo. A saída mostra que o controlador 4/0 é o principal e o 4/1 é o de backup. Os controladores 5/0 e 5/1 são membros do grupo e têm 24 canais B disponíveis.

A saída também mostra o número total de membros de NFAS e o número de canais disponíveis. Mostra que o canal D principal está no estado In Service enquanto o de backup está no estado Out of Service.

Veja um exemplo de uma saída do comando show isdn service:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

A saída do show isdn service mostra que os canais D do principal e do secundário estão no estado 3, que corresponde a Reserved. Os canais D dos outros membros estão no estado 2, o que indica que estão no estado Busy e em uso como canais B. Um estado de canal de 0 indica que o canal está disponível para uso.

Nota: Em muitos dispositivos (normalmente servidores de acesso) o Service State do canal D é 2, indicando que o canal está no estado Out of Service. Esse é um problema cosmético e não deve afetar sua conexão. Para determinar se o canal D está realmente funcionando, use o comando show isdn status, conforme descrito anteriormente

Para controladores que não estão designados como principais ou de backup (5/0 e 5/1), certifique-se de que o 24º canal esteja no estado Idle ou Busy. Não deve estar no estado Reserved.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, refira a informação importante em comandos Debug:

  • debugar o q931 de ISDN - Mostre a configuração de chamada e rasgue-a para baixo da conexão de rede ISDN (camada 3).

  • debugar isdn q921 - Mostre mensagens da camada de link de dados (camada 2) no canal D entre o roteador e o switch ISDN. Use essa depuração se o comando show isdn status não exibir a Camada 1 e a Camada 2.

Se o Controlador for Encerrado

O que acontece quando o controlador que pertence a um grupo de NFAS é encerrado? Todas as chamadas ativas naquele controlador encerrado serão canceladas, e uma das seguintes opções será aplicável:

  • Se o controlador encerrado for o principal e nenhum controlador de backup estiver configurado, todas as chamadas ativas em todo o grupo serão canceladas.

  • Se o controlador encerrado for o principal, o canal D ativo (IN SERVICE) estiver no principal e um controlador de backup estiver configurado, o canal D ativo mudará para o controlador de backup.

  • Se o controlador encerrado for o principal e o canal D ativo (IN SERVICE) estiver no backup, o canal D ativo permanecerá no controlador de backup.

  • Se o controlador encerrado for o de backup e o canal D ativo (IN SERVICE) estiver no backup, o canal D ativo mudará para o controlador principal.

Nota: A alteração do canal D ativo entre os controladores principal e de backup acontece somente quando um dos links falha, e não quando o link é ativado.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 9584