Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Configurando o retorno de chamada de PPP sobre o ISDN

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para a rechamada do Point-to-Point Protocol (PPP) sobre o Integrated Services Digital Network (ISDN). Você pode usar a rechamada para:

  • Consolidação e centralização da conta de telefone.

  • Poupanças de despesas em ligações nacional.

  • Controle de acesso.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 11.0(3) ou Mais Recente de Cisco IOS�.

  • Cisco 3640 (maui-nas-04) com Cisco IOS Software Release 12.0(5)XK1.

  • Cisco 1604 (maui-soho-01) com Cisco IOS Software Release 12.0(4)T.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Nesta configuração de exemplo, a rechamada usa o PPP e as facilidades que o RFC 1570leavingcisco.com especifica. A conclusão da rechamada ISDN PPP ocorre nesta ordem:

  1. O roteador A ativa uma conexão de circuito comutado com o roteador B.

  2. O Roteadores A e B negocia o protocolo ppp link control (LCP). O roteador A pode rquisitar uma rechamada ou o roteador B pode iniciar uma rechamada.

  3. O roteador A autentica-se ao roteador B com o protocolo ppp password authentication (PAP) ou o protocolo de autenticação de cumprimento do desafio (RACHADURA). O roteador B pode opcionalmente autenticar ao roteador A.

  4. Ambo o Roteadores deixa cair a conexão de circuito comutada.

  5. O roteador B ativa uma conexão de circuito comutado com o roteador A.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos usados neste documento use a ferramenta de Consulta de comando.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/9575/isdn-ppp-callback.gif

Configurações

Este documento utiliza as seguintes configurações:

maui-soho-01: callback client
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local

!--- Basic AAA configuration for PPP calls.

!
username maui-nas-04 password 0 happy

!--- Username for remote router (maui-nas-04) and shared secret password.
!--- Shared secret (for CHAP authentication) must be the same on both sides.

username admin password 0 <deleted>
!
ip subnet-zero
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 172.22.85.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 ip address 172.22.82.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 172.22.82.1 name maui-nas-04 20007

!--- Dialer map statements for the remote router.
!--- The name must match the name that the remote router uses to identify itself.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 20009
 ppp callback request

!--- Request PPP callback from the server.

 ppp authentication chap

!--- Use CHAP authentication.

!
no ip http server
ip classless
ip route 172.22.80.0 255.255.255.0 172.22.82.1
!
dialer-list 1 protocol ip permit

!--- Interesting traffic definition.
!--- Apply this to BRI0 with dialer-group 1.

line con 0
 transport input none
 stopbits 1
line vty 0 4
!
end

maui-nas-04: servidor de rechamada
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-04
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin password <deleted>
username maui-soho-01 password happy

!--- Username for remote router (maui-soho-01) and shared secret password.
!--- Shared secret(for CHAP authentication) must be the same on both sides.

!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 10

!--- Assign BRI 1/1 to the rotary-group 10.
!--- Rotary-group properties are defined in interface Dialer 10.

 isdn switch-type basic-ni
 isdn spid1 20007
!
interface dialer10

!--- Interface for the dialer rotary-group 10 configuration.

 ip address 172.22.82.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer callback-secure 

!--- Disconnect calls that are not properly configured for callback.
!--- Disconnects any unconfigured dial-in users. 

dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009

!--- Dialer map statements for the callback.
!--- The name must match the name that the remote router uses to identify itself.
!--- Use map-class dialer dial1 for this connection.

 dialer-group 1
 ppp callback accept

!--- Allows the interface to accept a callback request to a remote host.

 ppp authentication chap
!
ip classless
ip route 172.22.85.0 255.255.255.0 172.22.82.2
no ip http server
!
map-class dialer dial1

!--- The dialer map statement uses this map class for the callback.

 dialer callback-server username

!--- Use authenticated username to identify return call dial string.

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line 65 70
line aux 0
line vty 0 4
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

  • número de tipo de interface do discador da mostra — informação geral de diagnóstico dos indicadores para as relações que você configura para o Dial-on-Demand Routing (DDR). Os endereços de origem e destino do pacote que iniciou a discagem são mostrados na linha de razão de discagem. Este comando igualmente indica os temporizadores de conexão.

  • status de ISDN da mostra — assegura-se de que o roteador se comunique corretamente com o switch ISDN. Na saída, verifique se o status da camada 1 está ATIVO e se o estado de status da camada 2 = MULTIPLE_FRAME_ESTABLISHED é exibido. Esse comando exibe também o número de chamadas ativas.

  • dialer enable-timeout seconds — permite o intervalo do servidor de chamada de volta, e determina o tempo entre a disconexão do atendimento do atendimento e a iniciação de rechamada.

  • posse-fila do discador — permite que a chamada de volta ao cliente e o server mantenham pacotes destinados ao destino remoto até que a conexão esteja feita.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debugar ppp [pacote | negociação | erro | autenticação] — a informação dos indicadores no tráfego e nas trocas em uma rede interna essa executa o PPP.

    • pacote — pacotes PPP dos indicadores que estão sendo enviados e recebidos. (Este comando mostra cópias parciais da memória de pacote de nível baixo.)

    • negociação — pacotes PPP dos indicadores transmitidos durante a inicialização de PPP, onde as opções de PPP são negociadas.

    • os erros de protocolo e as estatísticas de erros das exibições de erros associaram com a negociação e a operação da conexão PPP.

    • a autenticação — mensagens do protocolo de autenticação dos indicadores, e inclui intercâmbios de pacotes do protocolo de autenticação de cumprimento do desafio (RACHADURA) e trocas do protocolo password authentication (PAP).

  • debugar o q931 de ISDN — configuração de chamada das mostras e rasgue-o para baixo da conexão de rede ISDN (camada 3).

  • debugar isdn q921 — mensagens da camada de link de dados das mostras (camada 2) no canal D entre o roteador e o switch ISDN. Use esse comando de depuração se o comando show isdn status não exibir a Camada 1 e a Camada 2 como ativadas.

  • debug dialer [events | pacotes] — informação sobre DDR debugging dos indicadores sobre os pacotes recebidos em uma interface do discador.

Exemplo de debug


!--- maui-soho-01 (callback client:172.22.82.2) pings maui-nas-04. 
!--- (Callback server:172.22.80.4 - Ethernet interface).
!--- and starts the callback process.
!--- Debugs are collected on maui-soho-01.



maui-soho-01#debug dialer events 
maui-soho-01#show debugging 
Dial on demand: 
  Dial on demand events debugging is on
maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)    
   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007 
   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for
    server disconnect 
   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.    
   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created 
   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 
   Success rate is 0 percent (0/5) 

   
!--- A few seconds later, maui-soho-01 receives the callback from maui-nas-04. 

   
   maui-soho-01# 
   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated 
   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up 
   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007 
   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007 
   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
       changed state to up 
   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
       20007 maui-nas-04 
   
!--- Verifies that the connection was successful


maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 9575