Discar e acessar : Conexões assíncronas

Discagem multlink de PPP assíncrono de Microsoft Windows Clients

26 Agosto 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Nesta configuração do multilink PPP assíncrono, os usuários remotos da discagem com Microsoft Windows 95/98 de PC usam modens múltiplos para aumentar a velocidade de acesso disponível. O multilink PPP assíncrono pode igualmente ser configurado com outros clientes, tais como Linux e Apple Macintosh, com software PPP cliente apropriado. A configuração do roteador para PPP multilink é independente da plataforma do PC cliente.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco AS5300 que executa o Software Release 12.07(T) do � do Cisco IOS.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Material de Suporte

O Multilink PPP (MPPP) permite que os dispositivos enviem dados ao mesmo destino sobre o ponto múltiplo para apontar os links de dados executando um enlace virtual. A conexão MPPP tem uma largura de banda máxima igual à soma das larguras de banda dos links componentes. O MPPP pode ser configurado para enlaces multifacetado, tais como o ISDN e o Frame Relay, ou para linhas assíncronas múltiplas.

O multilink PPP assíncrono pode ser usado para conectar clientes remotos em uma velocidade maior do que aquele disponível através de uma única conexão analógica. No MPPP assíncrono, o cliente remoto usa modens múltiplos, e consequentemente linhas telefônica múltipla, à discagem ao roteador central e alcança a rede. Porque as linhas telefônica múltipla são frequentemente mais baratas do que o serviço do Basic Rate Interface (BRI) ISDN, o MPPP assíncrono fornece uma maneira eficaz aumentar a velocidade de conexão para usuários remotos quando controlar custar. O MPPP assíncrono é igualmente uma maneira eficaz de obter umas velocidades de acesso mais altas para as áreas remotas que não podem ser prestadas serviços de manutenção pelo ISDN.

Os pacotes do MPPP assíncrono separam junto conexões de modem a um servidor de acesso. O software PPP em cada par fragmenta os pacotes e transmite as partes ao outro lado através das conexões analógicas múltiplas. A extremidade de recepção recolhe os pacotes das conexões separadas e, com base na informação PPP encaixada dentro delas, remonta as partes em pacotes de dados válidos, assim fornecendo um link virtual de ponta a ponta com a largura de banda mais alta. O MPPP assíncrono pode ser configurado entre dois Roteadores ou entre um roteador e um PC cliente.

Embora é possível usar mais de dois Modems para uma conexão multilink de um PC cliente, as despesas gerais que os resultados da fragmentação e da remontagem dos pacotes no PC podem negar toda a largura de banda adicional ganhada.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/9553/async_multilink.gif

Configuração de NAS

Nesta configuração, um server AS5300 com uma conexão da relação da taxa principal T1 (PRI) é usado como o servidor do acesso de rede análogo da discagem do usuário (NAS). Como nenhum dos outros controladores de T1 deste NAS está configurado, este servidor de acesso será usado exclusivamente para discagem assíncrona. Esta configuração do AS5300 utiliza modelos virtuais para clonar interfaces de acesso virtual para chamadas de entrada. O conjunto de PPP multilink replica seus parâmetros de interface nas definições de molde virtual.

Alguns comandos AAA (Autenticação, autorização e contabilização) básicos estão incluídos como exemplos de metodologia de prática recomendada. Nomes e senhas de usuário para usuários dialin estão configurados no roteador. Os endereços IP atribuídos aos usuários de linha telefônica são fornecidos em um conjunto de endereços.

Cisco AS5300
bobslake-nas-01#show running-config
Building configuration...

Current configuration:
!
! Last configuration change at 16:01:01 UTC Wed Jun 28 2000
! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000 
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- authenticate for PPP if not authenticated during login
!--- allows users with Terminal Window after Dial to initiate PPP!

username admin password <deleted> 
username charlie password <deleted> 
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
no ip source-route
ip domain-name the.net
!
multilink virtual-template 1

!--- use virtual-template 1 for multilink connections

async-bootp dns-server 172.22.53.210
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.21.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- summarizes addresses in address pool 
!--- Loopback 1 is in the same subnet as the address pool 

no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0  
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls
 
ppp authentication chap

!--- authenticate using Challenge Handshake Authentication Protocol (CHAP)

 ppp multilink
!

!--- configure D channel on PRI interface Serial0:23

 description Headquarters 324-1939 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1

!--- template to control all async interface configuration 

ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp

!--- use PPP encapsulation dialer in-band

 dialer-group 5
 async mode interactive
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls 

 no fair-queue
 no cdp enable
 ppp authentication chap callin

!--- CHAP authenticate for dialin users only 

 ppp multilink
 group-range 1 48

!--- assign modems 1-48 to the Group-Async 1 configuration template

 router eigrp 1
 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- define IP address pool range for dialin clients 

ip classless
no ip http server
!

access-list 105 permit ip any any
dialer-list 5 protocol ip list 105
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 autoselect during-login

!--- permits user login prompts after dialin 

 autoselect ppp

!--- automatically launch PPP on the line




 modem InOut

!--- modems can be used to dialin and dialout
!--- InOut may be replaced by Dialin 
!--- if NAS handles only incoming calls

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
 transport preferred none
 transport input telnet
 transport output telnet
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

bobslake-nas-01#

Configurando clientes de Windows 9x

O seguinte procedimento é uma visão rápida em configurar seus clientes de Windows 9x para o MPPP. Refira a site do microsoftleavingcisco.com se você tem a dificuldade.

A fim configurar clientes de Microsoft Windows 9x para o MPPP, certifique-se de você ter a versão 1.3 ou mais recente do Dial Up Networking instalada.

Vá à site do microsoftleavingcisco.com para mais informação e para transferir a versão a mais atrasada do Dial Up Networking (DUN).

  1. Conecte e configure cada modem separadamente.

    No Painel de Controle do Windows, use o utilitário “Adicionar Novo Hardware” para adicionar os modems ao cliente”. Se você tiver problemas para adicionar modems, entre em contato com o fornecedor do PC ou com a Microsoft para obter informações sobre os procedimentos de Troubleshooting. Verificar se cada modem está conectado corretamente e se é reconhecido pelo sistema operacional. Você pode querer usar um terminal emulator para verificar que seu modem funciona corretamente.

  2. Crie uma nova conexão dialup.

    No Windows, clique duas vezes no ícone "Meu Computador" e navegue até "Conexão Discada". Em seguida, clique duas vezes em “Criar uma nova conexão”. Siga as instruções para criar uma conexão dial up usando o modem principal. Os recursos multilink são configurados mais tarde. Teste a conexão discando para o seu provedor de serviços.

  3. Adicione recursos de multilink à conexão dial-up.

    Clique duas vezes no ícone "Meu computador" e navegue até "Rede dialup". Com o botão direito do mouse, clique no ícone da conexão que acabou de ser configurada. Selecione "Properties" (Propriedades) no menu exibido.

    Clique a aba do “Multilink”, dispositivos adicionais do “uso seleto,” e clique “adicionam” o botão. Selecione um modem adicional no menu suspenso e digite somente o número de telefone de sete dígitos do servidor de acesso ou aceite o número exibido. Não inclua o código de área ao configurar o dispositivo adicional, mesmo se for uma chamada de longa distância. A conexão utiliza automaticamente o código de área configurado para o primeiro modem. Clique em “OK" duas vezes para confluir a configuração.

    Aqui estão algumas capturas de tela de uma configuração multilink do Windows:

    /image/gif/paws/9553/win95_mppp_1.gif

    win95_mppp_2.gif

  4. Inicie a conexão do modem com o Servidor de acesso.

    Clique duas vezes no ícone de conexão de discagem recém-criado. Digite o nome de usuário e senha configurados no roteador, depois clique no botão "Conectar". O Dial Up Networking discará o número configurado para o modem principal especificado para a conexão. Quando a primeira conexão for estabelecida, a Rede dialup discará usando os modems adicionais especificados na lista Additional Devices.

    Quando todas as conexões forem estabelecidas, você poderá ver as informações de status do enlace clicando duas vezes no ícone “Communicating Computers” exibido na barra de tarefas, ou pode desfazer a conexão. Clique em "Details" para verificar se a conexão está utilizando vários dispositivos. Ao selecionar um dispositivo na caixa de lista, um botão Suspend (Suspender) ou Resume (Retomar) é exibido. Se aparecer o botão Suspend, o dispositivo agora está em uso e "em pacote" na conexão multilink. Clicar no botão "Suspend" desconectará aquela linha e a removerá das conexões agrupadas. Se o botão "Resume" aparecer, clique nela para discar essa conexão e adicione essa linha ao pacote. É possível suspender e reiniciar dinamicamente o multilink sem queda da conexão.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

  • show ppp multilink – Para exibir informações sobre conjuntos de multilink ativos. Este comando deve ser utilizado para verificar a conexão multilink.

  • show caller – Para exibir as informações sobre usuários individuais e recursos consumidos no NAS. Este comando exibe estatísticas de chamadas ativas para grandes conjuntos de conexões e exibe os tempos absoluto e ocioso para cada usuário.

  • show caller user - Para mostrar parâmetros de um determinado usuário, como a linha de TTY usada, interface assíncrona (prateleira/slot/porta), número do canal DSO, número do modem, endereço IP atribuído, parâmetros de pacote PPP e PPP, etc.

Para ajudar em verificar e em pesquisar defeitos a conexão MPPP, refira estas sugestões:

  • Assegure-se de que os prefixos, tais como a utilização de 9 antes de discar uma linha exterior, estejam configurados corretamente no PC cliente. Se isto não é configurado corretamente, você ouvirá um busy signal (sinal ocupado) assim que o número começar discar.

  • Crie clientes separados do DUN para cada modem e verifique que você tem a conectividade direta a seu provedor de serviços. Use cada modem separadamente antes de continuar com pesquisa de defeitos de sua conexão multilink.

  • Use um terminal emulator para conectar ao modem. Discar o número do NAS usando o comando atdt. Por exemplo, no HyperTerminal incorpore o atdt 55511111. Verifique que o modem disca corretamente e conecta ao NAS. Se o modem não conecta, pesquise defeitos seu modem. Veja a utilização básica na documentaçãoleavingcisco.com dos comandos modem na site do microsoft para obter mais informações sobre dos modens do cliente do Troubleshooting.

  • Se sua conexão principal conecta corretamente, mas a segunda conexão dialup dá um busy signal (sinal ocupado), verifique que o número de telefone para o modem adicional está configurado corretamente no DUN. Recorde, códigos de área não deve ser adicionado à configuração para dispositivos adicionais. Refira as etapas de configuração na seção configurando dos clientes de Windows 9x acima.

Exemplo de show e debug

Estão aqui alguns mostra e resultados do debug do AS5300. Partes da depuração foram removidas para dar rapidez. Preste atenção às seções em negrito e comentários fornecidos nas saídas.

Observe que o chamador está conectado em Async5 e em Async6 até depois da autenticação. Um endereço IP temporário é fornecido ao chamador do conjunto de endereços. O atendimento então é virtualizado ou amarrado a um conjunto virtual existente. Isso acontece porque o Access Server precisa saber quem é o chamador para determinar se eles pertencem a um pacote virtual estabelecido. Depois que o chamador é ligado ao conjunto, o endereço IP temporário é removido e o chamador usa o endereço IP do conjunto virtual.

bobslake-nas-01#
bobslake-nas-01#show ppp multilink 

Virtual-Access1, bundle name is charlie
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async5
    Async6


!--- Note that the bundle is using Async line 5 and 6 for multilink. 

bobslake-nas-01#show caller 
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        admin              Host connect  1w4d      16:50:19  
  tty 5        charlie             Async         00:04:34  00:01:54  
  tty 6        charlie             Async         00:02:00  00:00:57  
  vty 1        admin              VTY           00:13:43  00:00:00  
  As5          charlie             PPP           00:04:25  00:00:00  
  As6          charlie             PPP           00:01:53  00:00:00  
  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57  


!--- User charlie has two async lines, two tty, 
!--- and one virtual interface bundle.

bobslake-nas-01#show caller user charlie

  User: charlie, line tty 5, service Async

!--- shows hardware level settings for user charlie (first connection)

        Active time 00:04:43, Idle time 00:00:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 5, running PPP on As5

!--- user charlie is using tty 5

  DS0: (slot/unit/channel)=0/0/0  Line: Baud rate (TX/RX) is 115200/115200, 
no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line tty 6, service Async


!--- shows hardware level settings for user charlie (second connection)

        Active time 00:02:09, Idle time 00:01:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 6, running PPP on As6

!--- user charlie is using tty 6

  DS0: (slot/unit/channel)=0/0/1
  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line As5, service PPP

!--- PPP setting for user charlie (first connection).

        Active time 00:04:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async5
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 54 packets input, 4110 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          73 packets output, 4150 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

  User: charlie, line As6, service PPP

!--- PPP setting for user charlie (second connection).

        Active time 00:02:02, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is Open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async6
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 6 packets input, 462 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          20 packets output, 1129 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

    
User: charlie, line Vi1, service PPP Bundle


!--- Bundle information for user charlie

        Active time 00:04:34, Idle time 00:00:06
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, IPCP
  IP: Local 172.21.104.254, remote 172.21.104.2

!--- Remote IP address is obtained from IP pool.

  Counts: 50 packets input, 4034 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          80 packets output, 8750 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate
Virtual Template debugging is on
bobslake-nas-01#debug ppp multilink events 
Multilink events debugging is on
bobslake-nas-01#debug ppp negotiation 
PPP protocol negotiation debugging is on
bobslake-nas-01#debug ppp authentication 
PPP authentication debugging is on
bobslake-nas-01#debug ppp error 
PPP protocol errors debugging is on
bobslake-nas-01#debug modem
Modem control/process activation debugging is on
bobslake-nas-01#show debug
General OS:
  Modem control/process activation debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on

bobslake-nas-01#
Jun 28 15:41:46.281 UTC: TTY5: DSR came up
Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

!--- Modem responds to first dialin connection.

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate
Jun 28 15:41:48.537 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

!--- IP address for first link obtained from address pool.
!--- Route will be removed when link is virtualized later. 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin
Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open
Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

!--- LCP negotiation begins.

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46
...
Jun 28 15:41:51.549 UTC: Unthrottle 5
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7
...
Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47
Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size 
!--- that the peer will reconstruct.
!--- Both sides must agree on the packet size (MRRU).

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)
Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47
Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size that 
!--- the peer will reconstruct.

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)Jun 28 15:41:54.541 UTC: 
As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46
...
Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7
...
Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

!--- LCP negotiation is complete.

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

!--- CHAP authentication begins.

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful.

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending
Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

!--- Call is virtualized after authentication.

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046
Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup
Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

!--- Cloning from Virtual-Template.

interface Virtual-Access1
default ip address
no ip address
encap ppp
description Template for Multilink Users
ip unnumbered Loopback0
no ip directed-broadcast
no logging event link-status
no snmp trap link-status
peer default ip address pool addr-pool
ppp authentication chap
ppp multilink
ip unnum loop 1
end
Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line
Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37
...
Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP
Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

!--- First link in multilink bundle for user charlie is up.

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

!--- Temporary route to first link removed since link is virtualized.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40
...
Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

!--- IP address for virtual bundle obtained from address pool.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22
...
Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15
Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)
...
Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd
Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent
Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10
Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34
...
Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16
...
Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3
Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10
Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 
(0x0306AC156802)

!--- IP address of virtual bundle was previously obtained from 
!--- address pool.

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open
Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

!--- Add route for virtual bundle to routing table.

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired
Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

!--- Modem comes up for multilink connection.

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

!--- Async 6 is used for second connection.

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)
Jun 28 15:44:20.385 UTC: TTY6: EXEC creation
...
Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate
Jun 28 15:44:20.529 UTC: TTY6: EXEC creation
...Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

!--- IP address for second link is obtained from the pool.
!--- Route will be removed when link is added to the MPPP bundle.

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin
Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

!--- LCP negotiation begins.

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen
Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46
...
Jun 28 15:44:23.525 UTC: Unthrottle 6
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7
Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent
Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47
...
Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47
...
Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46
...
Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7
Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

!--- LCP negotiation is complete.
!--- CHAP authentication begins.

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end
Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful. 

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending
Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

!--- Link is virtualized.

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

!--- Multilink connection is up.

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

!--- Use IP address previously assigned to the bundle 
!--- (in this case, 172.21.104.2).

bobslake-nas-01#

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug vtemplate - Informação de clonagem dos indicadores para uma interface de acesso virtual do tempo onde seja clonada de um molde virtual ao tempo venha para baixo.

  • debug ppp multilink events - Indica a informação sobre os eventos que afetam conjuntos multilink.

  • debug ppp negotiation – Exibe informações sobre o tráfego PPP e alterações enquanto negocia o Protocolo de controle de enlace (LCP), autenticação e Protocolo de controle de rede (NCP). Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP e, em seguida, autenticará e, finalmente, negociará o NCP.

  • debugar a autenticação de PPP - Mensagens de protocolo da autenticação de PPP dos indicadores, incluindo intercâmbios de pacotes do protocolo de autenticação de cumprimento do desafio (RACHADURA) e trocas do protocolo password authentication (PAP).

  • debug ppp error - Exibe erros do protocolo e estatísticas de erros associados à negociação e operação da conexão PPP

  • debugar o modem - Indica a atividade de linha de modem em um servidor de acesso.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 9553