Switches de LAN : 802.1Q

entroncamento do 802.1Q entre os Catalyst Switches que executam Cactos e software do sistema do Cisco IOS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (25 Junho 2009) | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece configurações de amostra para o entroncamento do IEEE 802.1Q entre os Catalyst Switches que executam o software do sistema do OS do catalizador (Cactos) e o Switches modular da camada 3 (L3) que executa o Switches do ½ do ¿  do sistema Software.ï do ½ do ¿  de Cisco IOSï que executa Cactos inclui o catalizador 4500/4000, 5500/5000 de, e o Switches do 6500/6000 Series. Os switches L3 modulares que executam o Cisco IOS Software incluem os switches das séries Catalyst 4500/4000 e Catalyst 6500/6000. As configurações de amostra usam um catalizador 4000 (Cactos) e um Catalyst 6500 (Cisco IOS Software), mas do Switches apenas mencionado poderia ter sido usado para conseguir os mesmos resultados.

O entroncamento é um modo de conduzir o tráfego de vários VLANs por um link ponto a ponto entre dois dispositivos. Dois modos em que o truncamento de Ethernet pode ser implementado são:

  • Inter-Switch Link Protocol (ISL) (Cisco proprietary protocol)

  • 802.1q (padrão IEEE)

Pré-requisitos

Requisitos

Para requisitos do sistema, as diretrizes e as limitações relativas ao 802.1Q e ao ISL em Catalyst Switches, referem: Requisitos de sistema para implementar o truncamento.

Componentes Utilizados

Para criar os exemplos neste documento, este Switches foi usado:

  • Catalyst 4000 Switch com versão 8.1.3 running do Cactos Software do Supervisor Engine II (WS-X4013)

  • Catalyst 6509 com Supervisor Engine 2/Multilayer Switch Feature Card 2 (MSFC2) executando Cisco IOS Software Release 12.1(20)E2 no Supervisor Engine e na MSFC2

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Material de Suporte

Este documento inclui somente os arquivos de configuração do Switches e a saída dos comandos relacionados à exibição de amostra. Para detalhes em como configurar um tronco 802.1Q entre Catalyst Switches, refira as páginas da suporte de produto de LAN.

No truncamento 802.1Q, todos os pacotes de VLAN são rotulados no enlace do tronco, exceto o VLAN nativo. Os pacotes de VLAN nativa são enviados sem etiqueta no enlace de tronco. Consequentemente, o VLAN nativo deve ser o mesmo em ambo o Switches configurado para o entroncamento. Esta maneira, você pode deduzir a que VLAN um quadro pertence quando você recebe um quadro sem a etiqueta. À revelia, o VLAN1 é o VLAN nativo em todo o Switches.

  • No CatOS, o VLAN nativo pode ser alterado com a emissão do comando set vlan vlan-id mod/port, em que mod/port é a porta do tronco.

  • No Cisco IOS Software, o VLAN nativo pode ser alterado por meio da emissão do comando switchport trunk native vlan vlan-id interface que está configurado na porta do tronco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

As configurações neste documento foram implementadas em um ambiente de laboratório isolado. Certifique-se de que você entende o impacto potencial de qualquer configuração ou comando em sua rede antes de utilizá-la. As configurações em todos os dispositivos foram limpas com os comandos clear config all e write erase para garantir uma configuração padrão.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).leavingcisco.com

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/8760/67-a.gif

Configurações

Este documento utiliza as seguintes configurações:

Nota: Os comentários e as explicações são exibidos em itálico azul.

Catalyst 4000 Switch
#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- In this example, the VLAN Trunk Protocol (VTP) domain name is the same
!--- on both sides. This is required for the autonegotiation of the trunk
!--- by the Dynamic Trunking Protocol (DTP).


set vtp mode client vlan

!--- In this example, the VTP mode is set to client.
!--- Set the VTP mode according to your network requirements.

!--- For more details, refer to
!--- Understanding and Configuring VLAN Trunk Protocol (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- This is the IP address used for management.

!--- Output suppressed.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- Ports 5/13-24 have been assigned to VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- The trunking mode is set to desirable mode, which means
!--- the port automatically tries to form a trunk with a
!--- neighboring port set to desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the Dynamic Trunking Protocol section of
!--- Best Practices for Catalyst 4500/4000, 5500/5000, and 6500/6000 
Series Switches Running CatOS Configuration and Management.

!--- Output suppressed.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- The macro command set port host 5/2-24 was used to do three things:
!--- disable trunking, disable port channeling, and enable spantree portfast.

!--- For details on using the set port host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.

!
#module 6 empty
end

Catalyst 6500 Switch
Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- This is the privileged mode password used in the example.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- The switchport command must be entered once,  
!--- without any keywords, to configure the interface as a Layer 2 port.
!--- The interface is now automatically configured with the default command
!--- switchport mode dynamic desirable.

!--- This means the interface is ready to autonegotiate trunking
!--- encapsulation and form a trunk link (using DTP) with a neighbor port
!--- in desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the "Dynamic Trunking Protocol" section of
!--- Best Practices for Catalyst 6500/6000 Series and Catalyst 4500/4000 
Series Switches Running Cisco IOS Software.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- The interface range fastethernet mod/beginport - endport 
!--- command is used to configure interfaces 3/2 - 24 at once.

!--- Next, the switchport command is issued (if this has not been done already).


switchport mode access
 spanning-tree portfast

!--- Next, issue the macro command switchport host 3/2 - 24 to automatically
!--- configure these ports as access ports and to enable spantree portfast.

!--- For details on using the switchport host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- Interfaces 3/13 - 24 are placed in VLAN 2
!--- using the switchport access vlan 2 command.


 switchport mode access
 spanning-tree portfast


!--- Output suppressed.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- Output suppressed.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- This is the IP address used for management.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- This is the Telnet password used in the example.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

comandos show

Os determinados comandos de exibição são apoiados pela ferramentaleavingcisco.com do Output Interpreter (clientes registrados somente), que permite que você ver uma análise do emissor de comando de execução.

Nos Catalyst Switches que executam Cactos, use estes comandos:

  • show port capabilities module/port

  • show port module/port

  • show trunk module/port

  • show vtp domain

Nos Catalyst 6000 Switch que executam o Cisco IOS Software, use os comandos seguintes:

  • mostre o tronco da /porta do módulo do tipo de interface das relações

  • show vlan

Exemplo de saída do comando show

Catalyst 4000 Switch

O comando show port capabilities module/port é usado para verificar se a porta é capaz de fazer truncamento.

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

O comando show port module/port exibe o status de uma porta específica e se ela está executando entroncamento.

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

O comando show trunk é utilizado para verificar o status do truncamento e a configuração.

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

O comando show vtp domain é usado para verificar informações de VTP.

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Catalyst 6500 Switch

O comando show interfaces interface-type module/port trunk diz se a porta está fazendo truncagem.

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

O comando show vlan dão a informação sobre os VLAN e as portas que pertencem a um VLAN particular.

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- Output suppressed.
    
cat6500#

Nota: Somente são exibidas as portas configuradas como portas sem tronco da camada 2.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 8760