Switches de LAN : Inter-Switch Link (ISL)

Configurando o entroncamento ISL entre os Catalyst Switches que executam Cactos e software do sistema do Cisco IOS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece configurações de amostra para o entroncamento do Inter-Switch Link (ISL) entre um Cisco Catalyst 5000 Switch que execute o OS do catalizador (Cactos) e um Catalyst 6500 Switch que execute o software do sistema do ½ do ¿  de Cisco IOSïÂ. Você pode usar qualquer um desses switches deste cenário para alcançar os mesmos resultados:

  • Todo o catalizador 4500/4000, 5500/5000, ou 6500/6000 Series comuta que corridas Cactos

  • Qualquer Catalyst 4500/4000 ou Catalyst 6500/6000 Series comuta que software do sistema do Cisco IOS das corridas

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalyst 5000 Switch que executa o software de Cactos 6.1(1)

  • Catalyst 6509 Switch que executa o Cisco IOS Software Release 12.1(4)E1

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Para detalhes sobre o ambiente de laboratório, veja a seção do diagrama da rede deste documento. Assegure-se de que você compreenda o impacto potencial de toda a configuração ou comando em sua rede antes que você a use. As configurações em todos os dispositivos foram canceladas com os comandos clear config all e write erase a fim assegurar uma configuração padrão.

Material de Suporte

O entroncamento é uma maneira de levar o tráfego de diversos VLAN sobre um link de ponto a ponto entre dois dispositivos. Duas maneiras em que você pode executar o entroncamento de Ethernet são:

  • ISL (um protocolo de proprietário de Cisco)

  • IEEE 802.1Q (um padrão de IEEE)

Este documento inclui somente os arquivos de configuração do Switches e a saída dos comandos relacionados à exibição de amostra. Para detalhes em como configurar um tronco de ISL entre Catalyst Switches, refira estes documentos:

Notas importantes

  • O Switches do 4500/4000 Series do catalizador (que incluem o Catalyst 2948G e o Catalyst 2980G) esse entroncamento do 802.1Q do apoio de Cactos da corrida somente. Este Switches não apoia o entroncamento ISL.

  • Os Catalyst 4000 Switch com um Supervisor Engine II+ ou Cisco IOS Software à revelia mais tarde executado. Este Switches apoia o ISL e os modos de entroncamento do 802.1Q em todas as relações exceto em obstruir portas de gigabit nos módulos WS-X4418-GB e S-X4412-2GB-T. Nesses casos, o Switches apoia somente o entroncamento do 802.1Q. As portas 3 a 18 estão obstruindo portas de gigabit no módulo WS-X4418-GB. As portas 1 a 12 estão obstruindo portas de gigabit no módulo WS-X4412-2GB-T. O termo “porta de bloqueio” significa que a conexão de porta ao backplane é oversubscribed.

  • Toda a porta Ethernet em um Catalyst 6500/6000 series switch apoia o 802.1Q e o encapsulamento de ISL.

  • Baseado no módulo, o catalizador 5000 portas capazes de tronco suportam encapsulamento ISL somente ou apoia o ISL e o 802.1Q. A melhor maneira de determinar os tipos de encapsulamento suportados é usar o comando show port capabilities. O comando output explicitamente indica a capacidade de entroncamento, porque este exemplo mostra:

    cat5000> show port capabilities 3
    Model                    WS-X5225R
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q, ISL
    
    !--- This particular port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(none)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  no
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • Seja certo que os modos de entroncamento combinam através do enlace de tronco. Se você configura um lado do link como um tronco de ISL, você deve configurar o outro lado do link como o ISL. Similarmente, se você configura um lado do link como um 802.1Q, você deve configurar o outro lado do link como o 802.1Q.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/8759/66a.gif

Configurações

Este documento utiliza as seguintes configurações:

Nota: Este documento indica comentários e explicações nos itálico azul dentro das configurações.

Catalyst 5000 Switch
#version 6.1(1)
!
set option fddi-user-pri enabled
set password $2$h/BN$i3S54iNvIXknFelh6gOve0
set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
!
#errordetection
set errordetection portcounter enable
!
#system
set system name  cat5000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- In the example, the VLAN Trunk Protocol (VTP) mode is set to be transparent.
!--- Use your network as a basis to set the VTP mode.

set vtp mode transparent

!--- For details on VTP, refer to Configuring VTP.


set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 2
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip

!--- This is the IP address that is used for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
 
!
#set boot command
set boot config-register 0x10f
set boot system flash bootflash:cat5000-sup3.6-1-1.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 empty
!
#module 3 : 9-port Gigabit Ethernet
!
#module 4 : 24-port 10/100BaseTX Ethernet
!
#module 5 : 24-port 10/100BaseTX Ethernet

!--- Ports 5/13–24 have been assigned to VLAN 2.

set vlan 2 5/13-24


!--- The ISL trunking mode is set to "on".
!--- Use your network and requirements as a basis to set the trunking mode.

set trunk 5/1 on isl 1-1005

!--- For details on different trunking modes, refer to 
!--- Configuring VLAN Trunks on Fast Ethernet and Gigabit Ethernet Ports.


!--- PortFast has been enabled on the ports that are connected to the workstations.

set spantree portfast 5/2-24 enable

!--- For details on why to enable PortFast, refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.

end

Catalyst 6500 Switch
Current configuration : 4207 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6000
!
boot buffersize 126968
boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
no logging console

!--- The example uses the privileged mode password.

enable password mysecret
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
no ip domain-lookup
!
ip cef
cns event-service server
!
!
!
interface gigabitethernet1/1
 no ip address
 shutdown
!
interface gigabitethernet1/2
 no ip address
 shutdown
!
interface fastethernet9/1
 no ip address


!--- Issue the switchport command once, without any keywords, 
!--- in order to configure the interface as a Layer 2 (L2) port for the Catalyst 6500.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 6500).
!--- On a Catalyst 4000 switch that runs Cisco IOS Software, all ports are 
!--- L2 ports by default. If there is no change to the default configuration, 
!--- you do not need to issue the switchport command.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 4000).

 switchport

!--- Configure trunk encapsulation as ISL.

 switchport trunk encapsulation isl


!--- Enable trunking on the interface.

 switchport mode trunk
!

!--- Interfaces Fast Ethernet 9/2 through 9/24 are configured to be in access mode.
!--- For details, refer to the "Layer 2 Interface Modes" section of
!--- Configuring Layer 2 Ethernet Interfaces.

interface fastethernet9/2
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/11
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/12
 no ip address
 switchport
 switchport mode access
!

!--- Interfaces Fast Ethernet 9/13 through 9/24 are placed in VLAN 2.

interface fastethernet9/13
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/14
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/23
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/24
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/25
 no ip address
 shutdown
!

!--- Output suppressed.

!
interface fastethernet9/48
 no ip address
 shutdown
!
interface vlan1

!--- This is the IP address that is used for management.

 ip address 10.10.10.3 255.255.255.0
!
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4

!--- This example uses the Telnet password.

 password mysecret
login
!
end

Nota: Se você atribui uma relação a um VLAN que não existisse, a relação fechou até que você crie o VLAN na base de dados de VLAN. Para obter mais detalhes, consulte a seção Criando ou Modificando um VLAN Ethernet de VLANs de Configuração.

Verificar

comandos show

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Catalyst 5000 ou Catalyst 6000 switches que executam Cactos

  • /porta do módulo das capacidades do show port — Use este comando verificar se a porta é capaz do entroncamento.

    cat5000> (enable) show port capabilities 5/1
    Model                    WS-X5234
    Port                     5/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  5/1-2,5/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • /porta do módulo do show port — Este comando mostra o estado de uma porta particular e se é entroncamento.

    cat5000> (enable) show port 5/1
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     5/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     5/1  disabled  shutdown             0        0        1 disabled      66
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     5/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • mostre a /porta do módulo de tronco — Use este comando verificar o status de entroncamento e a configuração.

    cat5000> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     5/1      on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     5/1      1-1005
     
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     5/1      1-2
     
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     5/1      1-2
    
  • mostre o domínio do vtp — Use este comando verificar a informação de VTP.

    cat5000> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.2      disabled disabled 2-1000

Switches do Catalyst 6500/6000 ou Switches do catalizador 4500/4000 que executa o Cisco IOS Software

  • mostre o tronco da /porta do módulo do interface_type das relações — Este comando diz-lhe se a porta é entroncamento.

    cat6000#show interfaces fastethernet 9/1 trunk
     
    Port      Mode         Encapsulation  Status        Native vlan
    Fa9/1     on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    Fa9/1     1-1005
     
    Port      Vlans allowed and active in management domain
    Fa9/1     1-2,1002-1005
     
    Port      Vlans in spanning tree forwarding state and not pruned
    Fa9/1     1-2,1002-1005
  • mostra vlan — Este comando fornecem a informação sobre os VLAN e as portas que pertencem a um VLAN particular.

    cat6000#show vlan
     
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                    Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                    Fa9/10, Fa9/11, Fa9/12
    2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                    Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                    Fa9/21, Fa9/22, Fa9/23, Fa9/24
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    !--- Output suppressed.
    
    

Nota: Somente aquelas portas que são configuradas enquanto as portas do sem tronco L2 são indicadas. Para detalhes, refira as interfaces Ethernet configurando para a seção de switching de Camada 2 de configurar interfaces Ethernet da camada 2.

Troubleshooting

Use esta seção para resolver problemas de configuração.

O interruptor não aceita uma mudança do VLAN nativo em uma porta de tronco porque a porta é uma porta Non-802.1Q

Esta edição ocorre porque a porta de tronco não apoia o encapsulamento do 802.1Q. Um VLAN nativo exige o apoio do 802.1Q em uma porta. Se a porta não tem o apoio do 802.1Q, o interruptor não permite uma mudança do VLAN nativo.

o apoio do 802.1Q para o entroncamento é um fator do dependente de hardware. Emita o comando show port capabilities a fim verificar para ver se há o apoio de 802.1Q. A opção de encapsulamento na saída dos estados de comando show port capabilities o apoio do 802.1Q para o entroncamento.


Informações Relacionadas


Document ID: 8759