IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

Redistribuição de Routing Protocols

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (24 Maio 2008) | Inglês (22 Agosto 2015) | Feedback


Índice

RIP

Introdução

O uso de um protocolo de roteamento anunciar as rotas que são aprendidas por alguns outros meios, como por um outro protocolo de roteamento, rotas estáticas, ou diretamente rotas conectadas, é chamado redistribução. Quando executar um protocolo de roteamento único durante todo seu inter-rede IP inteiro for desejável, o roteamento multiprotocolo é comum para um número de razões, tais como fusões de empresas, departamentos múltiplos controlados por administradores de rede múltipla, e ambientes do multi-vendedor. A execução de protocolos de roteamento diferentes é frequentemente pare de um projeto de rede. Em qualquer caso, ter um ambiente de vários protocolos torna a redistribuição uma necessidade.

As diferenças nas características dos Routing Protocols, como métricas, distância administrativa, recursos com e sem classe, podem afetar a redistribuição. É necessário levar essas diferenças em consideração para que a redistribuição seja bem sucedida.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.2(10b) do ½ do ¿  de Cisco IOSïÂ

  • Cisco 2500 Series Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Métrica

Quando você redistribuir um protocolo para outro, lembre-se de que as métricas de cada protocolo têm um papel importante na redistribuição. Cada protocolo usa métricas diferentes. Por exemplo, a métrica do Routing Information Protocol (RIP) é baseada no contagem de saltos, mas o Interior Gateway Routing Protocol (IGRP) e o Enhanced Interior Gateway Routing Protocol (EIGRP) usam um métrica composta baseado na largura de banda, no atraso, na confiança, na carga, e na unidade de transmissão máxima (MTU), onde largura de banda e o atraso é os únicos parâmetros usados à revelia. Quando as rotas forem redistribuídas, é necessário definir uma métrica que seja compreensível para o protocolo de recebimento. Há dois métodos para definir a métrica na redistribuição de rotas.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-a.gif

Você só pode definir a métrica para essa redistribuição específica:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

Ou você pode usar a mesma métrica que um padrão para toda a redistribução (usar o comando default-metric salvar o trabalho porque elimina a necessidade para definir a métrica separadamente para cada redistribução.):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Distância administrativa

Se um roteador está executando mais de um protocolo de roteamento e aprende uma rota ao mesmo destino usando ambos os protocolos de roteamento, a seguir que a rota deve ser selecionada como a melhor ruta? Cada protocolo usa seu próprio tipo de métrica para determinar a melhor rota. Comparar rotas com os tipos de métrica diferente não pode ser feita. As distâncias administrativas resolvem este problema. As distâncias administrativas são atribuídas a origens de rota para que a rota da origem preferencial seja escolhida como o melhor caminho. Consulte Seleção de Rota nos Cisco Routers para obter mais informações sobre distâncias administrativas e seleção de rota.

As distâncias administrativas ajudam com a seleção de rotas entre protocolos de roteamento diferentes, contudo podem causar problemas de redistribuição. Estes problemas podem ser sob a forma dos loop de roteamento, dos problemas de convergência, ou do roteamento incapaz. Veja abaixo para uma topologia e uma descrição de um problema possível.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

Na topologia acima, se R1 estiver executando RIP, e R2 e R5 estiverem executando RIP e IGRP e redistribuindo RIP para IGRP, significa que existe um problema potencial. Por exemplo, R2 e R5 estão ambos detectando a rede 192.168.1.0 a partir de R1 usando RIP. Este conhecimento é redistribuído no IGRP. O R2 aprende sobre a rede 192.168.1.0 até R3 e R5 aprende sobre ela a partir de R4 usando IGRP. O IGRP tem uma distância administrativa mais baixa do que o RASGO (100 contra 120); consequentemente, a rota IGRP é o que é usado na tabela de roteamento. Agora há um circuito de roteamento em potencial. Mesmo se o horizonte rachado, ou todos os outros recursos significaram ajudar a impedir loop de roteamento entram o jogo, lá são ainda um problema de convergência.

Se R2 e R5 também estiverem redistribuindo o IGRP para o RIP (também conhecida como redistribuição mútua) e a rede, 192.168.1.0, não estiver diretamente conectada a R1 (R1 está aprendendo com outro roteador a fazer upstream), haverá um problema potencial pois R1 aprenderá a rede com R2 ou R5 com uma métrica melhor do que a da fonte original.

Nota: Os mecânicos da redistribuição de rota são proprietários em roteadores Cisco. As regras para a redistribução em um roteador Cisco ditam que a rota redistribuída esta presente na tabela de roteamento. Não é suficiente que a rota esta presente na topologia de roteamento ou no base de dados. As rotas com uma distância administrativa mais baixa (AD) são instaladas sempre na tabela de roteamento. Por exemplo, se uma rota estática é redistribuída no IGRP no R5, e então o IGRP redistribuído subseqüentemente no RASGO no mesmo roteador (R5), a rota estática não é redistribuído no RASGO porque nunca obteve participado na tabela de roteamento IGRP. Isto é devido ao fato de que as rotas estáticas têm um AD de 1 e rotas IGRP tem um AD de 100 e a rota estática está instalada na tabela de roteamento. A fim redistribuir a rota estática no IGRP no R5, você precisa de usar o comando redistribute static sob o comando router rip.

O comportamento padrão para o RASGO, o IGRP e o EIGRP é anunciar diretamente rotas conectadas quando uma instrução de rede sob o protocolo de roteamento inclui a sub-rede da interface conectada. Há dois métodos para obter uma rota conectada:

  • Uma relação é configurada com um endereço IP de Um ou Mais Servidores Cisco ICM NT e a máscara, esta sub-rede correspondente é considerada uma rota conectada.

  • Uma rota estática é configurada com somente uma interface enviada, e não um salto seguinte IP, isto é considerado igualmente uma rota conectada.

Router#conf t
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end

   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Um comando network configurado sob o EIGRP, o RASGO ou o IGRP que incluem (ou as “tampas”) qualquer um destes tipos de rotas conectadas inclui essa sub-rede de anúncio.

Por exemplo, se uma relação tem o endereço 10.0.23.1 e a máscara 255.255.255.0, a sub-rede 10.0.23.0/24 é uma rota conectada e estará anunciada por estes protocolos de roteamento quando uma instrução de rede é configurada como segue:

router rip | igrp # | eigrp #
   network 10.0.0.0

Esta rota estática, 10.0.77.0/24, é anunciada igualmente por estes protocolos de roteamento, porque é uma rota conectada e “é coberto” pela instrução de rede.

Consulte a seção Evitando problemas causados por redistribuição deste documento para obter dicas sobre como evitar este problema.

Sintaxe e exemplos de configuração de redistribuição

IGRP e EIGRP

Esta saída mostra um roteador IGRP/EIGRP que redistribui a estática, o Open Shortest Path First (OSPF), o RASGO, e as rotas do Intermediate System-to-Intermediate System (IS-IS).

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

O IGRP e o EIGRP precisam o medidor cinco ao redistribuir outros protocolos: largura de banda, atraso, confiança, carga, e MTU, respectivamente. Segue um exemplo de métrica de IGRP:

Métrico Valor
largura de banda Nas unidades de kilobits por segundo; 10000 para Ethernet
atraso Nas unidades de décimos de microssegundos; para Ethernet ele microssegundos is100 x 10 = 1 Senhora
confiança 255 para 100 por cento de confiabilidade
carga Carga efetiva no link expressa com um número de 0 a 255 (255 é 100 por cento de carga)
MTU Mínimo MTU do trajeto; geralmente iguais que para a interface Ethernet, que é 1500 bytes

Processos IGRP e EIGRP múltiplos podem ser executados no mesmo roteador, com redistribuição entre eles. Por exemplo, IGRP1 e IGRP2 podem ser executados no mesmo roteador. Contudo, executar dois processos do mesmo protocolo no mesmo roteador é raramente necessário, e pode consumir a memória e o CPU do roteador.

A redistribução do IGRP/EIGRP em um outro processo IGRP/EIGRP não exige nenhuma conversão métrica, tão não há nenhuma necessidade de definir o medidor ou usar o comando default-metric durante a redistribução.

Uma rota estática redistribuída toma a precedência sobre a rota sumária porque a rota estática tem uma distância administrativa de 1 visto que a rota sumária de Eigrp tem uma distância administrativa de 5. Isto acontece quando uma rota estática está redistribuída com o uso de redistribui a estática sob o processo de Eigrp e o processo de Eigrp tem uma rota padrão.

OSPF

Esta saída mostra um OSPF Router que redistribui a estática, as rotas do RASGO, IGRP, EIGRP, e IS-IS.

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

A métrica OSPF é um valor do custo baseado na largura de banda 108/ do link nos bit/segundo. Por exemplo, os custos de OSPF dos Ethernet são 10: 108/107 = 10

Nota: Se uma métrica não for especificada, o OSPF colocará o valor padrão 20 ao redistribuir as rotas de todos os protocolos, exceto as rotas do Protocolo de Gateway de Borda (BGP), que recebem uma métrica 1.

Quando há uma rede principal que seja sub-rede, você precisa de usar a sub-rede de palavra-chave para redistribuir protocolos no OSPF. Sem essa palavra-chave, o OSPF apenas redistribui grandes redes que não são sub-redes.

É possível executar mais de um processo de OSPF no mesmo roteador. entretanto, a execução de mais um processo do mesmo protocolo é raramente necessária e consome memória e CPU do roteador.

Você não precisa definir métrica nem usar o comando default-metric ao redistribuir um processo de OSPF para outro.

RIP

Nota: Os princípios neste documento aplicam-se às versões I e II do RIP.

Esta saída mostra um roteador do RASGO que redistribui a estática, as rotas IGRP, EIGRP, OSPF, e IS-IS.

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

A métrica do RASGO é composta do contagem de saltos, e a métrica válida máxima é 15. Qualquer coisa acima de 15 é considerado infinito; você pode usar 16 para descrever uma métrica infinita em RIP. Ao redistribuir um protocolo no RASGO, Cisco recomenda que você usa uma métrica baixa, tal como 1. Um métrico elevado, tal como o 10, limites RASGA mesmo mais adicional. Se você define uma métrica do 10 para rotas redistribuída, estas rotas podem somente ser anunciadas ao Roteadores até os saltos 5 afastado, que no ponto a métrica (contagem de saltos) excede 15. Ao definir uma métrica de 1, você habilita uma rota para realizar o número máximo de saltos em um domínio RIP. Mas, fazer isto aumenta a possibilidade de loop de roteamento se há uns pontos múltiplos da redistribução e um roteador aprende sobre a rede com uma métrica melhor do ponto da redistribução do que da fonte original, como explicado na seção da distância administrativa deste documento. Consequentemente, você tem que certificar-se de que a métrica não é nenhuma demasiado alta, impedindo que esteja anunciado a todo o Roteadores, ou demasiado baixo, conduzindo aos loop de roteamento quando há múltiplo a redistribução aponta.

Redistribuindo rotas estáticas exceto o Gateway of Last Resort no RASGO usando o mapa de rota

Esta configuração é um exemplo de redistribuir rotas estáticas exceto o gateway do último recurso do gateway no RASGO através do routemap.

Configuração inicial para este exemplo:

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

Termine estas etapas a fim configurar isto:

  1. Crie uma lista de acesso a fim combinar todas as redes que precise de ser redistribuída

    Router#show access-lists 10
    
    Standard IP access list 10
    
        10 permit 10.32.42.211
    
        20 permit 10.98.0.0, wildcard bits 0.0.0.255
    
        30 permit 10.99.0.0, wildcard bits 0.0.0.255
    
        40 permit 67.129.103.128, wildcard bits 0.0.0.15
    
        50 permit 156.55.231.0, wildcard bits 0.0.0.255
    
        60 permit 172.16.28.0, wildcard bits 0.0.3.255
    
        70 permit 192.168.248.0, wildcard bits 0.0.0.255
    
        80 permit 199.43.0.0, wildcard bits 0.0.0.255
    
        90 permit 204.103.0.0, wildcard bits 0.0.0.255
  2. Chame esta lista de acesso em um mapa de rotas.

    Route-map TEST
    
     Match ip address 10
  3. Redistribua no RASGO usando o mapa de rotas em e remova a informação do padrão originam o comando do processo do rasgo.

    Router RIP
    
    version 2
    
    network 10.0.0.0
    
    redistribute static route-map TEST
    
    no auto-summary

IS-IS

Esta saída mostra um roteador IS-IS que redistribui a estática, o RASGO, o IGRP, o EIGRP, e as rotas de OSPF.

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

A métrica IS-IS deve estar entre 1 e 63. Não há nenhuma opção do Default-metric no IS-IS — você deve definir uma métrica para cada protocolo, segundo as indicações do exemplo acima. Se nenhuma métrica é especificada para as rotas que estão sendo redistribuídas no IS-IS, um valor de métrica de 0 está usado à revelia.

Roteadores conectados

Redistribuir diretamente redes conectadas em protocolos de roteamento não é uma prática comum e não é mostrada em alguns dos exemplos acima por este motivo. Contudo, é importante notar direta e indiretamente que pode ser feita, ambos. A fim redistribuir diretamente rotas conectadas, use o comando configuration do roteador conectado da redistribuição. Você deve igualmente definir uma métrica neste caso. Você pode igualmente indiretamente redistribuir rotas conectadas em protocolos de roteamento segundo as indicações deste exemplo.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-cnctd.gif

Nesse exemplo, o Roteador B tem duas interfaces Fast Ethernet. O FastEthernet0/0 está na rede 10.1.1.0/24 e o FastEthernet0/1 está na rede 20.1.1.0/24. O roteador B está executando o EIGRP com roteador A, e o OSPF com roteador C. Roteador B está redistribuindo mutuamente entre o EIGRP e os processos de OSPF. Essas são informações de configuração pertinentes do roteador B:

roteador B
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Se você observar a tabela de roteamento para o Roteador B, verá o seguinte:

routerB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

Na tabela de configuração e roteamento, acima, há três aspectos a serem observados:

  • As redes em questão estão na tabela de roteamento do roteador B como redes conectadas diretamente.

  • A rede 10.1.1.0/24 é parte do processo EIGRP e a rede 20.1.1.0/24 é parte do processo OSPF.

  • O roteador B está redistribuindo mutuamente entre o EIGRP e o OSPF.

As tabelas de roteamento dos Roteadores A e C são fornecidas a seguir.

routerA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

O roteador A aprendeu sobre a rede 20.1.1.0/24 através do EIGRP, que é mostrado como uma rota externa, porque foi redistribuído do OSPF no EIGRP. O C do roteador aprendeu sobre a rede 10.1.1.0/24 através do OSPF como uma rota externa, porque foi redistribuída do EIGRP no OSPF. Embora o roteador B não esteja redistribuindo redes conectadas, anuncia a rede 10.1.1.0/24, que é parte do processo de EIGRP redistribuído no OSPF. De forma semelhante, o Roteador B anuncia a rede 20.1.1.0/24, que faz parte do processo OSPF redistribuído em EIGRP.

Refira a redistribuição de redes conectadas no OSPF para obter mais informações sobre das rotas conectadas que estão sendo redistribuídas no OSPF.

Nota: À revelia, somente a informação EBGP-instruída é candidato a ser redistribuído no IGP quando o comando bgp do redistibute é emitido. As rotas iBGP não estão redistribuídas no IGP até que o comando bgp redistribute-internal esteja configurado sob o comando router bgp. Mas as precauções devem ser ordem recolhida para evitar laços dentro do sistema autônomo quando as rotas iBGP redistirbuted no IGP.

Evitando problemas causados por redistribuição

Na seção sobre distância administrativa, você viu como a redistribuição pode potencialmente causar problemas, como roteamento abaixo do ideal, loops de roteamento ou convergência lenta. Evitar estes tipos de problema é realmente bastante simples — nunca anuncie a informação recebida originalmente do processo de roteamento X de novo no processo de roteamento X.

Exemplo 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

Na topologia antiga, o R2 e o R5 estão fazendo a redistribuição mútua. O RASGO está sendo redistribuído no IGRP e no IGRP está redistribuindo no RASGO, porque esta configuração mostra.

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

Com a configuração precedente você tem o potencial para o algum o os problemas descritos previamente. A fim evitá-los, você pode filtrar atualizações de roteamento como segue:

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

As lista da distribuição adicionaram às configurações, como mostrado acima, filtram todas as atualizações de IGRP que entrarem a relação da série 1 do Roteadores. Se as rotas nas atualizações são permitidas pela lista de acessos 1, o roteador aceita-as na atualização; caso contrário isso não acontece. Neste exemplo, o Roteadores está sendo dito que não deve aprender a rede 192.168.1.0 através das atualizações de IGRP que recebe em sua relação da série 1. portanto, o único conhecimento que estes roteadores possuem para a rede 192.168.1.0 é por meio do RIP a partir de R1.

Igualmente mantenha na mente que neste caso não é necessário usar a mesma estratégia de filtro para o processo do RASGO porque o RASGO tem uma distância administrativa mais alta do que o IGRP. Se as rotas que originam no domínio de IGRP foram alimentadas de volta ao R2 e ao R5 através do RASGO, as rotas IGRP ainda tomariam a precedência.

Exemplo 2

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-c.gif

Usando a topologia como acima, um outro método, que seja às vezes mais preferível, para evitar problemas de redistribuição pode ser demonstrado. Esse método usa mapas de rotas para configurar marcações para várias rotas. Os processos de roteamento podem então redistribuir baseado nas etiquetas. Note que a redistribução baseada em etiquetas não trabalha com versão RIP 1 ou IGRP.

Um dos problemas que você pode executar na topologia antiga é como segue:

R1 anuncia a rede 192.168.1.0 ao R2. Em seguida, o R2 redistribui para o EIGRP. O R5 conhece a rede via EIGRP e a redistribui para RIPv2. Segundo a métrica que o R5 ajusta para a rota do RIPv2, o R6 pôde preferir a rota menos desejável com o R5 em vez do r1 direto alcançar a rede. A configuração a seguir ajuda a prevenir isso, pela configuração de etiquetas e conseqüente redistribuição as utilizando como base.

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIP routes that are
 

!--- permitted by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and set the tags
 

!--- according to the eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag of "88"


!--- from being redistributed into EIGRP
  

!--- Notice the routes tagged with "88" should be the EIGRP
 

!--- routes that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag 


!--- on RIPv2 routes redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a
 

!--- tag of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2
 

!--- routes that are redistributed into EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP
 

!--- routes redistributed into RIPv2 to "88"

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIPv2 routes that are permitted 


!--- by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and sets the tags 


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag
 

!--- of "88" from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP routes
 

!--- that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag on rip routes 


!--- redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a tag 


!--- of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2 routes
 

!--- that are redistributed into EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP routes 


!--- redistributed into RIPv2 to "88"

Com a configuração acima executada, você pode olhar algumas rotas específicas na tabela de roteamento para ver que as etiquetas estiveram ajustadas. Abaixo da saída das mostras do comando show ip route para rotas do específico no R3 e no r1:

R3#show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1#show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

O EIGRP usa cinco variáveis diferentes para calcular a métrica. Contudo, as rotas redistribuída não têm estes parâmetros, que faz com que as rotas não sejam ajustadas uniformemente. O melhor prática é ajustar um Default-metric ao redistribuir rotas. Ajustando a métrica do padrão, o desempenho do EIGRP pode ser melhorado. Para o EIGRP, os valores padrão são incorporados com este comando:

Router(config-router)#default-metric 10000 100 255 100 1500

Exemplo 3

A redistribuição também pode ocorrer entre diferentes processos do mesmo Routing Protocol. A seguinte configuração é um exemplo de uma política de redistribuição usada redistribuindo o processo de EIGRP dois que é executado no mesmo roteador ou em roteadores múltiplos:

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 5 into EIGRP 3, setting the tags 


!--- according to the route map "to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 3 into EIGRP 5


!--- Routes with tag 33 will not be redistributed
 

!--- due to route map "to_eigrp_5"
!--- Though the default-metric command is not required
!--- when redistributing between different EIGRP processes,
!--- you can use it optionally as shown above to advertise 
!--- the routes with specific values for calculating the metric.


route-map to_eigrp_3 deny 10
match tag 55

!--- Route-map statement used to deny any routes that have a tag
 

!--- of "55" from being redistributed into EIGRP 3


!--- Notice the routes tagged with "55" should be the EIGRP 3 routes
 

!--- that are redistributed into EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 5 to EIGRP 3 to "33"


route-map to_eigrp_5 deny 10
 match tag 33

!--- Route-map statement used to deny any routes that have a tag 


!--- of "33" from being redistributed into EIGRP 5


!--- Notice the routes tagged with "33" should be the EIGRP 5 routes
 

!--- that are redistributed into EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 3 to EIGRP 5 to "55"

Estes são apenas alguns exemplos de estratégias de filtragem usados para a intenção deste documento. Contudo, pôde haver outras estratégias válidas que você pode se usar. Refira a seção na informação de roteamento de filtração em configurar características independentes do protocolo de IP Routing para mais informação.

Exemplo 4

Por exemplo, você tem dois Roteadores, um é um protocolo BGP running do roteador de extremidade alta, e outro é protocolo baixo da gama do RASGO do corredor do roteador. Quando você redistribui rotas de BGP no RASGO, é possível que você vê alguns pacotes se tornar perdidos.

A redistribução do BGP no protocolo do RASGO não é recomendada geralmente e os protocolos como o iBGP, o OSPF, e o EIGRP são escaláveis e têm as opções largas disponíveis.

Caso que você encontra esta encenação, que é a redistribução entre o BGP A SE RASGAR, e perca algum o mais packest, ele possível que você tem que configurar este comando no processo do RASGO:

Rasgo de Router(Config)#router

Roteador (Configuração-roteador) # entrada-fila 1024

Nota: Considere o uso do comando input-queue se você tem um roteador de produto avançado que envie na alta velocidade a um roteador de baixa velocidade que não possa poder receber na alta velocidade. A configuração deste comando help impede a perda de informação da tabela de roteamento.

Exemplo 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-d.gif

Este exemplo ilustra a redistribuição da rota estática no protocolo de RIP Routing. Conforme a topologia, nós temos três Roteadores (r1, R2, e R3). O r1 e o R2 têm o RASGO configurado no Ethernet0/0 da interface rápida. O r1 tem uma rota estática para alcançar o Lo 0 relações (endereço IP de Um ou Mais Servidores Cisco ICM NT 3.3.3.3/32) do roteador R3. Esta rota estática é redistribuída no protocolo de RIP Routing. O roteador R3 é configurado com um FastEthernet0/0 de 0.0.0.0 0.0.0.0 da rota da rota padrão R3# IP.

R1(config)# ip route 3.3.3.3 255.255.255.255 10.13.13.3
R1(config)# router rip
R1(config-router) redistribute static metric 10

No roteador R2, a rota 3.3.3.3 pode ser vista através do comando show ip route:

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0

Como redistribuir a única rota estática

A fim redistribuir a única rota estática, use o mapa de rotas para selecionar a rota estática que precisa de ser redistribuída.

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10
Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <map-name> metric <value>


Informações Relacionadas


Document ID: 8606