Roteadores : Roteadores Cisco 800 Series

Configurando o Cisco 827 Router como um PPPoE Cliente com NAT

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

No Software Release 12.1(3)XG de Cisco IOS�, uns recursos de cliente do PPP over Ethernet (PPPoE) foram introduzidos para o Cisco 827 Router. Esse recurso permite que a funcionalidade PPPoE seja movida para o roteador. Os PC múltiplos podem ser instalados atrás do Cisco 827. Antes que seu tráfego esteja enviado à sessão de PPPoE, pode ser cifrado, filtrado, e assim por diante. Também, o Network Address Translation (NAT) pode ser executado.

Este documento mostra um cliente PPPoE configurado na interface ATM (a interface DSL) do roteador Cisco 827. Essa configuração também pode ser usada em um roteador Cisco 1700 com WAN interface card (WIC) de Asymmetric Digital Subscriber Line (ADSL).

A configuração do NRP (node route processor) do Cisco 6400 também pode ser usada para outro roteador usado como um agregador e com uma interface ATM.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você é presentado com a informação usada para configurar as características descritas neste documento.

Nota: Para encontrar informações adicionais sobre os comandos usados neste documento, use a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/8514/827pppoe_client.gif

Configurações

Este documento utiliza as seguintes configurações:

O PPPoE é configurado no Cisco 827 Router com os comandos do Virtual Private Dial Network (VPDN). Certifique-se de você configurar primeiramente estes comandos.

Nota: Para obter informações sobre de como mudar o tamanho da unidade de transmissão máxima (MTU), refira pesquisando defeitos o tamanho do MTU na conectividade de discagem PPPoE.

Cisco 827 Router
! 
vpdn enable 
no vpdn logging

!--- This is the default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- This is the PPPoE client that requests to establish a session  
 !--- with the aggregation unit (6400 NRP). 
 
  protocol pppoe 
! 


!--- This is the Internal Ethernet network.
 
! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- The DSL interface.
 
! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 
!--- All defaults.

  


!--- PPPoE runs on top of AAL5SNAP. However, the 
!--- encap aal5snap command is not used.
  
! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that must be changed 
  !--- in order to match the value used by the ISP. 

 ! 



!--- The PPPoE client code ties into a dialer interface upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default -- 1492 + PPPoE headers = 1500

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.
  
 ppp authentication chap callin 
 ppp chap hostname <username> 
 ppp chap password <password> 
! 

!--- Note: The ISP  instructs you  about the 
!--- type of authentication to use. 
!--- In order to change from PPP CHAP to PPP PAP, replace
!--- ppp authentication chap callin 
!--- ppp chap hostname <username> 
!--- ppp chap password <password>   
!--- with ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>




!--- For NAT, overload on the Dialer1 interface 
!--- and add a default route out since dialer IP address can change. 
  
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400 NRP
*** local ppp user 

!--- Or,  use AAA.


username <username> password <password>



!--- Begin with the VPDN commands. 
!--- Notice that the PPPoE is bound here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE that begins  
!--- with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode.
 
  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.
  
! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- Needs the command on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface.
 
! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte Informações Importantes sobre Comandos de Depuração.

Debugar o PPPoE Client

A fim debugar o PPPoE Client no Cisco 827 Router ou no Cisco 6400 NRP, você deve considerar a pilha de protocolos. Você pode começar pesquisar defeitos na parte inferior.

1. Camada física DSL

Certifique-se que a linha é ascendente e treinada.

show interface atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:    Showtime (DMTDSL_SHOWTIME) 

2. Camada ATM

Se a interface ATM está acima, use o comando debug atm packets ver se qualquer coisa vem dentro do ISP.

Nota: Você não vê pacotes de saída com esse comando devido à maneira como os pacotes são processados.

Você precisa ver uma saída similar a esta, com o mesmo tipo, SAP, CTL e campos OUI, que mostram que o pacote ATM recebido é AAL5SNAP.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 
TYPE:0007 Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 
000E C021 09AB 000C 0235 
03:21:32: 279F 0000 0000 
03:21:32: 

3. Camada de Ethernet

Os frames da Ethernet completos estão nos pacotes AAL5SNAP. Não há comando de depuração de pacotes Ethernet. Contudo, você precisa de executar algum VPDN debuga a fim ver os quadros PPPoE.

Para a referência, um frame da Ethernet que seja um quadro PPPoE contém um de dois Ethertypes:

  • Ethertipo 0x8863 = pacote de controle de PPPoE (maneja a sessão de PPPoE)

  • Ethertipo 0x8864 = pacote de dados de PPPoE (contém pacotes PPP)

Uma nota importante é que há duas sessões em PPPoE. A sessão de PPPoE que é uma sessão do tipo VPDN L2TP e a sessão PPP. Consequentemente, a fim estabelecer o PPPoE, você tem uma fase de estabelecimento de sessão PPPoE e uma fase de estabelecimento da sessão de PPP.

A terminação geralmente envolve uma fase de terminação de PPP e fase de terminação de PPPoE.

A fase de estabelecimento de PPPoE consiste na identificação do PPPoE Client e do server (os endereços MAC), e na atribuição de um ID de sessão. Depois que isto está completo, o estabelecimento de PPP normal ocorre apenas como toda a outra conexão PPP.

A fim debugar, o uso VPDN PPPoE debuga para ajudá-lo a determinar se a fase de conexão PPPoE é bem sucedida.

#debug vpdn pppoe-events 

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in  this case encapsulated in ATM) 
!--- that requests  a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server 
!--- (very similar to a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply that accepts the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation and the establishment completes.

O estabelecimento de PPP começa como em todo o outro início de PPP. Depois que a sessão de PPPoE é estabelecida, use comandos show vpdn a fim obter o estado.

#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC 
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1

Você pode obter a informação de contagem de pacote de informação usando o comando show vpdn session all.

show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Outros comandos de debug:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

Camada PPP

Depois que a sessão de PPPoE foi estabelecida, o PPP debuga é o mesmo que para todo o outro estabelecimento de PPP.

Os mesmos comandos debug ppp negotiation e debug ppp authentication são utilizados. Esse é o exemplo de saída.

Nota: Nesta amostra, o hostname é "client1" e o nome do Cisco 6400 remoto NRP é “Nrp-b”.

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Debugar o servidor PPPoE

A fim debugar o Cisco 6400 (o servidor PPPoE), use o mesmo procedimento bottom-up usado para o Cisco 827 Router (cliente). A diferença está na camada física DSL, onde você precisa de verificar o DSL Access Multiplexer (DSLAM).

1. Camada física DSL

A fim verificar a camada física DSL, você precisa de ver as estatísticas de DSL no DSLAM. Para Cisco DSLAM, use o comando show dsl interface.

2. Camada ATM

No lado do Cisco 6400, você pode igualmente usar um comando debug atm packet e permitir o Cisco 6400 para uns Circuitos Virtuais Permanentes (PVC) específicos.

debug atm packet interface atm 0/0/0.182 vc 1/82

Você precisa ver uma saída similar a esta, com o mesmo tipo, SAP, CTL e campos OUI, que mostram que o pacote ATM recebido é AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Nota: Você não vê pacotes de saída com esse comando devido à maneira como os pacotes são processados.

3. Camada de Ethernet

Os mesmos comandos vpdn show e debugam usado no Cisco 827 Router podem ser usados no Cisco 6400 NRP para olhar o estabelecimento de PPPoE.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel
#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Outros comandos de debug:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

4. Camada PPP

Este é o resultado do debug PPP do Cisco 6400 NRP que corresponde ao mais adiantado debuga do Cisco 827 Router.

debug ppp negotiation and debug ppp authentication
4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, 
changed state to up 

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 8514