Banda larga a cabo : Cable Modem Termination Systems (CMTS)

Como transferir um arquivo de configuração de IOS aos cable modens Cisco usando o CMTS CLI de Cisco

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Os arquivos de configuração de software de Cisco IOS� são os arquivos de texto que contêm a configuração a ser enviada ao Roteadores. No caso de Cisco Cable Modems, a configuração enviada em geral contém listas de acesso, nomes de hosts, SNMP Community Strings, senhas ou configuração de roteamento diferentes da configuração de Bridging padrão. Para enviar um arquivo de configuração do Cisco IOS, é necessário incorporar esse arquivo no arquivo de configuração Data-over-Cable Service Interface Specifications (DOCSIS) usado pelos cable modems na parte TFTP do processo de inicialização.

Há duas maneiras de transferir um arquivo de configuração IOS Cisco aos cable modens Cisco.

A primeira, que é a maneira mais comum, é usar uma ferramenta Configurator DOCSIS de CPE. Consulte o Cisco DOCSIS CPE Configurator (somente clientes registrados). Os arquivos de configuração do DOCSIS 1.0 da construção do documento que usam o Configurador DOCSIS Cisco (clientes registrados somente) contêm uma explicação detalhada em como fazer isto.

A segunda maneira de realizar a mesma tarefa é usar a Interface de Linha de Comando (CLI) no Cisco IOS do Cable Modem Termination System (CMTS).

Este documento explica em detalhes a segunda maneira de fazer o download de um arquivo de configuração do IOS para Cisco Cable Modems sem a necessidade de usar uma ferramenta DOCSIS Configurator. Para isto nós usamos uma versão aprimorada da configuração completa que permite que Cisco CMTS seja configurado como o DHCP, o ToD, e os servidores TFTP, assim como para configurar um arquivo de configuração DOCSIS no CMTS próprio.

Quando nós queremos enviar um arquivo de configuração ao Modems a cabo usando o CLI para configurar o arquivo de configuração DOCSIS, nós precisamos de adicionar uma opção de DHCP chamada Vendor Specific Information Option DHCP, igualmente conhecido como a opção 43.

A principal vantagem de se configurar os modems a cabo dessa forma é que tudo pode ser feito no CMTS do Cisco e não é necessário nenhum outro servidor (como DHCP, TFTP ou ToD) e nenhum outro software (como DOCSIS CPE Configuration Tool) para enviar com êxito as configurações do Cisco IOS para os modems a cabo Cisco e torná-los operacionais com uma configuração personalizada.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

O leitor deve ter noções básicas de:

  • O protocolo DOCSIS

  • Interface de linha de comando (CLI) do Cisco IOS nos uBR Series Routers

  • UNIX

  • Protocolo de Configuração de Host Dinâmico (DHCP)

Componentes Utilizados

Consulte a seção Configuring all in one config including DHCP Option 43 (Configurando all in one config incluindo a opção 43 de DHCP) abaixo.

Opção de DHCP de informações específicas do fornecedor (Opção 43)

A opção 43 é uma opção DHCP usada pelos clientes e servidores para intercâmbio de Informações Específicas do Fornecedor.

Esta opção é formatada tipicamente em um estilo do “Tipo-Comprimento-Valor” onde as partes de informação diferentes possam ser representadas por tipos diferentes da subopção. O significado do campo Value é definido pelo fabricante do dispositivo final. A Figura 1 mostra uma representação gráfica da opção 43.

Tipo Duração Valor Tipo Duração Valor
T1 n d1 d2 ......... T2 n D1 D2 ........

Figura 1 - A estrutura do Tipo-Comprimento-Valor dos dados enviados dentro da opção 43.

Para fazer o download dos arquivos de configuração do Cisco IOS para os modems a cabo da Cisco, utilizamos duas subopções, que são Vendor ID e Vendor Specific Information Option (VSIF).

A subopção do Vendor ID tem o tipo 8. O Organization Unique Identifier de três-byte (OUI) para o vendedor é geralmente os primeiros três bytes do MAC address do modem a cabo. Esse valor é geralmente expresso como um número hexadecimal. Este campo deve ser 00:00:0C (em encantar) para o equipamento do Cisco Systems. Figura 2 abaixo dá os números hexadecimais para a subopção do Vendor ID.

Tipo Duração Valor
08 03 00:00:0C

Figura 2 - Vendor ID da subopção (no valor hexadecimal)

A segunda sub-opção utilizada é o VSIF (Campo de informações específicas do fornecedor). Esta subopção tem o tipo 128 e contém todos os valores arbitrários que forem definidos pelo fabricante do modem a cabo. O cable modem da Cisco usa esse campo para identificar o nome do arquivo de configuração do Cisco IOS que deve ser transferido por download (se houver) para um roteador.

Os comandos arbitrários do Cisco IOS também podem ser especificados nesse campo. Este campo é, em geral, representado por pontos decimais. O dotted decimal notation é a representação decimal das letras de acordo com o ASCII em que cada letra tem um valor decimal. Os "pontos" são usados entre a representação decimal para facilitar a compreensão.

Neste documento, mostraremos como fazer o download de um arquivo de configuração Cisco IOS chamado ios.cf. O nome desse arquivo é convertido de ASCII para ponto decimal.

Para saber qual é a tradução entre o ASCII e o pontilhado decimal, o comando man ascii do UNIX pode ser usado conforme mostrado abaixo. Esse comando fornece várias tabelas de conversão. Nós precisamos de procurar o decimal - Tabela do caráter.

sj-cse-494% man ascii
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)

 	 Decimal - Character

     |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
     |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
     | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
     | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
     | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
     | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
     | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
     | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
     | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
     | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
     | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
     | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
     | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
     |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
     |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
     |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

Consequentemente, a representação de pontilhado decimal do ios.cf é 105.111.115.46.99.102as mostrado abaixo em figura 3.

i o s . c f
105 111 115 46 99 192

Figura 3 - Representação de pontilhado decimal do ios.cf do nome de arquivo.

Como o VSIF tem o formato Tipo-Comprimento-Valor, a representação decimal completa pontuada do arquivo de configuração do Cisco IOS chamado ios.cf é 128.6.105.111.115.46.99.192. Como você pode ver, 128.6 foram adicionados à representação de pontilhado decimal de ios.cfshown em figura 3. recordam que "128" é o tipo e "6" está a um comprimento.

128.6.105.111.115.46.99.192 é o valor especificado no campo VSIF da ABA de informação de fornecedor do DOCSIS CPE Configurator Tool V3.2, conforme mostrado na Figura 4 a seguir.

iosconfig_option43.jpg

Figura 4 – Campo Vendor Info (Informações do Fornecedor) da Ferramenta Configuradora DOCSIS CPE

Entretanto, quando fizer essa função no Cisco IOS usando a opção DHCP 43, a informação do Tipo-Comprimento-Valor (TLV) deverá ser expressa em valores hexadecimais. Este documento se concentra nessa expressão hexadecimal.

Para descobrir a representação hexadecimal dos caracteres ASCII, podemos usar o comando Unix.

echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'

sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
69:6f:73:2e:63:66

Ou você pode usar também o comando de UNIX man ASCII anterior e encontrar a tabela de caractere hexadecimal.

sj-cse-494% man ASCII
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)


     Hexadecimal - Character

     | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
     | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
     | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
     | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
     | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
     | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
     | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
     | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
     | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
     | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
     | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
     | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
     | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
     | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
     | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
     | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

A figura 5 abaixo resume o pontilhado decimal bem como a representação hexadecimal do campo de informações específicas de fornecedor (VSIF).

Tipo Duração Valor
Decimal pontilhado 128 6 105.111.115.46.99.102
Hexadecimal 80 06 69:6F:73:2E:63:66

Figura 5 - Sub-opção VSIF em pontilhado decimal e hexadecimal.

Configurando all in one config incluindo DHCP Opção 43

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo.

  • Cisco uBR10012 executando 12.2(2)XF

  • Cisco CVA120 executando 12.2(2)XA

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede viva, certifique-se de que entende o impacto potencial de qualquer comando do Cisco IOS antes de utilizá-lo.

Primeiro passo - Crie o arquivo de configuração DOCSIS com a série 43 da opção correta

O primeiro passo na configuração da Opção 43 é saber os valores hexadecimais necessários da ID do fornecedor e das sub-opções VSIF da Opção 43 do DHCP.

A tabela a seguir resume esses valores que foram discutidos com detalhes na seção Informações Específicas do Fornecedor.

Opção secundária de ID de fornecedor Subopção VSIF
TLV Tipo Duração Valor Tipo Duração Valor
Hexadecimal 08 03 00:00:0C 80 06 69:6F:73:2E:63:66
Significado Tipo de ID de fornecedor Comprimento de ID do fornecedor Identificação da Cisco Tipo VSIF Duração de VSIF (filename) ios.cf

Figura 6

Uma vez que nós sabemos que valor nós incorporaremos, nós precisamos de usar o CLI do CMTS de Cisco para gerar todas as propriedades necessárias para o arquivo de configuração DOCSIS, incluindo a opção de DHCP 43.

Para criar o arquivo de configuração DOCSIS que nós precisamos de incorporar o DOCSIS-arquivo-nome do arquivo de configuração do cabo do comando global. A saída a seguir mostra a criação do arquivo de configuração DOCSIS chamado platinum.cm. Todas as configurações de platinum.cm são explicadas abaixo.

Note: 
!--- Comments are in blue.


cable config-file platinum.cm  
  
!---  Name of the DOCSIS config file is platinum.cm

  service-class 1 priority 2  
  
!---  The Upstream Channel priority is 2

  service-class 1 max-upstream 128 
  
!---  The Maximum upstream value is 128Kbps

  service-class 1 guaranteed-upstream 10
  
!---  The Guaranteed Upstream is 10 Kbps

  service-class 1 max-downstream 10000 
  
!---  The Maximum Downstream is 10Mbps

  service-class 1 max-burst 1600
  
!---  The Maximum Upstream Transmit burst is 1600 bytes

  cpe max 10 
  
!---  The Maximum number of CPE's is 10

  timestamp
  
!---  Enable timestamp generation

  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
  
!---  Using option 43 to send the IOS Configuration file named "ios.cf" 
  !---  to cable modems.

cuidado Cuidado: O comando cable config-file foi apresentado na versão 12.1(2)EC1 do Cisco IOS para uBR7200 e uBR7100 e na versão 12.2(1)XF1 do Cisco IOS para o uBR10K.

Nota: Esteja certo que você incorporou corretamente os dados TLV ao usar a opção encantar. Dados incorretamente digitados podem fazer com que os CMs sejam reinicializados, fiquem off-line ou desliguem, requerendo uma reinicialização de energia para continuar.

Segunda etapa – Crie o conjunto de DHCP para a configuração do servidor DHCP

Uma vez que nós criamos o arquivo de configuração DOCSIS platinum.cm, nós precisamos de configurar o CMTS para ser o servidor DHCP, e configuramos as opções necessárias para a funcionalidade de DHCP. Consulte o serviço do protocolo DHCP do Cisco IOS em um CMTS, que explica o significado de cada comando utilizado para a criação do conjunto dhcp. Aqui, iremos apenas resumir a configuração e dar uma breve descrição.

A configuração do conjunto do DHCP é:

ip dhcp pool surf
  
!---  name of the dhcp pool. This scope is for the cable modems attached 
  !---  to interface cable 5/0/0

  network 10.1.4.0 255.255.255.0
  
!---  pool of addresses for scope from interface c5/0/0

  bootfile platinum.cm
  
!---  DOCSIS config file name associated with this pool

  next-server 10.1.4.1
  
!---  IP address of TFTP server which sends bootfile

  default-router 10.1.4.1
  
!---  default gateway for cable modems, necessary to get DOCSIS files

  option 7 ip 10.1.4.1
  
!---  Log Server DHCP option

  option 4 ip 10.1.4.1
  
!---  ToD server IP address

  option 2 hex ffff.8f80
  
!---  Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

  lease 7 0 10
  
!---  lease 7 days 0 hours 10 minutes

  ! 

Terceira etapa - Configure o servidor CMTS como TFTP

A terceira etapa é configurar o CMTS para torná-lo um servidor TFTP. Para fazer isso, você precisará:

  1. Use o comando tftp-server

  2. Informe ao servidor TFTP onde está localizado o arquivo ios.cf

Você pode obter isso com o comando tftp-server disk0:ios.cf alias ios.cf. Observe que esse comando coloca o arquivo ios.cf em disk0.

tftp-server server

!--- enable the cmts to act as a tftp server

tftp-server disk0:ios.cf alias ios.cf

!--- get the IOS config file called ios.cf that is pre-downloaded to disk0
!--- this IOS  config file was built with a text editor and tftp to disk0  


Para colocar o arquivo ios.cf em seu flash ou disk0 (para uBR10012), você precisa transformar o arquivo criado em um arquivo tftp, utilizando um editor de arquivo de texto. Para fazer este primeiro certifica-se que você pode sibilar o server de tftp onde a configuração do IOS da Cisco é encontrada.

Em seguida, o comando global copy tftp <dispositivo> deve ser digitado para colocar o arquivo no CMTS. O flash é usado geralmente para uBR7200 ou uBR7100 ou uBR10K, contudo, mostras deste exemplo como usar o disco 0 para o uBR10012.

schooner#copy tftp disk0
Address or name of remote host []? 172.16.30.2
Source filename []? ios.cf
Destination filename [ios.cf]? 

Accessing tftp://172.16.30.2/ios.cf...
Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
[OK - 173/4096 bytes]

173 bytes copied in 0.152 secs

Para verificar se o arquivo de configuração IOS está armazenado no CMTS, execute o comando dir.

schooner#dir
Directory of disk0:/
    3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
 2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
47890432 bytes total (36274176 bytes free)

Para visualizar quais comandos estão configurados no arquivo ios.cf, o comando more <filename> pode ser usado no CMTS da seguinte maneira:

schooner#more ios.cf
hostname SUCCEED
service linenumber
enable password cisco
interface ethernet 0
load 30
no shut
interface cable 0
load 30
no shut
line vty 0 4
password cisco
end

Passo quatro - Configuração de CMTS como servidor ToD

Para configurar o ToD em um CMTS do Cisco, são necessários apenas dois comandos globais service udp-small-servers max-servers no-limit e cable time-server. A configuração se apresenta desta forma:

service udp-small-servers max-servers no-limit

!---  supports a large number of modems / hosts attaching quickly

cable timeserver

!---  permits cable modems to obtain Time of Day (ToD) from uBR10012


A configuração do CMTS

A configuração completa do uBR10012 é mostrada a seguir. Todos os comandos em negrito são relevantes para a finalidade deste documento.

Schooner#show run
Building configuration...

Current configuration : 3522 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname schooner
!
logging rate-limit console all 10 except critical
enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file platinum.cm
 service-class 1 priority 2
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
 option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
!
redundancy
 main-cpu
  auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1oc12pos-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 5/0 2cable-mc28
card 7/0 2cable-mc28
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool surf
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1 
   default-router 10.1.4.1 
   option 7 ip 10.1.4.1 
   option 4 ip 10.1.4.1 
   option 2 hex ffff.8f80
   lease 7 0 10
!
interface FastEthernet0/0/0
 ip address 172.16.30.50 255.255.255.192
!
interface POS1/0/0
 no ip address
 crc 32   
 pos report all
 POs flag j0 1
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/0/0
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 40000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server trap-source Cable5/0/0
snmp-server packetsize 2048
snmp-server enable traps cable
snmp-server host 172.16.30.8 public  cable snmp
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
!
end

schooner#

Outros fornecedores de CMTS não podem ter a capacidade para estabelecer todas estas partes usando somente seus comandos cmts visto que pode ser realizada completamente no Cisco IOS.

Para fazer com que os cable modems usem os comandos especificados no arquivo de configuração do Cisco IOS denominado ios.cf, é necessário reinicializar os cable modems em questão. Isto pode ser feito do do CLI do CMTS usando restauração clearcable do MAC address do modem do comando < endereço IP de Um ou Mais Servidores Cisco ICM NT/>.

Schooner#clear cable modem 10.1.4.4 reset

cuidado Cuidado: Se você tem uma rede grande e a quer enviar um arquivo de configuração diferente a todo o Modems a cabo em sua planta, recomenda-se fazer assim nas fases. Isso minimizará o impacto de milhares de modems a cabo tentando passar um por cima do outro enquanto tentam ficar on-line ao mesmo tempo.

Verificar a configuração

Para verificar a configuração, limpe o modem a cabo usando o comando clear cable modem. Assim que o modem a cabo retornar ao estado on-line, acesse-o por telnet e olhe suas configurações.

Schooner#show cable modem 
MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                         State       Sid  (db)  Offset CPEs Enbld
0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no

!--- CVA120
 
0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

Observação neste exemplo que os comandos ios cf file o Modems a cabo ter um hostname SUCCEED, e certamente este são o nome de arquivo que for considerado quando nós telnet no modem a cabo.

Schooner#telnet 10.1.4.4
Trying 10.1.4.4 ... Open

SUCCEED line 1 


User Access Verification

Password: 
SUCCEED>en
Password: 
SUCCEED#

Para verificar que o arquivo de configuração IOS Cisco esteve transferido com sucesso ao uso do modem a cabo o comando show version. A saída abaixo mostra as informações referentes ao arquivo ios.cf em negrito.

SUCCEED#show  version
Cisco Internetwork Operating System Software 
IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
TAC:Home:SW:IOS:Specials for info
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 27-Jun-01 02:02 by hwcheng
Image text-base: 0x800100A0, data-base: 0x80782844
ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SUCCEED uptime is 3 days, 3 hours, 21 minutes
System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
System restarted at 05:58:30 - Sat Oct 6 2001
System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
Host configuration file is "tftp://10.1.4.1/ios.cf"

cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
Processor board ID SAD043708GK
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
1 Universal Serial Bus (USB) interface(s)
8192K bytes of processor board System flash (Read/Write)
7296K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2

A configuração do CVA120 é mostrada abaixo. Observe que os comandos em negrito correspondem às linhas no arquivo ios.cf.

SUCCEED#show run
Building configuration...

Current configuration : 1429 bytes
!
! Last configuration change at 11:22:22 - Tue Oct 9 2001
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service linenumber
service internal
!
hostname SUCCEED
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable password cisco
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
interface Ethernet0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address docsis
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream mode annex-b
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface USB0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server chassis-id 
snmp-server manager
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
mgcp modem passthrough voaal2 mode 
no mgcp timer receive-rtcp
!
mgcp profile default
!
line con 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

Nota importante

Parece que o comando opcional para arquivo de configuração de cabo está com problema, pois se pode esperar que os comandos abaixo forneçam configuração válida.

option 43 instance 8 hex 00:00:0c
option 43 instance 128 ASCII ios.cf

Quando estes comandos forem aceitados, não gera o arquivo de configuração correto do Cisco IOS. Isso NÃO é um bug! O problema aqui é como o termo “exemplo” foi interpretado como uma “subopção,” que nunca supôs-se para ser.

A aplicação do “exemplo” permite somente a repetição dos mesmos tempos múltiplos da opção, como quando você tem múltiplas instâncias da opção 43 para vários vendedores! Aqui está um exemplo:

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67

!--- Config file cisco CM

option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67

!--- Some option for other CM

Observe que 11:22:33 é um ID de Fornecedor aleatório de uma empresa fictícia. Qualquer correspondência com um ID de fornecedor real é pura coincidência.

Como se espera que o termo "instância" reflita os campos de subopções TLV, e você realmente tem esses campos, digite a série inteira em hexadecimais.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 8323