Segurança : Dispositivos de segurança Cisco PIX 500 Series

Configurando o Firewall de PIX com Acesso ao Servidor de E-mail na Rede Interna

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo demonstra como configurar o PIX Firewall para acessar um servidor de e-mail localizado na rede interna.

Nota: A inspeção de SMTP configurada neste documento não é compatível com conexões ESMTP aos server tais como o Microsoft Exchange. Não configurar a inspeção de SMTP se você usa um mail server que confie no ESMTP. Alternativamente, versão de software de PIX 7.0 e apoios mais atrasados S TP e inspeção de ESMTP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • PIX Firewall 10000

  • Liberação de software de firewall de PIX 5.1(4)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede.

/image/gif/paws/8122/mailserver_in.gif

Configurações

Este documento utiliza estas configurações.

Firewall de PIX
PIX Version 5.1(4)

 !--- These commands name and set the security level for each PIX interface.

 nameif ethernet0 outside security0
 nameif ethernet1 inside security100
 enable password 8Ry2YjIyt7RRXU24 encrypted
 passwd 2KFQnbNIdI.2KYOU encrypted
 hostname PIX_1
 domain-name noplace.com
 fixup protocol ftp 21
 fixup protocol http 80
 fixup protocol h323 1720
 fixup protocol rsh 514
 fixup protocol smtp 25
 fixup protocol sqlnet 1521
 no names

 !--- Create an access list that permits SMTP traffic from anywhere
 !--- to the host at 209.164.3.5 (our server).  The name of this list is 
 !--- smtp. Add additional lines to this access list as required.
 !--- Note: There is one and only one access list allowed per
 !--- interface per direction (for example, inbound on the outside interface).
 !--- Because of limitation, any additional lines that need placement in
 !--- the access list need to be specified here.  If the server
 !--- in question is not SMTP, replace the occurrences of SMTP with
 !--- www, DNS, POP3, or whatever else is required. The access-list
 !--- command was introduced in PIX Software Release 5.0; it is used
 !--- here instead of a conduit statement.

 access-list smtp permit tcp any host 209.164.3.5 eq smtp
 pager lines 24
 logging on
 logging timestamp
 no logging standby
 logging console debugging
 logging monitor debugging
 logging buffered debugging
 logging trap debugging
 no logging history
 logging facility 23
 logging queue 512

 !--- Set each Ethernet interface to auto-detect its media type.

 interface ethernet0 auto
 interface ethernet1 auto
 mtu outside 1500
 mtu inside 1500

 !--- Define the IP address for each interface.

 ip address inside 192.168.1.1 255.255.255.0
 ip address outside 209.164.3.1 255.255.255.252
 no failover
 arp timeout 14400

 !--- Specify that any traffic that originates inside from the
 !--- 192.168.2.x network NATs (PAT) to 209.164.3.129 if
 !--- such traffic passes through the outside interface.

 global (outside) 1 209.164.3.129
 nat (inside) 1 192.168.2.0 255.255.255.0

 !--- Define a static translation between 192.168.2.57 on the inside and
 !--- 209.164.3.5 on the outside.  These are the addresses to be used by
 !--- the server located inside the firewall.

 static (inside,outside) 209.164.3.5 192.168.2.57 netmask 255.255.255.255

 !--- Apply the access list named smtp inbound on the outside interface.

 access-group smtp in interface outside

 !--- Set the default route to  209.164.3.2. 
 !--- The PIX assumes that this address is that of a router.

 route outside 0.0.0.0 0.0.0.0 209.164.3.2 1
 
 !--- Instruct the PIX to hand any traffic destined for 192.168.x.x
 !--- to the router at 192.168.1.2.

 route inside 192.168.0.0 255.255.0.0 192.168.1.2 1
 timeout xlate 1:30:00 conn 1:00:00 half-closed 0:10:00 udp 0:00:00
 timeout rpc 0:10:00 h323 0:05:00
 timeout uauth 0:00:00 absolute
 aaa-server TACACS+ protocol tacacs+
 aaa-server RADIUS protocol radius
 no snmp-server location
 no snmp-server contact
 snmp-server community public
 no snmp-server enable traps
 floodguard enable
 terminal width 200
 Cryptochecksum:d66eb04bc477f21ffbd5baa21ce0f85a
 : end
 
 !--- Alternate command:
 !--- conduit permit tcp host 209.164.3.5 eq smtp any
 !--- The conduit command is equivalent to 
 !--- the access-list statements this configuration shows.
 !--- In this case a path known as a conduit is created in order to allow any SMTP 
 !--- traffic to host 209.164.3.5.  Use of this command replaces the 
 !--- access-list and access-group 
 !--- statements that this configuration presents.

Router
Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname 2522-R5
 !
 enable secret 5 $1$N0F3$XE2aJhJlCbLWYloDwNvcV.
 !
 ip subnet-zero
 !
 !
 !
 !
 !
 interface Ethernet0
 
 !--- Sets the IP address of the Ethernet interface to 209.164.3.2.

  ip address 209.164.3.2 255.255.255.252
 !
 interface Serial0

  !--- Instructs the serial interface to use 
  !--- the address of the Ethernet interface when the need arises.

  ip unnumbered ethernet 0 
 !
 interface Serial1
  no ip address
  no ip directed-broadcast
 !
 ip classless

 !--- Instructs the router to send all traffic 
 !--- destined for 209.164.3.x to 209.164.3.1.

 ip route 209.164.3.0 255.255.255.0 209.164.3.1

 !--- Instructs the router to send 
 !--- all other remote traffic out serial 0.

 ip route 0.0.0.0 0.0.0.0 serial 0
 !
 !
 line con 0
  transport input none
 line aux 0
  autoselect during-login
 line vty 0 4
  exec-timeout 5 0
  password ww
  login
 !
 end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

O comando logging console debugging dirige mensagens ao console de PIX. Se a Conectividade ao mail server é um problema, examine o console debugam mensagens para encontrar os endereços IP de Um ou Mais Servidores Cisco ICM NT da emissão e das estações de recepção a fim determinar o problema.

Informações a Serem Coletadas se Você Abrir uma Ocorrência de Suporte Técnico

Se você ainda precisa o auxílio depois que você termina os passos de Troubleshooting neste documento e os quer abrir um caso com Suporte técnico de Cisco, seja certo incluir esta informação para pesquisar defeitos seu PIX Firewall.
  • Descrição do problema, que inclui a topologia e os detalhes do endereço IP de Um ou Mais Servidores Cisco ICM NT do mail server.
  • Termine todo o Troubleshooting antes que você abra o caso.
  • Saída do comando show tech-support.
  • Saída do comando show log depois que é executado com o comando logging buffered debugging, ou capturas de console que demonstram o problema (se disponível)
Anexe os dados coletados à sua ocorrência em formato de texto simples descompactado (.txt). Você pode anexar a informação a seu caso transferindo arquivos pela rede o com a ferramenta do pedido do serviço TAC (clientes registrados somente). Se você não pode alcançar a ferramenta do pedido do serviço TAC, você pode enviar a informação em um anexo de e-mail a attach@cisco.com com seu número de caso na linha de assunto de sua mensagem.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 8122