Switches : Cisco 6130 IP DSL Switch

Configurar uma interface ATM do Cisco 6400 com o RBE e o DHCP

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para um roteador do digital subscriber line (DSL) do Cisco 827 conectado a um multiplexador de acesso de linha de assinante digital do Cisco 6130 (DSLAM), isso termina em um concentrador de acesso universal (UAC) do Cisco 6400.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Customer Premises Equipment do Cisco 827-4V (CPE) com Software Release 12.1(1)XB IOS�.

  • Software Release 12.1(1)DC1 do Cisco 6400 UAC-NRP IOS (servidor de DHCP externo) ou 12.2(2)B (servidor DHCP IO).

  • Software Release 12.0(4)DB do Cisco 6400 UAC-NSP IOS.

  • IOS Software release 12.1(1)DA do Cisco 6130 DSLAM-NI2.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

O Cisco 827 é configurado com construção de uma ponte sobre e Integrated Routing and Bridging (IRB) do RFC1483. O Cisco 827 permite que os PC no segmento de Ethernet obtenham endereços de um servidor DHCP atrás dos 6400, ou do servidor DHCP 6400 IO. Além, o endereço BVI foi configurado igualmente para obter um endereço e uma rota padrão do servidor DHCP. A interface do Asynchronous Transfer Mode (ATM) do Cisco 6400 é configurada com o encapsulamento do bridge roteado (RBE), e configurada para operar-se com um servidor de DHCP externo ou o servidor DHCP IO no NRP.

Para o Cisco 6400, a característica ATM RBE no Cisco 6400 node route processor (NRP) distribui o IP sobre o tráfego Ethernet construído uma ponte sobre do RFC1483 de um Stub-Bridged LAN. Os pacotes IP construídos uma ponte sobre recebidos em uma interface ATM configurada no modo rota-construído uma ponte sobre são distribuídos através do cabeçalho IP. As relações aproveitam-se das características de uma topologia de LAN do stub de uso geral para o acesso DSL, e o desempenho aumentado e a flexibilidade da oferta sobre o IRB.

Também, as rotas do host para clientes DHCP estão adicionadas automaticamente à tabela de roteamento 6400 enquanto os endereços IP de Um ou Mais Servidores Cisco ICM NT são distribuídos. As rotas do host estão removidas da tabela de roteamento quando o endereço de DHCP é liberado.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento usa a instalação de rede mostrada em figuras 1 e 2:

Figura 1 – Encenação 1

/image/gif/paws/7208/fig1_7208.gif

Figura 2 – Encenação 2

/image/gif/paws/7208/fig2_7208.gif

Configurações

Este documento utiliza as seguintes configurações:

  • Cisco 827

  • Cisco 6400 NRP

  • 6400 debugar (usando o RBE com servidor de DHCP externo)

  • 6400 debugar (usando o RBE com servidor DHCP IO)

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 no ip address
 bridge-group 1

!--- Because the Ethernet0 is bridged to the WAN interface,
!--- PCs behind the ethernet0 can be setup as DHCP clients.
!--- They get their addresses from the DHCP server behind the 6400,
!--- or from the IOS DHCP server on the 6400.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address dhcp client-id Ethernet0

!--- This command tells the BVI interface to get the address
!--- from DHCP, and also to get the default route from DHCP.

! 
ip classless 

!--- Note: The default route will be inserted into
!--- the routing table automatically from the DHCP server, and
!--- no static routing statement is required.                         

no ip http server 
! 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP
Current configuration: 
! 
version 12.1
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 198.1.1.1 255.255.255.0 
 no ip directed-broadcast

!--- This address and mask must match the intended
!--- scope and network configured on the external DHCP server.

! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses IP
!--- unnumbered Loopback1 for its IP address requirements.

 ip unnumbered Loopback1 
 ip helper-address <dhcp server ip address>
 atm route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 

!--- Note: For every DHCP client that is relayed an address,
!--- a host route will be automatically inserted in the routing 
!--- table, and no host route statement for a DHCP client is required.

end 

6400 debugar (usando o RBE com servidor de DHCP externo)
debug ip dhcp server events 

Looks for existing binding. . .

00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1
00:10:56:  find_or_create(): Creating new binding with data
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards DHCP DISCOVER packet from the client to the
!--- external DHCP server.

00:10:56: DHCPD: Received DHCPDISCOVER on UNNUM-IF
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP OFFER packet from the external DHCP server 
!--- to the client.

00:10:56: DHCPD: Unnum: Received DHCPOFFER
00:10:56:  DHCPD: Server Address = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1
00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards the DHCP REQUEST packet from the client to the external
!--- DHCP server.

00:10:56: DHCPD: Received DHCPREQUEST on UNNUM-IF
00:10:56:  DHCPD: request_on_unnumif ():Real Server = 200.200.200.2   
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP ACK packet from the DHCP server to the client.

00:10:56: DHCPD: Unnum: Received DHCPACK
00:10:56:  DHCPD: lease time = 86400

!--- Adds a dynamic host route to the client into the routing table.

00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56:  DHCPD: Adding new route to host 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_create_and_hash_route index = 126
00:10:56: DHCPD: dhcpd_add_route: lease = 86400 
00:10:56:  DHCPD: Server ID saved in Binding = 200.200.200.2
00:10:56:  DHCPD: Server ID saved in Route block = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1

6400 debugar (usando o RBE com servidor DHCP IO)
debug ip dhcp server events 

Assigns an address to the client from the IOS DHCP server.

23:19:09: DHCPD: assigned IP address 124.124.124.3 to 
client 0063.6973.636f.2d30.3030.302e.3063.3036.2e32.3339.342d.4256.31.
23:19:10:  DHCPD: lease time = 86400

Adds a dynamic host route to the client into the routing table.

23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10:  DHCPD: Adding new route to host 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_create_and_hash_route index = 127
23:19:10: DHCPD: dhcpd_add_route: lease = 86400

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 7208