IP : Open Shortest Path First (OSPF)

Por que existem algumas rotas OSPF no banco de dados mas não na Tabela de Roteamento?

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Interativo: Este documento oferece análise personalizada do seu dispositivo Cisco.


Índice


Introdução

Um problema comum ao usar o Open Shortest Path First (OSPF) é rotas no banco de dados não aparece na tabela de roteamento. Na maioria dos casos o OSPF encontra uma discrepância no banco de dados assim que não instala a rota na tabela de roteamento. Frequentemente, você pode ver que o ADV Router é a mensagem não-alcançável (que significa que o roteador que anuncia o LSA não é OSPF direto alcançável) sobre o anúncio link state (LSA) no banco de dados quando este problema ocorre. Aqui está um exemplo:

Adv Router is not-reachable
LS age: 418
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.32.2
Advertising Router: 172.16.32.2
LS Seq Number: 80000002
Checksum: 0xFA63
Length: 60
 Number of Links: 3

Há diversas razões para este problema, a maioria de que negócio com configuração incorreta ou uma topologia quebrada. Quando a configuração é corrigida a discrepância da base de dados do OSPF parte e as rotas aparecem na tabela de roteamento. Este documento explica alguns de mais motivos comuns que podem causar a discrepância no banco de dados.

Alguns dos comandos usados durante todo este documento para a verificação do comportamento OSPF incluem a relação OSPF da mostra IP, o roteador de banco de dados OSPF IP, o vizinho OSPF da mostra IP e o banco de dados OSPF da mostra IP externo. Se você tem a saída de qualquens um comandos de seu dispositivo Cisco, você pode usar-se para indicar problemas potenciais e reparos. Para usar-se , você deve ser um cliente registrado, ser entrado, e ter o Javascript permitido.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter o conhecimento destes assuntos

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • O Software Release 12.3 do � do Cisco IOS estava sendo executado em todo o Roteadores.

  • Isto é apoiado em todas as plataformas do Cisco Router.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Razão 1: Incompatibilidade de tipo de rede

Deixe-nos usar como um exemplo o diagrama de rede seguinte:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
 ip ospf network broadcast

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1
  Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Como você pode ver acima, o roteador R4-4K é configurado para a transmissão, e o roteador R1-7010 é configurado para ponto a ponto. Este tipo da incompatibilidade de tipo de rede faz o roteador de anúncio inacessível.

R4-4K(4)# show ip ospf database router 172.16.32.2

  Adv Router is not-reachable
  LS age: 418
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.32.2
  Advertising Router: 172.16.32.2
  LS Seq Number: 80000002
  Checksum: 0xFA63
  Length: 60
   Number of Links: 3

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.33.1
    (Link Data) Router Interface address: 172.16.32.2
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 172.16.32.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

R1-7010(5)# show ip ospf database router 172.16.33.1

  Adv Router is not-reachable
  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 2

     Link connected to: a Transit Network
     (Link ID) Designated Router address: 172.16.32.1
     (Link Data) Router Interface address: 172.16.32.1
     Number of TOS metrics: 0
     TOS 0 Metrics: 64

Você pode ver que para a sub-rede 172.16.32.0/24, o roteador R1-7010 está gerando um link de ponto a ponto e o roteador R4-4K está gerando um enlace de trânsito. Isto cria uma discrepância na base de dados de link-state, que significa que nenhuma rota está instalada na tabela de roteamento.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solução

Para resolver este problema, configurar ambo o Roteadores para o mesmo tipo de rede. Você pode mudar o tipo de rede do roteador R1-7010 para transmitir, ou mudar a interface serial do roteador R4-4K a ponto a ponto.

Nota: Se você tem uma situação onde um lado seja uma interface multiponto e o outro lado é uma secundário-relação a seguir muda o tipo de rede para transmitir em ambos os lados.

Neste exemplo nós removemos a indicação do “tipo de rede broadcast” no R4-4K porque os ambos os lados são interfaces encapsulada pontos a ponto do High-Level Data Link Control (HDLC).

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2 
R4-4K(4)(config-if)# no ip ospf network broadcast 
R4-4K(4)(config-if)# end

R4-4K(4)# show ip ospf interface serial 2
 Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:04
  Neighbor Count is 1, Adjacent neighbor count is 1 
  Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

Razão 2: Atribuição de endereço errado na instalação do link serial dual

Considere este diagrama da rede como um exemplo:

/image/gif/paws/7112/26b.gif

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.29.1 255.255.255.0
!
interface Serial3
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

Você pode ver que os endereços IP de Um ou Mais Servidores Cisco ICM NT estão lançados nas configurações acima, que causa uma discrepância na base de dados do OSPF. Contudo, o Roteadores ainda forma vizinhos na versão do Cisco IOS mais cedo de 12.1 porque em um link de ponto a ponto, os OSPF Router não verificam que o roteador vizinho está na mesma sub-rede.

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:37    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:31    172.16.29.2     Serial3

Da saída acima, você pode ver que Serial2 está formando vizinhos com endereço IP 172.16.32.2, que não está na mesma sub-rede. Embora os vizinhos sejam formados, nenhuma rota é instalada na tabela de roteamento:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Solução

Para resolver este problema, qualquer um atribui corretamente os endereços IP de Um ou Mais Servidores Cisco ICM NT ou comuta os cabos serial. Aqui nós corrigimos os endereços IP de Um ou Mais Servidores Cisco ICM NT:

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
!
interface Serial3
 ip address 172.16.29.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:36    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:39    172.16.29.2     Serial3

Agora mostra o endereço vizinho correto na relação de Serial2. As rotas estão igualmente na tabela de roteamento:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.35.1/32 [110/65] via 172.16.32.1, 00:03:12, Serial1/0
                       [110/65] via 172.16.29.1, 00:03:12, Serial1/1
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Razão 3: Um lado do enlace ponto-a-ponto foi incluído na rede principal ou na rede auxiliar de maneira errada

Considere este diagrama da rede como um exemplo:

/image/gif/paws/7112/26c.gif

Esta situação cria exatamente o mesmo comportamento que a atribuição de endereço errado na instalação do link serial dual. Para resolver o problema, atribua endereços IP de Um ou Mais Servidores Cisco ICM NT na mesma sub-rede em ambo o Roteadores.

Razão 4: Um dos lados não é numerado e o outro lado é numerado

Considere o diagrama de rede seguinte como um exemplo:

/image/gif/paws/7112/unnum.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip unnumbered Loopback0
 router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show interface serial 2
Serial2 is up, line protocol is up 
  Hardware is cxBus Serial
  Interface is unnumbered.  Using address of Loopback0 (172.16.35.1)

R1-7010(5)# show interface serial 1/0
Serial1/0 is up, line protocol is up 
  Hardware is cxBus Serial
  Internet address is 172.16.32.2/24

A saída acima mostra que a relação de Serial2 do R4-4K é unnumbered a Loopback0, visto que o Serial1/0 do R1-7010 é uma interface numerada.

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 0.0.0.0/24, Area 0 
  Process ID 20, Router ID 172.16.35.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Como você pode ver acima, o tipo de rede é em ambos os casos ponto a ponto. O problema é que um lado é unnumbered e o outro lado não é, que cria uma discrepância no banco de dados como mostrado abaixo.

R4-4K(4)# show ip ospf database router 172.16.30.1

  OSPF Router with ID (172.16.35.1) (Process ID 20)
 Router Link States (Area 0)
 LS age: 202
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.30.1
     Advertising Router: 172.16.30.1
     LS Seq Number: 80000002
     Checksum: 0xC899
     Length: 60
     Number of Links: 3
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.35.1
     (Link Data) Router Interface address: 172.16.32.2
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.32.0
     (Link Data) Network Mask: 255.255.255.0
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.30.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R4-4k(4)#
    
R1-7010(5)# show ip ospf database router 172.16.35.1

OSPF Router with ID (172.16.30.1) (Process ID 20)
     Router Link States (Area 0)
 Adv Router is not-reachable
     LS age: 396
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.35.1
     Advertising Router: 172.16.35.1
     LS Seq Number: 80000003
     Checksum: 0xBEA1
     Length: 48
     Number of Links: 2
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.30.1
     (Link Data) Router Interface address: 0.0.0.3

          
!--- In case of an unnumbered link we use MIB 
          !--- II IfIndex value which usually starts with 0.

          
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.35.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R1-7010(5)#

Você pode ver que o R1-7010 está gerando um LSA para este link de ponto a ponto com o campo de dados de enlace que contém seu endereço da relação, quando o R4-4K gerar o LSA para o mesmo link com o campo de dados de enlace que contém o valor do ifIndex MIBII. Isto cria uma discrepância na base de dados de link-state, que significa que nenhuma rota está instalada na tabela de roteamento.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solução

Para resolver este problema, configurar as interfaces serial do Roteadores como ou numerado ou unnumbered. Neste exemplo nós numeramos a relação da série 2 do roteador R4-4K.

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2
R4-4K(4)(config-if)# no ip unnumbered loopback 0 
R4-4K(4)(config-if)# ip address 172.16.32.1 255.255.255.0

R4-4K(4))# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:03:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Razão 5: PVC quebrado em ambiente de Frame Relay totalmente em malha

Considere este diagrama da rede como um exemplo:

/image/gif/paws/7112/26d.gif

R9-2500
interface Loopback0
 ip address 50.50.50.50 255.255.255.255
 !
interface Serial0
 ip address 10.10.10.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast 
 frame-relay map ip 10.10.10.6 102 broadcast
 frame-relay map ip 10.10.10.7 101 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 50.50.50.0 0.0.0.255 area 0

R4-4K
interface Loopback0
 ip address 70.70.70.70 255.255.255.255
!
interface Serial0
 ip address 10.10.10.7 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 101 broadcast
 frame-relay map ip 10.10.10.6 100 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 70.70.70.0 0.0.0.255 area 0

R3-4K
interface Loopback0
 ip address 60.60.60.60 255.255.255.255
 !
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.10.10.6 255.255.255.0
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 102 broadcast
 frame-relay map ip 10.10.10.7 100 broadcast
!
router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 60.60.60.0 0.0.0.255 area 0

O modelo de broadcast sobre o Frame Relay funciona corretamente enquanto a perturbação do Frame Relay é engrenada inteiramente. Se algum circuito permanente (PVC) é quebrado, pode criar problemas na base de dados do OSPF, que produz por sua vez a mensagem alcançável do ADV Router não.

Neste exemplo, o PVC entre o R9-2500 e o R4-4K são quebrados, e o link R9-2500 ao Designated Router (DR) é quebrado. Em consequência, o R9-2500 declara todos os LSA do R3-4K (que não é um DR), como inacessíveis. Como você pode ver, o R9-2500 não está gerando um enlace de trânsito para a interface serial anexada ao R3-4K; está gerando um link do stub pelo contrário porque tanto quanto o R9-2500 não há nenhum DR neste link.

R9-2500(3)# show ip ospf database router

       OSPF Router with ID (50.50.50.50) (Process ID 10)
                Router Link States (Area 0)
  LS age: 148
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 8000000B
  Checksum: 0x55A
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.10.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 50.50.50.50
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

  Adv Router is not-reachable
  LS age: 1081
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 80000006
  Checksum: 0x4F72
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 60.60.60.60
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.6
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

          
  Adv Router is not-reachable
  LS age: 306
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 80000007
  Checksum: 0xC185
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 70.70.70.70
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.7
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

Refira problemas com executar o OSPF no modo de NBMA sobre o Frame Relay para informações mais detalhadas sobre deste problema.

Razão 6: Encaminhando endereços conhecidos via rota externa

Considere este diagrama da rede como um exemplo:

/image/gif/paws/7112/foradd.gif

R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1

R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

R2515
interface Serial1
ip address 4.4.4.3 255.255.255.0
       
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

R2507# show ip ospf data external 200.1.1.0
       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

O R2507 tem 200.1.1.0/24 em seu banco de dados mas não o instalou na tabela de roteamento porque 3.3.4.4 é instruído através de uma rota externa OSPF.

R2507# show ip route 3.3.4.4
       Routing entry for 3.3.4.0/ 24
       Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
       Redistributing via ospf 1
       Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
       Routing Descriptor Blocks:
       * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
          Route metric is 20, traffic share count is 1

Nota: Com o reparo do CSCdp72526 da identificação de bug Cisco (clientes registrados somente), o OSPF não gera um anúncio link state type-5 (LSA) de uma rede externa sobreposta; consequentemente, o R2507 terá somente uma rota intra-área sumária de 3.0.0.0/8. Então, o R2507 instalará 200.1.1.0/24 como o endereço de encaminhamento e serão alcançáveis através da rota intra-área 3.0.0.0/8, assim em conformidade com o RFC 2328leavingcisco.com .

Depois que o reparo de erro acima mencionado, saída olhará como o seguinte:

R2507# show ip route 3.3.4.4
      Routing entry for 3.0.0.0/8
      Known via "ospf 1", distance 110, metric 74, type inter area
      Last update from 1.1.1.2 on Serial0, 00:19:20 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:19:20 ago, via Serial0



R2507# show ip route  
      Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Serial0
    O IA 3.0.0.0/8 [110/74] via 1.1.1.2, 00:30:18, Serial0
    O E2 200.1.1.0/24 [110/20] via 1.1.1.2, 00:22:58, Serial0
    Route metric is 74, traffic share count is 1

R2507#

Se o endereço de encaminhamento é sabido igualmente através de uma rota externa, o OSPF não instala essa rota na tabela de roteamento. Para informações mais detalhadas sobre deste problema, veja o Problema de Roteamento Comum com Endereço de Encaminhamento do OSPF.

Razão 7: A lista de distribuição está bloqueando as rotas

Deixe-nos usar como um exemplo o diagrama de rede seguinte:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
 distribute-list 1 in
!
access-list 1 permit 172.16.32.0. 0.0.0.255

Como você pode ver acima, o R1-7010 tem o comando distribute-list configurado e está permitindo somente que aos 172.16.32.0/24 a escala de endereço fosse instalada na tabela de roteamento. Nos protocolos de estado de enlace você não pode realmente filtrar um LSA com o comando distribute-list. O LSA ainda estará no banco de dados; contudo o LSA não será instalado na tabela de roteamento.

R1-7010(5)# show ip ospf database router 172.16.33.1

  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 3

 Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.32.2
    (Link Data) Router Interface address: 172.16.32.1
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

O comando distribute-list configuration no R1-7010 está filtrando a rede 172.16.33.1/32 da instalação na tabela de roteamento.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solução

Para resolver este problema, configurar o R1-7010 e permitir 172.16.33.0/24 no Access Control List (ACL) assim que esta rede obtém instalado na tabela de roteamento.

R1-7010(5)# configure terminal 
R1-7010(5)(config)# access-list 1 permit 172.16.33.0 0.0.0.255 
R1-7010(5)(config)# end

R1-7010(5)# show ip access-list 1
Standard IP access list 1
    permit 172.16.32.0, wildcard bits 0.0.0.255
    permit 172.16.33.0, wildcard bits 0.0.0.255

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:00:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 7112