Discar e acessar : Dial-on-Demand Routing (DDR)

Configurando Dialin e Dialout nos mesmos circuitos T1/E1 PRI

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar um servidor de acesso para receber e enviar chamadas na mesma PRI T1. Todas as chamadas recebidas e enviadas tráfego-são baseadas e Dial-on-Demand Routing (DDR) do uso mas não fornecem o backup para nenhum outro roteador. Se você deseja configurar um servidor de acesso para chamadas dial-in somente, refira o documento que configura um servidor de acesso com os PRI para o assíncrono recebido e as chamadas ISDN. Para adaptar esta configuração para incluir o backup, refira o documento de Configuração e Troubleshooting de DDR Backup.

Pré-requisitos

Requisitos

Etapa 1 - Configurar e verifique que a discagem e os clientes de discagem setup corretamente. Como essa configuração focaliza a configuração de NAS da estação central, não incluímos um exemplo de configuração para os clientes. Alguns exemplos de configuração de cliente estão incluídos abaixo:

Cliente do dialin - Dispositivo que disca no NAS:

Cliente de discagem - Dispositivo a que este NAS disca para fora:

Etapa 2 – Verifique se os circuitos Telco estão funcionando adequadamente. Você pode usar o comando show isdn status verificar que o circuito BRI ou PRI functionting corretamente. Consulte o documento Utilizando o Comando show isdn status para o Troubleshooting de BRI para obter mais informações. Você também deve ativar o circuito T1/E1 PRI para chamadas realizadas. Entre em contato com a Telco para verificar essas informações.

Componentes Utilizados

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo.

  • NAS: Cisco AS5300 com um circuito T1 PRI. Este AS5300 executa a Versão 12.2(5) do Software Cisco IOS.

  • Cliente: Cisco AS5300 com um circuito T1 PRI. Essa configuração não está incluída.

  • Cliente: Cisco 1600 com um circuito BRI. Essa configuração não está incluída.

  • Cliente: Cisco 804 com um circuito BRI. Essa configuração não está incluída.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

É possível que seja necessário utilizar o mesmo circuito de PRI T1/E1 para conexões Dialin e Dialout em muitas situações. O Network Access Sever (NAS) apoiá-lo-ia chamadas recebidas dos usuários do ISDN múltiplo e poderia igualmente fazer chamadas externas no mesmo PRI a um outro dispositivo. A discagem de saída também poderia ser usada em um cenário de backup, no qual o NAS discaria e se conectaria a um peer que perdesse seu link de WAN primário.

Produtos Relacionados

Essa configuração pode ser utilizada com qualquer roteador que possua placas T1 ou PRI. Por essa razão, qualquer roteador do AS5xxx Series com uma placa T1 ou PRI pode usar essa configuração. Os Cisco 2600 e 3600 Series Routers também podem ser configurados de forma a aceitar chamadas ISDN com uma placa de interface WAN (WIC) ou um Módulo de Rede T1/PRI.

Essa configuração pode também ser modificada para ser usada com portas E1 ou PRI. Configure o controlador E1com a codificação de linha, enquadramento e outras características físicas suportadas pela Telco. A configuração de canal D (interface serial x:15 para E1s) é similar àquela mostrada aqui.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos utilizados neste documento, utilize a ferramenta IOS Command Lookup.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/6435/pri_dialin_6435.gif

Configurações

Há dois métodos principais para configurar um servidor de acesso para poder fazer chamadas feitas e aceitar chamadas recebidas no mesmo T1/E1 PRI. Estes são os perfis de discador grupos giratórios de discador. Cada um tem seus benefícios e inconvenientes, como:

  • Os grupos giratórios de discador são mais simples configurar e controlar.

  • Os Perfis de discagem precisam uma interface do discador separada para cada chamada recebida e enviada. Se houver vários peers de entrada e saída, será complicado criar e manter a configuração.

  • Os perfis de discador permitem configuração específica do cliente. Por exemplo, você pode especificar que um determinado cliente estará atribuído um endereço IP de Um ou Mais Servidores Cisco ICM NT do conjunto de endereços A quando um outro cliente será atribuído um endereço do pool B.

  • Os grupos giratórios de discador permitem que somente os mesmos parâmetros sejam aplicados a todos os usuários. A personalização por usuário não é possível.

  • Os Grupos giratórios de discadores permitem apenas uma definição de tráfego interessante para chamadas recebidas e enviadas. Daqui, você não pode configurar o roteador para usar uma definição de tráfego interessante para chamadas recebidas e outra para chamadas feitas.

  • Os Perfis de discagem permitem definições de tráfego interessante separadas para cada par.

Este documento fornece amostras usando Perfis de discagem e grupos giratórios de discador no NAS. Escolha o método apropriado para sua situação.

Servidor de Acesso Central com Perfis de Discador (AS5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration : 3351 bytes
!
! Last configuration change at 07:25:39 CDT Wed Oct 24 2001
! NVRAM config last updated at 16:37:00 CDT Tue Oct 23 2001
!
version 12.2
service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
username 5300-client password 7 <deleted>
username lanai-nas-01 password 7 <deleted>

! -- Usernames for local authentication of the call.
! -- The client presents the username/password 
! -- and the NAS authenticates the peer.

spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni

! -- Switch-type for this NAS. Obtain this information from the Telco.

isdn voice-call-failure 0
!
controller T1 0

! -- T1 PRI physical controller configuration.

 framing esf

! -- Framing for this T1 is Extended Super Frame (ESF). 
! -- Obtain this information from the telco.

 clock source line primary

! -- T1 0 is the primary clock source for this NAS. 
! -- Clock source must be specified for the timing 
! -- and synchronization of the T1 carrier.

 linecode b8zs

! -- Linecoding for this T1. Obtain this information from the telco.

 pri-group timeslots 1-24

! -- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
! -- as ISDN PRI channels. The router will now automatically create the 
! -- corresponding D-channel: interface Serial 0:23
!
! -- The configurations for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.


!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer pool-member 10

! -- Assign this D-channel as member of dialer pool 10.
! -- Dialer pool 10 is used by interface Dialer 1 and Dialer 2. 
! -- All Dialer Interfaces for incoming calls should be configured 
! -- to use this pool.

 dialer pool-member 50 max-link 10

! -- The D-channel is also a member of dialer pool 50.
! -- Dialer pool 50 is used by interface Dialer 100.
! -- The pool can use a maximum of 10 links and will be used for outgoing calls.
 
 isdn switch-type primary-ni
 isdn bchan-number-order ascending

! -- B Channel Outgoing Call Order is ascending.
! -- Contact the Telco to determine whether the ISDN outbound trunk 
! -- call selection is configured for ascending or descending on the switch.

 no cdp enable
 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp on this interface.

!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1
 description For Dialin ISDN Client - austin-soho-01
 ip unnumbered Ethernet0

! -- The interface is unnumbered to conserve IP addresses.

 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 2 also 
! -- uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 1600-isdn-client

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself (which can be different from
! -- the router hostname). The router uses this remote-name to bind the 
! -- incoming call to this dialer. without this command calls from 
! -- 1600-isdn-client will fail after authentication.

 dialer idle-timeout 0

! -- Set an idle-timeout of infinity. 
! -- The "zero" option for dialer idle-timeout was introduced in 12.1(3)T.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1.


 peer default ip address pool DIALIN

! -- Clients are assigned addresses from the ip address pool named "DIALIN".

 no fair-queue
 ppp authentication chap callin
 ppp multilink
!
interface Dialer2
 description For Dialin ISDN Client - travis-soho-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 1 
! -- also uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 800-isdn-client

! -- Binds incoming calls from  user "800-isdn-client" to this dialer.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1. 

 peer default ip address pool DIALIN
 pulse-time 0
 ppp authentication chap callin
 ppp multilink
!
interface Dialer100
 description For Dialout Client - lanai-nas-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 50

! -- This dialer will draw resources from dialer pool 50 
! -- in which int serial 0:23 is the sole member.
! -- Since this dialer is used for dialout, 
! -- the outgoing call will be sent to interface se 0:23.

 dialer remote-name lanai-nas-01

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself 
! -- (which can be different from the router hostname).

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.

 dialer string 81690 class 56k

!--- Dial 81690 and use the map-class named "56k" (defined below).

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for traffic at which
! -- additional connections will be added to the MP bundle load level.
! -- Values range from 1 (unloaded) to 255 (fully loaded). 
! -- With a threshold of 1, additional links will be immediately 
! -- brought up and added to the bundle.

 dialer-group 3

! -- Apply interesting traffic definition from dialer-list 3.
! -- Note: the interesting traffic definition for outbound 
! -- calls is different than for incoming calls.

 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp.

!         
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159

! -- IP address pools for dialin clients.

ip classless
ip route 172.16.0.0 255.255.0.0 Dialer100

! -- Static route for the 172.16.0.0/16 network. 
! -- Interesting Traffic for that network
! -- will be sent to interface Dialer100 and the router 
! -- will initiate the outbound call.

no ip http server
ip pim bidir-enable
!
!
map-class dialer 56k

!-- map-class named "56k" that was used with the dialer string in int Dialer100.

 dialer isdn speed 56

! -- Set the speed of the call to be 56k (default is 64k).
! -- This may not be neccessary for your connection. Consult your telco
! --  to find out if you need to configure the dial speed to 56k.

access-list 101 remark Interesting traffic definition for dialin clients
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for dialin clients.

access-list 103 remark Interesting traffic for link lanai-nas-01
access-list 103 deny   eigrp any any
access-list 103 deny   udp any any eq ntp
access-list 103 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for the outbound dial.
! -- Eventhough the two interesting traffic definitions here are identical, 
! -- they can be changed depending on your traffic patterns.

dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to interface Dialer 1 & 2 using the command dialer-group 1.
!--- Note: The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1".

dialer-list 3 protocol ip list 103
!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17180029
ntp server 172.22.53.1
end

A configuração do perfil de discador acima tem uma interface do discador separada para cada chamada recebida e enviada. As interfaces de discador para chamadas recebidas são Dialer 1 e Dialer 2, enquanto a interface de discador para chamadas enviadas é Dialer100. Após a autenticação da chamada recebida, o roteador liga a chamada à interface de discagem apropriada, com base no nome remoto do discador. Somente a interface de discador para chamada de saída (Dialer100) possui série de discador com o número a ser discado. Somente Dialer100 inclui o comando dialer load-threshold, desde que pode discar os links adicionais segundo a carga de entrada ou de saída (o padrão é de partida).

A configuração a seguir utiliza grupos giratórios de discador para este cenário:

Servidor de acesso central com grupos giratórios
maui-nas-03#show running-config 
Building configuration...

Current configuration : 2436 bytes
!
! Last configuration change at 08:20:11 CDT Thu Oct 25 2001
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username lanai-nas-01 password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

! -- The configuration for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.

!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer rotary-group 1

! -- T1 0 is a member of rotary group 1.
! -- The rotary group configuration is in interface Dialer 1.
! -- Note: this command was not included in the dialer profile configuration.

 isdn switch-type primary-ni
 isdn bchan-number-order ascending
 no peer default ip address
 no cdp enable
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1

!--- Configuration for rotary group 1.
!--- The Dialer interface number (1) must exactly match rotary group number
!--- configured on the physical interfaces(interface Serial 0:23).

 ip unnumbered Ethernet0

! -- This dialer is unnumbered to ethernet 0.

 encapsulation ppp
 dialer in-band

! -- Enable this dialer interface to be a DDR interface.

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.
! -- If dialer in-band is used and a dialer idle-timeout is not defined, then 
! -- the default idle-timeout of 120 seconds (2min) will be applied.

 dialer map ip 172.16.1.1 name lanai-nas-01 speed 56 broadcast 81690

! -- Dialer map for the outbound dial. Add a dialer map for every router 
! -- that needs to be dialed. Inbound calls do not need dialer maps. 
! -- They will be dynmamically created.

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for Multlink PPP at 1/255.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
! -- Note: The specified dialer-group number must be the same as 
! -- the dialer-list number; in this example, defined to be "1". 

 peer default ip address pool DIALIN

! -- clients are assigned addresses from the ip address pool named "DIALIN".

 no cdp enable
 ppp authentication chap
 ppp multilink
 multilink max-links 5
!
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159
ip classless
ip route 172.16.0.0 255.255.0.0 172.16.1.1
ip route 172.16.1.1 255.255.255.255 Dialer1
no ip http server
ip pim bidir-enable
!
!
access-list 101 remark Interesting traffic definition
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

! -- Interesting traffic is defined by dialer-list 1.
! -- This is applied to interface Dialer 1 using dialer-group 1.
! -- The interesting traffic definition for inbound and outbound calls 
! -- is the same. If you want different interesting traffic definition 
! -- for inbound and outbound calls use dialer profiles.

!
line con 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17179882
ntp server 172.22.53.1
end

Na configuração de grupo giratório de discador, acima, a interface do discador tem um único mapa de discador usado para a discagem. Configure um mapa de discador para cada peer que precisar ser discado.

Nota: As chamadas recebidas não precisam de mapas de discador, pois são criadas dinamicamente. Pode ser verificado com o comando show dialer map. Um exemplo é mostrado abaixo:

maui-nas-03#show dialer map
Dynamic dialer map ip 172.22.53.152 name 1600-isdn-client () on Di1

! -- Dynamic dialer map for 1600-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Dynamic dialer map ip 172.22.53.151 name 800-isdn-client () on Di1

! -- Dynamic dialer map for 800-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Static dialer map ip 172.16.1.1 name lanai-nas-01 (81690) on Di1

! -- Static map configured on Dialer 1 was applied to this link 
! -- connected to lanai-nas-01.


Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

  • show isdn status - Garante que o roteador está se comunicando corretamente com o switch ISDN. Na saída, verifique se o status da camada 1 está ATIVO e se o estado de status da camada 2 = MULTIPLE_FRAME_ESTABLISHED é exibido. Esse comando exibe também o número de chamadas ativas.

  • show ppp multilink – Exibe informações em conjuntos multilink que estão ativos. Este comando deve ser utilizado para verificar a conexão multilink.

  • show dialer [interface type number] - Exibe informações de diagnóstico geral para interfaces configuradas para DDR. Se o discador surgir adequadamente, o estado do discador é uma mensagem de camada de link de dados que deve ser exibida. Se uma camada física aparecer, então o protocolo de linha será exibido, mas o Protocolo de controle de rede (NCP), não. Os endereços de origem e destino do pacote que iniciou a discagem são mostrados na linha de razão de discagem. Este comando show mostra a configuração do cronômetro e o tempo antes que a conexão expire.

  • show caller user username detail - Mostra parâmetros para o usuário particular, como endereço IP designado, PPP, parâmetros de pacote PPP, etc. Se sua versão de Cisco IOS Software não apoia este comando, use o comando show user.

  • show dialer map – Exibe os mapas configurados de discador dinâmicos e estáticos. Este comando pode ser utilizado para ver se um mapa de discador dinâmico foi criado. Sem um mapa de discadores, você não pode encaminhar pacotes.

Abaixo há algumas saídas de comandos show para chamadas bem-sucedidas. Preste atenção às seções em negrito e comentários fornecidos nas saídas. Compare a saída que você obtém com o resultado mostrado abaixo.

maui-nas-03#show isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    ! -- Layer 1 is ACTIVE and Layer 2 is MULTIPLE FRAME ESTABLISHED.

    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0

maui-nas-03#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 

! -- All channels are Inservice.


maui-nas-03#show user
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   

  Interface      User        Mode                     Idle     Peer Address
  Di100        lanai-nas- PPP   Bundle        00:00:35 172.16.1.1

  ! -- Connection to lanai-nas-01 uses int Dialer 100.

  Di2          800-isdn-c PPP   Bundle        00:00:22 172.22.53.154
  
! -- Connection to 800-isdn-client uses int Dialer 2.

  Di1          1600-isdn- PPP   Bundle        00:01:29 172.22.53.153
 
 ! --  Connection to 1600-isdn-client uses int Dialer 1.

  Se0:0        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:1        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:2        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:3        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:4        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:5        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:6        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:7        800-isdn-c Sync PPP                    -   Bundle: Di2
  Se0:8        800-isdn-c Sync PPP                    -   Bundle: Di2

  ! -- Two B-channels are connected to 800-isdn-client (Se0:7-Se0:8) and 
  ! -- 1600-isdn-client (Se0:2-Se0:3). Five other B-channels 
  ! -- (Se0:0-Se0:1 and Se0:4-Se0:6) are connected to lanai-nas-01.


maui-nas-03#show ppp multilink 

Dialer2, bundle name is 800-isdn-client

  ! -- int Dialer 2 controls multilink bundle to 800-isdn-client.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x8 received sequence, 0xC sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:7, since 00:00:16, last rcvd seq 000006
    Serial0:8, since 00:00:15, last rcvd seq 000007

  ! -- B-channels Se0:7 and Se0:8 are connected.


Dialer100, bundle name is lanai-nas-01

! -- int Dialer 100 controls multilink bundle to lanai-nas-01.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x33 received sequence, 0x33 sent sequence
  Member links: 5 (max not set, min not set)
    Serial0:0, since 00:02:08, last rcvd seq 000032
    Serial0:1, since 00:02:05, last rcvd seq 00002E
    Serial0:4, since 00:01:35, last rcvd seq 00002F
    Serial0:5, since 00:01:05, last rcvd seq 000030
    Serial0:6, since 00:00:35, last rcvd seq 000031

  ! -- B-channels Se0:0-Se0:1 and Se0:4-Se0:6 are connected.


Dialer1, bundle name is 1600-isdn-client

! -- int Dialer 100 controls multilink bundle to 1600-isdn-client.

  Bundle up for never
  0 lost fragments, 1 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x28 received sequence, 0x7B sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:2, since 00:06:24, last rcvd seq 000026
    Serial0:3, since 00:06:22, last rcvd seq 000027

 ! -- B-channels Se0:2 and Se0:3 are connected.


Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Troubleshooting de Recursos

Utilize os seguintes recursos para Troubleshooting conforme necessário:

Comandos para Troubleshooting

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer - Exibe informações de depuração de DDR sobre os pacotes recebidos em uma interface de discador. Estas informações podem ajudá-lo a assegurar que há tráfego interessante que pode utilizar a interface de discador.

  • debug isdn q931 – Exibe a configuração de chamada e alinhamento da conexão de rede ISDN (Camada 3).

  • debug ppp negotiation – Exibe informações sobre o tráfego PPP e alterações enquanto negocia o Protocolo de controle de enlace (LCP), autenticação e Protocolo de controle de rede (NCP). Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP e, em seguida, autenticará e, finalmente, negociará o NCP. Parâmetros multilink, como Maximum receive reconstructed unit (MRRU), são estabelecidos durante a negociação LCP.

  • debug ppp authentication - Exibe as mensagens de protocolo de autenticação PPP, incluindo os intercâmbios do pacote CHAP e intercâmbios de protocolo de autenticação de senha (PAP).

  • debug ppp error - Exibe erros do protocolo e estatísticas de erros associados à negociação e operação da conexão PPP

Abaixo há saídas de depuração para uma chamada de saída bem-sucedida. Preste atenção às seções em negrito e comentários fornecidos nas saídas. Compare a saída que você obtém com o resultado mostrado abaixo.

maui-nas-03#debug dialer
Dial on demand events debugging is on
maui-nas-03#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-nas-03#debug ppp authentication
PPP authentication debugging is on
maui-nas-03#debug isdn q931
ISDN Q931 packets debugging is on

maui-nas-03#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Oct 24 12:56:16.205 UTC: Se0:23 DDR: rotor dialout [priority]
Oct 24 12:56:16.205 UTC: Se0:23 DDR: Dialing cause ip 
(s=172.22.53.150, d=172.16.1.1)

! -- The dialing cause is a ping for 172.16.1.1. 
! -- ICMP is tagged as interesting.

Oct 24 12:56:16.205 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:16.205 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0063

! -- Outgoing ISDN Q.931 SETUP message.

Oct 24 12:56:16.205 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:16.205 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.209 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:16.241 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8063
Oct 24 12:56:16.241 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.285 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8063

! -- Received Q.931 CONNECT message.

Oct 24 12:56:16.297 UTC: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
Oct 24 12:56:16.297 UTC: Se0:0: interface must be fifo queue, force fifo
Oct 24 12:56:16.297 UTC: %DIALER-6-BIND: Interface Se0:0 bound to profile Di100
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Treating connection as a callout
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Phase is ESTABLISHING, 
Active Open [0 sess, 1 load]
Oct 24 12:56:16.301 UTC: Se0:0 LCP: O CONFREQ [Closed] id 12 len 33
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.301 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0063
Oct 24 12:56:16.317 UTC: Se0:0 LCP: I CONFREQ [REQsent] id 10 len 34
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.321 UTC: Se0:0 LCP: O CONFACK [REQsent] id 10 len 34
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: I CONFACK [ACKsent] id 12 len 33
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: State is Open

! -- LCP negotation is complete.

Oct 24 12:56:16.325 UTC: Se0:0 PPP: Phase is AUTHENTICATING, 
by both [0 sess, 1 load]
Oct 24 12:56:16.325 UTC: Se0:0 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:16.337 UTC: Se0:0 CHAP: I CHALLENGE id 10 len 33 from "lanai-nas-01"
Oct 24 12:56:16.341 UTC: Se0:0 CHAP: O RESPONSE id 10 len 32 from "maui-nas-03"
Oct 24 12:56:16.353 UTC: Se0:0 CHAP: I SUCCESS id 10 len 4
Oct 24 12:56:16.357 UTC: Se0:0 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:16.361 UTC: Se0:0 CHAP: O SUCCESS id 8 len 4

! -- Two-way CHAP authentication is successful.

Oct 24 12:56:16.361 UTC: Se0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 DDR: Authenticated host lanai-nas-01 
with no matching dialer map
Oct 24 12:56:16.361 UTC: Di100 PPP: Phase is UP [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 IPCP: O CONFREQ [Closed] id 6 len 10
Oct 24 12:56:16.361 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.361 UTC: Di100 CDPCP: O CONFREQ [Closed] id 6 len 4
Oct 24 12:56:16.365 UTC: Di100 MLP: Added first link Se0:0 to bundle lanai-nas-01
Oct 24 12:56:16.365 UTC: Di100 PPP: Treating connection as a callout
Oct 24 12:56:16.377 UTC: Di100 IPCP: I CONFREQ [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.377 UTC: Di100 IPCP: O CONFACK [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.381 UTC: Di100 IPCP: I CONFACK [ACKsent] id 6 len 10
Oct 24 12:56:16.381 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.381 UTC: Di100 IPCP: State is Open
Oct 24 12:56:16.381 UTC: Di100 DDR: dialer protocol up
Oct 24 12:56:16.381 UTC: Di100 IPCP: Install route to 172.16.1.1

! -- A route to the peer is installed.

Oct 24 12:56:17.361 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, 
changed state to up
Oct 24 12:56:19.113 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Second call is being dialed.

Oct 24 12:56:19.113 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:19.113 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0064
Oct 24 12:56:19.113 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:19.113 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.113 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:19.141 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8064
Oct 24 12:56:19.141 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.205 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8064
Oct 24 12:56:19.217 UTC: %LINK-3-UPDOWN: Interface Serial0:1, 
changed state to up
Oct 24 12:56:19.217 UTC: Se0:1: interface must be fifo queue, force fifo
Oct 24 12:56:19.217 UTC: %DIALER-6-BIND: Interface Se0:1 bound to profile Di100
Oct 24 12:56:19.217 UTC: %ISDN-6-CONNECT: 
Interface Serial0:0 is now connected to 81690 lanai-nas-01
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Treating connection as a callout
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]
Oct 24 12:56:19.221 UTC: Se0:1 LCP: O CONFREQ [Closed] id 14 len 33
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 
(0x0506E384B037)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.221 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  
callref = 0x0064
Oct 24 12:56:19.241 UTC: Se0:1 LCP: I CONFREQ [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.241 UTC: Se0:1 LCP: O CONFACK [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: I CONFACK [ACKsent] id 14 len 33
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 (0x0506E384B037)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: State is Open
Oct 24 12:56:19.245 UTC: Se0:1 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load]
Oct 24 12:56:19.245 UTC: Se0:1 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:19.257 UTC: Se0:1 CHAP: I CHALLENGE id 11 len 33 from "lanai-nas-01"
Oct 24 12:56:19.261 UTC: Se0:1 CHAP: O RESPONSE id 11 len 32 from "maui-nas-03"
Oct 24 12:56:19.273 UTC: Se0:1 CHAP: I SUCCESS id 11 len 4
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: O SUCCESS id 8 len 4
! -- Authentication is successful.
Oct 24 12:56:19.281 UTC: Se0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:19.281 UTC: Di100 MLP: Added link Se0:1 to bundle lanai-nas-01

! -- The link is added to the Multilink bundle.

Oct 24 12:56:20.281 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:1, changed state to up
Oct 24 12:56:25.221 UTC: %ISDN-6-CONNECT: Interface Serial0:1 
is now connected to 81690 lanai-nas-01
Oct 24 12:56:49.117 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Third call is being dialed.

Oct 24 12:56:49.117 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:49.117 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0065
Oct 24 12:56:49.117 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:49.117 UTC:         Channel ID i = 0xA98385
Oct 24 12:56:49.117 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
...
...

! -- Output Omitted.

...
Oct 24 12:56:49.261 UTC: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:49.261 UTC: Di100 MLP: Added link Se0:4 to bundle lanai-nas-01

! -- The 3rd link is added to the bundle.

Oct 24 12:56:50.261 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:4, changed state to up
Oct 24 12:56:55.198 UTC: %ISDN-6-CONNECT: Interface Serial0:4 
is now connected to 81690 lanai-nas-01  
...
...
...

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 6435