WAN : Point-to-Point Protocol (PPP)

Configuração do Access Server Dial-In IP/PPP com V.120 PPP dedicado

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o discado IP/PPP do servidor de acesso V.120 dedicado PPP

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 11.2 ou Mais Recente do ½ do ¿  de Cisco IOSïÂ, para V.120 com interfaces assíncronas virtuais.

  • Cisco IOS Software Release 11.3 ou Mais Recente, para V.120 com moldes virtuais.

  • Imagem do Empreendimento Cisco IOS para configurar mais de cinco linhas VTY.

Use a ferramenta de aconselhamento de software (clientes registrados somente) para determinar que grupos dos recursos do Cisco IOS Software apoiam a funcionalidade de V.120. Dentro da ferramenta, selecione as seguintes características: Suporte V.120, Conversão de protocolo, e moldes virtuais para a Conversão de protocolo. Se você exige recursos adicionais, selecione-os como necessário.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A recomendação V.120 do Setor de Padronização de Telecomunicação da União de Telecomunicação Internacional (ITU-T), permite o transporte confiável de dados transparentes síncronos, assíncronos, ou mordidos sobre os canais de portador ISDN.

Uma conexão de V.120 pode reagir do PPP ou o modo não-PPP. Isto é porque muitos adaptadores terminal de V.120 são similares ao Modems, e apoia algum em conjuntos de comandos. O modo não-PPP pode ser usado para verificar se a instalação de V.120 está correta no cliente e no roteador. O PPP pode então ser configurado nesse link. Veja a verificação V.120 na seção do modo não-PPP para mais informação.

Há dois métodos principais para executar V.120:

  • Interfaces assíncronas virtuais

    Usando o Cisco IOS Software, você pode configurar recursos de protocolo assíncrono, tais como o PPP e o SLIP, em linhas VTY. O PPP e o SLIP funcionam normalmente somente em interface assíncrono, não em linhas VTY. Quando você configura uma linha VTY para apoiar recursos de protocolo assíncrono, você está criando interfaces assíncronas virtuais nas linhas VTY. Uma interface assíncrona virtual (igualmente conhecida como VTY-Assíncrono) é criada às chamadas de suporte que inscrevem o roteador através de uma interface não física. Por exemplo, os atendimentos do córrego do caractere assíncrono terminam, ou terra em interfaces não física. As interfaces assíncronas virtuais não são usuário configurável; um pouco, são criados dinamicamente, e por encomenda para baixo rasgado.

  • Moldes virtuais

    A aplicação do Virtual-molde apoia o Tunelamento do PPP, usando uma Conversão de protocolo do pas-de-deux. Quando um usuário de V.120 disca dentro através de uma linha de terminal virtual, o roteador cria uma interface de acesso virtual. A interface de acesso virtual é uma relação provisória que apoie a configuração do protocolo assíncrono especificada no molde de interface virtual. Essa relação é criada dinamicamente clonando a interface de molde virtual na configuração. Esta interface de acesso virtual está livrada acima de assim que a conexão deixar cair. O Virtual-molde é mais flexível, porque dá mais opções de configuração do que a aplicação Virtual-assíncrona limitada.

Como o V.120 afeta o desempenho do roteador

Cisco não recomenda que você executa o PPP sobre V.120 em Micamodem, porque o processamento de V.120 é extremamente processo intensivo de cpu. Um Cisco AS5200 não pode segurar muitas conexões PPP simultaneamente ativas de V.120. O outro Roteadores do AS5xxx pode segurar mais simultaneamente conexões PPP ativas de V.120. Como uma alternativa, Cisco recomenda configurar o adaptador terminal de ISDN do cliente (TA) para fazer de “a conversão de PPP sincronização-à-Assíncrono” de modo que a conexão entre o servidor do acesso de rede (NAS) como o sincronismo normal PPP em vez de V.120.

Contudo, com modens Nextport, uns novos recursos foram adicionados, fora-carga V.120 chamam ao processador do sinal digital do modem (DSP). Se você usa o Cisco IOS Software Release 12.2 XB (e 12.2(11)T e mais tarde), é possível terminar V.120 chama o NextPort DSP em vez do CPU. Para mais informação, veja a terminação de sessões de V.120 no NextPort DSP.

Por que implementar PPP em V.120?

O PPP sobre V.120 é processo intensivo de cpu. Consequentemente, Cisco desanima uma implementação extensiva. Contudo você pode querer executar o PPP sobre V.120 para as seguintes razões:

  • Você está usando um adaptador terminal (TA) que seja anexado a um equipamento de terminal dos dados assíncronos (DTE), e não pode fazer a conversão de PPP de sincronização-à-Assíncrono. Neste caso, você deve usar V.120.

  • A configuração padrão do seu TA é V.120, e você é incapaz de reconfigurar seu TA sem o auxílio de seu provedor de serviço do Internet (ISP).

  • O aplicativo quer mandar a sessão de PPP partir com um diálogo de terminal da célula de caractere (por exemplo, um desafio da senha de uma vez e uma resposta especiais), assim que você não quer uma sessão de PPP de sincronismo puro.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Esta seção igualmente descreve a aplicação para VTY-Assíncrono e moldes virtuais.

Nota: Estas etapas supõem que o NAS está configurado corretamente para o acesso básico ISDN ou de discagem assíncrona, e que o cliente está configurado corretamente para o PPP sobre V.120.

Interfaces virtual-assíncronas (vty-async)

Para executar VTY-Assíncrono, termine estas etapas:

  1. Crie interfaces assíncronas virtuais usando o comando global configuration de VTY-Assíncrono.

  2. Configurar a autenticação para a conexão de VTY-Assíncrono. Use VTY-Assíncrono ppp authen {rachadura | comando pap}.

  3. Configurar outros parâmetros de VTY-Assíncrono como, temporizadores de keepalive, tamanho MTU, compressão de cabeçalhos, e assim por diante, como necessário, para sua instalação. Refira a Conversão de protocolo e os comandos virtual asynchronous device para mais informação.

  4. Configurar a detecção automática do encapsulamento de V.120 usando o comando autodetect encapsulation v120 ppp. Este comando deve ser aplicado à interface física da chamada recebida (por exemplo, relação BRI0, série 1:23 da relação). Contudo, se V.120 de chamada TA sinaliza corretamente V.120 no campo de baixo nível SETUP Q.931 da compatibilidade, o encapsulamento autodetect não é precisado. Infelizmente, muitos TA não fazem este.

  5. Desabilite a alerta do nome de usuário e senha sob a configuração de linha VTY. Você pode fazer este não configurando nenhum início de uma sessão e nenhuma senha no modo de configuração de linha VTY. Se você está usando o AAA, defina uma lista que tenha o método nenhuns e aplique-a então à relação VTY. Por exemplo:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configurar o comando autocommand ppp default no modo de configuração de linha VTY. Sem a autenticação de login e o comando automático ppp, os novatos PPP VTY assim que uma conexão de V.120 entrar. Isto permite que o par de V.120 comece negociações de PPP imediatamente, sem ter que executar um script, ou incorpora o nome de usuário e senha a uma janela terminal. O comando autoselect não é apoiado em VTY.

    Nota: Desde que os VTY começam executar o PPP assim que a conexão for estabelecida, você não poderá emitir o comando telnet no NAS para propósitos administrativos. Para obter em torno desta limitação, aplicar o comando transport input v120 nos VTY usados para as conexões PPP de V.120, e aplicar o comando transport input telnet naquelas usadas para o telnet administrativo.

Moldes virtuais

Para executar moldes virtuais, termine estas etapas:

  1. Crie e configurar um molde de interface virtual usando o comando interface virtual-template. Configurar esta interface virtual apenas porque você configuraria uma interface serial assíncrona regular. Para fazer assim, atribua ao molde de interface virtual o endereço IP de Um ou Mais Servidores Cisco ICM NT de uma interface ativa (que usa o comando ip unnumbered interface), e configurar o endereçamento, apenas porque você o configuraria em um interface assíncrono. Você pode igualmente incorporar os comandos ao modo de configuração da interface que comprimem cabeçalhos de TCP ou configuram a autenticação do protocolo de autenticação de cumprimento do desafio (RACHADURA) para o PPP. Por exemplo:

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. Crie interfaces assíncronas virtuais usando o comando global configuration de VTY-Assíncrono.

  3. Configurar linhas de terminal virtual para suportar funções do protocolo assíncrono, com base na definição de um molde de interface virtual. Você pode fazer este que usa o comando vty-async virtual-template number no modo de configuração global. Por exemplo:

    vty-async
    vty-async Virtual-Template 1
  4. Configurar a detecção automática do encapsulamento de V.120 usando o comando autodetect encapsulation v120 ppp. Aplique este comando à interface física da chamada recebida (por exemplo, relação BRI0, série 1:23 da relação). Contudo, se V.120 de chamada TA sinaliza corretamente V.120 no campo de baixo nível SETUP Q.931 da compatibilidade, o encapsulamento autodetect não é exigido. Infelizmente, muitos TA não fazem este.

  5. Desabilite a alerta do nome de usuário e senha sob a configuração de linha vty. Faça isto não configurando nenhum início de uma sessão e nenhuma senha no modo de configuração de linha vty. Se você está usando o AAA, defina uma lista que tenha o método nenhuns e aplique-a então à relação vty. Por exemplo:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configurar o comando autocommand ppp default no modo de configuração de linha vty. Sem a autenticação de login e o comando automático ppp, os VTY inicia PPP assim que uma conexão de V.120 entrar. Isto permitirá que o par de V.120 comece negociações de PPP imediatamente, sem ter que executar um script ou incorporar o nome de usuário e senha a uma janela terminal. Note que o comando autoselect não está apoiado em VTY.

    Nota: Desde que os VTY começam executar o PPP assim que a conexão for estabelecida, você não poderá emitir o comando telnet no NAS para propósitos administrativos. Para obter em torno desta limitação, aplicar o comando transport input v120 nos VTY usados para as conexões PPP de V.120, e aplicar o comando transport input telnet naquelas usadas para o telnet administrativo.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/6306/28a.gif

Configurações

Este documento utiliza esta configuração:

  • Cisco AS5200 que apoia o IP do discado ou os clientes PPP para ISDN síncrono PPP (não o multilink), PPP assíncrono, e V.120 PPP.

Esta configuração usa o método das interfaces assíncronas virtuais (VTY-Assíncrono) descrito acima.

V.120 (PPP) com interfaces assíncronas virtuais
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a rota IP — indica as entradas de tabela de IP Routing.

  • usuários da mostra — informação dos indicadores sobre as linhas ativa do servidor de rede, incluindo o número de linha, os nomes de conexão, e o local de terminação.

Verifique a conexão de V.120

Para verificar a conexão de V.120, termine estas etapas:

  1. Use o debug v120, e gerencia um atendimento entrante de V.120. Você deve ver este resultado do debug no NAS:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    Se esta mensagem não aparece, a chamada recebida não era provavelmente V.120, e daqui o roteador não o detectou como tal.

  2. Verifique se a relação de VTY-Assíncrono vem acima. Se sua configuração usa V.120 com moldes virtuais, verifique se uma interface de acesso virtual esteja criada. Na seguinte saída do console log, o a relação de VTY-Assíncrono 32 está acima:

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. O uso debuga a negociação ppp e debuga a autenticação de PPP. para assegurar-se de que os parâmetros PPP estejam negociados corretamente. Para obter mais informações sobre do PPP debugging, veja a tecnologia dialup: Técnicas para Troubleshooting.

  4. Execute uma rota da mostra IP e mostre usuários para certificar-se do atendimento de V.120 esteja estabelecido corretamente.

Os exemplos seguintes são saídas de uma instalação onde nós não tenhamos moldes virtuais de V.120:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

Nota: O atendimento é conectado na relação VTY-Assíncrono 32, e há uma rota ao cliente.

Nota: O endereço IP de Um ou Mais Servidores Cisco ICM NT do lado NAS do link será aquele dos Ethernet ou da interface rápida de Ethernet no NAS, ao usar não a opção de configuração de molde virtual. Daqui verifique se o Ethernet ou a interface rápida de Ethernet são ascendente e podem ser sibilados.

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

Nota: O atendimento é conectado na relação VTY-Assíncrono 32, e o endereço IP do peer é especificado.

Se você usa a opção do Virtual-molde com V.120 a saída da rota da mostra IP e do usuário da mostra aparece como esta:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

Nota: O atendimento é conectado no acesso virtual 1 da relação, e há uma rota ao cliente.

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

Nota: O atendimento é conectado no acesso virtual 1. da relação.

Verifique V.120 no modo não-PPP

Muitos adaptadores terminal de V.120 são similares ao Modems, e apoiam algum em conjuntos de comandos. Daqui, você pode usar o modo não-PPP para verificar se V.120 setup no cliente e o roteador estão corretos. Você pode então configurar o PPP nesse link. Testar V.120 permite por si só que nós pesquisem defeitos problemas relacionados de V.120 sem adicionar a complexidade do PPP.

Para testar a conexão de V.120 no modo não-PPP, termine estas etapas:

  1. Permita a alerta do nome de usuário e senha sob a configuração de linha vty. Use o comando login permitir o início de uma sessão. Use o comando password password ajustar a senha de linha. Se você está usando o AAA, remova o comando list da autenticação de login sob o vty.

  2. Remova o comando autocommand ppp default no modo de configuração de linha vty. Por exemplo:

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. Gire sobre o debug v120, e inicie um atendimento do cliente. O roteador deve indicar este:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. Continue o resto da configuração de V.120. Termine as etapas descritas na seção configurar.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos de Troubleshooting (Opcional)

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes que você emita comandos debug, refira a informação importante em comandos Debug para mais informação.

  • o debug v120 — indica quando o processamento de V.120 é começado ou terminado, e a relação em que ele está sendo executado.

  • debugar a negociação ppp — informação dos indicadores no tráfego e nas trocas PPP, ao negociar os componentes de PPP que incluem o protocolo de controle de link (LCP), a autenticação, e o NCP. Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP, autenticará e, finalmente, negociará o NCP (normalmente IPCP).

  • debugar a autenticação de PPP — indica os mensagens de protocolo da autenticação de PPP, incluindo intercâmbios de pacotes da RACHADURA e trocas do protocolo password authentication (PAP).


Informações Relacionadas


Document ID: 6306