Discar e acessar : Conexões assíncronas

Configurando WINS, DNS e DHCP em servidores de acesso

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Determinados clientes de discagem exigem o Serviço de Cadastramento na Internet do Windows (WINS, Windows Internet Naming Service), e/ou o Sistema de Nome de Domínio (DNS, Domain Naming System) a fim de conectar corretamente à rede. Há também vários mecanismos diferentes para a entrega de endereços IP para clientes dialin nos servidores de acesso.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

Componentes Utilizados

Essa configuração foi desenvolvida e testada usando estes equipamentos/dispositivos:

  • Cisco AS5200 com dois circuitos T1 PRI

  • Servidor DNS

  • Servidor WINS

  • Servidor DHCP para atribuir endereços IP ao cliente

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esses comandos de configuração de DNS, DHCP e WINS podem ser usados em qualquer roteador que suporte chamadas PPP recebidas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Material de Suporte

Algumas opções possíveis para atribuir endereços IP aos clientes incluem:

  • Atribuir um endereço do conjunto IP local no servidor de acesso.

  • Utilizando um servidor DHCP (Dynamic Host Control Protocol) externo.

  • Utilizando o RADIUS (Serviço de Usuário de Discagem de Autenticação Remota) ou o TACACS+ (Sistema de Controle de Acesso do Controlador de Acesso do Terminal).

Este documento descreve o procedimento para passar informações de servidores WINS e DNS para o cliente de linha telefônica por meio do servidor de acesso. O servidor de acesso também transmitirá o endereço IP retornado por um servidor DHCP externo ao cliente de discagem.

Para obter mais informações, consulte os documentos na seção Informações Relacionadas deste documento

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/6303/winsdhcp.gif

Configurações

Esse AS5200 Access Server está configurado com duas Interfaces de Taxa Primária (PRIs) para permitir usuários assíncronos recebidos e usuários de ISDN. Os mapas de discadores dinâmicos são criados para usuários ISDN. Sem o TACACS+ ou o RADIUS configurados, um nome de usuário e uma senha devem ser configurados para cada usuário que precisa de acesso de discagem. Todos os endereços IP são entregues ao cliente pelo servidor DHCP. O servidor de acesso passa o endereço IP dos servidores DNS e WINS ao cliente durante a negociação do PPP IP Control Protocol (IPCP).

AS5200 Access Server
version 11.1
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service udp-small-servers
no service tcp-small-servers
!
hostname as5200
!
enable password letmein
!
username Jason password foo
username Laura password bar
username Russ password fake
username Syed password pseudo
username Tito password knockknock
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.16.209.65 255.255.255.192
!
interface Loopback1
 ip address 172.16.209.129 255.255.255.192
!
interface Ethernet0
 ip address 172.16.162.4 255.255.255.0

!
interface Serial0
 no ip address 
!
interface Serial1
 no ip address
!
interface Serial0:23
 no ip address
 isdn incoming-voice modem
 dialer rotary-group 1
 encapsulation ppp
 no fair-queue
!
interface Serial1:23
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn incoming-voice modem
 no fair-queue
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address dhcp

! -- Async dialup users will be assigned ip addresses from 
! -- the dhcp server. The dhcp server is specified with the
! -- ip dhcp-server command shown below.
! -- Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast 
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below.
! -- Refer to the section Command Summary for more information.

 ppp authentication chap
 group-range 1 48
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 peer default ip address dhcp

! -- ISDN dialup users will be assigned ip addresses from the dhcp server.
! -- The dhcp server specified with the ip dhcp-server command shown 
! -- below. Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast  
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below. 
! -- Refer to the section Command Summary for more information.

 dialer in-band
 dialer idle-timeout 300
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
router eigrp 222
 redistribute connected
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
async-bootp dns-server 172.16.224.100 172.16.154.101

! -- Specifies the primary and secondary DNS servers.
! -- The first IP address belongs to the primary DNS server.
! -- If you only have one DNS server you do not need to specify 
! -- a secondary DNS server.
! -- Refer to the section Command Summary for more information.

async-bootp nbns-server 172.16.224.10 172.16.4.2 

! -- Specifies the primary and secondary WINS  servers.
! -- The first IP address belongs to the primary WINS server.
! -- If you only have one WINS server you do not need to specify 
! -- a secondary WINS server.
! -- Refer to the section Command Summary for more information.

ip dhcp-server 172.16.162.10

! -- Specifies the dhcp server ip address. This command is required
! -- if the IP address for dialin clients is obtained from the server.
! -- Note: The dhcp server need not be on the same subnet as the 
! -- Ethernet interface. 
! -- It can be more than one hop away as long has it is reachable.

!
line con 0
 login 
line 1 48
modem InOut
transport input telnet
 autoselect during-login
 autoselect ppp
 flowcontrol hardware
line aux 0
line vty 0 4
 password secret
 login 
!
end

Resumo de comandos

Esta é uma descrição dos comandos relevantes para DHCP, DNS e WINS em servidores de acesso:

Verificar

Para verificar se o cliente recebeu corretamente os parâmetros apropriados do Servidor de Acesso, será necessário testar a partir do cliente.

Por exemplo, a partir do cliente, execute um ping para um endereço de DNS que pode ser resolvido, como www.cisco.com. Se o servidor DNS resolver o endereço, a configuração está funcionando corretamente. Para testar a atribuição de servidores WINS, use a rede do Windows para navegar na rede.

Use o comando show dialer map depois que uma conexão ISDN é estabelecida para ver se um mapa de discador dinâmico foi criado. Sem isso, você não pode executar o roteamento. Você deve ver um endereço atribuído ao peer (o endereço foi obtido do servidor DHCP). Isso verifica se a atribuição de endereços DHCP foi bem sucedida.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Este documento supõe que as Camadas 1, 2 e 3 do ISDN estejam funcionando corretamente. Se você tiver problemas com versões de camada inferior de ISDN. Consulte o documento Utilizando o Comando show isdn status para o Troubleshooting de BRI para obter mais informações.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debug ppp authentication - Para ver se um cliente foi aprovado na autenticação. Se você está usando uma versão antes do Software Release 11.2 de Cisco IOS�, use o comando debug ppp chap pelo contrário.

  • debug ppp negotiation - Para ver se um cliente está passando a negociação PPP; isto ocorre quando você verifica a negociação de endereço. A negociação IPCP mostra que as informações do DNS e do servidor WINS estão sendo transmitidas ao cliente

  • debug ppp error – Para exibir erros do protocolo e estatísticas de erros associados à negociação e operação da conexão PPP

A atribuição dos servidores DNS e WINS pode ser vista na fase de IPCP da negociação do PPP. Um exemplo de saída é fornecido abaixo.

Exemplo de debug

Esta saída do comando debug ppp negotiation (para um atendimento do discagem assíncrona) mostra a negociação de IPCP para o cliente. Neste exemplo, somente um servidor DNS principal foi especificado. O servidor WINS não é transmitido para o cliente.

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
from "maui-nas-02"
Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
from "async_user"
Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]

! -- IPCP negotiation begins

Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2

! -- The IP address for the client is assigned.

Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
id 1 len 15
Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
0x00000001 
(0x120600000001)
Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
EXTENDED 
(0x1105000104)
Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
protocol CCP
Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
Sep 26 12:50:47.483: As97 LCP:  (0x04)
Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
using 172.22.60.2
Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)

! -- The IP address of the client and Primary DNS server's 
! -- IP address are negotiated.

Sep 26 12:50:50.687: As97 IPCP: State is Open

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 6303