Cisco Interfaces and Modules : Adaptadores de serviço da Cisco

Configuração e vista geral do módulo de roteador para a família do catalizador 4500/4000 (WS-X4232-L3)

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento descreve o módulo de roteador WS-X4232-L3 para os switches das séries Cisco Catalyst 4500/4000. Além de uma descrição da arquitetura e da configuração do WS-X4232-L3, este documento também fornece uma configuração de exemplo que usa um switch da série Catalyst 4500/4000 e o módulo de roteador.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Liberação do OS do Cisco catalyst (CatOS) 5.5(1) ou mais atrasado

  • Software Release 12.0(7)W5(15d) de Cisco IOS�

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

O nome de arquivo da imagem do Cisco IOS Software para o WS-X4232-L3 começa com o "cat4232-". Você pode encontrar o arquivo o na seção do Catalyst 4232 da área do software da transferência (clientes registrados somente) para o software de LAN switching.

Nota: Há um apoio para o módulo de roteador quando você o usa conjuntamente com o Supervisor Engine 1 e o Supervisor Engine 2. Contudo, não há nenhum apoio para o módulo de roteador quando você o usa conjuntamente com o Supervisor Engine 2+, 3, 4, ou 5.

Nota: Refira a seção das características da nota de instalação e de configuração para o Módulo de serviços da camada 3 do catalizador 4000 para obter mais informações sobre dos recursos de software que têm o apoio no módulo de roteador (WS-X4232-L3).

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Visão geral da arquitetura

O módulo WS-X4232-L3 tem 32 portas de Ethernet rápidas e duas portas de Ethernet Gigabit.

Estas duas portas de Ethernet Gigabit correspondem ao gigabit 1 das relações e ao gigabit 2 na configuração de roteador. Estas portas de Gigabit Ethernet são portas roteadas.

Internamente, o módulo tem duas interfaces Gigabit Ethernet (gigabit 3 e gigabit 4) que conectam o roteador ao backplane do interruptor. O backplane do interruptor usa as primeiras duas portas nesse entalhe para conectar ao módulo de roteador. Quando você introduz o módulo WS-X4232-L3 no entalhe 3, as interfaces Gigabit Ethernet 3 e 4 conectam ao backplane as portas 3/1 e 3/2. As portas 3/1 e 3/2 são portas da camada 2 com configuração no Supervisor Engine do interruptor. As interfaces Gigabit Ethernet 3 e 4 são portas da camada 3 com configuração no módulo de roteador.

Há 32 portas Fast Ethernet no módulo do roteador. Estas portas são portas da camada 2 e não executam nenhumas funções da camada 3. Embora as portas tenham um local físico no módulo de roteador, você deve configurar as portas no Supervisor Engine do interruptor.

Este diagrama fornece uma explicação visual da arquitetura. Para esta instalação, instale o módulo de roteador no entalhe 2 do Catalyst Switch.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-a.gif

Configuração do WS-X4232-L3

Supervisor Engine

O comando show port indica as duas portas de gigabit e as 32 portas do 10/100 Mbps com os números 1 a 34.

Nota: As duas portas de gigabit que você vê do Supervisor Engine não são as duas portas que você vê no painel dianteiro. As portas que você vê do Supervisor Engine são as duas portas comutadas que conectam ao motor da rota. Você precisa de configurar as portas física como portas de switch. Esta configuração é similar à configuração do módulo multilayer switch (MS) no Catalyst 6500/6000 series switch. Mais a configuração comum para estas portas é ajustá-las como o Gigabit EtherChannel (GEC) e o entroncamento. Esta maneira, você pode distribuir entre todos os VLAN no roteador.

Nota: Você pode alcançar o módulo de roteador do Supervisor Engine se você emite o comando session module-. Esta ação é similar alcançar do módulo de switch de rota (RS) em um Series Switch do Catalyst 5500/5000.

Router

Se você vê uma alerta de roteador, procure quatro interfaces Gigabit Ethernet com os números de 1 a 4 (gigabit 1, gigabit 2, gigabit 3, e gigabit 4) e uma relação fora da banda do Fast Ethernet.

Esta é a configuração padrão:

Router#show run 
Building configuration...  

Current configuration:  
!  
version 12.0  
service config  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname Router  
!  
!  
ip subnet-zero  
!  
!  
!  
interface FastEthernet1  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface gigabitEthernet1  
 no ip address  
 no ip directed-broadcast 

!--- Output suppressed.

Nota: Nesta configuração, o gigabit 3 e o gigabit 4 são as conexões que vai ao backplane. O gigabit 1 e o gigabit 2 são as portas de usuário no painel dianteiro (portas roteada). Na maioria das vezes, como em um MS, você configura a porta 3 e a porta 4 para ser parte do mesmo Canal de porta da relação. Também, você configura subinterfaces nesse canal (com encapsulamento do [ISL] ou do IEEE 802.1Q do protocolo inter-switch link). Como no MS, a configuração de gigabit 3 e o gigabit 4 no módulo de roteador precisam de ser consistentes com a configuração da porta slot/1 e o slot/2 no lado do interruptor. Você pode verificar o tráfego entre o roteador e o interruptor se você emite os comandos show interface port-channel ou show interface gigabitethernet.

Suporte da lista de acesso no WS-X4232-L3

Há um apoio para o Access Control Lists (ACLs) no módulo de roteador WS-X4232-L3, mas a configuração de exemplo que este documento discute não apoia ACL. Refira configurar ACL no módulo de roteador WS-X4232-L3 para o Catalyst 4000 Family para obter mais informações sobre das configurações ACL com apoio para o módulo WS-X4232-L3.

Configurações de exemplo

A configuração de exemplo contém os elementos nesta lista. (Veja o diagrama da rede.)

  • Golpe — O 4500/4000 Series de um catalizador comuta com um módulo de roteador no entalhe 3.

  • Liki — Um roteador que anexe ao Gigabit Ethernet 1 no módulo de roteador.

  • Donald — Um roteador que anexe no VLAN2 na porta 3/3 do golpe. A porta 3/3 é uma das portas da camada 2 do módulo de roteador.

  • Daniella — Um roteador que anexe no VLAN3 na porta 2/3 do golpe.

Esta configuração inclui uma conexão de GEC entre o módulo de roteador e o 4500/4000 Series do catalizador comute. Você configura o entroncamento no GEC para permitir que os vlan múltiplos passem ao roteador para o roteamento de interVLAN. Esta configuração GEC é a configuração padrão. Todos os comandos específicos a essa configuração são movidos para as subinterfaces de canal de porta.

Quando você usa o módulo da camada 3, recorde que todo o tráfego que alcança o roteador no VLAN nativo está distribuído no software. Esta situação tem um efeito adverso no desempenho do interruptor. O microcódigo no WS-X4232-L3 não processa os pacotes do 802.1Q que vêm dentro no VLAN nativo sem etiquetas. Em lugar de, os pacotes vão ao CPU, e aos processos de CPU os pacotes. Este resultados do processo na utilização elevada da CPU se o CPU recebe pacotes sem etiquetas em uma taxa alta nas subinterfaces do VLAN nativo. , Crie consequentemente um manequim VLAN (que não contém nenhum tráfego de usuário) como o VLAN nativo. Neste exemplo de configuração (o diagrama da rede), o VLAN99 serve como o VLAN nativo. Configurar somente o VLAN nativo no GEC entre o roteador e o interruptor. Não configurar nenhuma outra portas no interruptor neste manequim VLAN.

Nota: Crie um manequim VLAN como o VLAN nativo nos enlaces de tronco entre o roteador e o interruptor. O CPU distribui no software todo o tráfego que envia sobre o VLAN nativo, que tem um efeito adverso no desempenho do interruptor. Crie um VLAN adicional que você não use em qualquer outro lugar na rede e faça a este VLAN o VLAN nativo para os enlaces de tronco entre o roteador e o interruptor.

Diagrama de Rede

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-b.gif

As seções da configuração e de configuração de módulo de roteador do Supervisor Engine do interruptor desta documentam as configurações e a saída atuais de alguns comandos show. As configurações estão no Supervisor Engine do 4500/4000 Series do catalizador comutam e o módulo de roteador. Isto reserva distribuir entre as três sub-redes (VLAN1, VLAN2, e roteador que anexa ao Gigabit Ethernet 1).

Comute a configuração do Supervisor Engine

A placa de switch de roteador mostra 34 portas no comando show module. Estas 34 portas incluem 32 portas comutadas ao painel dianteiro e a 2 portas comutadas de gigabit que conectam diretamente a duas das portas de roteador. Está aqui uma amostra:

bang> (enable) show module
Mod Slot Ports Module-Type                Model                Sub Status  
--- ---- ----- ------------------------- ------------------- ---  --------  
1   1    0     Switching  Supervisor      WS-X4012             no  ok  
2   2    34    10/100/1000  Ethernet      WS-X4232             no  ok  
3   3    34    Router Switch  Card        WS-X4232-L3          no  ok

Mod Module-Name         Serial-Num  
--- ------------------- --------------------  
1                        JAB02380AYG  
2                        JAB03210B6Y  
3                        JAB0417055S  

Mod MAC-Address(es)                         Hw     Fw          Sw  
--- -------------------------------------- ------ ---------- -----------------  
1   00-50-73-2a-f3-00 to 00-50-73-2a-f6-ff 1.0     4.5(1)     5.5(1)  
2   00-50-73-42-a9-68 to 00-50-73-42-a9-89 1.6  
3   00-01-42-06-73-a8 to 00-01-42-06-73-c9 1.0     12.0(7)W5( 12.0(7)W5(14.90

A única configuração adicionada no lado do catalizador 4000 relaciona-se ao tronco de GEC ao módulo de roteador, porque esta amostra mostra:

bang> (enable) show config

# ***** NON-DEFAULT CONFIGURATION *****  
!  
! 
!  
!  
!  
set port channel all distribution mac both  
!  
#ip  
set interface sl0 down  
set interface me1 down  
!  
#set boot command  
set boot config-register 0x102  
set boot system flash bootflash:cat4000.5-5-1.bin  
!  
#port channel  
set port channel 3/1-2 156  
!  
#module 1 : 0-port Switching Supervisor  
!  
#module 2 : 34-port 10/100/1000 Ethernet  

set VLAN 3    2/3

!  
#module 3 : 34-port Router Switch Card  
set VLAN 2    3/3
set VLAN 99   3/1-2

!--- This interface has a configuration for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the 
!--- router switch must match the one that you have configured on the router.
!--- VLAN 99 is a dummy native VLAN. For more information, 
!--- see the note in the Sample Configurations section.


set trunk 3/1  nonegotiate dot1q 1-1005


!--- Note: Trunk mode needs to be in no-negotiate status
!--- because the router module does not support Dynamic Trunking Protocol (DTP).


set trunk 3/2  nonegotiate dot1q 1-1005
set port channel 3/1-2 mode on


!--- Note: You need to force the channel mode to on because
!--- the router module does not support Port Aggregation Protocol (PAgP).
  
end

No interruptor, o comando show cdp neighbor indica o módulo de roteador como se o módulo era um roteador externo que conecte por um tronco de GEC nas portas de gigabit 3/1 e 3/2. Está aqui uma amostra:

bang> (enable) show cdp neighbor
* - indicates vlan mismatch.  
# - indicates duplex mismatch.  
Port     Device-ID                        Port-ID                    Platform  
-------- ------------------------------- -------------------------  ------------  
 2/3     daniella                         Ethernet0                  cisco 2500  
                                         
                                         
                                          
 3/3     donald                           Ethernet0                  cisco 2500

bang> (enable) show trunk 
* - indicates vtp domain mismatch  
Port      Mode          Encapsulation  Status        Native  vlan  
--------  -----------  -------------  ------------   -----------  
 3/1      nonegotiate  dot1q           trunking      99  
 3/2      nonegotiate  dot1q           trunking      99

Port      Vlans allowed on trunk  
--------  ---------------------------------------------------------------------  
 3/1      1-1005  
 3/2      1-1005

Port      Vlans allowed and active in management  domain  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Port      Vlans in spanning tree forwarding  state and not pruned  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Se você tem a saída de um comando show trunk de seu dispositivo Cisco, você pode usar a ferramenta Output Interpreter (clientes registrados somente) para indicar problemas potenciais e reparos.

bang> (enable) show port channel
Port  Status     Channel               Admin Ch  
                  Mode                  Group Id  
----- ---------- -------------------- ----- -----  
 3/1  connected  on                      156   833  
 3/2  connected  on                      156   833  
----- ---------- -------------------- ----- -----

Port  Device-ID                        Port-ID                    Platform  
----- ------------------------------- -------------------------  ----------------  
 3/1  bang-rp                          GigabitEthernet3           cisco Cat4232  
 3/2   Not directly connected to switch  
----- ------------------------------- -------------------------  ----------------

Se você tem a saída de um comando show port channel de seu dispositivo Cisco, você pode usar a ferramenta Output Interpreter (clientes registrados somente) para indicar problemas potenciais e reparos.

Configuração de módulo de roteador

bang-rp#show verify
Cisco Internetwork Operating System Software  
IOS (tm) L3 Switch/Router Software (CAT4232-IN-M), Version 12.0(7)W5(14.90)   INTERIM 
TEST SOFTWARE  
Copyright (c) 1986-2000 by cisco Systems, Inc.  
Compiled Fri 26-May-00 15:26 by integ  
Image text-base: 0x60010928, data-base: 0x605C8000  

ROM: System Bootstrap, Version 12.0(7)W5(15b) RELEASE SOFTWARE  

bang-rp uptime is 1 day, 22 hours, 7 minutes  
System restarted by power-on  
System image file is "bootflash:cat4232-in-mz.120-7.W5.14.90"  

cisco Cat4232 (R5000) processor with 57344K/8192K bytes of memory.  
R5000 processor, Implementation 35, Revision 2.1  
Last reset from power-on  
1 FastEthernet/IEEE 802.3 interface(s)  
4 Gigabit Ethernet/IEEE 802.3z interface(s)  
123K bytes of non-volatile configuration memory. 

16384K bytes of Flash internal SIMM (Sector size 256K).  
Configuration register is 0x1

bang-rp#show run
Building configuration...
Current Configuration:
!  
version 12.0  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname bang-rp  
!  
!  
ip subnet-zero  
!  
!  
!  
interface Port-channel1                    
 no ip redirects  
 no ip directed-broadcast  
 hold-queue 300 in  
!  
interface Port-channel1.2 


!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 2 tag.


encapsulation dot1Q 2
ip address 2.2.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast    
!  
interface Port-channel1.3

!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 3 tag.

encapsulation dot1Q 3  
ip address 1.1.1.2 255.255.255.0  
no ip redirects  
no ip directed-broadcast  
!
interface Port-channel1.99

!--- The configuration of this interface is for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the router 
!--- must match the one that you have configured on the switch. VLAN 99 is a dummy
!--- native VLAN. For more information, see the note
!--- in the Sample Configurations section.


encapsulation dot1Q 99 native
no ip address
no ip redirects
no ip directed-broadcast
!
interface FastEthernet1                  

!--- You can use this out-of-band interface for management.
  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet1  
 ip address 3.3.3.2 255.255.255.0  
 no ip directed-broadcast  
!  
interface GigabitEthernet2  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet3  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                         

!--- Both  Gigabit Ethernet 3 and Gigabit Ethernet 4 
!--- are part of channel group 1.
  
!  
interface GigabitEthernet4  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                          

!--- Both Gigabit Ethernet 3 and Gigabit Ethernet 4  
!--- are part of channel group 1.
  
!  
router eigrp 1  
 passive-interface FastEthernet1  
 network 1.0.0.0  
 network 2.0.0.0  
 network 3.0.0.0  
!  
ip classless  
!  
arp 127.0.0.2 0050.732a.f300 ARPA  
!  
line con 0  
 transport input none  
line aux 0  
line vty 0 4  
 login  
!  
end  
bang-rp#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route  Bridge  
                   S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce      Holdtme    Capability Platform  Port ID  
liki              Gig 1               
160         T S      
WS-C3508G-Gig 0/1                           

!--- Liki connects to gigabit 1 on the router. 
!--- You can only see Liki from the router; you cannot 
!--- see Liki from the Supervisor Engine.
  
JAB02380AYG(bang)Port-channel1      148          T S       WS-C4003  3/2  
JAB02380AYG(bang)Port-channel1      147          T S       WS-C4003  3/1

Troubleshooting

A sessão do supervisor ao módulo 4232-L3 não trabalha depois que é executado para por algum tempo

Depois que o interruptor é executado para por algum tempo, uma sessão do supervisor ao módulo 4232-L3 falha com este Mensagem de Erro:

4006> (enable) session 2
Trying IntlgLineCard-2...
session: Unable to tunnel to IntlgLineCard-2 (57)

A maioria de causa provável para esta é devido a uma adjacência incorreta formada na tabela do Address Resolution Protocol (ARP) do módulo do supervisor para o MAC address inband do módulo 4232-L3.

Esta edição pode ser resolvida com uma elevação do software do sistema a uma versão catos não afetada pela identificação de bug Cisco CSCdx30617 (clientes registrados somente).

Se uma elevação do software do sistema não é possível, você pode tentar estas ações alternativas:

  • Em vez de sessioning ao módulo, telnet a alguns dos endereços IP de Um ou Mais Servidores Cisco ICM NT configurados nele.

  • Uma restauração do módulo 4232-L3 pode recuperar o problema temporariamente.

  • Um movimento da relação sc0 em um VLAN diferente pode igualmente resolver esta edição.

Solicitações TFTP periódicas de 4232-L3

O módulo 4232-L3 continuamente tenta carregar uma configuração da rede e indica este Mensagem de Erro:

%Error opening tftp://255.255.255.255/network-config (Timed out)

O módulo L3 pode ser configurado para transferir automaticamente o arquivo de configuração de um servidor TFTP quando você emite o comando service config. Armazene os arquivos de configuração em um servidor TFTP e transfira-os ao carreg. Isto é útil quando o tamanho do arquivo de configuração é maior do que o tamanho do NVRAM no dispositivo.

Quando o módulo L3 é configurado com o comando service config, gera solicitações TFTP transferir sua configuração de um servidor TFTP.

Em uma encenação onde um IPS/IDS fosse usado, você pôde observar que o roteador envia continuamente a transmissão de tftp. Isto é confirmado pelo endereço IP de Um ou Mais Servidores Cisco ICM NT da fonte e o destino é 255.255.255.255, tráfego é o UDP 69 (TFTP).

A fim parar os mensagens de registro da geração, emita estes comandos:

Router#config terminal
Router(config)#no service config
Router(config)#exit
Router#copy running-config startup-config

Conclusão e dicas

Recorde estes pontos chaves quando você configura o módulo de roteamento no catalizador 4500/4000:

  • As interfaces de gigabit que você vê no painel dianteiro não são as mesmas que as interfaces de gigabit que você vê quando você emite o comando show port do Supervisor Engine. As relações no painel dianteiro são as relações com o gigabit 1 dos nomes e gigabit 2 no roteador.

  • Certifique-se de que o VLAN nativo dos troncos entre o interruptor e o roteador é um manequim VLAN. O CPU distribui no software todo o tráfego que está no VLAN nativo. , Crie consequentemente um VLAN adicional que você não usa em outra parte e faz a esse VLAN o VLAN nativo nos links entre o interruptor e o roteador.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 6198