Voz : H.323

How to Configure Video over IP for Polycom Video Units

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento abrange a configuração de rede básica e do Polycom ViewStation128 (unidade de videoconferência) com Cisco routers para aplicações de vídeo sobre IP. Ele também abrange a adição de QoS e o Troubleshooting de qualidade de vídeo em tempo real nas mídias de LAN e WAN.

Polycom Viewstation conecta a um TV para exibição de vídeo capturado e a um áudio; igualmente tem uma conexão ao LAN para passar pacotes da vídeo compactado sobre o IP. Polycoms é os valores-limite de H323 apenas como todo o outro gateway. O vídeo sobre o IP usa os seguintes protocolos:

  • H.225 para mensagens de sinalização de controle de chamada

  • H.245 para abrir e fechar canais de fluxo de mídia

  • H.263 e H.261 para codec de vídeo com formatos de imagem

  • G.723 para codecs de áudio, em modos de 5,3 kpbs ou 6,3 kpbs

O software para Polycom ViewStation128 deve ser recente e pode ser obtido por download a partir do website da Polycom. O firmware mais recente disponível na altura da publicação deste documento era 7.0.1. http://www.polycom.com/home/ leavingcisco.com

O ViewStation pode enviar vídeo e chamada de áudio compactados nas velocidades de 128k, 256k, 384k, 512k, 576k ou 768k. Essa taxa de compressão não inclui os cabeçalhos de IP e de LAN/WAN adicionados, então, quando for reservar a largura de banda no QoS, lembre-se de considerar essa carga adicional. Por exemplo, Áudio (64 kbps)+ Vídeo (704 kbps)+IP(25% de overhead) = 960 kbps.

O atraso ótimo para aplicativos de vídeo é similar exprimir: Round-Trip Time 125-150msec para resultados ótimos. A latência adicionada for tolerável, mas relatado em Polycom como um erro quando você telnet nela.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A instalação abaixo foi testada no laboratório com Software Release 12.1(5)T e 12.2(1a) de Cisco IOS� nos Cisco 7200 Router. O Polycom ViewStation 128 tem firmware versão 7.0.1.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo. Os produtos Polycom são codificados por hardware em modo semi-dúplex e 10 Mbps. O 2900XL tem neste caso todas as portas duro-codificadas a auto/automóvel, assim que nenhuma mudança era necessária no Cisco 7200 FE (interface rápida de Ethernet), assim que é ajustada a 100/Full. Se o anexo de Polycoms em alguns casos diretamente ao roteador ou aos Catalyst Switches, as portas deve ser configurado para combinar o duplex/apressa-se em conformidade.

/image/gif/paws/6172/polycom_video_over_ip1.gif

Configuração do Polycom ViewStation

Configurando a chamada de H.323 para o ViewStation

Em System Info > Admin Setup, execute estas etapas:

  1. Em LAN/H.323 e LAN/Intranet, configure o endereço IP do Polycom e do gateway padrão.

  2. Em LAN/H.323 e H323, configure o nome H323 para esta ViewStation e qualquer E164 ID, se desejado.

  3. (Opcional) Debaixo de LAN/H.323 e H323, o QoS pode ser especificado para portas UDP ou TCP específicas. A escala de portas TCP fixas é 3230-3231 e as portas fixas UDP são 3230 a 3235 para o tráfego de vídeo. Você pode definir para crítica a precedência do IP nos pacotes aqui, também.

  4. Sob a instalação geral, configurar as opções padrão tais como o nome de sistema, resposta automática, discagem automática, língua.

Fazendo uma chamada H.323 no ViewStation

Todos os atendimentos aqui são feitos usando o endereço IP remoto; você também pode usar números E.164 se utilizar um gatekeeper para fazer chamadas em vídeo. Sob a tela principal, datilografe dentro o endereço IP de Um ou Mais Servidores Cisco ICM NT para o polycom remoto, a seguir selecione a velocidade da compressão; isto deve corresponder ao que foi configurado como padrão no site remoto.

Configuração de roteadores com QoS para vídeo

Um dos métodos de QoS mais eficazes para usar com VideoOverIP sobre WAN é o Enfileiramento de latência baixa (LLQ). O policymap pode ser baseado em alguns parâmetros diferentes, discutidos abaixo. A largura de banda necessária pode ser dedicada e o vídeo sobre outros aplicativos IP pode ser priorizado, por meio do LLQ. Além disso, o link ATM deve ser VBR-NRT ou CBR para obter qualidade mais alta de vídeo.

Configuração de 7206VXR

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


Alternativamente, as seguintes configurações de lista de acesso poderiam ter sido usadas.

  • Baseado no endereço IP de origem/destino das unidades Visualizar Estação:

    host 192.168.1.90 de 192.168.3.90 do host da licença IP do access-list 101

    host 192.168.3.90 de 192.168.1.90 do host da licença IP do access-list 101

  • Baseado na Precedência IP 5:

    precedência 5 do access-list 101 permit ip any any

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Quando um atendimento é estabelecido, Polycom mantém-se a par de todos os pacotes de vídeo. Você pode fazer telnet no polycom e monitorar essa aproximação. O Polycom reporta a latência em pacotes H323, o vídeo ou os pacotes de áudio perdidos. Polycom debuga é legível e indica problemas quando pode ser duro os observar em uma tela video.

Alguns dos problemas de vídeo mais comuns, como congelamento, vem do Ethernet duplex e/ou de incompatibilidade de velocidade. Se os contadores dos Ethernet indicam o número grande de pacotes CRC/frame/deferred, a qualidade de vídeo degradará consideravelmente, assim que o primeiro ponto de verificação está certificando-se que todas as interfaces de LAN executam sem erros.

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

É possível verificar as configurações no Polycom, pela exibição das informações iniciais. Há depurações informativas desativadas para cada ação. Quando você tem um atendimento video, Polycoms relata automaticamente a latência calculada em uns pacotes: quaisquer pacotes perdidos e pacotes novamente seqüenciados, como resultado dos pacotes perdidos.

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

Antes que QoS esteve aplicado, quando o vídeo e os dados foram executados ao mesmo tempo, o resultado do telnet no polycom relatou o seguinte; isso é uma indicação evidente de problemas na rede e deve refletir também na qualidade do vídeo.

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

A saída a seguir foi capturada no LLQ dos Cisco IOS routers, aplicada em interfaces ATM interfaces e depois pings inundados foram enviados para criar congestionamento durante a chamada de vídeo. Quando há uma contenção de largura de banda, o LLQ dá a prioridade dinamicamente ao tráfego de vídeo.

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

Na saída a seguir, observe que não existe nenhuma queda de pacote de informação na sala de vídeo.

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 6172