Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Backup de DDR utilizando BRIs e o comando de interface de backup

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração demonstra o uso de uma linha de interface de taxa básica (BRI) da Rede digital de serviços integrados (ISDN) para fazer a cópia de segurançca de uma conexão de linha alugada. O comando backup interface coloca a interface especificada no modo em espera até que a interface primária seja desativada. Para obter mais informações sobre os recursos da interface de backup, consulte Avaliando Interfaces de Backup, Rotas Flutuantes e Relógio Discador de Backup do DDR.

Pré-requisitos

Requisitos

É recomendável que você consulte o documento Configuração e Troubleshooting de Backup DDR para obter mais informações.

Componentes Utilizados

Nesse cenário, temos um roteador Cisco 1604 conectado a um roteador Cisco 3640 em uma conexão serial. Ambos os roteadores também estão equipados com interfaces BRI, que são utilizadas para o link de backup. O Cisco 1604 está executando o software Release12.1(5)T de Cisco IOS� e o Cisco 3640 está usando o Cisco IOS 12.1(2).

Nota: Os conceitos nesta configuração podem ser usados em qualquer roteador com interfaces WAN e BRI.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Este exemplo usa Dial on Demand Routing (DDR), que usa o comando dialer map na conexão BRI. Você também pode usar perfis do discador em vez do DDR herdado. Para obter mais informações sobre perfis de discador, consulte Configurando ISDN DDR com perfis de discador.

Configurar o backup de DDR envolve duas etapas distintas:

  1. Configure o DDR com DDR anterior ou perfis de discador. Verifique se sua conexão DDR funciona corretamente antes de implementar a configuração de backup.

  2. Configure o roteador para iniciar a conexão DDR quando o link primário falhar. Esta configuração usa interfaces de backup para disparar o discagem. Consulte Avaliação de Interfaces de Backup, Rotas Estáticas Flutuantes e Observação de Discador para Backup DDR para obter mais informações sobre as outras opções.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos usados neste documento use a ferramenta de Consulta de comando.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/5607/bri-to-bri-backup.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

Essa configuração utiliza um circuito de BRI para realizar a cópia de segurança de um enlace serial. Essa configuração também está usando o Open Shortest Path First (OSPF) Routing Protocol entre os dois roteadores. Uma vez que a conexão de backup esteja ativada, assegure-se de que a tabela de roteamento esteja atualizada para uso com a nova rota de backup.

Nota:  Para obter mais informações sobre convenções de comando, consulte as Convenções de dicas técnicas Cisco.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1720 bytes
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default if-needed local

!--- This is basic aaa configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 7 <deleted>
username maui-nas-05 password 7 <deleted>

!--- Username for remote router (maui-nas-05) and shared secret
!--- (used for CHAP authentication). Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 backup delay 10 30

!--- Backup link is activated 10 seconds after primary link goes down.
!--- Backup link is deactivated 30 seconds after primary link is restored.

 backup interface BRI0

!--- BRI0 will backup interface serial 0.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no ip mroute-cache
 no fair-queue
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link).

 encapsulation ppp
 dialer idle-timeout 900

!--- Idle timeout(in seconds)for this link.

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111
 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551112

!--- Dialer maps for remote destination.
!--- The 2 different phone numbers correspond to the b-channels of the remote side.

 dialer load-threshold 1 outbound

!--- Load level for traffic at which additional connections 
!--- will be added to the MPPP bundle. 
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51299699380101 9969938
 isdn spid2 51299699460101 9969946
 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Use multilink to bring up both BRI channels.

!
router ospf 5

!--- OSPF configuration. If you use a different protocol
!--- configure that here. Make sure to include the BRI network in the RP.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 172.17.0.0 0.0.255.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
access-list 101 remark Interesting traffic definition for backup link
access-list 101 permit ip any any

!--- Interesting traffic definition. If you do not want OSPF to bring up
!--- the link, then mark it uninteresting.

dialer-list 1 protocol ip list 101

!--- Interesting traffic is applied to BRI0 using dialer-group 1.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end
!

Verifique as pontos a seguir na configuração do cliente maui-soho-01(1600):

  • Um endereço de loopback é usado. Isso é utilizado para que a id do roteador para OSPF não seja alterada e para que o enlace de backup possa estabelecer um peer quando ele for ativado.

  • O limiar de carga de discador está baixo. Esse valor pode ser alterado se você não precisar de uma conexão de backup multilink de 128k

  • Qualquer tráfego IP vai disparar a discagem (com base na lista 2 do discador e no grupo 1 do discador). Como o backup de link exige o tráfego interessante para discar para o backup de link, verifique se você não tem uma fonte de tráfego gerando o tráfego interessante. Neste exemplo, os pacotes de saudação do OSPF acionarão a discagem. Se você não estiver usando um Routing Protocol, poderá usar pings de ICMP para discar o backup de link. Ajuste o tráfego interessante, dependendo de suas necessidades.

  • O OSPF é usado. Você pode usar qualquer o protocolo de roteamento que desejar. Apenas certifique-se de que as redes da interface primária e de backup estejam incluídas no protocolo de roteamento. Se você quiser utilizar rotas estáticas e não um protocolo de roteamento, crie uma rota estática com o próximo salto sendo a interface BRI remota (você talvez precise criar uma rota estática flutuante dependendo do cenário).

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default if-needed local

!--- Basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 7 <deleted>
username maui-soho-01 password 7 <deleted>

!--- Username for remote router (maui-soho-01) and shared secret
!--- (used for CHAP authentication). The shared secret must be the same on both sides.

!
ip subnet-zero
!   
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip address 172.20.10.1 255.255.255.0

!--- IP address for the BRI interface (backup link).

 encapsulation ppp
 dialer idle-timeout 900
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- Dialer map for remote destination. 
!--- The name should match the authentication username provided by the remote side.
!--- Even though this router is not dialing out, the dialer map statement
!--- should be used.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap
 ppp multilink

!--- Use multilink to bring up both B-channels.

!

!--- Output removed.

!
interface Serial2/0
 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip any

!--- This defines all IP traffic as interesting.

!
Line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line AUX 0
line vty 0 4
!
end

Verifique os seguintes pontos na configuração do servidor maui-nas-05 (3640):

  • É configurada uma instrução de mapa de discador para o local remoto. Uma declaração de mapa de discador incorreta poderia resultar em problemas de roteamento no link de backup conectado.

  • Todo o tráfego IP é definido como interessante. Isso redefinirá o tempo limite inativo e manterá a conexão ativada até que o retorno do primário. Se o estabelecimento do link de backup não for necessário, você poderá alterá-lo.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

  • show interface bri0 – Indica se a interface BRI está ativa. Se o link primário estiver ativo, a interface BRI estará em espera. A interface BRI estará ativa apenas quando o enlace principal estiver inativo.

  • show isdn status - Use isso para garantir que o roteador esteja comunicando corretamente com o switch ISDN. Na saída, verifique se o status da camada 1 está ATIVO e se o estado de status da camada 2 = MULTIPLE_FRAME_ESTABLISHED é exibido. Esse comando exibe também o número de chamadas ativas.

Exemplo de saída show ip route

A tabela de roteamento do cliente, maui-soho-01 (1600), com o link primário em funcionamento é mostrada abaixo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1626] via 192.168.10.1, 00:00:22, Serial0
     172.22.0.0/32 is subnetted, 1 subnets
O       172.22.1.1 [110/65] via 192.168.10.1, 00:00:23, Serial0

A saída de show ip route (mostrada abaixo) exibe as rotas OSPF aprendidas dos peers utilizando o link primário (serial 0). Agora desativaremos o link primário e ativaremos o link de backup.

Nota: A emissão do comando shutdown na interface primária não causará a discagem da BRI de backup. Se você emitir um comando shutdown para desativar a conexão principal, o Cisco IOS Software não ativará automaticamente uma conexão de backup. Você deve desativar fisicamente a conexão principal, desconectando cabos ou utilizando outro método equivalente para ativar as interfaces de backup.

Depois que o link de backup for ativado, a tabela OSPF será trocada e as novas rotas que utilizam o link de backup serão instaladas. O tráfego agora flui pelo link de backup. Um exemplo é fornecido abaixo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/32 is subnetted, 1 subnets
O       172.22.1.1 [110/1563] via 172.20.10.1, 00:00:22, BRI0

Exemplo de saída show interface

O comando show interface permite verificar se as fases LCP, ICP e Multilink de PPP passaram com êxito.

maui-soho-01#show interface BRI 0
    BRI0 is up, line protocol is up
     Hardware is BRI with U interface and external S bus interface     
     Internet address is 172.20.10.2, subnet mask is 255.255.255.0
     MTU 1500 bytes, BW 256 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation PPP, loopback not set
     DTR is pulsed for 5 seconds on reset
     LCP Open, multilink Open
     Open: IPCP
   ...........................

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer – Utilizado para ver as informações do Dial-On-Demand Routing.

  • debug isdn events - É usado para ver a atividade ISDN ocorrendo no lado do usuário da interface ISDN.

  • debug isdn q931 - Isso mostra a configuração de chamada e a subdivisão da conexão de rede ISDN (Camada 3) e pode ser usado para isolar problemas.

  • debug ppp negotiation - Isso mostra informações sobre trocas e sobre o tráfego Point-to-Point Protocol (PPP) durante a negociação dos componentes PPP, incluindo o Link Control Protocol (LCP), a autenticação e o Network Control Protocol (NCP). Uma negociação de PPP bem-sucedida abrirá primeiro o estado LCP, efetuará a autenticação e, por fim, negociará o NCP.

  • debug ppp authentication - Isso exibe mensagens de protocolo de autenticação PPP, inclusive intercâmbios de pacotes Challenge Authentication Protocol (CHAP) e Password Authentication Protocol (PAP). Se você perceber uma falha, verifique se o nome de usuário e a senha da abertura estão configurados corretamente.

  • debug ppp error - Isso mostra erros de protocolo e estatísticas de erros associados à negociação e à operação da conexão PPP.

Exemplo de debug

Para obter informações sobre o troubleshooting de backup DDR, consulte o documento Configuração e Troubleshooting de Backup DDR.

A seguinte saída de depuração foi gerada com o uso de depurações descritas anteriormente. A saída mostra o link principal falhando e o link de backup sendo ativado:

*Mar  1 03:37:42.350: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is unplugged.

*Mar  1 03:37:42.358: Se0 IPCP: State is Closed
*Mar  1 03:37:42.362: Se0 CDPCP: State is Closed
*Mar  1 03:37:42.366: Se0 PPP: Phase is TERMINATING [0 sess, 1 load]
*Mar  1 03:37:42.370: Se0 LCP: State is Closed
*Mar  1 03:37:42.370: Se0 PPP: Phase is DOWN [0 sess, 1 load]
*Mar  1 03:37:42.386: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 03:37:42.394: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0 from
   FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 03:37:43.358: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
   changed state to down
*Mar  1 03:37:52.302: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

!--- The backup interface is changed to from "standby" to "down".
!--- The backup interface was activated 10 seconds after the primary link
!--- went down.
!--- This interval was defined with the backup delay command in maui-soho-01
!--- (the 1600).

*Mar  1 03:37:52.306: BR0:1 LCP: State is Closed
*Mar  1 03:37:52.310: BR0:1 DDR: disconnecting call
*Mar  1 03:37:52.314: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
*Mar  1 03:37:52.318: BR0:2 LCP: State is Closed
*Mar  1 03:37:52.322: BR0:2 DDR: disconnecting call
*Mar  1 03:37:52.417: %LINK-3-UPDOWN: Interface BRI0, changed state to up
*Mar  1 03:37:52.477: ISDN BR0: Event: Syncing Discards: L2 Discards 4,
   L2D_Task Counter 2
*Mar  1 03:37:52.489: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 03:37:52.493: BR0 DDR: Attempting to dial 5551111

!--- This is the phone number of the remote router that is dialed.

*Mar  1 03:37:54.477: ISDN BR0: Event: Syncing Discards: L2 Discards 4,
   L2D_Task Counter 3
*Mar  1 03:37:56.528: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0,
   TEI 112 changed to up
*Mar  1 03:37:56.556: ISDN BR0: TX ->  INFORMATION pd = 8  callref = (null)
        SPID Information i = '51299699380101'
*Mar  1 03:37:56.627: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x1F
*Mar  1 03:37:56.635:         Bearer Capability i = 0x8890
*Mar  1 03:37:56.643:         Channel ID i = 0x83
*Mar  1 03:37:56.651:         Keypad Facility i = '5551111'
*Mar  1 03:37:56.667: ISDN BR0: RX <-  INFORMATION pd = 8  callref = (null)
   ENDPOINT IDent i = 0x8081
*Mar  1 03:37:56.703: ISDN BR0: Received EndPoint ID
*Mar  1 03:37:56.738: ISDN BR0: RX <-  INFORMATION pd = 8  callref = (null)
   Locking Shift to Codeset 5
*Mar  1 03:37:56.750:         Codeset 5 IE 0x2A  i = 0x808001, 'P'
*Mar  1 03:37:56.857: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 65
   changed to up
*Mar  1 03:37:56.881: ISDN BR0: TX ->  INFORMATION pd = 8  callref = (null)
   SPID Information i = '51299699460101'
*Mar  1 03:37:56.917: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x9F
*Mar  1 03:37:56.925:         Channel ID i = 0x89
*Mar  1 03:37:56.949: ISDN BR0: RX <-  INFORMATION pd = 8  callref = (null)
   ENDPOINT IDent i = 0x8181
*Mar  1 03:37:56.984: ISDN BR0: Received Endpoint ID
*Mar  1 03:37:57.175: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x9F

!--- The call is connected.

*Mar  1 03:37:57.199: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 03:37:57.218: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 03:37:57.222: BR0:1 PPP: Phase is ESTABLISHING, Active Open
   [0 sess, 1 load]
*Mar  1 03:37:57.230: BR0:1 LCP: O CONFREQ [Closed] id 18 len 34
*Mar  1 03:37:57.234: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:57.242: BR0:1 LCP:    MagicNumber 0x1144F392 (0x05061144F392)
*Mar  1 03:37:57.246: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:57.250: BR0:1 LCP:    EndpointDisc 1 Local
   (0x130F016D6175692D736F686F2D3031)
*Mar  1 03:37:57.262: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x1F
*Mar  1 03:37:57.282: BR0:1 LCP: I CONFREQ [REQsent] id 43 Len 33
*Mar  1 03:37:57.286: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:57.294: BR0:1 LCP:    MagicNumber 0x363030C5 (0x0506363030C5)
*Mar  1 03:37:57.298: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:57.302: BR0:1 LCP:    EndpointDisc 1 Local
   (0x130E016D6175692D6E61732D3035)
*Mar  1 03:37:57.310: BR0:1 LCP: O CONFACK [REQsent] id 43 Len 33
*Mar  1 03:37:57.314: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:57.318: BR0:1 LCP:    MagicNumber 0x363030C5 (0x0506363030C5)
*Mar  1 03:37:57.326: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:57.330: BR0:1 LCP:    EndpointDisc 1 Local
   (0x130E016D6175692D6E61732D3035)
*Mar  1 03:37:57.341: BR0:1 LCP: I CONFACK [ACKsent] id 18 Len 34
*Mar  1 03:37:57.345: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:57.349: BR0:1 LCP:    MagicNumber 0x1144F392 (0x05061144F392)
*Mar  1 03:37:57.353: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:57.361: BR0:1 LCP:    EndpointDisc 1 Local
   (0x130F016D6175692D736F686F2D3031)
*Mar  1 03:37:57.365: BR0:1 LCP: State is Open
*Mar  1 03:37:57.369: BR0:1 PPP: Phase is AUTHENTICATING, by both
   [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 03:37:57.373: BR0:1 CHAP: O CHALLENGE id 17 Len 33 from "maui-soho-01"

!--- The username for CHAP is challenge. The remote router must have this
!--- username configured along with it's shared secret password.

*Mar  1 03:37:57.381: BR0:1 CHAP: I CHALLENGE id 30 Len 32 from "maui-nas-05"

!--- The incoming username for CHAP is challenge.
!--- This username must be locally configured.

*Mar  1 03:37:57.397: BR0:1 CHAP: O RESPONSE id 30 Len 33 from "maui-soho-01"
*Mar  1 03:37:57.425: BR0:1 CHAP: I SUCCESS id 30 Len 4
*Mar  1 03:37:57.433: BR0:1 CHAP: I RESPONSE id 17 Len 32 from "maui-nas-05"
*Mar  1 03:37:57.445: BR0:1 CHAP: O SUCCESS id 17 Len 4

!--- CHAP authentication is successful.

*Mar  1 03:37:57.453: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 03:37:57.460: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]
*Mar  1 03:37:57.480: BR0:1 IPCP: Packet buffered while building
   MLP bundle interface
*Mar  1 03:37:57.484: BR0:1 CDPCP: Packet buffered while building
   MLP bundle interface
*Mar  1 03:37:57.488: %LINK-3-UPDOWN: Interface Virtual-Access1,
   changed state to up

!---  Virtual Access Interface is created for the multilink
!--- (2 b-channel) connection.

*Mar  1 03:37:57.496: Vi1 DDR: Dialer statechange to up
*Mar  1 03:37:57.500: Vi1 DDR: Dialer call has been placed
*Mar  1 03:37:57.504: Vi1 PPP: Treating connection as a callout
*Mar  1 03:37:57.508: Vi1 PPP: Phase is ESTABLISHING, Active Open
   [0 sess, 1 load]
*Mar  1 03:37:57.516: Vi1 LCP: O CONFREQ [Closed] id 1 Len 34
*Mar  1 03:37:57.520: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:57.524: Vi1 LCP:    MagicNumber 0x1144F4B0 (0x05061144F4B0)
*Mar  1 03:37:57.528: Vi1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:57.536: Vi1 LCP:    EndpointDisc 1 Local
   (0x130F016D6175692D736F686F2D3031)
*Mar  1 03:37:57.548: Vi1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 03:37:57.556: Vi1 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 03:37:57.560: Vi1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 03:37:57.572: Vi1 CDPCP: O CONFREQ [Closed] id 1 Len 4
*Mar  1 03:37:57.576: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 03:37:57.580: Vi1 PPP: Pending ncpQ size is 2
*Mar  1 03:37:57.583: BR0:1 IPCP: Redirect packet to Vi1
*Mar  1 03:37:57.587: Vi1 IPCP: I CONFREQ [REQsent] id 1 Len 10
*Mar  1 03:37:57.591: Vi1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 03:37:57.599: Vi1 IPCP: O CONFACK [REQsent] id 1 Len 10
*Mar  1 03:37:57.603: Vi1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 03:37:57.607: BR0:1 CDPCP: Redirect packet to Vi1
*Mar  1 03:37:57.611: Vi1 CDPCP: I CONFREQ [REQsent] id 1 Len 4
*Mar  1 03:37:57.615: Vi1 CDPCP: O CONFACK [REQsent] id 1 Len 4
*Mar  1 03:37:57.623: Vi1 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 03:37:57.631: Vi1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 03:37:57.635: Vi1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 03:37:57.643: Vi1 CDPCP: I CONFACK [ACKsent] id 1 Len 4
*Mar  1 03:37:57.643: Vi1 CDPCP: State is Open
*Mar  1 03:37:57.651: Vi1 DDR: dialer protocol up
*Mar  1 03:37:57.663: BR0 IPCP: Install route to 172.20.10.1
*Mar  1 03:37:58.072: BR0 DDR: Attempting to dial 5551111

!--- Router is dialing.

*Mar  1 03:37:58.199: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x20
*Mar  1 03:37:58.206:         Bearer Capability i = 0x8890
*Mar  1 03:37:58.218:         Channel ID i = 0x83
*Mar  1 03:37:58.226:         Keypad Facility i = '5551111'
*Mar  1 03:37:58.445: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up
*Mar  1 03:37:58.512: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0xA0
*Mar  1 03:37:58.524:         Channel ID i = 0x8A
*Mar  1 03:37:58.548: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Virtual-Access1, changed state to up
*Mar  1 03:37:58.599: BR0:1 LCP: I ECHOREQ [Open] id 1 Len 12 magic 0x363030C5
*Mar  1 03:37:58.603: BR0:1 LCP: O ECHOREP [Open] id 1 Len 12 magic 0x1144F392
*Mar  1 03:37:58.746: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0xA0
*Mar  1 03:37:58.774: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 03:37:58.786: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
   5551111 maui-nas-05
*Mar  1 03:37:58.794: BR0:2 PPP: Treating connection as a callout
*Mar  1 03:37:58.798: BR0:2 PPP: Phase is ESTABLISHING, Active Open
   [0 sess, 0 load]
*Mar  1 03:37:58.810: BR0:2 LCP: O CONFREQ [Closed] id 16 Len 34
*Mar  1 03:37:58.814: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:58.818: BR0:2 LCP:    MagicNumber 0x1144F9C9 (0x05061144F9C9)
*Mar  1 03:37:58.821: BR0:2 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:58.825: BR0:2 LCP:    EndpointDisc 1 Local
   (0x130F016D6175692D736F686F2D3031)
*Mar  1 03:37:58.837: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x20
*Mar  1 03:37:58.861: BR0:2 LCP: I CONFREQ [REQsent] id 33 Len 33
*Mar  1 03:37:58.865: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:58.869: BR0:2 LCP:    MagicNumber 0x363036F1 (0x0506363036F1)
*Mar  1 03:37:58.873: BR0:2 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:58.877: BR0:2 LCP:    EndpointDisc 1 Local
   (0x130E016D6175692D6E61732D3035)
*Mar  1 03:37:58.889: BR0:2 LCP: O CONFACK [REQsent] id 33 Len 33
*Mar  1 03:37:58.893: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:58.897: BR0:2 LCP:    MagicNumber 0x363036F1 (0x0506363036F1)
*Mar  1 03:37:58.901: BR0:2 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:58.905: BR0:2 LCP:    EndpointDisc 1 Local
   (0x130E016D6175692D6E61732D3035)
*Mar  1 03:37:58.917: BR0:2 LCP: I CONFACK [ACKsent] id 16 Len 34
*Mar  1 03:37:58.921: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:37:58.929: BR0:2 LCP:    MagicNumber 0x1144F9C9 (0x05061144F9C9)
*Mar  1 03:37:58.933: BR0:2 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 03:37:58.937: BR0:2 LCP:    EndpointDisc 1 Local
   (0x130F016D6175692D736F686F2D3031)
*Mar  1 03:37:58.941: BR0:2 LCP: State is Open
*Mar  1 03:37:58.945: BR0:2 PPP: Phase is AUTHENTICATING, by both
   [0 sess, 0 load]
*Mar  1 03:37:58.952: BR0:2 CHAP: O CHALLENGE id 15 Len 33 from "maui-soho-01"
*Mar  1 03:37:58.956: BR0:2 CHAP: I CHALLENGE id 22 Len 32 from "maui-nas-05"
*Mar  1 03:37:58.976: BR0:2 CHAP: O RESPONSE id 22 Len 33 from "maui-soho-01"
*Mar  1 03:37:59.008: BR0:2 CHAP: I SUCCESS id 22 Len 4
*Mar  1 03:37:59.012: BR0:2 CHAP: I RESPONSE id 15 Len 32 from "maui-nas-05"
*Mar  1 03:37:59.028: BR0:2 CHAP: O SUCCESS id 15 Len 4

!--- Authentication (for the 2nd call) is successful.

*Mar  1 03:37:59.036: BR0:2 PPP: Phase is VIRTUALIZED [0 sess, 0 load]
*Mar  1 03:37:59.044: BR0:2 MLP: maui-nas-05, multilink up
*Mar  1 03:38:00.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2,
   changed state to up
*Mar  1 03:38:02.555: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on BRI0 from
   LOADING to FULL, Loading Done
*Mar  1 03:38:04.742: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to
   5551111 maui-nas-05

!--- Second B-channel (BRI0:2) is connected.

*Mar  1 03:38:08.599: BR0:1 LCP: I ECHOREQ [Open] id 2 Len 12 magic 0x363030C5
*Mar  1 03:38:08.603: BR0:1 LCP: O ECHOREP [Open] id 2 Len 12 magic 0x1144F392
maui-soho-01#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5607