Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Configurando o backup de DDR com uso de BRIs e relógio de discador

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento demonstra o uso de uma linha da BRI (interface de taxa básica) do ISDN para fazer backup de uma linha alugada, WAN ou conexão serial usando o recurso de relógio do discador. Para obter mais informações sobre os recursos do vigia do discador, consulte Avaliando interfaces de backup, rotas flutuantes e o vigia do discador para backup DDR.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Um Cisco 1604 com a 1 interface U de BRI que executa o Software Release 12.1(5)T de Cisco IOS�.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Este exemplo usa o Legacy Dial-on-Demand Routing (DDR), que usa o comando dialer map para a conexão BRI. Você pode usar também perfis de discador em vez de DDR legado (mapas de discador). Para obter mais informações sobre perfis de discador, consulte Configurando ISDN DDR com perfis de discador.

Configurar o backup de DDR envolve duas etapas distintas:

  1. Configure o DDR com DDR anterior ou perfis de discador. Verifique se sua conexão DDR funciona corretamente antes de implementar a configuração de backup. Isso permitirá verificar se o método de discagem utilizado, a negociação do PPP (Protocolo Ponto-a-Ponto) e a autenticação são bem-sucedidas antes de configurar o backup.

  2. Configure o roteador para iniciar a conexão de DDR de backup quando o enlace principal falhar. Essa configuração utiliza o recurso relógio de discador para disparar o dialout.

Para obter mais informações sobre os passos necessários para configurar o backup, consulte o documento Configuring and Troubleshooting DDR Backup

Operação de relógio de discador

Com o relógio de discador, o roteador monitora a existência de uma rota especificada e, se essa rota não estiver presente, iniciará a discagem do enlace de reserva. Ao contrário dos outros métodos de backup (como interface de backup ou rotas flutuantes) o relógio de discador não exige tráfego interessante para acionar a discagem. O processo usado pelo relógio de discador está descrito abaixo:

  • Quando uma rota vigiada for excluída, o vigia do discador verifica pelo menos uma rota válida para qualquer um dos endereços IP ou redes sendo vigiados.

    • Se não houver rota válida, a linha principal será considerada inativa e inutilizável.

      • O discador observe depois inicia a chamada e os roteadores se conectam e trocam informações de roteamento. Todo o tráfego para a rede local usará agora o backup de link.

    • Se houver uma rota válida para pelo menos uma das redes IP vigiadas e definidas e a rota apontar para uma interface que não seja a interface de backup configurada para vigiar o discador, o link primário é considerado ativo e o vigia do discador não inicia o backup de link.

  • Quando o enlace de reserva estiver ativado, o enlace principal será verificado novamente no vencimento de cada limite de tempo de ociosidade. Se o enlace principal permanecer desativado, o cronômetro ocioso será reinicializado. Desde que o roteador deve periodicamente verificar se o link principal esteja restabelecido, configurar um valor pequeno para o quietude-intervalo do discador. Quando o enlace primário for restabelecido, o Routing Protocol atualizará a tabela de roteamento e todo o tráfego deverá passar pelo enlace primário novamente. Como o tráfego não passará mais pelo link de backup, o intervalo de ociosidade expirará e o roteador desativará o link de backup.

    Nota: Ao definir o tráfego interessante, negue o tráfego do protocolo de roteamento para impedir que os hellos periódicos restaurem o idle timeout.

  • Se o link principal for reativado, o link de backup secundário será desconectado. Entretanto, um cronômetro de desabilitação pode ser implementado de forma que haja um retardo antes da perda do link de backup após a recuperação do link primário. Este cronômetro de retardo é iniciado quando o cronômetro ocioso expira, e a rota principal é descoberta ativa. Esse cronômetro de retardo pode garantir estabilidade, especialmente para interfaces não sincronizadas ou que estejam passando por alterações freqüentes de rota.

Para obter mais informações sobre os recursos do vigia do discador, consulte Avaliando interfaces de backup, rotas flutuantes e o vigia do discador para backup DDR.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/5600/bri-backup-map-watch.gif

Configurações

Essa configuração utiliza um circuito de BRI para realizar a cópia de segurança de um enlace serial. Essa configuração também está usando o Open Shortest Path First (OSPF) Routing Protocol entre os dois roteadores. Uma vez que a conexão de backup esteja ativada, assegure-se de que a tabela de roteamento esteja atualizada para uso com a nova rota de backup.

Para obter mais informações sobre convenções de comando, consulte as Convenções de dicas técnicas Cisco.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Nota: A configuração de maui-nas-05 não inclui nenhum backup relativo comandos. Do ponto de vista de maui-nas-05, o link de backup é apenas um outro cliente do dialin. Isto pode simplificar a configuração da instalação central nas situações onde muitos dispositivos estabelecem um link de backup à mesma central local. Nos cenários de backup, é ideal ter somente um novato do lado o seletor, quando o outro lado aceitar somente atendimentos.

Comandos de relógio do discador

A seguir, há uma relação de comandos disponíveis para relógio de discador. Alguns destes comandos forem incluídos na configuração acima, quando outro são fornecidos para a referência.

  • número de grupos IP da relógio-lista do discador máscara de endereço do IP address : Define o IP endereços ou redes a ser olhados. O endereço ou a rede (com o correto máscara) que é configurada deve existir na tabela de roteamento. Você pode igualmente olhar rotas múltiplas com o comando dialer watch-list. Um exemplo é mostrado:

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group número de grupos : Permita o Dialer Watch no Interface de backup. grupo número usado aqui combina número do grupo do discador comando da relógio-lista que define as rotas a ser olhadas. O discador o comando do relógio-grupo com um número de grupo particular pode somente ser configurado em uma relação. Isto significa que o roteador não pode usar o múltiplo relações para fornecer o backup para uma rota particular. Contudo, uma relação pode tenha comandos do relógio-grupo do discador múltiplo, com números de grupos diferentes. Consequentemente, uma relação pode ser usada para fornecer o backup para rotas múltiplas.

  • relógio-desabilitação do discador segundos : Aplique um tempo de retardo do desabilitação a a relação. Depois que a interface principal recupera, este atraso impede desligando a Interface de backup para o período especificado. Este atraso o temporizador é começado quando o temporizador de ociosidade expira, e o estado do preliminar a rota é verificada e encontrada para estar acima. Este atraso pode assegurar a estabilidade, especialmente para as interfaces de não-sincronização ou as relações que experimentam a rota frequente mudanças.

  • número de grupos da relógio-lista do discador segundos do delay route-check initial: Isto o comando permite o roteador de verificar se a rota principal seja acima após a partida inicial do roteador está completa e o temporizador (nos segundos) expira. Sem este comando, o Dialer Watch é provocado somente quando a rota principal é removido da tabela de roteamento. Se o link principal não vem acima durante a partida inicial do roteador, a rota é adicionada nunca à tabela de roteamento e daqui não pode ser olhado. Consequentemente, com este comando, o Dialer Watch vai faz4e-lo discar o link de backup no caso de uma falha de enlace principal durante a inicial comece acima do roteador.

Verificar

Para obter mais informações, consulte Utilização o comando show isdn status para o BRI Pesquisa de defeitos.

Esta seção fornece a informação que você pode se usar para confirmar o seu a configuração está trabalhando corretamente.

Os determinados comandos de exibição são apoiados pelo O Output Interpreter tomou, de que permite que você ver uma análise show command output (resultado do comando show).

  • tipo do show dialer [interface número] - informação geral de diagnóstico dos indicadores para as relações configuradas para o DDR e indicam a configuração do temporizador e tempo antes do tempo de conexão para fora. Você deverá verificar as seguintes mensagens:

    • "Dialer state is data link layer up" - O discador entrou no ar corretamente.

      • “Camada física acima” - O protocolo de linha veio acima, mas a rede O protocolo de controle (NCP) não fez.

    • “Discar a razão” que isto indica os endereços de rementente e destinatário de o pacote que iniciou discar.

  • status de ISDN da mostra - Assegure a isso o roteador está comunicando-se corretamente com o switch ISDN. Este comando igualmente indica número de chamadas ativa você deve verificar os seguintes mensagens:

    • "Layer 1 Status is ACTIVE",

    • "Estado de status da Camada 2 = MULTIPLE_FRAME_ESTABLISHED"

Exemplo de saída de show

A tabela de roteamento do cliente, maui-soho-01 (1600), com o preliminar o funcionamento do link é mostrado abaixo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

A saída da rota da mostra IP mostrada acima, indica as rotas de OSPF aprendidas dos pares que usam o link principal (série 0). Observe que a rota que está sendo olhada (172.22.53.0 com máscara 255.255.255.0) existe na tabela de roteamento. Isto deve ser verificado para que o Dialer Watch funcione corretamente.

Agora desativaremos o link primário e ativaremos o link de backup. Após o link de backup é ativado, a tabela de OSPF é trocada e as rotas novas usar o link de backup é instalada. O tráfego passa agora através do link de backup.

Um exemplo é fornecido abaixo:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

A saída acima mostra que a tabela de roteamento esteve atualizada e tudo o tráfego usará o link de backup (o BRI0)

O comando show dialer pode ser usado a verifique que a interface DDR veio acima corretamente. Observe que a interface BRI foi discado porque o roteador detectou que a rota vigiada esteve perdida.

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Troubleshooting

Troubleshooting de Relógio do Discador

Configurar e verifique que a conexão DDR está funcionando corretamente antes você configura o Dialer Watch. Isto ajudá-lo-á a isolar e pesquisar defeitos o DDR edições antes que você abordar problemas relacionados alternativos. Ao configurar o Dialer Watch recomeça-se que você usa o Software Release 12.1(7) ou Mais Recente de Cisco IOS�. Agora discutiremos vários problemas e possíveis soluções:

Problema: O roteador não discar o link de backup quando o link principal vai para baixo.

Solução possível #1: Use a mostra IP o comando route verificar que a rota que você está olhando existe dentro a tabela de roteamento. A rota configurada para o Dialer Watch deve exatamente combinar um na tabela de roteamento. Isto inclui a verificação disso a rede assim como as máscaras são idênticas. Por exemplo, se a tabela de roteamento mostra 10.0.0.0/8 e você usa a relógio-lista 1 IP 10.0.0.0 do discador 255.255.255.0 (que é 10.0.0.0/24), a operação de relógio de discador não possa detectar que 10.0.0.0/8 estão já não na tabela de roteamento.

Solução possível #2: Verifique que há o mapa de discadores dois indicações na Interface de backup.

  • Deve haver uma indicação do mapa para a rota/rede especificadas por o comando dialer watch-list

  • Deve haver uma indicação do mapa para o endereço IP de Um ou Mais Servidores Cisco ICM NT do telecontrole a relação do roteador.

Solução possível #3: Configurar o comando atraso do número de grupos da relógio-lista do discador segundos iniciais da verificação de rota . Consulte a seção comandos section dialer watch para mais informação.

Problema: O link de backup é estabelecido mas nenhum roteamento a informação é transmitida através do link de backup.

Possível solução: Verifique que o IP da Interface de backup a rede é incluída na configuração de protocolo de roteamento

Problema: O link de backup não for desativado quando o link principal recupera.

Nota: Com Dialer Watch, o tráfego interessante é usado somente para controlar quietude-intervalo que controla por sua vez o intervalo usado para votar o estado do rota principal.

Solução possível #1: Abaixe o discador quietude-intervalo. O padrão é 120 segundos, mas você pode desejar a abaixe este valor segundo suas necessidades.

Solução possível #2: Use a mostra o comando dialer verificar o idle timeout não está sendo restaurado.

Mude sua definição de tráfego interessante (configurada com comando dialer-list) ser mais restritivo. Roteamento O tráfego de protocolo deve ser sem interesse marcado.

Como um último recurso, você pode configurar todo o tráfego IP como sem interesse usando o comando dialer-list 1 protocol ip deny. Com esta definição de tráfego interessante, o idle timeout será restaurado nunca, e o roteador verificará o estado do link principal no especificado intervalo.

Solução possível #3: Verifique para certificar-se de que o link de backup é menos desejável do que o link principal da perspectiva do protocolo de roteamento no uso. Isto é de modo que quando o link principal recupera, o protocolo de roteamento dinâmico preferirá o preliminar sobre o link de backup e não equilíbrio da carga através dos dois links. A falha fazer isto pode causar o link de backup para ficar acima persistentemente. Use a rota da mostra IP a determine se o roteador está usando ambos os link principal e de backup para distribuir trafique entre o Roteadores. Em tal caso o roteador manter-se-á idêntico rotas duplicadas; um para o preliminar e um para o link de backup que você pode se usar os alguns dos seguintes métodos para assegurar-se de que o link de backup seja menos desejável da perspectiva do protocolo de roteamento: largura de banda, atraso, ou distância. Refira o comando do Cisco IOS Software Referência para mais detalhes.

Para as camadas de ISDN gerais 1,2 e 3 que pesquisam defeitos refira o documento Usando o status de ISDN da mostra Comando para o Troubleshooting de BRI.

Comandos para Troubleshooting

Os determinados comandos de exibição são apoiados pelo Ferramenta Output Interpreter, de que permite que você ver uma análise show command output (resultado do comando show).

Nota: Antes de emitir comandos debug, veja por favor Informação importante sobre Comandos Debug.

  • debug dialer - Isto é usado para indicar o DDR informação sobre os pacotes recebidos em uma interface do discador.

  • debugar o q931 de ISDN - Isto mostra a configuração de chamada e rasgue para baixo da conexão de rede ISDN (camada 3) entre o roteador e Switch ISDN.

  • debugar a negociação ppp - Isto indicadores informação no tráfego e nas trocas PPP ao negociar os componentes de PPP incluindo o protocolo de controle de link (LCP), a autenticação, e o NCP. Um bem sucedido A negociação de PPP primeiramente abrirá o estado LCP, a seguir autentica-o, e finalmente negocie o NCP.

  • debugar a autenticação de PPP - Isto indicadores os mensagens de protocolo da autenticação de PPP, incluindo o aperto de mão do desafio Intercâmbios de pacotes e autenticação de senha do protocolo de autenticação (RACHADURA) Trocas do protocolo (PAP). Se você observa uma falha para verificar que a rachadura o nome de usuário e senha é configurado corretamente.

  • debug ppp error - Isto indica o protocolo erros e estatísticas de erros associados com a negociação da conexão PPP e operação.

Exemplo de debug

A saída do debug dialer abaixo mostra failing e Dialer Watch do link principal que reconhecem a rota perdida. O roteador inicia então o link de backup. Em seguida cada vez que o quietude-intervalo expira, verificações do roteador se o link principal está para baixo. Se o link principal é encontrado a esteja acima, Dialer Watch desliga o link de backup após o temporizador do desabilitação expira. No debuga, pagam a atenção ao timestamp em cada mensagem como eles pode fornecer a informação nos vários temporizadores e nos intervalos inativos que são ativo.

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5600