Discar e acessar : Conexões assíncronas

Configurando um servidor de terminal/comm

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (14 Julho 2008) | Inglês (10 Novembro 2015) | Feedback


Índice


Introdução

Um servidor comm ou de terminal fornece normalmente acesso fora de banda a muitos dispositivos. Um servidor terminal é um roteador com várias portas assíncronas, de baixa velocidade conectadas a outros dispositivos seriais, como modems ou portas console em roteadores ou switches.

O servidor terminal permite acessar, por um único ponto, as portas do console de muitos dispositivos. Um servidor terminal elimina a necessidade de configurar cenários de backup, como modems em portas auxiliares, para cada dispositivo. Você também pode configurar um único modem na porta auxiliar do servidor terminal para fornecer o serviço de dial-up aos outros dispositivos quando a conectividade de rede falhar.

Este documento mostra como configurar um servidor terminal para acessar apenas as portas console em outros roteadores por meio de Telnet Reversa. A Telnet Reversa permite que você estabeleça uma conexão Telnet externa no mesmo dispositivo de origem, mas em uma interface diferente. Para obter mais informações sobre do telnet reverso refira controlando sessões de Telnet.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Cabeamento

Os Cisco 2509 - 2512 Series Routers usam um conector de 68 pinos e um cabo breakout. Este cabo (CAB-OCTAL-ASYNC) fornece oito portas assíncronas de cabo enrolado RJ-45 em cada conector de 68 pinos. Você pode conectar cada porta assíncrona de cabo enrolado RJ-45 à porta de console de um dispositivo. O roteador 2511 permite que no máximo 16 dispositivos possam ser acessados remotamente. Além disso, os módulos de rede assíncronos de alta densidade NM-16A ou NM-32A estão disponíveis para que os roteadores Cisco 2600 e 3600 series ofereçam a mesma função. Para obter mais informações sobre cabeamento, consulte Vamos Conectar: Seu Guia de Cabo Serial e o Guia de Cabeamento para Console e Portas AUX.

Nota: As portas assíncronas do conector de 68 pinos são dispositivos de equipamentos de terminal de dados (DTE). Dispositivos DTE a DTE exigem um cabo laminado (modem nulo) e dispositivos DTE a DCE (equipamento de terminação de circuito de dados) requerem um cabo com ligação direta. O cabo CAB-OCTAL-ASYNC é laminado. Consequentemente, você pode conectar cada cabo diretamente às portas console dos dispositivos com interfaces RJ-45. Entretanto, se a porta console do dispositivo ao qual você irá se conectar for uma interface de 25 pinos (DCE), deverá utilizar o adaptador RJ-45 para 25 pinos identificado como "Modem" (para inverter o "laminado"”) para completar a conexão.

Esta tabela mostra os tipos de porta para a console e portas auxiliares em roteadores e switches Cisco:

Tipo de interface Interface DB25 Interface RJ-45
Console DCE DTE
AUX DTE DTE

Estratégia do projeto

Configure o servidor terminal de modo que você possa acessá-lo de qualquer lugar. Para tornar o servidor terminal acessível, atribua um endereço de Internet público registrado e localize o servidor fora do firewall. Isso feito, os problemas com o firewall não interromperão sua conexão. Você pode sempre manter a conectividade ao servidor terminal e acessar os dispositivos conectados. Se você tiver preocupações com a segurança, configure listas de acesso para permitir o acesso ao servidor terminal apenas de determinados endereços. Para obter uma solução de segurança mais robusta, você também pode configurar a Autenticação, Autorização e Auditoria (AAA) com base no servidor, por exemplo, RADIUS ou TACACS+. Para obter mais informações sobre AAA, consulte o Autenticação, Autorização e Auditoria (AAA).

É possível configurar um modem na porta auxiliar do servidor terminal para backup de discagem no caso da conexão principal (pela Internet) falhar. Esse modem elimina a necessidade de configurar um backup de discagem para cada dispositivo. O servidor terminal é conectado através de duas portas assíncronas às portas console dos outros dispositivos. Para obter mais informações sobre como conectar um modem à porta auxiliar, consulte o Guia de Conexão do Roteador ao Modem.

Utilize a instrução ip default gateway e aponte para o roteador de salto seguinte na Internet. Esse comando permite que você se conecte ao servidor terminal pela Internet mesmo que o roteamento não esteja habilitado. Por exemplo, o servidor terminal está no modo Monitor de ROM (ROMMON) como resultado de uma reinicialização ruim após uma interrupção de energia.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

Configurações

Este documento utiliza esta configuração:

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.


!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.


!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.


!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch.
 

!--- An EXEC session ensures that the line never becomes unavailable 


!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.


!--- Allow all protocols to use the line.


!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.


!--- Note: This configuration does not implement modem on AUX port modem InOut. 


!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

Nota: Se você utiliza o 3600 como o servidor de acesso, consulte Como as Linhas Assíncronas são Numeradas nos Roteadores Cisco 3600 Series para obter detalhes sobre o número de linha.

Resumo de comandos

ip host - Use esse comando para definir o mapeamento de nome para endereço do host estático no cache do host. para remover o mapeamento de nome para endereço, use a forma no desse comando.

  • ip host name [tcp-port-number] address1 [address2...address8]

    • name - Esse campo indica o nome do host. O campo de nome não precisa corresponder ao nome real do roteador ao qual você deseja se conectar. No entanto, assegure-se de digitar um nome que você utilizaria na Telnet reversa. Quando você utiliza esse comando e o campo de nome, não é necessário saber o número da porta real do dispositivo remoto.

    • tcp-port-number - Esse campo representa o número da porta TCP à qual você deseja se conectar ao utilizar o nome de host definido juntamente com um comando EXEC connect ou telnet. Em nosso exemplo de configuração, utilizamos Telnet reversa, então, o número da porta deve ser 2000+line.

    • address1 - esse campo representa um endereço IP associado. Em nosso exemplo de configuração, utilizamos o endereço IP de loopback.

transport input - Use esse comando para definir os protocolos a serem utilizados quando você se conecta a uma linha específica do roteador.

  • transport input {all | lat | espanador | nasi | nenhum | almofada | rlogin | telnet | v120}

    • all — All seleciona todos os protocolos.

    • none — None impede a seleção de qualquer protocolo na linha. Nesse caso, a porta torna-se inutilizável para conexões recebidas.

    Nota:  Em nosso exemplo de configuração, as linhas assíncronas utilizam a configuração mínima do comando transport input telnet. Assim você pode utilizar a Telnet para os dispositivos na linha assíncrona.

telnet - Use esse comando EXEC para efetuar login em um host que oferece suporte a Telnet.

  • telnet host [port] [keyword]

    • host Esse campo indica um nome de host ou um endereço IP. O host pode ser um dos campos de nome definidos no comando ip host.

    • port - Esse campo indica um número da porta TCP decimal. A porta do roteador Telnet (decimal 23) no host é o número da porta TCP decimal padrão. Para a Telnet reversa, o número da porta deve ser 2000+line. Os números de linha variam de 1 a 16 em nossa configuração. Use o comando show line EXEC para ver as linhas disponíveis.

Comute entre Sessões Ativas

Siga estas etapas a fim de comutar entre sessões ativas:

  1. Use a sequência de escape Ctrl-Shift-6 e, em seguida, x para sair da sessão atual.

  2. Use o comando show sessions para exibir todas as conexões abertas.

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Nota: O asterisco (*) indica a sessão atual do terminal.

  3. Digite o número da sessão (conexão) para se conectar ao dispositivo correspondente. Por exemplo, para se conectar ao 2511-1 digite 1, que é o número de conexão. No entanto, se você pressionar a tecla de retorno, se conectará à sessão do terminal atual que, nesse caso, é o roteador 2511-3.

Encerre Sessões Ativas

Siga estas etapas para encerrar uma sessão de Telnet específica:

  1. Use a sequência de escape Ctrl-Shift-6 e, em seguida, x para sair da sessão Telnet atual.

    Nota: Assegure-se de que você possa emitir a sequência de escape confiavelmente para suspender uma sessão Telnet. Alguns pacotes de emulador terminal não podem enviar a sequência correta, Ctrl-Shift-6 e x.

  2. Execute o comando show sessions para exibir todas as conexões abertas.

  3. Execute o comando disconnect [connection] para se desconectar da sessão necessária.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show ip interface brief - indica se a interface utilizada para a sessão Telnet está ativa.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Procedimento de Troubleshooting

Siga estas instruções para resolver problemas da sua configuração.

Se você não puder se conectar ao roteador de sua escolha com um nome configurado no comando ip host, verifique:

  1. Verifique se o endereço da porta está configurado corretamente.

  2. Verifique se o endereço (interface) utilizado para a Telnet reversa é up/up. A saída do comando show ip interface brief fornece essas informações. A Cisco recomenda utilizar loopbacks porque estão sempre ativos.

  3. Assegure-se de que você tenha o tipo correto de cabeamento. Por exemplo, você não deve utilizar um cabo crossover para aumentar o comprimento. Consulte a seção Cabeamento para obter mais informações.

  4. Estabeleça uma conexão Telnet à porta do endereço IP para testar a conectividade direta. Você deve utilizar telnet de um dispositivo externo e do servidor terminal. Por exemplo, telnet 172.21.1.1 2003.

  5. Assegure-se de que você tenha o comando transport input telnet abaixo da linha para o dispositivo de destino. O dispositivo de destino é o dispositivo que está conectado ao servidor terminal.

  6. Use um terminal PC/"burro" para se conectar diretamente à console do roteador de destino. O roteador de destino é o dispositivo conectado ao servidor terminal. Esse passo o ajuda a identificar a presença de um problema na porta.

  7. Se você for desconectado, verifique os tempos limites. Você pode remover ou ajustar os tempos limites.

    Nota: Se você encontrar falhas de autenticação, lembre-se que o servidor terminal executa a primeira autenticação (se configurado), quando o dispositivo a que você experimentar se conectar executar a segunda autenticação (se configurado). Verifique se a Autenticação, Autorização e Auditoria estão configuradas corretamente no servidor terminal e no dispositivo de conexão.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5466