Discar e acessar : Conexões assíncronas

Configuração de Dialout com um modem na porta AUX

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como usar um modem na porta auxiliar (AUX) para configurar a discagem. Neste cenário, um roteador com um modem na porta auxiliar (AUX) disca para a Interface de acesso básico (PRI, Primary Rate Interface) do roteador do site central.

Nota: Não apresentaremos um cenário de backup, apenas a discagem de roteamento por demanda (DDR, dial-on-demand routing) entre roteadores com um modem na porta auxiliar (AUX).

Pré-requisitos

Requisitos

Antes de tentar essa configuração, assegure-se de que entendeu os vários problemas associados a modems em portas auxiliares (AUX). Para obter mais informações sobre esses problemas, consulte o Guia de Conexão Modem-Roteador.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Um Cisco 2600 Series Router que execute o Cisco IOS?? Software Release 12.1(2).

  • Um roteador Cisco AS5300 que execute o software Cisco IOS Release 12.0(7)T.

Nota: Essa configuração pode ser aplicada a qualquer roteador com uma porta auxiliar (AUX) ou até mesmo uma porta console. Entretanto, devido aos problemas de controle do modem RS232 e a alguns problemas relativos à segurança, não é recomendável conectar um modem à porta console. Consulte o Guia de Conexão Modem-Roteador para obter mais informações.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/5465/mod-aux-dialout.gif

Configurações

Este documento utiliza as seguintes configurações:

  • maui-slt-01 (2600)

  • maui-nas-03 (5300)

Nessa configuração, o maui-SLT-01(2600) usa o modem na porta auxiliar (AUX) para discar para a PRI do maui-nas-03 (um AS5300). O NAS (maui-nas-03) é configurado para enviar a chamada para um modem digital interno.

maui-slt-01 (2600)
maui-slt-01#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-slt-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-nas-03 password 0 cisco

!--- Defines username for remote router (maui-nas-03), and shared secret 
!--- password. Shared secret (used for CHAP authentication)
!--- must be the same on both sides.

!
memory-size iomem 30
ip subnet-zero
!
chat-script Dialout ABORT ERROR ABORT BUSY "" 
"AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

!--- Sets up chat script "Dialout" used for the dialout connection on aux 0.

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!--- Modemcap (MY_USR_MODEM) is applied to the AUX port line interface.
!--- This modemcap was created through the command:
!--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
!--- See the Modem-Router Connection Guide for more information.

!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!

!--- Irrelevant output has been removed.

!
interface Async65

!--- Async interface that corresponds to the AUX Port. 
!--- This was determined through the show line command.
!--- See External Modem Setup and Troubleshooting Tasks for more information.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation over this link.

 dialer in-band
 dialer pool-member 20

!--- Designate Async65 as member of dialer pool 20.
!--- The dialer pool 20 command is specified in interface Dialer 10.

 async default routing

!--- This permits routing over the async interface.
!--- This is required for a routing protocol to run accross the async link.

 ppp authentication chap callin
!
interface Dialer10

!---Dialer 10 is the logical interface for Dialer Pool 20.

 ip unnumbered Loopback0

!--- This uses the Loopback 0 IP address.

 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name maui-nas-03

!--- This specifies the remote router name. 
!--- This name must match the name that the remote router uses for 
!--- authentication.

 dialer pool 20

!--- Async 65 is a member of this pool.

 dialer idle-timeout 900
 dialer string 81690

!--- This defines the phone number of the destination router.

 dialer max-call 4096
 dialer-group 1

!--- Apply the definition of interesting traffic from dialer-list 1.


 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls.

!
router ospf 5
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0

!---OSPF is used between the routers.
!---A routing protocol is unnecessary if you configure appropriate static routes.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10

!--- Default route points to int dialer 10. 
!--- This is necessary because OSPF is not configured to send default routes.

no ip http server
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Use access list 101 for interesting traffic definition.
!--- This is applied to interface Dialer 10 through dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
!
line aux 0

!--- Line interface for the AUX port.

 exec-timeout 0 0

!--- This disables exec timeout on the interface.

 script dialer Dialout

!--- Use chat script "Dialout".

 modem InOut

!--- This enables incoming and outgoing calls.

 modem autoconfigure type MY_USR_MODEM

!--- Now apply the modemcap MY_USR_MODEM that you configured previously.

 transport input all
 stopbits 1

!--- Reduce async framing overhead to improve throughput. 

 speed 115200

!--- The AUX port on the 2600 supports a speed of 115200.
!--- Note: If you route through the AUX port, each character generates a 
!--- processor interrupt. This is an abnormally high load on the CPU, 
!--- which can be resolved if you use a lower AUX port speed.

 flowcontrol hardware

!--- This configures RTS/CTS flow control.

line vty 0 4
!
no scheduler allocate
end

maui-nas-03 (5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-slt-01 password 0 cisco

!--- Defines username for remote router (maui-slt-01) and shared secret password.
!--- Shared secret(used for CHAP authentication) must be the same on both sides.

spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
ip subnet-zero
!
isdn switch-type primary-ni
mta receive maximum-recipients 0
!
controller T1 0

!--- Primary T1.

 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

!--- Irrelevant output has been removed.

!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.22.53.105 255.255.255.0
 no ip directed-broadcast
 no keepalive
!

!--- Irrelevant output has been removed.

!
interface Serial0:23

!--- D-channel for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- This sends incoming async calls to the modems.

 fair-queue 64 256 0
 ppp authentication chap
!         

!--- Irrelevant output has been removed.

!
interface Group-Async0

!--- Group-Async interface is used to aggregate the modems.

 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf network point-to-point

!--- This identifies the type of OSPF network. 

 async default routing

!--- This permits routing over the async interface.
!--- It is required for a routing protocol to run on the async link.

 async mode interactive
 peer default ip address pool clientpool

!--- This assigns an IP address from the pool named "clientpool" for the
!--- incoming call.

 ppp authentication chap
 group-range 1 96
!
router ospf 5
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
!
ip local pool clientpool 172.22.1.2 172.22.1.30

!--- IP addresses for dialin calls are given from this pool.

ip classless
no ip http server
!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 1 96
 autoselect ppp
 modem InOut
 transport preferred lat pad telnet rlogin udptn v120 lapb-ta
 transport output lat pad telnet rlogin udptn v120 lapb-ta
line aux 0
line vty 0 4
!
end

Nota: O maui-nas-03 não é especialmente configurado para aceitar apenas chamadas de maui-slt-01 (o cliente). Do ponto de vista do NAS (maui-nas-03), a chamada recebida é apenas outro cliente de discagem. Essa configuração pode ser usada para que muitos clientes remotos disquem para a PRI do NAS do site central e se conectem à rede corporativa.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Exemplo de saída de show

Use o comando show ip route para verificar se há uma rota para a interface do discador ou para a interface assíncrona. Se não houver nenhuma rota para a interface assíncrona ou do discador, a discagem não poderá ocorrer. Portanto, configure rotas estáticas quando necessário.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Dialer10

Nota: Há uma rota padrão para a interface do discador.

O roteador inicia a discagem, se conecta, negocia o PPP e troca o banco dados OSPF. Para obter mais detalhes sobre esse processo, consulte as informações de debugação a seguir:

Use o comando show ip route depois de estabelecer uma conexão bem-sucedida. Neste cenário, o protocolo de roteamento OSPF é usado. Observe as rotas OSPF adicionadas à tabela de roteamento.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1795] via 172.22.1.1, 00:00:03, Dialer10
C       172.22.1.1/32 is directly connected, Dialer10
S*   0.0.0.0/0 is directly connected, Dialer10

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Tarefas de Configuração e Troubleshooting de Modem Externo

Conclua as etapas para configurar o modem externo e verifique se o modem funciona corretamente. Verifique se o roteador pode discar e se conectar com a ajuda desse modem. Se ele puder, você poderá efetuar a configuração DDR necessária, a configuração PPP e outras configurações de protocolo de nível superior no roteador de discagem. Esta seção presume que o roteador que recebe a chamada está configurado corretamente, como mostrado acima.

  1. Conecte o cabo apropriado da porta AUX ao modem. Para obter mais informações sobre opções de cabeamento, consulte o Guia de Conexão Modem-Roteador.

  2. Utilize o comando show line para determinar a interface assíncrona da porta AUX. Embora a maioria dos roteadores tenha a porta AUX como a interface assíncrona 1, os servidores de acesso têm a interface da porta AUX após as linhas TTY. Por exemplo, se seu roteador tiver 16 linhas assíncronas ou de modem, a porta auxiliar (AUX) será a linha 17. Nesse caso, a porta AUX deve ser configurada na interface assíncrona 17. Configure a porta AUX com base nas saídas show line. Este exemplo verifica se no maui-slt-01 a configuração da porta auxiliar (AUX) está na interface Async65.

    maui-slt-01#show line
       Tty Typ   Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise  Overruns  Int
    *    0 CTY            -    -      -    -    -     0      0     0/0      -
        65 AUX 9600/9600  -    -      -    -    -     0      1     0/0      -
        66 VTY            -    -      -    -    -     0      0     0/0      -
        67 VTY            -    -      -    -    -     0      0     0/0      -
        68 VTY            -    -      -    -    -     0      0     0/0      -
        69 VTY            -    -      -    -    -     0      0     0/0      -
        70 VTY            -    -      -    -    -     0      0     0/0      -
    
    Line(s) not in async mode -or- with no hardware support: 
    1-64
  3. Configure uma tampa de modem para o modem conectado à porta AUX. Consulte o Modem-Router Connection Guide (Guia de conexão entre modem e roteador) para obter a string de inicialização apropriada a ser usada para a plataforma do modem. Crie um novo modemcap que inclua essa string de inicialização (init). Aqui está um exemplo de um novo modemcap (nomeado MY_USR_MODEM):

    maui-slt-01(config)#modemcap edit MY_USR_MODEM miscellaneous &F1S0=1

    Na configuração da tampa de modem, acima, &F1S0=1 é a série init. Consulte Como Criar um Modemcap para obter informações específicas sobre a string init apropriada ao seu modem.

  4. Aplique o modemcap à porta auxiliar (AUX). Verificamos previamente que a porta auxiliar (AUX) está na linha 65.

    maui-slt-01(config)#line 65
    maui-slt-01(config-line)#modem autoconfigure type MY_USR_MODEM

    Configure também a linha de porta AUX para a conectividade do modem. Consulte o Guia de conexões modem-roteador para obter informações sobre a configuração da linha. A configuração de exemplo de maui-slt-01 mostrada anteriormente também inclui os comandos necessários.

    Use debug confmodem para verificar se o modemcap foi aplicado corretamente. Depois de você executar o ciclo de energia do modem, o roteador configurará automaticamente o modem.

    maui-slt-01#debug confmodem
    Modem Configuration Database debugging is on
    maui-slt-01#
    
    !--- Power cycle the modem.
    
    *Mar  1 06:58:10.118: TTY65: detection speed (115200) response ---OK---
    *Mar  1 06:58:10.122: TTY65: Modem command:  --AT&F1S0=1--
    
    !--- Apply the init string specified in the modemcap.
    
    *Mar  1 06:58:10.758: TTY65: Modem configuration succeeded
    
    !--- Modem configuration is successful.
    
    *Mar  1 06:58:10.758: TTY65: Detected modem speed 115200
    *Mar  1 06:58:10.758: TTY65: Done with modem configuration
    maui-slt-01#
  5. Emita o comando show line aux 0 ou show line aux-line. Verifique se todos os sinais estão ativos. Por exemplo, CT, RTS, DTR, CD. Se nada aparecer ao lado deles, eles estarão ativados. Se aparecer um "No" ao lado deles (por exemplo, No CTS), significa que eles estão desativados. Se estiverem desativados, verifique o cabo e a configuração no roteador. Verifique também se a interface assíncrona e a linha da porta auxiliar (AUX) estão configuradas corretamente. Para obter mais informações sobre cabelamento, consulte o Modem-Router Connection Guide (Guia de conexão entre modem e roteador). Use o documento em Resolução de Problemas de Conexões de Discagem para obter informações sobre como resolver problemas. Aqui está um exemplo:

    maui-slt-01#show line 65
       Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
    A   65 AUX 115200/115200- inout     -    -    -      8       1     1/0       -
      Ready
    
    Line 65, Location: "PPP: 172.22.1.1", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
    Status: Ready, Active, No Exit Banner, Async Interface Active
      Modem Detected, CTS Raised, Modem Signals Polled
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Modem Autoconfigure
    Modem state: Ready
    Group codes:    0
    Line is running PPP routing for address 172.22.1.1.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS
    
    !--- All signals are up.
    
     TTY NUMBER 65
    Parity Error = 0 Framing Error = 536 Receive Error = 536 Overrun = 1
    Outcount = 0 totalout = 40615 incount = 0 totalin = 49805
    , Modem Configured
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none                   
    Timeouts:    Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                 00:10:00        never                        none    not set
                              Idle Session Disconnect Warning
                                never 
                              Login-sequence User Response
                               00:00:30
                              Autoselect Initial Wait
                                not set 
    Modem type is MY_USR_MODEM.
    
    !--- Modemcap is MY_USR_MODEM.
    
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 10.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed transports are lat pad v120 mop telnet rlogin nasi. 
    Preferred is lat.
    No output characters are padded
    No special data dispatching characters
    maui-slt-01# 
  6. Execute T

    elnet reverso na porta auxiliar (AUX) para o modem e use o conjunto de comandos AT para discar e se conectar manualmente ao dispositivo remoto. Isso pode ser usado para verificar se o hardware de modem e o circuito de telefone funcionam corretamente. Neste exemplo, como a porta auxiliar (AUX) está na linha 65, você deve inverter telnet para a porta 2065 no roteador. Para obter mais informações sobre Telnets Reversos, consulte Establishing a Reverse Telnet Session to a Modem (Estabelecendo um Telnet Reverso com um Modem).

    maui-slt-01#telnet 172.17.1.1 2065 
    Trying 172.17.1.1, 2065 ...Open
    
    User Access Verification
    
    Username: admin Password:
    
    !--- Authentication performed by local router for the reverse Telnet.
    
    at
    OK
    atdt 81690 
    
    !--- The modem dials (81690), and connects. 
    !--- This process takes approximately 30 to 45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connection speed and protocols that were negotiated.
    
    User Access Verification
     
    Username: maui-slt-01
    Password:
    
    !--- Authentication performed by the remote router for the incoming call.
    
    
    
    maui-nas-03>
    
    !--- Prompt on the remote router.
    
    

    Como mostrado acima, executamos Telnet reverso para o modem e usamos o comando at para verificar se o modem responde. Quando você receber o OK, disque o número remoto com a ajuda do comando atdt number. A chamada prossegue e se conecta ao dispositivo remoto. O roteador remoto autentica a chamada de entrada. Caso note que o modem externo não disca, verifique se o cabeamento está correto, se o modem externo não está com defeito e se a linha de telefone está ativa. Consulte Configurando Suporte a Modems e Outros Recursos Assíncronos e Troubleshooting de Conexões de Discagem de Entrada para obter mais informações.

    Quando você concluir as tarefas e os procedimentos acima, poderá continuar testando se o roteador pode estabelecer a conexão dial-up automaticamente. Consulte as seções Exemplo de Saída Show e Exemplo de Saída Debug do documento Configuração de Discagem Usando um Modem na Porta Auxiliar (AUX) para obter mais informações.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer??? os indicadores debugam a informação sobre os pacotes recebidos em uma interface do discador. Quando o DDR está habilitado na interface, as informações referentes à causa de qualquer chamada (a causa da discagem) também são mostradas. Para obter mais informações, consulte o comando debug dialer em debug clns - debug fras.

  • debugar o modem??? indica a atividade de linha de modem, o controle do modem e os mensagens de ativação do processo no roteador.

  • debugar o bate-papo??? monitora a execução do chat script quando discar async/POTS é iniciado. Consulte a seção Chamada de Saída Assíncrona - Verificação de Operação de Script de Bate-papo da Tecnologia Dial-up: Técnicas de Troubleshooting para obter mais informações.

  • debugar a negociação ppp??? indica a informação no tráfego e as trocas como negocia os componentes de PPP como, o protocolo de controle de link (LCP), a autenticação, e o protocolo network control PPP (NCP). Uma negociação de PPP bem-sucedida abre primeiramente o estado do LCP e, em seguida, autentica e, finalmente, negocia o NCP.

  • debugar a autenticação de PPP??? indica os mensagens de protocolo da autenticação de PPP, isso inclui intercâmbios de pacotes do protocolo challenge authentication (RACHADURA) e trocas do protocolo password authentication (PAP).

Exemplo de debug

Use estes comandos de debugação para resolver os problemas da conexão:

maui-slt-01#debug dialer
Dial on demand events debugging is on
maui-slt-01#debug chat
Chat scripts activity debugging is on
maui-slt-01#debug modem
Modem control/process activation debugging is on
maui-slt-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-slt-01#debug ppp authentication
PPP authentication debugging is on       
maui-slt-01#
maui-slt-01#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
maui-slt-01#
maui-slt-01#ping 172.22.53.105

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.22.53.105, timeout is 2 seconds:

*Mar  1 05:37:44.858: As65 DDR: rotor dialout [priority]
*Mar  1 05:37:44.858: As65 DDR: Dialing cause ip (s=172.17.1.1, d=172.22.53.105)

!--- Dialing reason.

*Mar  1 05:37:44.858: As65 DDR: Attempting to dial 81690

!--- Phone number that is dialed.

*Mar  1 05:37:44.858: CHAT65: Attempting async line dialer script
*Mar  1 05:37:44.858: CHAT65: Dialing using Modem script: Dialout
 & System script: none

!--- Use the chat-script "Dialout".

*Mar  1 05:37:44.862: CHAT65: process started
*Mar  1 05:37:44.862: CHAT65: Asserting DTR
*Mar  1 05:37:44.862: TTY65: Set DTR to 1
*Mar  1 05:37:44.862: CHAT65: Chat script Dialout started

!--- Chat-script "Dialout" has started.

*Mar  1 05:37:44.862: CHAT65: Sending string: AT
*Mar  1 05:37:44.862: CHAT65: Expecting string: OK
*Mar  1 05:37:44.990: CHAT65: Completed match for expect: OK
*Mar  1 05:37:44.990: CHAT65: Sending string: ATDT \T<81690>
*Mar  1 05:37:44.990: CHAT65: Expecting string: CONNECT
*Mar  1 05:38:02.774: CHAT65: Completed match for expect: CONNECT
*Mar  1 05:38:02.774: CHAT65: Sending string: \c
*Mar  1 05:38:02.774: CHAT65: Chat script Dialout finished, status = Success

!--- Chat script is successful. 
!--- Notice the Expect/Send Attributes and the time elapsed.

*Mar  1 05:38:02.774: TTY65: destroy timer type 1
*Mar  1 05:38:02.778: TTY65: destroy timer type 0
*Mar  1 05:38:04.778: %LINK-3-UPDOWN: Interface Async65, changed state to up
*Mar  1 05:38:04.778: Async65 DDR: Dialer statechange to up
*Mar  1 05:38:04.778: %DIALER-6-BIND: Interface As65 bound to profile Di10
*Mar  1 05:38:04.782: Async65 DDR: Dialer call has been placed
*Mar  1 05:38:04.782: As65 PPP: Treating connection as a callout

!--- PPP LCP negotiation begins.

*Mar  1 05:38:04.782: As65 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 05:38:04.782: As65 PPP: No remote authentication for call-out
*Mar  1 05:38:04.782: As65 LCP: O CONFREQ [Closed] id 43 len 20
*Mar  1 05:38:04.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:04.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:04.786: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:04.786: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:06.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:06.782: As65 LCP: O CONFREQ [REQsent] id 44 len 20
*Mar  1 05:38:06.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:06.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:06.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:06.782: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:08.782: As65 LCP: O CONFREQ [REQsent] id 45 len 20
*Mar  1 05:38:08.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.782: As65 LCP:    ACFC (0x0802)

!--- Observe that two outgoing CONFREQs timed out.
!--- If you observe such a situation with no incoming CONFREQs, verify that the 
!--- autoselect ppp or async mode dedicated commands are configured
!--- on the router that receives the call.

*Mar  1 05:38:08.934: As65 LCP: I CONFREQ [REQsent] id 2 len 25
*Mar  1 05:38:08.934: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.934: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.934: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.938: As65 LCP: O CONFACK [REQsent] id 2 len 25
*Mar  1 05:38:08.938: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.938: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.938: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.942: As65 LCP: I CONFACK [ACKsent] id 45 len 20
*Mar  1 05:38:08.946: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.946: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.946: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.946: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.946: As65 LCP: State is Open
*Mar  1 05:38:08.946: As65 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 05:38:09.066: As65 CHAP: I CHALLENGE id 1 len 32 from "maui-nas-03"
*Mar  1 05:38:09.066: As65 CHAP: O RESPONSE id 1 len 32 from "maui-slt-01"
*Mar  1 05:38:09.206: As65 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful.

*Mar  1 05:38:09.206: As65 PPP: Phase is UP
*Mar  1 05:38:09.210: As65 IPCP: O CONFREQ [Not negotiated] id 13 len 10
*Mar  1 05:38:09.210: As65 IPCP:    Address 172.17.1.1 (0x0306AC110101)
*Mar  1 05:38:09.218: As65 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.218: As65 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.350: As65 IPCP: I CONFNAK [ACKsent] id 13 len 10
*Mar  1 05:38:09.350: As65 IPCP:    Address 172.22.1.9 (0x0306AC160109)
*Mar  1 05:38:09.350: As65 IPCP: O CONFREQ [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: I CONFACK [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: State is Open

!--- IPCP negotiation is complete.

*Mar  1 05:38:09.482: As65 DDR: dialer protocol up
*Mar  1 05:38:09.482: Di10 IPCP: Install route to 172.22.1.1
*Mar  1 05:38:10.206: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,
 changed state to up

!--- Interface is up.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5465