Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

Configurando o modo seguro (do roteador) no módulo content switching

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O CSM (Módulo de switching de conteúdo) fornece conexões de alto desempenho entre os usuários de rede e server farms, com base nas informações das camadas 4 até 7. Você pode representar um grupo de servidores reais (o server farm) como uma instância de servidor simples (servidor virtual), balancear o tráfego ao server farm, selecionando um dos métodos de balanceamento de carga de servidores e limitar o tráfego a servidores individuais (conexões difíceis) e a server farms (políticas). Esta configuração de exemplo descreve como configurar o Server Load Balancing (SLB) no Catalyst 6000 Family CS.

Você não pode executar o software de SLB do � do Cisco IOS no mesmo interruptor que o CS. Você deve configurar o modo de CSM emitindo o modo do slb IP [csm | comando rp] antes de alguma configuração. No comando ip slb mode, o argumento rp é padrão.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Versão de IOS Supervisor 12.1(8)EX da família Catalyst 6000 para Supervisor Engine 1 com MSFC1 (c6sup11-jsv-mz.121-8.EX)

  • Liberação de software CSM 2.1(0) do Catalyst 6000 Family (c6slb-apc.2-1-1.bin)

O CSM é executado na versão 12.1(6)E ou posteriores do Cisco IOS. Se você está usando um Supervisor Engine 2, você deve usar o Cisco IOS Release 12.1(8a)E ou Mais Recente.

Modo de operação

As conexões do cliente e servidor com o CS podem usar a camada 2 ou o switching da camada 3. Os clientes conectam ao lado VLAN do cliente, e os server conectam ao lado de servidor VLAN. Servidores e clientes podem existir em diferentes sub-redes. Os server podem igualmente ser encontrados mais de um salto afastado e conectar ao lado de servidor VLAN através do Roteadores. Neste caso, o gateway padrão dos server e o roteamento através da rede dos server ao lado de servidor VLAN CS devem dirigir todo o tráfego equilibrado carga dos server com o CS, ou o cliente serverfarm NAT deve ser configurado no CS para todo o tráfego destinado aos server na fazenda do server. Um cliente envia um pedido a um endereço VIP, ao � e ao CS para a frente o pedido a um server que possa satisfazer o pedido. O server para a frente a resposta ao CS, e o CS para a frente a resposta ao cliente.

Quando o lado do cliente e o lado de servidor VLAN estão em sub-redes diferentes, você pode configurar o CS no modo seguro (do roteador). Esta configuração de exemplo centra-se sobre a configuração de modo segura (do roteador). Quando o lado do cliente e o lado de servidor VLAN estão na mesma sub-rede, você pode configurar o CS para operar-se no modo da sub-rede única (ponte). Refira as configurações de amostra abaixo para mais informação.

Diagrama de Rede

O lado do cliente e o lado de servidor VLAN estão em sub-redes diferentes no modo seguro (do roteador). O diagrama mostra como a configuração de modo seguro (roteador) está definida.

csm_router.gif

Configurações

Termine estas etapas para configurar o CS para o modo seguro (do sub-rede múltipla):

  1. Selecione o modo CSM.

    cat(config)# ip slb mode csm
    
  2. Crie o cliente e servidor VLAN no banco de dados. Ao retirar o modo de banco de dados de VLAN, as alterações de configuração são aplicadas.

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. Configure interfaces físicas que conectem o cliente (uplink) à VLAN correspondente.

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. Configurar as interfaces física que conectam os server ao VLAN correspondente.

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. Crie o lado VLAN do cliente e o gateway.

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. Crie o lado de servidor VLAN.

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. Crie o serverfarm.

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. Crie o vserver e associe o serverfarm.

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

O seguinte é uma configuração de exemplo do Server Load Balancing que usa o Cisco catalyst 6500 e o CS.

Configuração running CS (WS-X6066-SLB-APC)
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.� 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
�ip address 172.17.63.217 255.255.255.192 
�gateway 172.17.63.210 
! 


!--- Server side VLAN configuration.�
 
ip slb vlan 200 server 
�ip address 10.1.1.251 255.255.255.0 
�alias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
�nat server� 
�no nat client 
real 10.1.1.3 
� inservice 
�real 10.1.1.5 
� inservice 
! 


!--- Vserver configuration.�
 
ip slb vserver SERVER 
�virtual 172.17.63.241 tcp www 
�serverfarm WWWFARM 
�inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
�no ip address 
�switchport 
�switchport access vlan 100 
�switchport mode access 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
� 
interface FastEthernet2/3 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access 
! 
interface FastEthernet2/4 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access ... 
interface FastEthernet2/48 
�no ip address 
�shutdown 
! 
interface Vlan1 
�no ip address 
�shutdown 
! 
interface Vlan100 
�ip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
�login 
! 
end

comandos show

Nota: A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Comando show ip slb status

O comando show ip slb status mostra o status do módulo SLB. O módulo deve ser em linha.

cat6#show ip slb status�
SLB Module is online in slot 3.�
Configuration Download state: COMPLETE, SUCCESS

Comando show ip slb vserver

O comando show ip slb vserver exibe informações sobre o servidor virtual. Você igualmente vê o estado do servidor virtual e quantas conexões lá são:

cat6#show ip slb vserver
slb vserver�� prot��� virtual������������� vlan�� state�������� conns����������
---------------------------------------------------------------------------
SERVER������� TCP���� 172.17.63.241/32:80� ALL��� OPERATIONAL�� 0

Comando show ip slb reals

O comando show ip slb reals indica a informação para cada servidor real, tal como a fazenda do server onde cada server reside, os estados do servidor, os pontos iniciais, e as conexões.

cat6#show ip slb reals
real����������������� server farm����� weight� state��������� conns
-------------------------------------------------------------------
10.1.1.5������������� WWWFARM��������� 8������ OPERATIONAL��� 0��������
10.1.1.3������������� WWWFARM��������� 8������ OPERATIONAL��� 0

Comando show ip slb serverfarms

O comando show ip slb serverfarms exibe informações sobre o server farm. Esse comando mostra o preditor utilizado para o balanceamento de carga. Este exemplo usa o padrão, arredondamento robin.

cat6#show ip slb serverfarm
server farm��� predictor��� nat�� reals�� redirect� bind id
-------------------------------------------------------------
WWWFARM������� RoundRobin�� S���� 2������ 0�������� 0

Comando show ip slb vlan

O comando show ip slb vlan indica a informação de VLAN para o cliente e o server.

cat6# show ip slb vlan
vlan�� IP address������ IP mask����������� type��
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192��� CLIENT
200��� 10.1.1.251������ 255.255.255.0����� SERVER

Troubleshooting

Você pode somente sibilar o servidor real do Catalyst 6500 usando o comando ping slb, como mostrado abaixo.

cat6#ping slb 10.1.1.3�
IP address������ Reachable�
--------------------------�
10.1.1.3�������� Yes

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5448