IP : Border Gateway Protocol (BGP)

Compreendendo a agregação de rota no BGP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O Border Gateway Protocol (BGP) permite a agregação de rotas específicas em uma única rota com uso do comando aggregate-address address mask [as-set] [summary-only] [suppress-map map-name] [advertise-map map-name] [attribute-map map-name]. Ao realizar o comando aggregate-address sem quaisquer argumentos, não ocorre a herança de atributos de rota individual (como AS_PATH ou community), o que causa uma perda da granularidade. Este documento ilustra como manipular os diferentes atributos ao usar o comando aggregate-address e como influenciar a propagação.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas. Contudo, a configuração neste documento foi testada com Software Release 12.2(28) de Cisco IOS�.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diagrama de Rede

/image/gif/paws/5441/aggregation1.gif

Agregado sem o argumento do recurso

O uso do argumento do recurso cria um endereço agregado com um conjunto matemático dos sistemas autônomo (AS). Este argumento do recurso resume os atributos AS_path de todas as rotas individuais. Estas configurações de amostra permitem-no de examinar esta característica e como este argumento ajuda o BGP a detectar e evitar laços.

Roteador A
Current configuration: 

 hostname RouterA 
 ! 
 interface Serial1 
  ip address 2.2.2.2 255.0.0.0 
 !  
interface Loopback0
  ip address 160.20.1.1 255.255.0.0
 !
 router bgp 100 
  network 160.20.0.0 

!--- Router A advertises network 160.20.0.0/16.      

  neighbor 2.2.2.1 remote-as 300 
 ! 
 end

roteador B
Current configuration: 

 hostname RouterB 
 ! 
 interface Serial0 
  ip address 3.3.3.3 255.0.0.0 
 ! 
interface Loopback0
  ip address 160.10.1.1 255.255.0.0
 !
 router bgp 200 
  network 160.10.0.0 

!--- Router B advertises network 160.10.0.0/16.      

  neighbor 3.3.3.1 remote-as 300 
 ! 
 end

Roteador C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 summary-only  

!--- The network is summarized, and Router C only
!--- advertises 160.0.0.0/8.

 ! 
 end  

Roteador D
Current configuration: 

 hostname RouterD
 ! 
 interface Serial0 
  ip address 4.4.4.4 255.0.0.0 
 ! 
 router bgp 400 
  neighbor 4.4.4.1 remote-as 300                     
 ! 
 end 

O C do roteador (AS-300) agrega as rotas 160.20.0.0/16 e 160.10.0.0/16 que vêm do AS-100 e do AS-200, respectivamente. Esta ação ocorre porque você configurou o argumento somente resumo no roteador que C. Roteador C anuncia somente os 160.0.0.0/8 agregados ao roteador D. Os 160.0.0.0/8 agregados são a rota do Classless Interdomain Routing (CIDR). As 160.10.0.0/16 e 160.20.0.0/16 rotas mais específicas são suprimidas, porque esta tabela de BGP no C do roteador mostra:

RouterC# 
show ip bgp
 
BGP table version is 6, local router ID is 4.4.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      0.0.0.0                            32768 i
s> 160.10.0.0       3.3.3.3                  0             0 200 i
s> 160.20.0.0       2.2.2.2                  0             0 100 i

É aqui a tabela de BGP do roteador D. Observação a informação de caminho da rota agregada:

RouterD# 
show ip bgp

BGP table version is 6, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      4.4.4.1                                0 300 i

A rota agregada 160.0.0.0/8 é considerada ter originado do AS-300 com código de origem IGP. A rota perdeu toda a informação AS_path específica dos prefixos individuais 160.10.0.0/16, do AS-200, e 160.20.0.0/16, do AS-100.

Agregado com o argumento do recurso

Agora, você configura o argumento do recurso no comando aggregate-address no C do roteador. Está aqui a configuração nova:

Roteador C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 summary-only as-set

!--- With the as-set configuration command, the aggregate 
!--- inherits the attributes of the more-specific routes.

 ! 
 end 

Agora, olhar em como este argumento influencia as saídas BGP IP da mostra no roteador D:

RouterD# 
show ip bgp

BGP table version is 2, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      4.4.4.1                                0 300 {200,100} i

Com o argumento do recurso, a informação de caminho na tabela de BGP para que as mudanças da rota agregada incluam um grupo de 300 {200,100}. Este grupo indica que o agregado resume realmente as rotas que passaram com o AS-200 e o AS-100. A informação do recurso torna-se importante na vacância dos loop de roteamento porque os registros da informação onde a rota esteve.

Em toda a rede fechada, esta informação agregada propaga com o BGP e de volta a um dos AS esses as lista do recurso. Esta propagação cria a possibilidade de um laço. O comportamento da detecção do laço do BGP nota seus próprios COMO o número no recurso da atualização agregada e deixa cair o agregado. Esta ação impede um laço.

Nota: O argumento do recurso contém a informação sobre cada rota individual que o agregado resume. As mudanças na rota individual causam uma atualização do agregado. No exemplo, se 160.10.0.0/16 vão para baixo, a informação de caminho do agregado muda 300 {200,100} a 300 {200}. O agregado é atualizado. Se o agregado resume os dez ou as centenas de rotas e das rotas que formam o agregado têm problemas, pode haver um flap constante.

Mude os atributos da rota agregada

O agregado com a seção de argumento do recurso mostra-lhe como usar o recurso para salvar os atributos AS_path com uma rota específica. Em alguns casos, você pode exigir uma mudança nos atributos da rota agregada. Os exemplos de tais atributos incluem a métrica, a comunidade, e a origem.

Esta seção mostra como você pode usar o argumento de mapa de atributo para manipular os atributos do agregado-endereço. Neste caso, você configura umas ou várias das rotas agregadas específicas com o atributo de comunidade sem exportação. O roteador A ajusta o atributo de comunidade sem exportação à rede 160.20.0.0/16 e anuncia a rede ao C do roteador. Esta seção mostra a configuração. O C do roteador herda o atributo de comunidade sem exportação quando o roteador agregar 160.0.0.8. Consequentemente, não há nenhuma propaganda de 160.0.0.0/8 ao roteador D. A configuração do roteador B, o C, e D não mudam. Está aqui a configuração para roteador nova A:

Roteador A
Current configuration: 

 hostname RouterA 

 ! 
 interface Serial1 
  ip address 2.2.2.2 255.0.0.0 
 !  
 router bgp 100 
  network 160.20.0.0 

!--- Router A advertises network 160.20.0.0/16.

  neighbor 2.2.2.1 remote-as 300 
  neighbor 2.2.2.1 send-community 
  neighbor 2.2.2.1 route-map SET_NO_EXPORT out 
 ! 
 access-list 1 permit 160.20.0.0 0.0.255.255 
 route-map SET_NO_EXPORT permit 10 
  match ip address 1 
  set community no-export 

!--- This sets the community attribute no-export.    

  at Router A for route 160.20.0.0/16 
 ! 
 end

Está aqui a tabela de BGP do C do roteador para 160.0.0.0/8:

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 9
Paths: (1 available, best #1, not advertised to EBGP peer)
  Not advertised to any peer
  {200,100}, (aggregated by 300 4.4.4.1)
    0.0.0.0 from 0.0.0.0 (4.4.4.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2
      Community: no-export

A comunidade sem exportação para o roteador o anúncio do C que da rota agregada ao roteador de peer D. Roteador D do eBGP mostra que não aprendeu 160.0.0.0 do C do roteador:

RouterD# show ip bgp 160.0.0.0
% Network not in table

Você pode configurar o argumento de mapa de atributo no C do roteador a fim manipular o atributo de comunidade da rota agregada de sem exportação a nenhuns. Esta configuração permite a propaganda do agregado ao roteador D.

Roteador C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0 
  as-set summary-only attribute-map Map 

!--- Use of the attribute-map argument allows
!--- you to change the community of the aggregate.
 
 ! 
 route-map Map permit 10 
  set community none 

!--- This sets the community of the aggregate to none.

 end

Agora, olhar na tabela de BGP do C do roteador para 160.0.0.0/8. Porque não há nenhum conjunto da comunidade para a rota agregada, o C do roteador anuncia 160.0.0.0/8 ao roteador D.

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 6
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
  2.2.2.2 3.3.3.3 4.4.4.4
  {200,100}, (aggregated by 300 4.4.4.1)
    0.0.0.0 from 0.0.0.0 (4.4.4.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2

A saída BGP 160.0.0.0 da mostra IP no roteador D mostra que o roteador D aprendeu a rota agregada 160.0.0.0/8 do C do roteador.

RouterD# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 10
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  300 {200,100}, (aggregated by 300 4.4.4.1)
    4.4.4.1 from 4.4.4.1 (4.4.4.1)
      Origin IGP, localpref 100, valid, external, best

Use o anunciar-mapa para agregar um subconjunto de rota específica

Se você tem o controle sobre os prefixos individuais que formam a rota agregada, você pode mais facilmente decidir que atributos o agregado levará. Exclua o prefixo 160.20.0.0 da rota agregada no exemplo na mudança os atributos da seção de rota agregada. Neste caso, os 160.0.0.0/8 agregados não herdam o atributo de comunidade sem exportação. A fim fazer esta mudança, configurar o argumento do anunciar-mapa no C do roteador.

Roteador C
Current configuration: 

 hostname RouterC 
 ! 
 interface Serial0 
  ip address 2.2.2.1 255.0.0.0 
 ! 
 interface Serial1 
  ip address 3.3.3.1 255.0.0.0 
 ! 
 interface Serial2 
  ip address 4.4.4.1 255.0.0.0 
 ! 
 router bgp 300 
  neighbor 2.2.2.2 remote-as 100 
  neighbor 3.3.3.3 remote-as 200 
  neighbor 4.4.4.4 remote-as 400 
  aggregate-address 160.0.0.0 255.0.0.0
  as-set summary-only advertise-map SELECT_SP_ROUTE   

!--- You exclude a particular prefix with the
!--- use of advertise-map.

 ! 
 access-list 1 permit 160.10.0.0 0.0.255.255 
 ! 
 route-map SELECT_SP_ROUTE permit 10 
  match ip address 1 
 ! 
 end

Agora, olhar na tabela de BGP do C do roteador para 160.0.0.0/8:

RouterC# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 15
Paths: (1 available, best #1)
  Advertised to non peer-group peers:
  2.2.2.2 4.4.4.4
  200, (aggregated by 300 2.2.2.1)
    0.0.0.0 from 0.0.0.0 (2.2.2.1)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-
aggregate, best, ref 2

Somente o AS-200 é parte da informação AS_path do agregado; O AS-100 não é parte da informação. Também, não há nenhuma herança da comunidade sem exportação de 160.20.0.0/16. Consequentemente, a rota agregada é anunciada ao roteador D. A saída BGP 160.0.0.0 da mostra IP mostra o anúncio:

RouterD# show ip bgp 160.0.0.0
BGP routing table entry for 160.0.0.0/8, version 7
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  300 200, (aggregated by 300 4.4.4.1)
    4.4.4.1 from 4.4.4.1 (4.4.4.1)
      Origin IGP, localpref 100, valid, external, atomic-aggregate, best
ip bgp 160.0.0.0

Nota: Porque o recurso agregado tem o AS-200 somente, o roteador A no AS-100 aceita a rota agregada e instala a rota na tabela de roteamento. O mecanismo de detecção do laço BGP causa esta aceitação da rota. O mecanismo de detecção do laço BGP não detecta seus próprios COMO no recurso.

RouterA# show ip bgp
BGP table version is 3, local router ID is 160.20.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 160.0.0.0/8      2.2.2.1                                0 300 200 i
*> 160.20.0.0       0.0.0.0                  0         32768 i

Impacto do uso do mapa de omissões com outros comandos Configuration

O comando aggregate-address inclui outros comandos configuration, tais como o mapa de omissões. A fim compreender o impacto do uso de todos os comandos configuration na combinação, note que o agregado-endereço herda somente os atributos das rotas dos mais específico quando você usa o comando configuration do recurso. Os exemplos dos atributos que o agregado-endereço pode herdar incluem sem exportação e nenhum-anunciam-no.

  • Quando você usa o comando configuration do mapa de omissões junto com o comando configuration somente resumo, o comando configuration somente resumo não tem nenhum efeito. Com uso do comando configuration do mapa de omissões, as rotas dos mais específico que o mapa de omissões suprime não são anunciadas. Contudo, as rotas que o mapa de omissões não cobre são anunciadas além do que a rota agregada. Consequentemente, as notas nesta seção aplicam ao uso do mapa de omissões qualquer um com ou sem o comando configuration somente resumo.

  • Quando você usa o recurso com mapa de omissões, embora as rotas suprimidas não estejam anunciadas, a rota agregada herda os atributos de todas as rotas suprimidas. Mas você pode cancelar os atributos herdados com o uso de outros comandos configuration, tais como o mapa de atributos. A mudança os atributos da seção de rota agregada descreve o uso do mapa de atributos.

  • Quando você usa os comandos configuration do recurso e do mapa de omissões com anunciar-mapa, o agregado forma. O agregado herda os atributos somente fora das rotas que são selecionadas no anunciar-mapa, independentemente de se o mapa de omissões suprime a rota. Veja o anunciar-mapa do uso para agregar uma seção do subconjunto de rota específica.

  • Quando você usa o anunciar-mapa e o mapa de atributos junto com o recurso e os outros comandos configuration, o mapa de atributos cancela os atributos que são escolhidos no anunciar-mapa.

Geralmente, quando você usar o anunciar-mapa, simplesmente o anunciar-mapa influencia o agregado. Na ausência do anunciar-mapa, o agregado herda os atributos das rotas dos mais específico, suprimidas e unsuppressed. Em ambos os casos, você pode usar o comando configuration do mapa de atributos cancelar os atributos escolhidos.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5441