IP : Serial Tunnel (STUN)

Guia para BSC e BSTUN

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento é projetado ajudá-lo a configurar e usar o protocolo de link de dados de uma comunicação síncrona binária (BSC) e o Block Serial Tunneling (BSTUN) em roteadores Cisco. Igualmente ajuda-o a pesquisar defeitos os problemas que puderam ocorrer.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Conceitos das comunicações síncrona binária (BSC).

  • Compreensão geral de princípios de processo de dados básicos.

Componentes Utilizados

A informação neste documento é baseada no Cisco IOS?? software com o conjunto de recursos IBM.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Visão geral sobre o sistema

Figuras 1 e 2 mostram como um link existente BSC entre dois dispositivos pode ser reconfigurado para usar roteadores Cisco. Isto fornece o mesmo enlace lógico, sem nenhumas mudanças aos dispositivos existentes BSC.

Figura 1 - Instalação existente BSC

bsc_guide_1.gif

Figura 2 - BSC Setup com roteadores Cisco

bsc_guide_2.gif

Os roteadores Cisco transportam todos os blocos BSC entre os dois dispositivos, com o uso do encapsulamento do Block Serial Tunneling (BSTUN). Para cada bloco BSC que é recebido da linha, de um endereço e dos bytes de controle são adicionados para criar um quadro BSTUN, a seguir um BSTUN é usado para entregar ao roteador do destino correto.

Configuração BSC/BSTUN

Em um roteador limpo, emita estes comandos, na ordem em que estão listados.

Comandos globais

IP address do par-nome do bstun do [no]

O IP address define o endereço por que este bstun peer é conhecido a outros bstun peer que usam o transporte TCP.

Nota:  Este comando deve ser configurado nos Cisco IOS Software Release mais cedo do que a liberação 11.3, ou deve ser configurado se os endereços TCP/IP são usados nas declarações de rota.

número de grupos do grupo de protocolos do bstun do [no] {bsc | Bsc-local-ack | adplex | adt-votação | Adt-poll-select | Adt-vari-poll | diebold | genérico assíncrono | mdi}

Este é um comando global associar números do grupo com os nomes de protocolo. O número de grupos é um número inteiro decimal entre 1 e 255. O bsc | Bsc-local-ack | o adplex é palavras-chave de protocolo predefinidas BSTUN. Para mais informação, refira a definição do grupo de protocolo em configurar o túnel serial e obstrua o túnel serial.

A seleção do tipo de grupo é importante determinar se usar o passthru ou o reconhecimento local (Local-ack).

Nota: Este comando deve sempre ser configurado.

Comandos de interface

bstun do encapsulamento

Este é um comando interface que configure a função BSTUN em uma interface serial particular. Este comando deve ser configurado em uma relação antes que todos os comandos mais adicionais BSTUN ou BSC estejam configurados para esta relação.

número de grupos do grupo bstun do [no]

Este é um comando interface que defina o grupo bstun a que esta relação pertence. Cada um relação BSTUN-permitida em um roteador deve ser colocado em um grupo bstun previamente definido. Os pacotes viajam somente entre as relações BSTUN-permitidas que estão no mesmo grupo. O número de grupos é um número inteiro decimal entre 1 e 255.

O número do grupo tem determinado já se esta relação executa o Local-ack ou o passthru.

modo bsc do [no]

Está aqui uma lista de algumas das opções principal. Para uma lista abrangente, refira configurando opções bisync em uma interface serial em configurar o túnel serial e obstrua o túnel serial

Nenhum quadro está recebido ou enviado até que o modo esteja configurado para um destes ajustes:

  • disputa — Isto ajusta o link BSC que é conectado à interface serial para ser para uma estação ponto a ponto BSC. Somente 3780, e somente no modo passthru.

  • endereço virtual da disputa — Primeiro disponível no Cisco IOS Software Release 11.3. Usado com seletor-disputa para permitir dispositivos remotos múltiplos de usar a mesma relação no roteador de extremidade de host.

  • intervalo da seletor-disputa — Primeiro disponível no Cisco IOS Software Release 11.3. Usado no roteador de extremidade de host para a disputa. Permite dispositivos remotos múltiplos de multiplexar sobre a mesma interface física.

  • preliminar — Define que o roteador está atuando como a extremidade preliminar do link BSC e que o dispositivo anexo ou os dispositivos são estações tributárias BSC.

  • secundário — Define que o roteador está atuando como a extremidade secundária do link BSC e que o dispositivo remoto anexado é uma estação de controle BSC (tal como um [FEP] do processador de front end ou o outro dispositivo host).

Se este comando não é configurado então o protocolo de linha na relação estará para baixo e a relação não se operará.

Configuração de rota TCP

Nesta configuração, o sistema de transporte é TCP/IP. Isto pode executar sobre alguns dos meios físicos sobre que o TCP/IP pode ser executado.

rota do bstun do [no] todo o IP address tcp

IP address tcp do endereço-número do endereço da rota do bstun do [no]

O IP address é o mesmo que o endereço IP de Um ou Mais Servidores Cisco ICM NT que é especificado no par-nome do roteador de parceiro.

Configuração da rota serial

Nesta configuração, o túnel usa o transporte proprietário de Cisco. É muito mais rápido do que o TCP/IP, mas vai sobre uma interface serial somente.

a rota toda do bstun do [no] conecta o número de interface de série

número de interface da série da relação do endereço-número do endereço da rota do bstun do [no]

Configuração do frame relay passthru direto

Nesta configuração, o túnel usa um formulário de propriedade do encapsulamento em série sobre o Frame Relay, que funciona tão rapidamente quanto rotas serial.

DLCI-número de série do dlci do número de interface da relação do endereço-número do endereço da rota do bstun do [no]

Emita este comando na interface do Frame Relay:

bstun do DLCI-número do mapa do Frame Relay do [no]

Configuração direta do Local-ACK Frame Relay

Esta configuração usa o Logical Link Control, o tipo-2 (LLC2) sobre o Encapsulamento frame relay, para dar o reconhecimento local e o controle de sessão fim-a-fim. A palavra-chave do lsap deve ser incluída; se não, o encapsulamento irá como o passthru.

lsap de série do lsap do DLCI-número do dlci do número de interface da relação do endereço-número do endereço da rota do bstun do [no]

Emita este comando na interface do Frame Relay:

DLCI-número llc2 do mapa do Frame Relay do [no]

Nota: Para mais informação, refira a especificação de como os quadros são enviados em configurar o túnel serial e obstrua o túnel serial.

Configuração Passthru

Por que passthru?

O passthru é o modo básico da escavação de um túnel. Cada quadro que é transmitido entre os dispositivos obtém passado, inalterado, através do túnel BSTUN. Um número de sequência e um endereço de dispositivo são adicionados, para assegurar-se de que as latências através da rede não afetem a operação do protocolo. A chegada de votações ou de sinais atrasados do encerramento de transmissão (EOT) poderia significativamente interromper uma sessão existente.

Quando usar o passthru

O passthru deve ser usado nestas circunstâncias:

  • Os dados que estão sendo transferidos não têm um quadro explícito do reconhecimento enviado para verificar a integridade de dados.

  • O protocolo não é 3270 puros.

  • O usuário quer a conectividade de dispositivo fim-a-fim e as latências da rede são pequenas.

Configuração do Local-ack

Por que Local-ack?

O Local-ack remove as despesas gerais de enviar todos os frames de controle através do túnel. Quando o host envia a primeira votação a uma unidade de controle, um quadro do controle especial está enviado através do túnel para começar o polling remoto desse endereço de dispositivo. Uma vez que o dispositivo remoto indica que está acima, um frame de controle é enviado ao roteador host para dizê-lo para responder às votações. Quando o dispositivo remoto vai para baixo, uma indicação está enviada através do túnel dizer o roteador host para responder já não às votações.

Quando usar o Local-ack

O Local-ack pode ser usado nestas circunstâncias:

  • 3270 bisync estão no uso.

  • A latência da rede causa timeouts de sessão bisync.

  • O tráfego excedente através de WAN é um problema.

Opções do Local-ack

tempo da pausa bsc do [no]

Este comando especifica a quantidade de tempo entre o começo de um ciclo de polling e o seguinte. O valor padrão é 30 (isto é, 30 décimos ou 3 segundos).

É uma boa ideia configurar este comando quando há somente um ou dois controladores na relação bisync. Retarda eficazmente a votação e distribui mais ciclos de CPU ao dispositivo anexo.

tempo do votação-intervalo bsc do [no]

Este conjuntos de comandos o intervalo para uma votação ou uma sequência seleta, nas unidades de um-décimos de um segundo; o valor padrão é 30 (isto é, 30 décimos, ou 3 segundos).

O valor do tempo o menor é determinado pela velocidade do dispositivo anexo, e é de mais interesse na extremidade do host. Se o host que está conduzindo o roteador reduz seu intervalo ao valor o menor possível, haverá uma melhoria de desempenho quando alguns dispositivos falharam.

o [no] bsc experimenta de novo o novo-número

Este os conjuntos de comandos o número de novas tentativas a tentar antes de um dispositivo são considerados mortos. A escala é 1 a 100; o padrão é as novas tentativas 5.

valor do servlim bsc do [no]

Este comando especifica o valor do servlim (ativo contra a proporção de pesquisa inativa da estação final). A escala é 1 aos 50 pés; o padrão é 3.

SPEC-votação bsc do [no]

Este comando diz o host para segurar eleições específicas como pesquisas gerais. Use este comando quando você está trabalhando com host em tandem.

Para mais informação, refira configurando opções bisync em uma interface serial em configurar o túnel serial e obstrua o túnel serial.

Configuração de Contenção

Por que disputa?

A disputa é a variação 3780 do bisync. Não há nenhum endereço de unidade de controle. Os dispositivos são pontos a ponto conectado. Geralmente, um dispositivo remoto disca em um local central e supõe que nenhum outro dispositivo existe.

Quando usar a disputa

Use a disputa somente quando você está usando a entrada de trabalho remoto (RJE), 3780, e os 2780 protocolos. Uma vez que você identificou a disputa, assegure-se de que o ambas as extremidades esteja configurado para usar a disputa.

Se você é incerto, a seguir execute estas etapas:

  1. Configurar o bsc preliminar.

  2. Gire debugam sobre o pacote bsc.

  3. Faça o dispositivo anexo começar votar.

As mensagens com 1 bytes 2D indicam a disputa. Nenhuns bytes antes do 2D não são 3780.

Prioridades

Quando comparado com todo tráfego restante que está indo sobre o backbone WAN, o tráfego bisync é muito pequeno e inundado facilmente pelo outro tráfego. Uma perda de quadros no bisync exige um intervalo de recuperação longo, que seja facilmente perceptível aos dispositivos finais. Para minimizar este problema, a prioridade do tráfego bisync é recomendada. Você pode dar a prioridade ao tráfego com prioridades do BSTUN ou com Enfileiramento feito sob encomenda.

  • As filas de prioridade são uns recursos de roteamento em que os quadros em uma fila de saída da interface são dados a prioridade com base em várias características, tais como o tamanho do pacote ou o tipo de interface.

    O Enfileiramento de saídas de prioridade permite que um administrador de rede defina quatro prioridades do tráfego??? alto, normal, médio, e baixo??? em uma dada interface. Enquanto o tráfego entra o roteador, está atribuído a uma das quatro filas de saída. Os pacotes na fila a mais prioritária são transmitidos primeiramente. Quando essa fila esvazia, o tráfego na fila a mais prioritária seguinte está transmitido, e assim por diante. Este mecanismo assegura-se de que, durante a congestão, os dados os mais prioritários não obtenham atrasados pelo tráfego de prioridade inferior. Contudo, se o tráfego enviado a uma dada interface excede a largura de banda dessa relação, o tráfego de prioridade inferior pode experimentar atrasos significativos.

    Por exemplo, se você faz a IP uma prioridade mais alta do que o IPX em enlaces serial MACILENTOS, o tráfego BSC no TCP/IP aproveitar-se-á do fato de que o IP está sendo transferido em uma prioridade mais alta.

  • O Enfileiramento feito sob encomenda permite que um cliente reserve um porcentagem de largura de banda para protocolos especificados. Os clientes podem definir até dez filas de saída para dados normais e uma fila adicional para mensagens de sistema, tais como mensagens de keepalive LAN (os pacotes de roteamento não são atribuídos à fila de sistema). Os roteadores Cisco prestam serviços de manutenção a cada fila sequencialmente: transmitem um porcentagem de tráfego configurável em cada fila antes que se movam sobre para seguinte. Quando você usa o Enfileiramento feito sob encomenda, você pode garantir que dados de missão crítica estão atribuídos sempre uma determinada porcentagem da largura de banda, quando o throughput previsível para o outro tráfego for assegurado igualmente.

    Para fornecer esta característica, os roteadores Cisco determinam quantos bytes devem ser transmitidos de cada fila, com base na velocidade da relação e no porcentagem configurada. Quando o contagem de byte calculado de uma fila dada foi transmitido, o roteador termina a transmissão do pacote atual e transporta-se sobre à fila seguinte. Eventualmente, cada fila é prestada serviços de manutenção, em um estilo round-robin.

Refira configurar o túnel serial e obstrua o túnel serial, e refira a decisão do que política de enfileiramento a se usar na visão geral sobre Tratamento de Congestionamento.

fila do bstun do protocolo do número de lista da prioridade-lista do [no] [GT | o lt packetsize] o [address bstun-group bsc-addr]

Emita o comando priority-list protocol bstun global configuration estabelecer as prioridades de enfileiramento BSTUN baseadas no cabeçalho BSTUN. Não emita nenhum formulário do comando reverter às prioridades normal.

[list] da costume-fila-lista do [no]

A lista é um inteiro (1 - 16) que represente o número da lista de fila personalizada.

Configuração de keepalive

intervalo do remoto-par-keepalive do bstun do [no]

Este comando permite o Keepalives do bstun peer. Isto envia um pedido ao par sempre que o par foi silencioso para mais por muito tempo do que o período de tempo de intervalo. Todo o quadro restaura o pulso de disparo, não apenas Keepalives. O padrão é 30 segundos.

número da keepalive-contagem do bstun do [no]

Quando este número de Keepalives é faltado consecutivamente, a conexão de BSTUN está derrubada. O padrão é 3.

Quando usar o Keepalives

O Keepalives é útil de proteger contra as indisponibilidade do túnel em que você está executando o Local-ack e o TCP/IP. O túnel derruba uma relação somente quando um sinal é recebido do telecontrole. Se o túnel está para baixo, os sem sinais estão recebidos nunca.

No passthru, isto não é precisado, porque a conectividade de ponta a ponta é exigida.

Comandos debug

grupo do debug bstun event do [no]

Este comando permite que você debugue conexões de BSTUN e estado. Quando permitido, causa o indicador das mensagens que mostram o estabelecimento de conexão e o status geral.

o [no] debuga o indicar-byte-tamanho do tamanho de buffer do grupo do grupo do pacote do bstun

Este comando permite que você debugue os pacotes que viajam através dos links BSTUN.

o [no] debuga o indicar-byte-tamanho do tamanho de buffer do grupo do grupo do pacote bsc

Este comando permite que você debugue os quadros que viajam através da característica BSC.

o [no] debuga o pacote bsc

Este comando permite que você debugue os quadros que viajam através da característica BSC. Segue todas as relações que são configuradas com um número de grupo bstun.

o [no] debuga o grupo de evento bsc

Este comando permite que você debugue os eventos que ocorrem na característica BSC. Se o número do grupo é omitido, a seguir segue todas as relações que são configuradas com um número de grupo bstun.

comandos show

show bstun

Este comando indica o status atual do BSTUN.

This peer: 10.10.20.108
 *Serial5 -- interface for ATM: R1710V421 (group 3 [bsc])
route  transport  address      state       rx_pkts   tx_pkts     drops
C2    TCP         10.10.10.107 open        655630    651332      0
 Serial6 -- interface for SEC: MST012  (group 2 [bsc])
route  transport  address      state       rx_pkts   tx_pkts   drops
C2     TCP        10.10.10.107 open        649385    644001      0

Verifique para ver se há estes problemas:

  • Estado fechado.

  • Gotas.

  • Baixo contagem de pacote de informação.

    Nota: O baixo contagem de pacote de informação não indica sempre problemas. Quando você está executando o Local-ack, a contagem consiste somente nos frames de dados, que é significativamente menor do que o número real de quadros que são enviados do host.

show bsc

Este comando indica o status atual do BSC.

No passthru

BSC pass-through on Serial5:
Output queue depth: 0.
HDX enforcement state: IDLE.
Frame sequencing state: SEC.
Tx-Active: Idle. Rx-Active: False.
Tx Counts: 670239 frames(total). 670239 frames(data). 9288816 bytes.
Rx Counts: 651332 frames(total). 651332 frames(data). 651332 bytes.

Verifique para ver se há estes problemas:

  • Se o estado da aplicação HDX obtém colado em um estado a não ser a QUIETUDE, a seguir pode haver um problema com o dispositivo anexo ou com este roteador. Isto indica geralmente que o dispositivo não está respondendo. Gire sobre o evento bsc debugam. Se você não vê muita nenhuma resposta das mensagens remotas, primeira verificação que o dispositivo está ativado, a seguir duplex da verificação. Se não há nenhuma mensagem e nenhuma recuperação eventual, a seguir um evento da conclusão transmitir esteve perdido, e um erro foi encontrado que pudesse potencialmente ser catastrófico.

  • O estado da sequência de frame diz-lhe que máquina de estado finito (FSM) a verificar.

  • Se RX-ativo é colado em verdadeiro, isto indica que algo ruim aconteceu com o hardware. Emita fechado e então um nenhum fechados para restaurar a relação. Se isto não trabalha, recarregue o roteador.

No Local-ack

BSC local-ack on Serial0:
Secondary state is CU_Idle.
Control units on this interface:

      Poll address: 40. Select address: 60 *CURRENT-CU*
      Current active device address is: 40.
      State is Active.
      Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
      Rx Counts: 87271 frames(total). 5 frames(data). 436312 bytes.

Total Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
Total Rx Counts: 174516 frames(total). 5 frames(data). 523557 bytes.

Se o estado obtém colado em TCU_Down, este indica que algo está forçando essa relação a ficar para baixo. Verifique cronometrar e modo de BSC e assegure-se de que nada esteja para baixo administrativamente. Ocasionalmente, um comando shut seguido por um comando no shut começa a relação outra vez.

No general

  • Uma profundidade da fila de saída maior de 1 indica uma reserva na relação. Certifique-se de metade - o duplex é configurado corretamente.

  • Fora da SYN-caça o modo significa qualquer um que a relação está para baixo ou que o receptor esteve desabilitado. Isso que se aplica a RX-ativo igualmente aplica-se aqui.

mostre o número de série da relação

Este comando é útil considerar os contadores que são associados com essa interface serial.

Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

Nota: Alguns erros significam problema.

Verifique para ver se há estes problemas:

  • os abortos indicam uma transmissão ruim.

  • os quadros ignorados são os quadros que violam o protocolo bissíncrono.

  • os gigantes indicam qualquer um que o MTU é demasiado pequeno ou uma sequência bisync é ruim.

  • o overrun indica faltas dos recursos do CPU.

  • O CRC indica a corrupção sobre a linha (ruidosa ou outro).

Se você está usando o cabo DTE e a linha parece ir para baixo frequentemente, ou transmite a falha mas recebe o trabalho, a seguir você pôde precisar de emitir o comando ignore-dcd. Isto pode ser verificado com um analisador de protocolo. Quando o DCE transmite, os dados levados detectam (DCD) estão aumentados. Quando termina, o DCD está abaixado assim o roteador não capaz de responder.

  • O hardware é CD2430 indica o conjunto de chip cirrus.

  • O hardware é HD64570 indica o chipset de Hitachi.

Hitachi usa interrupções do caráter e a moldação software-construída. Não segura o DCD bem. O cirro usa interrupções do quadro. Os quadros são construídos no ucode. Tem as opções a jogar com DCD. É importante, quando você está debugando, que você conhece o tipo de interface, porque há algumas diferenças entre elas.

O protocolo de linha deve estar acima. Se o protocolo de linha não está acima, a seguir certifique-se do modo de BSC esteja configurado.

Serial5 is up, line protocol is up
  Hardware is CD2430 in sync mode
 MTU 265 bytes, BW 4 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation BSTUN, loopback not set
    Half-duplex enabled.
      cts-delay 0 millisec
      dcd-txstart-delay 100 millisec
      dcd-drop-delay 100 millisec
      transmit-delay 0 millisec
      Errors - 0 half duplex violation
   Last input 10:27:12, output 1:07:12, output hang never
   Last clearing of "show interface" counters 4d11
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      3223346 packets input, 3223356 bytes, 0 no buffer
      Received 0 broadcasts, 0 runts, 0 giants
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      3242346 packets output, 45259079 bytes, 0 underruns
      0 output errors, 0 collisions, 8 interface resets, 0 restarts
      0 output buffer failures, 0 output buffers swapped out
      4 carrier transitions
      DCD=up DSR=up DTR=up RTS=down CTS=down

Como solucionar problemas do IBM Bisync

Como utilizar FSMs de passagem

Assegure-se de que você esteja executando o passthru. Você precisa de encontrar a máquina de estado finito (FSM) correta para seguir.

Olhe o evento debugam mensagens. Há dois FS a ir completamente. O HDX-FSM é um FSM de aplicação semiduplex. É conduzido apesar de se a linha é - duplex ou parcialmente - duplex completamente configurado. Tenta assegurar-se de que o transmitir fila de um roteador não obtenha backlogged com dados velhos. O FS-FSM assegura-se de que os quadros atrasados através da rede não destruam sessões estabelecidas.

Para determinar onde olhar, vá em linha reta à disputa FS, se a disputa é configurada. Se não, olhe o estado em que entra após o estado ocioso. Se você vê o SEC, olhe a sequência de frame secundária FS. Se você vê o PRI, olhe a sequência de frame preliminar FS.

BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: FS-FSM event: SDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: SDI: Data (1 bytes): 37
BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.

Quando você olha a tabela, você vê entradas no lado esquerdo e no você ver estados na parte superior. Cada entrada em uma coluna é do formulário {estado, ação seguintes} que a ação é feita primeiramente, a seguir a transição acontece.

Como usar o Local-ack FS

Assegure-se de que você esteja executando o Local-ack. Um comando show bsc diz-lhe se a relação é poller ou pollee. Disto, use a FALTA apropriada FS.

Problemas comuns

Passando dados 3780 para a configuração 3270 ou vice-versa

cuidado Cuidado:  Não faça isto. Isto não trabalha confiantemente.

Configuração de rota para um peer incorreto

Você configurou tudo e nada acontece. Você gira sobre debuga o pacote bsc no roteador remoto e não vê nada. Você gira então debuga sobre o pacote do bstun e ainda não vê nada. Nesta fase, gire sobre o debug bstun event; você provavelmente ainda não vê nada. Vá para trás ao roteador da extremidade do host e gire sobre o debug bstun event. Você deve agora ver diversas mensagens que indicam uma conexão inválida.

Configuração inadequada de números de grupos

Isto é observado quando uma ou outra extremidade do túnel é configurada com um número do grupo diferente. Os dados derramam fora da interface errada ou obtêm rejeitados a nível BSTUN.

O Local-ack e os números do grupo do passthru não misturam. Assegure-se de que as definições do grupo de protocolos estejam consistentes através da toda a rede. Os dispositivos que executam a disputa (3780) igualmente precisam de estar em números do grupo diferentes de uns 3270.

Host em tandem

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C240402D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 404040402D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37

Os Tandems não obedecem 3270 convenções restritas. Fazem toda sua votação com eleições específicas, que causa um problema para a FALTA FS do padrão. Para pegar tandems trabalhar corretamente, configurar a SPEC-votação bsc na interface secundária BSC.

Diferença entre bidirecional e semi-duplex

É fácil confundir completamente - duplex e metade - o duplex.

  • O Full-duplex pode transmitir dados simultaneamente entre uma estação de envio e uma estação de recepção.

  • Meio - o duplex pode transmitir dados em somente um sentido de cada vez, entre uma estação de envio e uma estação de recepção.

Veja a seção no comando show bsc para mais detalhes.

Se você tem um analisador de protocolo ou uma caixa breakout disponível, conecte seu analisador no sistema sem o Roteadores.

  • Se o RTS ou o CTS mudam o sinal, a seguir você tem a metade - duplex; mais está completo - duplex.

  • Se o DCD parece mudar muito, e a linha vai para cima e para baixo ou fica para baixo, você pôde ter o DCD de comutação.

Nota: O roteador principal pode ser - duplex quando o roteador remoto for meio - duplex completo, e vice-versa. Estas são linhas físicas separadas, e os sinais de controle das relações não são transportados através do túnel.

Exemplos BSC e BSTUN

Não há exemplo de resposta de dispositivo

Este é um exemplo de duas relações em um roteador secundário: um Local-ack e o outro passthru. Nenhum está recebendo uma resposta do telecontrole. Assim que você vir votações entrar o roteador secundário, você precisa de determinar o que está acontecendo na extremidade remota.

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 40407F7F2D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:24: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:25: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:25: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:27: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:27: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:28: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:28: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:30: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:30: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D

Quando você olha a extremidade remota no exemplo do passthru, você pode ver quadros vir através do túnel, mas o dispositivo anexo é ainda quieto.

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037

Em seguida, determine se o dispositivo anexo está inoperante ou se o roteador tem um transmissor ruim: gire sobre o event debugging.

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: Response not received from remote
BSC: Serial6: HDX-FSM event: T/O old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: FS-FSM event: NDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpEOT old_state: PND_COMP. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)

Do traço, siga o HDX-FSM. Se é colado no estado PND_COMP, o transmissor está falhando. É provavelmente o caso que o sem relógio está sendo fornecido. Como você pode ver na saída de exemplo anterior, o estado PND_RCV é alcançado, e você vê a resposta não recebida do telecontrole, que aponta a qualquer um que um mau recebe ou um dispositivo inativo.

Exemplo de latências de rede

Este é um exemplo das latências da rede em um ambiente do multidrop virtual:

BSC: Serial0: NDI: Data (5 bytes): C703001061
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37

!--- Output suppressed.

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C4C4C4C42D

Há um problema aqui, porque o C4 não respondeu a tempo:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C5C5C5C52D
BSC: Serial0: NDI: Data (4 bytes): C5C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C7C7C7C72D

Além disso, isto é perdido. Olhe mais, e você vê que o problema se transforma um pouco mais ruim:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C1C1C1C12D

O EOT para o C7 apareceu de repente outra vez. Rejeite esse EOT para recuperar deste; o frame seguinte é o EOT para o C1.

Neste exemplo, os quadros da rede estão chegando tarde e fora da sequência. Isto causa um grande número votações não respondidas no host. A solução, neste caso, é configurar o Local-ack.

Exemplo de configurações BSC e BSTUN

Diagrama de Rede

Este diagrama é uma configuração de exemplo de um local que esteja executando 3270 e 3780 terminais bissíncrono.

/image/gif/paws/5316/bsc_guide_3.gif

Configurações

Esse diagrama usa estas configurações:

Central
hostname central
!
bstun peer-name 10.10.10.107
bstun protocol-group 1 bsc
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc contention 1
 bstun route all tcp 10.10.10.108
!
interface Serial2
 description WAN-ppp backbone
 ip address 10.10.10.107 255.255.255.0
 encapsulation ppp
 clockrate 2000000
!
interface Serial3
 description WAN-hdlc
 ip address 10.10.20.107 255.255.255.0
 bandwidth 2000
 no keepalive
 clockrate 2000000
!
interface Serial4
 description ATM Host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 bstun group 44
 bsc secondary
 bstun route all tcp 10.10.20.108
!
interface Serial5
 description ATM host
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 2
 bsc secondary
 bstun route address C2 tcp 10.10.20.108
!
end

Telecontrole 1
hostname remote1
!
bstun peer-name 10.10.10.108
bstun protocol-group 1 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS 1
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc char-set ebcdic
 bsc contention
 bstun route all tcp 10.10.10.107
!
interface Serial1
 description ATM 3
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address 40 tcp 10.10.10.107
!
interface Serial3
 description WAN -ppp
 ip address 10.10.10.108 255.255.255.0
 encapsulation ppp
!
end

Telecontrole 2
hostname remote2
!
!
bstun peer-name 10.10.20.108
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
bstun protocol-group 10 bsc-local-ack
!
interface Serial0
 description WAN-hdlc
 ip address 10.10.20.108 255.255.255.0
 bandwidth 2000
 no keepalive
!
interface Serial5
 description ATM 1
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
interface Serial6
 description interface for ATM 2
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 2
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
ip route 10.10.10.0 255.255.255.0 10.10.20.107
!
end

Referências

Informação geral - Uma comunicação sincrônica binária, Biblioteca de Referência de Sistemas IBM, GA27-3004-2.

IBM 3274: Capítulo 4: Operações remotas BSC.

IBM 3275: Capítulo 9.

Comandos BSTUN na CD-ROM da Documentação da Cisco (acessível em linha no túnel serial e nos comandos do túnel serial do bloco).

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5316