IP : Border Gateway Protocol (BGP)

Understanding Redistribution of OSPF Routes into BGP

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta Nota Técnica explica o comportamento do Open Shortest Path First (OSPF) para redistribuição do Border Gateway Protocol (BGP) em roteadores Cisco. O comportamento do OSPF à redistribuição do BGP é destacada na RFC 1403.leavingcisco.com

Há diversos tipos de rotas de OSPF:

  • Intra-area — Em uma rede de OSPF do multiarea, as rotas, originadas dentro de uma área, são sabidas pelo Roteadores na mesma área que rotas intra-áreas. Estas rotas são embandeiradas como O na saída do comando show ip route.

  • Inter-area — Quando uma rota cruzar um roteador de borda da área do OSPF (ABR), a rota está sabida como uma rota de área interna OSPF. Estas rotas são embandeiradas como O IA na saída do comando show ip route.

    Intra e rotas inter-área são chamados igualmente rotas internas OSPF, porque estão gerados por OSPF próprio, quando uma relação é coberta com o comando ospf network.

  • Tipo 2 externo ou tipo-1 externo — Distribui que foram redistribuídos no OSPF, tal como conectado, estática, ou o outro protocolo de roteamento, são sabidos como o Tipo 2 externo ou o tipo-1 externo. Estas rotas são embandeiradas como O E2 ou O E1 na saída do comando show ip route.

  • Tipo-2 externo NSSA ou tipo-1 externo NSSA — quando uma área estiver configurada como uma área do Não-Assim-stub (NSSA), e as rotas estão redistribuídas no OSPF, as rotas são sabidas como o tipo-2 externo NSSA ou o tipo-1 externo NSSA. Estas rotas são embandeiradas como o N1 do N2 O ou O na saída do comando show ip route.

    Descrevendo as diferenças entre o tipo-2 ou 1 externo e NSSA são além do alcance deste documento — refira o guia de design de OSPF para mais informação.

O comportamento padrão não é redistribuir nenhuma rotas do OSPF no BGP. A redistribução deve ser configurada. Você pode usar o comando route-map às rotas de filtro durante o OSPF à redistribuição de BGP. Ao redistribuir, as palavras-chaves específicas como interno, externo e nssa externo são exigidas redistribuir rotas respectivas.

Pré-requisitos

Requisitos

Uma compreensão de tipos da rota de OSPF é exigida antes de usar este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Instalação de rede

Há quatro casos de redistribuir as rotas de OSPF no BGP discutidas abaixo. O diagrama da rede aplica-se aos primeiros três casos. O diagrama e a instalação para o quarto caso podem ser encontrados na redistribução de rotas nssas externo OSPF na seção BGP.

/image/gif/paws/5242/bgp-ospf-redis1.jpg

Redistribuição de apenas rotas internas OSPF (Intra-área e inter-área) no BGP

Se você configura a redistribução do OSPF no BGP sem palavras-chaves, simplesmente o intra-area e as rotas inter-área OSPF estão redistribuídos no BGP, à revelia. Você pode usar a palavra-chave interna junto com o comando redistribute sob o BGP do roteador redistribuir o OSPF intra e as rotas inter-área.

Esta configuração é uma configuração do roteador nova B que redistribua somente a rota intra-área (131.108.2.0/24) e a rota inter-área (131.108.1.0/24) no BGP e somente as rotas internas OSPF (intra-area e inter-area) são redistribuídas no BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!-- This redistributes only OSPF intra- and inter-area routes into BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

O roteador B redistribui somente rotas internas OSPF:

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

C do roteador que aprende estas rotas do BGP:

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

Redistribuição de apenas roteadores OSPF externos (tipos 1 e 2) para o BGP

Use a palavra-chave externa junto com o comando redistribute sob o BGP do roteador redistribuir rotas externas OSPF no BGP. Com a palavra-chave externa, você tem três escolhas:

  • redistribua o tipo-1 externo e o tipo-2 (o padrão)

  • redistribua o tipo-1

  • redistribua o tipo-2

Incorpore os comandos ao modo de configuração como descritos aqui:

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

Nesta configuração do roteador B, nós redistribuímos somente rotas externas OSPF, mas tipo-1 e tipo-2:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- This redistributes ONLY OSPF External routes, 
!--- but both type-1 and type-2.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: O fósforo 1 2 externo externos das mostras da configuração e o comando entered eram redistribuem o fósforo OSPF 1 externo. Isto é normal porque o OSPF adiciona automaticamente “1 2" externo externo na configuração. Combina OSPF 1 externo e as 2 rotas externos e redistribuem ambas as rotas no BGP.

O roteador B redistribui somente rotas externas OSPF:

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

O C do roteador aprende sobre estas duas rotas externas OSPF do BGP:

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

Redistribução somente do tipo-1 externo OSPF ou das rotas do Tipo 2 no BGP

Incorpore este comando sob BGP 100 do roteador no roteador B redistribuir somente as rotas 1 externos OSPF:

router bgp 100
 redistribute ospf 1 match external 1

A tabela de BGP do roteador B mostra que está redistribuindo somente as rotas 1 externos no BGP e todas rotas de OSPF restantes não estão redistribuídas no BGP:

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

Da mesma forma, incorpore este comando sob BGP 100 do roteador no roteador B redistribuir somente rotas externos OSPF 2:

router bgp 100
 redistribute ospf 1 match external 2

Redistribuição de rotas internas e externas de OSPF no BGP

Neste caso, todas as rotas de OSPF são redistribuídas no BGP usando o interno e palavra-chaves externas, segundo as indicações desta configuração de roteador B:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- This redistributes all OSPF routes into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Além disso, externo é substituído com o 1 2 externo externos na configuração. Isto é normal a menos que você especificar que rotas externas específicas você quer redistribuir no BGP. Após ter executado a alteração de configuração, o roteador B redistribui todas as rotas de OSPF e o C do roteador começa aprender todas as rotas do BGP:

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

Redistribuição de rotas NSSA externas de OSPF no BGP

Este é um caso especial em que somente as rotas da not-so-stubby area (NSSA) são redistribuídas no BGP. Este caso é muito similar ao caso descrito na redistribução somente de rotas externos OSPF (tipo-1 e 2) na seção BGP. A única diferença é que o BGP está combinando agora rotas nssas externo em vez apenas das rotas externas. A tabela de roteamento do roteador B mostra a estes o OSPF rotas nssas externo:

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

Este diagrama da rede é usado para este caso:

/image/gif/paws/5242/bgp-ospf-redis2.jpg

O diagrama da rede mostra que o roteador B recebe rotas do N1 e do N2 OSPF. O comportamento padrão é redistribuir rotas do N1 e do N2 se somente a palavra-chave nssa externo é usada. Esta configuração do roteador B permite que nós redistribuam rotas do N1 OSPF 200.2.2.0/24) (200.1.1.0/24) e do N2 OSPF (no BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1 
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- This redistributes only OSPF NSSA-external routes 
!--- Type-1 and Type-2 into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: Como a configuração externa de OSPF, o fósforo acima 1 2 nssa externo nssas externo dos indicadores da configuração e o comando entered eram redistribuem o fósforo OSPF 1 nssa externo. Isto é normal porque o OSPF adiciona automaticamente “1 2" nssa externo nssa externo na configuração. Combina rotas do N1 OSPF e do N2 OSPF e redistribui ambas as rotas no BGP.

Após a alteração de configuração no roteador B, o roteador B redistribui rotas nssas externo OSPF, e o C do roteador começa aprender rotas nssas externo OSPF do BGP:

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp 
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

Da mesma forma como com rotas externas OSPF, para redistribuir somente rotas do N1 OSPF, inscreva o comando seguinte sob o roteador BGP 100 no roteador B:

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- This redistributes only OSPF NSSA-external 
!--- Type-1 routes into BGP.

Para redistribuir somente rotas do N2 OSPF, inscreva o comando seguinte sob o roteador BGP 100 no roteador B:

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- This redistributes only OSPF NSSA-external 
!--- Type-2 routes into BGP.

Nota: Os mapas de rotas podem igualmente ser usados para redistribuir o tipo 1/2 OSPF no BGP. Consulte para redistribuir rotas OSPF E2 no BGP para mais informação.

Altere a opção de redistribuição no OSPF

É importante compreender como a alteração de configuração sucessiva pode alterar sua configuração. Um comando new com a opção do fósforo não overwrite precedente mas é-lhe adicionado. Começando sem a redistribução, esta sequência de comandos do exemplo de configuração mostra seu impacto na redistribução:

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Initially, we redistribute internal OSPF routes into BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- With this second command, we tell BGP 
!--- to also redistribute external OSPF routes.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- With this no command, we only disable the 
!--- redistribution of external type 2 into BGP. 
!--- All other types of routes previously configured remain.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- As you can see, internal and external type 1 remain.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z 

!--- Now, with this no command, which includes all configured 
!--- keywords, it is important to note that we 
!--- still do not disable the redistribution fully.
!--- We only removed the keyword. After this, 
!--- the IOS still acts as default—redistributing
!--- internal routes only.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 

!--- Always use this command in order to completely
!--- disable redistribution.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

Incapaz de redistribuir o iBGP aprendeu rotas em um IGP tal como o EIGRP, OSPF

A redistribuição de rota é usada para propagar as rotas aprendidas com o uso de um protocolo, em um outro protocolo de roteamento. Quando o BGP for redistribuído em um IGP, simplesmente as rotas aprendidas do eBGP obtêm redistribuídas. As rotas ensinadas pelo iBGP conhecidas no roteador não são introduzidas no IGP a fim impedir que os loop de roteamento estejam formados.

À revelia, a redistribuição de iBGP no IGP é desabilitada. Emita o comando bgp redistribute-internal a fim permitir a redistribução das rotas iBGP no IGP. As precauções precisam de ser tomadas para redistribuir rotas específicas usando mapas de rota no IGP.

Uma configuração de exemplo para redistribuir rotas iBGP no OSPF é mostrada aqui:

router bgp 65345 
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

Nota: A redistribução de rotas do internal border gateway protocol (iBGP) em um protocolo Interior Gateway Protocols pode causar loop de roteamento dentro do sistema autônomo. Isto não é recomendado. Os filtros da rota precisam de ser ajustados a fim controlar a informação, que é importada no IGP.

Redistribua rotas padrão OSPF dentro ao BGP

A fim redistribuir dentro rotas padrão ao BGP, use a instrução de rede e a padrão-informação origina. Em nosso exemplo, as rotas padrão OSPF são redistribuídas dentro ao BGP. Isto é feito com a criação de um mapa de rotas e a distribuição da rede padrão, que é permitida pelo padrão ACL.

!
route-map map_default_only permit 10

 match ip address acl_default_only

!

ip access-list standard acl_default_only

 permit 0.0.0.0

!

router bgp 64601

network 0.0.0.0

 redistribute ospf 1 route-map map_default_only

 default-information originate

!--- distributes the default route in bgp

!

Após a configuração, cancele as sessões BGP com o comando clear ip bgp *.


Informações Relacionadas


Document ID: 5242