Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

Configuração do Modo de Sub-rede Simples (Ponte) no CSM

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O CSM (Módulo de switching de conteúdo) oferece SLB (Balanceamento de carga do servidor) de alto desempenho entre os dispositivos de rede e os server farms com base nos pacotes de informações das camadas 4 a 7. Fazendas do server que são representadas enquanto os servidores virtuais podem melhorar a escalabilidade e a Disponibilidade dos serviços para sua rede. Você pode adicionar novos servidores e remover servidores com falha ou existentes a qualquer momento sem afetar a disponibilidade dos servidores virtuais.

Os clientes conectam-se ao CSM, fornecendo o endereço VIP (IP virtual) do servidor virtual. Quando um cliente inicia uma conexão com o servidor virtual, o CSM escolhe um servidor real (um dispositivo físico que é atribuído a um server farm) para a conexão, de acordo com políticas e algoritmos de balanceamento de carga configurados (regras de acesso). As políticas controlam o tráfego definindo onde enviar pedidos do cliente para a informação.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração pode ser usada com toda a versão de software e hardware que apoia o CS.

Material de Suporte

Os clientes e servidor comunicam-se com o CS usando a tecnologia da camada 2 ou da camada 3� em uma configuração de VLAN específica. Os clientes conectam-se à VLAN no lado do cliente e os servidores, à VLAN no lado do servidor. Servidores e clientes podem existir em diferentes sub-redes. Os servidores também podem estar localizados em mais de um nó e ser conectados ao VLAN no lado de servidor por meio de roteadores. Um cliente envia uma requisição para um dos endereços VIP do módulo. O CS para a frente este pedido a um server que possa responder ao pedido. O servidor encaminha então a resposta ao CSM e o CSM encaminha a resposta ao cliente.

Quando as VLANs no lado cliente e no lado servidor estão nas mesmas sub-redes, você pode configurar o CSM em modo de sub-rede (ponte) única. Este documento descreve o modo da sub-rede única (ponte).

Quando o lado do cliente e o lado de servidor VLAN estão em sub-redes diferentes, você pode configurar o CS para operar-se em um modo seguro (do roteador). Para mais informação, refira configurar o modo seguro (do roteador) no CS.

Configurar

Diagrama de Rede

O diagrama a seguir ilustra diferentes VLANs e diferentes sub-redes.

csm-bridge.gif

Configurações

Conclua estes passos:

  1. Crie a VLAN cliente e servidor no MSFC.

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. Configure as interfaces físicas que conectam o cliente (uplink) à VLAN correspondente.

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. Configurar interfaces física que conecta os server ao VLAN correspondente.

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. Configurar o CS.

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. Crie o vlan do lado do cliente e o gateway.

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. Crie o lado de servidor VLAN.

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. Crie a fazenda do server.

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. Crie o vserver e associe a fazenda do server.

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

Esta é uma configuração de exemplo do SLB usando o Cisco catalyst 6500 e o CS.

Configuração running CS (WS-X6066-SLB-APC)
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.�
 
! 
module ContentSwitchingModule 3� 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
�vlan 100 client 
� ip address 172.17.63.217 255.255.255.192 
� gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
�vlan 200 server 
� ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
�serverfarm WWWFARM 
� nat server� 
� no nat client 
� real 172.17.63.215 
�� inservice 
� real 172.17.63.216 
�� inservice 
! 

!--- VServer configuration. 

! 
�vserver SERVER 
� virtual 172.17.63.241 tcp www 
� serverfarm WWWFARM 
� persistent rebalance 
� inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
�switchport 
�switchport access vlan 100 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/4 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/5 
�no ip address 
�shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
�ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
�login 
! 
end

Verificar (comandos show)

Comando show module csm # status

O comando show module csm - status indica o estado do módulo de SLB. O módulo tem que estar online.

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

Comando show module csm # vserver name word detail

O comando show module csm - vservers name word detail indica informação detalhada do servidor virtual. Você igualmente vê o estado do servidor virtual e quantas conexões lá são. Este é o melhor comando usar-se para obter a informação do servidor virtual.

cat#show module csm 3 vservers name server detail�
SERVER, state = OPERATIONAL, v_index = 10
� virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
� idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
� max parse len = 600, persist rebalance = TRUE
� conns = 0, total conns = 4
� Default policy:
��� server farm = WWWFARM
��� sticky: timer = 0, subnet = 0.0.0.0, group id = 0
� Policy���������� Tot Conn���� Client pkts� Server pkts
� ------------------------------------------------------
� (default)������� 4����������� 56���������� 56

Comando show module csm # real detail

O comando show module csm # real detail exibe as informações de cada servidor real, como o server farm em que cada servidor está, os estados, limiares e conexões dos servidores.

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

Comando show module csm # serverfarm name word detail

O comando show module csm # serverfarms name word detail exibe as informações do server farm. Esse comando mostra o preditor utilizado para o balanceamento de carga. Neste exemplo, o arredondamento robin, que é padrão, está sendo usado.

cat#show module csm 3 serverfarms name wwwfarm detail�
WWWFARM, predictor = RoundRobin, nat = SERVER
� virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
� inband health config: <none>
� retcode map = <none>
� Real servers:
��� 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
��� 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
� Total connections = 0

Comando show module csm # vlan detail

O comando show module csm # vlan detail exibe as informações de VLAN o cliente e do servidor.

cat#show module csm 3 vlan detail�
vlan�� IP address������ IP mask��������� type������
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192� CLIENT
� GATEWAYS
� 172.17.63.214����
200��� 172.17.63.217��� 255.255.255.192� SERVER
cat#

Troubleshooting

Você deve poder sibilar o servidor real e o gateway CSM do Catalyst 6500 emitindo os comandos ping ou ping module csm - reals.

cat#ping module csm 3 reals
IP address������ Reachable
--------------------------
172.17.63.215��� Yes
172.17.63.216��� Yes
cat#ping module csm 3 gateway�������������������������
IP address������ Reachable
--------------------------
172.17.63.214��� Yes

Um outro bom comando de Troubleshooting é show module csm # arp. O CS aprenderá os endereços. Certifique-se que o gateway e os reais estão aparecendo.

cat#show module csm 3 arp�
Internet Address� Physical Interface� VLAN����� Type������ Status
--------------------------------------------------------------------
�172.17.63.210��� 00-E0-B6-01-FA-49�� 100������ LEARNED��� up(0 misses)
�172.17.63.214��� 00-04-C0-C0-68-00�� 100������ GATEWAY��� up(0 misses)
�172.17.63.215��� 00-60-B0-87-DC-1A�� 200������ REAL������ up(0 misses)
�172.17.63.216��� 00-50-DA-BF-A1-7F�� 200������ REAL������ up(0 misses)
�172.17.63.217��� 00-30-F2-71-5D-2E�� 100/200�� --SLB--��� local
�172.17.63.222��� 00-02-B9-45-A2-91�� 100������ LEARNED��� up(0 misses)
�172.17.63.241��� 00-30-F2-71-5D-2D�� 0�������� VSERVER��� local

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 5217