Serviços de rede de aplicativos : Mecanismos de conteúdo Cisco 500 Series

Configurando o redirecionamento transparente e de media proxy com uso do software ACNS 4.x

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar o Cisco Cache/Content Engine para transparente e a mídia de proxy que põe em esconderijo usando a liberação 4.x de Cisco ACNS da versão 2. do protocolo web cache coordination (WCCP), inclui, como uma opção, o RealProxy de RealNetworks, Inc.leavingcisco.com para apoiar o córrego que racham (alimentos vivos de distribuição) e a mídia fluente que põe em esconderijo (índice por encomenda) no Real-Time Streaming Protocol (RTSP) - fluência baseada e em outros formatos reais PNM (metafile de RealNetworks).

O Content Engine pode ser configurado para aceitar transparentemente os pedidos RTSP reorientados do roteador WCCP, assim como pedidos tradicionais do proxy-estilo RTSP do software do cliente do RealPlayer. Pôr em esconderijo da mídia fluente fornece por encomenda satisfeito ao alargamento que, se um usuário tem visto já um arquivo de mídia fluente posto em esconderijo, pode ser servido aos usuários subsequentes sem a exigência conectar ao servidor de origem. Esteja ciente que as transmissões ao vivo não podem ser postas em esconderijo.

Para configurar o Content Engine para aceitar o tráfego RTSP, termine estas etapas:

  1. Emita o comando rtsp proxy no modo de configuração global para entrar no endereço IP de Um ou Mais Servidores Cisco ICM NT, na porta, e na licença usada no RealProxy do Content Engine.

  2. Emita o comando wccp media-cache global configuration registrar o Content Engine com todo o Roteadores WCCP-permitido.

Os objetos da mídia fluente são postos em esconderijo nos partições de disco do sistema de arquivos de media (mediafs) quando o software RealProxy estiver copiado à separação do sistema de arquivo de software (swfs) como parte do procedimento de instalação. Emita o comando disk criar as separações dos mediafs; emita o comando mediafs manter estas separações (refira a manutenção do armazenamento de disco rígido para mais informações sobre dos partições de disco). O software RealProxy pode ser administrado com o RealAdministrator GUI� (para alcançar esta página, o nome de usuário/senha padrão é admin/diamante).

Para configurar WCCP-permitiu o Roteadores, você precisa de emitir o comando do grupo de serviço 80 do wccp. A saída do comando é mostrada na seção de configurações.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Content Engine que executa a liberação de software de ACNS 4.x ou mais tarde

  • Software RealProxy instalado com as separações dos mediafs montadas

Nota: Você deve comprar uma chave de licença a fim ativar as características de RealProxy no software em cache. Para pedir em Cisco.com, refira pedir.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Liberação de software Cisco ACNS running 4.x do Cisco Content Engine 590 ou mais tarde em um ambiente de laboratório com configurações esclarecida

  • Cisco IOS Software Release 12.0.18(S) running do Cisco 7513 Router

Configurar

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

/image/gif/paws/4717/media_redir.jpg

Configurações

Cisco Cache Engine 560 (liberação de software de ACNS 4.x de Cisco�)
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable�

rtsp proxy incoming 554�

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

�ip address 172.17.241.45 255.255.255.0

�no ip directed-broadcast

�ip wccp 80 redirect out

!

interface Ethernet5/1

�ip address 10.10.10.1 255.255.255.0

�no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

�exec-timeout 0 0

line aux 0

line vty 0 4

�password <removed>

�login

!

end

comandos debug e show

Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Comandos show do Cache Engine

Comando show Descrição
show wccp content-engines Informação do Content Engine dos indicadores WCCP.
show wccp flows media-cache Indica fluxos de pacote de informação do serviço de ocultação dos media.
show wccp routers Lista do roteador WCCP dos indicadores.
show wccp services Serviços dos indicadores WCCP configurados.
show wccp slowstart Começo lento dos indicadores WCCP.
show wccp status Status de execução do WCCP dos indicadores.
show statistics mediacache real savings Indica estatísticas salvas.
show statistics mediacache real requests Estatísticas do pedido dos indicadores.
show rtsp all Indica toda a configuração RTSP.
show rtsp proxy Indica a configuração de modo de proxy.
show mediafs volumes Indica volumes dos mediafs.

Comandos debug do motor do esconderijo

comando debug Descrição
debug wccp all Permite o WCCP de girar sobre toda a eliminação de erros.
debug wccp events Permite eventos WCCP.
debug wccp packets Permite a informação relacionada ao pacote WCCP.

Comandos show do roteador

Comando show Descrição
show ip wccp 80 detail Estatísticas do motor e do roteador WCCP do esconderijo dos indicadores para um grupo de serviço específico.
show ip wccp 80 view Indica a informação da opinião do grupo de serviço

Comandos debug do roteador

comando debug Descrição
debug ip wccp events Eventos WCCP dos indicadores.
debugar pacotes do wccp IP Informação relacionada ao pacote dos indicadores WCCP.

Resumo de comandos

Estes comandos cache engine foram usados nesta configuração:

  • versão {1 do wccp | 2}

  • wccp router-list number ip-address

  • número router-list-num do media-esconderijo do wccp

  • chave media-real da chave de licença do proxy do rtsp

  • rtsp proxy media-real ip-address ip-address

  • o proxy do rtsp media-real permite

  • porta de recebimento do proxy do rtsp

Estes são os comandos router que foram usados nesta configuração:

  • wccp IP {cache de web | número do serviço}

  • wccp IP {cache de web | o número do serviço} reorienta para fora

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 4717