IP : Open Shortest Path First (OSPF)

Redistribuição OSPF entre processos de OSPF diferentes

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece diretrizes para a redistribuição do Open Shortest Path First (OSPF) entre diferentes processos. A redistribuição entre diferentes processos é difícil e medidas especiais são necessárias para a operação apropriada da rede. Este documento igualmente destaca algumas mudanças introduzidas no software de Cisco IOS�.

Por que redistribua entre dois processos de OSPF?

Pode haver diversas razões para a redistribução entre processos múltiplos. Estes são alguns exemplos:

  • Para filtrar parte de uma rota de OSPF do domínio

  • Para separar domínios de OSPF diferentes

  • Para migrar entre domínios separados

Embora a redistribução entre processos diferentes possa ser necessária em certos casos, uma solução alternativa do projeto (se possível) é uma escolha mais apropriada, como será discutido nas subseções desta seção.

Filtrando a rota de OSPF

Rotas intra-áreas

No OSPF, os prefixos IP dentro de uma área não são trocados diretamente entre o Roteadores. São parte da propaganda do estado do link (LSA) que igualmente anuncia a topologia da rede; consequentemente, não há nenhuma maneira às rotas de filtro dentro de uma área.

Nota: A filtração local em um roteador (que pode ser feito para impedir que algumas rotas estejam instaladas em um roteador dado) não é considerada ser filtração da rota real. Isto é realizado normalmente com o comando distribute-list sob o roteador OSPF.

Uma solução seria usar um processo diferente e filtrar as rotas desejadas no Roteadores de redistribuição; contudo, fazer isto separa realmente a área em dois domínios. Um melhor design seria separar a área em áreas diferentes e usar o tipo 3 recursos de filtragem do Cisco IOS, que é explicado mais tarde.

Rotas inter-área

No OSPF, todo o Roteadores dentro de uma área tem o exato a mesma topologia. Uma área não tem nenhum conhecimento da topologia de uma outra área; consequentemente, confia na informação anunciada pelos roteadores de borda da área anexa (ABR).

A informação anunciada dentro de uma área por um ABR (como um tipo 3 LSA) é realmente os prefixos IP que são instruídos das áreas remotas ou que são calculados para outras áreas anexa.

Um ABR origina estas rotas:

  • rotas intra-áreas do NON-backbone no backbone

  • Intra-area e rotas inter-área do backbone na área sem backbone

Consequentemente, entre áreas há um comportamento do vetor de distância que possa ser leveraged às rotas de filtro entre áreas.

O Cisco IOS Software executou uns recursos de filtragem do inter-area. Para obter mais informações sobre desta característica, refira o OSPF ABR type 3 LSA filtering.

Filtração da rota externa

Porque as rotas externas são anunciadas como o tipo 5 LSA e são amplo domínio inundado, a não ser que nas áreas de stub e no Not-So-Stubby Areas (NSSA), não haja atualmente nenhuma maneira de filtrar um tipo 5 LSA. Uma solução é ter um processo diferente e filtrá-la entre processos ao redistribuir.

Mantendo-se os domínios de OSPF diferentes separam

Vê-se como uma prática comum usar processos de OSPF diferentes a fim separar domínios diferentes de Roteamento IP, para propósitos administrativos ou segmentar o domínio de roteamento e controlar a informação de roteamento no ponto da redistribução.

Deve-se notar, contudo, que a instabilidade em um domínio poderia afetar o outro domínio. Por exemplo, se há uma mudança na rede de OSPF (tipo-1 e 2) onde um roteador de limite de sistema autônomo (ASBR) reside entre os dois domínios, todo o tipo 5 LSA re-será originado e inundado durante todo o domínio remoto. Assim, se há uma instabilidade constante em uma rede, isto pode conduzir a uma injeção constante e a uma retirada do tipo 5 LSA no outro domínio.

Uma escolha do melhor design é usar o Border Gateway Protocol (BGP) entre domínios diferentes. Neste caso, a troca OSPF entre domínios diferentes vai embora BGP; e, porque o BGP tem a capacidade de umedecimento, a instabilidade em um domínio será menos visível no outro domínio.

Redistribuição entre processos de OSPF diferentes

Como mencionado previamente, pode haver uma solução alternativa à redistribuição entre processos múltiplos. A seção mostra como a redistribução entre processos diferentes deve ser planeada com cuidado, segundo o número de redistribução aponta.

Regra da preferência da rota de OSPF

A regra de seleção da rota de OSPF é que as rotas intra-áreas estão preferidas sobre as rotas inter-área, que são preferidas sobre rotas externas. Contudo, esta regra deve aplicar-se às rotas aprendidas através do mesmo processo. Ou seja não há nenhuma preferência entre rotas externas de um processo comparado às rotas internas do outro processo.

A regra da preferência entre um processo de OSPF dado e qualquer outro processa (seja OSPF ou um outro protocolo de roteamento) deve seguir a regra da distância administrativa. Contudo, porque os processos de OSPF diferentes terão a mesma distância administrativa à revelia, a distância OSPF deve ser configurada explicitamente para processos de OSPF diferentes, para conseguir o comportamento desejado.

Nota: Antes que a identificação de bug Cisco CSCdi7001 — fixado no Cisco IOS Software Release 11.1 e Mais Recente — distância administrativa entre processos não trabalhou corretamente, e as rotas internas de um processo foram preferidas sobre as rotas externas de um outro processo.

Um único ponto da redistribução

Quando há um único ponto da redistribução, toda a troca entre os domínios ocorre em um único ponto, e não há nenhuma maneira que um laço da redistribução pode formar. Este é um exemplo de configuração:

Figura 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-01.gif

Configuração de Roteador A
router ospf 1
redistribute ospf 2 subnet

router ospf 2
redistribute ospf 1 subnet

Dois pontos da redistribução

É mais complicada quando há dois pontos da redistribução. Se a redistribução é feita em ambos os pontos de uma rede sem nenhum cuidado especial, pode haver uns resultados inesperados.

Considere a topologia seguinte, onde o roteador A e o roteador B estão redistribuindo mutuamente entre ambos os domínios. Esta configuração não está trabalhando, como será demonstrado mais tarde nesta seção.

Figura 2

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-02.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet

router ospf 2
redistribute ospf 1 subnet

Dado uma rede N no domínio 1, o roteador A e B aprendem a rede N como uma rota interna no domínio 1. Porque estão redistribuindo o processo 1 no processo 2, a mesma rede N é aprendida no domínio 2 como uma rota externa.

Agora, em cada roteador, a rede interna aprendida através de um processo está competindo contra a rede externa de um outro processo. Como mencionado previamente, não há nenhuma regra da preferência entre processos diferentes; consequentemente, o resultado seria indeterministic, como ambos processam têm a mesma distância administrativa.

Nota: Isto podia conduzir a uma injeção constante e a uma retirada de um tipo 5 de um processo ao outro.

Antes que a identificação de bug Cisco CSCdw10987 (clientes registrados somente) (integrado nos Cisco IOS Software Release 12.2(07.04)S, 12.2(07.04)T, e mais tarde), o último processo para fazer um primeiro algoritmo do caminho mais curto (SPF) ganharia, e os dois processos overwrite outras rotas na tabela de roteamento. Agora, se uma rota é instalada através de um processo, não overwritten por um outro processo de OSPF com o mesmo campo administrativo (AD), a menos que a rota for suprimida primeiramente da tabela de roteamento pelo processo que instalou inicialmente a rota na tabela de roteamento.

Distância administrativa

Quando você está usando a redistribução entre processos múltiplos, você pode usar a distância administrativa para preferir um processo sobre um outro processo, porque as preferências da rota de OSPF se aplicam somente dentro do mesmo processo. Contudo, este não é bastante para a operação apropriada na rede, como explicado mais tarde nesta seção.

Figura 3

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet
distance ospf external 200

router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

Operação de rede sem falha de rede

Considere uma rede N no domínio 1, onde N será sabido como uma rota interna no domínio 1 e redistribuído pelo roteador A e pelo roteador B. Porque a distância administrativa de rotas externas foi aumentada, o roteador A e o roteador que B escolheram o processo de OSPF 1 alcançar a rede N.

Em mais maneira geral, todas as redes internas ao domínio 1 serão alcançadas através do domínio 1 e todas as redes internas ao domínio 2 serão alcançadas através do domínio 2, pelo roteador A e pelo roteador B. O outro Roteadores em cada domínio pegara o ASBR o mais próximo (se o tipo-2 métrico é usado) ou o caminho mais curto com um dos ASBR (se o tipo-1 métrico é usado).

Se há uns prefixos externos a ambos os domínios (de que vem de alguns outros pontos da redistribução), o mesmo problema ainda ocorrerá porque a distância administrativa para aquelas rotas externas é a mesma em ambos os processos. Se você faz a distância administrativa para processos externos diferente, não resolverá o problema. Este é um exemplo:

Figura 4

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-04.gif

O C do roteador (ASBR) anuncia N externo no domínio 1. Este prefixo obtém redistribuído pelo roteador A e pelo roteador B no domínio 2 e alcançará cada um do Roteadores; consequentemente, N será externo em ambos os domínios. Para ter operações apropriadas, a distância administrativa de rotas externas precisa de ser diferente para os dois processos, de modo que um domínio seja preferido sobre o outro. Supõe que a distância administrativa para o domínio 1 está ajustada mais baixa do que o domínio 2.

Agora, se o roteador D (ASBR) está anunciando M externo no domínio 2, a seguir este prefixo é redistribuído pelo roteador A e pelo roteador B no domínio 1 e alcançará cada um do Roteadores. Assim, M será externo em ambos os domínios e, porque a distância administrativa é mais baixa para o domínio 1, M será alcançável através do domínio 1. Esta sequência de evento podia ocorrer:

  1. Roteador A (o roteador B) redistribui M no domínio 1, e M externo alcançará o roteador B (roteador A).

  2. Porque a distância administrativa do domínio 1 é mais baixa do que o domínio 2, o roteador A (o roteador B) instalará M através do domínio 1 e ajustará ao período máximo seu LSA originado precedente (evento 1) no domínio 1.

  3. Porque M foi ajustado ao período máximo no domínio 2, o roteador A (o roteador B) instalará M embora o domínio 2 e, consequentemente, redistribuirá M no domínio 2.

  4. Mesmos que o evento 1.

Este ciclo continua, e a maneira de fixá-lo é ter o prefixo do domínio 2 alcançável através do domínio 2. Contudo, se a distância administrativa é ajustada mais baixa para o domínio 2, a seguir o mesmo problema ocorrerá para o domínio 1 e para o prefixo N.

A solução é ajustar a distância administrativa baseada no prefixo. Veja a filtração thePrefix-baseada e filtração com base no prefixo e seções com base no prefixo da distância administrativa para mais informação.

Operação de rede com falha de rede

Você quer um backup do domínio o outro domínio, caso que um domínio é inacessível.

Por exemplo, considere o caso onde o roteador A perdeu a Conectividade à rede N através do domínio 1. Uma vez que o roteador A perde sua Conectividade através do domínio 1, nivelará seu LSA previamente gerado que anuncia a rede N no domínio 2 e instalará o trajeto à rede N através do domínio 2 através da rede externa recebida do B. Porque o processo 2 é redistribuído no processo 1, o roteador A igualmente injetará uma rede externa N no domínio 1.

Nota: Quando o roteador A teve a Conectividade à rede N, usou o processo 1 devido à distância administrativa melhor, e o processo 2 foi mantido para a informação de backup. Uma vez que o trajeto com o processo 1 se torna inacessível, o processo 2 está usado para a Conectividade.

Figura 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-05.gif

Agora, todo o Roteadores no domínio 2 usará o roteador B para alcançar a rede N; e o roteador A (ou parte do domínio 1 que perdeu a Conectividade à rede N através do domínio 1) usarão o domínio 2 para a Conectividade à rede N. Esta encenação permanece válida se o roteador B tinha perdido a Conectividade à rede N, em vez do roteador A.

Se o roteador A e o roteador B ambo Conectividade fraca à rede N (por exemplo, se o C do roteador vai para baixo), a seguir à esta sequência de evento poderiam ocorrer:

  1. Antes que a rede N se torne inacessível, o roteador A e o roteador B aprenderam que a rede N processa embora 1 e redistribua lhe no processo 2 como externos.

  2. O roteador A e o roteador B detectam (quase ao mesmo tempo) que a rede N é inacessível através do domínio 1; consequentemente, nivelarão seu N previamente externo no domínio 2.

  3. Antes do roteador A (o roteador B) recebe o LSA nivelado do roteador B (roteador A), instalará o N externo através do domínio 2 (uma distância administrativa mais alta) como a rota de backup.

  4. Desde o roteador A (roteador B) N instalado com o processo 2, gerará um N externo no domínio 1.

  5. Roteador A (o roteador B) recebe o LSA nivelado (evento 1) do roteador B (roteador A). Removerá a rede N com o processo 2 e, consequentemente, nivelar o N externo na rede N do domínio 1. era instruído através do domínio 2 e redistribuído no domínio 1.

  6. Antes do roteador A (o roteador B) recebe o LSA nivelado do roteador B (roteador A), instalará a rede externa N através do domínio 1, porque N foi o domínio embora nivelado 2.

  7. Desde o roteador A (roteador B) a rede instalada N com o processo 1, gerará um N externo no domínio 2.

Você pode ver que há uma race condition que poderia aparecer de um domínio ao outro domínio. Nos eventos 1, 4, e 7, o roteador A gera uma rede externa N no domínio 2; e nos eventos 2 e 5, o roteador A retira o prefixo. O problema ocorre porque as rotas aprendidas através de um domínio são redistribuídas de volta ao mesmo domínio.

Solução proposta

Esta seção mostra como impedir uma rota que pertença a um domínio da redistribuição de volta ao mesmo domínio, para evitar loop de roteamento.

Usando o comando distance 255

A seção anterior mostra como um loop de roteamento é criado se os prefixos aprendidos de um domínio são redistribuídos de volta ao mesmo domínio. Porque a redistribução está ocorrendo de uma tabela de roteamento, você pode impedir uma rota que pertençam ao domínio 1 e que seja instruída do roteador remoto sobre o domínio 2 da instalação na tabela de roteamento. Consequentemente, o roteador não redistribuirá aquelas rotas de volta ao domínio 1.

Para fazer isto, emita o comando distance 255 router_ID inverse_mask access-list. Este comando diz o roteador para negar todos os prefixos que são recebidos por um roteador remoto com o Router ID especificado e que combinam o Access Control List (ACL) da tabela de roteamento.

Nota: O comando distance 255 dá uma distância de 255 2 aquelas rotas e, impede consequentemente sua instalação na tabela de roteamento.

Na figura 6, o roteador A usa o comando access-list 1 combinar todas as rotas no domínio 1 e usa o comando distance 255 sob o processo 1 negar as rotas recebidas do roteador B que combinam os prefixos que pertencem ao domínio 1.

Quando você usa o comando distance 255, nega toda a rota recebida do roteador B que pertence ao domínio 1. Porque o roteador B redistribui todas as rotas no domínio 1 no domínio 2, o roteador A não instalará aquelas rotas e, consequentemente, não as redistribuirá de novo no domínio 1 outra vez.

Nota: A interface conectada do roteador B no domínio 1 deve ser excluída do ACL.

Figura 6

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Configuração de Roteador A Configuração do Roteador B
router ospf 1
redistribute ospf 2 subnet
distance 255 <Router B> 0.0.0.0 2
!
access-list 1

!--- Matches the router in Domain 2.


router ospf 2
redistribute ospf 1 subnet
distance 255 <Router B> 0.0.0.0 1
!
access-list 2

!--- Matches the route in Domain 1.

router ospf 1
redistribute ospf 2 subnet
distance 255 <Router A> 0.0.0.0 2
!
access-list 1

!--- Matches the router in Domain 2.


router ospf 2
redistribute ospf 1 subnet
distance 255 <Router A> 0.0.0.0 1
!
access-list 2

!--- Matches the route in Domain 1.

O comando distance ospf external 200 precedente é precisado já não porque as rotas aprendidas do roteador remoto através de um dos processos não são instaladas.

Esta configuração trabalha corretamente nos casos onde ambo o Roteadores afrouxa a Conectividade à rede (como descrito na operação de rede sem falha de rede e na operação de rede com falha de rede). Contudo, porque os prefixos são negados da tabela de roteamento, os domínios não podem suportar-se.

Nota: Você deve explicitamente alistar todos os prefixos de cada domínio em um ACL. A manutenção de tal ACL pode ser muito difícil.

Rotas de filtração baseadas em etiquetas

Há uns novos recursos no Cisco IOS Software (da identificação de bug Cisco CSCdt43016 (clientes registrados somente)) que o permite às rotas de filtro baseou na etiqueta. Para impedir a redistribução das rotas de um domínio de novo no mesmo domínio, um roteador pode etiquetar uma rota que pertença a um domínio quando redistribuir, e você pode filtrar aquelas rotas no roteador remoto baseado na mesma etiqueta. Porque as rotas não serão instaladas na tabela de roteamento, não serão redistribuídas de novo no mesmo domínio.

Figura 7

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet tag 1
distribute-list 1 route-map filter_domain2 in
!
route-map filter_domain2 deny 10
match tag 2
route-map filter_domain2 permit 20

router ospf 2
redistribute ospf 1 subnet tag 2
distribute-list 1 route-map filter_domain1 in
!
route-map filter_domain1 deny 10
match tag 1
route-map filter_domain1 permit 20

Quando você está redistribuindo do domínio 1, as rotas são etiquetadas com a etiqueta 1 e filtradas no roteador remoto baseado na mesma etiqueta. Quando você está redistribuindo do domínio 2, as rotas são etiquetadas com a etiqueta 2 e filtradas no roteador remoto baseado na mesma etiqueta.

Nota: O comando distance ospf external 200 precedente é precisado já não porque a rota aprendida do roteador remoto através de um dos processos não é instalada.

Esta configuração trabalha corretamente nos casos onde ambo o Roteadores afrouxa a Conectividade à rede (como descrito na operação de rede sem falha de rede e na operação de rede com falha de rede). Contudo, porque os prefixos são negados da tabela de roteamento, os domínios não podem suportar-se.

Usando a palavra-chave interna do fósforo ao redistribuir

Quando você está redistribuindo de um domínio, você pode usar a palavra-chave interna do fósforo para redistribuir somente as rotas internas que pertencem a um domínio em um outro domínio. Isto impede a redistribução dos prefixos que são já externos de novo no mesmo domínio.

Figura 8

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet match internal
distance ospf external 200
!

router ospf 2
redistribute ospf 1 subnet match internal
distance ospf external 200
!

Esta configuração trabalha corretamente nos casos onde ambo o Roteadores afrouxa a Conectividade à rede (como descrito na operação de rede sem falha de rede e na operação de rede com falha de rede). Um domínio podia suportar o outro domínio.

Se há já uns prefixos externos em qualquer um dos domínios (tais como os prefixos externos que estiveram redistribuídos através de um outro protocolo), a seguir aqueles prefixos não estarão redistribuídos a outros domínios, porque somente os prefixos internos são redistribuídos. Também, não há nenhum controle sobre prefixos externos, e todos os prefixos externos serão obstruídos.

Filtração com base no prefixo

Quando você está redistribuindo de um domínio, os prefixos podem ser combinados contra um ACL para evitar a redistribução dos prefixos que pertencem a um domínio de novo no mesmo domínio.

Figura 9

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Roteador A e configuração B
router ospf 1
redistribute ospf 2 subnet route-map filter_domain2
distance ospf external 200
!
route-map filter_domain2 permit 10
match ip address 1
!
access-list 1

!--- Matches the prefix in Domain 1.


router ospf 2
redistribute ospf 1 subnet route-map filter_domain1
distance ospf external 200
!
route-map filter_domain1 permit 20
match ip address 2
!
access-list 2

!--- Matches the prefix in Domain 2.

Esta configuração trabalha corretamente nos casos onde ambo o Roteadores afrouxa a Conectividade à rede (como descrito na operação de rede sem falha de rede e na operação de rede com falha de rede). Um domínio podia suportar o outro domínio.

Nota: Você deve explicitamente alistar todos os prefixos de cada domínio em um ACL. A manutenção de tal ACL pode ser muito difícil. Uma outra solução é etiquetar prefixos durante a distribuição e filtrar então as etiquetas correspondentes.

Figura 10

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet tag 1 route-map filter_domain2
distance ospf 2 external 200
!
route-map filter_domain2 deny 10
match tag 2
route-map filter_domain2 permit 20

router ospf 2
redistribute ospf 1 subnet tag 2 route-map filter_domain1
distance ospf 1 external 200
!
route-map filter_domain1 deny 10
match tag 1
route-map filter_domain1 permit 20

Filtração com base no prefixo e distância administrativa com base no prefixo

Como mencionado na seção da distância administrativa, há uma necessidade para uma distância administrativa com base no prefixo onde haja uns prefixos externos originados por outros ASBR em cada domínio. Na topologia do exemplo seguinte, ASBR1 e ASBR2 estão redistribuindo redes X e Y no domínio 1 e no domínio 2, respectivamente.

Este exemplo usa um ACL para combinar todos os prefixos que (internos e externos) pertencem a um domínio, e usa o comando distance aumentar a distância administrativa de prefixos que não pertencem inicialmente ao domínio correspondente.

Figura 11

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-06.gif

Roteadores A e configuração B
router ospf 1
redistribute ospf 2 subnet route-map filter_domain2
distance 200 0.0.0.0 255.255.255.255 2
!
route-map filter_domain2 permit 10
match ip address 1
!
access-list 1

!--- Matches the prefixes in Domain 1.

access-list 2

!--- Matches the prefixes in Domain 2.


router ospf 2
redistribute ospf 1 subnet route-map filter_domain1
distance 200 0.0.0.0 255.255.255.255 1
!
route-map filter_domain1 permit 10
match ip address 2
!
access-list 1

!--- Matches the prefixes in Domain 1.

access-list 2

!--- Matches the prefixes in Domain 2.

O comando 2 de 0.0.0.0 255.255.255.255 da distância 200 sob o processo 1 ajusta a distância administrativa de todos os prefixos que pertencem ao domínio 2 200; consequentemente, o Roteadores A e B usa o domínio 1 para alcançar os prefixos que pertencem ao domínio 1.

Nota: Você deve explicitamente alistar todos os prefixos externos de cada domínio em um ACL. A manutenção de tal ACL pode ser muito difícil.

Resumo

Quando há mais de um ponto da redistribução entre domínios de OSPF, os loop de roteamento podem facilmente ocorrer. Para impedir loop de roteamento, os prefixos que pertencem a um domínio não devem ser redistribuídos de volta ao mesmo domínio. Também, as distâncias administrativas dos processos de OSPF devem ser ajustadas corretamente. Estes cinco métodos foram propostos neste documento:

  • Use o comando distance 255.

  • Filtre baseado em etiquetas.

  • Use a palavra-chave interna do fósforo durante a redistribução.

  • Use a filtração com base no prefixo durante a redistribução.

  • Use a filtração com base no prefixo e a distância administrativa com base no prefixo.

As primeiras duas soluções impedem as rotas que pertencem a um domínio da instalação na tabela de roteamento, que impede sua redistribução de volta ao mesmo domínio.

Nota: Porque os prefixos são negados da tabela de roteamento, os domínios não podem suportar-se.

Você pode usar as últimas três soluções para suportar um domínio com um outro domínio, se necessário. Contudo, você deve notar estas advertências:

  • A solução interna do fósforo não permite que você tenha o controle sobre prefixos, e todos os prefixos externos serão obstruídos da redistribução. Ou seja se há uns prefixos externos de outros ASBR, a seguir daqueles LSA não será redistribuído de um domínio ao outro.

  • Do “a filtração com base no prefixo uso durante a solução da redistribução” permite que um domínio suporte um outro domínio. Contudo, o backup trabalha somente corretamente quando não há nenhuma rota externa do outro ASBR.

  • Do “a solução da filtração com base no prefixo uso e da distância administrativa com base no prefixo” é a única solução que permite que um domínio suporte um outro domínio na presença das rotas externas de outros ASBR.

Este documento refere repetidamente o uso de um domínio suportar um outro domínio. Deve-se notar que o “backup” significa que, se o roteador A frouxamente sua conexão parte de ao domínio através de um domínio dado (tal como o domínio 1), a seguir poderia usar o outro domínio (domínio 2) para distribuir corretamente 2 aqueles destinos que não podem ser alcançados através do domínio 1.

Contudo, se um domínio é dividido porque os prefixos não estão redistribuídos de volta ao domínio original, a seguir o outro domínio não poderia suportar o domínio dividido a menos que os prefixos fossem redistribuídos de volta ao domínio original. Contudo, como referido na distância administrativa e na operação de rede com seções da falha de rede, isto introduzirá outros problemas.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 4170