Switches : Switches Cisco Catalyst 3750 Series

Configurando e analisando a aglomeração em switch de configuração fixa do catalizador

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Outubro 2015) | Feedback


Índice


Introdução

Este documento descreve as etapas básicas de configuração para formar um cluster no Catalyst 1900/2820 e nos switches de configuração fixa Catalyst através do uso da Cluster Management Suite (CMS). Os switches de configuração fixa Catalyst que este documento aborda inclui as séries 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560 e 3750. A intenção deste documento é fornecer o conhecimento básico de como os clusters funcionam e para fornecer troubleshooting básico e analisar procedimentos com comandos show e saídas de depuração de erros. O documento oferece um exemplo simples de um grânulo construído com uso de Web Interface. Ele também mostra alterações automáticas de configuração, perceptíveis durante o processo de criação de cluster.

Pré-requisitos

Requisitos

Um documento separado do gerenciamento de web fornece a informação em como alcançar o interruptor com Cisco Visual Switch Manager (VS) ou CMS. O documento, pesquisar defeitos o Cisco Visual Switch Manager ou o acesso ao conjunto de gerenciamento de grupos no Catalyst 2900XL/3500XL/2950/3550 switch, endereça estes problemas:

  • Incapaz de conectar ao página da web principal do interruptor

  • 404 erros não encontrados

  • Uma tela em branco quando você alcançar o VS ou o CMS

  • A Java não é tela habilitada

  • A interface da WEB pede continuamente o nome de usuário e a senha

  • Nenhuma resposta das mensagens do dispositivo durante o link ou a criação de gráficos de largura de banda

Consulte Troubleshooting Cisco Visual Switch Manager ou Cluster Management Suite Access no Catalyst 2900 XL/3500 XL/2950/3550 Switch, se tiver problemas de acesso com a Interface de Gerenciamento Baseado na Web (VSM or CMS) ou se observar qualquer um desses sintomas.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Notas importantes

A tecnologia de Cisco Switch Clustering é os conjuntos do recurso de software disponíveis a todo o 2900/3500XL, 2940, 2950, 2955, 2970, 3550, 3560, e 3750 Series Switch e o padrão e os Enterprise Edition switch do Catalyst 1900/2820. A tecnologia de aglomeração permite até um máximo de 16 switch interconectados de formar controlado, rede do endereço único-IP. É essencialmente um método para controlar um grupo de Switches sem a necessidade de atribuir um endereço IP de Um ou Mais Servidores Cisco ICM NT a cada interruptor.

Os Switches em um agrupamento têm uma destas funções:

  • Comando switch

  • Switch membros

  • Switch de candidato

Em cada conjunto, há um switch mestre chamado um comando switch. O resto do Switches serve como switch membros. O comando switch oferece a interface de gerenciamento principal para todo o cluster. O comando switch é tipicamente o único interruptor dentro do conjunto do interruptor configurado com um endereço IP de Um ou Mais Servidores Cisco ICM NT. Cada requisição de gerenciamento vai ao comando switch antes da reorientação ao switch membro apropriado. Para a Redundância, você pode configurar um interruptor do comando standby. O interruptor do comando standby deve ser o mesmo modelo que o comando switch. Um switch membro não é configurado tipicamente com um endereço IP de Um ou Mais Servidores Cisco ICM NT e recebe os comandos management que o comando switch reorientou. Um switch de candidato é um interruptor que você possa adicionar ao conjunto do interruptor como um switch membro.

Características do comando switch

Um interruptor do comando catalyst deve cumprir estas exigências:

  • O interruptor tem um endereço IP de Um ou Mais Servidores Cisco ICM NT.

  • O interruptor tem a versão 2 do protocolo cisco discovery (CDPv2) permitida (o padrão).

  • O interruptor não é um comando ou um switch membro de um outro conjunto.

  • O interruptor conecta ao Switches do comando standby com o VLAN de gerenciamento e aos switch membros com um VLAN comum.

O alto-fim, interruptor comando-capaz no conjunto deve ser o comando switch, como detalhado aqui:

  • Se seu conjunto do interruptor tem um 3750 Switch, esse interruptor deve ser o comando switch.

  • Se seu conjunto do interruptor tem 2900XL, 2940, a 2950, 2955, 3550, os 3560 e 3500XL Switch, os 3550 ou os 3560 devem ser o comando switch.

  • Se seu conjunto do interruptor tem 2900XL, 2940, a 2950, 2955, e os 3500XL Switch, a 2950 ou os 2955 devem ser o comando switch.

  • Se seu conjunto do interruptor tem 1900, 2820, 2900XL, e 3500XL Switch, o 2900XL ou 3500XL devem ser o comando switch.

Características do Switch de comando de standby

Um interruptor do comando standby do catalizador deve cumprir estas exigências:

  • O interruptor tem um endereço IP de Um ou Mais Servidores Cisco ICM NT.

  • O interruptor tem o CDPv2 permitido.

  • O interruptor é conectado ao outro Switches à espera com o VLAN de gerenciamento e a todos os switch membros com um VLAN comum.

  • O interruptor é conectado redundantemente ao conjunto para manter a Conectividade aos switch membros.

  • O interruptor não é um comando ou um switch membro de um outro conjunto.

O Switches do comando standby igualmente deve cumprir estas exigências:

  • Quando o comando switch é o interruptor a�3750, todo o Switches do comando standby deve o Switches be�3750.

  • Quando o comando switch é o interruptor a�3550, todo o Switches do comando standby deve o Switches be�3550.

  • Quando o comando switch é o interruptor a�2955, todo o Switches do comando standby deve o Switches be�2955.

  • Quando o comando switch é interruptor dos Ethernet de longo alcance a�2950 (LRE), todo o Switches do comando standby deve Switches be�2950 LRE.

  • Quando o comando switch é um interruptor non-LRE�2950 que execute o software Release�12.1(9)EA1 de Cisco IOS� ou mais tarde, todo o Switches do comando standby deve ser o Switches non-LRE�2950 que executa o Cisco IOS Software Release�12.1(9)EA1 ou mais tarde.

  • Quando o comando switch é um interruptor non-LRE�2950 que execute o Cisco IOS Software Release�12.1(6)EA2 ou mais tarde, todo o Switches do comando standby deve ser o Switches non-LRE�2950 que executa o Cisco IOS Software Release�12.1(6)EA2 ou mais tarde.

  • Quando o comando switch executa o Cisco IOS Software Release�12.0(5)WC2 ou mais cedo, o Switches do comando standby enlata be�2900XL, non-LRE�2950, Switches and�3500XL.

O Switches do comando switch e do comando standby deve ser da mesma plataforma do switch.

  • Com comando switch a�3550, o Switches do comando standby se o Switches be�3550.

  • Com comando switch a�2955, o Switches do comando standby se o Switches be�2955.

  • Com comando switch a�2950 LRE, o Switches do comando standby se o Switches be�2950 LRE.

  • Com um comando switch non-LRE�2950, o Switches do comando standby deve ser o Switches non-LRE�2950.

  • Com comando switch a�2900XL or�3500XL, o Switches do comando standby se o Switches be�2900XL and�3500XL.

Características do switch de candidato e do switch membro

Os switch de candidato são o Switches capaz de cluster que não foi adicionado ainda a um conjunto. Os switch membros são o Switches que foi adicionado realmente a um conjunto do interruptor. Embora não exigido, um candidato ou um switch membro podem ter um endereço IP de Um ou Mais Servidores Cisco ICM NT e uma senha. (Para considerações relacionadas, refira a seção dos endereços IP de Um ou Mais Servidores Cisco ICM NT e a seção das senhas dos switch de aglomeração do documento.)

Para juntar-se a um conjunto, um switch de candidato deve cumprir estas exigências:

  • O interruptor executa atualmente o software capaz de cluster.

  • O interruptor tem o CDPv2 permitido.

  • O interruptor não é um comando ou um switch membro de um outro conjunto.

  • O interruptor conecta ao comando switch com pelo menos um VLAN comum.

  • Se um grupo de standby do conjunto existe, o interruptor conecta a cada interruptor do comando standby com pelo menos um VLAN comum. O VLAN a cada interruptor do comando standby pode diferir.

Nota: Este o candidato e os switch membros devem conectar ao Switches do comando switch e do comando standby com o VLAN de gerenciamento:

  • 1900 Switch

  • 2820 Switch

  • 2900XL Switch

  • Switches non-LRE�2950 que executa atualmente uma liberação mais cedo do que o Cisco IOS Software Release�12.1(9)EA1

  • 3500XL Switch

Nota: Esta exigência não se aplica se você tem um comando switch 2950 não-LRE que execute atualmente o Cisco IOS Software Release�12.1(9)EA1 ou mais tarde, um comando switch 2950 LRE, um comando switch 2955, ou o comando switch a�3550. O candidato e os switch membros podem conectar com todo o VLAN em comum com o comando switch.

Com CDPv2, todo o Switches, incluindo o comando switch, descobre vizinhos de CDP e armazena esta informação no cache de CDP de vizinho respectivo. Switches que executa a passagem capaz de cluster do software a informação sobre o Switches e os vizinhos respectivos ao comando switch. Para fazer isto, o Switches usa o mecanismo de uma comunicação intracluster (ICC), que é executado sobre o User Datagram Protocol (UDP). O comando switch filtra a informação e cria uma lista de switch de candidato.

Para indicar esta lista do candidato, emita o comando show cluster candidates no comando switch.

Nota: A lista não pode refletir a tabela de CDP vizinho do comando switch. A tabela de vizinho CDP exibe apenas informações sobre vizinhos com conexão direta. Todo o interruptor que estiver na lista é um candidato a ser um switch membro, ou um interruptor que o comando switch possa controlar. Um switch de candidato deve satisfazer estas exigências juntar-se a um conjunto:

  • O interruptor deve ter potencialidades de grânulos. Veja os modelos de Catalyst switch com seção das potencialidades de grânulos deste documento para verificar se o interruptor tem potencialidades de grânulos e executa atualmente o software correto.

  • O interruptor tem o CDPv2 permitido. (CDPv2 está ativado por padrão.)

  • O interruptor não é um membro ativo ou um comando switch de um outro conjunto.

  • O interruptor conecta a um comando switch através das portas que pertencem ao mesmo VLAN de gerenciamento.

Nota: Um switch de candidato pode ter um endereço IP de Um ou Mais Servidores Cisco ICM NT, mas um endereço IP de Um ou Mais Servidores Cisco ICM NT não é necessário.

Nota: O comando switch IP address fornece acesso a todas as facilidades de gerenciamento de cluster. O comando switch IP address pertence sempre pertence ao VLAN de gerenciamento (VLAN1, por padrão). Todo o Switches dentro do conjunto do interruptor deve ter o mesmo VLAN de gerenciamento que o comando switch. Até à data do Cisco IOS Software Release 12.0(5)XP para os 2900XL e 3500XL Switch, você pode mudar o VLAN de gerenciamento do padrão do VLAN1. Além, o Cisco IOS Software Release 12.0(5)XU ou Mais Recente permite que você mude o VLAN de gerenciamento para o conjunto inteiro do interruptor. A alteração requer um único comando via interface de Web de CMS. Para detalhes em como mudar o VLAN de gerenciamento, refira estes documentos:

Descoberta através das portas roteada

Se o interruptor do comando cluster tem uma porta roteada configurada, o interruptor descobre o Switches somente do candidato e do membro de grânulos no mesmo VLAN que a porta roteada. Para obter mais informações sobre das portas roteada, refira a seção das portas roteada do manual de configuração do software 3750 que configura características da relação.

Descoberta com os VLAN diferentes

Se o comando switch é a�3550, 3560, ou o 3750 Switch, o conjunto podem ter switch membros em VLAN diferentes. Os switch membros que são 3550 devem conectar com pelo menos um VLAN que o interruptor tem em comum com o comando switch. Switch membros que are�2900XL, 2950 do �are e sido executado uma liberação mais cedo do que o Cisco IOS Software Release�12.1(9)EA1, ou are�3500XL deve conectar ao comando switch com o VLAN de gerenciamento. Para obter informações sobre da descoberta com os VLAN de gerenciamento, refira a descoberta através da mesma seção VLAN de gerenciamento e a descoberta através da seção diferente dos VLAN de gerenciamento dos switch de aglomeração do documento. Para obter mais informações sobre dos VLAN, refira o documento que configura VLAN.

Modelos do Catalyst Switch com Recursos de Cluster

A instalação da versão capaz de cluster do Catalyst Software consegue a funcionalidade do conjunto. Todo o Switches conjunto-compatível do catalizador pode ser switch de comando. Você pode promover os 2900XL Series Switch do 8 MB para atuar como switch de comando. Você não pode promover os 2900XL Switch do 4 MB para servir como switch de comando. Também, este Switches pode somente atuar como membros de grânulos se o Switches executa atualmente o Cisco IOS Software Release 11.2(8.x)SA6.

Antes que você crie conjuntos, você precisa de determinar que Switches é capaz de cluster. Você igualmente precisa de determinar que Switches pode atuar como um comando switch. Para determinar se seu interruptor pode servir como um membro de grânulos ou um comando switch, veja esta tabela:

Catalizador 2900XL/3500XL, 2950, 2955, versões mínimas de software 2970, 2940, 3550, 3560, e 3750 potencialidades de grânulos dos modelos e

Tipo do Catalyst Switch Cisco IOS Software Release� Potencialidade de grânulos
3750 Cisco IOS Software Release 12.1(11)AX ou Mais Recente Membro ou comando switch
3560 Cisco IOS Software Release 12.1(19)EA1 ou Mais Recente Membro ou comando switch
3550 Cisco IOS Software Release 12.1(4)EA1 ou Mais Recente Membro ou comando switch
2970 Cisco IOS Software Release 12.1(11)AX ou Mais Recente Membro ou comando switch
2950 Cisco IOS Software Release 12.0(5.2)WC(1) ou Mais Recente Membro ou comando switch
2955 Cisco IOS Software Release 12.1(12c)EA1 ou Mais Recente Membro ou comando switch
2950 LRE Cisco IOS Software Release 12.1(11)YJ ou tarde Membro ou comando switch
2940 Cisco IOS Software Release 12.1(13)AY ou Mais Recente Membro ou comando switch
3500XL Cisco IOS Software Release 12.0(5.1)XU ou Mais Recente Membro ou comando switch
2900 LRE XL (Switches do 16 MB) Cisco IOS Software Release 12.0(5.1)WC1 ou Mais Recente Membro ou comando switch
2900XL (Switches do 8 MB) Cisco IOS Software Release 12.0(5.1)XU ou Mais Recente Membro ou comando switch
2900XL (Switches do 4 MB) Cisco IOS Software Release 11.2(8.5)SA6 (recomendado) Switch membro somente1
1900 e 2820 Software 9.0 do Cisco IOS Release (- A ou - EN) Switch membro somente

o Switches 1The 2900XL (4 MB) aparece no painel frontal e nos visualizações de topologia do CMS. Contudo, o CMS não apoia a configuração ou o monitor destes switches.�To determina se seu 2900XL Switch tem o 4 MB ou o 8 MB do DRAM, e se o interruptor precisa um upgrade de software, emita o comando show version do nível de usuário. Para obter mais informações sobre deste comando, refira como determinar a quantidade de memória no interruptor usando a seção da interface da linha de comando do software em upgrade nos Catalyst 2900XL e 3500XL Switches usando a interface da linha de comando.

Nota:  Para apoiar 1900 e 2820 Switch como switch membros, o comando switch (3500XL ou 8 MB 2900XL) deve atualmente executar o Cisco IOS Software Release 12.0(5)XP ou Mais Recente. O comando switch 2950 deve executar o Cisco IOS Software Release 12.0(5)WC(1) ou Mais Recente.

Os 1900 e 2820 Switch devem executar a versão de firmware 9.00 (padrão ou edição de empreendimento) e não podem servir como switch de comando. Para uns detalhes mais adicionais, refira os Release Note para o Switches do Catalyst 1900 e Catalyst 2820 Series, versão 9.00.

Protocolo de gerenciamento de cluster

Com a possibilidade do interruptor que aglomera-se, há uma atribuição ao comando switch de um endereço IP de Um ou Mais Servidores Cisco ICM NT virtual conhecido como o protocolo cluster management (CMP). Quando um interruptor assenta bem em um membro, o comando switch gera um outro endereço CMP para o switch membro novo. Esse endereço é para qualquer ICC. O comando switch usa este endereço CMP para enviar e adicionar uma mensagem ao switch candidato. O switch de candidato verifica para ter certeza que não seja parte de um outro conjunto antes que o interruptor extraia o endereço CMP e a informação de cluster da mensagem adicionar. O switch de candidato responde então ao comando switch.

Nota: Os endereços CMP que são para o ICC diferem do endereço IP de Um ou Mais Servidores Cisco ICM NT que é para o interruptor ou o gerenciamento de grânulos. Os endereços CMP não respondem aos sibilos. Esta falta da resposta é devido às entradas estáticas do Address Resolution Protocol (ARP) que existem para todos os endereços CMP dentro do conjunto do interruptor mas é transparente ao mundo externo o conjunto.

O CMP é uma coleção das tecnologias subjacentes que facilitam o Gerenciamento dos 16 Switch com uso de um único endereço IP de Um ou Mais Servidores Cisco ICM NT. O CMP consiste em três partes de tecnologia chave:

  • Mecanismo da atribuição de endereço CMP

  • Mecanismo de transporte CMP/IP

  • Mecanismo do address resolution do Reverse Address Resolution Protocol (RARP) CMP/

O mecanismo de atribuição de endereço CMP oferece uma maneira de alocar dinamicamente esses endereços para membros de um cluster e garantir que eles não entrem em conflito com os outros endereços CMP e IP do cluster. O mecanismo de atribuição de endereço CMP também fornece uma forma de resolver um conflito de endereço. O CMP/IP é o mecanismo de transporte que troca pacotes de gerenciamento entre o comando switch e os switch membros. Os pacotes CMP/IP são os pacotes IP regulares que são encapsulados em um encabeçamento (INSTANTÂNEO) do protocolo de acesso de sub-rede de comunicação com identificador exclusivo organizacional (OUI) de Cisco e tipo de protocolo CMP. A identificação distingue esses pacotes dos pacotes de Ethernet TCP/IP normais. O formato permite aplicativos atuais IP trabalhar no CMP/IP sem nenhuma mudança e permite que a reorientação HTTP e de Simple Network Management Protocol (SNMP) ocorra. O CMP/RARP é uma variação do RARP. Adiciona e remove o Switches de um conjunto, ajusta parâmetros do conjunto, e notifica o comando switch de conflitos de endereço CMP.

A seção debug cluster ip deste documento explica melhor o CMP com a ajuda dos comandos debug.

Uma comunicação dentro de um conjunto ICC do interruptor

Uma comunicação dentro de um conjunto usa endereços CMP; O ICC transporta-a. Toda a comunicação externo ao conjunto usa endereços IP de Um ou Mais Servidores Cisco ICM NT e o mecanismo de transporte TCP/IP. Para uma comunicação de um dispositivo CMP-endereçado a um dispositivo IP-endereçado externo, o comando switch atua como um proxy e executa a tradução entre os protocolos CMP e TCP/IP.

Como as menções da seção do protocolo cluster management, o comando switch atribuem os endereços IP de Um ou Mais Servidores Cisco ICM NT chamados endereços CMP a todo o Switches dentro de um conjunto. Quando o Gerenciamento PC usa o comando switch ip address alcançar os switch membros, o comando switch usa os endereços CMP para reorientar o tráfego.

Por exemplo, na criação de um conjunto, o comando switch controla a troca das mensagens entre switch membros e um aplicativo de SNMP. O software do gerenciamento de grânulos adiciona o número de switch membro (o @esN, em que N é o número do switch) à primeira leitura/gravação (RW) configurada e os string de comunidade (RO) de leitura apenas no comando switch. Propaga-os então ao switch membro. O comando switch usa os string de comunidade para controlar o dianteiro do GET-pedido, do set-request, e das mensagens do GET-seguinte-pedido entre a estação do gerenciamento de SNMP e os switch membros.

Quando você controla um switch membro dentro de um conjunto com o uso do CMS ou do SNMP, a estação de gerenciamento envia requisições de gerenciamento ao comando switch ip address. Os pedidos vão ao comando switch porque um switch membro tipicamente não tem um endereço IP de Um ou Mais Servidores Cisco ICM NT. O pedido inclui um qualificador (o esN, em que N é o número do switch). O qualificador informa o switch de comando do membro ao qual a requisição está finalmente destinada. O comando switch altera o pedido tais que o pedido parece ter vindo do comando switch. Ele então para a frente o pedido ao switch membro apropriado. O switch membro recebe a requisição de gerenciamento e executa o comando localmente. Desde que o switch membro “pensa” que os pacotes de gerenciamento vieram do comando switch, os reconhecimentos vão diretamente ao comando switch. Finalmente, o comando switch altera os reconhecimentos e envia-os novamente à estação de gerenciamento.

Este fluxograma demonstra como o redirecionamento SNMP funciona:

/image/gif/paws/4085/61-a.gif

Para uns detalhes mais adicionais no gerenciamento de SNMP nos Series Switch XL, refira os documentos alistados aqui:

Configurar a aglomeração

Esta seção descreve procedimentos passo a passo para configurar a aglomeração no catalizador 2900XL/3500XL, 2940, 2950, 2955, 2970, 3550, 3560, e 3750 Switch com uso do CMS. O desenvolvimento e o teste das configurações nesta seção ocorreram com estes versão de software e hardware:

Versões de software

  • Software Cisco IOS versão 12.0(5.2)XU 3500XL (3500XL-C3H2S-M), software temporário de manutenção

  • (2900XL-C3H2S-M) Cisco IOS Software Release 12.0(5.2)XU 2900XL, software de temporário de manutenção

  • 2900XL (2900XL-HS-M) Cisco IOS Software Release 11.2(8.6)SA6, software temporário de manutenção

Versões de hardware

  • Processador de Cisco WS-C3524XL (PowerPC403) (Revision 0x01) com 8192 KB/1024 KB da memória

  • Processador de Cisco WS-C3512XL (PowerPC403) (Revision 0x01) com 8192 KB/1024 KB da memória

  • Processador de Cisco WS-C2924MXL (PowerPC403GA) (Revision 0x11) com 8192 KB/1024 KB da memória

  • Processador de Cisco WS-C2916MXL (PowerPC403GA) (Revision 0x11) com 4096 KB/640 KB da memória

Cenários de laboratório

Diagrama 1

/image/gif/paws/4085/61-b.gif

Diagrama 2

/image/gif/paws/4085/61-c.gif

Diagrama 3: Topologia estrela

/image/gif/paws/4085/61-d.gif

Diagrama 4: Topologia da interligação de equipamentos em cascata

61-e.gif

Crie conjuntos com o Cluster Management Suite

Esta seção descreve o procedimento passo-a-passo para criar um cluster simples com o uso de CMS. Os exemplos de configuração e a saída nestas etapas usam 3500XL e 2900XL Series Switch. Contudo, você pode substituir outros switch de configuração fixa que apoiam a aglomeração CMS. Também, a interface do utilizador de algum Switches pode parecer diferente do que os indicadores que você vê nesta seção. (Veja figura 1 e as imagens que seguem figura 1.) esta diferença depende da versão de código que você instalou no interruptor.

A maneira a mais fácil de configurar um conjunto é através da interface da WEB. Contudo, você deve conhecer o que está indo “atrás das cenas”. Esta seção fornece os indicadores que mostram a configuração de grânulos da Web assim como as mudanças às configurações no Switches que resulta.

Esta seção também utiliza um exemplo para explicar o procedimento de criação de agrupamentos com o uso de CMS. No exemplo, você prendeu junto quatro Switches com uso do gigabit e das portas de Ethernet rápidas. Inicialmente, você cria um conjunto com o um comando switch e os dois switch membros. Mais tarde, você adiciona um outro interruptor no conjunto, que demonstra como adicionar um membro novo.

Nota: Este documento não mostra como configurar o ^cluster com a CLI (interface de linha de comando). Para obter mais informações sobre do CLI, refira as seções de configuração de CLI da criação e controlando conjuntos.

A aplicação das configurações neste documento ocorreu em um ambiente de laboratório isolado, como você vê no diagrama 1 e o diagrama 2. fosse certo que você compreende o impacto potencial de toda a configuração ou comando em sua rede antes que você a use. A emissão do comando write erase limpou as configurações em todos os dispositivos e assegurou que eles tivessem uma configuração padrão.

Nota: Este documento supõe que você pode alcançar o CLI no Switches com uso da porta de Console. Para detalhes em como alcançar um XL switch com a porta de Console, refira o acesso do interruptor usando a seção da porta de Console do software em upgrade nos Catalyst 2900XL/3500XL Switch usando a interface da linha de comando.

  1. Certifique-se de todo o Switches tenha uma versão do código do comando either ou do switch membro que tem o apoio do conjunto.

    Este é sempre o argumento para 2940, 2950, 2970, 3550, 3560, e 3750 Series Switch porque todas as versões de código apoiam a aglomeração.

    Para detalhes nas versões de software e no Switches que apoiam a aglomeração, veja os modelos de Catalyst switch com seção das potencialidades de grânulos deste documento. Para determinar se seu interruptor 2900XL/3500XL executa o software capaz de cluster, emita o comando show version do nível de usuário no interruptor.

    Por exemplo, um 2900XL ou 3500XL Series Switch que execute o software do comando e o capacitado para membro fornece esta saída do comando show version:

    Switch> show version
    Cisco Internetwork Operating System Software
    IOS (TM) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.2)XU, 
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 17-Jul-00 18:29 by ayounes
    Image text-base: 0x00003000, data-base: 0x00301F3C
    
    ROM: Bootstrap program is C3500XL boot loader
    
    Switch uptime is 3 days, 1 hour, 45 minutes
    System returned to ROM by reload
    System image file is "flash:c3500XL-c3h2s-mz-120.5.2-XU.bin"
    
    
    cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K 
    bytes of memory.
    Processor board ID , with hardware revision 0x00
    Last reset from warm-reset
    
    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)
    
    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:D0:58:68:F1:80
    Configuration register is 0xF
    

    Nota: Nesta saída, em interruptor do comando cluster capazes e do interruptor do membro de grânulos mostra capaz que o interruptor executa atualmente um software que seja comando e capacitado para membro. Se o interruptor executa somente o software capacitado para membro, a seguir somente o interruptor do membro de grânulos capaz aparece na saída. Você pode igualmente configurar um interruptor que execute o software comando-capaz como um switch membro; contudo, você pode nunca configurar um interruptor que execute somente o software capacitado para membro como um comando switch.

  2. Se você encontra em etapa 1 que o interruptor não executa o software capaz de cluster, promova o interruptor ao software correto.

    Uma vez que o interruptor executa a imagem capaz de cluster, continue a etapa 3.

  3. Cabografe o Switches de modo que o comando switch possa descobrir os switch de candidato que são capazes da adição ao conjunto.

    Com uso do CDPv2, o comando switch pode automaticamente descobrir o Switches nas topologias da estrela ou da interligação de equipamentos em cascata que são até três dispositivos conjunto-permitidos (três saltos) longe da borda do conjunto. Com código do Cisco IOS Software Release 12.0(5)XU, ou mais tarde, você pode configurar o comando switch descobrir o Switches que é até sete dispositivos conjunto-permitidos (sete saltos) afastado.

    Emita este comando no comando switch se você quer permitir a descoberta do switch de candidato que é até sete saltos afastado:

    Switch(config)# cluster discovery hop-count 7
    

    Se um interruptor apoia o CDP mas não apoia a aglomeração, e conecta ao comando switch, o conjunto é incapaz de descobrir os candidatos que lhe anexam. Por exemplo, o construtor de grânulos não pode criar um conjunto que inclua os candidatos que conectam a um Catalyst 5500/5000 ou o 6500/6000 Series comuta que conecta ao comando switch.

    Também, seja certo que você conecta todo o Switches com aquelas portas que estão no mesmo VLAN de gerenciamento. O acesso a todas as facilidades de gerenciamento de grânulos é através do comando switch ip address. O comando switch IP address pertence sempre pertence ao VLAN de gerenciamento (VLAN1, por padrão). Todo o Switches dentro do conjunto do interruptor deve ter o mesmo VLAN de gerenciamento que o comando switch.

    Nota: Até à data do Cisco IOS Software Release 12.0(5)XP para os 2900XL e 3500XL Switch, você pode mudar o VLAN de gerenciamento do padrão (VLAN1). Além, o Cisco IOS Software Release 12.0(5)XU ou Mais Recente permite que você mude o VLAN de gerenciamento para o conjunto inteiro do interruptor. A alteração requer um único comando via interface de Web de CMS. Para detalhes em como mudar o VLAN de gerenciamento, refira estes documentos:

    Este exemplo configura o switch central (3524XL) como o comando switch. (Veja o diagrama 1.)

  4. Após a determinação do comando switch, atribua um endereço IP de Um ou Mais Servidores Cisco ICM NT.

    O IP Address da opção de comando nesse exemplo é 172.16.84.35. Use estes comandos executar a configuração inicial no comando switch:

    Switch> enable
    Switch# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# enable password mysecret
    Switch(config)# interface vlan1
    Switch(config-if)# ip address 172.16.84.35 255.255.255.0
    Switch(config-if)# exit
    Switch(config)# ip default-gateway 172.16.84.1
    Switch(config)# ip http server(Enabling web access to the switch)
    Switch(config)# end
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    Switch# write memory
    Building configuration...
    [OK]
    

    Nota: Esta é uma configuração inicial que você deva configurar no interruptor para o alcançar com a Web. A configuração de grânulos não ocorreu neste momento. Se você emite o comando show running-config no interruptor, você não observa a adição de nenhuns comandos cluster no arquivo de configuração.

  5. Para começar a interface da WEB, inscreva o comando switch ip address em sua janela de navegador.

    Use esta sintaxe para incorporar o endereço IP de Um ou Mais Servidores Cisco ICM NT:

    http://x.x.x.x
    
    

    Nota: A variável x.x.x.x é o endereço IP do comando switch.

    Pode haver uma solicitação de login e senha. Utilize a senha de ativação como seu login e senha. Neste exemplo, o mysecret é a senha da possibilidade. Depois que você incorpora o início de uma sessão e a senha, você vê a página de acesso Cisco, como você vê em figura 1. Se você tem o problema com acesso do interruptor quando você usa o navegador da Web, refira pesquisando defeitos o Cisco Visual Switch Manager ou o acesso ao conjunto de gerenciamento de grupos no Catalyst 2900XL/3500XL/2950/3550 switch.

    Figura 1

    /image/gif/paws/4085/61-f.gif

    Nota: Umas versões de software mais atrasadas usam uma página de acesso Cisco como esta:

    Figura 2

    /image/gif/paws/4085/61-g.gif

  6. Cluster Management Suite ou Visual Switch Manager do clique na página de acesso Cisco.

    Isso cria a tela de logotipo do Visual Switch Manager, como você vê na Figura 3. A home page do Switch Manager, como você verá na Figura 4, é carregada.

    Nota: Ao acessar o enlace do Cluster Management Suite ou do Visual Switch Manager na página de acesso da Cisco, aparece a tela de logotipo do Visual Switch Manager primeiro. Com a ativação de clusters, você exibe a tela Cluster Management Suite depois da tela de logotipo do Visual Switch Manager (em vez da Figura 4).

    Figura 3

    /image/gif/paws/4085/61-h.gif

    Figura 4

    /image/gif/paws/4085/61-i.gif

    Nota: Se você tem a dificuldade com acesso ao Home Page do interruptor que você vê em figura 4, refira pesquisando defeitos o Cisco Visual Switch Manager ou o acesso ao conjunto de gerenciamento de grupos no Catalyst 2900XL/3500XL/2950/3550 switch para pesquisar defeitos o problema.

    Até este ponto, nenhuma configuração de cluster foi efetuada. Consequentemente, não há nenhuma mudança na configuração de algum do Switches que se relaciona à aglomeração. Nas etapas que seguem, você adiciona comandos cluster nos arquivos de configuração. O procedimento discute cada comando.

  7. Da barra de menus, escolha a configuração do conjunto > do comando cluster.

    Isso abre a janela Cluster Configuration, como na Figura 5.

    Figura 5

    /image/gif/paws/4085/61-j.gif

  8. O no campo de estado do comando switch, escolha permitem.

  9. Digite um nome no campo Nome do Cluster.

    Você pode usar até 31 caracteres para nomear o cluster. Este exemplo usa "engenharia" como o nome do cluster:

    Figura 6

    /image/gif/paws/4085/61-k.gif

  10. Clique em OK.

    Isto permite a aglomeração no switch central e faz-lhe um comando switch. Ao clicar em OK, você observa a adição de informações de cluster na tela, conforme visto na Figura 7.

    O Endereço IP de Comando e o Nome de Agrupamento agora estão visíveis. Esta tela também possui o nome Cluster Management Suite.

    Figura 7

    /image/gif/paws/4085/61-l.gif

    Neste momento, a atualização da configuração do switch central (3524XL) ocorreu com os comandos que aparecem em corajoso:

    !
    hostname Switch
    !
    enable password mysecret
    !
    ip subnet-zero
    cluster enable engineering 0
    !
    !
    !
    interface VLAN1
    ip address 172.16.84.35 255.255.255.0
    no ip directed-broadcast
    ip nat outside
    !
    !
    ip default-gateway 172.16.84.1
    ip Nat inside source list 199 interface VLAN1 overload
    access-list 199 dynamic Cluster-NAT permit ip any any
    
    !--- Full configuration output is suppressed.
    
    
    

    Ao emitir o comando cluster enable engineering, você habilita a funcionalidade de Switch do comando com o nome de cluster "engineering". Os comandos network address translation (nat) têm a adição automática ao arquivo de configuração do comando switch. Não remova estes comandos porque os comandos alcançam os switch membros. Quando o comando switch controla um switch membro através da interface da WEB, o comando switch atua como um proxy e para a frente o HTTP e a Java chamam ao switch membro. O comando switch usa os endereços internos virtuais NAT (igualmente conhecidos como endereços CMP) para executar esta ação. Para detalhes em como o CMP trabalha, veja a seção do protocolo cluster management deste documento.

  11. Escolha o conjunto > o gerenciamento de grânulos.

    Um indicador novo do gerenciamento de grânulos abre. O indicador mostra o construtor de grânulos (mapa do Switches). Dentro deste indicador, o indicador sugerido do candidato aparece, como você vê em figura 8. Você pode mover ou minimizar o indicador sugerido do candidato para ver claramente o indicador do construtor de grânulos (mapa). O mapa mostra o comando e o switch de candidato.

    O construtor de grânulos usa o CDP para descobrir os switch de candidato que são capazes da adição a um conjunto. Com CDP, o comando switch pode automaticamente descobrir o Switches nas topologias da estrela ou da interligação de equipamentos em cascata que são até três dispositivos conjunto-permitidos (três saltos) longe da borda do conjunto. (Veja etapa 3 desta seção.) Com código do Cisco IOS Software Release 12.0(5)XU, ou mais tarde, você pode configurar o comando switch descobrir o Switches que é até sete dispositivos conjunto-permitidos (sete saltos) afastado.

    Nota: No indicador sugerido do candidato, a mostra sugeriu candidatos cada vez que a caixa de verificação dos começos do construtor de grânulos é verificada. Segundo esta seleção, você pode ou não pode ver o indicador sugerido do candidato, que é permitido à revelia.

    Figura 8

    /image/gif/paws/4085/61-m.gif

    Nota: Há somente um switch de candidato que aparece no mapa. O comando switch aparece no verde, e o switch de candidato aparece no azul. Os switches aparecem dessa maneira porque há dois switches que possuem o nome de host padrão Switch. Neste tempo, nenhuns dos switch de candidato que aparecem no azul foram adicionados no conjunto. A gerente de cluster indicou somente um interruptor na figura 8 diagrama de topologia quando há realmente dois.

    Você pode ver o número correto de switch de candidato no indicador sugerido do candidato, como você vê em figura 8. Você pode igualmente usar o CLI para verificar o número correto de switch de candidato que têm o potencial ser um switch membro. Por exemplo:

    Switch# show cluster candidates
                                                                 |---Upstream---|
    MAC Address      Name    Device Type    PortIf  FEC  Hops  SN    PortIf   FEC
    00e0.1e9f.50c0   Switch  WS-C2916M-XL   Fa0/1          1    0     Fa0/2
    00d0.5868.eb80   Switch  WS-C3512-XL    Gi0/2          1    0     Gi0/1
    
    
  12. Clique a APROVAÇÃO no indicador sugerido do candidato, e espere aproximadamente 30 segundos.

    Você vê esta tela, que mostra o número correto de switch membros e do comando switch:

    Figura 9

    /image/gif/paws/4085/61-n.gif

    Neste diagrama, o interruptor do switch central é o comando switch. O Switch 1 e o switch 2 são os switch membros. Agora, todo o Switches é verde, que mostra que está no conjunto com o nome “engenharia”.

    Você pode verificar este conjunto se você emite estes comandos no comando e nos switch membros:

    • Comando switch (switch central, 3524XL):

      Switch# show cluster
      Command switch for cluster "engineering"
           Total number of members:                3
           Status:                                 0 members are unreachable
           Time since last status change:          0 days, 0 hours, 7 minutes
           Redundancy:                             Disabled
           Heartbeat interval:                     8
           Heartbeat hold-time:                    80
           Extended discovery hop count:           3
      
      Switch# show cluster members
                                                               |---Upstream---|
      SN   MAC Address      Name      PortIf   FEC   Hops  SN  PortIf  FEC  State
      0    00d0.5868.f180   Switch                     0                    Up (Cmdr)
      1    00e0.1e9f.50c0   Switch-1   Fa0/1           1    0  Fa0/2        Up
      2    00d0.5868.eb80   Switch-2   Gi0/2           1    0  Gi0/1        Up
      
      Switch# show cluster view
                                                                 |---Upstream---|
      SN   MAC Address      Name       Device Type    PortIf FEC Hops  SN PortIf  FEC
      0    00d0.5868.f180   Switch     WS-C3524-XL                0
      1    00e0.1e9f.50c0   Switch-1   WS-C2916M-XL   Fa0/1       1     0   Fa0/2
      2    00d0.5868.eb80   Switch-2   WS-C3512-XL    Gi0/2       1     0   Gi0/1
      

      As mudanças que ocorrem no arquivo de configuração do comando switch depois que você executa etapa 12 aparecem aqui em corajoso:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      
      

      Nota: Quando um switch candidato torna-se um switch membro, o comando switch configuration adiciona o MAC Address do switch membro. Também, a configuração de switch membro adiciona o comando switch mac address.

    • Switch 1 do membro (switch inferior, 2916MXL)

      Switch-1# show cluster
      Cluster member 1
      Cluster name: engineering
      Management ip address: 172.16.84.35
      Command device Mac address: 00d0.5868.f180
      Switch-1#

      O endereço IP de gerenciamento é o endereço IP de Um ou Mais Servidores Cisco ICM NT do comando switch. Isto define o conceito da aglomeração, que é o Gerenciamento de um grupo de Switches com uso de um único endereço IP de Um ou Mais Servidores Cisco ICM NT.

      Também, se você tem a conexão de console ao Switch 1 do membro, esta mensagem aparece no console do switch membro assim que o conjunto adicionar o interruptor:

      Switch#
      %CMP-CLUSTER_MEMBER_1-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-1#

      As mudanças que ocorrem no arquivo de configuração do comando switch depois que você executa etapa 12 aparecem aqui em corajoso:

      !
      hostname Switch-1
      !
      enable password mysecret
      !
      !
      no spanning-tree vlan 1
      no ip domain-lookup
      !
      cluster commander-address 00d0.5868.f180
      
      !--- You may also see the member number and cluster name in the
      !--- above line. This depends on the version of code that you use.
      
      !
      interface VLAN1
      no ip address
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
      
    • Switch 2 do membro (interruptor superior, 3512XL)

      Switch-2# show cluster
      Member switch for cluster "engineering"
             Member number:                                2
             Management IP address:                        172.16.84.35
             Command switch Mac address:                   00d0.5868.f180
             Heartbeat interval:                           8
             Heartbeat hold-time:                          80
      Switch-2#

      O endereço IP de gerenciamento é o endereço IP de Um ou Mais Servidores Cisco ICM NT do comando switch.

      Também, se você tem a conexão de console ao switch 2 do membro, esta mensagem aparece no console do switch membro assim que o conjunto adicionar o interruptor:

      Switch#
      %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
      (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
      Switch-2#

      As mudanças que ocorrem no arquivo de configuração do comando switch depois que você executa etapa 12 aparecem aqui em corajoso:

      !
      hostname Switch-2
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 2 name engineering
      
      !--- If you run an older version of code, you may not see
      !--- the member number and cluster name in the above line.
      
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      

      Se você vê as saídas do Switch 1 do membro e das configurações do switch 2 do membro, você observa a herança pelos switch membros da senha da possibilidade e do nome de host, adicionados com um número de comando switch.

      Se um nome de host não foi atribuído previamente ao switch membro (como neste exemplo), o comando switch adiciona um número original do membro ao nome de host do comando switch; o comando switch atribui então o número sequencialmente ao interruptor quando o interruptor se junta ao conjunto. O número indica a ordem em que o interruptor se juntou ao conjunto. Neste exemplo, o comando switch tem o interruptor do nome de host do padrão. O primeiro switch membro (WS-C2916MXL) toma o Switch 1 do nome de host. O segundo switch membro (WS-C3512XL) toma o switch 2 do nome de host.

      Nota: Se o switch membro já tem um nome de host, o interruptor retém esse nome de host quando se junta ao conjunto. Se o switch membro sae do conjunto, o nome de host permanece.

      O Member Switch também herda o comando switch enable secret ou enable password quando o switch entra no cluster. Retém a senha quando sae do conjunto também. Se você não configurou uma senha do comando switch, o switch membro herda uma senha nula.

  13. Escolha as etiquetas das vistas > do pino de madeira para ver uma informação de cluster mais detalhada.

    A janela exibe estas informações adicionais:

    • MAC address dos switch membros

    • Endereço IP de Um ou Mais Servidores Cisco ICM NT do comando switch

    • Números de porta e tipo de enlaces (enlaces Fast Ethernet ou Gigabit Ethernet)

    Figura 10

    /image/gif/paws/4085/61-o.gif

  14. Para ver uma imagem de todo o Switches no conjunto, escolha o conjunto > vão à gerente de cluster.

    A gerente de cluster aparece. Indica uma ideia do Switches em um formulário do conjunto:

    Figura 11

    /image/gif/paws/4085/61-p.gif

    Você pode usar o Cluster Manager para gerenciar e configurar alterações em um cluster. Você pode usá-lo para monitorar e configurar portas, alterar a VLAN de gerenciamento e o nome de host. O gerenciamento de grânulos e como executar tarefas de configuração diferentes com a gerente de cluster é além do alcance deste documento, contudo. Para estes detalhes, refira os documentos:

Adicionar um membro em um conjunto existente

Esta seção descreve como adicionar um switch membro a um conjunto que já exista. O exemplo adiciona um Catalyst 2924MXL Switch no conjunto, como você vê na figura 10.

Termine estas etapas para adicionar um outro membro no conjunto com CMS:

  1. Conecte o interruptor que você quer adicionar a uma das portas no comando ou no switch membro.

    Na seção dos cenários de laboratório deste documento, o interruptor novo conecta aos FastEthernet 0/2 de relação do comando switch. Seja certo que as portas que conectam os dois Switches pertencem ao mesmo VLAN de gerenciamento ou que as portas são portas de tronco. Igualmente nos cenários de laboratório, todas as portas pertencem ao VLAN1, que é o VLAN de gerenciamento à revelia.

    Nota: O acesso a todas as facilidades de gerenciamento de grânulos é através do comando switch ip address. O comando switch IP address pertence sempre pertence ao VLAN de gerenciamento (VLAN1, por padrão). Todo o Switches dentro do conjunto do interruptor deve ter o mesmo VLAN de gerenciamento que o comando switch. Até à data do Cisco IOS Software Release 12.0(5)XP para os 2900XL e 3500XL Switch, você pode mudar o VLAN de gerenciamento do padrão do VLAN1. Além, o Cisco IOS Software Release 12.0(5)XU ou Mais Recente permite que você mude o VLAN de gerenciamento para o conjunto inteiro do interruptor. A alteração requer um único comando via interface de Web de CMS. Para detalhes em como mudar o VLAN de gerenciamento, refira estes documentos:

  2. Em seu navegador, escolha o conjunto > o gerenciamento de grânulos.

    A ação abre o Construtor de Grânulos em uma nova janela do navegador e exibe esta tela:

    Figura 12

    61-q.gif

    Você pode ver que o indicador sugerido do candidato alista o interruptor novo (2924MXL) como um switch de candidato. Figura 12 igualmente mostra que há um interruptor novo, no azul. O novo switch se conecta ao switch central (comando switch). Quando este switch de candidato assenta bem em um membro do conjunto, a cor muda para esverdear, e o interruptor é alistado como o Switch 3.

  3. Para adicionar o switch de candidato ao conjunto e atualizar o mapa de rede, execute uma destas etapas:

    • Clique a APROVAÇÃO no indicador sugerido do candidato e espere por alguns segundos.

      Isto mostra uma atualização do mapa de rede com o interruptor novo, Switch 3.

    • Ou, clique o switch de candidato, como você vê em figura 13, e escolha-o então adicionam para aglomerar-se.

    Figura 13

    /image/gif/paws/4085/61-r.gif

    Figura 14

    /image/gif/paws/4085/61-s.gif

  4. Escolha as vistas > as etiquetas do pino de madeira para ver mais detalhes no mapa de rede.

    Figura 15

    /image/gif/paws/4085/61-t.gif

    Se você quer verificar este conjunto, emita estes comandos no comando switch e no switch membro novo, Switch 3:

    • Comando switch (switch central, 3524XL)

      Switch# show cluster
      Command switch for cluster "engineering"
            Total number of members:            4   
            Status:                             0 members are unreachable
            Time since last status change:      0 days, 0 hours, 7 minutes
            Redundancy:                         Disabled
            Heartbeat interval:                 8
            Heartbeat hold-time:                80
            Extended discovery hop count:       3
      
      Switch# show cluster members
                                                        |---Upstream---|
      SN  MAC Address      Name     PortIf   FEC  Hops SN PortIf FEC  State
      0   00d0.5868.f180   Switch                   0                 Up (Cmdr)
      1   00e0.1e9f.50c0   Switch-1 Fa0/1           1   0  Fa0/2      Up
      2   00d0.5868.eb80   Switch-2 Gi0/2           1   0  Gi0/1      Up
      3   00ee.1e9f.50c0   Switch-3 Fa0/1           1   0  Fa0/3      Up
      
      Switch# show cluster view
                                                               |---Upstream---|
      SN  MAC Address       Name      Device Type   PortIf  FEC Hops SN  PortIf FEC
      0   00d0.5868.f180    Switch    WS-C3524-XL                0 
      1   00e0.1e9f.50c0    Switch-1  WS-C2916M-XL  Fa0/1        1   0    Fa0/2
      2   0d0.5868.eb80     Switch-2  WS-C3512-XL   Gi0/2        1   0    Gi0/1
      3   00ee.1e9f.50c0    Switch-3  WS-C2924M-XL  Fa0/1        1   0    Fa0/3
      

      As mudanças que ocorrem no arquivo de configuração do comando switch depois que você executa etapa 4 aparecem aqui em corajoso:

      !
      ip subnet-zero
      cluster enable engineering 0
      cluster member 1 Mac-address 00e0.1e9f.50c0
      cluster member 2 Mac-address 00d0.5868.eb80
      cluster member 3 Mac-address 00ee.1e9f.50c0
      !
      !
      !
      
      !--- Full configuration output is suppressed.
      
      

      Nota: Quando um switch candidato torna-se um switch membro, o comando switch configuration adiciona o MAC Address do switch membro. Também, a configuração de switch membro adiciona o comando switch mac address.

    • Switch 3 do membro (2924MXL)

      Switch-3# show cluster
      Member switch for cluster "engineering"
         Member number:     3
         Management IP address:     172.16.84.35
         Command switch Mac address:     00d0.5868.f180
         Heartbeat interval:     8
         Heartbeat hold-time:     80
      Switch-3#
      

      O endereço IP de gerenciamento é o endereço IP de Um ou Mais Servidores Cisco ICM NT do comando switch.

      As mudanças que ocorrem no arquivo de configuração do comando switch depois que você executa etapa 4 aparecem aqui em corajoso:

      !
      hostname Switch-3
      !
      enable password mysecret
      !
      !
      ip subnet-zero
      !
      cluster commander-address 00d0.5868.f180 member 3 name engineering
      !
      interface VLAN1
      no ip address
      no ip directed-broadcast
      no ip route-cache
      
      !--- Full configuration output is suppressed.
      
      
  5. Escolha o conjunto > vão à gerente de cluster.

    A gerente de cluster aparece, como você vê em figura 16. Esta vista é atualizada de figura 11 e mostra o interruptor recentemente adicionado (2924MXL) na lista:

    Figura 16

    61-u.gif

comandos debug e show

Exemplo de saída do comando show

show cluster e show cluster members

Utilize os comandos show cluster e show cluster members para verificar o status do cluster e os membros.

  • Comando switch (switch central, 3524XL)

    Switch# show cluster
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         0 members are unreachable
            Time since last status change:  0 days, 0 hours, 7 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    
    
    Switch# show cluster members 
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2     Gi0/2       1     0  Gi0/1       Up
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Se um dos switch membros perde a Conectividade ao comando switch, a saída dos comandos show cluster e show cluster members reflete a perda.

    Por exemplo, se o switch 2 do membro perde a Conectividade ao comando switch, a saída destes comandos é:

    Switch# show cluster       
    Command switch for cluster "engineering"
            Total number of members:        4
            Status:                         1 members are unreachable
            Time since last status change:  0 days, 0 hours, 0 minutes
            Redundancy:                     Disabled
            Heartbeat interval:             8
            Heartbeat hold-time:            80
            Extended discovery hop count:   3
    Switch#
    
    Switch# show cluster member
                                                    |---Upstream---|
    SN MAC Address    Name         PortIf FEC Hops   SN PortIf  FEC  State
    0  00d0.5868.f180 Switch                   0                    Up   (Cmdr)
    1  00e0.1e9f.50c0 Switch-1     Fa0/1       1     0  Fa0/2       Up  
    2  00d0.5868.eb80 Switch-2                 1                    Down
    3  00ee.1e9f.50c0 Switch-3     Fa0/1       1     0  Fa0/3       Up
    
    

    Nota: Você não observa imediatamente as alterações refletidas por esses comandos. O comando switch tem que esperar um determinado intervalo (hold-time da pulsação do coração) antes que o comando switch declare um switch membro para baixo. À revelia, o tempo de espera de heartbeat é 80 segundos. Este é um parâmetro configurável. Você pode alterar o parâmetro emitindo o comando cluster holdtime 1-300 no modo de configuração global.

  • Switch 1 do membro (2916MXL)

    Switch-1# show cluster
    Cluster member 1
    Cluster name: engineering
    Management ip address: 172.16.84.35
    Command device Mac address: 00d0.5868.f180
    Switch-1#
  • Switch 2 do membro (interruptor superior, 3512XL)

    Switch-2# show cluster 
    Member switch for cluster "engineering"
            Member number:                  2
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-2#
  • Switch 3 do membro (2924MXL)

    Switch-3# show cluster
    Member switch for cluster "engineering"
            Member number:                  3
            Management IP address:          172.16.84.35
            Command switch Mac address:     00d0.5868.f180
            Heartbeat interval:             8
            Heartbeat hold-time:            80
    Switch-3#

show cdp neighbors and show cdp neighbors detail

Como discutido na seção das características do switch de candidato e do switch membro deste documento, todo o Switches, incluindo o comando switch, usa o CDPv2 para descobrir os vizinhos de CDP. O Switches armazena esta informação no cache de CDP de vizinho respectivo. Quando o comando switch recebe a informação, o interruptor filtra os caches vizinho de CDP e cria uma lista de switch de candidato.

Use os comandos show cdp neighbors e show cdp neighbors detail verificar que o Switches está no cache vizinho de CDP e que todo o Switches executa atualmente o CDPv2.

  • Comando switch (3524XL)

    Switch# show cdp neighbors
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch-3         Fas 0/3            162         T S       WS-C2924M-Fas 0/1
    Switch-2         Gig 0/1            121         T S       WS-C3512-XGig 0/2
    Switch-1         Fas 0/2            136          S        WS-C2916M-Fas 0/1
    
    
    Switch# show cdp neighbors detail
    -------------------------
    Device ID: Switch-3
    Entry address(es):
    Platform: cisco WS-C2924M-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/3, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 132 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=25,
    value=0AA050C000000003010103FF00D05868F18000EE1E9F50C001
    VTP Management Domain: ''
    
    -------------------------
    Device ID: Switch-2
    Entry address(Es):
          IP address: 0.0.0.0
          IP address: 172.16.84.35
    Platform: cisco WS-C3512-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/1, Port ID (outgoing port): GigabitEthernet0/2
    Holdtime : 141 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68EB8000000002010123FF00D05868F18000D05868EB80010001
    VTP Management Domain: ''
    Duplex: full
    
    -------------------------
    Device ID: Switch-1
    Entry address(Es):
          IP address: 172.16.84.35
    Platform: cisco WS-C2916M-XL, Capabilities: Switch
    Interface: FastEthernet0/2, Port ID (outgoing port): FastEthernet0/1
    Holdtime : 140 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=25,
    value=0A9F50C000000001010103FF00D05868F18000E01E9F50C001
    VTP Management Domain: ''
    
  • Switch 1 do membro (2916MXL)

    Switch-1# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1           139         T S       WS-C3524-XFas 0/2
    
    Switch-1# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/2
    Holdtime : 147 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    
  • Switch 2 do membro (3512XL)

    Switch-2# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Gig 0/2            147         T S       WS-C3524-XGig 0/1
    
    
    Switch-2# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: GigabitEthernet0/2, Port ID (outgoing port): GigabitEthernet0/1
    Holdtime : 141 sec
    
    
    !--- Output suppressed.
    
    advertisement version: 2 
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27, 
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001 
    VTP Management Domain: '' Duplex: full 
  • Switch 3 do membro (2924MXL)

    Switch-3# show cdp neighbors 
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    Switch           Fas 0/1            125         T S       WS-C3524-XFas 0/3
    
    
    Switch-3# show cdp neighbors detail
    -------------------------
    Device ID: Switch
    Entry address(Es):
          IP address: 172.16.84.35
          IP address: 172.16.84.35
    Platform: cisco WS-C3524-XL, Capabilities: Trans-Bridge Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/3
    Holdtime : 179 sec
    
    !--- Output suppressed.
    
    
    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload Len=27,
    value=0A68F18000000000010123FF00D05868F18000D05868F180000001
    VTP Management Domain: ''
    

Nota: Se você não vê a versão de anúncio: 2 no comando show cdp neighbors detail output para um interruptor, esse interruptor não podem transformar-se um switch membro.

Exemplo de saída do comando debug

Esta seção discute os comandos de depuração que verificam a atividade do cluster. Aqui, os comandos verify a atividade de cluster entre o comando switch (3524XL) e o switch 2 do membro (3512XL). Você pode usar os mesmos comandos debug verificar a atividade de cluster entre o comando switch e algum dos switch membros.

Nota: Sempre que houver uma adição ou remoção de um membro com o uso da Interface Web, você verá o registro dessas informações:

%CMP-CLUSTER_MEMBER_2-5-REMOVE:
The Device is removed from the cluster (Cluster Name: engineering)

%CMP-CLUSTER_MEMBER_2-5-ADD:
The Device is added to the cluster(Cluster Name: engineering, 
CMDR IP Address 172.16.84.35)

debug cluster member, debug cluster neighbors e debug cluster events

Os dois primeiros comandos debug nesses exemplos, debug cluster member e debug cluster neighbor, mostram as atualizações dos vizinhos do cluster de saída a partir de um switch de comando ou de membro. O comando third debug, debug cluster events, mostra hellos vizinhos entrantes. Entre os comandos, os comentários no azul aumentam a visibilidade de determinadas saídas. Também, este indicador suprime a informação desnecessária do resultado do debug completo.

  • Comando switch (3524XL)

    Switch# debug cluster members 
    Cluster members debugging is on
    Switch#
    23:21:47: Sending neighbor update...
    23:21:47: 
    Cluster Member: 00, active.
    
    !--- Member 00 means commander switch.
    
    23:21:47:       Unanswered heartbeats: 1
    23:21:47:       Hops to commander:     0
    23:21:47:       Assigned CMP address:  10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Cmdr IP address:       172.16.84.35   
    23:21:47:       Cmdr CMP address:      10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:21:47:       Auto update counter:   0
    23:21:47:       Cmdr MAC address:      00d0.5868.f180
    23:21:47:       Mbr  MAC address:      00d0.5868.f180
    23:21:47:       Command Port ID:       
    23:21:47:       Platform Name:         cisco WS-C3524-XL
    23:21:47:       Host Name:             Switch
    
    Switch# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch#
    23:51:50:           Neighbor update from member 0
    
    !--- This is an update from the commander.
    
    23:51:50:           3 Cluster neighbors:
    
    !--- Information about member Switch-2 starts here.
    
    23:51:50:           00d0.5868.eb80 connected to Member 0 
                        on port GigabitEthernet0/2
    23:51:50:           Port Macaddr: 00d0.5868.eb8e
    23:51:50:           Hostname: Switch-2
    23:51:50:           Port ID: GigabitEthernet0/2
    23:51:50:           Neighbor FEC: 255
    23:51:50:           Member FEC: 255
    23:51:50:           Capabilities: 0A
    23:51:50:           Link Qualification: 0
    23:51:50:           Qualification Note: 21
    23:51:50:           Member 2 of stack with commander 0.104.187.140
    23:51:50:           CMP address: 10.104.235.128
    23:51:50:           Hops to Commander: 1
    23:51:50:           Management vlan: 1
    
    !--- Information about member Switch-2 ends here.
    
    
    
    !--- Information about member Switch-1 starts here.
    
    23:51:50:      00e0.1e9f.50c0 connected to Member 0 on port FastEthernet0/2
    23:51:50:      Port Macaddr: 00e0.1e9f.50c1
    23:51:50:      Hostname: Switch-1
    23:51:50:      Port ID: FastEthernet0/1
    23:51:50:      Neighbor FEC: 255
    23:51:50:      Member FEC: 255
    23:51:50:      Capabilities: 08
    23:51:50:      Link Qualification: 3
    23:51:50:      Qualification Note: 01
    23:51:50:      Member 1 of stack with commander 0.77.44.124
    23:51:50:      CMP address: 10.159.80.192
    23:51:50:      Hops to Commander: 1
    23:51:50:      Management vlan: 0
    
    !--- Information about member Switch-1 ends here.
    
    
    
    !--- Information about member Switch-3 starts here.
    
    23:51:50:       00ee.1e9f.50c0 connected to Member 0 on port FastEthernet0/3
    23:51:50:       Port Macaddr: 00ee.1e9f.50c1
    23:51:50:       Hostname: Switch-3
    23:51:50:       Port ID: FastEthernet0/1
    23:51:50:       Neighbor FEC: 255
    23:51:50:       Member FEC: 255
    23:51:50:       Capabilities: 0A
    23:51:50:       Link Qualification: 3
    23:51:50:       Qualification Note: 00
    23:51:50:       Member 3 of stack with commander 0.77.184.56
    23:51:50:       CMP address: 10.160.80.192
    23:51:50:       Hops to Commander: 1
    23:51:50:       Management vlan: 1
    
    !--- Information about member Switch-3 ends here.
    
    
    !--- The information that follows is from Switch-2, as seen on 
    !--- the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:52:00:           Sender Version: 1, Works with version 1 and later
    23:52:00:           Flags: 23, Number of hops to the commander: 1
    23:52:00:           Cluster member number: 2
    23:52:00:           Cluster Cmdr Mac Address: 00d0.5868.f180
    23:52:00:           Sender Mac address: 00d0.5868.eb80
    
    !--- This is the Switch-2 MAC address.
    
    
    23:52:00:           Sender CMP address: 10.104.235.128
    
    !--- This is the Switch-2 CMP address.
    
    23:52:00:           Upstream switch No: 0.0.0.0
    23:52:00:           FEC Number: 255
    23:52:00:           Management vlan: 1
    
    !--- Output suppressed.
    
    
  • Switch 2 do membro (3512XL)

    Switch-2# debug cluster member
    Cluster members debugging is on
    Switch-2#
    23:22:51:     Sending neighbor update...
    23:22:51:     Switch 00d0.5868.f180 connected on port GigabitEthernet0/2
    
    !--- This is the command switch MAC address local port.
    
    23:22:51:     Port ID: GigabitEthernet0/2
    23:22:51:     Capabilities: 0A
    23:22:51:     Link Qualification: 5
    23:22:51:     Qualification Note: 20
    23:22:51:     Member 0 of stack with commander 00d0.5868.f180
    23:22:51:     CMP address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:22:51:     Hops to Commander: 0
    23:22:51:     Management vlan: 1*
    23:22:51:
    
    !--- Up to this point, the information is about the command switch.
    !--- The output that follows is the local switch information that goes to the 
    !--- neighbor (command) switch.
    
    Cluster Member: 02, active.
    23:22:51:    Unanswered heartbeats: 1
    23:22:51:    Hops to commander: 1
    23:22:51:    Assigned CMP address: 10.104.235.128
    23:22:51:    Cmdr IP address: 172.16.84.35
    23:22:51:    Cmdr CMP address: 10.104.241.128
    23:22:51:    Auto update counter: 0
    23:22:51:    Cmdr MAC address: 00d0.5868.f180
    23:22:51:    Mbr MAC address: 00d0.5868.eb80
    23:22:51:    Command Port ID: GigabitEthernet0/2
    
    !--- This is the port that connects to the commander.
    
    23:22:51:    Platform Name: cisco WS-C3512-XL
    23:22:51:    Host Name: Switch-2
    Switch-2#
    
    Switch-2# debug cluster neighbors
    Cluster neighbors debugging is on
    Switch-2#
    23:59:32: cmi_setCommandPort: setting ups mbr num to 0
    23:59:32: cmp_sendNeighborsToCmdr: skip neighbor 00d0.5868.f180
    Switch-2#
    23:59:42:
    
    !--- Information that follows is from the command switch.
    !--- You can see the same information if you issue the
    !--- debug cluster events command on certain versions 
    !--- of codes.
    
    Cluster neighbor's Protocol Hello payload:
    23:59:42:    Sender Version: 1, Works with version 1 and later
    23:59:42:    Flags: 23, Number of hops to the commander: 0
    23:59:42:    Cluster member number: 0
    23:59:42:    Cluster Cmdr Mac Address: 00d0.5868.f180
    23:59:42:    Sender Mac address: 00d0.5868.f180
    
    !--- This is the commander MAC address.
    
    23:59:42:    Sender CMP Address: 10.104.241.128
    
    !--- This is the commander CMP address.
    
    23:59:42:    Upstream switch No: 0.0.0.0
    23:59:42:    FEC Number: 255
    23:59:42:    Management vlan: 1

debug cluster ip

Um campo de endereço CMP aparece no comando debug. Enquanto a seção do protocolo cluster management explica, o comandante e os switch membros comunicam-se com o uso destes endereços CMP.

Se você vê as saídas no membro de grânulos debugar, debugar vizinhos do conjunto, e seção do debug cluster events, você pode ver que os endereços CMP do Switches neste exemplo são:

  • Endereço do comandante CMP: 10.104.241.128

  • Endereço do Switch 1 CMP do membro: 10.159.80.192

  • Endereço do switch 2 CMP do membro: 10.104.235.128

  • Endereço do Switch 3 CMP do membro: 10.160.80.192

Enquanto a seção do protocolo cluster management discute, o CMP consiste em três partes de tecnologia chave. Um delas é o mecanismo CMP/RARP. O CMP/RARP igualmente adiciona e remove o Switches do conjunto. A saída de depuração a seguir mostra o registro de mensagens CMP/RARP após a inclusão de um membro no cluster.

Nota: Para ser coerente com os comandos das seções debug cluster member, debug cluster neighbors e debug cluster events, aqui você emite um comando debug cluster ip no comandante (3524XL) e no segundo switch a adicionar (Switch-2, 3512XL).

  • Comandante Interruptor (3524XL) (o switch 2 da adição de membro)

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The command switch generates the new CMP address.
    
    1d08h: cmdr_generate_cluster_ip_address: generated cluster,
    ip addr 10.104.235.128 for Mac 00d0.5868.eb80
    
    
    !--- The commander allocates the CMP address to member Switch-2.
    
    1d08h: cmdr_generate_and_assign_ip_address:
    setting addr for member 2 addr 10.104.235.128
    
    1d08h: cmdr_generate_and_assign_ip_address:
    adding static ARP for 10.104.235.128
    1d08h: cluster_send_rarp_reply:
    Sending reply out on Virtual1 to member 2
    1d08h: cmdr_process_rarp_request: received RARP req :
    1d08h: proto type : 0000
    1d08h: source Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    1d08h: source ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    
    1d08h: target Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    1d08h: target ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    1d08h: cmdr_process_rarp_request: rcvd ACK for the bootstrap req
    
  • Switch 2 do membro (3512XL) (que o comandante adiciona)

    Switch# debug cluster ip
    Cluster IP/transport debugging is on
    Switch#
    
    
    !--- The member switch receives information from the command switch.
    
    00:01:24: cluster_process_rarp_reply: received RARP reply :
    00:01:24: source Mac : 00d0.5868.f180
    
    !--- This is the commander MAC Address.
    
    00:01:24: source ip : 10.104.241.128
    
    !--- This is the commander CMP Address.
    
    00:01:24: target Mac : 00d0.5868.eb80
    
    !--- This is the member MAC Address.
    
    00:01:24: target ip : 10.104.235.128
    
    !--- This is the member CMP Address.
    !--- The member switch extracts and implements the cluster information.
    
    00:01:24: cluster_process_rarp_reply:
    setting commander's MAC address: 00d0.5868.f180
    00:01:24: create_cluster_idb: creating HWIDB(0x0) for the cluster
    00:01:24: cluster_create_member_idb:
    creating cluster-idb 4D4378, cmp-addr: 10.104.235.128
    00:01:24: Authorizing the password string:
    00:01:24: cluster_send_rarp_request: Sending request out to cmdr
    00:01:24: cluster_process_rarp_reply:
    created hwidb and set IP address (10.104.235.128)
    00:01:24: cluster_process_rarp_reply:
    setting commander's addr (10.104.241.128) info
    00:01:24: cluster_process_rarp_reply:
    setting static ARP for cmdr addr 10.104.241.128
    00:01:24: cluster_set_default_gateway:
    setting default gw to cmdr's addr (10.104.241.128)
    00:01:24: setting hostname to Switch-2
    00:01:24: setting password to enable password 0 mysecret
    00:01:24: cluster_pick_defaultidb: picking cluster IDB to be default IDB
    00:01:24: This switch is added to the cluster
    00:01:24: Cluster Name : engineering ; Cmdr IP address: 172.16.84.35
    00:01:24: CMP address: 10.104.235.128 ; Cmdr CMP address: 10.104.241.128
    
    !--- At this point, the switch has been added to the cluster.
    
    00:01:24: %CMP-CLUSTER_MEMBER_2-5-ADD: The Device is added to the cluster
    (Cluster Name: engineering, CMDR IP Address 172.16.84.35)
    00:01:24: cluster_process_rarp_reply: bootstrap for the firsttime, start member
    00:01:24: cluster_process_rarp_reply: setting netsareup to TRUE
    

Uso do rcommand para Administração CLI Remota

Esta última parcela da análise debugar explica como o CMP/IP trabalha. Porque a seção do protocolo cluster management deste documento discute, o CMP/IP é o mecanismo de transporte para trocar pacotes de gerenciamento entre o comando switch e os switch membros.

Um exemplo é o uso do rcommand, que é realmente uma sessão de Telnet do comando switch ao switch membro. Usa os mesmos endereços virtuais CMP.

  1. Estabeleça uma sessão de Telnet ao comando switch.

  2. Do CLI no comando switch, emita o rcommand para obter ao CLI de alguns dos switch membros.

    O rcommand é útil nas situações em que você quer pesquisar defeitos ou fazer alterações de configuração em alguns dos switch membros com uso do CLI.

    Este exemplo demonstra o uso:

    Switch# rcommand 2
    
    !--- This accesses member Switch-2.
    
    Trying ... Open
    
    Switch-2#
    
    !--- Here, you establish a Telnet session with member Switch-2.
    
    Switch-2# exit
    
    !--- Use this command to end the Telnet session.
    
    
    [Connection closed by foreign host]
    Switch#
    

Com a possibilidade do comando debug ip packet no switch membro e a introdução do rcommand do comando switch a esse switch membro, você vê estas mensagens no console do switch membro:

01:13:06: IP: s=10.104.241.128 (Virtual1), d=10.104.235.128, Len 44, rcvd 1

!--- This is a received request from the command switch.


01:13:06: IP: s=10.104.235.128 (local), d=10.104.241.128 (Virtual1), Len 44, sending

!--- A reply returns to the command switch.


Nota: Para ver esta saída no switch membro, você precisa primeiramente de estabelecer uma conexão direta de console ao switch membro. Depois que você estabelece a conexão, emita o comando debug ip packet e abra então uma sessão de rcommand do comando switch.

Apêndice

Configurações de exemplo de cluster

Esta seção alista configurações de amostra completas de todo o Switches que os cenários de laboratório usaram. Você pode localizar detalhes sobre as etapas da configuração nas seções Criar clusters com o conjunto de gerenciamento de clusters e Adicionar um membro no cluster existente deste documento.

Switch de Comando

Switch# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
cluster enable engineering 0
cluster member 1 Mac-address 00e0.1e9f.50c0
cluster member 2 Mac-address 00d0.5868.eb80
cluster member 3 Mac-address 00ee.1e9f.50c0
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 172.16.84.35 255.255.255.0
no ip directed-broadcast
ip Nat outside
!
ip default-gateway 172.16.84.1
ip Nat inside source list 199 interface VLAN1 overload
access-list 199 dynamic Cluster-NAT permit ip any any
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch 1 do membro

Switch-1# show running-config
Building configuration...
Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch-1
!
enable password mysecret
!
!
no spanning-tree vlan 1
no ip domain-lookup
!
cluster commander-address 00d0.5868.f180
!
interface VLAN1
no ip address
no ip route-cache
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
!
line con 0
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch 2 do membro

Switch-2# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-2
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 2 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch 3 do membro

Switch-3# show running-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch-3
!
enable password mysecret
!
!
!
!
!
!
ip subnet-zero
!
cluster commander-address 00d0.5868.f180 member 3 name engineering
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end

Informações adicionais

Para obter informações sobre de como usar o CMS após a configuração inicial, refira o manual de configuração do software para seus produtos de switch:

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 4085