Serviços de rede de aplicativos : Cisco LocalDirector 400 Series

Servidores FTP do Balanceamento de carga com LocalDirector sem o uso do serviço de FTP do proxy

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou a fim--venda para o Cisco LocalDirector. Para mais informação, refira o fim da vida útil do 400 Series de LocalDirector e as observações e os boletins de produto da Fim--venda.


Índice


Introdução

Este documento explica como carregar server do File Transfer Protocol (FTP) do equilíbrio com um LocalDirector sem o uso do serviço de FTP do proxy.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Problemas e soluções

As dificuldades principais de controlar o FTP através dos dispositivos como o LocalDirector são na maior parte devido ao canal de dados. Os seguintes são dois cenários possíveis:

  1. PORTA FTP: igualmente sabido como o FTP ativo. A conexão de dados é aberta pela porta de server 20 à porta do cliente que é passada através do comando port sobre o canal de controle.

  2. PASSAGEM FTP: a conexão de dados é iniciada pelo cliente. O server envia o endereço IP de Um ou Mais Servidores Cisco ICM NT e a porta o cliente tem que abrir a conexão com sobre o canal de controle.

Cenário 1

O problema na encenação número 1, a PORTA FTP, é que o LocalDirector tem que ser instruído para criar uma entrada do fluxo para o tráfego iniciado do servidor interno.

Tipicamente, a solução nesta encenação é emitir o comando static. Para o tráfego FTP, contudo, o LocalDirector aplica-o automaticamente.

Cenário 2

Há dois problemas com encenação número 2, PASSA O FTP. O primeiro problema é que o equilibrador da carga tem que ser instruído esperar uma conexão do cliente à porta do TCP destino que é diferente de essas configuradas nos virtuais.

A solução neste problema é criar não uma configuração do limite de porta tal como 172.17.241.254:0:0:tcp. Não usando nenhuma solução do limite de porta, o LocalDirector aceita e cria fluxos para cada protocolo da camada 4 (L4) que bate o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual. Com o FTP no LocalDirector, contudo, isto não é necessário, mesmo com uma configuração do limite de porta tal como 172.17.241.254:21:0:tcp.

O LocalDirector continua a olhar nas sessões do controle de FTP a fim interceptar os comandos que provocarão transferência de dados passiva.

O segundo problema é que o LocalDirector tem que tomar da tradução do endereço IP de Um ou Mais Servidores Cisco ICM NT enviado pelo server ao cliente no modo de FTP da PASSAGEM.

Isto é feito automaticamente, mesmo sem o serviço do proxy de FTP. O endereço IP de Um ou Mais Servidores Cisco ICM NT e a porta a que o cliente terá que conectar são mostrados durante a sessão de FTP sempre que um comando que provoque uma conexão de dados é emitido, como mostrado abaixo.

> 227 Entering Passive Mode (172,17,241,254,95,57) 

Você pode ver que o endereço retornado é o VIP externo e não o endereço real interno. Isto significa que o LocalDirector continua a olhar o payload dos pacotes da conexão de controle. Veja o diagrama abaixo para mais informação.

lb_ftp_servers.gif

O exemplo de saída de comando é fornecido abaixo.

[OK] 
localdirector# sho conf 
: Saved 
: LocalDirector 420 Version 4.2.2 
: Uptime is 0 weeks, 0 days, 3 hours, 0 minutes, 35 seconds 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 10baset 
interface ethernet 1 10baset 
interface ethernet 2 100basetx 
interface ethernet 3 100basetx 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure? 0 
no secure? 1 
no secure? 2 
no secure? 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 172.17.241.11 255.255.255.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 172.17.241.27 
no failover 
failover hellotime 30 
password dfeaf10390e560aea745ccba53e044ed encrypted 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
virtual 172.17.241.254:21:0:tcp is 
real 172.17.241.126:21:0:tcp is 
bind 172.17.241.254:21:0:tcp 172.17.241.126:21:0:tcp 

Está abaixo o log da sessão de FTP.

smarsill@bru-cse-126% ftp 172.17.241.254 
Connected to 172.17.241.254. 
220 CISCO FTP server (Version wu-2.6.1(1) Wed Aug 9 05:54:50 EDT 2000) ready. 
Name (172.17.241.254:smarsill): cisco 
331 Password required for cisco. 
Password: 
230 User cisco logged in. 
Remote system type is UNIX. 
Using binary mode to transfer files. 
ftp> ls 
227 Entering Passive Mode (172,17,241,254,95,57) 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> pass 
Passive mode off. 
ftp> ls 
200 PORT command successful. 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> 

Está abaixo a saída do comando netstat -n depois que o último comando foi emitido.

cisco@localhost cisco]$ netstat -n 
Active Internet connections (w/o servers) 
Proto Recv-Q Send-Q Local Address?????????? Foreign Address???????? State 
tcp??????? 0????? 0 172.17.241.126:20?????? 144.254.3.201:40411???? TIME_WAIT?? 

!--- Data Active expired.
 
tcp??????? 0????? 0 172.17.241.126:24377??? 144.254.3.201:40410???? TIME_WAIT?? 

!--- Data Passive expired.

tcp??????? 0????? 0 172.17.241.126:21?????? 144.254.3.201:40408???? ESTABLISHED 

!--- Control.

tcp??????? 0??? 126 172.17.241.126:23?????? 144.254.3.201:40220???? ESTABLISHED 

!--- Telnet session. 


Informações Relacionadas


Document ID: 4068