IP : Serviços de endereçamento IP

Balanceamento de Carga de NAT no IOS para Duas Conexões de ISP

13 Junho 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (15 Novembro 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Diagrama de Rede
      Configurações
Verificação
Troubleshooting

Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve a configuração de um roteador Cisco IOS® necessária para conectar uma rede à Internet com a Network Address Translation via duas conexões de ISP. A Network Address Translation (NAT) do Cisco IOS Software pode distribuir conexões TCP e sessões UDP subseqüentes por várias conexões de rede se houver rotas com o mesmo custo disponíveis para um mesmo destino. Se uma dessas conexões se tornar indisponível, o rastreamento de objetos, um componente do Optimized Edge Routing (OER), poderá ser usado para desativar a rota até a conexão se tornar disponível novamente, o que assegura a disponibilidade da rede independentemente da instabilidade ou da falta de confiabilidade de uma conexão com a Internet.

ios-nat-2isp-1.gif

Pré-requisitos

Requisitos

Este documento pressupõe que você possua conexões de LAN e WAN operacionais. Ele não contém informações de configuração ou troubleshooting para o estabelecimento da conectividade inicial.

  1. Este documento não descreve uma forma de diferenciar as rotas. Assim, não há forma de preferir uma conexão mais desejável em detrimento de uma conexão menos desejável.

  2. Este documento descreve a configuração do OER para ativar ou desativar cada rota da Internet com base em quão acessíveis são os servidores DNS do ISP. É necessário identificar os hosts específicos que podem ser alcançados somente por uma das conexões de ISP, os quais não estarão disponíveis se essa conexão também não estiver.

Componentes Utilizados

Esta configuração foi desenvolvida com um roteador Cisco 1811 com o Advanced IP Services Software 12.4(15)T . Se uma versão diferente do software for usada, alguns recursos poderão não estar disponíveis e os comandos de configuração poderão ser diferentes daqueles mostrados neste documento. Configurações semelhantes estão disponíveis em todas as plataformas de roteador Cisco IOS, ainda que a configuração da interface possa variar entre plataformas diferentes.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração

É potencialmente necessário adicionar o roteamento com base em políticas para um tráfego específico para garantir que ele use sempre uma conexão ISP. Exemplos de tráfego que necessitam deste comportamento incluem clientes de VPN IPSec, telefones VoIP e qualquer outro tráfego que use somente uma das opções de conexão de ISP para dar preferência ao mesmo endereço IP, à velocidade mais alta ou a uma menor latência da conexão.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

ios-nat-2isp-2.gif

Configurações

Este exemplo de configuração, como ilustrado no diagrama de rede, descreve um roteador de acesso que usa uma conexão IP com DHCP configurado em um ISP (conforme mostrado por FastEthernet 0) e uma conexão PPPoE na outra conexão de ISP. Os tipos de conexão não possuem impacto específico na configuração, a menos que o rastreamento de objetos e o OER e/ou o roteamento com base em politicas seja usado com uma conexão da Internet com DHCP atribuído. Nesses casos, pode ser muito difícil definir o roteador do próximo salto para o roteamento de políticas ou OER.

Exemplo de configuração de roteador

track timer interface 5
!
! Configura temporizadores no rastreamento de rotas
!
track 123 rtr 1 reachability
 delay down 15 up 10
!
track 345 rtr 2 reachability
 delay down 15 up 10
!
! Usa “ip dhcp client route track [número]”
   ! para monitorar a rota em interfaces DHCP
! Define as interfaces voltadas para o ISP com “ip nat outside”
!
interface FastEthernet0
 ip address dhcp
 ip dhcp client route track 345
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
interface FastEthernet3
 no cdp enable
!
interface FastEthernet4
 no cdp enable
!
interface FastEthernet5
 no cdp enable
!
interface FastEthernet6
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 no cdp enable
!
interface FastEthernet9
 no cdp enable
!
! Define as interfaces voltadas para a LAN com “ip nat inside”
!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
! Define as interfaces voltadas para o ISP com “ip nat outside”
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configura a sobrecarga de NAT (PAT) para usar mapas de roteamento
!
ip nat inside source route-map fixed-nat
   interface Dialer0 overload
ip nat inside source route-map dhcp-nat
   interface FastEthernet0 overload
!
! Configura uma entrada de rastreamento OER
   ! para monitorar a primeira conexão de ISP
!
ip sla 1
 icmp-echo 172.16.108.1 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
!
! Configura uma segunda entrada de rastreamento OER
   ! para monitorar a segunda conexão de ISP
!
ip sla 2
 icmp-echo 172.16.106.1 source-interface FastEthernet0
 timeout 1000
 threshold 40
 frequency 3
!
! Define o agendamento e a duração do SLA
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Define ACLs para tráfego que será
   ! convertido via NAT para as conexões de ISP
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Os mapas de rota associam ACLs de NAT ao NAT
   ! externo nas interfaces voltadas para o ISP
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0

Com rastreamento de rotas atribuído por DCHP:

Exemplo de configuração de rastreamento de rotas atribuído por DHCP (Opcional)

interface FastEthernet0
 description Internet Intf
 ip dhcp client route track 123
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 no cdp enable

Verificação

Utilize esta seção para confirmar se a sua configuração está funcionando corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • show ip nat translation — Exibe a atividade de NAT entre os hosts internos e os externos. Este comando permite verificar que os hosts internos são convertidos para ambos os endereços NAT externos.

    Router# sh ip nat tra
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
    
  • show ip route — Verifica que há várias rotas disponíveis para a Internet.

    Router# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,
           L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default,
           U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected,
            FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#
    

Troubleshooting

Após configurar o roteador Cisco IOS com a NAT, se as conexões não funcionarem, verifique se:

  • A NAT foi aplicada de forma adequada nas interfaces externa e interna.

  • A configuração da NAT está concluída, e as ACLs refletem o tráfego que deverá ser convertido pela NAT.

  • Várias rotas para a Internet/WAN estão disponíveis.

  • Se você usa o rastreamento de rotas para ter certeza de que as conexões com a Internet estão disponíveis, verifique o estado do rastreamento de rotas.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 99427