Cisco Unified Communications System for Contact Center Release 6.0(1)

How to Use Microsoft Visio Drawings Efficiently
   Home    History
Resource Library TOC
System Release Documentation
Network Topology Resources
Component Resources

How to Use Microsoft Visio Drawings Efficiently

Download PDF
Download Site_Content_PDF

Microsoft Visio allows you to bring drawings into several applications (for example, Microsoft Word, PowerPoint). Unfortunately, the default method is to insert the whole "Visio object" into a file. This can cause problems.

When you copy and paste a Visio drawing into another application, the Visio object includes all the application data with the drawing. This object information is needed if you want to be able to double-click the drawing from Word or PowerPoint and have it open in Visio for editing. But pasting as an object adds many megabytes to the size of your file. With only a few such drawings, a Word document can bloat from 300 KB to 12 MB, making it troublesome to share among authors or reviewers, and a trial for partners or customers to download.

Bringing a Visio Drawing into a Document

Unless you really need the live editing capability, avoid unnecessary file bloating by performing the following steps when you paste:

Step 1 In Visio, copy the drawing as you normally do. Tip: Ctrl-C copies the whole drawing.

Step 2 At the desired location in the destination document, choose Edit > Paste Special. In the Paste Special dialog box, choose Picture (Windows Metafile).

Step 3 Click OK. The drawing is inserted as an ordinary picture. If it is not positioned properly, choose Format > Picture, click the Layout tab and select In line with text.

The Bottom Line

Do not use the paste default (Edit > Paste or Ctrl-V) to paste Visio drawings. Always use Paste Special.

Downsizing Existing Drawings

If a document is larger than it should be, you can check to see if the Visio drawings are the reason and, if so, fix the problem.

Step 1 With the drawing selected in the Word or PowerPoint document, choose Edit. At the bottom of the Edit menu, you will see one of the following:

Edit Object, if the drawing was inserted by simple pasting. It is a Visio object and taking up much more file space than it needs to. Go on to Step 2.

Edit Picture, if the drawing was inserted properly, as a picture. It is not the source of the large file size.

Step 2 If the drawing is an object, cut it (Ctrl-X), and then repaste as in Bringing a Visio Drawing into a Document.

Tip You can easily click through the document to check each picture by using the Go To feature in Microsoft Word. Where you want to start searching, press Ctrl-G. In the Go To What list, select Graphic and click Next. You go to the next graphic. Click it to select and then check as in Step 1. If needed, repaste as in Step 2. Click Next and continue these steps for other graphics.