
Configurar o upgrade de imagem de software do 
ASA 9.X usando o ASDM ou a CLI
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Introdução

Este documento descreve como atualizar uma imagem de software nos dispositivos Cisco ASA 
5500 com o Cisco Adaptive Security Device Manager.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

Cisco ASA 5500 e ASA 5500-X 9.1(2) e posterior•

Cisco ASDM 7.1 e posterior•

As informações neste documento foram criadas a partir de dispositivos em um ambiente de 



laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma 
configuração (padrão) inicial. Se a rede estiver ativa, certifique-se de que você entenda o impacto 
potencial de qualquer comando.

Produtos Relacionados

Essa configuração também pode ser usada com o software Cisco ASA 5500-X Series Security 
Appliance versão 9.x.

Conventions

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre 
convenções de documentos.

Software da transferência

Para fazer o download da versão necessária das imagens do software ASA e do software ASDM, 
use estes links:

Download da versão do software Cisco ASA (somente clientes registrados)•

Download da versão do software Cisco ASDM (somente clientes registrados)•

Observação: credenciais de usuário válidas da Cisco são necessárias para fazer o 
download deste software em Cisco.com.

Compatibilidade entre ASA e ASDM

O link mostrado é atualizado com a compatibilidade e a versão do ASDM recomendada pela 
Cisco para cada versão do ASA.

Compatibilidade com ASA e ASDM

Caminho de atualização do ASA

O link mostrado fornece o caminho de atualização para o ASA. Algumas versões requerem uma 
atualização temporária antes que você possa atualizar para a versão mais recente.

Caminho de atualização do ASA

Atualizar uma imagem do software ASA com o uso do ASDM 7.x

Conclua estas etapas para atualizar uma imagem de software no ASA 5500 com o uso do ASDM.

1. Quando o ASA estiver no modo de contexto Único, selecione Tools > Upgrade Software from Local 

Computer

https://www.cisco.com/c/pt_br/support/docs/dial-access/asynchronous-connections/17016-techtip-conventions.html
https://www.cisco.com/c/pt_br/support/docs/dial-access/asynchronous-connections/17016-techtip-conventions.html
https://software.cisco.com/download/home/278875415
https://software.cisco.com/download/home/279513399/type/280775064/release/7.17.1.155
/content/en/us/td/docs/security/asa/compatibility/asamatrx.html#pgfId-121785
/content/en/us/td/docs/security/asa/upgrade/asa-upgrade/planning.html#id_58680


.. na janela Início do ASDM.

 

Quando o ASA é executado no modo de contexto múltiplo, o comando Upgrade Software from Local 

Computer sob o comando Tools está disponível somente no contexto do Sistema.

 
2. Selecione ASA como o tipo de imagem para fazer upload na lista drop-down.

 



 
3. Clique em Browse Local Files... ou digite o caminho no campo Local File Path para especificar o local da 
imagem do software no PC. 
 
4. Clique em Procurar Flash.... 
 
5. Uma caixa de diálogo Procurar Flash é exibida, com o nome do arquivo inserido 
automaticamente. Se o nome do arquivo não for exibido, insira-o manualmente no File Name campo. 
Clique em OK quando terminar. 
 

 
 
6. Quando os nomes de arquivo local e remoto forem especificados, clique em Upload Image.

 



 
 
7. Uma janela de status é exibida enquanto o ASDM grava a imagem na memória flash. Quando 
terminar, uma janela de informações será exibida, indicando que ocorreu um upload bem-
sucedido e perguntando se a imagem deve ser definida como a imagem de inicialização. 
Selecionar Yes.



Clique em OK na caixa de diálogo Informações e clique em Close na caixa de diálogo Upload Image 
from Local PC. 

8. Escolha Tools > System Reload na janela Início para recarregar o dispositivo.

 
 

Uma nova janela é exibida para verificar os detalhes da recarga. Selecionar Save the running 

configuration at the time of reload e escolha um horário para recarregar. As opções de horário incluem:

Agora — Reinicialize o dispositivo imediatamente.•
Atrasar em — Especifique em quantos minutos ou horas a partir de agora para recarregar o 
dispositivo.

•

Agendar em — Especifique uma hora e data para recarregar o dispositivo.•

 
Além disso, especifique se o dispositivo deve forçar um recarregamento imediatamente quando 
um recarregamento agendado falhar. Verificar On Reload failure, force an immediate reload after e, em seguida, 
especifique um tempo de espera máximo. Este é o tempo que o Security Appliance aguarda para 
notificar outros subsistemas antes de desligar ou reinicializar. Após esse tempo, ocorre um 
desligamento/reinicialização rápido (forçado). Clique em Schedule Reload.

 



 
Quando o recarregamento estiver em andamento, uma Reload Status é exibida para indicar que uma 
recarga está em andamento. Uma opção para sair do ASDM também é fornecida. 
 

Observação: Inicie o ASDM novamente após o ASA ser recarregado.

 



Atualizar a Imagem ASDM com o Uso do ASDM 7.x.

Conclua estas etapas para atualizar uma imagem de software no ASA 5500 com a do ASDM.

1. Selecione Tools > Upgrade Software from Local Computer... nos Home do ASDM.

 



 
 
2. Selecione ASDM como o tipo de imagem a ser carregado na lista suspensa.

 
3. Clique em Browse Local Files...  ou digite o caminho no campo Local File Path para especificar o local da 
imagem do software no PC.

Clique em Browse Flash....

R Browse Flash é exibida com o nome do arquivo inserido automaticamente. Se o nome do arquivo 
não for exibido, insira-o manualmente no File Name campo. Clique em OK ao terminar.



 
4. Clique em OK quando a imagem é atualizada com a nova imagem.

 
5. Selecione File > Save Running Configuration to Flash nos Home do ASDM.

 



 
Saia do ASDM e faça login novamente para gerenciar o ASA com a imagem do ASDM atualizada.

Atualizar o ASA e o ASDM por uma imagem Download 
Diretamente do CCO

 
Conclua estas etapas para atualizar uma imagem ASA e ASDM diretamente do CCO. 
 
1. Selecione Tools > Check for ASA/ASDM Updates... nos Home do ASDM.

 
2. Quando o prompt de nome de usuário e senha for exibido, forneça as credenciais de 
Cisco.com e clique em Login.



 
 
3. A Comissão Cisco.com Upgrade Wizard é exibida. No Overview , clique em Next. 
 



 
 
4. No Select Software , verifique o software que precisa ser atualizado. Se o ASA e o ASDM 
precisarem ser atualizados, marque as duas opções. 
 



 
5. Na lista suspensa Versão do ASA, selecione a versão para a qual a atualização do ASA deve 
ser executada.



 
6. Na lista drop-down Versão do ASDM, selecione a versão para a qual o upgrade do ASDM 
deverá ser executado. Clique em Next quando as versões apropriadas tiverem sido selecionadas.



 
7. No quadro do Review Changes revise as alterações e clique em Next.



 
8. A instalação das imagens começa e o progresso geral pode ser visto como mostrado. Depois 
de concluído, clique em Finish. 
No Results , verifique a Save configuration and reload device now opção. Clique em Finish.



 
9. A Comissão Reload Status é exibida enquanto o dispositivo é recarregado.



 
10. Clique em Exit ASDM e faça login novamente quando o dispositivo for ativado após o 
recarregamento.

Usar CLI para Atualizar uma Imagem de Software e uma Imagem 
ASDM

Um servidor TFTP é necessário para fazer upgrade ou downgrade de uma imagem de software, 
bem como de uma imagem ASDM para um ASA. Consulte Seleção e Uso do Servidor TFTP para 
saber mais sobre a seleção do servidor TFTP.

O  copy tftp flash permite que uma imagem de software seja baixada na memória Flash do firewall 
pelo TFTP. Use o copy tftp flash com qualquer modelo de dispositivo de segurança. A imagem 
baixada agora pode ser usada na próxima reinicialização por uma alteração da variável do 
sistema de inicialização para apontar para essa imagem.

Esta é a saída do comando copy tftp flash comando:

 

https://www.cisco.com/c/pt_br/support/docs/routers/10000-series-routers/48700-tftp-server.html


copy tftp[:[[//location] [/tftp_pathname]]] [[flash/disk0][:[image | asdm]]]

 

Para o modo de contexto múltiplo, execute estas etapas no espaço de execução do sistema.

Observação: para o ASA, a palavra-chave disk0 substitui flash no copy comando.

Se o comando for usado sem os parâmetros opcionais de local ou nome de caminho, o local e o 
nome de arquivo serão obtidos do usuário interativamente por uma série de perguntas 
semelhantes às apresentadas pelo software Cisco IOS®. Se apenas dois-pontos forem inseridos, 
os parâmetros serão extraídos do tftp-server configurações de comando. Se outros parâmetros 
opcionais forem fornecidos, esses valores serão usados no lugar dos parâmetros associados tftp-

server configuração de comando. Se parâmetros opcionais, como dois-pontos e qualquer coisa 
depois dele, forem fornecidos, o comando será executado sem um prompt para entrada do 
usuário.

O local é um endereço IP ou um nome que é resolvido para um endereço IP pelo mecanismo de 
resolução de nome do Security Appliance, que está atualmente mapeado estaticamente pelo name 
e names comandos. O Security Appliance deve saber como alcançar esse local com suas 
informações da tabela de roteamento. Essas informações são determinadas pelo IP address,o route, 
ou RIP comandos. Isso depende da sua configuração.

O nome do caminho pode incluir quaisquer nomes de diretório além do último componente real do 
caminho para o arquivo no servidor. O nome do caminho não pode conter espaços. Se o nome de 
um diretório tiver espaços, configure-o no servidor TFTP em vez de no copy tftp flash comando. E se 
o servidor TFTP estiver configurado para apontar para um diretório no sistema do qual você faz 
download da imagem, use apenas o endereço IP do sistema e o nome do arquivo da imagem. O 
servidor TFTP recebe o comando e determina o local de arquivo real de sua informação do 
diretório raiz. Em seguida, o servidor faz o download da imagem TFTP para o Security Appliance.

Esses comandos são necessários para atualizar a imagem do software, bem como a imagem do 
ASDM, e torná-la como uma imagem de inicialização na próxima recarga.

 
<#root>

ASA

#copy tftp [[flash:/disk0:][software image name/asdm image name]]

 

!--- Command to set an image as bootup or specify the 

!--- ASDM image file.

 
 
ASA(config)

#boot system [flash:/disk0:]/[software image name]

 



!--- Save active configuration to the Flash.

 
ASA

#write memory

 

!--- Reboot the security appliance and load 

!--- with the new boot image as per the configuration file.

 
ASA

#reload 

 

Exemplo:

 
<#root>

ASA-5512# copy tftp: disk0: 
 
Address or name of remote host []? 172.16.31.1 
Source filename []? asa916-smp-k8.bin 
Destination filename [asa916-smp-k8.bin]? 
Accessing tftp://172.16.31.1/asa916-smp-k8.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
Writing file disk0:/asa916-smp-k8.bin... 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
38043648 bytes copied in 32.290 secs (1188864 bytes/sec) 
 
ASA-5512# sh disk0 
--#--  --length--  -----date/time------  path 
 

 191  38191104    Nov 21 2014 21:07:48  asa912-smp-k8.bin 

  192  17906032    Apr 08 2015 22:33:44  asdm-713.bin 

  193  26350916    Apr 09 2015 06:28:20  asdm-741.bin 

  194  38043648    May 10 2015 02:14:06  asa916-smp-k8.bin 

 

4118732800 bytes total (3556712448 bytes free) 
 
 

!--- Command to set "asa916-smp-k8.bin" as the boot image.

 
ASA-5512(config)

# boot system disk0:/asa916-smp-k8.bin

 

!--- Command to set "asdm-741.bin" as the ASDM image.

 
ASA-5512(config)



# asdm image disk0:/asdm-741.bin

ASA-5512

# write memory

ASA-5512

# reload 

 

Observação: quando você tentar atualizar a imagem no ASA de um servidor FTP, use o 
comando copy ftp flash comando. Esse comando permite que parâmetros, como endereço IP 
remoto e nome do arquivo de origem, sejam especificados. Esse procedimento é 
semelhante ao TFTP. No entanto, uma limitação é que você não pode modificar a interface 
de origem/IP remota (como é possível com o TFTP). No modo TFTP, as opções 
especificadas com o comando tftp-server pode ser recebido e executado. No entanto, com o 
FTP, essa opção não existe. Por padrão, a interface de origem é sempre a externa, que não 
pode ser modificada. Ou seja, o servidor FTP pode ser acessado a partir da interface 
externa.

Verificar

Use esta seção para confirmar se o upgrade de software foi bem-sucedido.

O Cisco CLI Analyzer (somente clientes registrados) suporta determinados show comandos. Use o 
Cisco CLI Analyzer para visualizar uma análise do show Saída do comando.

Depois que o ASA for recarregado e se conectar novamente ao ASDM com êxito, verifique a 
versão da imagem que é executada no dispositivo. Consulte a seção General na guia Home para 
obter essas informações.

Estes comandos CLI são usados para verificar a atualização:

https://cway.cisco.com/cli
http://tools.cisco.com/RPF/register/register.do


Show version — Mostra a imagem atual com a qual o ASA é inicializado.1. 
Show bootvar — Mostra a prioridade da imagem a ser usada após o recarregamento.2. 
Show asdmimage — Mostra a imagem atual do ASDM usada pelo ASA.3. 

Troubleshooting

No momento, não há informações específicas disponíveis para solucionar esse problema de 
configuração.

Informações Relacionadas

Notas de versão•
Novos recursos do Cisco ASA por versão•
Compatibilidade com o Cisco ASA•
Planejando sua atualização•
Atualizar uma Configuração de Failover Ativo/Standby•

https://www.cisco.com/c/pt_br/support/security/asa-5500-series-next-generation-firewalls/products-release-notes-list.html
/content/en/us/td/docs/security/asa/roadmap/asa_new_features.html
/content/en/us/td/docs/security/asa/compatibility/asamatrx.html
/content/en/us/td/docs/security/asa/upgrade/asa-upgrade/planning.html
/content/en/us/td/docs/security/asa/upgrade/asa-upgrade/asa-appliance-asav.html#concept_xxv_yvn_kkb


Sobre esta tradução
A Cisco traduziu este documento com a ajuda de tecnologias de tradução automática e
humana para oferecer conteúdo de suporte aos seus usuários no seu próprio idioma,
independentemente da localização.
 
Observe que mesmo a melhor tradução automática não será tão precisa quanto as realizadas
por um tradutor profissional.
 
A Cisco Systems, Inc. não se responsabiliza pela precisão destas traduções e recomenda
que o documento original em inglês (link fornecido) seja sempre consultado.


