Roteadores Cisco 7200 Series

Configuração Básica de Roteadores com o SDM

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Diagrama de Rede
      Configuração das Interfaces
      Configuração do NAT
      Configuração do Roteamento
      Configurações Diversas
      Configuração via CLI
Verificação
Troubleshooting

Introdução

Este documento descreve como utilizar o Cisco Security Device Manager (SDM) para fazer a configuração básica do roteador. Isso inclui a configuração de endereço IP, roteamento padrão, roteamento estático e dinâmico, NAT estático e dinâmico, nome do host, banner, senha de segredo, contas dos usuários, etc. O Cisco SDM permite que você configure seu roteador em todos os tipos de ambientes de rede, incluindo escritórios pequenos ou domésticos (SOHO), escritórios de filiais (BO), escritórios regionais e sites centrais ou matrizes corporativas, com o uso de uma interface de gerenciamento fácil de usar baseada na Web.

Pré-requisitos

Requisitos

Este documento pressupõe que o roteador Cisco esteja completamente operacional e configurado de forma a permitir que o Cisco SDM efetue alterações de configuração.

Nota: Consulte Permitindo o Acesso HTTPS para o SDM para permitir que o roteador seja configurado pelo SDM.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Roteador Cisco 3640 com Cisco IOS® Software Release 12.4(8)

  • Cisco Security Device Manager (SDM) versão 2.3.1

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração

Nesta seção, você encontrará informações para definir as configurações básicas de um roteador em uma rede.

Nota:  Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento usa esta configuração de rede:

basic-router-config-sdm-diag_rev.gif

Nota: Os esquemas de endereçamento IP utilizados nesta configuração não são legalmente roteáveis na Internet. Eles são endereços da RFC 1918 leavingcisco.com que foram usados em um ambiente de laboratório.

Configuração das Interfaces

Execute estes passos para configurar as interfaces de um roteador Cisco.

  1. Clique em Home para ir para a página inicial do SDM.

    A página inicial do SDM fornece informações tais como o software e o hardware do roteador, a disponibilidade dos recursos e um resumo da configuração. Os círculos verdes mostram os recursos com suporte desse roteador e os círculos vermelhos mostram os recursos sem suporte.

    basic-router-config-sdm-1.gif

  2. Selecione Configure > Interfaces and Connections > Create Connection para configurar a conexão WAN da interface.

    Como exemplo, para a interface serial 2/0, selecione a opção Serial e clique em Create New Connection.

    Nota: Para outros tipos de interfaces, como Ethernet, selecione o tipo da respectiva interface e prossiga ao clicar no botão Create New Connection.

    basic-router-config-sdm-2.gif

  3. Clique em Next para prosseguir assim que essa interface for exibida.

    basic-router-config-sdm-3.gif

  4. Selecione Serial interface 2/0 (desejada) na opção Available Interfaces e clique em Next.

    basic-router-config-sdm-4.gif

  5. Selecione o tipo de encapsulamento para a interface serial e clique em Next.

    basic-router-config-sdm-5.gif

  6. Especifique o endereço IP estático com a máscara de sub-rede correspondente para a interface e clique em Next.

    basic-router-config-sdm-6.gif

  7. Configure o roteamento padrão com parâmetros opcionais como o endereço de IP do próximo salto (192.168.1.2 pelo diagrama de rede) fornecido pelo ISP e clique em Next.

    basic-router-config-sdm-7.gif

    Esta janela será exibida e mostrará o resumo da configuração efetuada pelo usuário. Clique em Finish.

    basic-router-config-sdm-8.gif

    Esta janela será exibida e mostrará o status do envio dos comandos para o roteador. Caso contrário, ela exibirá erros se o envio de comandos falhar devido a comandos incompatíveis ou a recursos sem suporte.

    basic-router-config-sdm-9.gif

  8. Selecione Configure > Interfaces and Connections > Edit Interfaces/Connections para adicionar/editar/excluir as várias interfaces.

    basic-router-config-sdm-10.gif

    Realce a interface na qual você deseja fazer alterações e clique em Edit para editar ou alterar as configurações da interface. Aqui você pode alterar o endereço IP estático existente.

    basic-router-config-sdm-11.gif

Configuração do NAT

Configuração do NAT Dinâmico

Execute estes passos para configurar o NAT dinâmico em um roteador Cisco.

  1. Selecione Configure > NAT > Basic NAT e clique em Launch the selected task para configurar o NAT básico.

    basic-router-config-sdm-rev1.gif

  2. Clique em Next.

    basic-router-config-sdm-rev2.gif

  3. Selecione a interface que se conecta à Internet ou ao seu ISP e selecione o intervalo de endereços IP com o qual o acesso à Internet será compartilhado.

    basic-router-config-sdm-rev3.gif

  4. Esta janela será exibida e mostrará o resumo da configuração efetuada pelo usuário. Clique em Finish.

    basic-router-config-sdm-rev4.gif

  5. A janela Edit NAT Configuration mostra a configuração do NAT dinâmico com o endereço IP convertido sobrecarregado (PAT). Se você desejar configurar o NAT dinâmico com o pool de endereços, clique em Address Pool.

    basic-router-config-sdm-rev6.gif

  6. Clique em Add.

    basic-router-config-sdm-rev7.gif

    Aqui são fornecidas informações como o nome do pool e o intervalo de endereços IP com a máscara de rede. Pode haver ocasiões em que a maioria dos endereços do pool já foram atribuídos, e o pool de endereços IP está quase esgotado. Quando isso ocorre, o PAT pode ser utilizado com um único endereço IP para satisfazer solicitações adicionais por endereços IP. Marque Port Address Translation (PAT) se desejar que o roteador use o PAT quando o pool de endereços estiver quase esgotado.

    basic-router-config-sdm-rev8.gif

  7. Clique em Add.

    basic-router-config-sdm-rev9.gif

  8. Clique em Edit.

    basic-router-config-sdm-rev10.gif

  9. Selecione Address Pool no campo Type, atribua o nome pool1 ao pool de endereços e clique em OK.

    basic-router-config-sdm-rev11.gif

  10. A janela mostra a configuração do NAT dinâmico com o pool de endereços. Clique em Designate NAT Interfaces.

    basic-router-config-sdm-rev12.gif

    Use esta janela para designar as interfaces interna e externa que deseja utilizar nas conversões de NAT. O NAT utiliza as designações interna e externa quando interpreta as regras de conversão, pois as conversões são feitas de dentro para fora ou de fora para dentro.

    Uma vez designadas, essas interfaces são utilizadas em todas as regras de conversão do NAT. As interfaces designadas são exibidas acima da lista Translation Rules na janela principal do NAT.

    basic-router-config-sdm-rev25.gif

Configuração do NAT Estático

Execute estes passos para configurar o NAT estático em um roteador Cisco.

  1. Selecione Configure > NAT > Edit NAT Configuration e clique em Add para configurar o NAT estático.

    basic-router-config-sdm-rev13.gif

  2. Defina o valor de Direction como de dentro para fora ou de fora para dentro e especifique o endereço IP interno a ser convertido em Translate from Interface. Na área Translate to Interface, selecione o valor de Type.

    • Selecione IP Address se desejar que o Translate from Address seja convertido em um endereço IP definido no campo IP Address.

    • Selecione Interface se desejar que Translate from Address use o endereço de uma interface do roteador. Translate from Address é convertido no endereço IP atribuído à interface que você especificou no campo Interface.

    Marque Redirect Port se desejar incluir informações de porta para o dispositivo interno na conversão. Isso permite que você use o mesmo endereço IP público para diversos dispositivos, desde que as porta especificadas para cada dispositivo sejam diferentes. Você deve criar uma entrada para cada mapeamento de porta para esse endereço Translated to. Clique em TCP se esse for um número de porta de TCP e clique em UDP se for um número de porta UDP. No campo Original Port, insira o número da porta do dispositivo interno. No campo Translated Port, insira o número da porta que o roteador deve utilizar para esta conversão. Consulte a seção Permitindo o Acesso a Dispositivos Internos pela Internet de Configurando a Tradução de Endereço de Rede: Introdução.

    basic-router-config-sdm-new14.gif

    Esta janela mostra a configuração de NAT estático com o redirecionamento de porta ativo.

    basic-router-config-sdm-new15.gif

Configuração do Roteamento

Configuração do Roteamento Estático

Execute estes passos para configurar o roteamento estático em um roteador Cisco.

  1. Selecione Configure > Routing > Static Routing e clique em Add para configurar o roteamento estático.

    basic-router-config-sdm-rev16.gif

  2. Insira o endereço de rede de destino com a máscara e selecione a interface de saída ou o endereço IP do próximo salto.

    basic-router-config-sdm-rev17.gif

    Esta janela mostra a rota estática configurada para a rede 10.1.1.0 com 192.168.1.2 como endereço IP do próximo salto.

    basic-router-config-sdm-rev18.gif

Configuração do Roteamento Dinâmico

Execute estes passos para configurar o roteamento dinâmico em um roteador Cisco.

  1. Selecione Configure > Routing > Dynamic Routing.

  2. Selecione RIP e clique em Edit.

    basic-router-config-sdm-rev19.gif

  3. Marque Enable RIP, selecione a versão do RIP e clique em Add.

    basic-router-config-sdm-rev22.gif

  4. Especifique o endereço de rede a ser anunciado.

    basic-router-config-sdm-rev21.gif

  5. Clique em OK.

    basic-router-config-sdm-rev22.gif

  6. Clique em Deliver para transferir os comandos para o roteador.

    basic-router-config-sdm-rev23.gif

    Esta janela mostra a configuração do roteamento RIP dinâmico.

    basic-router-config-sdm-rev24.gif

Configurações Diversas

Execute estes passos para definir as outras configurações básicas em um roteador Cisco.

  1. Selecione Configure > Additional Tasks > Router Properties e clique em Edit se você desejar alterar as propriedades de nome de host, nome de domínio, banner e senha secreta de enable de um roteador.

    basic-router-config-sdm-14.gif

  2. Selecione Configure > Additional Tasks > Router Access > User Accounts/View para adicionar/editar/excluir as contas de usuário do roteador.

    basic-router-config-sdm-15.gif

  3. Selecione File > Save Running Config to PC... para salvar a configuração na NVRAM do roteador e do PC e para redefinir a configuração atual para a configuração padrão (de fábrica).

    basic-router-config-sdm-16.gif

  4. Vá para a barra de tarefas e selecione Edit > Preferences para habilitar estas opções de preferências do usuário:

    • Visualizar comandos antes de enviá-los para o roteador.

    • Salvar arquivo de assinatura na Flash.

    • Confirmar antes de sair do SDM.

    • Continuar a monitoração do status da interface ao alternar o modo/tarefa.

    basic-router-config-sdm-17.gif

  5. Selecione View na barra de tarefas se desejar:

    • Exibir as páginas Home, Configure ou Monitor.

    • Exibir a configuração em execução do roteador.

    • Exibir vários comandos show.

    • Exibir as regras padrão do SDM.

    • Selecione Refresh para sincronizar a configuração do roteador se alguma alteração tiver sido efetuada via linha de comando com o SDM.

    basic-router-config-sdm-18.gif

Configuração via CLI

Configuração do Roteador

Router#show run
Building configuration...

Current configuration : 2525 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable password cisco
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!

!--- Certificado RSA gerado após você habilitar o !--- comando ip http secure-server.

crypto pki trustpoint TP-self-signed-392370502
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-392370502
 revocation-check none
 rsakeypair TP-self-signed-392370502
!
!
crypto pki certificate chain TP-self-signed-392370502
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657
  69666963 6174652D 33393233 37303530 32301E17 0D303530 39323330 34333
  375A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 13254
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3339 32333
  35303230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818
  C86C0F42 84656325 70922027 EF314C2F 17C8BBE1 B478AFA3 FE2BC2F2 3C272
  A3B5E13A 1392A158 73D8FE0D 20BFD952 6B22890C 38776830 241BE259 EE2AA
  CF4124EA 37E41B46 A2076586 2F0F9A74 FDB72B3B 6159EEF7 0DEC7D44 BE489
  9E351BF7 F5C808D9 2706C8B7 F5CE4B73 39ED8A61 508F455A 68245A6B D072F
  02030100 01A36630 64300F06 03551D13 0101FF04 05300301 01FF3011 06035
  11040A30 08820652 6F757465 72301F06 03551D23 04183016 80148943 F2369
  ACD8CCA6 CA04EC47 C68B8179 E205301D 0603551D 0E041604 148943F2 36910
  D8CCA6CA 04EC47C6 8B8179E2 05300D06 092A8648 86F70D01 01040500 03818
  3B93B9DC 7DA78DF5 6D1D0D68 6CE075F3 FFDAD0FB 9C58E269 FE360329 2CEE3
  D8661EB4 041DEFEF E14AA79D F33661FC 2E667519 E185D586 13FBD678 F52E1
  E3C92ACD 52741FA4 4429D0B7 EB3DF979 0EB9D563 51C950E0 11504B41 4AE79
  0DD0BE16 856B688C B727B3DB 30A9A91E 10236FA7 63BAEACB 5F7E8602 0C33D
  quit
!
!
!
!
!
!
!
!
!
!

!--- Crie uma conta de usuário chamada sdmsdm com todos os privilégios.

username sdmsdm privilege 15 password 0 sdmsdm
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!

!--- A interface de LAN configurada com um endereço IP privado.

interface FastEthernet1/0
 ip address 172.16.1.2 255.255.255.0

!--- Determina que o tráfego originado por trás da !--- interface está sujeito à Tradução de Endereço de Rede (NAT).

 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!

!--- Esta é a interface da WAN configurada com um endereço IP roteável (público).

interface Serial2/0
 ip address 192.168.1.1 255.255.255.0

!--- Determina que a interface é o !--- destino do tráfego que passou pelo processo de NAT.

ip nat outside
 ip virtual-reassembly
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!

!--- O roteamento RIP versão 2 está habilitado. 

router rip
 version 2
 network 172.1.0.0
 no auto-summary

!--- Aqui é onde os comandos para habilitar o HTTP e o HTTPS são configurados.

ip http server
ip http secure-server
!

 !--- Esta configuração é para o NAT dinâmico. 

!

!--- Define o pool de endereços IP externos para o NAT.

ip nat pool pool1 192.168.1.3 192.168.1.10 netmask 255.255.255.0

!--- Para habilitar o NAT dos endereços de origem internos, !--- especifique que o tráfego dos hosts que correspondem à lista de acesso 1 !--- seja traduzido pelo NAT para o pool de endereços chamado pool1.

ip nat inside source list 1 pool pool1
!

!--- A lista de acesso 1 permite o NAT somente da rede 172.16.1.0.

access-list 1 remark SDM_ACL Category=2
access-list 1 permit 172.16.1.0 0.0.0.255
!

 !--- Esta configuração é para o NAT estático. 


!--- Para converter os pacotes entre o endereço IP real 172.16.1.1 com porta do TCP !--- 80 e o endereço IP mapeado 192.168.1.1 com porta do TCP 500.

ip nat inside source static tcp 172.16.1.1 80 192.168.1.3 500 extendable
!
!

!
!

!--- A rota padrão é configurada e aponta para 192.168.1.2.

ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
!

!--- A rota estática é configurada e aponta para 192.168.1.2.

ip route 10.1.1.0 255.255.255.0 192.168.1.2
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0

!--- Telnet habilitado com a senha sdmsdm.

line vty 0 4
 password sdmsdm
 login
!
!
end

Verificação

Selecione Configure > Interface & Connections > Edit Interface Connections > Test Connection para testar a conectividade ponta a ponta. Você pode especificar o endereço IP da extremidade remota ao clicar no botão de opção User-specified.

basic-router-config-sdm-23.gif

Troubleshooting

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar os comandos debug.

Você pode usar estas opções para o troubleshooting:

  • Selecione Tools > Update SDM na barra de tarefas para fazer ping, telnet e para atualizar o SDM para a versão mais atual. Isso pode ser feito de Cisco.com, do PC local ou do CD.

    basic-router-config-sdm-19.gif

  • Selecione Help > About this Router para exibir informações sobre a configuração de hardware do roteador.

    basic-router-config-sdm-20.gif

    Esta janela mostra informações sobre a imagem do IOS armazenada no roteador.

    basic-router-config-sdm-21.gif

  • A opção Help fornece informações sobre as várias opções disponíveis no SDM para a configuração de roteadores.

    basic-router-config-sdm-22.gif