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はじめに

この前書きは、次の項で構成されています。

• マニュアルの入手方法およびテクニカル サポート（v ページ）

• その他のツールに関する資料の入手（v ページ）

マニュアルの入手方法およびテクニカル サポート
マニュアルの入手方法、テクニカル サポート、その他の有用な情報について、次の URL で、毎月
更新される『What's New in Cisco Product Documentation』を参照してください。
http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

「What's New in Cisco Product Documentation」に配信登録すると、新しい（または改訂された）シスコ
技術情報のリストが RSS フィードとして提供され、リーダー アプリケーションを使ってコンテン
ツがデスクトップに直接配信されるようにすることができます。RSS フィードは無料のサービス
です。

その他のツールに関する資料の入手
その他のツールについては、次の関連資料を参照してください。

• Net-SNMP Version 5.1.2 のマニュアルおよびオンライン ヘルプ（Linux）

• IWL Silvercreek テスト スイートのチュートリアルおよびオンライン ヘルプ（最新バー
ジョン）

• HP OpenView NNM SPI Version 7.53 のマニュアル

• Ipswitch WhatsUp Gold Version 12.3 のマニュアルおよびオンライン ヘルプ

• CiscoWorks for Windows LMS Version 3.1 のオンライン ヘルプおよびチュートリアル
v
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C H A P T E R 1

概要

SNMP バージョン 3 では、User-based Security Model（USM; ユーザベース セキュリティ モデル）
および View-based Access Control Model（VACM; ビューベース アクセス コントロール モデル）に
よる認証オプションやプライバシー オプションを使用することにより、SNMP エージェントに
よる SNMP トランザクションのセキュアな通信が実現されます。SNMP バージョン 1 および 
SNMP バージョン 2c では、MIB のアクセス コントロールを行う場合ユーザは認識されないた
め、暗号化されたプライバシー オプションを使用して認証を行うことはできません。VACM のサ
ポートは、次リリース以降に先送りされました。

この章では、ASA ソフトウェア バージョン 8.2(1) 以降が稼働しているデバイス上で、SNMP バー
ジョン 3 を介して ASA と通信可能な CiscoWorks およびいくつかのサードパーティ製ツールを
インストールする方法、設定する方法、および使用する方法について説明します。

この章は、次の項目を取り上げます。

• ネットワーク管理ツール（1-1 ページ）

• ネットワーク トポロジ（1-2 ページ）

• ASA 設定（1-2 ページ）

ネットワーク管理ツール
このマニュアルでは、次のネットワーク管理ツールについて説明します。

• Net-SNMP（CLI アプリケーション）

• IWL SilverCreek（SNMP テスト スイート）

• Ipswitch WhatsUp Gold

• HP OpenView NNM

• CiscoWorks for Windows LMS

シスコでは、これらのツール対して、NMS および ASA との間の相互運用性試験をすでに実施し
ています。
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第 1 章      概要

  ネットワーク トポロジ
ネットワーク トポロジ
図 1-1 は、SNMP バージョン 3 を実装するためのネットワーク トポロジを示したものです。

図 1-1 SNMP バージョン 3 を実装するためのネットワーク トポロジ

ASA 設定
ASA を使用するためには、SNMP サーバ グループ、そのグループに関連付けられた SNMP サー
バ ユーザ、および SNMP トラップの受信ユーザを指定するための SNMP サーバ ホストを設定す
る必要があります。

SNMP バージョン 3 の動作を設定する際に必要となるコマンドは次のとおりです。

• snmp-server group

• snmp-server user

• snmp-server host

ASA の構成例を以下に示します。

ciscoasa# snmp-server group authPriv v3 priv
ciscoasa# snmp-server group authNoPriv v3 auth
ciscoasa# snmp-server group noAuthNoPriv v3 noauth

ciscoasa# snmp-server user md5des authPriv v3 auth md5 mysecretpass priv des passphrase
ciscoasa# snmp-server user md5user authNoPriv v3 auth md5 mysecretpass 
ciscoasa# snmp-server user noauthuser noAuthNoPriv v3 

ciscoasa# snmp-server host mgmt 10.0.0.1 version 3 md5des
ciscoasa# snmp-server host mgmt 10.0.0.2 version 3 md5des
ciscoasa# snmp-server host mgmt 10.0.0.3 version 3 md5des

ciscoasa# snmp-server location Anywhere, USA
ciscoasa# snmp-server contact admin@example.com
ciscoasa# snmp-server enable traps snmp authentication linkup linkdown coldstart
ciscoasa# snmp-server enable traps syslog
ciscoasa# snmp-server enable traps ipsec start stop
ciscoasa# snmp-server enable traps entity config-change fru-insert fru-remove
ciscoasa# snmp-server enable traps remote-access session-threshold-exceeded

CiscoWorks
Ipswitch
ASDM

HP OpenView
IBM Tivoli

CSM
Codenomicon

ASA

27
53

66
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C H A P T E R 2

ネットワーク管理ツールの使用方法

この章では、CiscoWorks およびいくつかのサードパーティ製ネットワーク管理ツールについて
説明します。内容は次のとおりです。

• Net-SNMP（2-1 ページ）

• SilverCreek SNMP テスト スイート（2-3 ページ）

• Ipswitch WhatsUp Gold（2-17 ページ）

• HP OpenView Network Node Manager（2-30 ページ）

• CiscoWorks（2-46 ページ）

Net-SNMP
Net-SNMP Version 5.1.2 には、次のようなツールおよびライブラリが用意されています。

• 拡張可能なエージェント

• SNMP ライブラリ

• SNMP エージェントに対して情報を要求または設定するためのツール

• SNMP トラップを生成および処理するためのツール

Net-SNMP ネットワーク管理ツールは次の URL からダウンロードできます。

http://sourceforge.net/projects/net-snmp/

この項では、次のトピックについて取り上げます。

• MIB のポーリング（2-1 ページ）

• トラップの送信（2-2 ページ）

MIB のポーリング

ASA の設定を完了した後で MIB をポーリングする場合は、NMS から ASA に対して次のような 
snmpwalk コマンドを実行します。

（注） snmpwalk コマンドを実行する場合、Linux 上の Net-SNMP に対しては特別な設定を行う必要は
ありません。
2-1
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第 2 章      ネットワーク管理ツールの使用方法
  Net-SNMP
[root@iLinux2 ~]# snmpwalk -v3 -u md5des -l authPriv -a MD5 -A mysecretpass –x des -X 
passphrase 10.31.8.254 1.3.6.1.2.1.1

次に示すのは、snmpwalk コマンドを実行した場合の出力例です。

SNMPv2-MIB::sysDescr.0 = STRING: Cisco Adaptive Security Appliance Version 8.2(0)227
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.9.1.915
SNMPv2-MIB::sysUpTime.0 = Timeticks: (486600) 1:21:06.00
SNMPv2-MIB::sysContact.0 = STRING: admin admin
SNMPv2-MIB::sysName.0 = STRING: ciscoasa
SNMPv2-MIB::sysLocation.0 = STRING: sjc - 190 W Tasman Drive, San Jose, CA 95134
 USA
SNMPv2-MIB::sysServices.0 = INTEGER: 4

トラップの送信

ASA により送信されたトラップは信頼されます。そのため、snmptrapd コマンド内で作成された
ユーザは、そのトラップを送信した EngineID に関連付けられている必要があります。

関連付けを行う手順は次のとおりです。

ステップ 1 /var/net-snmp/snmptrapd.conf ファイル内に、次のステートメントを入力します。

createUser -e ENGINEID myuser authentication protocol “my authentication pass” AES “my 
privacy pass”

このステートメントの中に現れる次の各パラメータを定義します。

– ENGINEID：トラップを送信するアプリケーションの EngineID 

– myuser：トラップを送信する USM ユーザ名

– authentication protocol：認証タイプ（SHA または MD5。SHA を推奨） 

– "my authentication pass"：秘密認証キーを生成する際に使用する認証パスフレーズ。ス
ペースを含むパスフレーズは引用符で囲んでください。

– privacy protocol：使用する暗号のタイプ（AES または DES。AES を推奨） 

– "my privacy pass"：秘密暗号キーを生成する際に使用する暗号化パスフレーズ。スペース
を含むパスフレーズは引用符で囲んでください。引用符で囲まない場合、その暗号化パ
スフレーズは認証パスフレーズと同じ値に設定されます。

ステップ 2 /tmp/snmptrapd.conf ファイル内に、次のステートメントを入力します。

createUser -e 80000009fe8949e0b20319e2d175b93fe7dc24af0dff7db915 md5des MD5 mysecretpass 
DES passphrase

ステップ 3 そのファイルを指定して、snmptrapd コマンドを実行します。

（注） このプロセスはフォアグラウンドで実行されます。使用されるのは指定されたコンフィ
ギュレーション ファイルのみで、ログとして stderr ファイルにメッセージが記録されます。

[root@iLinux2 net-snmp]# snmptrapd -f -C -c /tmp/snmptrapd.conf -Le

ステップ 4 次のようなコマンドを入力し、ASA から snmptrap コマンドを実行して、リンクダウントラップ
またはリンクアップトラップを送信します。

cicoasa (config)# int g3/1.391
cicoasa (config-if)# shut
cicoasa (config-if)# no shut
2-2
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第 2 章      ネットワーク管理ツールの使用方法

  SilverCreek SNMP テスト スイート
次に示すのは、snmptrap コマンドを実行した場合の出力例です。

2009-03-18 23:52:06 NET-SNMP version 5.1.2 Started.
2009-03-18 23:52:20 10.31.8.254 [10.31.8.254]:
SNMPv2-MIB::sysUpTime.0 = Timeticks: (938700) 2:36:27.00        SNMPv2-MIB::snmp
TrapOID.0 = OID: IF-MIB::linkDown       IF-MIB::ifIndex.1 = INTEGER: 1  IF-MIB::
ifAdminStatus.1 = INTEGER: down(2)      IF-MIB::ifOperStatus.1 = INTEGER: down(2
)
2009-03-18 23:52:22 10.31.8.254 [10.31.8.254]:
SNMPv2-MIB::sysUpTime.0 = Timeticks: (939000) 2:36:30.00        SNMPv2-MIB::snmp
TrapOID.0 = OID: IF-MIB::linkUp IF-MIB::ifIndex.1 = INTEGER: 1  IF-MIB::ifAdminS
tatus.1 = INTEGER: up(1)        IF-MIB::ifOperStatus.1 = INTEGER: up(1)

SilverCreek SNMP テスト スイート
SilverCreek SNMP テスト スイートを使用すると、プライベート MIB および標準 MIB から、
SNMP に準拠していない部分や SNMP の実装エラーを検出できます。このソフトウェアの無償
バージョンを次の URL からダウンロードできます。

http://www.iwl.com/trial-downloads/silvercreek-trial.html?Itemid=

この項では、次のトピックについて取り上げます。

• SilverCreek の実行（2-3 ページ）

• SNMP バージョン 3 エージェントのセットアップ（2-5 ページ）

• MIB のロードと削除（2-7 ページ）

• テスト スイートの実行（2-8 ページ）

• デバッグの有効化（2-10 ページ）

• MIB のテスト（2-12 ページ）

• 通知トラップ メッセージの受信（2-15 ページ）

• パフォーマンスのテスト（2-16 ページ）

SilverCreek の実行

SilverCreek ソフトウェアを実行する場合は、[Start] > [All Programs] > [SilverCreekMx Evaluation] > 
[Run Test Suite and Tools (Start Here)] を選択します。

アプリケーションが起動すると、SilverCreek のメイン ウィンドウ（図 2-1 を参照）とともにコン
ソール ウィンドウ（図 2-2 を参照）が開き、次のような情報が表示されます。

• ログ メッセージ

• デバッグ メッセージ

• NMS と SNMP バージョン 3 エージェントとの間でやり取りされるその他のメッセージ

• ロードされた MIB
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第 2 章      ネットワーク管理ツールの使用方法

  SilverCreek SNMP テスト スイート
図 2-1 SilverCreek のメイン ウィンドウ
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第 2 章      ネットワーク管理ツールの使用方法

  SilverCreek SNMP テスト スイート
図 2-2 SilverCreek のコンソール ウィンドウ

SNMP バージョン 3 エージェントのセットアップ

SNMP バージョン 3 エージェントのセットアップを行う手順は次のとおりです。

ステップ 1 [File] > [New Agent Setup] を選択します。

図 2-3 は、新しいエージェントの設定方法を示したものです。
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第 2 章      ネットワーク管理ツールの使用方法

  SilverCreek SNMP テスト スイート
図 2-3 [New Agent Setup] ダイアログボックス

ステップ 2 ホスト名または IP アドレス、ポート番号、および SNMP バージョン 3 パラメータを入力します。

エージェントが接続されると、左側ペインの [Test Suites] タブ（図 2-4 を参照）から SNMP テスト 
スイートを実行できます。
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第 2 章      ネットワーク管理ツールの使用方法

  SilverCreek SNMP テスト スイート
図 2-4 接続済み SNMP エージェントが表示された SilverCreek のメイン ウィンドウ

MIB のロードと削除

MIB をロードおよび削除する手順は次のとおりです。

ステップ 1 MIB のロードおよび削除を手動で行う場合は、[MIB] > [Load | Delete MIBs] を選択します。

ステップ 2 ロードした MIB を表示する場合は、[View Loaded Modules] をクリックします（図 2-5 を参照）。

MIB ファイルはすべて、デフォルトの mibs ディレクトリ内に保持できます。このディレクトリ
は、環境変数 MIB_PATH を使用して定義します。
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図 2-5 [Load and Delete MIBs] ダイアログボックス

テスト スイートの実行

テスト スイートを実行する手順は次のとおりです。

ステップ 1 メイン ウィンドウの左側ペイン（図 2-6 を参照）でテスト カテゴリ（MIB-II など）を選択します。

右側ペインには、選択したテスト カテゴリに対して実行できるテストがリスト表示され、下部ペ
インにはテストの詳細が表示されます。

ステップ 2 1 つまたは複数のテストを選択し、[Run All or Selected Tests] をクリックします。

[Status] 列にテストのステータスが表示されます。またウィンドウの下部には、実行されたテス
ト、問題なく完了したテスト、問題が検出されたテストなどの総数が表示されます。
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図 2-6 選択したテストが表示されている SilverCreek のメイン ウィンドウ 
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デバッグの有効化

デバッグを有効にする場合は、[Tools] > [Options] を選択します（図 2-7 を参照）。

図 2-7 [Options] ダイアログボックスの [Debug] タブ

図 2-8 の画面に表示されているのは、デバッグが有効になっているためテストの実行には時間が
かかるという内容の警告メッセージです。
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図 2-8 警告を表示する [Notes] ダイアログボックス

図 2-9 は、デバッグ メッセージが表示されたコンソール ダイアログボックスを示したものです。
これらのメッセージはテストを実行した際に表示されます。
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図 2-9 デバッグ メッセージが表示されたコンソール ダイアログボックス

MIB のテスト

MIB をテストする手順は次のとおりです。

ステップ 1 メインウィンドウの左側ペインにある [MIB Testing] タブをクリックします。

ロードされ、テストに使用可能なすべての MIB モジュールが表示されます（図 2-10 を参照）。

ステップ 2 テストが必要な MIB に対応するオプション ボタンをクリックします。

ステップ 3 右側ペインで、実行する必要のあるテストを選択します。

テストの目的および詳細が下部ペインに表示されます。
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図 2-10 MIB のテストの詳細が表示された SilverCreek のメイン ウィンドウ

MIB ブラウザへのアクセス

MIB ブラウザにアクセスする手順は次のとおりです。

ステップ 1 メインウィンドウで、[MIB] > [MIB Browser] を選択します。

MIB ブラウザ（図 2-11 を参照）を使用すると、MIB の個別ポーリングや選択したツリーのウォー
クなど、エージェントの MIB に対してより細かい操作が可能です。
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図 2-11 [MIB Browser: Local MIB Tree Mode] ダイアログボックス

ステップ 2 目的の OID（.iso.org.dod.internet.mgmt.mib-2.system）までスクロールして [system] を右クリック
し、ツリーをウォークするためのオプションを選択します。

右側ペインに MIB の参照結果が表示されます（図 2-12 を参照）。
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図 2-12 MIB の参照結果が表示された [MIB Browser: Local MIB Tree Mode] ダイアログボックス

（注） SNMP MIB に関する未解決の警告の一覧については、Cisco ASA 5500 シリーズのリリースノート
を参照してください。

通知トラップ メッセージの受信

通知トラップ メッセージを受信する手順は次のとおりです。

ステップ 1 メインウィンドウで、[Notifications] > [Notifications Monitor] を選択します。

ステップ 2 エージェント固有の情報を設定するため、[V3 Inform] をクリックします。

受信通知のダイアログボックス（図 2-13 を参照）に受信したトラップ メッセージが表示され、そ
の下部には通知の詳細が表示されます。

（注） SNMP バージョン 3 では、認証失敗トラップは送信されません。代わりに SNMP バージョ
ン 3 エージェントからは PDU レポートが送信されます。
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図 2-13 [Notification Monitor] ダイアログボックス

パフォーマンスのテスト

パフォーマンスをテストする手順は次のとおりです。

ステップ 1 [Tools] > [Performance Monitoring Tool] を選択した後、実行する動作（[Walk (get-bulks)] など）を選
択し、オブジェクト名を入力します。さまざまなコマンドを繰り返し実行することができます。

ステップ 2 [Send Synchronously] をクリックします。

選択した SNMP の動作が開始されます。結果は別ウィンドウに表示されます。

次に示す例（図 2-14）では ifType が使用され、動作の繰り返し回数は 10 となっています。
2-16
CiscoWorks およびサードパーティ製ツールを使用した SNMP バージョン 3 実装ガイド

OL-22912-01-J



第 2 章      ネットワーク管理ツールの使用方法
  Ipswitch WhatsUp Gold
図 2-14 [Performance Measuring] ダイアログボックス

Ipswitch WhatsUp Gold
Ipswitch WhatsUp Gold は、ネットワーク探索、SNMP モニタリング、および SNMP ポーリングを
行えるネットワーク管理ソフトウェアです。このソフトウェアの無償バージョンを次の URL か
らダウンロードできます。

http://www.whatsupgold.com/products/download/

この項では、次のトピックについて取り上げます。

• Ipswitch WhatsUp Gold の起動（2-18 ページ）

• SNMP エージェントの新規追加（2-18 ページ）

• SNMP バージョン 3 クレデンシャルの追加（2-19 ページ）

• WhatsUp Gold Web インターフェイスの使用方法（2-22 ページ）

• SNMP MIB または OID のウォーク（2-23 ページ）

• SNMP トラップの設定（2-27 ページ）
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Ipswitch WhatsUp Gold の起動

Ipswitch WhatsUp Gold アプリケーションを起動する場合は、[Start] > [Programs] > [Ipswitch 
WhatsUp Gold 12.3] > [WhatsUp Gold] を選択します。

ネットワーク エクスプローラのメイン ウィンドウが表示されます（図 2-15 を参照）。

図 2-15 ネットワーク エクスプローラのメイン ウィンドウ

SNMP エージェントの新規追加

SNMP エージェントを新たに追加する手順は次のとおりです。

ステップ 1 [File] > [New] > [New Device] を選択します。

[Add New Device] ダイアログボックスが表示されます（図 2-16 を参照）。
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図 2-16 [Add New Device] ダイアログボックス

ステップ 2 IP アドレスまたはホスト名を入力します。

ステップ 3 デバイスが追加されたら、[General] ペイン（図 2-17 を参照）でデバイスのプロパティを入力し
ます。

図 2-17 [Device Properties] ダイアログボックス

SNMP バージョン 3 クレデンシャルの追加

SNMP バージョン 3 クレデンシャルを追加する手順は次のとおりです。

ステップ 1 [Credentials] リンク（図 2-18 を参照）をクリックし、SNMP デバイスのオブジェクト ID 情報を入
力します。
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図 2-18 SNMP クレデンシャルが表示された [Device Properties] ダイアログボックス

ステップ 2 [SNMP v1/v2/v3 credentials] ドロップダウンリストの横にあるボタンをクリックし、ユーザ名、認
証アルゴリズム、暗号化アルゴリズム、および認証と暗号化のそれぞれに使用するパスワードを
入力して、[OK] をクリックします（図 2-19 および図 2-20 を参照）。

図 2-19 [Edit SNMP v3 Credential Type] ダイアログボックス
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図 2-20 [Credentials Library] ダイアログボックス

図 2-21 は、ネットワーク上に追加された SNMP バージョン 3 ノードが表示されている画面です。

図 2-21 追加された SNMP バージョン 3 ノードが表示されているネットワーク エクスプローラ ウィン
ドウ
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WhatsUp Gold Web インターフェイスの使用方法

WhatsUp Gold アプリケーションを起動する手順は次のとおりです。

ステップ 1 [Start] > [Programs] > [IpSwitch WhatsUp Gold v12.3] > [WhatsUp Web Interface] を選択します。こ
の場所から SNMP バージョン 3 のウォークおよびポーリングを実行できます。

ステップ 2 図 2-22 は、初回ログイン時に表示されるウィンドウです。デフォルトのユーザ名およびパスワー
ド（「admin」）を入力します。

図 2-22 WhatsUp Gold Web インターフェイスのログイン ウィンドウ

図 2-23 は、ユーザがログインした後に表示される [Home Workspace] ペインです。
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図 2-23 WhatsUp Gold の [Home Workspace] ペイン

SNMP MIB または OID のウォーク

MIB または OID をウォークする手順は次のとおりです。

ステップ 1 [GO] > [Tools] > [SNMP MIB Walker] を選択します（図 2-24 を参照）。
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図 2-24 [SNMP MIB Walker] メニュー オプション

ステップ 2 [Network Tool: SNMP MIB Walker] ダイアログボックス（図 2-25 を参照）で、次の情報を入力し
ます。

• エージェントの IP アドレスまたはホスト名

• ウォークの対象となる OID または MIB

• SNMP バージョン 3 クレデンシャル 
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図 2-25 [Network Tool: SNMP MIB Walker] ダイアログボックス

ステップ 3 [Walk] をクリックします。
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図 2-26 は、ツリー形式で表示されたウォークの結果を示したものです。

図 2-26 [Network Tool: SNMP MIB Walker] にツリー形式で表示されたウォークの結果

図 2-27 は、ウォーク順に表示された結果を示したものです。
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図 2-27 [Network Tool: SNMP MIB Walker] の結果ウィンドウ

SNMP トラップの設定

SNMP トラップを設定する手順は次のとおりです。

ステップ 1 [Program Options] > [Passive Monitor Listeners] > [SNMP Trap] > [Configure] を選択します（図 2-28 
を参照）。
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図 2-28 [Program Options – Passive Monitor Listeners] ダイアログボックス

[SNMP Listener Configuration] ダイアログボックスが表示されます（図 2-29 を参照）。このダイア
ログボックスでは、リスナー ポートを設定できるだけでなく、トラップをホストへ転送すること
もできます。

図 2-29 [SNMP Listener Configuration] ダイアログボックス

ステップ 2 [Reports] タブをクリックし、[SNMP Trap Log] を選択します（図 2-30 を参照）。
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図 2-30 SNMP レポートのペイン

図 2-31 は SNMP トラップのログを示したものです。
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図 2-31 SNMP トラップ ログのペイン

HP OpenView Network Node Manager
HP OpenView Network Node Manager（NNM）7.53 は、ネットワーク トポロジの作成、デバイスの管
理、およびデバイス ヘルスのモニタリングを自動的に行うための管理ツールです。ASA は、この 
HP NNM のデバイス トポロジに組み込まれ、SNMP バージョン 3 に基づいてデバイスの統計情
報や SNMP トラップをやり取りします。

（注） NNM 8.x に関する未解決の警告の一覧については、Cisco ASA 5500 シリーズのリリースノートを
参照してください。

この項では、次のトピックについて取り上げます。

• NNM のインストール（2-31 ページ）

• NNM の起動（2-31 ページ）

• MIB のロード（2-32 ページ）

• 現在のマップへのネットワークの追加（2-33 ページ）

• 特定の SNMP バージョン 3 パラメータの設定（2-36 ページ）

• グローバルな SNMP バージョン 3 クレデンシャルの設定（2-37 ページ）
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• ノード情報の表示（2-38 ページ）

• NNM MIB ブラウザの設定（2-39 ページ）

• HP OpenView NNM Web アプリケーションの使用方法（2-44 ページ）

NNM のインストール

NNM 7.53 は Windows 2003 Server プラットフォーム上でテスト済みです。トライアル バージョ
ン、およびインストールに必要な手順は、次の URL から入手できます。

https://h10078.www1.hp.com/cda/hpms/display/main/hpms_content.jsp?zn=bto&cp=1-11-15-119^115
5_4000_100__

NNM の起動

NNM を起動する手順は次のとおりです。

ステップ 1 NNM サーバのコマンド プロンプトから、次のいずれかを実行します。

• [Start] > [Programs] > [HP OpenView] > [Network Node Manager Admin] > [Network Node 
Manager] を選択します。

• C:\Program Files\HP OpenView\bin にある ovw.exe ファイルをダブルクリックします。

[Root] ウィンドウが開き、[Internet map] アイコンが表示されます（図 2-32 を参照）。

図 2-32 NNM コンソールの [Root] ウィンドウ
2-31
CiscoWorks およびサードパーティ製ツールを使用した SNMP バージョン 3 実装ガイド

OL-22912-01-J

https://h10078.www1.hp.com/cda/hpms/display/main/hpms_content.jsp?zn=bto&cp=1-11-15-119^1155_4000_100__


第 2 章      ネットワーク管理ツールの使用方法
  HP OpenView Network Node Manager
ステップ 2 [Internet map] アイコンをダブルクリックします。

[Internet] ウィンドウが開き、ネットワーク ノードが表示されます（図 2-33 を参照）。

図 2-33 ネットワーク ノードが表示された NNM コンソールの [Internet] ウィンドウ

MIB のロード

MIB をロードする手順は次のとおりです。

ステップ 1 NNM のメインウィンドウで、[Options] > [Load/Unload MIBs: SNMP] を選択します。

現在ロードされている MIB がリスト表示されます。

ステップ 2 [Load] をクリックし、さらにロードする MIB をサーバファイルシステムから選択します
（図 2-34 を参照）。
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図 2-34 [Load/Unload MIBs: SNMP] ダイアログボックス

現在のマップへのネットワークの追加

現在のマップにネットワークを追加する手順は次のとおりです。

ステップ 1 追加するネットワークの中からトラフィック量の多いデバイスを少なくとも 1 つ選び、その IP 
アドレスおよびホスト名を特定します。

ステップ 2 インターネットレベル サブマップ内で、[Edit] > [Add Objects] を選択します。

[Add Object Palette] ダイアログボックスが表示されます（図 2-35 を参照）。
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図 2-35 [Add Object Palette] ダイアログボックス

ステップ 3 [Connector] シンボル クラス アイコンをクリックし、[Gateway] シンボル サブクラス アイコンを
インターネットレベル サブマップ上にドラッグします。探索を開始する際に使用しているデバ
イスのタイプにかかわらず、このゲートウェイ コネクタを選択してください。

[Add Object] ダイアログボックスが表示されます（図 2-36 を参照）。
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図 2-36 [Add Object] ダイアログボックス

ステップ 4 [IP Map] をダブルクリックします。

[Add Object – Set Attributes] ダイアログボックスが表示されます（図 2-37 を参照）。
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図 2-37 [Add Object – Set Attributes] ダイアログボックス

ステップ 5 管理ドメインに追加するネットワーク内の SNMP 対応デバイスの IP アドレスおよびホスト名
を入力し、[Verify] をクリックします。

ステップ 6 NNM により、設定内容がチェックされた後で、記号の選択内容が変更されます。必要であればそ
の位置も修正されます。この時点で、そのデバイスは NNM によって管理されるよう設定され、イ
ンターネット マップ上に表示されます。

特定の SNMP バージョン 3 パラメータの設定 
特定の SNMP ノードに対してクレデンシャルを設定する手順は次のとおりです。

ステップ 1 C:\Program Files\HP OpenView\bin にある xnmsnmpconf.exe ファイルをダブルクリックします。

ステップ 2 NNM のメインウィンドウで、[Options] > [SNMP Configuration] を選択します。

設定ペインが表示されます。
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（注） SNMP バージョン 3 クレデンシャルを設定する場合は、オーバーロードされた SNMP ス
トリングを使用する必要があります。詳細については、「NNM MIB ブラウザの設定」セク
ション（2-39 ページ）のステップ 2 を参照してください。

グローバルな SNMP バージョン 3 クレデンシャルの設定

グローバルな SNMP バージョン 3 クレデンシャルを設定する場合は、[グローバル設定] セク
ションで、デフォルトの通信に使用する SNMPv3 ユーザおよびパスワードを入力します（図 2-38 
を参照）。コミュニティ ストリングの形式については、「NNM MIB ブラウザの設定」セクション

（2-39 ページ）のステップ 2 を参照してください。

図 2-38 SNMP の設定
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特定の SNMP バージョン 3 クレデンシャルの設定

特定の SNMP バージョン 3 クレデンシャルを設定する場合は、[Specific Nodes] タブ（図 2-39 を
参照）をクリックして、個々の SNMP ノードに対する SNMP バージョン 3 ユーザおよびパスワー
ドを入力します。

図 2-39 [SNMP Configuration] ダイアログボックス

ノード情報の表示

ノード情報を表示する手順は次のとおりです。

ステップ 1 インターネット マップから特定のノードへドリルダウンし、使用可能なインターフェイスをす
べて表示します。

ステップ 2 さらにインターフェイス情報を表示する場合は、いずれかのインターフェイスを右クリックし、
[Interface Properties] または [Interface Status] を選択します。

[Network Interface Properties] ダイアログボックスが表示されます（図 2-40 を参照）。
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図 2-40 [Network Interface Properties] ダイアログボックス

NNM MIB ブラウザの設定

NNM MIB ブラウザを設定する手順は次のとおりです。

ステップ 1 NNM サーバのコマンド プロンプトから、C:\Program Files\HP OpenView\bin にある xnmbrowser.exe 
を実行して MIB ブラウザを起動します。

ステップ 2 SNMP ホストの IP アドレスおよびコミュニティ ストリングを入力します。SNMP バージョン 3 
接続の場合、コミュニティ ストリングには、オーバーロードされたコミュニティ ストリングの
構文が使用されます。

次に示すのは、オーバーロードされたコミュニティ ストリングに使用される構文の例です。

SNMPv3 noAuthNoPriv
3N[/KEEP]/[ [contextEngineID] [-contextName]/ ]username
SNMPv3 authNoPriv
3A[;[MD5ˆ|SHAˆ]authKey[/KEEP]]/[ [contextEngineID] [-contextName]/
]username
SNMPv3 authPriv
3P[;[MD5ˆ|SHAˆ]authKey[;[DESˆ|AESˆ|3DESˆ]privKey][/KEEP]]/[
[contextEngineID] [-contextName]/ ]username
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（注） デフォルトの認証方式は MD5、デフォルトの暗号化方式は DES です。

この項では、次のトピックについて取り上げます。

• SNMP バージョン 3 の No-auth/No-priv 接続の設定（2-40 ページ）

• SNMP バージョン 3 の MD5 Auth/No-priv 接続の設定（2-40 ページ）

• SNMP バージョン 3 の SHA Auth/No-priv 接続の設定（2-40 ページ）

• SNMP バージョン 3 の MD5 Auth/Priv 接続の設定（2-41 ページ）

• SNMP バージョン 3 の SHA Auth/Priv 接続の設定（2-41 ページ）

• MIB の参照（2-41 ページ）

• MIB ブラウザのパケット トレースの実行（2-42 ページ）

• NNM SNMP バージョン 3 トラップ ビューアの使用方法（2-43 ページ）

SNMP バージョン 3 の No-auth/No-priv 接続の設定

SNMP バージョン 3 の No-auth/No-priv 接続を設定する手順は次のとおりです。

ステップ 1 UUT グループを設定するため、snmp-server group asanoauth v3 noauth コマンドを入力します。

ステップ 2 UUT ユーザを設定するため、snmp-server user titannoauth asanoauth v3 コマンドを入力します。

ステップ 3 コミュニティ名として、3N/titannoauth と入力します。

SNMP バージョン 3 の MD5 Auth/No-priv 接続の設定

SNMP バージョン 3 の MD5 Auth/No-priv 接続を設定する手順は次のとおりです。

ステップ 1 UUT グループを設定するため、snmp-server group asaauth v3 auth コマンドを入力します。

ステップ 2 UUT ユーザを設定するため、snmp-server user titanauth asaauth v3 auth md5 authpass コマンド
を入力します。

ステップ 3 コミュニティ名として、3A:authpass/titanauth と入力します。

SNMP バージョン 3 の SHA Auth/No-priv 接続の設定

SNMP バージョン 3 の SHA Auth/No-priv 接続を設定する手順は次のとおりです。

ステップ 1 UUT グループを設定するため、snmp-server group asaauth v3 auth コマンドを入力します。

ステップ 2 UUT ユーザを設定するため、snmp-server user titanshaauth asaauth v3 auth sha authpass コマン
ドを入力します。

ステップ 3 コミュニティ名として、3A:SHA^authpass/titanshaauth と入力します。
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SNMP バージョン 3 の MD5 Auth/Priv 接続の設定

SNMP バージョン 3 の MD5 Auth/Priv 接続を設定する手順は次のとおりです。

ステップ 1 UUT グループを設定するため、snmp-server group asapriv v3 priv コマンドを入力します。

ステップ 2 UUT ユーザを設定するため、snmp-server user titandes asapriv v3 auth md5 authpass priv des 
privpass コマンドを入力します。

ステップ 3 コミュニティ名として、次のいずかを入力します。

• 3P:authpass:privpass/titandes

• 3P:MD5^authpass:DES^privpass/titandes

SNMP バージョン 3 の SHA Auth/Priv 接続の設定

SNMP バージョン 3 の SHA Auth/Priv 接続を設定する手順は次のとおりです。

ステップ 1 UUT グループを設定するため、snmp-server group asapriv v3 priv コマンドを入力します。

ステップ 2 UUT ユーザを設定するため、snmp-server user titanshades asapriv v3 auth sha authpass priv des 
privpass コマンドを入力します。

ステップ 3 コミュニティ名として、3P:SHA^authpass:DES^privpass/titanshades と入力します。

MIB の参照

MIB を参照する手順は次のとおりです。

ステップ 1 目的の OID（.iso.org.dod.internet.mgmt.mib-2.system）までドリルダウンし、system オブジェクト
を選択します。

ステップ 2 [Start Query] をクリックして、[MIB Values] フィールドに DUT の説明を入力します（図 2-41 を
参照）。
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図 2-41 [Browse MIB] ダイアログボックス

MIB ブラウザのパケット トレースの実行

MIB ブラウザのパケットトレースを実行する場合は、[MIB Browser] ダイアログボックスで、
[View] > [SNMP Packet Trace] を選択します。

[Messages] ダイアログボックス（図 2-42 を参照）が開き、MIB ブラウザと SNMP エージェントと
の間で行われる SNMP 通信のパケットの内容が表示されます。この情報は、デバッグを実行する
際に有用です。
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図 2-42 [Messages] ダイアログボックスでのパケット トレース

NNM SNMP バージョン 3 トラップ ビューアの使用方法

NNM SNMP バージョン 3 トラップ ビューアを使用する場合の操作手順は次のとおりです。

ステップ 1 SNMP エージェント上のユーザの SNMP バージョン 3 クレデンシャルが、NNM にキャッシュさ
れていることを確認します。

ステップ 2 MIB ブラウザを使用して SNMP エージェントに照会する場合は、次のようなコミュニティ スト
リングを入力します。

3P:authpass:privpass/KEEP/titandes 

（注） オーバーロードされたコミュニティストリングの中で KEEP パラメータを使用するこ
とにより、ユーザの資格情報を NNM コンフィギュレーション ファイル内に保存するこ
とができます。SNMP エージェントから NNM へセキュアな SNMP バージョン 3 トラッ
プおよび inform 要求を送信し、かつ認証を必ず実行するためには、この操作は必須です。
このコンフィギュレーション ファイルにはユーザ情報が保持されています。ファイルの
保存場所は C:\etc\srconf\mgr\mgr.cnf です。このファイルの内容は直接修正できます。手
順については、NNM SPI SNMP Version 7.53 のマニュアルを参照してください。

また、次の例のように、snmpget コマンドを使用することもできます。

C:\Program Files\HP OpenView\bin>snmpget -c “3P;MD5^authpass;DES^privpass/KEEP/titandes” 
10.0.0.33 sysDescr.0
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ステップ 3 SNMP エージェントを使用してトラップを送信する場合は、ASA で次のコマンドを入力します。

cicoasa (config)# snmp-server host inside 10.0.0.10 traps version 3 titandes

（注） コマンドの構文は、ASA のプラットフォームによって若干異なります。この例の中で設
定されたユーザは、「NNM MIB ブラウザの設定」セクション（2-39 ページ）でコミュニ
ティ ストリングを使用して定義したユーザと同じです。

NNM traprcv ユーティリティは、リモート SNMP エンティティから送信される SNMP トラップ 
メッセージの受信、および SNMP inform 要求への応答を行うためのコマンドライン ツールです。
このユーティリティは、通知をリッスンするため SNMP トラップ ポート（udp/162）にバインドさ
れています。そのため、root として実行する必要があります。また受信した通知に関しては標準
的な出力メッセージを出力します。traprcv ユーティリティでは、SNMP バージョン 1 トラップ、
SNMP バージョン 2c トラップ、SNMP バージョン 2c inform 要求、SNMP バージョン 3 トラップ、
および SNMP バージョン 3 inform 要求を受信できます。詳細については、NNM SPI SNMP Version 
7.53 のマニュアルを参照してください。

ステップ 4 traprcv ユーティリティを実行し、SNMP エージェント上でトラップが送達されるのを待機しま
す。このユーティリティの実行ファイルは、C:\Program Files\HP OpenView\snmpv3\utils\traprcv.exe 
です（図 2-43 を参照）。

図 2-43 SNMP トラップ レシーバ

HP OpenView NNM Web アプリケーションの使用方法

NNM Web アプリケーションを起動する手順は次のとおりです。

ステップ 1 Web ブラウザから、次の URL にアクセスします。

http://<NNM サーバの IP アドレス>:7510/topology/home

ステップ 2 SNMP ノードを表示するため、ドロップダウンメニューから [Internet View] を選択します
（図 2-44 を参照）。

[Internet View] ウィンドウが表示されます（図 2-45 を参照）。
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図 2-44 [NNM Home Base] ウィンドウ

ステップ 3 ノードのプロパティを表示するため、選択したノードをダブルクリックします。ブラウザ ウィン
ドウが開き、ノード情報が表示されます。
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図 2-45 [Internet View] ウィンドウ

CiscoWorks
CiscoWorks LAN Management Solution（LMS）は、Cisco ネットワークの設定、管理、モニタリング、
およびトラブルシューティングの作業を簡素化するための強力な管理ツール スイートです。詳
細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/sw/cscowork/ps2425/index.html

この項では、次のトピックについて取り上げます。

• CiscoWorks の起動（2-47 ページ）

• CiscoWorks LMS Portal の概要（2-48 ページ）

• Device Center の使用方法（2-48 ページ）

• SNMP ウォークの実行（2-49 ページ）

• Management Station to Device ツールの使用方法（2-54 ページ）
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CiscoWorks の起動

Windows 2003 サーバ上で CiscoWorks を起動する手順は次のとおりです。

[Start] > [All Programs] > [CiscoWorks] > [CiscoWorks] を選択します。図 2-46 は、ログイン ページ
を示したものです。

図 2-46 ログイン ページ
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CiscoWorks LMS Portal の概要

CiscoWorks LMS Portal は、LMS アプリケーションの起動時に表示される最初のページです
（図 2-47 を参照）。このページは、アプリケーションの中で頻繁に使用する機能へのインターフェ
イスであり、それらの使用開始画面としての役割を持っています。

図 2-47 [CiscoWorks LMS Portal] ページ

Device Center の使用方法

デバイスを管理する手順は次のとおりです。

ステップ 1 [Device Diagnostic Tools] > [Device Center] を選択します（図 2-48 を参照）。

[Device Center Home] ページが開き、左側ペインに [Device Selector]、右側ペインに Device Center 
のサマリー情報が表示されます。

ステップ 2 [Device Selector] ペインで、IP アドレスまたはデバイス名を入力するか、あるいはリストからデ
バイスを選択して、[Go] をクリックします。
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図 2-48 [Device Center Home] ウィンドウ

SNMP ウォークの実行

SNMP ウォークを実行する手順は次のとおりです。

ステップ 1 [Functions Available] ペインで、[SNMP Walk] リンクをクリックします。

[SNMP Walk] ダイアログボックスが表示されます（図 2-49 を参照）。
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図 2-49 [SNMP Walk] ダイアログボックス

ステップ 2 次の中から、使用する SNMP のバージョンを選択します。

• SNMP バージョン 3（セキュリティ レベルが NoAuthNoPriv および AuthNoPriv）の場合

a. SNMPv3 ユーザ名を入力します。

b. SNMPv3 認証パスワードを入力します。

c. ドロップダウン リストから SNMP v3 認証プロトコル（MD5 または SHA）を選択します。

d. SNMP コンテキスト名を入力します。

（注） ASA ではコンテキストがサポートされていません。そのため、[SNMP Context Name] 
は空欄にしておく必要があります。

• SNMP バージョン 3（セキュリティ レベルが AuthPriv）の場合

a. SNMPv3 ユーザ名を入力します。

b. SNMPv3 認証パスワードを入力します。

c. SNMP v3 認証プロトコルを指定します。MD5 と SHA のどちらかを選択します。

d. プライバシー パスワードを入力します。

e. ドロップダウン リストからプライバシー プロトコルを選択します。DES、トリプル DES、
AES128、AES192、AES256 のいずれかを選択できます。

f. SNMP コンテキスト名を入力します。
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（注） ASA ではコンテキストがサポートされていません。そのため、[SNMP Context Name] 
は空欄にしておく必要があります。

g. （任意）開始 OID を入力します。このフィールドを空にした場合は 1 から開始されます。

h. SNMP タイムアウト時間を入力します。デフォルト値は 10 秒です。

i. （任意）出力される OID を数値として表示する場合は、[Output OIDs Numerically] チェック
ボックスをオンにします。

j. デフォルトの場合、出力ウィンドウには対応する OID 名が表示されます。

k. （任意）出力されるインデックスを数値として出力する場合は、[Output Indexes Numerically] 
チェックボックスをオンにします。

l. （任意）デバッグオプションを有効にする場合は、[Debug] チェックボックスをオンにします。
これらのフィールドに入力する文字列はすべて、大文字と小文字が区別されます。

m. [OK] をクリックすると、入力したパラメータに基づく結果を取得できます。

n. ウォークが完了したら、その結果をテキスト ファイルとして保存します（図 2-50 を参照）。

（注） 完全なウォークを実行すると、完了するまでに時間がかかる場合があります。

図 2-50 SNMP ウォークの結果例
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SNMP バージョン 3 の read/write ユーザ名およびパスワードと、SNMP バージョン 1 および 2c の 
read/write コミュニティ ストリングはどちらも、大文字と小文字が区別されます。Device and 
Credential Repository（DCR）にあるデバイス クレデンシャル（SNMP バージョン 1、2c、および 3）
が使用可能であれば、それらが [SNMP Walk] ダイアログボックスに表示されます。使用可能でな
い場合は、各 SNMP バージョンに対するデフォルト値が表示されます。

Network Operator/Help Desk アクセス権限で SNMP ウォーク機能を使用すると、デバイス クレデ
ンシャルのフェッチは失敗し、SNMP バージョン 1、2c、および 3 に対応する read/write コミュニ
ティ ストリングの各フィールドにはデフォルト値が設定されます。

図 2-49 は、サポートされているプライバシー プロトコルのリストを示したものです。SNMP バー
ジョン 1、2c、および 3 のクレデンシャルは、手動で入力する必要があります（図 2-52 を参照）。

図 2-51 [SNMP Walk] ダイアログボックス
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図 2-52 SNMP バージョン 3 のパラメータ

図 2-53 は、MD5 認証および AES256 暗号化アルゴリズムの設定に関する SNMP ウォークの結果
を示したものです。

図 2-53 [SNMP Walk Results] ダイアログボックス
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Management Station to Device ツールの使用方法

管理対象外のデバイスや応答のないデバイスに関するトラブルシューティングを行う場合、デ
バイスの接続をプロトコルごとにチェックすることがあります。Management Station to Device 
ツールを使用すると、レイヤ 4（アプリケーション）の接続の問題点を診断することが可能です。

レイヤ 4 のテストは、ネットワーク デバイスの管理に欠くことのできない次のようなサービス
要素を対象とします。

• デバッグ ツールおよび測定ツール（UDP および TCP）

• Web サーバ（HTTP）

• ファイル転送（TFTP）

• 端末（Telnet）

• 読み取り/書き込みアクセス (SNMP)

Management Station to Device ツールによるチェックの対象となるのは、プロトコルの接続のみで
す。対応するプロトコルのクレデンシャルは、テストや検証の対象にはなりません。IP アドレス
ではなくホスト名を入力すると、アドレスを特定するため名前検索が実行されます。アドレスが
特定できないと、このタスクは失敗します。

このツールを使用すると、SNMP 読み取りテスト（SNMPR）を行う場合に、宛先デバイスに SNMP 
の get 要求を送信することができます。また、SNMP 書き込みテスト（SNMPW）を行う場合には、
宛先デバイスに SNMP の set 要求を送信することもできます。このプロトコルは、SNMP バー
ジョン 1、2c、および 3 に対してサポートされています。

Network Operator/Help Desk アクセス権限で Management Station to Device ツールを起動すると、
デバイス クレデンシャルのフェッチは失敗し、SNMP バージョン 1、2c、および 3 に対応する 
read/write コミュニティ ストリングの各フィールドにはデフォルト値が設定されます。SNMP 
バージョン 1、2c、および 3 のクレデンシャルは、手動で入力する必要があります。

Management Station to Device ツールを起動する手順は次のとおりです。

ステップ 1 [Device Diagnostic Tools] > [Device Center] を選択します。

ステップ 2 チェックの対象となるデバイスの名前または IP アドレス、完全修飾ドメイン名、またはホスト名
を [Device Selector] フィールドに入力するか、またはチェックの対象となるデバイスをリストか
ら選択し、[Go] をクリックします。

[Summary] ペインおよび [Functions Available] ペインが表示されます。

ステップ 3 [Functions Available] ペインで [Management Station to Device] をクリックします。

[Management Station to Device] ダイアログボックスが表示されます（図 2-54 を参照）。
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図 2-54 [Management Station to Device] ダイアログボックス

ステップ 4 次の中から、対象とする接続アプリケーションを選択します。これらのフィールドに入力する文
字列はすべて、大文字と小文字が区別されます。

• SNMP v3（セキュリティ レベルが NoAuthNoPriv）を選択した場合は、次の情報を入力します。

– read ユーザ名。

– write ユーザ名。

– タイムアウト（秒単位）。デフォルト値は 2 秒です。

• SNMP v3（セキュリティ レベルが AuthNoPriv）を選択した場合は、次の情報を入力します。

– read ユーザ名。

– read 認証パスワード。

– read 認証プロトコル。ドロップダウン リストから MD5 と SHA のどちらかを選択します。

– write ユーザ名。

– write 認証パスワード。

– write 認証プロトコル。ドロップダウン リストから MD5 または SHA を選択します。

– タイムアウト（秒単位）。デフォルト値は 2 秒です。

• SNMP v3（セキュリティ レベルが AuthPriv）を選択した場合は、次の情報を入力します。

– read ユーザ名。

– read 認証パスワード。

– read 認証プロトコル。ドロップダウン リストから MD5 または SHA を選択します。

– read プライバシー パスワード。
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– read プライバシー プロトコル。ドロップダウン リストからプライバシー プロトコルを
選択します。DES、トリプル DES、AES128、AES192、AES256 のいずれかを選択できます。

– write ユーザ名。

– write 認証パスワード。

– write 認証プロトコル。ドロップダウン リストから MD5 または SHA を選択します。

– write プライバシー パスワード。

– write プライバシー プロトコル。ドロップダウン リストからプライバシー プロトコルを
選択します。DES、トリプル DES、AES128、AES192、AES256 のいずれかを選択できます。

– タイムアウト（秒単位）。デフォルト値は 2 秒です。

[Interface Test Results] ダイアログボックスに結果が表示されます（図 2-55 を参照）。[Interface 
Details Results] ダイアログボックスには、テスト済みのインターフェイスおよびテスト結果がオ
プションごとに表示されます。

（注） SNMP バージョン 3 の read/write ユーザ名およびパスワードと、SNMP バージョン 1 およ
び 2c の read/write コミュニティ ストリングはどちらも、大文字と小文字が区別されます。

図 2-55 [Management Station Device Results] ダイアログボックス
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