内容

概要

このドキュメントでは、Cisco Jabber for Windowsにログインしようとしたときに発生する問題について説明し、この問題の解決策を示します。

前提条件

要件

次の項目に関する知識があることが推奨されます。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。

問題

Cisco Jabber for Windowsにログインしようとすると、[Connecting]でプログラムがハングします。

原因

このシナリオでは、Cisco Jabberがサーバに接続できません。 Cisco JabberのログインサーバのIPアドレスが入力されますが、CUPSノード名はIPアドレスではなくホスト名として設定され、そのホスト名は解決できません。CUPSノード名を確認するには、[Admin Page] > [System] > [Cluster Topology] に移動します。次のログに示すように、CUPSのIPアドレスを入力しても、Cisco Jabberはホスト名への接続を試行します。

2012-05-01 11:18:52,937 INFO  [0x00000e88] [ied\featuresets\adapters\imp\Log.cpp(33)]
[JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: login, jabber, serv:
2012-05-01 11:18:52,937 DEBUG [0x00000e88] [ied\featuresets\adapters\imp\Log.cpp(32)]
[JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CXmppClientMgr::SignOn
2012-05-01 11:18:52,937 DEBUG [0x00000e88] [ied\featuresets\adapters\imp\Log.cpp(32)]
[JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::SignOn
2012-05-01 11:18:52,937 DEBUG [0x00000e88] [ied\featuresets\adapters\imp\Log.cpp(32)]
[JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: Connect result is:1

解決方法

CUPS完全修飾ドメイン名(FQDN)を解決し、ワークステーションがActive Directory(AD)ドメインの一部であることを確認するには、ドメインネームサーバ(DNS)エントリに問い合わせてください。ワークステーションがドメインに属していない場合、ホスト名は解決できません。FQDNのみがADドメインの一部である場合は、ワークステーションをドメインの一部にするか、ワークステーションにローカルホストエントリを作成する必要があります。これを行うには、C:\WINDOWS\system32\drivers\etcにある「hosts」ファイルを編集し、Cisco Jabber for Windowsに再ログインします。

防止

DNSにCUPS FQDNのエントリがある場合は、Cisco Jabber for Windowsが展開されているワークステーションがADドメインの一部であることを確認します。