Cisco MWR 2941-DC Mobile Wireless Edge Router Software Configuration Guide
Appendix B
Downloads: This chapterpdf (PDF - 427.0KB) The complete bookPDF (PDF - 2.66MB) | Feedback

Configuration Examples

Table Of Contents

Configuration Examples

Examples

Asymmetric PWE3 Configuration

PWE3 Redundancy Configuration

TDM over MPLS Configuration

ATM over MPLS Configuration

GSM-Only Configuration

GSM-Only Configuration Using Satellite

GSM Congestion Management


Configuration Examples


The Cisco MWR 2941-DC supports a variety of topology designs based on various GSM configurations, including the following common topologies:

A backhaul interface is used to transfer optimized GSM traffic between RAN-O devices. The traditional backhaul interface is comprised of one or more T1/E1 controllers logically combined to form a multilink connect (except HSDPA, which uses the backhaul interface for T1/E1 line clocking).

A shorthaul interface is used to transfer GSM traffic from the BTS/Node-B to the Cisco MWR 2941-DC router and from the Cisco MWR 2941-DC router to the BSC/RNC. The traditional shorthaul connections on the RAN-O devices are connected through the Cisco T1/E1 interface card.

Topology naming conventions such as 3x2 and 4x3 are used to describe the type of deployment. The first number signifies the number of GSM shorthaul interface connections and the second number signifies the number of multilink backhaul interface connections.

Examples

This appendix includes examples of the following real-world RAN-O configurations:


Note The Cisco MWR 2941-DC does not currently support L2TP as shown in some of the following examples.


Asymmetric PWE3 Configuration

PWE3 Redundancy Configuration

TDM over MPLS Configuration

ATM over MPLS Configuration

GSM-Only Configuration

GSM-Only Configuration Using Satellite

GSM Congestion Management


Note The network addresses in these examples are generic addresses, so you must replace them with actual addresses for your network.


Asymmetric PWE3 Configuration

The following example shows an Asymmetric PWE3 configuration (Figure B-1).

Figure B-1 Asymmetric PWE3 Configuration

PE_1

version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname MWR1
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 2147483
!
no aaa new-model
memory-size iomem 25
!
network-clock-select 1 E1 1/3
!
ipran-alt-interrupt tracing
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
!
!
controller E1 0/0
 clock source internal
 cem-group 1 unframed
!
controller E1 0/1
 clock source internal
 cem-group 20 unframed
!
controller E1 0/2
 clock source internal
 cem-group 12 unframed
 description connected to E1 4/0 of BERT
!
controller E1 0/3
 clock source internal
 cem-group 30 unframed
!
controller E1 0/4
 clock source internal
 cem-group 8 unframed
!
controller E1 0/5
 clock source internal
 cem-group 25 unframed
!
controller E1 1/0
 mode  aim 1
 clock source internal
!
controller E1 1/1
 mode  aim 1
 clock source internal
!
controller E1 1/2
 mode  aim 1
 clock source internal
!
controller E1 1/3
!
!
pseudowire-class mpls
 encapsulation mpls
 preferred-path peer 50.0.0.2 
!
pseudowire-class l2tp
 encapsulation mpls
 ip protocol udp
 ip local interface Loopback50
!
!
class cem cemclass
 payload-size 32
!
class cem cemclass1
 dejitter-buffer 400
!
! 
!
!
!
!
!
interface Loopback50
 ip address 50.0.0.1 255.255.255.255
!
interface CEM0/0
 no ip address
 cem 1
  xconnect 50.0.0.2 1 encapsulation mpls
 !
!
interface GigabitEthernet0/0
 ip address 20.0.0.1 255.0.0.0
 load-interval 30
 duplex auto
 speed auto
 mpls label protocol ldp
 mpls ip
!
interface CEM0/1
 no ip address
 cem 20
  xconnect 50.0.0.2 2 encapsulation mpls
!
interface GigabitEthernet0/1
 ip address 60.0.0.1 255.0.0.0
 duplex auto
 speed auto
 mpls ip
!
interface CEM0/2
 no ip address
 cem 12
  xconnect 50.0.0.2 3 encapsulation mpls
 !
!
interface CEM0/3
 no ip address
 cem 30
  xconnect 50.0.0.2 4 encapsulation mpls
!
interface CEM0/4
 no ip address
 cem 8
  xconnect 50.0.0.2 5 encapsulation mpls
 !
!
interface CEM0/5
 no ip address
 cem 25
  xconnect 50.0.0.2 6 encapsulation mpls
 !
!
interface ATM0/IMA0
 no ip address
 load-interval 30
  mcpt-timers 2000 6000 10000 
 no  ilmi-keepalive
 pvc 1/10 l2transport
  xconnect 50.0.0.2 101 encapsulation mpls
 !
 pvc 1/11 l2transport
  xconnect 50.0.0.2 102 pw-class mpls
 !
 pvc 1/21 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 2
  xconnect 50.0.0.2 111 encapsulation mpls
 !
 pvc 1/22 l2transport
  encapsulation aal0
  cell-packing 18 mcpt-timer 3
  xconnect 50.0.0.2 112 encapsulation mpls
 !
!
interface ATM0/IMA0.1 point-to-point
 no snmp trap link-status
 pvc 1/12 l2transport
  xconnect 50.0.0.2 103 encapsulation mpls
 !
!
interface ATM0/IMA0.2 multipoint
 no snmp trap link-status
  cell-packing 20 mcpt-timer 2
 xconnect 50.0.0.2 104 pw-class mpls
 pvc 1/13 l2transport
  encapsulation aal0
 !
 pvc 1/14 l2transport
  encapsulation aal0
 !
!
interface ATM0/IMA0.3 point-to-point
 no snmp trap link-status
 pvc 1/15 l2transport
  encapsulation aal0
  cell-packing 10 mcpt-timer 3
  xconnect 50.0.0.2 105 pw-class mpls
 !
!
interface ATM0/IMA0.4 point-to-point
 no snmp trap link-status
 pvc 1/16 l2transport
  encapsulation aal0
  cell-packing 14 mcpt-timer 3
  xconnect 50.0.0.2 106 pw-class mpls one-to-one
!
interface ATM0/IMA0.6 multipoint
 no snmp trap link-status
 pvc 1/17 l2transport
  xconnect 50.0.0.2 107 pw-class mpls
 !
 pvc 1/18 l2transport
  encapsulation aal0
  xconnect 50.0.0.2 108 encapsulation mpls
 !
 pvc 1/19 l2transport
  encapsulation aal0
  cell-packing 12 mcpt-timer 1
  xconnect 50.0.0.2 109 encapsulation mpls
 !
!
interface ATM1/0
 no ip address
 load-interval 30
 scrambling-payload
  mcpt-timers 1000 5000 10000 
 no  ilmi-keepalive
 pvc 0/5 l2transport
  encapsulation aal0
  cell-packing 10 mcpt-timer 3
  xconnect 50.0.0.2 10 pw-class l2tp
!
 pvc 0/6 l2transport
  xconnect 50.0.0.2 20 pw-class l2tp
 !
 pvc 0/7 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 50.0.0.2 30 encapsulation mpls pw-class mpls one-to-one
 !
 pvc 0/8 l2transport
  xconnect 50.0.0.2 40 pw-class mpls
 !
 pvc 0/9 l2transport
  encapsulation aal0
  xconnect 50.0.0.2 50 pw-class mpls one-to-one
 !
!
interface ATM1/0.1 point-to-point
 no snmp trap link-status
 pvc 0/15 l2transport
  xconnect 50.0.0.2 13 pw-class mpls
 !
!
interface ATM1/0.2 multipoint
 no snmp trap link-status
  cell-packing 2 mcpt-timer 1
 xconnect 50.0.0.2 12 encapsulation mpls
 pvc 0/10 l2transport
  encapsulation aal0
 !
 pvc 0/11 l2transport
  encapsulation aal0
 !
 pvc 0/12 l2transport
  encapsulation aal0
 !
 pvc 0/13 l2transport
  encapsulation aal0
 !
!
interface ATM1/0.3 point-to-point
 no snmp trap link-status
 pvc 0/16 l2transport
  encapsulation aal0
  xconnect 50.0.0.2 14 encapsulation mpls
 !
!
interface ATM1/0.4 point-to-point
 no snmp trap link-status
 pvc 0/17 l2transport
  encapsulation aal0
  xconnect 50.0.0.2 15 pw-class mpls one-to-one
 !
!
interface ATM1/0.6 multipoint
 no snmp trap link-status
 pvc 0/26 l2transport
  xconnect 50.0.0.2 16 pw-class mpls
 !
 pvc 0/27 l2transport
  encapsulation aal0
  cell-packing 8 mcpt-timer 3
  xconnect 50.0.0.2 17 pw-class mpls
 !
 pvc 0/28 l2transport
  encapsulation aal0
  cell-packing 16 mcpt-timer 2
  xconnect 50.0.0.2 18 pw-class mpls
 !
!
interface ATM1/0.7 multipoint
 no snmp trap link-status
!
interface ATM1/1
 no ip address
 scrambling-payload
  mcpt-timers 1000 5000 10000 
 no  ilmi-keepalive
  cell-packing 20 mcpt-timer 2
 xconnect 50.0.0.2 11 encapsulation mpls
 pvc 0/21 l2transport
  encapsulation aal0
 !
 pvc 0/22 l2transport
  encapsulation aal0
 !
 pvc 0/23 l2transport
  encapsulation aal0
 !
!
interface ATM1/1.1 point-to-point
 no snmp trap link-status
!
interface ATM1/1.2 multipoint
 no snmp trap link-status
!
interface ATM1/2
 no ip address
 scrambling-payload
 ima-group 0
 no  ilmi-keepalive
!
ip route 9.10.0.254 255.255.255.255 9.11.49.254
ip route 30.0.0.0 255.0.0.0 GigabitEthernet0/0
ip route 50.0.0.2 255.255.255.255 20.0.0.2
ip route 50.0.0.5 255.255.255.255 20.0.0.2
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback50 force
!
!
!
!
!
alias exec cpu show proc cpu | i CPU
alias exec hist show proc cpu history
alias exec clc clear counters
alias exec cmpls clear mpls counters
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

PE_2

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MWR2
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 1000000
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 0/0
network-clock-select 2 E1 0/1
network-clock-select 3 E1 0/2
network-clock-select 4 E1 0/3
network-clock-select 5 E1 0/4
network-clock-select 6 E1 0/5
ipran-alt-interrupt tracing
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
!
!
controller E1 0/0
 cem-group 1 unframed
!
controller E1 0/1
 cem-group 20 unframed
!
controller E1 0/2
 cem-group 12 unframed
!
controller E1 0/3
 cem-group 30 unframed
!
controller E1 0/4
 cem-group 8 unframed
!
controller E1 0/5
 cem-group 25 unframed
!
controller E1 1/0
 mode  aim 1
 clock source internal
!
controller E1 1/1
 mode  aim 1
 clock source internal
!
controller E1 1/2
 mode  aim 1
 clock source internal
!
controller E1 1/3
 clock source internal
!
pseudowire-class mpls
 encapsulation mpls
 preferred-path peer 50.0.0.1 
!
pseudowire-class l2tp
 encapsulation l2tpv3
 ip protocol udp
 ip local interface Loopback50
!
!
class cem test
!
class cem cemclass
 payload-size 32
!
! 
!
!
!
!
!
interface Loopback50
 ip address 50.0.0.2 255.255.255.255
!
interface CEM0/0
 no ip address
 cem 1
  xconnect 50.0.0.1 1 encapsulation mpls
 !
!
interface GigabitEthernet0/0
 ip address 30.0.0.1 255.0.0.0
 duplex auto
 speed auto
 mpls ip
!
interface CEM0/1
 no ip address
 cem 20
  xconnect 50.0.0.1 2 encapsulation mpls
 !
!
interface GigabitEthernet0/1
 ip address 70.0.0.1 255.0.0.0
 duplex auto
 speed auto
 mpls ip
!
interface CEM0/2
 no ip address
 cem 12
  xconnect 50.0.0.1 3 encapsulation mpls
 !
!
interface CEM0/3
 no ip address
 cem 30
  xconnect 50.0.0.1 4 encapsulation mpls
 !
!
interface CEM0/4
 no ip address
 cem 8
  xconnect 50.0.0.1 5 encapsulation mpls
 !
!
interface CEM0/5
 no ip address
 cem 25
  xconnect 50.0.0.1 6 encapsulation mpls
 !
!
interface ATM0/IMA0
 no ip address
 load-interval 30
  mcpt-timers 2000 6000 10000 
 no  ilmi-keepalive
 pvc 1/10 l2transport
  xconnect 50.0.0.1 101 encapsulation mpls
 !
 pvc 1/11 l2transport
  xconnect 50.0.0.1 102 pw-class mpls
 !
 pvc 1/21 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 111 encapsulation mpls
 !
 pvc 1/22 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 112 encapsulation mpls
 !
!
interface ATM0/IMA0.1 point-to-point
 no snmp trap link-status
 pvc 1/12 l2transport
  xconnect 50.0.0.1 103 encapsulation mpls
 !
!
interface ATM0/IMA0.2 multipoint
 no snmp trap link-status
  cell-packing 15 mcpt-timer 3
 xconnect 50.0.0.1 104 pw-class mpls
 pvc 1/13 l2transport
  encapsulation aal0
 !
 pvc 1/14 l2transport
  encapsulation aal0
 !
!
interface ATM0/IMA0.3 point-to-point
 no snmp trap link-status
 pvc 1/15 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 105 pw-class mpls
 !
!
interface ATM0/IMA0.4 point-to-point
 no snmp trap link-status
 pvc 1/16 l2transport
  encapsulation aal0
  cell-packing 7 mcpt-timer 2
  xconnect 50.0.0.1 106 pw-class mpls one-to-one
 !
!
interface ATM0/IMA0.6 multipoint
 no snmp trap link-status
 pvc 1/17 l2transport
  xconnect 50.0.0.1 107 pw-class mpls
 !
 pvc 1/18 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 108 encapsulation mpls
 !
 pvc 1/19 l2transport
  encapsulation aal0
  cell-packing 9 mcpt-timer 3
  xconnect 50.0.0.1 109 encapsulation mpls
 !
!
interface ATM1/0
 ip address 1.1.1.2 255.0.0.0
 load-interval 30
 scrambling-payload
  mcpt-timers 1000 5000 10000 
 no  ilmi-keepalive
 pvc 0/5 l2transport
  encapsulation aal0
  cell-packing 25 mcpt-timer 3
  xconnect 50.0.0.1 10 pw-class l2tp
 !
 pvc 0/6 l2transport
  xconnect 50.0.0.1 20 pw-class l2tp
 !
 pvc 0/7 l2transport
  encapsulation aal0
  cell-packing 12 mcpt-timer 2
  xconnect 50.0.0.1 30 encapsulation mpls pw-class mpls one-to-one
 !
 pvc 0/8 l2transport
  xconnect 50.0.0.1 40 pw-class mpls
 !
 pvc 0/9 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 50 pw-class mpls one-to-one
 !
 pvc 0/99 
  protocol ip 1.1.1.1 broadcast
  encapsulation aal5snap
 !
!
interface ATM1/0.1 point-to-point
 no snmp trap link-status
 pvc 0/15 l2transport
  xconnect 50.0.0.1 13 pw-class mpls
 !
!
interface ATM1/0.2 multipoint
 no snmp trap link-status
  cell-packing 10 mcpt-timer 2
 xconnect 50.0.0.1 12 encapsulation mpls
 pvc 0/10 l2transport
  encapsulation aal0
 !
 pvc 0/11 l2transport
  encapsulation aal0
 !
 pvc 0/12 l2transport
  encapsulation aal0
 !
 pvc 0/13 l2transport
  encapsulation aal0
 !
!
interface ATM1/0.3 point-to-point
 no snmp trap link-status
 pvc 0/16 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 14 encapsulation mpls
 !
!
interface ATM1/0.4 point-to-point
 no snmp trap link-status
 pvc 0/17 l2transport
  encapsulation aal0
  xconnect 50.0.0.1 15 pw-class mpls one-to-one
 !
!
interface ATM1/0.6 multipoint
 no snmp trap link-status
 pvc 0/26 l2transport
  xconnect 50.0.0.1 16 pw-class mpls
 !
 pvc 0/27 l2transport
  encapsulation aal0
  cell-packing 18 mcpt-timer 3
  xconnect 50.0.0.1 17 pw-class mpls
 !
 pvc 0/28 l2transport
  encapsulation aal0
  cell-packing 24 mcpt-timer 2
  xconnect 50.0.0.1 18 pw-class mpls
 !
!
interface ATM1/0.7 multipoint
 no snmp trap link-status
!
interface ATM1/1
 no ip address
 scrambling-payload
  mcpt-timers 1000 5000 10000 
 no  ilmi-keepalive
  cell-packing 20 mcpt-timer 2
 xconnect 50.0.0.1 11 encapsulation mpls
 pvc 0/21 l2transport
  encapsulation aal0
 !
 pvc 0/22 l2transport
  encapsulation aal0
 !
 pvc 0/23 l2transport
  encapsulation aal0
 !
!
interface ATM1/2
 no ip address
 scrambling-payload
 ima-group 0
 no  ilmi-keepalive
!
ip route 9.10.0.254 255.255.255.255 9.11.49.254
ip route 20.0.0.0 255.0.0.0 GigabitEthernet0/0
ip route 50.0.0.1 255.255.255.255 70.0.0.2
ip route 50.0.0.5 255.255.255.255 70.0.0.2
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback50 force
!
!
!
!
!
alias exec cpu show proc cpu | i CPU
alias exec hist show proc cpu history
alias exec clc clear counters
alias exec cmpls clear mpls counters
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
end

PWE3 Redundancy Configuration

The following example shows a PWE3 Redundancy configuration (Figure B-2).

Figure B-2 PWE3 Redundancy Configuration

MWR_1

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr-pe1
!
boot-start-marker
boot-end-marker
!
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 10000000
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 1/2
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
!
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
archive
 log config
  hidekeys
!
!
controller E1 0/0
 clock source internal
 cem-group 0 unframed
!
controller E1 0/1
!
controller E1 0/2
!
controller E1 0/3
 clock source internal
!
controller E1 1/0
 mode  aim 1
 clock source internal
!
controller E1 1/1
!
controller E1 1/2
!
controller E1 1/3
 clock source internal
!
interface cem0/0
cem 0
 xconnect 2.2.2.2 1 encapsulation mpls
 backup peer 2.2.2.2 2 
 backup delay 20 20 
!
interface ATM1/0
 no ip address
 scrambling-payload
 no  ilmi-keepalive
 xconnect 2.2.2.2 3 encapsulation mpls
 backup peer 2.2.2.2 4 
 backup delay 20 20 
 pvc 0/1 l2transport
  encapsulation aal0
!
interface Loopback0
 no ip address
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 load-interval 30
!
interface Loopback101
 no ip address
!
!  
! 
! 
interface GigabitEthernet0/0.3
encapsulation dot1q 3
 xconnect 2.2.2.2 5 encapsulation mpls 
 backup peer 2.2.2.2 6
 backup delay 20 20 
! 
interface GigabitEthernet0/1
 ip address 9.9.9.6 255.255.255.0
 load-interval 30
 speed 100
 full-duplex
 mpls ip
!
!
ip forward-protocol nd
ip route 2.2.2.2 255.255.255.255  9.9.9.8 
!
ip http server
no ip http secure-server
!
!
snmp-server community public RO
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
exception data-corruption buffer truncate
!
end

MWR_2

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr-pe2
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 10000000
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip arp proxy disable
ip cef
!
!
!
!
no ip domain lookup
vlan ifdescr detail
l2tp-class l2tp
multilink bundle-name authenticated
mpls label protocol ldp
mpls ldp session protection
mpls oam
 echo revision 4
vpdn enable
!

!
!
!
archive
 log config
  hidekeys
!
!
controller E1 0/0
 cem-group 0 unframed
!
controller E1 0/1
 clock source internal
 cem-group 0 unframed 
!
controller E1 0/2
!
controller E1 0/3
 clock source internal
!
controller E1 0/4
 clock source internal
 !
controller E1 0/5
!
controller E1 1/0
 mode  aim 1
 clock source internal
!
controller E1 1/1
 clock source internal
 !
controller E1 1/2
 clock source internal
 !
controller E1 1/3
 mode  aim 1
 clock source internal
!
! Primary 
interface cem0/0 
cem 0
 xconnect 1.1.1.1 1 encapsulation mpls
!
! Backup 
interface cem0/1 
cem 0
 xconnect 1.1.1.1 2 encapsulation mpls
!
! Primary
interface ATM1/0
 no ip address
 scrambling-payload
 no  ilmi-keepalive
 xconnect 1.1.1.1 3 encapsulation mpls
 pvc 0/1 l2transport
  encapsulation aal0
 !
! Backup 
interface ATM1/3
no ip address
 scrambling-payload
 no  ilmi-keepalive
 xconnect 1.1.1.1 4 encapsulation mpls 
 pvc 0/1 l2transport
  encapsulation aal0
 !
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!

! Primary
interface GigabitEthernet0/0.3
encapsulation dot1q 3
xconnect 1.1.1.1 5 encapsulation mpls 
! 
! Backup
interface GigabitEthernet0/0.4 
encapsulation dot1q 4
xconnect 1.1.1.1 6 encapsulation mpls 
! 
!
!
interface GigabitEthernet0/1
 ip address 9.9.9.8 255.255.255.0
 load-interval 30
 speed 100
 full-duplex
 mpls ip
 no cdp enable
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255  9.9.9.6 
!
no ip http server
no ip http secure-server
!
!
snmp-server community private RW
snmp-server community public RO
snmp-server ifindex persist
snmp-server trap link ietf
no snmp-server sparse-tables
snmp-server queue-length 100
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps ipran
no cdp run
route-map test permit 10
 match mpls-label
!
!
!
mpls ldp router-id Loopback1 force
!
control-plane
!
no call rsvp-sync
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
exception data-corruption buffer truncate
!
end

TDM over MPLS Configuration

Figure B-3 shows a TDM over MPLS configuration. The configuration uses both SAToP and CESoPSN for E1 and T1.

Figure B-3 TDM over MPLS Configuration

MWR_A

!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service internal
!
hostname mwr_A
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type t1 0 2
enable password xxx
!
no aaa new-model
clock timezone est -5
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
controller E1 0/0
cem-group 0 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/1
clock source internal
cem-group 1 unframed
description E1 SATOP example
!
controller T1 0/4
framing esf
clock source internal
linecode b8zs
cem-group 4 unframed
description T1 SATOP example
!
controller T1 0/5
framing esf
clock source internal
linecode b8zs
cem-group 5 timeslots 1-24
description T1 CESoPSN example
!
controller E1 1/0
clock source internal
!
controller E1 1/1
!
interface Loopback0
ip address 30.30.30.1 255.255.255.255
!
interface CEM0/0
no ip address
cem 0
  xconnect 30.30.30.2 300 encapsulation mpls
!
!
interface GigabitEthernet0/0
duplex auto
speed auto
no cdp enable
!
interface CEM0/1
no ip address
cem 1
  xconnect 30.30.30.2 301 encapsulation mpls
!
!
interface GigabitEthernet0/1
ip address 50.50.50.1 255.255.255.0
duplex auto
speed auto
mpls ip
no cdp enable
!
interface CEM0/4
no ip address
cem 4
  xconnect 30.30.30.2 304 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 5
  xconnect 30.30.30.2 305 encapsulation mpls
!
!
no ip classless
ip route 30.30.30.2 255.255.255.255 50.50.50.2
!
no ip http server
no ip http secure-server
!
line con 0
password xxx
login
line aux 0
password xxx
login
no exec
line vty 0 4
password xxx
login
!
end

MWR_B

!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service internal
!
hostname mwr_B
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type t1 0 2
enable password xxx
!
no aaa new-model
clock timezone est -5
!
network-clock-select 1 E1 1/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
controller E1 0/0
clock source internal
cem-group 0 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/1
clock source internal
cem-group 1 unframed
description E1 SATOP example
!
controller T1 0/4
framing esf
clock source internal
linecode b8zs
cem-group 4 unframed
description T1 SATOP example
!
controller T1 0/5
framing esf
clock source internal
linecode b8zs
cem-group 5 timeslots 1-24
description T1 CESoPSN example
!
controller E1 1/0

!
controller E1 1/1
!
interface Loopback0
ip address 30.30.30.2 255.255.255.255
!
interface CEM0/0
no ip address
cem 0
  xconnect 30.30.30.1 300 encapsulation mpls
!
!
interface GigabitEthernet0/0
duplex auto
speed auto
no cdp enable
!
interface CEM0/1
no ip address
cem 1
  xconnect 30.30.30.1 301 encapsulation mpls
!
!
interface GigabitEthernet0/1
ip address 50.50.50.2 255.255.255.0
duplex auto
speed auto
mpls ip
no cdp enable
!
interface CEM0/4
no ip address
cem 4
  xconnect 30.30.30.1 304 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 5
  xconnect 30.30.30.1 305 encapsulation mpls
!
!
no ip classless
ip route 30.30.30.2 255.255.255.255 50.50.50.1
!
no ip http server
no ip http secure-server
!
line con 0
password xxx
login
line aux 0
password xxx
login
no exec
line vty 0 4
password xxx
login
!
end

ATM over MPLS Configuration

This example shows how to accomplish the following configurations (Figure B-4):

port mode PW on interface 0/0

AAL5 SDU mode PW on 0/1 PVC 0/100

N:1 VCC cell mode PW on 0/1 PVC 0/101

Multiple PVCs N:1 VCC cell mode PW on 0/1.1

1:1 VCC cell mode PW on 0/1 PVC 0/102

Cell-packing for port mode PWs

VCC cell-relay mode PWs

PVC mapping for 0/1.1 N:1 VCC cell relay PWs

Figure B-4 ATM over MPLS Configuration

MWR_A

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr_A
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
card type e1 1 0
logging buffered 4096
enable password lab
!
no aaa new-model
memory-size iomem 25
!
network-clock-select 1 E1 1/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip domain lookup
ip domain name cisco.com
multilink bundle-name authenticated
mpls label range 100 100000 static 16 99
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
!
!
controller E1 0/0
 mode  aim 1
 clock source internal
!
controller E1 0/1
 mode  aim 1
 clock source internal
!
controller E1 0/2
 mode  aim 1
 clock source internal
!
controller E1 0/3
 mode  aim 1
 clock source internal
!
controller E1 0/4
!
controller E1 0/5
!
controller E1 1/0
!
controller E1 1/1
!
pseudowire-class mpls-exp-5
 encapsulation mpls
 mpls experimental 5
!
!
! 
!
!
!
!
!
interface Loopback0
 ip address 88.88.88.88 255.255.255.255
!
interface ATM0/0
 no ip address
 scrambling-payload
  mcpt-timers 1000 2000 3000 
 no  ilmi-keepalive
  cell-packing 28 mcpt-timer 3
 xconnect 99.99.99.99 100 encapsulation mpls
 pvc 1/35 l2transport
  encapsulation aal0
 !
 pvc 1/36 l2transport
  encapsulation aal0
 !
 pvc 1/37 l2transport
  encapsulation aal0
 !
!
interface GigabitEthernet0/0
 ip address 172.18.52.129 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface ATM0/1
 no ip address
 load-interval 30
 scrambling-payload
  mcpt-timers 1000 2000 3000 
 no  ilmi-keepalive
 pvc 0/10 
 !
 pvc 0/100 l2transport
  encapsulation aal5
  xconnect 99.99.99.99 1100 encapsulation mpls
 !
 pvc 0/101 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 99.99.99.99 1101 encapsulation mpls
 !
 pvc 0/102 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 99.99.99.99 1102 encapsulation mpls
 !
 pvc 0/103 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 99.99.99.99 1103 pw-class mpls-exp-5
 !
!
interface ATM0/1.1 multipoint
 no snmp trap link-status
  cell-packing 28 mcpt-timer 3
 xconnect 99.99.99.99 1200 encapsulation mpls
 pvc 1/35 l2transport
  encapsulation aal0
  pw-pvc 2/135
 !
 pvc 1/36 l2transport
  encapsulation aal0
  pw-pvc 2/136
 !
 pvc 1/37 l2transport
  encapsulation aal0
  pw-pvc 2/137
 !
!
interface GigabitEthernet0/1
 description interface to 7600 fas 3/5
 ip address 2.2.2.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 no keepalive
!
interface ATM0/2
 no ip address
 scrambling-payload
 no  ilmi-keepalive
!
interface ATM0/3
 no ip address
 scrambling-payload
 no  ilmi-keepalive
!
interface ATM0/IMA1
 no ip address
 no  ilmi-keepalive
!
ip route 0.0.0.0 0.0.0.0 172.18.52.1
ip route 99.99.99.99 255.255.255.255 2.2.2.3
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
disable-eadi
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password lab
 no login
!
end

MWR_B

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr_B
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 4096
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip domain lookup
ip domain name cisco.com
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
!
!
controller E1 0/0
 mode  aim 1
!
controller E1 0/1
 mode  aim 1
!
controller E1 0/2
 mode  aim 1
!
controller E1 0/3
 mode  aim 1
!
controller E1 0/4
!
controller E1 0/5
!
pseudowire-class mpls-exp-5
 encapsulation mpls
 mpls experimental 5
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 99.99.99.99 255.255.255.255
!
interface ATM0/0
 no ip address
 scrambling-payload
  mcpt-timers 1000 2000 3000 
 no  ilmi-keepalive
  cell-packing 28 mcpt-timer 3
 xconnect 88.88.88.88 100 encapsulation mpls
 pvc 1/35 l2transport
  encapsulation aal0
 !
 pvc 1/36 l2transport
  encapsulation aal0
 !
 pvc 1/37 l2transport
  encapsulation aal0
 !
!
interface GigabitEthernet0/0
 ip address 172.18.52.130 255.255.255.0
 duplex auto
 speed auto
 keepalive 1
!
interface ATM0/1
 no ip address
 scrambling-payload
  mcpt-timers 1000 2000 3000 
 no  ilmi-keepalive
 pvc 0/2 
 !
 pvc 0/100 l2transport
  encapsulation aal5
  xconnect 88.88.88.88 1100 encapsulation mpls
 !
 pvc 0/101 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 88.88.88.88 1101 encapsulation mpls
 !
 pvc 0/102 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 88.88.88.88 1102 encapsulation mpls
 !
 pvc 0/103 l2transport
  encapsulation aal0
  cell-packing 28 mcpt-timer 3
  xconnect 88.88.88.88 1103 pw-class mpls-exp-5
 !
!
interface ATM0/1.1 multipoint
 no snmp trap link-status
  cell-packing 28 mcpt-timer 3
 xconnect 88.88.88.88 1200 encapsulation mpls
 pvc 2/135 l2transport
  encapsulation aal0
 !
 pvc 2/136 l2transport
  encapsulation aal0
 !
 pvc 2/137 l2transport
  encapsulation aal0
 !
!
interface GigabitEthernet0/1
 ip address 2.2.2.3 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface ATM0/2
 no ip address
 scrambling-payload
 ima-group 0
 no  ilmi-keepalive
!
interface ATM0/3
 no ip address
 scrambling-payload
 ima-group 0
 no  ilmi-keepalive
!
ip route 0.0.0.0 0.0.0.0 172.18.52.1
ip route 88.88.88.88 255.255.255.255 2.2.2.2
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
end

GSM-Only Configuration

The standard GSM topology includes one or more shorthaul interface connections from the BTS to a Cisco MWR 2941-DC through separate T1/E1 connections. The Cisco MWR 2941-DC routers are connected back-to-back using an MLPPP backhaul connection (two or more T1/E1 connections). At the BSC side, the Cisco MWR 2941-DC-to-BSC connectivity is exactly the same as the BTS-to-Cisco MWR 2941-DC connections. In this example, only GSM traffic traverses the topology (Figure B-5).

Figure B-5 GSM-Only Configuration

MWR_A

!
card type E1 0 0
card type E1 0 1
!
network-clock-select 1 E1 0/1
!
ipran-mib snmp-access inBand
ipran-mib location cellSite
!         
!         
controller E1 0/0
 framing NO-CRC4 
 clock source internal
 channel-group 0 timeslots 1-31
!         
controller E1 0/1
 channel-group 0 timeslots 1-31
!         
controller E1 0/2
 framing NO-CRC4 
 clock source internal 
 channel-group 0 timeslots 1-31	
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
  priority percent 99
class class-default
  bandwidth remaining percent 1
  queue-limit 45
!
interface Multilink1
ip address 10.10.10.1 255.255.255.252
load-interval 30
 no keepalive
 no cdp enable
 ppp pfc local request
 ppp pfc remote apply
 ppp acfc local request
 ppp acfc remote apply
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 0 1
 ppp multilink multiclass
 max-reserved-bandwidth 100
 service-policy output llq-policy
 hold-queue 50 out
 ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.1 4444
 gsm-abis remote 10.10.10.2 4444
 gsm-abis set dscp ef
 no keepalive
!
interface Serial0/1:0
 no ip address
 encapsulation ppp
 keepalive 1
 ppp multilink group 1
 max-reserved-bandwidth 100
!
interface Serial0/2:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.1 4446
 gsm-abis remote 10.10.10.2 4446
 gsm-abis set dscp ef
 no keepalive
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
no snmp-server sparse-table
snmp-server host 64.50.100.254 version 2c V2C 
disable-eadi

MWR_B

!
card type E1 0 0
card type E1 0 1
!
network-clock-select 1 E1 0/0
network-clock-select 2 E1 0/2
!
ipran-mib snmp-access outOfBand
ipran-mib location aggSite
! 
! 
controller E1 0/0
 framing NO-CRC4 
 channel-group 0 timeslots 1-31
!         
controller E1 0/1
 clock source internal 
 channel-group 0 timeslots 1-31
!         
controller E1 0/2
 framing NO-CRC4 
 channel-group 0 timeslots 1-31	
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
  priority percent 99
class class-default
  bandwidth remaining percent 1
  queue-limit 45
!
interface Multilink1
ip address 10.10.10.2 255.255.255.252
load-interval 30
 no keepalive
 no cdp enable
 ppp pfc local request
 ppp pfc remote apply
 ppp acfc local request
 ppp acfc remote apply
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 0 1
 ppp multilink multiclass
 max-reserved-bandwidth 100
 service-policy output llq-policy
 hold-queue 50 out
 ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.2 4444
 gsm-abis remote 10.10.10.1 4444
 gsm-abis set dscp ef
 no keepalive
!
interface Serial0/1:0
 no ip address
 encapsulation ppp
 keepalive 1
 ppp multilink group 1
 max-reserved-bandwidth 100
!
interface Serial0/2:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.2 4446
 gsm-abis remote 10.10.10.1 4446
 gsm-abis set dscp ef
 no keepalive
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
no snmp-server sparse-table
snmp-server host 64.50.100.254 version 2c V2C 
disable-eadi

GSM-Only Configuration Using Satellite

The GSM-only using satellite configuration allows for point-to-point network optimization (Figure B-6).

Figure B-6 GSM-Only Configuration Using Satellite

MWR_A

!
card type E1 0 0
!
network-clock-select 1 E1 0/1
!
ipran-mib snmp-access inBand
ipran-mib location cellSite
! 
! 
controller E1 0/0
 framing NO-CRC4 
 clock source internal
 channel-group 0 timeslots 1-20
! 
controller E1 0/1
 channel-group 0 timeslots 1-20
! 
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
  priority percent 99
class class-default
  bandwidth remaining percent 1
  queue-limit 45
!
interface Multilink1
ip address 10.10.10.1 255.255.255.252
load-interval 30
 no keepalive
 no cdp enable
 ppp pfc local request
 ppp pfc remote apply
 ppp acfc local request
 ppp acfc remote apply
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 0 1
 ppp multilink multiclass
 max-reserved-bandwidth 100
 service-policy output llq-policy
 hold-queue 50 out
 ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.1 4444
 gsm-abis remote 10.10.10.2 4444
 gsm-abis set dscp ef
 no keepalive
!
interface Serial0/1:0
 no ip address
 encapsulation ppp
 keepalive 1
 ppp multilink group 1
 max-reserved-bandwidth 100
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
no snmp-server sparse-table
snmp-server host 64.50.100.254 version 2c V2C 
disable-eadi

MWR_B

!
card type E1 0 0
!
network-clock-select 1 E1 0/0
!
ipran-mib snmp-access outOfBand
ipran-mib location aggSite
! 
! 
controller E1 0/0
 framing NO-CRC4 
 channel-group 0 timeslots 1-20
! 
controller E1 0/1
 clock source internal 
 channel-group 0 timeslots 1-20
! 
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
  priority percent 99
class class-default
  bandwidth remaining percent 1
  queue-limit 45
!
interface Multilink1
ip address 10.10.10.2 255.255.255.252
load-interval 30
 no keepalive
 no cdp enable
 ppp pfc local request
 ppp pfc remote apply
 ppp acfc local request
 ppp acfc remote apply
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 0 1
 ppp multilink multiclass
 max-reserved-bandwidth 100
 service-policy output llq-policy
 hold-queue 50 out
 ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.2 4444
 gsm-abis remote 10.10.10.1 4444
 gsm-abis set dscp ef
 no keepalive
!
interface Serial0/1:0
 no ip address
 encapsulation ppp
 keepalive 1
 ppp multilink group 1
 max-reserved-bandwidth 100
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
no snmp-server sparse-table
snmp-server host 64.50.100.254 version 2c V2C 
disable-eadi

GSM Congestion Management

These examples show how to configure GSM congestion management for the BTS side and the BSC side.

BTS side

interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.1 4444
 gsm-abis remote 10.10.10.2 4444
 gsm-abis congestion enable
 gsm-abis congestion critical 1-10
 gsm-abis congestion critical 31
 gsm-abis set dscp ef
 no keepalive

BSC side

interface Serial0/0:0
 no ip address
 encapsulation gsm-abis
 gsm-abis local 10.10.10.2 4444
 gsm-abis remote 10.10.10.1 4444
 gsm-abis congestion enable
 gsm-abis congestion critical 1-10
 gsm-abis congestion critical 31
 gsm-abis set dscp ef
 no keepalive