Guest

Cisco MWR 2900 Series Mobile Wireless Routers

Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3

  • Viewing Options

  • PDF (207.5 KB)
  • Feedback
Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3

Table Of Contents

Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3

Contents

Introduction

System Requirements

Memory Requirements

Determining the Software Version

Upgrading to a New Software Release

New and Changed Information

New Features in the Cisco IOS Release 12.4(19)MR3 Software

New Features in the Cisco IOS Release 12.4(19) MR2 Software

Limitations and Restrictions

Supported Hardware—Cisco MWR 2941-DC Router

Supported MIBs

Caveats

Caveats in Cisco IOS Release 12.4(19)MR3

Open Caveats

Resolved Caveats

Caveats in Cisco IOS Release 12.4(19)MR2

Open Caveats

Resolved Caveats

Troubleshooting

Related Documentation

Services and Support


Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3


October 8, 2009

OL-18715-01

These release notes are for the Cisco MWR Mobile Wireless Router 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3. These release notes are updated as needed to describe new features, memory requirements, hardware support, software platform deferrals, and changes to the microcode.

For a list of the software caveats that apply to Cisco IOS Release 12.4(19)MR3, see the "Caveats in Cisco IOS Release 12.4(19)MR3" section.

To review all Cisco MWR 2900-DC release notes, including Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3, go to:

http://www.cisco.com/en/US/docs/wireless/mwr_2941_dc/release/notes/2941dc.html

To review release notes for the Cisco IOS Software Release 12.4 main line, go to:

http://www.cisco.com/en/US/products/ps6350/prod_release_notes_list.html

Contents

This document contains the following sections:

Introduction

System Requirements

New and Changed Information

Limitations and Restrictions

Caveats

Troubleshooting

Related Documentation

Services and Support

Introduction

The Cisco MWR 2941-DC mobile wireless edge router is a special-purpose networking platform optimized for use in mobile wireless networks. The router is used at the cell site edge as a part of a 2G, 3G, or 4G radio access network (RAN). The Cisco MWR 2941-DC router offers high performance and meets the requirements for deployment in cell sites, including small size, high availability, and DC input power flexibility.

Cisco IOS Release 12.4(19)MR3 for the Cisco MWR 2941-DC is a specific technology early deployment release and introduces a variety of features including PWE3 Circuit Emulation over Packet Switched Networks (CEoPSN), GSM Abis Optimization over IP, IEEE 1588-2008 Timing over Packet (ToP), Adaptive Clock Recovery (ACR), and Synchronous Ethernet.

System Requirements

The Cisco MWR 2941-DC router requires the minimum following system configuration:

Cisco IOS Release 12.4(19)MR3 software or later.

Memory Requirements

Table 1 lists the required memory for using this software.

Table 1 Cisco IOS Release 12.4(19)MR3 Memory Requirements

Platform
Feature Set
Software Image
Recommended Flash Memory
Recommended DRAM Memory
Runs From

Cisco MWR 2941-DC Mobile Wireless Edge Router

RAN Optimization

mwr2941-iprank9-mz.124-19.MR3.bin

128 MB

512 MB

RAM


Determining the Software Version

To determine the image and version of Cisco IOS software running on your Cisco MWR 2941-DC router, log in to the router and enter the show version EXEC command:

router> show version
     Cisco Internetwork Operating System Software
	IOS (tm) 2900 Software (MWR2941-IPRANK9-MZ), Version 12.4(19)MR3, EARLY DEPLOYMENT 
	RELEASE SOFTWARE (fcl)

Upgrading to a New Software Release

For general information about upgrading to a new software release, refer to the Software Installation and Upgrade Procedures at:

http://www.cisco.com/web/psa/products/index.html

New and Changed Information

The following sections list the new hardware and software features supported by the Cisco MWR 2941-DC router.

New Features in the Cisco IOS Release 12.4(19)MR3 Software

The following features are supported in release 12.4(19)MR3 of the Cisco IOS software:

Release 12.4(19)MR3 introduces support for IS-IS routing. For instructions on how to configure IS-IS, see the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4T.

New Features in the Cisco IOS Release 12.4(19) MR2 Software

The following features are supported in release 12.4(19)MR2 of the Cisco IOS software:

PWE3 Circuit Emulation over PSN (Packet Switched Network)—Allows you to create pseudowires (PWs) that emulate unstructured and structured T1s and E1s over an MPLS infrastructure, down to NxDS0 circuits. The Cisco MWR 2941-DC supports the following PWE3 standards:

Structure-agnostic TDM over Packet (SAToP)—Encapsulates TDM bit-streams (T1, E1, T3, E3) as PWs over PSNs; the feature is compliant with RFC 4553.

Structure-aware TDM Circuit Emulation Service over Packet-Switched Network (CESoPSN)—Encapsulates structured (NxDS0) TDM signals as PWs over PSNs; the feature is compliant with RFC 5086.

Transportation of Service Using ATM over MPLS—Uses an Asynchronous Transfer Mode (ATM) PW to carry cells over an MPLS network; the feature is compliant with RFCs 4717 and 4816.

GSM Abis Optimization over IP Implementation—Allows the Cisco MWR 2941-DC to optimize GSM voice and data traffic and maximize effective utilization of E1/T1 backhaul connections.

Clocking features—Cisco IOS Release 12.4(19)MR2 introduces several new clocking features that are supported on the ASM-M2900-TOP daughter card, also known as the RTM Module. The RTM module supports the following new clocking features:

Precision Time Protocol (PTP)—Clocking and clock recovery based on the IEEE 1588-2008 standard; allows the Cisco MWR 2941-DC router to receive clocking from another PTP-enabled device or provide clocking to a PTP-enabled device.

This feature introduces a variety of new global commands: ptp domain, ptp mode, ptp priority1, and ptp priority2; the following interface commands: ptp announce, ptp clock-destination, ptp clock-source, ptp delay-req, ptp enable, ptp master, ptp slave, and ptp sync; and the following show commands: show ptp clock, show ptp foreign-master-record, show ptp parent, show ptp port, and show ptp time-property.

Adaptive Clock Recovery (ACR)—Pseudowire-based Timing over Packet (TOP) that allows the MWR 2941 to use in-band or out-of-band clocking on a virtual or regular TDM pseudowire interface. ACR allows the Cisco MWR 2941-DC to recover clocking from the headers of a packet stream and is compliant with the G.823 and G.824 standards. You can use the recovered-clock slave command to configure out-of-band clock recovery and the recovered-clock recovered adaptive command to configure adaptive clock recovery.

Synchronous Ethernet—Allows the network to transport frequency and time information over Ethernet. You can use the network-clock-select command to configure synchronous Ethernet.


Note The RTM module is not required to use Synchronous Ethernet.


ATM—This release includes ATM support with AAL0 and AAL5 encapsulation, F4 and F5 OAM (Operation, Administration, and Maintenance) monitoring, and Virtual Path (VP) shaping.

IMA—This feature allows you to connect one or more interfaces to an ATM network using Inverse Multiplexing ATM (IMA). You can define IMA groups that can contain up to 8 bundles, with up to 24 links per bundle.

IP Header Compression over PPP—This feature introduces support for IP header compression over PPP that is compliant with RFCs 2507, 2508, and 3544.

Distributed Multilink PPP—Release 12.4(19)MR2 supports multilink PPP that is compliant with the RFC 1990 specification.

Flexlink—Backup switchport interfaces using the switchport backup interface command.

IEEE 802.1d Ethernet Switching

IEEE 802.1q VLANS

VLAN Trunking Protocol (VTP)

Per-VLAN Spanning Tree (PVST)+

BITS Clocking

Open Shortest Path First (OSPF)

Bi-Directional Forwarding Detection (BFD) for OSPF

VPN Routing and Forwarding (VRF) Lite for OSPF

ATM cell switching

Label Distribution Protocol (LDP)

Limitations and Restrictions


Caution The Cisco MWR 2941-DC router does not support online insertion and removal (OIR) of WAN interface cards. Any attempt to perform OIR on a card in a powered-on router might cause damage to the card.

Cisco IOS Release 12.4(19)MR3 for the Cisco MWR 2941-DC router has the following limitations and restrictions:

UMTS Iub Optimization not supported—Release 12.4(19)MR3 does not support UMTS Iub optimization.

L2TP not supported—The MWR 2941 currently does not support L2TP.

PTP Boundary mode not supported—This release does not support PTP Boundary mode.

PTP Transparent mode not supported—This release does not support PTP Transparent mode.

Channel group limitations on GSM-Abis interfaces—Only one channel group per E1/T1 is supported on GSM-Abis interfaces.

Contiguous time slots on GSM-Abis channel groups—GSM-Abis channel groups cannot use non-contiguous time slots. For example, you can configure channel-group 0 timeslot 8-20, but not channel-group 0 timeslot 1-5, 10-20.

Out-of-band master mode not supported—This release does not support out-of-band master mode for Timing over Packet/adaptive clock recovery. If your network design requires out-of-band master clocking, you can use the CEoPs SPA on the 7600 router for this purpose.

ACR out-of-band payload limitation—The MWR 2941 only supports the payload-size values 486 (625 packets per second) or 243 (1250 packets per second) for out-of-band clock recovery.

Limited BFD support—Bidirectional Forwarding Detection (BFD) is supported on VLAN interfaces only. OSPF is the supported BFD client.

T1 SAToP is not supported on the HWIC-4T1/E1.

L3VPNs (also known as MPLS VPNs) are not supported.

Limited OAM support—ATM OAM (Operation, Administration, and Maintenance) is not supported on the short haul side of the Cisco MWR 2941-DC.

The Cisco MWR 2941-DC does not support the mpls traffic-eng tunnels command at the global or interface level.

Supported Hardware—Cisco MWR 2941-DC Router

The Cisco MWR 2941-DC supports the following interface cards:

HWIC-4T1/E1

ASM-M2900-TOP

The Cisco MWR 2941-DC router supports the following SFP modules:

SFP-GE-S

SFP-GE-L

SFP-GE-Z

GLC-ZX-SM-RGD

GLC-LX-SM-RGD

GLC-SX-MM-RGD

Other hardware interfaces are not supported.

Supported MIBs

The Cisco MWR 2941-DC router supports the following MIBs:

CISCO-ACCESS-ENVMON-MIB

CISCO-CDP-MIB

CISCO-CONFIG-COPY-MIB

CISCO-CONFIG-MAN-MIB

CISCO-ENHANCED-MEMPOOL-MIB

CISCO-ENTITY-EXT-MIB

CISCO-ENTITY-FRU-CONTROL-MIB

CISCO-ENTITY-SENSOR-MIB

CISCO-ENTITY-VENDORTYPE-OID-MIB

CISCO-ENVMON-MIB

CISCO-FLASH-MIB

CISCO-IETF-PW-MIB

CISCO-IETF-PW-TC-MIB

CISCO-IF-EXTENSION-MIB

CISCO-IMAGE-MIB

CISCO-IP-RAN-BACKHAUL-MIB

CISCO-L2-TUNNEL-CONFIG-MIB

CISCO-MEMORY-POOL-MIB

CISCO-PROCESS-MIB

CISCO-PRODUCTS-MIB

CISCO-RTTMON-MIB

CISCO-SMI

CISCO-SYSLOG-MIB

CISCO-TC

CISCO-VTP-MIB

ENTITY-MIB

HCNUM-TC

IANAifType-MIB

IF-MIB

IMA-MIB

INET-ADDRESS-MIB

MPLS-VPN-MIB

OLD-CISCO-CHASSIS-MIB

OLD-CISCO-INTERFACES-MIB

OLD-CISCO-SYS-MIB

OLD-CISCO-TS-MIB

PerfHist-TC-MIB

RMON2-MIB

RMON-MIB

SNMP-FRAMEWORK-MIB

SNMP-TARGET-MIB

SNMPv2-CONF

SNMPv2-MIB

SNMPv2-SMI

SNMPv2-TC


Caveats

This section documents the open and resolved caveats for the Cisco MWR 2941-DC router running Cisco IOS Release 12.4(19)MR3 and later. Only severity 1 through 3 caveats are included.

Caveats describe unexpected behavior in Cisco IOS software releases. Severity 1 caveats are the most serious caveats, severity 2 caveats are less serious, and severity 3 caveats are the least serious of these three severity levels.

For information on caveats in Cisco IOS Software Releases 12.4 Mainline, go to:

http://www.cisco.com/en/US/products/ps6350/prod_release_notes_list.html

These documents list severity 1 and 2 caveats, and are located on the Documentation DVD and Cisco.com.


Note If you have an account with Cisco.com, you can use the Bug Toolkit to find caveats of any severity for any release. To reach the Bug Toolkit, log in to Cisco.com and click the Support tab and select Support from the drop-down menu. Under Frequently Used Resources, click Bug Toolkit. You must then log in. Another option is to go directly to: http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl.


The following sections document the opened and resolved caveats by Cisco IOS release:

Caveats in Cisco IOS Release 12.4(19)MR3

Troubleshooting

Caveats in Cisco IOS Release 12.4(19)MR3

The following caveats apply to Cisco IOS Release 12.4(19)MR3.

Open Caveats

This section lists the open caveats in Cisco IOS Release 12.4(19)MR3.

CSCsy18615

Description: If you indiscriminately remove and add a multilink PPP interface, this may cause the router to reload unexpectedly. This may occur when packets are unexpectedly received by a multilink interface during a transitional state.

Workaround: Perform the shutdown and no shutdown commands on the underlying multilink components in the sequence as indicated by the following configuration example. In the example, the multilink interface consists of two underlying links.

int multilinkl 1
shutdown
no int multilink 1

int serial0/1:0 
shutdown
int serial0/2:0 
shutdown

controller t1 0/1
shutdown
controller t1 0/2
shutdown

controller t1 0/1
no channel-group 0 
controller t1 0/2
no channel-group 0

controller t1 0/1
channel-group 0 timeslot 1-24
controller t1 0/2
channel-group 0 timeslot 1-24

int serial0/1:0 
no ip address
encapsulation ppp
ppp multilink group 1

int serial0/2:0 
no ip address
encapsulation ppp
ppp multilink group 1

interface multilink 1
ip address 192.168.1.1 255.255.255.0
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
ppp timeout multilink lost-fragment 1

controller t1 0/1
no shutdown
controller t1 0/2
no shutdown

int serial0/1:0 
no shutdown
int serial0/2:0 
no shutdown

CSCsy30207

Description: If you indiscriminately remove and add a multilink PPP interface, this may cause the router to reload unexpectedly. This may occur when packets are unexpectedly received by a multilink interface during a transitional state.

Workaround: Perform the shutdown and no shutdown commands on the underlying multilink components in the sequence as indicated by the following configuration example. In the example, the multilink interface consists of two underlying links.

int multilinkl 1
shutdown
no int multilink 1

int serial0/1:0 
shutdown
int serial0/2:0 
shutdown

controller t1 0/1
shutdown
controller t1 0/2
shutdown

controller t1 0/1
no channel-group 0 
controller t1 0/2
no channel-group 0

controller t1 0/1
channel-group 0 timeslot 1-24
controller t1 0/2
channel-group 0 timeslot 1-24

int serial0/1:0 
no ip address
encapsulation ppp
ppp multilink group 1

int serial0/2:0 
no ip address
encapsulation ppp
ppp multilink group 1

interface multilink 1
ip address 192.168.1.1 255.255.255.0
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
ppp timeout multilink lost-fragment 1

controller t1 0/1
no shutdown
controller t1 0/2
no shutdown

int serial0/1:0 
no shutdown
int serial0/2:0 
no shutdown

Resolved Caveats

This section lists the closed caveats in Cisco IOS Release 12.4(19)MR3.

CSCso25507

Description: Authentication & authorization with TACACS fails. When making modem calls with TACACS AAA servers, authorization failed with the following error message:

TPLUS(00000002): Fail to set vrf socket option - FAIL

Conditions: Occurs when configuring the following AAA and TACACS configuration:

aaa new-model
aaa authentication login logintest local
aaa authorization exec default tacacs
aaa accounting exec wait-start tacacs+

tacacs-server host X.X.X.X
tacacs-server key X

Issue was observed in Cisco AS5400, running 12.4(19.9)T1 image.

Workaround: None.

CSCsy62813

Symptom: A multilink bundle which is under heavy packet load may cause the router to reload.

Conditions: This symptom has been observed when an interface which has just joined a multilink bundle receives packets at a rate faster than the router can process them.

Workaround: There is no workaround.

CSCsy88148

Symptom: The MWR 2941 does not support the IS-IS routing protocol. IS-IS Hello packets are dropped by MWR 2941 ethernet switch.

Workaround: There is no workaround.

CSCsq24002

Cisco IOS Software contains a vulnerability that could allow an attacker to cause a Cisco IOS device to reload by remotely sending a crafted encryption packet. Cisco has released free software updates that address this vulnerability. This advisory is posted at http://www.cisco.com/warp/public/707/cisco-sa-20090923-tls.shtml.

CSCsx25880

A vulnerability exists in the Session Initiation Protocol (SIP) implementation in Cisco IOS Software that could allow an unauthenticated attacker to cause a denial of service (DoS) condition on an affected device when the Cisco Unified Border Element feature is enabled. Cisco has released free software updates that address this vulnerability. For devices that must run SIP there are no workarounds; however, mitigations are available to limit exposure of the vulnerability. This advisory is posted at http://www.cisco.com/warp/public/707/cisco-sa-20090923-sip.shtml.

CSCsz22425

Symptom: When 7600 is reloaded (or switchover occurs), TDM/PWE3 circuit is re-established but packets may not transmitted by the MWR 2941 across the network.

Workaround: Transmission on circuit may be recovered by shut/no-shut of CEM controller on MWR 2941.

CSCsz49123

Symptom: When the MWR 2941 is setup as an IP SLA responder, the jitter and round trip times measured are much higher than when compared to other Cisco platforms such as the ISR.

Conditions: This defect occurs when the MWR 2941 is setup as an IP SLA responder and is connected to another Cisco device setup as the collector. With another device such as an ISR setup in an identical topology to compare the round trip and jitter times with.

Workaround: No workarounds for this defect.

CSCsz88220

Symptom: When Flexlink is configured on the MWR 2941 and both links are on, in certain setup, a layer 2 loop occurs during or after the MWR 2941 boots.

Conditions: Occurs when the MWR 2941 is configured with flexlink and you create a new VLAN that involves both of the configured flexlink ports, and both ports are up during boot or a configuration change. The error can occur during the MWR 2941 boot due to configuration process timing or when you configure new VLANs.

The problem involves a specific IOS configuration; you can detect a layer 2 loop from a switch connected to the MWR 2941 as a MAC address flapping between two ports, or where one of the ports is directly connected.

Workaround: No workarounds for this defect.

Caveats in Cisco IOS Release 12.4(19)MR2

The following caveats apply to Cisco IOS Release 12.4(19)MR2.

Open Caveats

This section lists the open caveats in Cisco IOS Release 12.4(19)MR2.

CSCsy18615

If you indiscriminately remove and add a multilink PPP interface, this may cause the router to reload unexpectedly. This may occur when packets are unexpectedly received by a multilink interface during a transitional state.

Workaround: Perform the shutdown and no shutdown commands on the underlying multilink components in the sequence as indicated by the following configuration example. In the example, the multilink interface consists of two underlying links.

int multilinkl 1
shutdown
no int multilink 1

int serial0/1:0 
shutdown
int serial0/2:0 
shutdown

controller t1 0/1
shutdown
controller t1 0/2
shutdown

controller t1 0/1
no channel-group 0 
controller t1 0/2
no channel-group 0

controller t1 0/1
channel-group 0 timeslot 1-24
controller t1 0/2
channel-group 0 timeslot 1-24

int serial0/1:0 
no ip address
encapsulation ppp
ppp multilink group 1

int serial0/2:0 
no ip address
encapsulation ppp
ppp multilink group 1

interface multilink 1
ip address 192.168.1.1 255.255.255.0
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
ppp timeout multilink lost-fragment 1

controller t1 0/1
no shutdown
controller t1 0/2
no shutdown

int serial0/1:0 
no shutdown
int serial0/2:0 
no shutdown

CSCsy30207

If you indiscriminately remove and add a multilink PPP interface, this may cause the router to reload unexpectedly. This may occur when packets are unexpectedly received by a multilink interface during a transitional state.

Workaround: Perform the shutdown and no shutdown commands on the underlying multilink components in the sequence as indicated by the following configuration example. In the example, the multilink interface consists of two underlying links.

int multilinkl 1
shutdown
no int multilink 1

int serial0/1:0 
shutdown
int serial0/2:0 
shutdown

controller t1 0/1
shutdown
controller t1 0/2
shutdown

controller t1 0/1
no channel-group 0 
controller t1 0/2
no channel-group 0

controller t1 0/1
channel-group 0 timeslot 1-24
controller t1 0/2
channel-group 0 timeslot 1-24

int serial0/1:0 
no ip address
encapsulation ppp
ppp multilink group 1

int serial0/2:0 
no ip address
encapsulation ppp
ppp multilink group 1

interface multilink 1
ip address 192.168.1.1 255.255.255.0
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
ppp timeout multilink lost-fragment 1

controller t1 0/1
no shutdown
controller t1 0/2
no shutdown

int serial0/1:0 
no shutdown
int serial0/2:0 
no shutdown

Resolved Caveats

There are no closed caveats for Cisco IOS Release 12.4(19)MR2.

Troubleshooting

Collecting Data for Router Issues

To collect data for reporting router issues, issue the following command:

show tech-support—Displays general information about the router if it reports a problem.

Collecting Data for ROMmon Issues

To collect data for ROMmon issues, issue the following command while in EXEC mode:

show rom-monitor—Displays currently selected ROM monitor.

Related Documentation

Related documents for implementing the Cisco MWR 2941-DC mobile wireless edge router are available on Cisco.com and the Documentation DVD.

To access the related documentation on Cisco.com, go to:

http://www.cisco.com/en/US/products/ps9395/tsd_products_support_series_home.html

Documents related to the Cisco MWR 2941-DC mobile wireless edge router include the following guides:

Cisco MWR 2941-DC Mobile Wireless Edge Router documents

Cisco MWR 2941-DC Mobile Wireless Edge Router Hardware Installation Guide

Cisco MWR 2941-DC Mobile Wireless Edge Router Software Configuration Guide

Regulatory Compliance and Safety Information for the Cisco MWR 2941-DC Mobile Wireless Edge Router

Cisco Interface Cards Installation Guides

Quick Start Guide: Interface Cards

Cisco Interface Cards Installation Guide

Release Notes—Release Notes for Cisco MWR 2941-DC Mobile Wireless Edge Router for Cisco IOS Release 12.4(19)MR3

Services and Support

For information on obtaining documentation, obtaining support, providing documentation feedback, security guidelines, and also recommended aliases and general Cisco documents, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html