Cisco MWR 1941-DC Router Software Configuration Guide
Configuring the MWR 1941-DC in an IP-RAN
Downloads: This chapterpdf (PDF - 424.0KB) The complete bookPDF (PDF - 1.98MB) | Feedback

Configuring the MWR 1941-DC in an IP-RAN

Table Of Contents

Configuring the MWR 1941-DC in an IP-RAN

Before You Begin

Verifying the Version of Cisco IOS Software

Configuring the Host Name and Password

Configuring Loopback Interfaces

Configuring Fast Ethernet Interfaces

Configuring the FE Interface IP Address

Setting the Speed and Duplex Mode

Configuring Routing Protocol Attributes

Configuring PIM

Configuring HSRP Support

Enabling the FE Interface

Configuring Multilink Interfaces

Configuring Multilink PPP

Configuring IP Address Assignment

Configuring PPP Multiplexing

Configuring ACFC and PFC Handling During PPP Negotiation

Configuring RTP/UDP Compression

Configuring the RTP/UDP Compression Flow Expiration Timeout Duration

Configuring Routing Protocol Attributes

Configuring PIM

Configuring T1 and E1 Interfaces

Configuring T1 Interfaces

Configuring E1 Interfaces

Configuring QoS Attributes

Creating a Class Map

Creating a Policy Map

Assigning a QoS Boilerplate to an Interface

Configuring Redundancy

Redundant MWR 1941-DCs

Stand-Alone MWR 1941-DC

Configuring the Link Noise Monitor

Usage Notes

Configuring LNM

Saving Configuration Changes

Verifying the Configuration

Notes

Monitoring and Managing the MWR 1941-DC

Show Commands for Monitoring the MWR 1941-DC

Where to Go Next


Configuring the MWR 1941-DC in an IP-RAN



Note Cisco IOS Release 12.3(11)T supports the Cisco IOS IP-RAN feature set (software image) for the MWR 1941-DC router.


This chapter describes how to use the Cisco IOS software command-line interface (CLI) to configure the following features of the Cisco MWR 1941-DC in an IP-RAN:

Before You Begin

Verifying the Version of Cisco IOS Software

Configuring the Host Name and Password

Configuring Multilink Interfaces

Configuring Fast Ethernet Interfaces

Configuring Multilink Interfaces

Configuring T1 and E1 Interfaces

Configuring QoS Attributes

Configuring Redundancy

Configuring the Link Noise Monitor

Saving Configuration Changes

Verifying the Configuration

Monitoring and Managing the MWR 1941-DC

Where to Go Next

Follow the procedures in this chapter to configure the router manually or if you want to change the configuration after you have run the setup command facility (described in Chapter 1, "First-Time Configuration").

This chapter describes how to configure features related to the use of the MWR 1941-DC in an IP-RAN. For additional configuration topics, refer to the Cisco IOS configuration guide and command reference publications. These publications are available on the Documentation CD-ROM that came with your router, on the World Wide Web from Cisco's home page, or you can order printed copies separately.


Note If you skipped the previous chapter, "Cisco IOS Software Basics," and you have never configured a Cisco router, go back to that chapter and read it now. The chapter contains important information you need to successfully configure your router.


Before You Begin

Before you configure the MWR 1941-DC in an IP-RAN, please be aware of the following:

Cisco IOS Release 12.2(8)MC2 or later "mwr1900-i-mz" image must be installed on the Cisco MWR 1941-DC router.

You cannot disable Cisco Express Forwarding (CEF) on the MWR 1941-DC. Commands such as no ip cef will display an error message "%Cannot disable CEF on this platform." Some commands, such as no ip route-cache cef, will not return an error message. However, CEF will not be disabled regardless of whether an error message is displayed.

If you are using the MWR 1941-DC in a redundant configuration and are attaching the MWR 1941-DC to a device that uses spanning tree, configure portfast on the device to avoid problems with HSRP at start up.

In case of a tie in priority, HSRP uses the IP address to determine the active router. Therefore, you should ensure that the order of the IP addresses of the E1/T1 interfaces of the active router corresponds to the order of the IP addresses of the E1/T1 interfaces of the standby router.

Verifying the Version of Cisco IOS Software

To implement the MWR 1941-DC router in an IP-RAN, Cisco IOS Release 12.2(8)MC2 or a later must be installed on the router. To verify the version of Cisco IOS software, use the show version command.

The show version command displays the configuration of the system hardware, the software version, the names and sources of configuration files, and the boot images.

Configuring the Host Name and Password

One of the first configuration tasks you might want to do is configure the host name and set an encrypted password. Configuring a host name allows you to distinguish multiple Cisco routers from each other. Setting an encrypted password allows you to prevent unauthorized configuration changes.

 
Command
Purpose

Step 1 

Router> enable

Password: password

Router# 

Enter enable mode. Enter the password.

You have entered enable mode when the prompt changes to Router#.

Step 2 

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

Enter global configuration mode. You have entered global configuration mode when the prompt changes to Router(config)#.

Step 3 

Router(config)# hostname Router

Router(config)#

Change the name of the router to a meaningful name. Substitute your host name for Router.

Step 4 

Router(config)# enable secret guessme

Enter an enable secret password. This password provides access to privileged EXEC mode. When a user types enable at the EXEC prompt
(Router>), they must enter the enable secret password to gain access to configuration mode. Substitute your enable secret for guessme.

Step 5 

Router(config)# line con 0




Router(config-line)#
exec-timeout 0 0



Router(config-line)#
exit

Router(config)#

Enter line configuration mode to configure the console port. When you enter line configuration mode, the prompt changes to Router(config-line)#.

Prevent the router's EXEC facility from timing out if you do not type any information on the console screen for an extended period.

Exit back to global configuration mode.

To verify that you configured the correct host name and password:


Step 1 Enter the show config command:

Router(config)# show config
Using 1888 out of 126968 bytes
!
version XX.X
.
.
.
!
hostname Router
!
enable secret 5 $1$60L4$X2JYOwoDc0.kqa1loO/w8/
.
.
.

Check the host name and encrypted password displayed near the top of the command output.

Step 2 Exit global configuration mode and attempt to re-enter it using the new enable password:

Router# exit
.
.
.
Router con0 is now available
Press RETURN to get started.
Router> enable
Password: guessme
Router#


Configuring Loopback Interfaces

The loopback interface is a software-only, virtual interface that emulates an interface that is always up. The interface-number is the number of the loopback interface that you want to create or configure. There is no limit on the number of loopback interfaces you can create.

The multilink interface is a virtual interface, if you are not going to assign an explicit IP address to the interface, you should create a loopback interface for the multilink interface to enable IP processing on the interface.

In the case where the MWR 1941-DC is used in a redundant configuration, you must also configure loopback interfaces for the health and revertive interfaces. The health interface monitors the status of the redundant configuration so that the standby router can take over if there is a problem with the active router. The revertive interface is required to ensure that the switchover takes place. We recommend that you use 101 for the health interface and 102 for the revertive interface.

To configure a loopback interface, do the following beginning in global configuration mode:


Step 1 Create a loopback interface for each multilink interface:

Router(config)# interface loopback number
Router(config-if)# ip address ip_address subnet_mask


Note For the health and revertive interfaces, you do not need to assign an IP address.



Step 2 Exit interface configuration mode:

Router(config-if)# exit


Configuring Fast Ethernet Interfaces

To configure the FE interface of the MWR 1941-DC, complete the following tasks:

Configuring the FE Interface IP Address

Setting the Speed and Duplex Mode

Configuring Routing Protocol Attributes

Configuring PIM

Configuring HSRP Support

Enabling the FE Interface

Configuring the FE Interface IP Address

To configure the FE interface, do the following starting in global configuration mode:


Step 1 Specify the port adapter type and the location of the interface to be configured.

Router(config)# interface fastethernet slot/port

The slot is always 0 and the port is the number of the port (0 or 1).

Step 2 Assign an IP address and subnet mask to the interface.

Router(config-if)# ip address ip_address subnet_mask 


Setting the Speed and Duplex Mode

The Fast Ethernet ports of the MWR 1941-DC can run in full or half duplex mode and at 100 Mbps or 10 Mbps. The MWR 1941-DC also has an auto-negotiation feature that allows the router to negotiate the speed and duplex mode with the corresponding interface on the other end of the connection.

Auto negotiation is the default setting for the speed and transmission mode.

When configuring an interface speed and duplex mode, note these guidelines:

If both ends of the line support auto negotiation, we highly recommend the default auto negotiation settings.

When the auto negotiation is turned on for either speed or duplex, it auto negotiates both speed and duplex.

If one interface supports auto negotiation and the other end does not, configure duplex and speed on both interfaces; do not use the auto setting on the supported side or the duplex setting will be half.

To configure speed and duplex operation, do the following while still in interface configuration mode:


Step 1 Specify the duplex operation.

Router(config-if)# duplex [auto | half | full]

Step 2 Specify the speed.

Router(config-if)# speed [auto | 100 | 10]


Configuring Routing Protocol Attributes

When used in the CDMA IP-RAN solution, the MWR 1941-DC must be configured to support the OSPF routing protocol. To configure OSPF routing protocol attributes, do the following while still in interface configuration mode:


Step 1 Enable OSPF Message Digest 5 (MD5) authentication.

Router(config-if)# ip ospf message-digest-key key-id md5 key 

Step 2 Specify the interval between hello packets that the Cisco IOS software sends on the interface.

Router(config-if)# ip ospf hello-interval seconds 

Step 3 Set the interval at which hello packets must not be seen before neighbors declare the router down.

Router(config-if)# ip ospf dead-interval seconds 


Configuring PIM

Because the MWR 1941-DC is used in a multicast PPP environment, you should configure the PIM mode of the FE interface.

To configure the PIM mode, do the following while still in interface configuration mode:


Step 1 Enter the following command:

Router(config-if)# ip pim {sparse-mode | sparse-dense-mode | dense-mode [proxy-register 
{list access-list | route-map map-name}]} 


Configuring HSRP Support

In redundant configurations, the MWR 1941-DC uses HSRP to control the active and standby routers. To use HSRP, you must configure the standby priority attributes and the IP address of the virtual router. Priority is determined first by the configured priority value, and then by the IP address. In each case a higher value is of greater priority.


Note If you do not plan to use the MWR 1941-DC in a redundant configuration, do not configure HSRP support and see Configuring Redundancy for information about using the router in a stand-alone environment.


To configure HSRP support, do the following while still in interface configuration mode:


Step 1 Specify the name of the standby group.

Router(config-if)# standby group name group-name


Note The standby group names must be "one" and "two." For FE 0/0, the command must be standby 1 name one. For FE 0/1, the command must be standby 2 name two.



Tips If you omit the group-name or if you enter a group name that doesn't begin with one or two, the configuration will fail and there will be a mismatch in the information displayed by the show redundancy and show standby commands.


Step 2 Enable HSRP and assign an IP address to the virtual router. This address is the same for both the active and standby routers.

Router(config-if)# standby group ip address

Step 3 Configure the time between hello packets and the time before other routers declare the active Hot Standby or standby router to be down.

Router(config-if)# standby group timers [msec] hellotime [msec] holdtime


Note You must use 1 for the hello time and 3 for the hold time.


Step 4 Indicate that the router can become the active router when its priority is higher than all other HSRP-configured routers. Without preemption, a standby router will only transition to the active state if HSRP "hello messages" cease. In the CDMA IP-RAN solution, there may be situations in which you want a switchover to occur in the absence of a router or FE failure, therefore, preemption is required.

Router(config-if)# standby group preempt

Step 5 Specify other interfaces on the router for the HSRP process to monitor in order to alter the HSRP priority for a given group. When using the MWR 1941-DC router in the CDMA IP-RAN solution, you must configure each FE interface to track the multilink interface, the loopback interfaces, and the other FE interface.

Router(config-if)# standby group track multilink number decrement_value

Router(config-if)# standby group track loopback number decrement_value

Router(config-if)# standby group track fastethernet number decrement_value


Note In redundant configurations, you should issue standby track commands for both the health interface (loopback101) and the revertive interface (loopback102) as well as for the backhaul interface (multilink1). The decrement values must be as follows: 10 for the multilink, FE, and health interfaces; 5 for the revertive interface.


Step 6 Specify a priority of 100.

Router(config-if)# standby group priority 100



Note If you are using the MWR 1941-DC in a redundant configuration, you must also set the keepalives under the FE interface to 1.

Router(config-if)# keepalive 1


Enabling the FE Interface

Once you have configured the FE interface, enable it by doing the following while still in interface configuration mode:


Step 1 Enable the interface.

Router(config-if)# no shutdown


Configuring Multilink Interfaces

To configure the multilink interfaces, complete the following tasks:

Configuring Multilink PPP

Configuring IP Address Assignment

Configuring PPP Multiplexing

Configuring RTP/UDP Compression

Configuring the RTP/UDP Compression Flow Expiration Timeout Duration

Configuring Routing Protocol Attributes

Configuring PIM

Configuring Multilink PPP

As higher-speed services are deployed, Multilink-PPP (MLP) provides a standardized method for spreading traffic across multiple WAN links, while providing multivendor interoperability and load-balancing on both inbound and outbound traffic.

A Multilink interface is a special virtual interface which represents a multilink PPP bundle. The multilink interface serves to coordinate the configuration of the bundled link, and presents a single object for the aggregate links. However, the individual PPP links that are aggregated together, must also be configured. Therefore, to enable Multilink PPP on multiple serial interfaces, you need to first set up the multilink interface, and then configure each of the serial interfaces and add them to the same multilink interface.

The MWR 1941-DC router can support up to 16 T1 interfaces through the multilink interface.

To set up the multilink interface, do the following beginning in global configuration mode:


Step 1 Specify the multilink interface to be configured.

RPM-3(config)# interface multilink number

Step 2 Enable multilink PPP operation.

RPM-3(config-if)# ppp multilink

Step 3 If using Cisco IOS Release 12.3(15)MC2a or prior, enter the following command to specify an identification number for the multilink interface.

RPM-3(config-if)# multilink-group group-number

If using Cisco IOS Release 12.3(11)T or later, enter the following command to specify an identification number for the multilink interface:

RPM-3(config-if)# ppp multilink group group-number

Step 4 Enable IP processing on a the multilink interface without assigning an explicit IP address to the interface.

RPM-3(config-if)# ip unnumbered loopback number

Where number is the number of the multilink loopback interface that you configured in Configuring Loopback Interfaces.


Configuring IP Address Assignment

A point-to-point interface must be able to provide a remote node with its IP address through the IP Control Protocol (IPCP) address negotiation process. The IP address can be obtained from a variety of sources. The address can be configured through the command line, entered with an EXEC-level command, provided by TACACS+ or the Dynamic Host Configuration Protocol (DHCP), or from a locally administered pool.

IP address pooling uses a pool of IP addresses from which an incoming interface can provide an IP address to a remote node through IPCP address negotiation process. IP address pooling also enhances configuration flexibility by allowing multiple types of pooling to be active simultaneously.

To configure IP address assignment, do the following do the following while still in multilink interface configuration mode:


Step 1 Specify an IP address, an address from a specific IP address pool, or an address from the Dynamic Host Configuration Protocol (DHCP) mechanism to be returned to a remote peer connecting to this interface:

RPM-3(config-if)# peer default ip address {ip-address | dhcp | pool [pool-name]}


Configuring PPP Multiplexing

To enable and control the multiplexing of PPP frames, do the following while still in multilink interface configuration mode:


Step 1 Enable PPP multiplexing:

RPM-3(config-if)# ppp mux

Step 2 Specify the parameters of multiplexing.

To set the maximum time delay, enter:

RPM-3(config-if)# ppp mux delay integer

To set the maximum length of the subframe, enter:

RPM-3(config-if)# ppp mux subframe length integer

To set maximum length of the superframe, enter:

RPM-3(config-if)# ppp mux frame integer

To set the maximum number of subframes in a superframe, enter:

RPM-3(config-if)# ppp mux subframe count integer

To set the default PPP protocol ID, enter:

RPM-3(config-if)# ppp mux pid integer


Configuring ACFC and PFC Handling During PPP Negotiation


Note This feature requires Cisco IOS Release 12.2(15)MC1 and later be installed on the MWR 1941-DC router.


ACFC and PFC handling during PPP negotiation can be configured. By default, ACFC/PFC handling is not enabled.

To configure ACFC handling during PPP negotiation, do the following while in multilink interface configuration mode:


Step 1 Enter the following command to configure how the router handles the ACFC option in configuration requests received from a remote peer.

RPM-3(config-if)# ppp acfc remote {apply | reject | ignore}

Where:

apply—ACFC options are accepted and ACFC may be performed on frames sent to the remote peer.

reject—ACFC options are explicitly ignored.

ignore—ACFC options are accepted, but ACFC is not performed on frames sent to the remote peer.

Step 2 Enter the following command to configure how the router handles ACFC in its outbound configuration requests.

RPM-3(config-if)# ppp acfc local {request | forbid}

Where:

request—The ACFC option is included in outbound configuration requests.

forbid—The ACFC option is not sent in outbound configuration requests, and requests from a remote peer to add the ACFC option are not accepted.

To configure PFC handling during PPP negotiation, do the following while in multilink interface configuration mode:


Step 1 Enter the following command to configure how the router handles the PFC option in configuration requests received from a remote peer.

RPM-3(config-if)# ppp pfc remote {apply | reject | ignore}

Where:

apply—PFC options are accepted and ACFC may be performed on frames sent to the remote peer.

reject—PFC options are explicitly ignored.

ignore—PFC options are accepted, but ACFC is not performed on frames sent to the remote peer.

Step 2 Enter the following command to configure how the router handles PFC in its outbound configuration requests.

RPM-3(config-if)# ppp acfc local {request | forbid}

Where:

request—The PFC option is included in outbound configuration requests.

forbid—The PFC option is not sent in outbound configuration requests, and requests from a remote peer to add the PFC option are not accepted.

Configuring RTP/UDP Compression

Enabling RTP/UDP compression (cRTP/cUDP) on both ends of a low-bandwidth serial link can greatly reduce the network overhead if there is a lot of RTP traffic on that slow link. This compression is beneficial especially when the RTP payload size is small (for example, compressed audio payloads of 20-50 bytes).

Before you can enable RTP header compression, you must configure a serial line that uses PPP encapsulation.

To configure RTP header compression, do the following while still in multilink interface configuration mode:


Step 1 If using Cisco IOS release 12.2(15)MC2a or prior, enter the following command to enable RTP header compression for serial encapsulations:

SRPM-3(config-if)# ip rtp header-compression

If using Cisco IOS release 12.3(11)T or later, enable RTP header compression for serial encapsulations and suppress IP ID checking during RTP compression by entering the ip rtp header-compression interface configuration command and specifying the ignore-id keyword option:

SRPM-3(config-if)# ip rtp header-compression ignore-id

Step 2 By default, the software supports a total of 16 RTP header compression connections on an interface. To change that number, enter the following command:

RPM-3(config-if)# ip rtp compression-connections number


Note The MWR 1941-DC supports up to 1000 RTP header compression connections on an interface.




Configuring the RTP/UDP Compression Flow Expiration Timeout Duration

To minimize traffic corruption, cUDP flows expire after a period of time during which no packets are passed. When this user defined duration of inactivity occurs on a flow at the compressor, the compressor sends a full header upon receiving a packet for that flow, or, if no new packet is received for that flow, the compressor makes the CID for the flow available for new use. When a packet is received at the decompressor after the duration of inactivity has been exceeded, the packet is dropped and a context state message is sent to the compressor requesting a flow refresh.

The default expiration timeout is 5 seconds. The recommended value is 8 seconds.


Caution Failure of performance/latency scripts could occur if the expiration timeout duration is not changed to the recommended 8 seconds.

To configure the duration of the cUDP flow expiration timeout, do the following while in multilink interface configuration mode:


Step 1 To specify the duration of inactivity, in seconds, that when exceeded causes the cUDP flow to expire, enter the following command:

RPM-3(config-if)# ppp iphc max-time seconds


Configuring Routing Protocol Attributes

When used in the CDMA IP-RAN solution, the multilink interface must be configured to support the OSPF routing protocol.

To configure OSPF routing protocol attributes, do the following while still in interface configuration mode:


Step 1 Enable OSPF Message Digest 5 (MD5) authentication:

RPM-3(config-if)# ip ospf message-digest-key key-id md5 key 

Step 2 Specify the interval between hello packets that the Cisco IOS software sends on the interface:

RPM-3(config-if)# ip ospf hello-interval seconds 

Step 3 Set the interval at which hello packets must not be seen before neighbors declare the router down:

RPM-3(config-if)# ip ospf dead-interval seconds 


Configuring PIM

Because the MWR 1941-DC is used in a multicast PPP environment, you should configure the PIM mode of the multilink interface.

To configure the PIM mode, do the following while still in interface configuration mode:


Step 1 Enter the following command:

RPM-3(config-if)# ip pim {sparse-mode | sparse-dense-mode | dense-mode [proxy-register 
{list access-list | route-map map-name}]} 


Configuring T1 and E1 Interfaces

To configure a T1/E1 multiflex trunk interface, enter the following Cisco IOS commands at the router prompt.


Note Before you begin, disconnect all WAN cables from the router to keep it from trying to run the AutoInstall process. The router tries to run AutoInstall whenever you power it on if there is a WAN connection on both ends and the router does not have a valid configuration file stored in NVRAM (for instance, when you add a new interface). It can take several minutes for the router to determine that AutoInstall is not connected to a remote Transmission Control Protocol/Internet Protocol (TCP/IP) host.


Configuring T1 Interfaces

To configure the T1 interfaces, do the following while still in global configuration mode:


Step 1 Specify the controller that you want to configure. For information about interface numbering, see Understanding MWR 1941-DC Router Interface Numbering.

Router(config)# controller t1 slot/port

Step 2 Specify the framing type.

Router(config-controller)# framing esf

Step 3 Specify the line code format.

Router(config-controller)# linecode b8zs 

Step 4 Specify the channel group and time slots to be mapped. For the VWIC interfaces, you can configure two channel-groups (0 and 1) on the first T1 port or you can configure one channel-group (0 or 1) on each T1 port. Once you configure a channel group, the serial interface is automatically created.


Note The default speed of the channel group is 56. To get full DS0/DS1 bandwidth, you must configure a speed of 64.


Router(config-controller)# channel-group 0 timeslots 1-24 speed 64 

Step 5 Configure the cable length.

Router(config-controller)# cablelength feet

Note Although you can specify a cable length from 0 to 450 feet, the hardware only recognizes two ranges: 0 to 49 and 50 to 450. For example, entering 35 feet uses the 0 to 49 range. If you later change the cable length to 40 feet, there is no change because 40 is within the 0 to 49 range. However, if you change the cable length to 50, the 50 to 450 range is used. The actual number you enter is stored in the configuration file.


Step 6 Exit controller configuration mode.

Router(config-controller)# exit 

Step 7 Configure the serial interface. Specify the T1 slot (always 0), port number, and channel group.

Router(config)# interface serial slot/port:0 

Step 8 Assign an IP address and subnet mask to the interface. If the interface is a member of a Multilink bundle (MLPPP), then skip this step.

Router(config-if)# ip address ip_address subnet_mask 

Step 9 Before you can enable RTP header compression, you must have configured a serial line that uses PPP encapsulation. Enter the following command to configure PPP encapsulation.

Router(config-if)# encapsulation ppp 

Step 10 Enable keepalive packets on the interface and specify the number of times keepalive packets will be sent without a response before bringing down the interface:

Router(config-if)# keepalive [period [retries]]


Note When enabled in an IP-RAN solution, the recommended configuration is keepalive 1 2 on both the MWR 1941-DC serial interface and associated MGX-RPM-1FE-CP virtual template interface.


Step 11 Set the carrier delay for the serial interface.

Router(config-if)# carrier-delay number 

Step 12 Return to Step 1 to configure the second port on the VWIC and the ports on any additional VWICs.

Step 13 Exit to global configuration mode.

Router(config-if)# exit 


Configuring E1 Interfaces

To configure the E1 interfaces, do the following while still in global configuration mode:


Step 1 Specify the controller that you want to configure. Controller E1 0/0 maps to the first port of the VWIC in slot 0. Controller E1 0/1 maps to the second port of the VWIC in slot 0.

Router(config)# controller e1 slot/port

Step 2 Specify the framing type.

Router(config-controller)# framing crc4

Step 3 Specify the line code format.

Router(config-controller)# linecode hdb3

Step 4 Specify the channel group and time slots to be mapped. For the VWIC interfaces, you can configure channel-group 0 and 1 on one port or one channel-group (either 0 or 1) on each port. Once you configure a channel group, the serial interface is automatically created.

Router(config-controller)# channel-group 0 timeslots 1-24 speed 64


Note The default speed of the channel group is 56. To get full DS0/DS1 bandwidth, you must configure a speed of 64.


Step 5 Configure the serial interface. Specify the E1 slot (always 0), port number, and channel group.

Router(config-controller)# interface serial slot/port:0

Step 6 Configure the cable length.

Router(config-controller)# cablelenth feet


Note Although you can specify a cable length from 0 to 450 feet, the hardware only recognizes two ranges: 0 to 49 and 50 to 450. For example, entering 35 feet uses the 0 to 49 range. If you later change the cable length to 40 feet, there is no change because 40 is within the 0 to 49 range. However, if you change the cable length to 50, the 50 to 450 range is used. The actual number you enter is stored in the configuration file.


Step 7 Assign an IP address and subnet mask to the interface. If the interface is a member of a Multilink bundle (MLPPP), then skip this step.

Router(config-if)# ip address ip_address subnet_mask

Step 8 Before you can enable RTP header compression, you must have configured a serial line that uses PPP encapsulation. Enter the following command to configure PPP encapsulation.

Router(config-if)# encapsulation ppp 

Step 9 Enable keepalive packets on the interface and specify the number of times keepalive packets will be sent without a response before bringing down the interface:

Router(config-if)# keepalive [period [retries]]


Note When enabled in an IP-RAN solution, the recommended configuration is keepalive 1 2 on both the MWR 1941-DC serial interface and associated MGX-RPM-1FE-CP virtual template interface.


Step 10 Set the carrier delay for the serial interface.

Router(config-if)# carrier-delay number

Step 11 Return to Step 1 to configure the second port on the VWIC and the ports on any additional VWICs.

Step 12 Exit to global configuration mode.

Router(config-if)# exit


Configuring QoS Attributes

To use QoS on the MWR 1941-DC router, you must first create a class map. The class map defines the criteria that a packet must match to be placed in that class. Once you have created a class map, the router can recognize packets that are subject to QoS. You must then tell the router the action to take on those packets by creating a policy map.Once you have completed the creation of a QoS boilerplate, you can assign it to an interface.


Note The QoS functionality of the MWR 1941-DC router is built on the same code as the Cisco 10000 ESR (with some exceptions). For more information about the QoS feature, see "Configuring Quality of Service" (http://www.cisco.com/univercd/cc/td/doc/product/aggr/10000/10ksw/qosos.htm) and the "Cisco 10000 Series ESR Quality of Service" feature module (http://www.cisco.com/univercd/cc/td/doc/product/aggr/10000/10kfm/fm_qos.htm), as well as the "Cisco IOS Quality of Service Solutions Configuration Guide" and the "Cisco IOS Quality of Service Solutions Command Reference."


Creating a Class Map

For each class map that you want to create, do the following in global configuration mode:


Step 1 Assign a name to your class map.

Router(config)# class-map [match-all | match-any] class_name

Where match-any means a single match rule is sufficient for class membership and match-all means only those packets that have all the attributes you specify are part of the class.

When you enter the class-map command, you are placed in class map configuration mode.

Step 2 Describe the characteristics of the packets that are subject to QoS using one or more of the following.

Router(config-cmap)# match access-group number
Router(config-cmap)# match ip dscp number
Router(config-cmap)# match ip precedence number
Router(config-cmap)# match input-interface interface-name
Router(config-cmap)# match protocol protocol

match access-group specifies access control list (ACL) that a packet must match.

match ip dscp specifies the IP differentiated service code point (DSCP) that a packet must match.

match ip precedence specifies the precedence values (0-7) that a packet must match.

match input-interface specifies the name of the input interface used as a match criterion.

match input-protocol specifies the protocol that a packet must match.

For more information about these commands, see the "Cisco IOS Quality of Service Solutions Command Reference."

Step 3 Exit class map configuration mode.

Router(config-cmap)# exit


Creating a Policy Map

To create a policy map, do the following in global configuration mode:


Step 1 Assign a name to your policy map.

Router(config)# policy-map policy_name

When you enter the policy-map command, you are placed in policy map configuration mode.

Step 2 Associate the policy map with a class map.

Router(config-pmap)# class class_name

Specify the same class_name as you did in Step 1 of Creating a Class Map. When you enter the class command, you are placed in class submode of the policy-map configuration mode.

Step 3 Describe the QoS actions you want the router to perform when the router encounters a packet that has the characteristics described by the class map. Use one or more of the following commands:

Router(config-pmap-c)# priority percent number

Router(config-pmap-c)# bandwidth percent number

Router(config-pmap-c)# queue-limit number

Router(config-pmap-c)# priority rate-in-kbps

Router(config-pmap-c)# shape {average | peak} cir [bc] [be]

Router(config-pmap-c)# shape max-buffers number-of-buffers

priority percent gives priority to a class of traffic belonging to a policy map and specifies that a certain percentage of the available bandwidth should be reserved for this class.

bandwidth percent specifies the bandwidth allocated for a class belonging to a policy map.

queue-limit specifies the maximum number of packets the queue can hold for a class policy configured in a policy map.

priority enables low-latency priority queuing, which allows you to assign a specified share of the link bandwidth to one queue that receives priority over all others. Low-latency priority queueing minimizes the packet-delay variance for delay-sensitive traffic, such as live voice and video.

shape and shape max-buffers are used with class-based weighted fair queuing (CB-WFQ), which allows you to control the traffic going out an interface in order to match its transmission to the speed of the remote target interface.


Note The bandwidth percent and priority percent commands cannot be used in the same class, within the same policy map. These commands can be used together in the same policy map, however.


For more information about these commands, see the "Cisco IOS Quality of Service Solutions Command Reference."

Step 4 To configure the Class-Based Packet Marking feature, you must configure either an IP Precedence value or an IP differentiated services code point (DSCP). The QOS group is optional.

Router(config-pmap-c)# set ip dscp ip-dscp-value

Router(config-pmap-c)# set ip precedence ip-precedence-value

Router(config-pmap-c)# set qos-group qos-group-value

set ip dscp marks a packet by setting the IP DSCP value.

set ip precedence marks a packet by setting the IP Precedence bits in the ToS byte.

set qos-group associates a local QoS group value with a packet.

For more information about these commands, see the "Cisco IOS Quality of Service Solutions Command Reference."

Step 5 Repeat Step 2 and Step 3 for each class map.

Step 6 Exit policy map configuration mode.

Router(config-pmap-c)# exit
Router(config-pmap)# exit


Assigning a QoS Boilerplate to an Interface

To assign a QoS boilerplate to a multilink interface, do the following in global configuration mode.


Step 1 Access the multilink interface configuration mode.

Router(config)# interface multilink number

Step 2 Assign the QoS boilerplate to the multilink interface.

Router(config-if)# service-policy output policy_name


Configuring Redundancy

The MWR 1941-DC router can be used in either a redundant configuration (preferable) or as a stand-alone device.


Note Before implementing redundancy, you must disable EADI capabilities on the router using the diable-eadi global configuration command and also configure HSRP under the Fast Ethernet interface. See the "Configuring HSRP Support" section for more information on configuring HSRP under the Fast Ethernet interface.


Redundant MWR 1941-DCs

For redundancy, the MWR 1941-DC router makes use of the existing HSRP feature. However, additional controls are needed for the MWR 1941-DC. In a redundant configuration, the MWR 1941-DC router must track the status of the health and revertive loopback interfaces as well as the backhaul interface.

To configure an MWR 1941-DC for use in a redundant configuration, do the following starting in global configuration mode:


Step 1 Enter redundancy mode.

Router(config)# redundancy

Step 2 Enter the y-cable mode.

Router(config-r)# mode y-cable

Step 3 Specify the loopback interface to be used to monitor the health of the router and for revertive purposes.

Router(config-r-y)# standby use-interface interface health 

Router(config-r-y)# standby use-interface interface revertive


Note The interfaces that you specify for the health and revertive interfaces should match those that you configured and tracked in Configuring Loopback Interfaces. (We recommend you use loopback101 for the health and loopback102 for the revertive interface).


Step 4 Specify the interface to be used for backhauling.

Router(config-r-y)# standby use-interface interface backhaul 


Note The interface that you specify for the backhaul must be an MLPPP interface. If you want to use a serial interface as the backhaul, you must first configure that interface to be part of an MLPPP bundle. The interface that you specify for the backhaul interface should match one of those that you configured and tracked in Configuring Loopback Interfaces.


Step 5 Exit y-mode configuration mode.

Router(config-r-y)# exit


To verify the status of the relays on an MWR 1941-DC router, use the show controllers command.

Stand-Alone MWR 1941-DC

The MWR 1941-DC router has relays that work with a special "y" cable for redundancy and are controlled by HSRP. You can, however, use the MWR 1941-DC as a stand-alone device. If you choose not to use the MWR 1941-DC in a redundant configuration, you should not configure HSRP and you must control the relays of the VWIC card manually.

To manually set the relays to open or closed, do the following starting in global configuration mode:


Step 1 Enter redundancy mode.

Router(config)# redundancy

Step 2 Enter the y-cable mode.

Router(config-r)# mode y-cable

Step 3 Specify that the router is to be used as a stand-alone device. This command closes the relays.

Router(config-r-y)# standalone

Step 4 Exit y-mode configuration mode.

Router(config-r-y)# exit


To verify the status of the relays on an MWR 1941-DC router, use the show controllers command.

Configuring the Link Noise Monitor


Note This feature requires Cisco IOS Release 12.2(8)MC2d and later be installed on the MWR 1941-DC router.


Noise on T1 and E1 links that span between the BTS and central office can affect voice quality for mobile users to the point where it becomes unacceptable. To monitor the quality of individual links in a multilink bundle, you can configure the Link Noise Monitor (LNM) on your MWR 1941-DC router

The LNM detects, alerts, and removes noisy links from a bundle based on user-defined thresholds and durations. In addition, the LNM notifies the operator once the quality of the line has improved, and restores the link service if the link has been removed.

Specifically, to detect noise on a link, the LNM monitors the following two types of errors which make up the Bit Error Rate (BER) and compares the number of errors with the user-defined thresholds:

Line Code Violation (LCV)—A Bi-Polar Violation (BPV) or Excessive Zeroes (EXZ) error has occurred.

Path Code Violation (PCV)—A Cyclic Redundancy Check (CRC) error, which is generally caused by one or more LCV or logic errors, has occurred in a time slot.

The LNM provides the following types of noise monitors:

Link Warning—Issues a warning when the noise level of a link exceeds a user-defined threshold and notifies the operator when the noise level improves to the point that it drops below a second user-defined threshold.

Link Removal—Issues an error and removes a link from service when the noise level of the link exceeds a user-defined threshold and restores the link and provides notification when the noise level improves to the point that it drops below a second user-defined threshold.


Note If the noise level on the last active link in a multilink bundle exceeds the Link Removal threshold, an alert is issued but the link will not be removed from service. If this situation occurs, the standard T1 error rate is used to determine if the last active link must be removed from service.


Usage Notes

When configuring the LNM, please note the following:

If the warn and remove keywords are specified without any other options, the LCV and PCV thresholds and duration defaults will be use to determine (set) and clear (clear) the condition.

If the span command is issued with the set keyword specified (defining the LNM type and parameters to use to determine a condition exists) and the command is not issued again with the clear keyword specified (defining the parameters used to clear a condition), or vice versa, the values configured for the threshold and duration will be used for both.

If the span command is issued without either the set or clear keywords specified, set is the default.

The set and clear keywords can only be specified if the threshold and/or duration has been specified.

If the PCV threshold is not configured (using the pcv keyword and value), the threshold is calculated using Gaussian probability distribution that is representative of most noise environments.

The following SYSLOG messages have been added for fault notification:

- %LNM-4- WARNEXCEED:Controller <Controller IF>, exceeded noise warning threshold 
  <int>, duration <int>
- %LNM-4- WARNIMPROVE:Controller <Controller IF>, noise improved below threshold 
  <int>, duration <int>
- %LNM-2-REMOVE:Interface <Serial IF> removed, noise exceeded threshold <int>, 
  duration <int>
- %LNM-2- RESTORE:Interface <Serial IF> restored, noise improved below threshold 
  <int>, duration <int>
- %LNM-2- REMEXCEED:Interface <Serial IF>, noise exceeded threshold <int>, 
  duration <int>
- %LNM-2- REMIMPROVE:Interface <Serial IF>, noise improved below threshold <int>, 
  duration <int>

Configuring LNM

To configure the LNM feature, issue the span command from controller configuration mode of each T1 or E1 link in the bundle that you want to monitor. To disable LNM on a link, issue the no version of the command from controller configuration mode of the link.

span { warn | remove } [ { [ lcv value [ pcv value ]] [ duration seconds ] } set | clear ]

where:

warn—Enables Link Warning monitoring on the link.

remove—Enables Link Removal monitoring on the link.

lcv value—Threshold (in bit errors per second) that when exceeded for the configured duration when the set keyword has been specified, creates a condition (warning or link removal), or when fallen below for the configured duration when the clear keyword has been specified, clears the condition.

For T1 links:

Valid range is 5 to 1544.

For Link Warning monitoring, the default is 15.

For Link Removal monitoring, the default is 154.

For E1 links,

Valid range is 7 to 2048.

For Link Warning monitoring, the default is 20.

For Link Removal monitoring, the default is 205.

pcv value—Number of time slots in errors per second. If not specified by the user, this value is calculated from the LCV threshold based on a Gaussian distribution that matches typical noise-induced errors.

For T1 links:

Valid range is 3 to 320.

For Link Warning monitoring, the default is 15.

For Link Removal monitoring, the default is 145.

For E1 links,

Valid range is 8 to 832.

For Link Warning monitoring, the default is 20.

For Link Removal monitoring, the default is 205.

duration seconds—Number of seconds that a threshold must be exceeded to create a condition or fallen below to clear a condition. Valid range is 1 to 600. The default is 10.

When specified with the lcv keyword, the duration must be configured after the LCV threshold. For example, span warn lcv 55 duration 20 is a correct way to issue the command; span warn duration 20 lcv 55 is not.

set—Specifies that the values configured for the span command are to be used to set a condition.

clear—Specifies that the values configured for the span command are to be used to clear a condition.

Saving Configuration Changes

To prevent the loss of the router configuration, save it to non-volatile random access memory (NVRAM). To save the configuration to NVRAM, do the following:


Step 1 Exit configuration mode.

Router(config)# exit


Note You can press Ctrl-z in any mode to immediately return to enable mode (Router#), instead of entering exit, which returns you to the previous mode.


Step 2 Save the configuration changes to NVRAM so that they are not lost during resets, power cycles, or power outages.

Router# copy running-config startup-config


Verifying the Configuration

To verify the configuration of the MWR 1941-DC, enter the following command:

MWR1900-1#show running-config

hostname MWR1900-1
!
boot system slot0:mwr-1900-boot
!
! description Loopback IP for O & M
!
interface loopback 0
 ip address 10.1.170.3 255.255.255.255
!
! description Loopback IP for IP Unnumbered
!
interface loopback 2
 ip address 192.168.170.2 255.255.255.255
!
interface loopback101
 description Health Loopback Interface
 no ip address
!
interface loopback102
 description Revertive Loopback Interface
 no ip address
!
enable password cisco 
!
memory-size iomem 25
!
redundancy
  mode y-cable
   standby use-interface Loopback101 health
   standby use-interface Loopback102 revertive
   standby use-interface Multilink2 backhaul
!
controller T1 0/0
 framing esf
 cablelength short 133ft
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-1 speed 64
 channel-group 1 timeslots 2-24 speed 64
!
controller T1 0/1
 framing esf
 clock source internal
 linecode b8zs
 cablelength short 133ft
!
!
class-map match-all class1_fch
 match ip dscp cs5 
class-map match-all class2_sch
 match ip dscp cs4 
class-map match-any class3_paging_ospf
 match ip dscp cs3 
match access-group 101
!
policy-map llq-policy
 class class1_fch
  priority percent 68 
 class class2_sch
  bandwidth percent 20 
  queue-limit 128 
 class class3_paging_ospf
  bandwidth percent 2 
  queue-limit 128 
 class class-default
  queue-limit 512
!
ip dhcp excluded-address 192.168.146.1 192.168.146.3
ip dhcp ping packets 0 
!
ip dhcp pool pbts
 network 192.168.146.0 255.255.255.0
 bootfile CENOMIbts.img
 next-server OMCR-IPaddr 
 option 43 ascii "Logical-IPaddr CENOMI-IPaddr another-IPaddr SpanMapping"
 default-router 192.168.146.3
 dns-server OMCR-IPaddr
 lease 0 0 1
!
ip routing
ip subnet-zero 
ip classless
ip multicast-routing
ip tftp source-interface Loopback 0
cdp run
!
! Setup sys logging to OMCIP-CW2000
!
logging on
logging buffered 4
logging cw4mw 
logging trap 5
logging source-interface Loopback0
! 
! Setup SNMP
!
snmp community private rw
snmp community public ro
snmp-server enable traps
snmp-server trap-source Loopback 0
snmp-server host cw4mw public
!
! Setup useful aliases
!
ip host omcr OMCR_ip_address 
ip host omcip OMCIP_ip_address 
ip host cw4mw CW4MW_ip_address 
ip host btsha-other-0 192.168.146.2 
ip host btsha-other-1 192.168.147.2 
!
!interface Multilink1
description Backhaul Interface
ip unnumbered loopback 2
 cdp enable
 ppp multilink
 ip ospf hello-interval 1
 ip ospf dead-interval 3
 ip ospf message-digest-key 1 md5 mymd5pw
!
interface Multilink2
 description 
 ip unnumbered loopback 2
 ip mroute-cache
 ip mtu 256
 cdp enable 
 ppp multilink 
 ip rtp header-compression ignore-id
 ip rtp compression-connections 700 
 ppp mux
 ppp mux subframe length 64
 ppp mux subrame count 15
 ppp mux frame 256
 ppp mux delay 800
 ppp mux pid 0x2067 
 ip ospf hello-interval 1
 ip ospf dead-interval 3 
 ip ospf message-digest-key 1 md5 mymd5pw 
 ip pim sparse-mode
 ip pim version 2
 service-policy output llq-policy
!
interface FastEthernet0/0
 ip address 192.168.146.1 255.255.255.0
 no ip proxy-arp
 no ip mroute-cache
 keepalive 1
 full-duplex
 speed 100
 ntp broadcast version 3
 standby 1 ip 192.168.146.3
 standby 1 timers 1 3
 standby 1 priority 100
 standby 1 preempt
 standby 1 name one
 standby 1 track FastEthernet0/1 10
 standby 1 track Loopback101 10
 standby 1 track Loopback102 5
 standby 1 track Multilink2 10
 ip ospf hello-interval 1
 ip ospf dead-interval 3
 ip ospf message-digest-key 1 md5 mymd5pw 
 ip pim sparse-mode 
 ip pim version 2
 ip pim query-interval 2 

interface FastEthernet0/1
 ip address 192.168.147.1 255.255.255.0 
 standby 2 timers 1 3
 standby 2 preempt
 standby 2 priority 100
 standby 2 ip 192.168.147.3
 standby 2 name two 
 standby 2 track Fa0/0 10
 standby 2 track Multilink2 10
 standby 2 track Loopback101 10
 standby 2 track Loopback102 5
 keepalive 1
 speed 100
 full-duplex
 ntp broadcast version 3
 ip ospf hello-interval 1
 ip ospf dead-interval 3
 ip ospf message-digest-key 1 md5 mymd5pw
 ip pim sparse-mode 
 ip pim version 2
 ip pim query-interval 2 
!
!
!interface Serial0/0:0
 no ip address
 encapsulation ppp
 keepalive 1 2
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1:0
 no ip address
 encapsulation ppp
 keepalive 1 2
 ppp multilink
 ppp multilink group 2
!
router ospf 1
 log-adjacency-changes
 area 2 nssa
 area 2 authentication message-digest 
 auto-cost reference-bandwidth 10240
 timers spf 1 10
 redistribute ospf 2 metric-type 1 subnets
 redistribute static metric-type 1 subnets
 network 192.168.170.2 0.0.0.3 area 2 
 distribute-list 10 out
 distance ospf external 125
 summary-address area-51-prefix mask 
!
router ospf 2 
 log-adjacency-changes
 auto-cost reference-bandwidth 10240
 area 51 authentication message-digest 
 timers spf 1 10
 redistribute ospf 1 metric-type 1 subnets tag 202051
 network 192.168.146.0 0.0.0.255 area 51
 network 192.168.147.0 0.0.0.255 area 51
 network 10.0.0.0 0.255.255.255 area 51
 default-information originate metric 100 metric-type 1 
 distribute-list 11 out 
 distance 120 
!
ip route 64.102.16.25 255.255.255.255 FastEthernet0/0
ip route 64.102.16.25 255.255.255.255 192.168.1.10
!

Notes

Keepalives must be set for all Ethernet interfaces to ensure proper redundant behavior. A keepalive value of 1 has been selected for maximum responsiveness.

Configuring no ip proxy-arp is helpful to avoid confusion with routes and ARP caches.

In a redundant configuration, both MWR 1941-DCs share a common IP address for their Multilink interface.

Monitoring and Managing the MWR 1941-DC

You can use Cisco's network management applications, such as CiscoWorks2000 for Mobile Wireless (CW4MW), to monitor and manage aspects of the MWR 1941-DC.

To enable remote network management of the MWR 1941-DC, do the following:


Step 1 At the privileged prompt, enter the following command to access configuration mode:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

Step 2 At the configuration prompt, enter the following command to assign a host name to each of the network management workstations:

Router(config)# ip host hostname ip_address

Where hostname is the name assigned to the Operations and Maintenance (O&M) workstation and ip_address is the address of the network management workstation.

Step 3 Enter the following commands to create a loopback interface for O&M:

Router(config)# interface loopback number
Router(config-if)# ip address ip_address subnet_mask

Step 4 Exit interface configuration mode:

Router(config-if)# exit

Step 5 At the configuration prompt, enter the following command to specify the recipient of a Simple Network Management Protocol (SNMP) notification operation:

Router(config)# snmp-server host hostname [traps | informs] [version {1 | 2c | 3 [auth | 
noauth | priv]}] community-string [udp-port port] [notification-type]

Where hostname is the name assigned to the CW4MW workstation with the ip host command in Step 2.

Step 6 Enter the following commands to specify the public and private SNMP community names:

Router(config)# snmp-server community public RO
Router(config)# snmp-server community private RW

Step 7 Enter the following command to enable the sending of SNMP traps:

Router(config)# snmp-server enable traps

Step 8 Enter the following command to specify the loopback interface from which SNMP traps should originate:

Router(config)# snmp-server trap-source loopback number

Where number is the number of the loopback interface you configured for the O&M in Step 3.

Step 9 At the configuration prompt, press Ctrl-Z to exit configuration mode.

Step 10 Write the new configuration to nonvolatile memory as follows:

Router# copy running-config startup-config


Show Commands for Monitoring the MWR 1941-DC

To monitor and maintain the MWR 1941-DC router (including the multilink, VWIC, and FE interfaces) and to view information about the PPP mux and header compression configuration, use the following commands:

Command
Purpose

show ip rtp header-compression

Displays RTP header compression statistics.

show interface fastethernet slot/port

Displays the status of the FE interface.

show ppp multilink

Displays MLP and multilink bundle information.

show ppp multilink interface number

Displays multilink information for the specified interface.

show ppp mux interface interface

Displays statistics for PPP frames that have passed through a given multilink interface.

show controllers fastethernet slot/port

Displays information about initialization block, transmit ring, receive ring and errors for the Fast Ethernet controller chip.

show controllers t1

Displays information about the cable length, framing, firmware, and errors associated with the T1. With the MWR 1941-DC, this command also displays the status of the relays on the VWIC.

show redundancy

Displays current redundant setting and recent changes in state.

show standby

Displays HSRP configuration information.

clear counters fastethernet slot/port

Clears interface counters.

clear ppp mux interface

Clears the PPP mux counters on the specified interface.

clear ip rtp header-compression

Clears RTP header compression structures and statistics.

show controllers

Displays all network modules and their interfaces. Displays the status of the VWIC relays when a VWIC is installed.

show interface type slot/port

Displays the configuration and status of the specified interface.

show protocols

Displays the protocols configured for the router and the individual interfaces.


Where to Go Next

At this point you can proceed to the following:

The Cisco IOS software configuration guide and command reference publications for more advanced configuration topics. These publications are available on the Documentation CD-ROM that came with your router, on the World Wide Web from Cisco's home page, or you can order printed copies.

The System Error Messages and Debug Command Reference publications for troubleshooting information