Guest

Cisco Wireless Controller Software for SRE

Installing Wireless Controller on Cisco SRE

  • Viewing Options

  • PDF (385.3 KB)
  • Feedback
Installing Wireless Controller on Cisco SRE

Table Of Contents

Installing Wireless Controller on Cisco SRE

Contents

Cisco Wireless Controller Software Support

Limitations and Restrictions

Preparing to Install Wireless Controller

Configuring Server for Installation Files

Configuring HTTP Server on Linux: Example

Configuring FTP Server on Windows: Example

Placing Installation Files on Server

Configuring a Host Router with an Onboard Gigabit Ethernet Port for Wireless Controller

Configuring Interfaces and NAT on the Host Router

Configuring Interfaces and NAT on a Host Router: Example

Verifying Connectivity on Three Interfaces

Configuration Examples

Standard Configuration Example

Multiple VLANs MGF without EtherSwitch Configuration Example

Installing Wireless Controller on the Cisco SRE

Installing Wireless Controller on the Cisco SRE: Example

Observing the Installation

Troubleshooting Tips

Where to Go Next

Additional References

Related Documents

Technical Assistance


Installing Wireless Controller on Cisco SRE


First Published: April 14, 2011
Last Updated: April 14, 2011

The Wireless Controller on Cisco SRE enables systemwide wireless functions in small to medium-sized businesses and branch offices. This document describes Wireless Controller installation on Cisco Integrated Services Routers Generation 2 (Cisco ISRs G2) running Cisco IOS Release 15.1(3)T.01 or a later software release. The Wireless Controller is supported on the following modules:

Cisco SRE Internal Service Module-Services Ready Engine (Cisco SRE ISM): ISM-SRE-300

Cisco SRE Service Module-Services Ready Engine (Cisco SRE SM): SM-SRE-700, SM-SRE -900

Although the Cisco ISR G2 can support more than one Cisco SRE, only one Wireless Controller per host platform is supported.

Contents

Cisco Wireless Controller Software Support

Limitations and Restrictions

Preparing to Install Wireless Controller

Configuring a Host Router with an Onboard Gigabit Ethernet Port for Wireless Controller

Configuration Examples

Installing Wireless Controller on the Cisco SRE

Troubleshooting Tips

Where to Go Next

Additional References

Cisco Wireless Controller Software Support

Cisco Wireless Controller requires the following software:

Cisco Wireless LAN Controller (WLC) version 7.0.115.0 and higher versions

Cisco Wireless Control System (WCS) version 7.0.172.0 and higher versions

Cisco IOS Release 15.1(3)T.01 and later releases

Limitations and Restrictions

Wireless Controller on Cisco SRE does not support the following features:

Datagram Transport Layer Security (DTLS) data encryption

OfficeExtend Access Point (OEAP)

Wireless Controller on Cisco SRE supports a maximum of 20 Hybrid Remote Edge Access Point (H REAP) groups with up to 25 access points (APs) per group.

The following restrictions apply to MGF and Wireless Controller on Cisco SRE:

MGF is enabled on the Cisco SRE only after Wireless Controller is successfully installed. MGF is not enabled on a blank Cisco SRE.

The interface on the EtherSwitch module must be in the same VLAN as the Wireless Controller on SRE to utilize MGF; otherwise, interVLAN communication still uses the PCIe interface on the Cisco SRE.

MGF check happens on each router bootup or reboot. You must reconfigure MGF if an EtherSwitch that does not support MGF is added or removed. For example, if you add a Cisco EtherSwitch HWIC or Cisco EtherSwitch Network Module switch to the host router, MGF will be disabled. All data traffic will no longer use the slot/1 interface of the Cisco SRE.

Preparing to Install Wireless Controller

Perform these tasks to prepare for installing Wireless Controller on the Cisco SRE:

Configuring Server for Installation Files

Placing Installation Files on Server

Configuring Server for Installation Files

Decide on the location of a directory for the Wireless Controller installation files. This location can be either an FTP server or HTTP server. These Wireless Controller installation files are later remotely accessed by the Cisco SRE module during the installation of Wireless Controller.

The following two examples show how to set up FTP server software on Windows or HTTP server software on Linux.

You may also choose to use different HTTP or FTP server software than the software that is used in these examples.

Configuring HTTP Server on Linux: Example

OR

Configuring FTP Server on Windows: Example

Configuring HTTP Server on Linux: Example

In the following procedure, the SimpleHTTPServer Python script is usually in one of the following locations:

/usr/lib64/python2.3/SimpleHTTPServer.py (64-bit Linux)

/usr/lib/python2.3/SimpleHTTPServer.py (32-bit Linux)

If the script is not located in one of the directories above, search for it using:

$ find /usr -name SimpleHTTPServer.py


Step 1 Open up a terminal window, such as xterm in Linux.

Step 2 cd /home/mydir

Step 3 Copy the Wireless Controller installation files shown in Table 1 to /home/mydir.

Step 4 python -m SimpleHTTPServer

The current directory is set up as an HTTP server. The following message appears. It shows the HTTP server starting in port 8000.

Serving HTTP on 0.0.0.0 port 8000 ...

Step 5 Open an internet browser and go to the server address and port number:

http://<server IP address>:8000

The directory files are listed. These files are the files used later in the "Installing Wireless Controller on the Cisco SRE" section.


Configuring FTP Server on Windows: Example


Step 1 Create an empty directory/folder on Windows to be the server location. For example, c:\ftp_server.

Step 2 Using an internet browser, go to https://filezilla-project.org/.

Step 3 Click "Download FileZilla Server"-for Windows.

Step 4 Click "FileZilla_Server-0_9_37.exe"-for Windows.

Step 5 Save this installer file to a directory on your Windows machine.

Step 6 Double-click on the installer file "FileZilla_Server-0_9_37.exe".

"License Agreement" is displayed in the setup dialog box.

Step 7 Click "I Agree".

"Choose Components" is displayed in the setup dialog box.

Step 8 Click Next.

"Choose Install Location" is displayed in the setup dialog box..

Step 9 Click Next.

The following default startup appears: "Install as service, started with Windows (default)".

Step 10 Click Next.

The following default setting appears: "Start if user logs on, apply to all users (default)"

Step 11 Click Install.

"Installing" and then "Installation Complete" is displayed in the setup dialog box.

Step 12 Click Close.

Step 13 Select Start > All Programs > FileZilla Server > Start FileZilla Server

The Connect to Server dialog box appears and shows the server address of 127.0.0.1 and Port 14147.

Step 14 Click OK.

The main FileZilla Server dialog box appears.

Step 15 Select Edit > Users.

The Users dialog box appears.

Step 16 Click Add.

The Add user account dialog box appears.

Step 17 Enter "anonymous" in the first text box and click OK.

The user named "anonymous" is displayed in the Users area on the right of the Users dialog box.

Step 18 In the Page: area of the Users dialog box, select "Shared folders" and click Add.

The Browse for Folder dialog box appears.

Step 19 Navigate to the directory/folder to use as your root FTP directory.

This example assumes that you choose directory c:\ftp_server, which was created in Step 1.

Step 20 Click OK.

Step 21 With the directory c:\ftp_server highlighted in the Shared Folders area, click "Set as home dir".

The letter H appears next to directory c:\ftp_server.


Note Start or stop the FTP server from the menu at Start > Programs > FileZilla Server.



Placing Installation Files on Server

Copy the files in Table 1 to your FTP or HTTP server from http://www.cisco.com. Choose Products & Services > Wireless > Wireless LAN Controllers > Cisco Wireless Controller Module for ISR G2 > Download Software > Cisco Wireless LAN Controller Module.

In the case of the FTP server used in the "Configuring FTP Server on Windows: Example" section, the installation files go in directory c:\ftp_server.

In the case of the HTTP server used in the "Configuring HTTP Server on Linux: Example" section, the installation files go in directory /home/mydir.

Table 1 WLC Installation Files 

File Name
Notes

AIR-WLC-SRE-K9-7.0.115.0.aes

File used in the service-module sm install command in the "Installing Wireless Controller on the Cisco SRE" section.

AIR-WLC-SRE-K9-7.0.115.0.aes.install.sre

 

AIR-WLC-SRE-K9-7.0.115.0.aes.install.sre.header

 

AIR-WLC-SRE-K9-7.0.115.0.aes.installer

 

AIR-WLC-SRE-K9-7.0.115.0.aes.key

 

ism_bl
OR
sm_bl

Use file ism_bl if you are installing WLC on a Cisco SRE-ISM module.

Use file sm_bl if you are installing WLC on a Cisco SRE-SM module.


Configuring a Host Router with an Onboard Gigabit Ethernet Port for Wireless Controller

Before configuring the host router, we recommend that you familiarize yourself with Cisco SRE and Multi Gigabit Fabric. See the following documents:

Cisco SRE Service Module Configuration and Installation Guide.

Cisco ISR G2 Multi Gigabit Fabric

Figure 1 shows an example branch office topology that includes Wireless Controller on Cisco SRE. The FTP and HTTP servers in the corporate office are used for installation. The TFTP server is used for licensing and cannot be used for installation. Installation is performed through the onboard Gigabit Ethernet port of the host router.

Figure 1 Example Branch Office Topology

To configure a host router for installation through an onboard Gigabit Ethernet port, perform the tasks in the following sections:

Configuring Interfaces and NAT on the Host Router

Verifying Connectivity on Three Interfaces

Configuring Interfaces and NAT on the Host Router

Perform the steps in this section to configure the interfaces and Network Address Translation (NAT) on the router prior to installing the Wireless Controller.

SUMMARY STEPS

From the Host-Router CLI

1. interface GigabitEthernet0/0

2. ip address router-side-ip-address subnet-mask

3. ip nat outside

4. no shutdown

5. exit

6. interface ism slot/0
or
interface sm slot/0

7. ip address router-side-ip-address subnet-mask

8. ip nat inside

9. service-module ip address module-side-ip-address subnet-mask

10. service-module ip default-gateway gateway-ip-address

11. no shutdown

12. exit

13. interface ism slot/0
or
interface sm slot/0

14. switchport mode trunk

15. no shutdown

16. interface vlan 1

17. ip address router-side-ip-address subnet-mask

18. exit

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

interface GIgabitEthernet0/0

Example:

Router(config)# interface GigabitEthernet0/0

Configures an interface type and to enter interface configuration mode.

This interface can be any interface that connects to the outside network.

Step 2 

ip address router-side-ip-address subnet-mask

Example:

Router(config-if)# ip address 172.19.150.230 255.255.255.0

Specifies the IP address for the router side of the interface.

router-side-ip-address subnet-mask—IP address and subnet mask for the router.

You must have an outside IP address.

Step 3 

ip nat outside

Example:

Router(config-if)# ip nat inside

Enables Network Address Translation (NAT) of the outside source address.

Step 4 

no shutdown

Example:

Router(config-if)# ip virtual-reassembly in

Restarts a disabled interface.

Step 5 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode on the host router.

Step 6 

interface ism slot/0

or

interface sm slot/0

Example:

Router(config)# interface sm 3/0

Enters interface configuration mode for the slot and port where the Cisco ISM-SRE resides.

or

Enters interface configuration mode for the slot and port where the Cisco SM-SRE resides.

Step 7 

ip address router-side-ip-address subnet-mask

Example:

Router(config-if)# ip address 40.1.0.30 255.255.0.0

Specifies the IP address for the router side of the interface.

router-side-ip-address subnet-mask—IP address and subnet mask for the router.

You must have an outside IP address to allow Telnet sessions into the module.

Step 8 

ip nat inside

Example:

Router(config-if)# ip nat inside

Enables NAT of the inside source address.

Step 9 

service-module ip address module-side-ip-address subnet-mask

Example:

Router(config-if)# service-module ip address 40.1.0.40 255.255.0.0

Specifies the IP address for the module side of the interface.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router

Step 10 

service-module ip default-gateway gateway-ip-address

Example:

Router(config-if)# service-module ip default-gateway 40.1.0.30

Specifies the IP address of the default gateway for the module.

gateway-ip-address—IP address for the default router.

Step 11 

no shutdown

Example:

Router(config-if)# no shutdown

Restarts a disabled interface.

Step 12 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode on the host router.

Step 13 

interface ism slot/0

or

interface sm slot/0

Example:

Router(config)# interface sm 3/1

Configures an interface type and to enter interface configuration mode.

Step 14 

switchport mode trunk

Example:

Router(config-if)# switchport mode trunk

Sets the interface type to trunking VLAN Layer 2.

Step 15 

no shutdown

Example:

Router(config-if)# ip virtual-reassembly in

Restarts a disabled interface.

Step 16 

interface vlan 1

Example:

Router(config)# interface vlan 1

Configures an interface type and enters interface configuration mode.

Step 17 

ip address router-side-ip-address subnet-mask

Example:

Router(config-if)# ip address 30.1.0.2 255.255.0.0

Specifies the IP address for the router side of the interface.

router-side-ip-address subnet-mask—IP address and subnet mask for the router.

Step 18 

ip nat inside

Example:

Router(config-if)# ip nat inside

Enables NAT of the inside source address.

Step 19 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode on the host router.

Configuring Interfaces and NAT on a Host Router: Example

This example shows the configuration of the following three interfaces on the host router:

Interface GE 0/0: connection to the FTP or HTTP server for downloading the Wireless Controller installation files

Interface ISM/SM: used for Wireless Controller installation

Interface VLAN1: native VLAN used to connect to Wireless Controller after installation

NAT is configured on all three interfaces.

interface GigabitEthernet0/0 
 ip address 172.19.150.233 255.255.0.0  !IP address to outside network (TFTP/FTP server)
 ip nat outside                         !Set interface to NAT outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface ISM0/0
 ip address 10.1.1.2 255.255.255.0      !Service module host side IP address
 ip nat inside  !To establish connectivity between SM and outside network for installation
 ip virtual-reassembly in
 service-module ip address 10.1.1.3 255.255.255.0 !Needed for WLC installation
!Application: Running
 service-module ip default-gateway 10.1.1.2       !Host side IP address
 hold-queue 60 out
!
interface ISM0/1
 description Internal switch interface connected to Internal Service Module
 switchport mode trunk    !Used for connectivity to Wireless Controller after installation
!
interface Vlan1
 ip address 10.0.78.15 255.255.255.0 
!Set Wireless Controller management interface to use this as default gateway
 ip nat inside     
!Use NAT to allow access from outside network to use Wireless Controller GUI
 ip virtual=reassembly in
!
! Sample NAT configuration
ip nat inside source list 5 interface GigabitEthernet0/0 overload
ip nat inside source static tcp 10.1.0.100 443 172.19.150.230 443 extendable
ip nat inside source static udp 10.1.0.100 443 172.19.150.230 443 extendable
!
! Static routes to help routing
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
! Access list for NAT translation
access-list 5 permit any
!
 
   

Verifying Connectivity on Three Interfaces

The following example shows files being installed from an FTP server. To install files from an HTTP server, change the url in the service-module sm install or service-module ism install command
from "ftp://<ftpserver>/AIR-WLC-SRE-K9-7.0.115.0.aes"
to "http://<httpserver>/AIR-WLC-SRE-K9-7.0.115.0.aes".

where, an example of <ftpserver> is: myuser:mypassword@172.19.150.32

an example of <httpserver> is: myuser:mypassword@192.168.1.2:8000

In the following example, the following IP addresses are used:

FTP server: 172.19.150.32

Cisco SRE: 10.1.0.40

Cisco SRE gateway: 10.1.0.30

Follow these steps to verify connectivity between the Cisco SRE, the Cisco SRE gateway, and the FTP server:


Step 1 Verify connectivity from the router that will host Wireless Controller to your FTP server:

Router# ping 172.19.150.32
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.19.150.32, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Router#
 
   

Step 2 Verify connectivity from the host router to the Cisco SRE:

Router# ping 10.1.0.40
             
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.0.40, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Router#
 
   

Step 3 Verify connectivity from the Cisco SRE to the Cisco SRE gateway and to the FTP server:

Router# service-module sm 3/0 session 
ServicesEngine boot-loader> ping 10.1.0.30                                     
 
   
Sending 5, 32 byte ICMP Echos to 10.1.0.30:
!!!!!
Success rate is 100% (5/5)
 
   
ServicesEngine boot-loader> ping 172.19.150.32                                 
 
   
Sending 5, 32 byte ICMP Echos to 172.19.150.32:
!!!!!
Success rate is 100% (5/5)
 
   
ServicesEngine boot-loader>   
 
   

Proceed to the "Installing Wireless Controller on the Cisco SRE" section.

Configuration Examples

This section contains the following host router configuration examples:

Standard Configuration Example

Multiple VLANs MGF without EtherSwitch Configuration Example

Standard Configuration Example

This configuration uses the onboard Gigabit Ethernet interface to install Wireless Controller on Cisco SRE.

interface GigabitEthernet0/0
 ip address 30.1.13.130 255.255.0.0  (External Network IP Subnet)
 ip nat outside
!
interface ISM0/0
 ip address 10.1.1.2 255.255.0.0  (Dummy IP address for reverse telnet to SRE)
 ip nat inside
 service-module ip address 10.1.0.30 255.255.0.0 (WLC install connectivity only)
 service-module ip default-gateway 10.1.0.2  (WLC install connectivity only)
!
interface ISM0/1
switchport mode trunk (Layer 2 MGF Interface) 
!
interface Vlan1  (Internal Network IP Subnet for MGF interface connectivity)
 ip address 55.1.0.1 255.255.0.0  (WLC Management IP address = 55.1.0.2)
 ip nat inside
!         
ip nat inside source list 5 interface GigabitEthernet0/0 overload  (PAT Config)
ip nat inside source static udp 55.1.0.2 161 30.1.13.130 161 extendable (WCS)
ip nat inside source static udp 55.1.0.2 162 30.1.13.130 162 extendable (WCS)
ip nat inside source static tcp 55.1.0.2 443 30.1.13.130 443 extendable (GUI)
ip nat inside source static udp 55.1.0.2 443 30.1.13.130 443 extendable (GUI)
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0  (static route)
access-list 5 permit any (ACL for your PAT Config)
 
   

Multiple VLANs MGF without EtherSwitch Configuration Example

The following configuration example applies to the deployment of Wireless Controller on Cisco SRE without EHWIC shown in Figure 2.

Figure 2 Wireless Controller Without EtherSwitch Deployment

(Cisco Controller) >show interface summary
 
   
Interface Name             Port Vlan Id  IP Address      Type    Ap Mgr Guest
-------------------------- ---- -------- --------------- ------- ------ -----
management                 1    untagged 55.1.0.2        Static  Yes    No   
virtual                    N/A  N/A      1.1.1.1         Static  No     No   
vlan20                     1    20       55.20.0.5       Dynamic No     No   
vlan30                     1    30       55.30.0.5       Dynamic No     No
 
   
Router Config:
interface GigabitEthernet0/1  (port connected to the L3 Switch)
 no ip address
!            
interface GigabitEthernet0/1.1 (Same subnet as External Switch VLAN1)
 encapsulation dot1Q 1 native
 ip address 50.1.1.50 255.255.255.0
!
interface GigabitEthernet0/1.20  (Same subnet as External Switch VLAN20)
 encapsulation dot1Q 20
 ip address 20.1.1.20 255.255.255.0
!
interface GigabitEthernet0/1.30  (Same subnet as External Switch VLAN30)
 encapsulation dot1Q 30
 ip address 30.1.1.30 255.255.255.0
 
   
 
   
interface ISM0/1    (MGF interface set to trunk)
 switchport mode trunk
!
interface Vlan1  (Same subnet as native VLAN on SRE-WLC)
 ip address 55.1.0.1 255.255.0.0
 ip nat inside
!
interface Vlan20  (Same subnet as VLAN 20 on SRE-WLC)
 ip address 55.20.0.1 255.255.0.0
!
interface Vlan30  (Same subnet as VLAN 30 on SRE-WLC)
 ip address 55.30.0.1 255.255.0.0
!
Interface GigabitEthernet0/0  (port connected to external network with WCS)
 ip add 172.168.13.130 255.255.255.0
 ip nat outside
!
ip nat inside source list 5 interface GigabitEthernet0/0 overload
ip nat inside source static udp 55.1.0.2 161 172.168.13.130 161 extendable
ip nat inside source static udp 55.1.0.2 162 172.168.13.130 162 extendable
ip nat inside source static tcp 55.1.0.2 443 172.168.13.130 443 extendable
ip nat inside source static udp 55.1.0.2 443 172.168.13.130 443 extendable
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
access-list 5 permit any
 
   
 
   
Layer3 Switch (E.g. C3560):
 
   
vlan 2-3,10,20,30,40
!
interface FastEthernet0/10  (port connected to GE 0/1 of Router)
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport access vlan 20  (VLAN 20 for APs)
!
interface Vlan1  (Same subnet as Router GE 0/1.1 interface)
 ip address 50.1.1.1 255.255.255.0
!
interface Vlan10 (Same subnet as Router GE 0/1.10 interface)
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan20 (Same subnet as Router GE 0/1.20 interface)
 ip address 20.1.1.1 255.255.255.0
!
interface Vlan30 (Same subnet as Router GE 0/1.30 interface)
 ip address 30.1.1.1 255.255.255.0
! 
 
   
 
   
Layer3 Switch (E.g. C3560):
! 
ip routing  (Key to inter-VLAN routing)
ip dhcp excluded-address 20.1.1.1 20.1.1.10
ip dhcp excluded-address 50.1.1.1 50.1.1.10
!
ip dhcp pool ap-pool
   network 50.1.1.0 255.255.255.0
   default-router 50.1.1.1 
   option 43 hex f104.3701.0002
!
ip dhcp pool vlan20
   network 20.1.1.0 255.255.255.0
   default-router 20.1.1.1 
   option 43 hex f104.3701.0002
!
ip route 55.1.0.0 255.255.0.0 Vlan1  (Can do static or dynamic routing)
ip route 55.20.0.0 255.255.0.0 Vlan20
ip route 55.30.0.0 255.255.0.0 Vlan30
 
   
 
   
Layer3 Switch (E.g. C3560):
 
   
3560-1# show ip dhcp binding 
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
20.1.1.13        0100.2290.90a2.22       Mar 22 1993 12:32 AM    Automatic
50.1.1.12        011c.df0f.9483.88       Mar 22 1993 12:53 AM    Automatic
 
   
3560-1# show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
 
   
Device ID         Local Intrfce     Holdtme   Capability    Platform   Port ID
AP1cdf.0f94.8388  Fas 0/9           151             T       AIR-LAP126Gig 0
AP0022.9090.a222  Fas 0/11          135             T       AIR-LAP114Gig 0
Router            Fas 0/10          151           R S I     CISCO2901/Gig 0/1.1
3560-1#
 
   
 
   
AP:
 
   
AP0022.9090.a222# show ip int brief
Interface                  IP-Address      OK? Method Status        Protocol
Dot11Radio0                unassigned      NO  unset  up            up      
Dot11Radio1                unassigned      NO  unset  up            up      
GigabitEthernet0           20.1.1.13       YES DHCP   up            up      
 
   
AP0022.9090.a222# show capw client rcb
AdminState                  :  ADMIN_ENABLED 
SwVer                       :  7.0.114.71 
NumFilledSlots              :  2 
Name                        :  AP0022.9090.a222 
Location                    :  default location 
MwarName                    :  2911_gn 
MwarApMgrIp                 :  55.1.0.2
MwarHwVer                   :  0.0.0.0 
 
   
AP0022.9090.a222# ping 55.1.0.2
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 55.1.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
 
   
 
   

Installing Wireless Controller on the Cisco SRE

After beginning the installation as described in this section, continue to the following subsections:

Installing Wireless Controller on the Cisco SRE: Example

Observing the Installation


Note Ensure all the WLC SRE installation files in Table 1 are placed under the root FTP/HTTP path as described in "Configuring Server for Installation Files" section.


To install Wireless Controller on the Cisco SRE module, complete the following steps.


Note Once the installation begins, do not enter commands on the module until the installation successful message appears.


SUMMARY STEPS

1. enable

2. service-module ism slot/port install url url [script filename] [argument "string"] [force]

or
service-module sm slot/port install url url [script filename] [argument "string"] [force]

3. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

password

Example:

Router> enable

Router> password

Router#

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

service-module ism 0/0 install url url [script filename] [argument "string"] [force]

or

service-module sm 3/0 install url [ftp | http]://[username:password]@<IP-address>/direct ory>/<pkg-filename>

Example:

Router# service-module sm 3/0 install url ftp://myuser:mypassword@172.19.150.32/AS_SMWLC_ 7_0_112_70.aes

Runs bootloader to start installation of an application on the specified Cisco SRE module.

slot/port—Position of target module in router chassis. For Cisco ISM-SRE or SM-SRE, always use 0 for the port number. The slash (/) is required between the slot and port numbers.

url url—URL, as defined in RFC 2396, of the server and directory on which the application packages and Tcl script are located. The URL should point to the .bin or .pkg file on the FTP or HTTP server. The router downloads and installs all other files required to complete the application installation.

Step 3 

exit

Example:

Router# exit

Exits privileged EXEC mode.

Installing Wireless Controller on the Cisco SRE: Example

The following example shows files being installed from an FTP server. To install files from an HTTP server, change the url in the service-module sm install or service-module ism install command
from "ftp://<ftpserver>/AIR-WLC-SRE-K9-7.0.115.0.aes"
to "http://<httpserver>/AIR-WLC-SRE-K9-7.0.115.0.aes".

where, an example of <ftpserver> is: myuser:mypassword@172.19.150.32

an example of <httpserver> is: myuser:mypassword@192.168.1.2:8000

In the following example Wireless Controller is installed on the Cisco SRE from the FTP server.

Router# service-module sm 3/0 install url 
ftp://123:123@172.19.150.32/AIR-SRE-K9-7.0.115.0.aes    
Proceed with installation? [no]: yes
Loading AS_SMWLC_7_0_112_59.aes.install.sre !
[OK - 2787/4096 bytes]
Welcome to WLC installation checking resource requirements now
Resource check complete proceeding with installation
 
   
Router#
 
   

Observing the Installation

To see messages from the 12-step installation process open a session on the SRE-ISM or SRE-SM. The following is a sample installation. Significant steps are bolded.

SRE step 1 - SM registration...
 
   
SRE step 2 - SM requests key file info...
 
   
SRE step 3 - SM stores registration info...
 
   
Updating flash with bootloader configuration.
Please wait................done.
 
   
SRE step 4 - SM downloads key-file...
Writing keyfile to flash Size 914
writing complete.
 
   
SRE step 5 - SM requests installer info...
 
   
SRE step 6 - SM stores installer info...
 
   
Updating flash with bootloader configuration.
Please wait ..
 
   
SRE step 7 - SM now downloads installer
 
   
SRE step 8 - SM requests tcl header file ino...
 
   
SRE step 9 - SM now downloads the tcl header file
TCL header file downloaded completely size: 690
SRE step 10 - SM requests tcl file info...
SRE step 11 - SM now downloads the tcl file
TCL file downloaded completely size: 2787
 
   
SRE step 12 - SM now boots installer
Verifying...
 
   

After Step 12, more messages appear. If the installation is successful, you see a confirmation message and a system restart message similar to the following:

Install successful on ISM0/0
.
.
.
Restarting system.
 
   

The installation process should take approximately 2-3 minutes.

Troubleshooting Tips

TFTP/FTP/HTTP server can not ping the SRE

1. Check if NAT configuration is applied on interfaces.

2. Check if access list is correctly configured.

Cisco SRE and [interface ism | sm ] 0/0 interface can't ping each other

1. Check service-module ip address is configured on Cisco IOS software.

2. Check that the service-module ip default-gateway command is configured.

3. Check that IP address of SRE in SRE bootloader, using show config command, has same IP address as that configured by the service-module ip address command.

4. Check that TFTP server IP address in SRE bootloader, using show config command, has same IP address as that configured by the service-module ip default gateway address command.

Example:

ServicesEngine boot-loader> show config                                        
IP addr:                40.1.0.30
Netmask:                255.255.0.0
TFTP server :           30.1.1.115
GW IP addr:             40.1.0.2
Default Boot:           chainloader
Bootloader Version:     2.1.29
Bootloader Name:        bootloader
Default Helper-file:    AS_SMWLC_7_0_114_9.aes.installer
Default bootloader:     secondary
 
   

Cannot access Wireless Controller via HTTPS (GUI)

If NAT is used, check that extendable TCP and UDP port 443 pair are configured.

No connectivity between Wireless Controller management interface to host interface and external network

1. If MGF is enabled, check that Wireless Controller Management Interface is in the same subnet of the native VLAN on the Cisco IOS software side.

2. Verify that interface [ism | sm] slot/1 is in no shutdown and has switchport mode trunk configured.

or

1. If MGF is disabled because of the presence of a legacy EtherSwitch module, check that VLAN sub-interfaces are created and bridged to use the BVI interface.

2. Verify that encapsulation dot1q and `bridge irb are configured.

Cannot add Wireless Controller to WCS

1. If NAT is used, check that extendable UDP port 161, 162 are configured.

2. Debug the connectivity issue between WCS and Wireless Controller if they are not in the same network.

Cisco SRE can ping the FTP server but installation will not start

1. Check username and password.

2. Check the directory or path to the files on the FTP server.

Where to Go Next

To configure Wireless Controller, see Configuring Wireless Controller on Cisco SRE.

Additional References

Related Documents


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html