Cisco Voice Log Translator 2.7(8) User Guide
How to Use Cisco VLT
Downloads: This chapterpdf (PDF - 1.4MB) The complete bookPDF (PDF - 2.67MB) | Feedback

How to Use Cisco VLT

How to Use Cisco VLT

The following sections provide information on using Cisco VLT.

Displaying a List of Trace Log Messages

You can open trace log message files and display a list of messages as follows:

Summary Steps

To display a list of trace log messages, follow these summarized steps:

Procedure

  1. Choose Start > Programs > Cisco VLT > VLT.
  2. Choose File > Open > Open > Yes/No.
  3. Choose File > Append > Open > Yes/No.
  4. Choose View...
  5. Choose File > Save Translation.
  6. Choose File > Close and File > Exit.

Detailed Steps

To display a list of trace log messages, follow these detailed steps:

  1. Choose Start > Programs > Cisco VLT > VLT to open Cisco VLT.
  2. In the Open Files box, go to the folder where the trace log message files are stored, highlight one or more filenames (use <Ctrl> or <Shift> as needed to select multiple messages) and click Open.

The first 1000 selected files open in a single pane, sorted by timestamp.


Note


The number of files that you can open is limited only by available system memory. If files are large, system performance may be affected.



Note


If you open multiple log files, the tab displays only the first filename.


  1. Open an additional set of log files, if needed:
    • Choose File > Append.
    • Highlight one or more filenames and click Open.
  2. Edit the Messages upper pane display:
    • To display or hide columns, choose View > Columns, check or uncheck the boxes, as needed.
    • To display all calls in a file, choose View > List All CallRefs. A new window displays the following information depending on protocol and message types: timestamp, protocol, call reference, calling party, and called party. Close the window when finished.
    Figure 1. Cisco VLT View Menu



To change the display contrast and font size, follow these steps:

Procedure:

  1. Choose View > Configuration as shown in Detailed Steps.
  2. Choose a log level (off, fatal, error, warn, info, debug, or all).
  3. Choose a theme (default or high contrast).
  4. Choose a font size (small, normal, or large).
  5. Click OK.
    Figure 2. Cisco VLT Configuration Window



  6. Edit the Messages Translation lower pane display by toggling among the following choices: Raw, Simple, and Detailed.

    Note


    If the signaling protocol for a message is invalid or not supported, you can display the message in raw format only.


  7. To open and display the trace log files that contain one or more particular messages, highlight the messages, right-click, and select Open Trace File. New windows display the trace log files. To search for a particular text string, use the Find box. Close the windows when you are finished.

    Note


    To display a list of valid wildcards and operations, choose Help > Regular Expression Reference.


  8. To save a message translation to a flat text (.txt file extension) file, choose File > Save Translation. In the Save File box, enter a location and name for the new file, and click Save.
  9. When you are finished, close any active messages-list windows by choosing File > Close. Exit Cisco VLT by choosing File > Exit.

Filtering the Trace Log Message List

You can filter a trace log message list to do the following:

  • Display or exclude keep-alive messages, see Detailed Steps below.
  • Display a list of messages with criteria that you check or supply, or with the same criteria as those possessed by messages that you highlight, see Detailed Steps below. Criteria includes the following:
    • Retries—Messages that are flagged as retried messages.
    • Highlighted device IP—Device IP address where messages are sent or received. Typically includes Cisco Unified Communications Manager, Cisco IOS gateways, IP phones, and more.
    • Highlighted direction—Receive or Send.
    • Highlighted protocol—H.225, H.245, JTAPI, MGCP, Q.931, SCCP, or SIP.
    • Highlighted message type—Example: Q.931 SETUP messages.
    • Highlighted call reference—The call-reference string in the CallRef column.
    • Highlighted channel—A voice port on a device. Examples: B channels on a PRI, a voice port on an IP phone, a CTI port for JTAPI.
    • Highlighted call—All messages that are associated with the call for which one or more messages are highlighted, across multiple signaling protocols (MGCP, Q.931, SCCP, and SIP).
    • Highlighted rows—Only the highlighted messages use <Ctrl> or <Shift> as needed to select multiple rows. If you highlight multiple messages, the Messages Translation lower pane displays the message for the last selected message.
    • Keyword—Messages that contain a specified text string.
    • Abnormal disconnect—Messages that have abnormal disconnect causes (cause codes that designate abnormal disconnect vary by protocol). This applies to calls that disconnect for reasons other than Normal Call Clearing or User Busy. Calls that disconnect because the user dials an invalid prefix or other numbers is classified as an abnormal disconnect.
    • Excluding keepalive.
      • Display a list of messages for calls with specified criteria—this is useful if you prefer to enter parameters directly instead of selecting messages in the Messages upper pane, see Detailed Steps below.

Summary Steps

To filter the trace log message list, perform the following steps:

Procedure

  1. Display message list.
  2. Choose Exclude KeepAlive.
  3. Choose Filter...
  4. Choose Filter > Advanced Filter...
  5. Choose File > Close and File > Exit.

Detailed Steps

To filter the trace log message list, perform the following detailed steps:

  1. Display the desired message list (see the Displaying a List of Trace Log Messages).
  2. To suppress display of keepalive messages, check the Exclude KeepAlive box.
  3. To display messages that contain a specific text string, enter the text in the Keyword box and press Enter.
  4. To define a filter based on existing message displays, do the following:

    Note


    The Filter function operates on the list of messages in the Messages upper pane.



    Note


    In contrast, the Find in Messages Translation function (see the Finding Information in Trace Log Message Text), operates on the current message in the Messages Translation lower pane.

    • Highlight one or more messages (use <Ctrl> or <Shift> as needed to select multiple messages) with the desired device IP, direction, protocol, message type, call reference, channel, or call.
    • Click Filter (or right-click the highlighted message), then check the desired filter criteria and, if prompted, enter required information such as keywords (Detailed Steps). (To see a list of filter criteria, see the discussion preceding this procedure.) Column headings for the desired criteria display in parentheses.
    • Repeat, as needed, to further filter by other criteria.


    Note


    To disable a filter, click the column headings in parentheses or choose Filter > Clear All Filters.


    Figure 3. Cisco VLT Filter Menu



  5. A customized filter is useful if you know the parameters and prefer to enter them directly instead of constructing filters by selecting messages in the Messages upper pane. To define your own customized filter, do the following:
  6. Choose Filter > Advanced Filter.
  7. Check and uncheck the displayed conditions as appropriate. Review the displayed values for each condition and edit them using wildcards and simple AND and OR operations.

    Note


    To display a list of valid wildcards and operations, click ?.



    Note


    To clear all entries, click Clear. To reload the current filter, click Current.


  8. Click Ok. A filtered list displays.
  9. When you are done, do the following:
  10. Close any active messages-list windows by choosing File > Close.
  11. Exit Cisco VLT by choosing File > Exit.

Finding Information in Trace Log Message Text

You can do the following with the text of a trace log message:

  • Specify a level of translation—raw, simple, or detailed (Detailed Steps below).
  • Copy message text to the clipboard (Detailed Steps below).
  • Search for a specific message-text string (Detailed Steps below).
  • Display the desired message text.

Summary Steps

To find information in trace log message text, perform the following steps:

Procedure

  1. Display message list.
  2. Choose Raw, Simple, or Detailed.
  3. Choose Edit > Copy.
  4. Choose Edit > Find in Messages Translation.
  5. Choose File > Close and File > Exit.

Detailed Steps

To find information in trace log message text, perform the following detailed steps:

  1. Display the desired message list (see the Displaying a List of Trace Log Messages).
  2. Specify a level of translation by toggling among the following choices—Raw, Simple, or Detailed (see samples of each in the Cisco VLT Message Translations).
  3. To copy a message translation to the Windows clipboard, do the following:
  4. Highlight the message or translation that you want to copy.
  5. Choose Edit > Copy or click the Copy icon.
  6. To search for a specific text string in the Messages Translations lower pane for all messages listed in the Messages upper pane, do the following:

    Note


    The Find in Messages Translation function operates on the current message in the Messages Translation lower pane.



    Note


    In contrast, the Filter function (see the Filtering the Trace Log Message List), operates on the list of messages in the Messages upper pane.


  7. Choose Edit > Find in Messages Translation or click the Find in Translated Message icon.
  8. In the Text to Find box, type a text string using wildcards and simple AND and OR operations, then click Find Next. The first match is highlighted (Detailed Steps).

    Note


    To display a list of valid wildcards and operations, choose Help > Regular Expression Reference.


  9. Choose Edit > Find Again to highlight additional instances.
    Figure 4. Cisco VLT Edit Menu



  10. When you are finished, do the following:
  11. Close any active messages-list windows by choosing File > Close.
  12. Choose File > Exit to exit Cisco VLT.