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* Logger
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* AGENT-PG

- VRU-PG

CVP Template
« CVP CALL SERVER
- CVP OAMP
+ CVP REPORTING

VOS Template
* FINESSE
- CUIC
+ CUCM
- |dS
* Live Data

Optional Template

* Media Sense
* Remote Silent
Monitor (RSM)

Customer Host 1

* Unified CCE Rogger side A

* Unified CVP server

« AW-HDS-DDS

* Finesse Publisher

* Unified Communications Manager Publisher

- Unified Communications Manager Subscriber 1
* Unified CVP Reporting (Optional)

Customer Host 2

*» Unified CCE Rogger side B

* Unified CVP server 1B

- Unified CVP server 2B

* Unified Intelligence Centre Subscriber

* Finesse Subscriber

= Unified Communications Manager Subscriber 2
* Unified CVP OAMP

Customer Host Optional

» Cisco Remote Silent Monitoring Server
+ Cisco Media Sense

Automated Cloning and 0S Customization

For the following automation software and download information see, Automation Software section in Cisco

HCSfor Contact Center Installing and Upgrading Guide http://www.cisco.com/c/en/us/support/

Running Automation
script (Power CLI)
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* GoldenTemplateTool
* PowerCLI
* OVF Tool
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Automated Cloning and 0S Customization Using Golden Templates .

* Winlmage

Automated Cloning and 0S Customization Using Golden Templates

Sequence Task Done
1 Download Golden Template
Automation Tool, on page 3
2 Complete Automation Spreadsheet,
on page 4
3 Run Automation Script, on page
5
4 OS Customization Process, on page
6

Download Golden Template Automation Tool

Golden Template Tool is required for automated cloning of Golden Templates and deploying the customized
Virtual machines in a customer instance. To download and extract the Golden Template Tool, see Automated
Cloning and OS Customization, on page 2 to the root of the C: drive on your system. You can browse the
automation scripts using VMware vSphere PowerCLI.

The extracted content includes the following:

» The automation spreadsheets, which is the interface to the scripts.

* The scripts folder that contains five scripts. The deployVM.PS1 file is the primary automation script,
which calls the other four scripts.

* The Archive, Log, OVF, PlatformConfigRepository, and Report folders are empty until you run the
automation script for export.

After you run the script for the first time:

« Archive holds the prior versions of the automation spreadsheet, saved with a date and a time stamp.
* Log holds all the log files saved with a date and a time stamp.

» OVF, when the tool runs the Export operation, a sub folder is created for each virtual machine. The
folders take their names from the GOLDEN TEMPLATE NAME cells in the spreadsheet. These folders
are used to import the virtual machines to the customer ESXi host.

» PlatformConfigRepository is populated with three subfolders that holds XML files generated as part of
the golden template process.

* Report holds all automation reports, saved with a date and a time stamp.

Related Topics
Automated Cloning and OS Customization, on page 2
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. Complete Automation Spreadsheet

Complete Automation Spreadsheet

Fill the information provided in the table to complete the automation spreadsheet for cloning process. Deploy
VM automation script requires this information to clone the virtual machines to the customer instance.

The table describes the values of each virtual server and associated properties:

Column Domain-based VM Workgroup-based VM | VOS-based VM

CREATEVM YES YES YES

CUSTOMIZATION YES YES YES

OPERATION

SOURCE HOST IP 10.10.0.10 10.10.0.10 10.10.0.10

SOURCE_DATASTORE NAME Datastore-AO Datastore-AO Datastore-AO

SOURCE_VMNAME

OVF _NETWORKI1

OVF _NETWORK?2

GOLDEN_TEMPLATE NAME GT-Rogger GT-CVP-Server GT-CUCM

NEW_VM NAME CCE-RGR-SIDE-A  |CVP-SVR-SIDE-A  |UCM-SUB-SIDE-A

DEST HOST _IP 10.10.1.10 10.10.1.11 10.10.1.12

DEST DATASTORE NAME Datastore-Al Datastore-A3 Datastore-A6

PRODUCT_VERSION 10.0.1

COMPUTER NAME CCE-RGR-SDE-A CVP-SVR-SDE-A UCM-SUB-SDE-A

WORK GROUP NO YES

WORK_GROUP_NAME WORKGROUP

DOMAIN NAME HCSCC.COM HCSCC.COM
(Optional)

TIME_ZONE _LINUX_AREA America

TIMEZONE LINUX LOCATION Los Angeles

TIME_ZONE_WINDOWS (GMT-08:00) (GMT-08:00)

DOMAIN_USER HCSCC\administrator

DOMAIN PASSWORD eeccccce

PRODUCT_KEY OORXIOARXIKAIIX | XHOHIIOARIOAXHKAKX

OWNER_NAME HCS HCS

ORGANIZATION_NAME CISCO CICO CICO

ORGANIZATION_UNIT HCS

ORGANIZATION_ LOCATION San Jose
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Run Automation Script .

Column Domain-based VM Workgroup-based VM | VOS-based VM
ORGANIZATION_STATE CA
ORGANIZATION_COUNTRY USA
NTP_SERVER 10.81.254.131
NIC_NUM 2 1 1

IP_ ADDRESS NICI 10.10.10.10 10.10.10.20 10.10.10.30
SUB NET MASK NIC1 255.255.255.0 255.255.255.0 255.255.255.0
DEFAULT GATEWAY NICI 10.10.10.1 10.10.10.1 10.10.10.1
DNS _IP NICI 10.10.10.3 10.10.10.3 10.10.10.3
DNS_ALTERNATE NIC]1

IP_ ADDRESS NIC2 192.168.10.10

SUB_NET_MASK_NIC2 255.255.255.0

DEFAULT GATEWAY NIC2 192.168.10.1

DNS IP NIC2 192.168.10.3

DNS ALTERNATE NIC2

VM _NETWORK1

VM_NETWORK?2

Run Automation Script

Before you begin

Download and install VMware vSphere PowerCLI on the client computer.

\}

Note Ensure Winlmage (32-bit) is installed in the following location: C:\Program Files (x86)\WinImage

N

Note If you import any of the VOS VMs and have an unlicensed copy of WinImage, displays the popup for each
VOS platform. Click OK to continue the import process.

Procedure
Step 1 Sign-in as an administrator and open VMwar e vSphere Power CLI (32-bit) application.
Step 2 Enter the get-executionPolicy command to determine the restricted execution policy.
Step 3 If the policy is restricted, enter set-executionPolicy command. At the Supply Values prompt, enter

Unrestricted, then enter Y.

Clone and 0S Customization .
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. 0S Customization Process

Step 4
Step 5

Change the execution policy to run unsigned scripts on your local computer and signed scripts from other
users.

Enter the CD < GoldenTemplate directory>command.

Run the automation script using the following syntax:

Syntax: Example:

<Path to the script> <Path
of the spreadsheet>
<vCenter |P/ Hosthame>
<vCenter User> <Password
to connect to vCenter>

.\scripts\DeployVM.PS1
C:\GoldenTemplate\GoldenTemplate VMDataSheet.xls
testvCenter testuser testpassword

This starts the script that parses and validates the data, creates entries in the GoldenTemplate directory.
Displays the completion percentage on the screen and generates the Status Report inthe Report folder.

Click the Log File link in the Status report to debug error conditions and to consult Cisco Support.

Figure 1: Status Report of Golden Template Tool

Status Report of Golden Template Tool

VM NAME

OPERATION

HOST IP

DATASTORE NAME

STATUS

DESCRIPTION

40PG-CUCM-Cust9-Pub

|CREATE VM from A Template

aurora-fl-cth-bS.cisco.com:

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust9-Sub

|CREATE VM from A Template

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust9-Pub

|CREATE VM from A Template

aurora-fl-ch10-b3.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust9-Sub

CREATE VM from A Template|

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust10-Pub.

CREATE VM from A Template|

aurora-fl-ch10-b3.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust10-Sub|

CREATE VM from A Template|

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust10-Pub

CREATE VM from A Template

aurora-fl-ch10-b3.cisco.com

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust10-Sub

CREATE VM from A Template [aurora-fl-ch10-b6.cisco.com

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

Log File

Related Topics

Automated Cloning and OS Customization, on page 2

OS Customization Process, on page 6

0S Customization Process

Sequence

Task

Done

Windows Customization Process

1 Validate Network Adapter Settings
and Power On, on page 7
2 Edit Registry Settings and Restart

VM, on page 7

VOS Customization Process

1

Configure DNS Server

. Clone and 0S Customization
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Validate Network Adapter Settings and Power On .

Sequence Task Done
2 Configure Host in DNS Server
3 Validate Network Adapter Settings

and Power On, on page 7

Validate Network Adapter Settings and Power On

Step 1
Step 2

Step 3

Step 4

Perform this procedure for all Windows VMs.

Procedure

Select the Virtual Machine in the vSphere client. Right-click the VM and choose Edit settings.

On the Har dwar etab, select each Network adapter. Make sure that Connect at power on in the Device Status
group is checked:

Power on the virtual machine.

Important Do not press Ctrl-Alt-Delete. If you press Ctrl-Alt-Delete after powering on, the customization
does not take effect. You must complete it manually.

Wait for the VM to restart and to apply customization. This can take five to ten minutes.

Recover from Pressing Ctrl-Alt-Del During Power-0On

Step 1
Step 2
Step 3

Step 4

Validate Network Adapter Settings and Power On initializes the customization process. Although you are
prompted to press Ctrl-Alt-Delete after powering on, doing do prevents the customization from taking effect.
DO NOT press Ctrl-Alt-Del. If you inadvertently press Ctrl-Alt-Del, you have the following option to restore
the customization.

Procedure

Get the GoldenTemplate VMDataSheet.xls from the C: /GoldenTemplateTool/Archive.
Copy and paste the GoldenTemplate VMDataSheet.xlsto C: /GoldenTemplateTool.

In the GoldenTemplate VMDataSheet.xls select No in all the rows for the column CREATEVM except for
those which needs to re-deploy.

Else, you can enter that data manually for the VM.

Edit Registry Settings and Restart VM

Step 1

Perform this procedure for all Windows VMs.

Procedure

Select Start > All Programs> Administrative Tools> Computer Management.

Clone and 0S Customization .
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. Automated Cloning and 0S Customization Using OVF

Step 2

Step 3
Step 4
Step 5
Step 6
Step 7

Step 8
Step 9

On the left panel, expand Computer Management (L ocal) > System Tools> L ocal Usersand Groups>
Users.

On the right panel, right-click the administrator and select Set Password.
Click Proceed at the warning message, then enter the new password.
Click OK.

Access the Registry Editor (Start > Run > regedit).

Select HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > Current Version >
Winlogon.

a) Set AutoAdminLogon to O.
b) Remove these keys if they exist: DefaultDomainName and DefaultUser Name.

Restart the machine. If the machine is in the domain, log in to the domain.
Enter NET TIME /DOMAIN:<domain> command to synchronize time with the domain controller.

Automated Cloning and 0S Customization Using OVF

Sequence Task Done

1 Download Golden Template
Automation Tool, on page 3

2 Complete Automation Spreadsheet
for Export, on page 8

3 Run Automation Script for Export,
on page 9

4 Transport to Desired Location, on
page 10

5 Ensure Readiness of the Location,
on page 10

6 OS Customization Process, on page
6

Complete Automation Spreadsheet for Export

Prerequisite:
Before the Export process, ensure that the VM has only one Network Adapter to export.

When you complete the automation spreadsheet to export, fill only the columns so that the export automation
script creates export OVFs in the OVF subfolder of the GoldenTemplate directory.

Table 1: Required Columns for Automation Spreadsheet for Export

Column Description Example

CREATEVM Select NO to skip VM creation. | NO

. Clone and 0S Customization
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Run Automation Script for Export .

Column

Description

Example

OPERATION

Select ExportServer to specify the
operation you are performing with
the script.

ExportServer

SOURCE_HOST _IP

The IP address of the physical
server hosting the VM to be
exported.

XX XX XXX XXX

SOURCE DATASTORE NAME

The name of the Datastore defined
in VMware.

datastore1(3)

SOURCE VMNAME

The name of the VM that will be
exported cannot contain spaces or
special characters. Maximum of 32
characters.

TemplateRoggerA

GOLDEN TEMPLATE NAME

New Name for the Exported VM
cannot contain spaces or special
characters. Maximum of 32
characters.

CustomerRoggerA

Leave all the other columns blank.

Run Automation Script for Export

Step 1
Step 2

Step 3

Step 4
Step 5

The export script processes the data in the export spreadsheet and validates that the required fields are present

in the correct format.

The script creates a folder from which you can import the OVF at the desired location.

\)

Note

Run the script from the GoldenTemplate directory.

Before you begin

Download and install VMware vSphere PowerCLI on the client computer.

Procedure

Launch VMwar e vSphere Power CLI (32-Bit) as administrator.

Enter get-executionPolicy command to determine whether the Restricted Execution policy is in effect

or is unrestricted.

If the policy is restricted, enter set-executionPolicy command. At the Supply Values prompt, enter
Unrestricted and then enter Y. This changes the execution policy, so that you can run unsigned scripts
that you write on your local computer and signed scripts from other users

Enter cd < GoldenTemplate directory>command.

Enter the command to run the automation script using the following syntax:

Clone and 0S Customization .
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Syntax:

Example:

vCenter>

<Path to the script> <Path of the
spreadsheet> <vCenter |P / Hosthame>
<vCenter User> <Password to connect to

.\scripts\DeployVM.PS1
C:\GoldenTemplate\GoldenTemplate VMDataSheet.xls
testvCenter testuser testpassword

This starts a script that parses the data, validates the data, and creates entries in the OVF folder in the
GoldenTemplate directory.

Script is run despite errors. Errors get displayed on the screen and stored in the log file.

Script takes several hours to complete.

After completion, script generates a status report in the Report folder. The status report has a link to the
Log file. Use this file to debug error conditions and to consult with Cisco Support.

Figure 2: Status Report of Golden Template Tool

Status Report of Golden Template Tool

VM NAME

OPERATION

HOST IP

DATASTORE NAME

STATUS

DESCRIPTION

40PG-CUCM-Cust9-Pub

|CREATE VM from A Template

aurora-fl-chl(}-bS.cisco.com:

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust9-Sub

|CREATE VM from A Template

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust9-Pub

|CREATE VM from A Template

aurora-fl-ch10-b3.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust9-Sub

CREATE VM from A Template|

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust10-Pub.

CREATE VM from A Template|

aurora-fl-ch10-b3.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-CUCM-Cust10-Sub|

CREATE VM from A Template|

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust10-Pub

CREATE VM from A Template|

aurora-fl-ch10-b3.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

40PG-Finesse-Cust10-Sub

CREATE VM from A Template|

aurora-fl-ch10-b6.cisco.com|

Solidfire-HCS-40PG-3 |

Success

VM deployed successfully

Log File

Related Topics

Automated Cloning and OS Customization, on page 2

Transport to Desired Location

After the successful completion of export process, the OVF files can be transferred to any desired location.

You can also transfer the GoldenTemplate directory to a USB device.

)

Note

In that case, you would complete the import spreadsheet and run the import script from the USB drive.

Ensure Readiness of the Location

Before completing the import spreadsheet and running the import script, the environment must be set up with

the following:

« the ESXihost or vCenter

. Clone and 0S Customization
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Manual Cloning and 0S Customization .

* the datastores

Manual Cloning and 0S Customization

* Create Customization File for Windows Based Components, on page 11
* Deploy Virtual Machine from the Golden Template, on page 12

* Generate Answer File for VOS Product Virtual Machines, on page 12

* Copy Answer Files to Virtual Machines, on page 13

Create Customization File for Windows Based Components

Step 1
Step 2
Step 3

Step 4
Step 5

Step 6

Step 7

Step 8
Step 9
Step 10

Step 11

Complete the following procedure to create the customization file for windows based components .

Procedure

In VMware vSphere Client, choose View > Management > Customization Specification Manager.
Click New.
On the New Customization Specification page, complete the new customization specification:

a) From the Target Virtual Machine OS menu, choose Windows.

b) Under the Customization Specification Information, enter a name for the specification and an optional
description and click Next.

On the Registration Information page, specify the registration information for this copy of the guest operating
system. Enter the virtual machine owner's name and organization and click Next.

On the Computer Name page, click the most appropriate computer name option that identifies this virtual
machine on the network.

On the Windows License page, specify the Windows licensing information for this copy of the guest operating
system:

a) Enter your product volume license key.
b) Check Include Server Licenseinformation (required to customize a server guest operating system).

¢) Click Per server to specify the server license mode. Enter 5 as the maximum number of connections you
want the server to accept. Click Next.

On the Administrator Password page, enter a password for the administrator account and confirm the password
by reentering it. Click Next.

On the Time Zone page, choose the time zone for the virtual machine and click Next.

On the Run Once page, click Next.

On the Network page, choose the type of network settings to apply to the guest operating system and click
Next:

a) Typical settings allow the vCenter server to configure all network interfaces from a DHCP server.
b) Custom settings require you to manually configure the network settings.

On the Workgroup or Domain page, click Windows Server Domain and enter the destination domain, the
username, and the password for a user account that has permission to add a computer to the specified domain.

Clone and 0S Customization .
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. Deploy Virtual Machine from the Golden Template

Step 12

Step 13

On the Operating System Options page, check Generate New Security ID (SID) to generate a new security
identity and click Next.

On the Ready to complete page, review your Customization File Summary, and then click Finish.

Deploy Virtual Machine from the Golden Template

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Step 7

Step 8
Step 9
Step 10

Complete the following procedure to deploy the virtual machine from the golden template. Use the deployment
checklists to record the hosts, IP addresses, and SAN locations for your deployment.

Procedure

Right-click the template and choose Deploy Virtual Machine from this template.
Enter a virtual machine name, choose a location, and click Next.

On the Host/Cluster page, specify the host on which you want to store the template. Make sure that the
host/cluster is valid. Click Next.

Click Advanced. Specify a valid datastore for the virtual machine that complies with the Cisco HCS for CC
for Contact Center component you deploy.

Click Next.

Make sure that the data store RAID levels for the component that you install comply with conditions specified
in the table of SAN Configuration for your deployment model.

Click Thick provisioned Lazy Zeroed to allocate a fixed amount of storage space to the virtual disk. Click
Next.

Click Customize using an existing customization specification and click Next.
Select the customization file created in the Customization File for the Template.

Review the settings for the new virtual machine. Click Finish.

Generate Answer File for VOS Product Virtual Machines

Step 1
Step 2

Complete the following procedure to generate an answer file for VOS product Virtual machines.

Procedure

Open the link http://www.cisco.com/web/cuc_afg/index.html.

Configure the following cluster-wide parameters:

a) Under Hardware, select Virtual Machine for Primary Node Installed On.

b) Under Product, select the product name and the product version.

¢) Under Administrator credentials, enter the administrator username and password, and confirm the password.
d) Under Security Password, enter a password and confirm password.

e) Under the Application user credentials, enter the application username, password, and confirm the password.

Use the same System Application or Administrator credentials for all nodes.
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Step 3

Step 4

Step 5

Step 6

Copy Answer Files to Virtual Machines .

f) Under Certificate information, enter the organization name, unit, location, state, and country for the Unified
CM and Unified Intelligence Center.
g) Under SMTP, check the box Configure SMTP host and enter the SMTP location.

Configure the following primary node parameters:
a) Under NIC Interface Settings, check the check box Use Auto Negotiation.

Note Do not change the MTU settings.

b) Under Network Information, enter the IP address, hostname ,IP mask, and gateway information.

Do not select the option Use DHCP for | P Address Resolution.

¢) Under DNS, select the option Configure Client DNS, and enter Primary DNS IP and DNS name.
d) Under Timezone, select the option Use Primary Time Zone Settings.

e) Under Network Time Protocol, check Use Network Time Protocol and enter the IP address, NTP server
name, or NTP Server Pool name for at least one external NTP server.

Configure the following secondary node parameters:
a) Under NIC Interface Settings, check the check box Use Auto Negotiation.

Note Do not change the MTU settings.
b) Under Network Information, enter the IP address, hostname, IP mask, and gateway information.
Do not select the option Use DHCP for |P Address Resolution.

¢) Under DNS, select the option Configure Client DNS, and enter primary DNS IP and DNS name.
d) Under Timezone, check Use Primary Time Zone Settings check box.
e) Under List of Secondary Nodes, click Add Secondary Node.

Click Generate Answer files& License M AC to download the answer file for publisher and first subscriber.

Note For Unified CM, where an answer file for a second subscriber is required, close and open the
answer file generator web page and enter the details for the publisher and second subscriber.
Download the answer file for the second subscriber only, because you already downloaded the
publisher file along with the first subscriber.

Perform steps given in section for mounting the answer files to VM.

Related Topics
Copy Answer Files to Virtual Machines, on page 13

Copy Answer Files to Virtual Machines

Golden Template automation tool generates answer files for unattended installations. Individual answer files
get copied to the C:\GoldenTemplateTool _|O\PlatformConfigRepository directory. These answer files are
then converted to a floppy diskette file format and are used in addition to your VOS product DVD during the
installation process.

Before you begin

Download and then install Winlmage 8.5 on the client computer from which the automation scripts will be
run. http://winimage.com/download.htm

Clone and 0S Customization .
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. Copy Answer Files to Virtual Machines

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6

Step 7

Step 8

Step 9

Step 10
Step 11
Step 12

Step 13

Procedure

Copy the generated Answer file to the folder and rename it to platformConfig.xml

Example:

Copy CUCM_PUB_SideA platformConfig.xml to other location and rename it to platformConfig.xml
Launch Winlmage and select File > New > 1.44 MB and click OK

Drag and drop platformConfig.xml into Winlmage

When prompted to inject the file, click Yes.

Select File> Save As

From the Save astypelist, choose Virtual floppy image. Provide the file name as platformConfig.flp and
click Save

Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs
are deployed

Navigate to the Configuration tab. In the storage section, right click on the Datastore and choose Browse
Datastore, create a folder named <Product Node>

Example:

CUCM_PUB.

Upload the platformConfig.flp file to the folder <Product Node>.

Example:

CUCM_PUB.

Navigate to the <Product Node> Virtual Machine(Ex; CUCM_PUB_SdeA). Right-click and choose Edit
Settings

On the Hardware tab, click Floppy drive 1, choose the radio button Use The Existing Floppy Imagein
Datastore.

Mount the platformConfig.flp from the <Product Node> folder (Ex. CUCM_PUB) on the data store and
click OK

Ensure that the Device status shows Connect at Power On checked for the Network adapter and for the
Floppy drive and click OK.

. Clone and 0S Customization
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