
Administration

• Unified CCE Administration, on page 1
• Unified CVP Administration, on page 64
• Unified Communication Manager Administration, on page 64
• Single Sign-on Administration, on page 87

Unified CCE Administration
• Provision Unified CCE Using Unified CCDM, on page 1
• Provision Unified CCE Using Administration Workstation, on page 62
• Provision Unified CCE Using Web Administration, on page 63
• Provision Routing Script Using Internet Script Editor, on page 63

Provision Unified CCE Using Unified CCDM
Complete the following procedures to provision the Unified CCE using Unified Contact Center Domain
Manager (Unified CCDM).

• CRUD Operations for Unified CCDM Objects, on page 2

• Configure User, on page 4

• Configure Departments, on page 7

• Configure Agents, on page 8

• Configure Agent Desktop, on page 10

• Configure Agent Team, on page 11

• Configure Call Type, on page 13

• Configure Precision Routing, on page 14

• Configure Network VRU Scripts, on page 18

• Configure Dialed Number, on page 20

• Configure Enterprise Skill Group, on page 21
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• Configure Expanded Call Variable, on page 23

• Configure ECC Payload , on page 24

• Configure Folder, on page 25

• Configure Group, on page 27

• Configure Label, on page 29

• Configure Person, on page 30

• Configure Supervisors , on page 31

• Configure Service, on page 32

• Configure Skill Group, on page 33

• Configure Route , on page 35

• Agent Re-skilling and Agent Team Manager, on page 35

• Configure User Variable, on page 38

• View the Unified CCDM Version, on page 39

• Bulk Operations Using Unified CCDM, on page 39

• Manage Roles , on page 54

• Configure Gadgets, on page 61

CRUD Operations for Unified CCDM Objects

The following table mentions the Create, Read, Update, and Delete (CRUD) operations for Unified CCDM
objects.

Bulk upload supports only the create operation. See Bulk Operations Using Unified CCDM, on page 39.

You cannot edit any default resources in CCDM portal.

Note

Bulk UploadDeleteUpdateReadCreateObject

xBucket Interval, see
Configure Call Type, on
page 13.

xxxxECC Variables, see
Configure Expanded Call
Variable, on page 23.

xxxxxNetwork VRU Script, see
Configure Network VRU
Scripts, on page 18.
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Bulk UploadDeleteUpdateReadCreateObject

xxxxxCall Type, see Create a Call
Type, on page 13.

xxxxxDialed Number, see
Configure Dialed Number,
on page 20.

xxxxxSkill Group, see Configure
Skill Group, on page 33.

xxxxxFolder, see Configure
Folder, on page 25.

xxxxGroup, see Configure
Group, on page 27.

xxxxxAgent, see Configure
Agents, on page 8.

xxxxxAgent Desktop, see
Configure Agent Desktop,
on page 10.

xxxxxAgent Team, see Configure
Agent Team, on page 11.

xxxxxPerson, see Configure
Person, on page 30.

xxxxxUser, see Configure User,
on page 4.

xxxxxUser Variable, see
Configure User Variable, on
page 38.

xxxxxEnterprise Skill Group, see
Configure Enterprise Skill
Group, on page 21.

xxxxxLabel, see Configure Label,
on page 29.

xxxxxAttribute, see Configure
Precision Attribute, on page
14.

xxxxxPrecision Queue, see
Configure Precision Queue,
on page 16.

xxxxService, see Configure
Service, on page 32
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Configure User
Complete the following procedures to configure a user:

• Create Users in Active Directory

• Create User, on page 4

• Assign Roles to Users, on page 5

• Assign Permission to Sub-customer Tenant and User, on page 6

• Edit User, on page 6

• Delete User, on page 6

Create User

Login as administrator to create tenant/sub customer user.Note

Procedure

Step 1 In Unified CCDM portal, click burger icon in the top-left corner and select Security > Users.
Step 2 Select the tenant in which you have to create user and click New.
Step 3 Enter Login Name.
Step 4 Enter First Name, Last Name and Description.
Step 5 From Culture drop-down list, select English (United States) option.
Step 6 Check the following check boxes:

Advanced Mode

• Account Enabled

• Password Never Expires

• User Cannot Change Password

• Internet Script Editor Enabled (applicable for ISE user)

Step 7 In User Home Folder field, ensure that selected path is correct.

Ensure that Create a new folder for this user check box is unchecked.

Step 8 Enter Password and Confirm the password.
Step 9 Click Save.

Configure an Imported Unified CCE User

After integration of Unified CCE with Unified CCDM, Unified CCDM import existing Unified CCE users.
All imported users are located in default import location, move the imported users to appropriate tenants/folders.
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Follow the below steps to configure imported users.

Procedure

Step 1 In Unified CCDM, locate the imported Unified CCE user. Edit the username of Unified CCDM as follows:

<username>@<domainname>, where username is a windows username and domainname is a fully qualified
windows domain name.

Example:

iseuser1@testdomain.local

Step 2 Select the user to view the details.
Step 3 Select Details tab and check the following check boxes:

• Account Enabled

• Advanced Mode

• Internet Script Editor (applicable for ISE user)

Step 4 Click Save to update the user details for the linked Unified CCDM user.

Before you login ISE, if SSO is disabled, you must log in to Unified CCDM portal as imported
Unified CCE user. Enter corresponding windows active directory user password in Password
field.

Note

Assign Roles to Users

Follow the below procedure to assign corresponding roles to the user:

Procedure

Step 1 In Unified CCDM portal, click burger icon in the top-left corner and select Security > Users.
Step 2 Select newly created user from the list.
Step 3 Select Group tab, click Add to Group.
Step 4 Select the tenant/folder that has a user you want to assign roles.
Step 5 Check Basic Users check box to provide basic permission for the tenant.
Step 6 Check Advanced Users check-box for a tenant/ISE user and click OK.

Default, advanced users will have Browse Dimension permission.

Step 7 Check Supervisors check-box for a supervisor user and click OK.
Step 8 Click Save.
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Assign Permission to Sub-customer Tenant and User

Procedure

Step 1 Log in to CCDMWeb portal.
Step 2 Click burger icon.
Step 3 Select Security > Permissions.
Step 4 Select the sub-customer tenant and click Permission tab, uncheck Inherit Permissions from /Root and click

OK.

Repeat this step for Unallocated > SCCTenant Folder.

Step 5 Select newly added user and click Group tab.
Step 6 Click Add to Groups.
Step 7 Click Unallocated > SCCTenant Folder and enable Basic Users permissions.
Step 8 Click the sub-customer tenant and assign Advanced Users permissions and click OK.

Default, Advanced User will have Browse Dimension permission.

Step 9 Click Save.

Edit User

Follow the below procedure to edit user:

Procedure

Step 1 In Unified CCDM portal, click burger icon in the top-left corner and select Security > Users.
Step 2 From the folder tree, select the folder containing the user that you want to edit.
Step 3 Select the user you want to edit.
Step 4 Click Details tab.
Step 5 Edit the required details.
Step 6 Click Groups tab, to add or remove the groups.
Step 7 Click Save.

Delete User

Follow the below procedures to delete users:

Procedure

Step 1 In Unified CCDM portal, click burger icon in the top-left corner and select Security > Users.
Step 2 From folder tree on left, select the folder containing the user that you want to delete.

Administration
6

Administration
Assign Permission to Sub-customer Tenant and User



Step 3 Select the user that you want to delete.
Step 4 Click Delete and click Yes.

Configure Departments
To configure a department perform the following instructions.

• Create a Department, on page 7
• Edit a Department, on page 7
• Move a Department, on page 7
• Delete a Department, on page 8

Create a Department

Procedure

Step 1 Log in to CCDM portal as Tenant Administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Select the required Folder from the Tenant. Click Resource and select Department.
Step 4 Enter the name of the department and complete the mandatory fields.
Step 5 Click Save.

Edit a Department

Procedure

Step 1 Log in to CCDM portal as Tenant Administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Expand the required Folder from the Tenant. Click Department.
Step 4 Select the department that you want to edit and modify the required fields.
Step 5 Click Save.

Move a Department

Procedure

Step 1 Log in to CCDM portal as Tenant Administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Expand the required Folder from the Tenant. Click Department.
Step 4 In Department tab, check the department you want to move and click Move.
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Step 5 Browse to the destination folder you want the department to be moved and click Save and click Ok.

Delete a Department

Procedure

Step 1 Log in to CCDM portal as Tenant Administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Expand the required Folder from the Tenant. Click Department.
Step 4 In the Department tab, Select the department that you want to delete.
Step 5 Click Delete and click Ok.

Configure Agents
Complete the following procedures for agent configuration:

• Create an Agent, on page 8

• Edit an Agent, on page 9

• Delete an Agent, on page 10

Create an Agent

Complete the following procedure to create an agent:

Procedure

Step 1 Log in to CCDM portal as tenant or sub customer user or Supervisor user.
Step 2 Click the burger icon and select Provisioning.
Step 3 Create an agent.

• For Tenant or Sub customer user, select Resource Manger, select the folder that you want to create the
agent. Select Resource > Agent.

• For Supervisor user, select Agent Team Manager and click New Agent.

Step 4 Click the Details tab and configure as follows:
a) Enter the Agent's Name.
b) Enter a Description of the agent.
c) Select a Peripheral to create the agent.
d) Associate the person with the agent.

You can choose an existing person, or you can create a new person and associate with the agent.
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• Select Existing Person: Select an existing person from the drop-down list, . You can search for a
specific person by typing a part of their name in the search box. The new agent uses the details
specified in that person's Peripheral Login box to log in to their Agent Desk Setting.

• Create New Person: Enter the first name and last (or family) name for the person, and fill in the
details they will use to log in to the peripheral. The person is automatically created and associated
with the agent.

e) If Unified CCE is in hybrid mode , check the SSO checkbox to make the agent a SSO agent.

Step 5 To make agent a supervisor, click Supervisor tab and check the Supervisor checkbox. If supervisor is a
non-SSO agent, do the following:
a) Associate the agent with a Domain Account (the account the agent uses to log into a computer on the

contact center network).

You cannot set up a domain account from Unified CCDM because security rules typically
prevent this. Contact your administrator if you are uncertain of the domain account to use.

Note

b) Enter part of the account name, click Find and then select the correct account.

Step 6 Click the Agent Teams tab and configure the following:
a) Select an agent team to which the agent belongs to. Agents may only be a member of a single team, but

a supervisor can supervise multiple teams. Use the Selected Path drop-down list to see agent teams in
other folders.

b) Click Add to associate the team with this agent.
c) Check the Member check box to make the agent a member of the team.

Supervisors can supervise a team without being a member.

d) If the agent is a supervisor, select a primary or secondary supervisory role for any team they supervise..

They may or may not also be a member of this team.

Step 7 Click the Skill Groups tab and configure the following:
a) Select skill groups for the agent to belong to. Use the Selected Path drop-down to change folders.
b) Click Add to add the agent to the selected skill groups.

Step 8 Click Save.

Edit an Agent

Complete the following procedure to view or edit agents.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, in the folder tree panel, select the folder where you want to edit the agent.
Step 4 In Items panel, select the agent from the list.
Step 5 Edit the agent details.
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Clicking a different tab (such as Supervisor or Agent Teams) shows a different set of fields. You can return
to previous tabs if necessary.

Step 6 Click Save.

Delete an Agent

Complete the following procedure to delete an agent.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, navigate to the folder containing the Agent you want to delete, and view the agents

in that folder using the Items panel list view.
Step 4 In the Items panel, check the required agent check boxes that you want to delete.
Step 5 Click Delete.
Step 6 Click Yes to delete the agent.

Configure Agent Desktop
Complete the following procedures to configure an agent desktop:

• Create an Agent Desktop, on page 10

• Edit an Agent Desktop, on page 10

• Delete an Agent Desktop, on page 11

Create an Agent Desktop

Complete the following procedure to create an agent desktop.

Procedure

Step 1 Login to Unified CCDM Portal as Tenant or Sub customer user and select Resource Manager.
Step 2 In Resource Manager, in the Folder Tree panel, select the folder where you want to create the agent desktop.
Step 3 Click Resource, and click Agent Desktop.
Step 4 Complete the required fields.
Step 5 Click Save.

Edit an Agent Desktop

Complete the following procedure to edit an agent desktop.
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that contains the agent desktop you want to edit, and view the agent desktops in that folder

using the Items panel list view.
Step 4 In the Items panel, click the agent desktop you want to edit.

The details of this agent desktop appears in the Details panel.

Step 5 In the Details tab, click the appropriate tab and make the required changes.
Step 6 Click Save.

Delete an Agent Desktop

Complete the following procedure to delete the agent desktop.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that contain the agent desktop you want to delete, and view the agent desktops in that folder

using the Items panel list view.
Step 4 In the Items panel, check the check box or check boxes of the agent desktops you want to delete.
Step 5 Click Delete and Click Yes.

Deletion of agent desktop will remove the associated agent desktops automatically.Note

Configure Agent Team
Complete the following procedures to configure an agent team:

• Create an Agent Team, on page 11

• Edit an Agent Team, on page 12

• Delete an Agent Team, on page 12

Create an Agent Team

Complete the following procedure to create an agent team:

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
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Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In the folder tree panel, select the folder where you want to create the agent team.
Step 4 Click Resource, and then click Agent Team.
Step 5 Enter a unique name for the team.
Step 6 Enter all the required fields to create the agent team.
Step 7 To assign agents to the team, check the check boxes of one or more agents in the Agents tab, and click Add.
Step 8 When you add an agent to the team, you must also check their Member check box to make them a member

of the team.

This is because it is possible to be involved with a team without being a member, by supervising it.

If an agent is a supervisor, a drop-down list appears in the right-hand column.

Step 9 Specify whether the agent has a supervisory role for this particular team.
Step 10 Click Save.

Edit an Agent Team

Complete the following procedure to edit an agent team.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that contain the agent team you want to edit, and view the agent teams in that folder using

the Items panel list view.
Step 4 In the Items panel, click the agent team you want to edit.

The details of this agent team appear in the Details panel.

Step 5 Click through the tabs and edit the fields you want to change.
Step 6 To remove agents from a team, click the Agents tab and check the check boxes of the agents you wish to

remove from the team and click Remove.
Step 7 Click Save.

Delete an Agent Team

Complete the following procedure to delete an agent team

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that contains the agent teams you want to delete, and view the agent teams in that folder

using the Items panel list view.
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Step 4 In Items panel, check the check box or check boxes of the agent teams you want to delete.
Step 5 Click Delete.

Delete Agent Teams confirmation dialog box appears.

Step 6 Click Yes to delete the agent teams.

Configure Call Type
• Create a Call Type, on page 13

• Edit a Call Type, on page 13

• Delete a Call Type, on page 14

Create a Call Type

Complete the following procedure to create a call type.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In folder tree panel, select a folder where you want to create the call type.
Step 4 Click Resource, and then click Call Type.
Step 5 Enter the following details:

a) In Name field, enter the unique name.
b) Select Bucket Interval from the drop-down list.

The bucket interval is the count of answered or abandoned calls that are used as intervals for
the Call Type. The default value is system default.

Note

c) Select Service Level Threshold from the drop-down list.
d) Select Service Level Type from the drop-down list.

Step 6 Click Save.

Edit a Call Type

Complete the following procedure to edit a call type.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
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Step 3 Select the folder that contain call types that you want to delete, and view the call types in that folder using
the Items panel list view.

Step 4 In Items panel, select the call types you want to edit.
Step 5 Click through the tabs and edit the fields you want to change.
Step 6 Click Save.

Delete a Call Type

Complete the following procedure to delete a call type.

You cannot delete the default call type.Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the call types you want to delete and under Summary in Items panel list view

click Call Type .
Step 4 In Items panel, select the call types you want to delete.
Step 5 Click Delete and click Yes.

Configure Precision Routing
Complete the following procedures to configure precision routing.

• Configure Precision Attribute, on page 14

• Assign Precision Attribute to an Agent, on page 16

• Configure Precision Queue, on page 16

• Create Routing Scripts, on page 18

Configure Precision Attribute

Complete the following procedures to configure precision attribute.

• Create Precision Attribute, on page 14

• Edit Precision Attribute, on page 15

• Delete Precision Attribute, on page 15

Create Precision Attribute

Complete the following procedure to create a precision attribute.
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the required tenant to create precision attribute.
Step 4 Click Resource, and click Precision Attribute.
Step 5 Provide a Name for the precision attribute. For example, ENGLISH.
Step 6 Enter the Description for the precision attribute.
Step 7 Select the Data Type for the precision attribute. For example, Proficiency.
Step 8 Select the Default Value from the drop-down list.
Step 9 Click Save.

Edit Precision Attribute

Complete the following procedure to edit a precision attribute.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, select the folder containing the precision attribute you want to edit, and view the

precision attributes in that folder using the Items panel list view.
Step 4 In the Items panel, click the precision attribute you want to edit.

The details of this precision attribute appears in the Details panel.

Step 5 In the Details panel, click the appropriate tab and make the desired changes.
Step 6 Click Save.

The precision attribute of a data type cannot be modified once it is assigned. However, the default
value of the data type can be modified.

Note

Delete Precision Attribute

Complete the following procedure to delete a precision attribute.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, select the folder containing the precision attribute you want to delete, and view the

precision attributes in that folder using the Items panel list view.
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Step 4 In Items panel, check the check boxes of the precision attributes that you want to delete.
Step 5 Click Delete.

You cannot delete the precision attribute if it is referenced by a precision queue, remove the
reference to delete the precision attribute.

Note

Step 6 Click Yes.

Assign Precision Attribute to an Agent

Complete the following procedure to assign the precision attribute to an agent.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, navigate to the folder containing the agent to which you want to assign the precision

attribute and view the agent in that folder using the Items panel list view.
Step 4 In the Items panel, click the agent to which you want to assign the precision attribute.

The details of this agent appear in the Details panel.

Step 5 In the Details panel, click Precision Attribute. Check the check box against the precision attribute tab and
click Add.

Step 6 Click Save.

The supervisor agent must be associated with a domain account before they can have precision
attributes assigned to them.

Note

Configure Precision Queue

Complete the following procedures to configure precision queue.

• Create Precision Queue , on page 16

• Edit Precision Queue, on page 17

• Delete Precision Queue, on page 17

Create Precision Queue

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the required tenant to create the precision queue.

Administration
16

Administration
Assign Precision Attribute to an Agent



Step 4 Click Resource, and click Precision Queue.

A new page appears.

Step 5 Complete the required fields
Step 6 Select the Steps tab and click Step1. A new page appears.
Step 7 In the Expression1 field, provide the attribute name and select the operation from the drop-down list and also

select Proficiency level from the drop-down list. For example, Attribute = ENGLISH, Operation is >, and
Proficiency level is 6.

Based on the requirement, we can add the attribute, expression and steps.Note

Step 8 Click OK.
Step 9 Click Save.

Edit Precision Queue

Complete the following procedure to edit a Precision Queue.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In Resource Manager, select the folder containing the Precision Queue you want to edit, and view the

Precision Queue in that folder using the Items panel list view.
Step 4 In the Items panel, click the Precision Queue that you want to edit.

The details of this Precision Queue appears in the Details panel.

Step 5 In the Details panel, click the appropriate tab and make the desired changes.
Step 6 Click Save.

Delete Precision Queue

Complete the following procedure to delete the Precision Queue.

You cannot delete a precision queue that is referenced in a routing script, remove the reference to delete the
precision queue.

Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.

Administration
17

Administration
Edit Precision Queue



Step 3 In Resource Manager, navigate to the folder containing the Precision Queue you want to delete and view
the Precision Queue in that folder using the Items panel list view.

Step 4 In the Items panel, check the check boxes of the Precision Queue that you want to delete.
Step 5 Click Delete.
Step 6 Click Yes.

Create Routing Scripts

See the following illustration to create routing scripts:

Figure 1: Create Routing scripts

Configure Network VRU Scripts
• Create Network VRU Script, on page 18
• Edit Network VRU Scripts, on page 19
• Delete Network VRU Scripts, on page 19

Create Network VRU Script

Complete the following procedure to set up the network VRU script.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
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Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to create the network VRU Script.
Step 4 Select Resource, and click Network Vru Script.
Step 5 Complete fields as follows:

a) Name* (Required)- Enter a unique name that will identify the script.

Example:

Play_Welcome
b) Network VRU* (Required) - Select the Network VRU from the drop-down list.
c) VRU Script Name* (Required)- Enter the name of the script as it is known on the Unified CVP.
d) Configuration Parameter (Optional)- A string used by Unified CVP to pass additional parameters to the

IVR Service. The content of string depends on the micro-application to be accessed.
e) Timeout* (Required)- Enter a number to indicate the number of seconds for the system to wait for a

response from the routing client after directing it to run the script.
f) Interruptible (Optional)- This check box indicates whether or not the script can be interrupted; for example,

when an agent becomes available to handle the call.

• System generates a default Enterprise Name in Advance tab.

• You cannot upload an audio file, when you first create the network VRU script.

Note

Step 6 Click Save.

Edit Network VRU Scripts

Complete the following procedure to edit Network VRU details and associate an audio file with a VRU script:

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the Network VRU script you want to edit.
Step 4 In the Items panel, click the Network VRU script you want to edit.
Step 5 Click the Audio tab.
Step 6 Click Browse and select the audio file from your hard drive.
Step 7 Click Upload.
Step 8 After the file has uploaded, click Save.

Delete Network VRU Scripts

You cannot delete the dialed number that is referenced in a script. This reference should be removed to delete
the dialed number.

Note
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the Network VRU script you want to delete.
Step 4 In the Items panel, click the Network VRU script you want to delete.
Step 5 Select the Delete option.
Step 6 Click Yes, to delete the Network VRU script.

Configure Dialed Number
Complete the following procedures for dialed number configuration:

• Create a Dialed Number, on page 20

• Edit a Dialed Number, on page 20

• Delete a Dialed Number, on page 21

Create a Dialed Number

Complete the following procedure to create one or more dialed numbers.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to create the dialed number.
Step 4 Click Resource, and then click Dialed Number.
Step 5 Enter unique name of up to 32 characters for the dialed number.

This should consist alphanumeric characters, periods, and underscores only.

For wild card dialed number follow the pattern below:

Example:

7xx

Step 6 Complete fields as for the dialed number Fields.
Step 7 Click Add to specify the call types and other dialing information to be associated with this dialed number.
Step 8 Click Save.

Edit a Dialed Number

Complete the following procedure to edit the dialed numbers.
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to edit, and view the dialed number in that folder using the Items panel list

view.
Step 4 In the Items panel, select the dialed numbers that you want to edit.
Step 5 After modification, click Save.

Delete a Dialed Number

Complete the following procedure to delete one or more dialed numbers.

You cannot delete the dialed number that is referenced in a script, remove the reference to delete the dialed
number.

Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the dialed numbers that you want to delete, and view the dialed numbers in that

folder using the Items panel list view.
Step 4 In Items panel, select the dialed numbers to be deleted.
Step 5 Click Delete.
Step 6 Click Yes.

Configure Enterprise Skill Group
Complete the following procedures for enterprise skill group configuration:

• Create an Enterprise Skill Group, on page 21

• Edit an Enterprise Skill Group Configuration, on page 22

• Delete an Enterprise Skill Group, on page 22

Create an Enterprise Skill Group

Complete the following procedure to create an enterprise skill group.
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to create the enterprise skill group.
Step 4 Click Resource, and then click Enterprise Skill Group.
Step 5 Enter a unique name for the group.
Step 6 Enter all the required fields to create an enterprise skill group.
Step 7 To assign skill groups to the group, click Add and select one or more skill groups.
Step 8 Click Save.

Edit an Enterprise Skill Group Configuration

Complete the following procedure to edit an enterprise skill group.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In the folder tree panel, select the folder where you want to edit, and view the enterprise skill groups in that

folder using the Items panel list view.
Step 4 In the Items panel, select the enterprise skill groups that you want to edit.
Step 5 After modification, click Save.

Delete an Enterprise Skill Group

Complete the following procedure to delete an enterprise skill group.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the enterprise skill groups you want to delete, and view the enterprise skill groups

in that folder using the Items panel list view.
Step 4 In the Items panel, check the check box or check boxes of the enterprise skill groups you want to delete.
Step 5 Click Delete.
Step 6 Click Yes.
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Configure Expanded Call Variable
Complete the following procedures to configure an expanded call variable.

• Create an Expanded Call Variable, on page 23

• Edit an Expanded Call Variable, on page 23

• Delete an Expanded Call Variable, on page 24

Create an Expanded Call Variable

Complete the following procedure to create an expanded call variable.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to create the expanded call variable.
Step 4 Click Resource, and then click Expanded Call Variable.
Step 5 Enter the required information in the following fields:

a) In Name field, enter the unique name.
b) In Description field, enter the description.
c) In Maximum Length field, enter the maximum length of call variable.
d) Optional, check Persistent check-box.
e) Optional, check Enabled check-box.
f) Optional, check ECC Array check-box.

Step 6 In Advanced tab, set the end date for the call variable.

Uncheck Forever check-box to set the end date.Note

Step 7 Click Save.

Edit an Expanded Call Variable

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to modify the expanded call variable.
Step 4 Click Expanded Call Variable in the items panel.
Step 5 Select the Expanded Call Variable to modify.
Step 6 Modify the fields in Details tab as required.
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Step 7 Click Save.

Delete an Expanded Call Variable

Complete the following procedure to delete expanded call variable.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the expanded call variables you want to delete, and view the expanded call

variables.
Step 4 In Items panel, select the expanded call variables that you want to delete.
Step 5 Click Delete.
Step 6 Click Yes.

Configure ECC Payload
Complete the following procedures to configure an expanded call variable.

• Create an ECC Payload, on page 24

• Edit an ECC Payload, on page 25

• Delete an ECC Payload, on page 25

Create an ECC Payload

Complete the following procedure to create an ECC Payload.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the Cisco icon and select Gadget > Open App. Create an App if it is not already created. For more

information, see Configure Gadgets, on page 61.
Step 3 Select an ECC payload resource from the search bar list.
Step 4 Click the New icon.
Step 5 On the Details tab, enter the required information:

a) In the Name field, provide a name for the ECC Payload.
b) In the Description field, provide a suitable description for the ECC Payload.

Step 6 To add the Expanded Call Variable to the ECC Payload, on the Expanded Call Variable tab, click Show
Available. Select the available call variable and add it to the ECC payload.

Step 7 On theAdvanced tab, enter the Enterprise name and set the end date for the ECC payload.
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Step 8 Click Save.

Edit an ECC Payload

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the Cisco icon and select Gadget > Open App.
Step 3 Select an ECC payload resource from the search bar list.
Step 4 Select the ECC payload to be modified.
Step 5 Modify the fields in the Details tab as required.
Step 6 Add or remove the ECC variable as required.
Step 7 Click Save.

Delete an ECC Payload

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the Cisco icon and select Gadget > Open App.
Step 3 Select the ECC payload resource from the search bar list.
Step 4 Select the ECC payload to be deleted and click Delete.
Step 5 Click OK to confirm the changes.

Configure Folder
Complete the following procedures for folder configuration:

• Create Folders, on page 25

• Rename a Folder, on page 26

• Move Folder, on page 26

• Delete Folder, on page 26

Create Folders

Complete the following procedures to create folders:
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder/tenant where you want to create the new folder.
Step 4 Click System, and then click Folder.
Step 5 In the Name field enter a name for the new folder.
Step 6 In the Description field enter any explanatory text for the folder, this is optional.
Step 7 If required, uncheck the Inherit Permissions check box to make this folder a policy root that does not inherit

security permissions from its parent folder.
Step 8 Check theCreate Another check box if you want to create more folders at the same point in the tree structure.
Step 9 Click Save to save the new folder in the tree.

Rename a Folder

Procedure

In Resource Manager, right-click the folder in the Folder Tree panel and select Rename Folder and enter
the required name.

Move Folder

Complete the following procedure to move a folder:

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In the Items panel, click Folders.
Step 4 Check the folder(s) check box that you want to move.
Step 5 Click Move.
Step 6 In the folder tree, select the location that you want to move the folders.
Step 7 Click Save.

You can also use drag and drop option to move folders.

Delete Folder

Complete the following procedures to delete a folder:
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In the Items panel, click Folders.
Step 4 Check the folder(s) check boxes that you want to delete.
Step 5 Click Delete.
Step 6 In the Delete folder dialog, select Yes.

Configure Group
Complete the following procedure for group configuration:

• Create a Group, on page 27

• Edit a Group, on page 27

• Move a Group, on page 28

• Delete a Group, on page 28

Create a Group

Complete the following procedure to create a group.

Procedure

Step 1 Log in to Unified CCDM Portal as Administrator/Tenant /Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager .
Step 3 Select the folder or the tenant where you want to create the new group.
Step 4 Click System , and then click Group

Step 5 Enter the following details:
a) In the Name field enter the name for the new group.

Groups in different folders may have the same name.

b) In the Description field enter a description for the group, such as a summary of its permissions or the
categories of users it is intended for.

c) If you want to create more than one group, check theCreate Another check box (to remain on the Create
a new group page after you have created this group).

d) Click Save.

Edit a Group

Complete the following procedure to edit or view group details.
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Procedure

Step 1 Log in to Unified CCDM Portal as Administrator/Tenant /Sub Customer user.
Step 2 Click the burger icon and select Provisioing > Resource Manager .
Step 3 Select the folder that contain groups that you want to modify, and view the group in that folder using the Items

panel list view.
Step 4 In the Items panel , select the group that you want to edit.
Step 5 Edit the group details as required.
Step 6 Click the Members tab to add or remove the members of the group.
Step 7 Click the Groups tab to add or remove the group from other groups.
Step 8 Click Save.

Move a Group

Complete the following procedure to move a group.

Procedure

Step 1 Log in to Unified CCDM Portal as Administrator/Tenant /Sub Customer user.
Step 2 Click the burger icon and select Provisioing > Resource Manager.
Step 3 Select the folder that contain groups that you want to move, and view the group in that folder using the Items

panel list view.
Step 4 In the Items panel , select the group to be moved.
Step 5 Click Move.

Step 6 Navigate to the tenant or the folder you want to move the group to.
Step 7 Click Save.

Delete a Group

Complete the following procedure to delete a group.

Procedure

Step 1 Log in to Unified CCDM Portal as Administrator/Tenant /Sub Customer user.
Step 2 Click the burger icon and select Provisioing > Resource Manager .
Step 3 Select the folder that contain groups that you want to delete, and view the group in that folder using the Items

panel list view.
Step 4 In the Items panel , select the group that you want to deleted.
Step 5 Click Delete and confirm the deletion when prompted.
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Configure Label
Complete the following procedures for label configuration:

• Create a Label, on page 29

• Edit a Label, on page 29

• Delete a Label, on page 29

Create a Label

Complete the following procedure to create a label.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder where you want to create the label.
Step 4 Click Resource, and click Label.
Step 5 Complete all fields for the label.
Step 6 Click Save.

Edit a Label

Complete the following procedure to edit a label.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the labels that you want to edit, and view the labels in that folder using the Items

panel list view.
Step 4 In the Items panel, select the labels that you want to edit.
Step 5 After modification, Click Save.

Delete a Label

Complete the following procedure to delete a label.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
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Step 3 Select the folder containing the labels you want to delete, and view the labels in that folder using the Items
panel list view.

Step 4 In the Items panel, check the check box or check boxes of the labels you want to delete.
Step 5 Click Delete.
Step 6 In the Delete Labels dialog box, click Yes.

Configure Person
Complete the following procedures to configure a person:

• Create a Person, on page 30

• Edit a Person, on page 30

• Delete a Person, on page 31

Create a Person

Complete the following procedure to create a person.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user or Supervisor user.
Step 2 Click the burger icon and select Provisioning.
Step 3 Create a person.

• For Tenant or Sub customer user, select Resource Manger, select the folder that you want to create the
agent. Select Resource > Person.

• For Supervisor user, select Agent Team Manager and click New Person.

Step 4 Complete the required fields for person.
Step 5 Select Equipment tab, select the Unified Contact Center Enterprise.
Step 6 Set Active from and to dates in the Advanced tab.
Step 7 Click Save.

After you create a person, you cannot edit the Unified CCDM account details for a person through
another person. You must edit the Unified CCDM account details directly.

You cannot link a person with an existing Unified CCDM user account.

Note

Edit a Person

Complete the following procedure to edit a person.
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Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub-Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the persons that you want to edit, and view the person in that folder using the

Items panel list view.
Step 4 In the Items panel, select the persons that you want to edit.
Step 5 Optional, reset the password as follows:

a) Select Details tab.
b) Check Reset Password check box.
c) Enter new password and confirm.

Step 6 After modification, Click Save.

Delete a Person

Complete the following procedure to delete a person.

Deletes all the agents associated with the person.Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select folder containing the person or persons you want to delete the persons in that folder using the Items

panel list view.
Step 4 In the Items panel check the check box or check boxes of the person or persons you want to delete.
Step 5 Click Delete.
Step 6 Click Yes to delete the person.

Configure Supervisors
Complete the following procedure to configure a supervisor.

Before you begin

This is applicable for Sub-customer users of Small Contact Center Deployment that requires Supervisor to
associate with Domain account.

1. Select Security > Sub-customer Tenant.

2. Select User Tab > User and click Change Permission.
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3. Check Full Permission check-box for the Sub customer tenant and click OK.

4. Add this sub-customer tenant to Advanced Group.

Procedure

Step 1 Log in to the CCDM portal as Tenant/Sub Customer User and select Resource Manager.
Step 2 In Resource Manager, select the folder that contains the agent that you want as a supervisor or create a new

agent to configure supervisor, see Create an Agent, on page 8.
Step 3 Click Supervisor tab and and check the Supervisor checkbox. This does not require that they supervise a

team. If supervisor is a non-SSO agent, the Supervisor tab only displays the Supervisor checkbox. All other
fields and checkboxes are not available when a default domain has been configured for Unified CCE 11.5 or
later versions.

You cannot set up a domain account fromUnified CCDMbecause security rules typically prevent
this. Contact your administrator if you are uncertain of which domain account to use.

Note

Step 4 Click Save.

Configure Service

Complete the following procedures to configure service:

• Create Service, on page 32

• Edit Service, on page 33

• Delete Service, on page 33

Note

Create Service

Complete the following procedure to create service:

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that you want to create service from the left-hand side panel.
Step 4 In Resource drop-down list, select Service option.
Step 5 Complete the required fields.
Step 6 Goto Advanced tab, choose Cisco_Voice from Media Routing Domain drop-down list.
Step 7 Goto Skillgroups tab, check the skill group that you want to add and click Add.
Step 8 Click Save.
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Edit Service

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Navigate to the folder that you want to edit or view service from the left-hand side panel.

Displays the list of all the services in items panel.
Step 4 Click on the service that you want to edit.
Step 5 After editing click Save.

Delete Service

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder that you want to delete service from the left-hand side panel.
Step 4 Check the service from the list that you want to delete.
Step 5 Click Delete and click Yes.

Configure Skill Group
Complete the following procedures to configure skill group:

• Create a Skill Group, on page 33

• Edit a Skill Group, on page 34

• Delete a Skill Group, on page 34

Create a Skill Group

Complete the following procedure to create a skill group.

When you create a skill group, a default route is created.Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
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Step 3 In the folder tree panel, select the folder where you want to create the skill group.
Step 4 Click Resource, and click Skill Group.
Step 5 Enter a unique name for the group.
Step 6 Select Agents tab, check the agent(s) check box and click Add.
Step 7 Click Save.

Edit a Skill Group

Complete the following procedure to edit a skill group.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the skill group that you want to edit, and view the skill groups in that folder using

the Items panel list view.
Step 4 In the Items panel, click the skill group you want to edit.

The details of this skill group display in the Details panel.

Step 5 Click the tabs and edit the fields you want to change.
Step 6 Optional, to remove agents from a skill group, select Agents tab and select the agents you want to remove

from the team.
Step 7 Click Remove.
Step 8 Optional, to remove the route association from a skill group, selectRoute tab and clickDelete for which route

you want to delete.
Step 9 Optional, to edit the details of an existing route associated with the skill group, select Route tab and click

Edit for which route you want to delete. Click Update.
Step 10 Click Save.

Delete a Skill Group

Complete the following procedure to delete a skill group.

You cannot delete the skill group that is referenced in a script, remove the reference to delete the skill group.Note

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the skill groups you want to delete, and view the skill groups in that folder using

the Items panel list view.
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Step 4 In the Items panel, select the skill groups you want to delete.

Ensure that skillgroup is not mapped to any services.Note

Step 5 Click Delete.

Delete Skill Groups page appears.

Step 6 Click Yes.

The skill groups are deleted.

Configure Route
Complete the following procedure to configure a route.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In the folder tree panel, select the folder where you want to create the route.
Step 4 In the Folder Tree panel, click Skill Group.
Step 5 Choose the skill group for which you are creating a route.
Step 6 Select Routes tab.
Step 7 In Route Name field, enter a unique name that will identify the script.
Step 8 Click Add.
Step 9 Click Save.

Agent Re-skilling and Agent Team Manager
You can login as user with supervisor role to perform agent re-skilling and agent team manager.

Before performing these tasks ensure that the user is created. To create user, see Create User, on page 4 and
to assign supervisor role, see Assign Roles to Users, on page 5.

Configure Supervisor for Agent Re-skill and Agent Team Manager in CCDM

Procedure

Step 1 Log in to the Unified CCDM Portal as administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager .
Step 3 Click on resource and select Agent resource.
Step 4 Select an agent for the supervisor.
Step 5 In Supervisor tab, check the checkbox for supervisor and click Save.
Step 6 In Person tab, select the goto person icon.
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Step 7 In Portal tab, click the portal account and click the existing user.
Step 8 Select the tenant and select supervisor user from the list of users.
Step 9 Click next icon.

Displays User's Group dialog box.
Step 10 Make sure supervisor group is added to the user and click Save.
Step 11 Click Save.

Associating Supervisor Agent to Agent Team

Procedure

Step 1 Log in to Unified CCDM Portal as administrator.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Click resource and select Agent resource.
Step 4 Select the Supervisor agent.
Step 5 In the Agent Team tab, select agent teams that you want to add and click Add.
Step 6 In Supervisory Role column, Select Primary from the drop-down list and click Save.

View Skill Group

Complete the following procedure to view a skill group.

Procedure

Step 1 Log in to Unified CCDM portal as supervisor.
Step 2 Click the burger icon and select Provisioning > Agent Re-Skilling.
Step 3 From the Skill Group drop-down list, select the skill group you want to view.

Displays a list of agents for the selected skill group.
Step 4 Click the Goto Agent icon to modify the agent details

Add an Agent to Skill Group

Complete the following procedure to add an agent to a skill group.

Procedure

Step 1 Log in to Unified CCDM portal as supervisor.
Step 2 Click the burger icon and select Provisioning > Agent Re-Skilling .
Step 3 Select Skill Group from the drop-down list.

Displays a list of agents for the selected skill group.
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Step 4 In My Agents on Peripheral list, select the agents you want to add to the skill group, then click Add.

You can search agents using a search bar with a part of agent's name.Note

Step 5 Click Save.

Remove an Agent from Skill Group

Complete the following procedure to remove an agent from a skill group.

Procedure

Step 1 Log in to Unified CCDM portal as supervisor.
Step 2 Click the burger icon and select Provisioning > Agent Re-Skilling .
Step 3 Select a skill group to remove an agent or agents.
Step 4 In the top list, select the agents to remove from the skill group using the check boxes.
Step 5 You enter part of an agent's name into the search box, and then click Search to filter the list of agents by the

specified search string.
Step 6 Click Remove to remove the agents from this skill group.
Step 7 Click Save to save your changes, or Cancel to leave the details as they were before you started.

View Agent Team

Login as a supervisor user and complete the following procedure to view Agent team

Procedure

Step 1 Log in to Unified CCDM portal as supervisor.
Step 2 Click the burger icon and select Provisioning > Agent Team manager .
Step 3 Select the Agent team drop-down list and select the agent team you want to view.

Displays the list of agents for the selected agent team.

Modify Agent Team

Complete the following procedure to modify an agent's team:

Procedure

Step 1 Log in to Unified CCDM portal as supervisor.
Step 2 Click the burger icon and select Provisioning > Agent Team Manager.
Step 3 From the My Agent Team drop-down list, select the agent team to which agent belongs.
Step 4 Click the Goto Agent icon to modify the agent details.
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Step 5 Select Agent Team tab.
Displays the current membership of agent with the agent team.

Step 6 Optional, check the agent team check box that you want to remove and click Remove.
Step 7 Optional, select the agent team from the list that you want to add and click Add.

You can add an agent as a member of that team, check the Member check box. Otherwise, you
can also add an agent as primary or secondary supervisor, if they are supervisor agent.

Note

Step 8 Click Save.

Configure User Variable
Complete the following procedure for user variable configuration:

• Create a User Variable, on page 38

• Edit a User Variable, on page 38

• Delete a User Variable, on page 39

Create a User Variable

Complete the following procedure to create a user variable.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 In folder tree panel, select the folder where you want to create the user variable.
Step 4 Click Resource and click User Variable

Step 5 Complete the required fields for user variable.
Step 6 Set Active from and to dates in Advanced tab.
Step 7 Click Save.

Edit a User Variable

Complete the following procedure to edit a user variable.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the user variables that you want to edit, and view the user variables in that folder

using the Items panel list view.
Step 4 In the Items panel, select the user variables that you want to edit.
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Step 5 After modification, Click Save.

Delete a User Variable

Complete the following procedure to delete a user variable.

Procedure

Step 1 Log in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager.
Step 3 Select the folder containing the user variables you want to delete, and view the user variables in that folder

using the Items panel list view.
Step 4 In Items panel, check the check box or check boxes of the user variables you want to delete.
Step 5 Click Delete.
Step 6 In the Delete User Variables dialog box, click Yes.

The user variables are deleted.

View the Unified CCDM Version
Complete the following procedure to view the Unified CCDM version.

Procedure

Step 1 In the Settings page, click Settings.
Step 2 Click About.

View the Unified CCDM version installed on your system.

Bulk Operations Using Unified CCDM
The bulk upload tool is used for importing large numbers of resource items into Unified CCDM. It is used to
generate resources such as Agents or Skill Groups by filling in resource attributes using the standard CSV
format. All CSV files require headers that dictate where each value goes. These headers are provided by
templates that can be downloaded from the appropriate Bulk Upload page in Unified CCDM. You can bulk
upload the following resources:

• Agents
• Agent desktop
• Agent team
• Call Type
• Department
• Dialed Number
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• Enterprise Skill Group
• Skill Group
• User Variable
• Folder
• Network VRU Script
• Label
• Person
• User
• Precision Attribute
• Precision Queue

Bulk Upload for Unified CCDM

Complete the following procedure to bulk upload Unified CCDM:

Procedure

Step 1 Log in to Unified CCDM portal as Tenant or Sub-Customer.
Step 2 Click the burger icon and select Provisioing > Resource Manager.
Step 3 Click the required folder.
Step 4 ClickUpload in the Folder Tree panel and then select the item type youwant to bulk upload from the drop-down

list.

The Bulk Upload Control page appears.

Step 5 Select a template for your chosen resource. The template link is present in the horizontal toolbar near the top
of the page. Once selected, a download box is presented allowing you to save this CSV file onto your machine.
.

Step 6 Open the template in the editor you require (such as Notepad) and begin to enter your data or paste it from
another source.
For detailed information on Bulk Upload templates, please refer to User Guide for Cisco Unified Contact
Center Domain Manager

Step 7 Return to the Bulk Upload Control page and make sure the path is set correctly.

This path is only used if you removed the Path column in the CSV file. This option is not available
for folders, dashboard layouts or dashboard styles.

Note

Step 8 Browse to the CSV file into which you just entered the data.
Step 9 Click Upload.

A progress bar at the bottom of the screen displays the upload progress.

Do not upload more than 500 items per CSV file.Note
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Templates for Creating CSV Files

Data types

The following data types are used for creating CSV files:

• Standard Naming Convention (SNC). This is alphanumeric data with no exclamation marks or hyphens,
although underscores are permitted.

• BOOLEAN values can be one of the following:

• TRUE.

• FALSE.

• Empty field. Leaving these fields empty defaults the field to FALSE.

• Y/N is similar to BOOLEAN however it can only contain the values Y or N.

• Date format is the universal date format <Year>-<Month>-<Day> for example 2006-08-30.

• Any Data Type marked with a hyphen (-) implies that there are no constraints on what you can put in
the field (except for the constraints imposed by the built-in CSV format).

• When a column supports a list of values (for example, an agent may belong to multiple skill groups)
separate each skill group with a semi-colon, for example Skillgroup1; Skillgroup2; Skillgroup3.

Global Template Columns

These columns are common to every template file except where stated. The Required? column indicates
whether the column can be removed entirely.

DescriptionRequired?Data TypeColumn Name

Describes where in the tree the resource will be created. If
you wish to supply the path in the bulk upload screen, you
must remove this column.

If you leave the column present and do not
set a value, it attempts to upload into the Root
directory, which is valid for items such as
folders, but not for resources such as agent or
skill group. If you remove the column
completely, the resources upload into the
folder youwere working in when you initiated
the bulk upload.

Note

NoPathPath

The name of the resource in the Unified CCDM system.
This must be a unique name. In most cases, this is not
provisioned.

YesSNCName

Describes the dimension being created. This is never
provisioned.

Yes—Description
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DescriptionRequired?Data TypeColumn Name

The name for the resource being created. This field is
provisioned. If you leave it blank an Enterprise name is
generated for you.

NoSNCEnterpriseName

The date from which the resource is active. The default is
the current date.

This date is not localized, and is treated as a
UTC date.

Note

NoDateEffectiveFrom

The date on which the resource becomes inactive. The
default is forever.

This date is not localized, and is treated as a
UTC date.

Note

NoDateEffectiveTo

Department Template

DescriptionRequired?Data TypeColumn Name

The name for the
Department being created.
This field is provisioned.
If you leave it blank an
Enterprise name is
generated for you.

NoSNCEnterpriseName

The name of the
Department in the Unified
CCDMsystem. Thismust
be a unique name. Inmost
cases, this is not
provisioned.

YesSNCName

The date from which the
resource is active. The
default is the current date.
Note This date is not
localized, and is treated as
a UTC date.

NoDateEffectiveFrom

The date on which the
resource becomes
inactive. The default is
forever. Note. This date is
not localized, and is
treated as a UTC date.

NoDateEffectiveTo

Person Template

DescriptionRequired?Data TypeColumn Name
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The instance name of the Unified CCE or Unified CM
you want this person added to. This name corresponds
directly with the equipment instance name that was
specified when configured through the Unified CCDM
Cluster Configuration utility.

NoSNCEquipmentName

The first name of the person.YesSNCFirstName

The last name of the person.YesSNCLastName

The peripheral login name for the person.YesSNCLoginName

The peripheral login password for the person.YesPasswordPassPhrase

The department that this person represents.NoEnterprise
Name

DepartmentMember

Agent Template

DescriptionRequired?Data TypeColumn Name

The service number as
known at the peripheral.

NoNumericPeripheralNumber

The name identifying the
agent on the associated
peripheral.

NoSNCPeripheralName

Indicates whether the agent
is a supervisor. The
Supervisor column name
does not create a Unified
CCDM system user but it
allows you to bind this
agent to a domain login
name.

NoBooleanSupervisor

Indicates whether the
software collects agent state
trace data for the agent.

NoY/NAgentStateTrace

The login name for the
domain user this agent is
associated with. The login
name often uses the form
<domain>\<username>

If Agent is a supervisorNETBIOS Login NameDomainLogin

The username of the
domain user this agent is
associated with.

If Agent is a supervisorNETBIOS UsernameDomainUserName

The peripheral to assign
this agent to.

YesEnterpriseName-PG namePeripheralMember
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DescriptionRequired?Data TypeColumn Name

The desktop this agent will
use.

NoEnterprise NameAgentDesktopMember

The person that this agent
represents.

YesEnterprise NamePersonMember

The team this agent belongs
to. The teammust be on the
same peripheral otherwise
provisioning will fail. This
columnmay also be subject
to capacity limitations. For
example, there may only be
so many agents allowed in
a team and that team has
already reached its
capacity.

NoEnterprise NameAgentTeamMember

The skill group or skill
groups this agent belongs
to. The skill groups must be
on the same peripheral
otherwise provisioning
fails. To specify multiple
skill groups, separate each
skill group with a
semi-colon (;) character.

NoEnterprise NameSkillGroupMember

The department that this
agent represents.

NoEnterprise NameDepartmentMember

The attributes that agent has
and the values of each.
Assign values using '=' and
separate each attributes
with a semicolon(;).

Example: Spanish=5,
MortgageTraining=True

NoEnterprise Name and
Values

PrecisionAttributeMember

NoEnterprise NameDefaultSkillGroup

Agent Desktop Template

DescriptionRequired?Data TypeColumn Name
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Indicates whether the agent is
allowed or required to enter wrap-up
data after an inbound call.

0: Required

1: Optional

2: Not allowed

3 : Required with Wrap up Data. If
value is blank, it assigns default value
to 1

NoNumericWrapupDataIncomingMode

Indicates whether the agent is
allowed or required to enter wrap-up
data after an outbound call.

0: Required

1: Optional

2: Not allowed

3 : Required with Wrap up Data. If
value is blank, it assigns default value
to 1

NoNumericWrapupDataOutgoingMode

The amount of time in seconds
(1-7200) allocated to an agent to wrap
up the call.

Default value will be 7200.

NoNumericWorkModeTimer

Indicates how mobile agents are
handled.

0 : No remote access

1 : Use call by call routing

2 : Use nailed connection

3 : Agent chooses routing at login

4 : Required with Wrap up Data If
value is blank, it assigns default value
to 1

NoNumericRemoteAgentType

The department that this agent
desktop represents

NoAlpha
Numeric

DepartmentMember

Agent Team Template

DescriptionRequired?Data TypeColumn Name

The peripheral to assign
this agent team to.

YesEnterprise Name- PG
name

PeripheralMember
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The dialed number to use
for this agent team.

NoEnterprise NameDialedNumberMember

The department that this
agent team represents.

NoEnterprise NameDepartmentMember

Call Type Template

DescriptionRequired?Data TypeColumn Name

Indicates how the system
software calculates the
service level for the skill
group. If this field is 0,
Unified CCE uses the
default for the associated
Peripheral/MRD pair.
Valid numbers are as
follows: 0 or blank: Use
Default 1: Ignore
Abandoned Calls 2:
Abandoned Call Has
Negative Impact
3:Abandoned Call Has
Positive Impact.

NoNumericServiceLevelType

The service level
threshold, in seconds, for
the service level. If this
field is negative, the value
of the Service Level
Threshold field in the
Peripheral table is used.

NoNumericServiceLevelThreshold

The department that agent
team represents.

NoEnterprise NameDepartmentMember

Dialed Number Template

DescriptionRequired?Data TypeColumn Name

The string value by which
the Agent/IVR Controller
identifies the dialed
number.

YesSNCDialed Number

The name of the routing
client (such as NIC or PG)
that this number should
use to submit routing
requests to the Unified
CCE.

YesSNCRoutingClient Member
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DescriptionRequired?Data TypeColumn Name

The name of the media
routing domain.

YesSNCMediaRouting
DomainMember

The department that agent
team represents.

NoEnterprise NameDepartmentMember

Skill Group Template

DescriptionRequired?Data TypeColumn Name

The service number as known at the peripheral.NoNumericPeripheralNumber

The name of the peripheral as it is known on
the site.

NoSNCPeripheralName

The value for this skill group instead of using
the one associated with this peripheral.

NoNumericAvailableHoldoffDelay

The routing priority for the skill. This should
be set to 0.

NoNumericPriority

The extension number for the service.NoNumericExtension

Indicates whether the Unified CCE picks the
agent.

NoY/NIPTA

The service level threshold, in seconds, for the
service level. If this field is negative, it uses the
value of the Service Level Threshold field in
the peripheral table.

NoNumericServiceLevelThreshold

Indicates how the system software calculates
the service level for the skill group. If this field
is 0, Unified CCE uses the default for the
associated peripheral/MRD pair. Possible
values are:

0 = Use Default

1 = Ignore Abandoned Calls

2 = Abandoned Call Has Negative Impact

3 = Abandoned Call Has Positive Impact

NoNumericServiceLevelType

Typical entries are 0 (zero). Any records with
a value greater than 0 are considered a default
skill group for configuration purposes. Unified
CCE uses records with the value of 1 as the
default target skill group.

NoNumericDefaultEntry

The peripheral to assign this skill group to.YesEnterprise
Name

PeripheralMember

You cannot change this column name after skill
group upload.

YesNumericMediaRoutingDomainMember
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The department that this skill group represents.YesEnterprise
Name

DepartmentMember

The Routes associated with this skill group. To
supply a list of routes, separate the routes in the
list with a semi-colon (;).

The specified route or routes must
not already exist. They will be
created as part of the bulk upload
of the skill group.

Note

NoSNCRouteMember

Enterprise Skill Group Template

DescriptionRequired?Data TypeColumn Name

The department that this
item belongs to. This field
is only valid if the tenant
is associated with a
Unified CCE instance
running Unified CCE
version 10.0 or later.
Otherwise, an error will
be reported if this field is
present.

NoEnterprise NameDepartmentMember

The skill group or skill
groups associated with
this enterprise skill group.
The skill groups must be
on the same Peripheral
otherwise provisioning
will fail. To specify
multiple skill groups,
separate each skill group
with a semi-colon (;)
character.

NoEnterprise NameSkillGroupMember
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User Variable Template

DescriptionRequired?Data TypeColumn Name

A number indicating the type of object with which
to associate the variable. Select 31 (User Variable)
if you choose to not associate the user variable with
an object. The valid numbers are:

1: Service

2: Skill Group

7: Call Type

8: Enterprise Service

9: Enterprise Skill Group

11: Dialed Number

14: Peripheral

16: Trunk Group

17: Route

20: Master Script

21: Script Table

29: Application Gateway

31: User Variable

YesNumericObjectType

Label Template

DescriptionRequired?Data TypeColumn Name

The name of the routing
client (NIC or PG), this
number is used to submit
the routing request to
Unified CCE.

YesSNCRoutingClientMember

The type of label:

• 0: Normal

• 1: DNIS Overide

• 2: Busy

• 3: Ring

• 4: Post-Query

• 5: Resource

FalseNumericLableType
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DescriptionRequired?Data TypeColumn Name

The string value used to
identify the label by the
routing client.

FalseSNCLabel

Network VRU Script Template

DescriptionRequired?Data TypeColumn Name

The network VRU to
associate with this
Network VRU Script.

YesSNCNetworkVruMember

Represent the VRU Script
Name

YesSNCVruScriptName

The department that is
Network VRU represent .

NoEnterpriseDepartmentMember

The number of seconds to
wait for a response after
the script starts executing.

YesNumericTimeout

Folder Template

Folders do not use the Enterprise Name, Effective To or Effective From global columns.Note

DescriptionRequired?Data TypeColumn Name

Allows you to set security
on the folder you upload.
See section Security Field
Example for an example
of the syntax for this field.

NoCSS Styled ListSecurity

User Template

Users use only the 'Path' and 'Description' global columns from the Global TemplateNote

DescriptionRequired?Data TypeColumn Name

Login name of the user that will be used for
application logon

YesSNCLoginName

Password for the new user accountYesPasswordPassword

Determines if the user is advanced or notNoBooleanAdvancedMode

The first name of the userNoSNCFirstName
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DescriptionRequired?Data TypeColumn Name

The last name of the userNoSNCLastName

Determines if after the initial logon the user should
be prompted to reset their password

NoBooleanChangePasswordOn
NextLogon

Determines if the password for this user will ever
expire

NoBooleanPasswordNeverExpires

The folder path to the folder which will be used as
the users home folder

NoPathHomeFolder

Determines whether a new folder should be created
for the user home folder in the HomeFolder location

NoBooleanCreateNewUserFolder

A semi colon separated list of Group names
(including their path) to which the user will be
added. Since group names are not unique the path
must also be specified for example,
/Folder1/Admins;/Folder2/Admins

NoGroup Name(s)Groups

Whether the user is linked to a Unified CCE user
that can access Cisco's Internet Script Editor. If
true, the following apply:

• The login namemust correspond to an existing
Windows active directory use

• If the installation does not use single sign on,
the specified password must match the
password for the corresponding active
directory user

NoBooleanInternetScriptEditorEnabled

Precision Attribute Template

The following table includes the columns that are required for loading bulk precision attributes.

DescriptionRequired?Data TypeColumn Name

Type of data to associate
with one of the following
attributes:

3: Boolean (true or false
only)

4: Proficiency (a numeric
range)

YesNumericAttributeDataType

Default value to be used
when an attribute is
assigned to an agent if no
explicit value is specified.

YesBoolean or Numeric,
according to Attribute
Data Type

DefaultValue
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DescriptionRequired?Data TypeColumn Name

The department that this
attribute represents.

NoEnterprise NameDepartmentMember

Precision Queue Template

The following table includes the columns that are required for loading bulk precision queues.

DescriptionRequired?Data TypeColumn Name

Specification of the steps
in this precision queue.
See Syntax for Precision
Queue Steps, on page 53

Yes__Steps

If more than one agent
satisfies the precision
queue criteria agents are
chosen in the following
order to handle the call:

1: Agent that has been
available the longest.

2: Most skilled agent.

3: Least skilled agent.

YesNumericAgentOrdering

The service level
threshold in seconds for
allocating the call to a
suitable agent using the
rules in the precision
queue from 0 to
2147483647.

NoNumericServiceLevelThreshold

Abandoned calls in
service level calculations,
calls are handled in the
following order:

1: Ignore abandoned calls.

2: Abandoned calls have
negative impact (that is,
exceed the service level
threshold).

3: Abandoned calls have
positive impact (that is,
meet the service level
threshold).

NoNumericServiceLevelType
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DescriptionRequired?Data TypeColumn Name

The department that this
precision queue
represents.

NoEnterprise NameDepartmentMember

Syntax for Precision Queue Steps

The Precision Queue Steps field consists of one or more steps. Each step is divided into the following parts:

• Consider If condition (optional, but not valid if there is only one step, and not valid for the last step if
there is more than one step). If it is present, this condition specifies the circumstances to which the step
applies. For example, a step might apply only if there has been a higher than usual number of unanswered
calls for the day.

• Condition Expressions (always required for each step). This condition specifies the attributes that an
agent must have to receive the call. It may be a simple comparison, or it may involve multiple comparisons
linked by and or or. For example, the condition expressions might specify an agent who can speak Spanish
and is trained to sell mortgages and is based in London.

• Wait Time (always required, except for the last step) this condition specifies the amount of time in
seconds to wait before moving on to the next step if the conditions in this step cannot be satisfied. For
example, a wait time value of 20 means that if no agent that matches the conditions for that step is
available at the end of 20 seconds, the next step is considered.

To build the Steps field from these components, separate each step with a semicolon (;) and separate the parts
of each step with a colon (:) as example shown below:

Example: ENGLISH1==5:WaitTime=22;ENGLISH1==5:WaitTime=20;ENGLISH==5

Note

"English1" and "English" indicates the Enterprise Name of Precision Attribute.

The following example shows a Steps field with three steps. The first step has a Wait Time expression and
the condition expression. The second has a Consider If expression and a Wait Time expression as well as
the condition expression. The third step is the last step, so it has only a condition expression.

First Step:

Specify the time in seconds to wait for the conditions in the step to be satisfied. This syntax is a part of the
step, so it ends with a colon.
WaitTime=10:

Specify the condition expression to be used. This syntax is the end of the step, so it ends with a semicolon.
Spanish >= 5 && MortgageTrained == True && Location == London;

Second Step:

Specify the circumstances to consider this step. This syntax is part of the step, so it ends with a colon. See the
note below for the syntax for the Consider If statement.
ConsiderIf=TestforSituation:

Specify the time in seconds to wait for the conditions in the step to be satisfied. This syntax is a part of the
step, so ends with a colon.
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WaitTime=20:

Specify the condition expression to be used. This syntax is the end of the step, so it ends with a semicolon.
Spanish >= 5 && MortgageTrained == True;

Third Step:

Specify the condition expression to be used if all previous steps fail.
(Spanish >= 5) || (Spanish >=3 && MortgageTrained == True),

Manage Roles
Roles are collections of tasks that can be grouped together and applied to users or groups. Like tasks, roles
can be folder-based, containing a collection of folder-based tasks, or global, containing a collection of global
tasks. Folder roles always apply to folders. A user that has a particular folder role can perform all the tasks
in that role on the items in that folder. A user with a global role can perform all the tasks for that global role.

Default Roles

Following default roles are provided in the system:

• Default global roles

• Global Basic - Allows a user to perform basic provisioning and management functions.

• Global Advanced - Allows a user to perform advanced provisioning and management functions,
including all those allowed by the global basic role.

• Global Host - Allows a user to perform all licensed functions.

• Default folder roles

• Supervisor - Allows a user to manage users and most resources in the specified folder.

• Basic - Allows a user to browse most resources and to manage reports and parameter sets in the
specified folder.

• Advanced - Allows a user to browse and access most resources in the specified folder, including
all those allowed by the basic folder role and the supervisor folder role.

• Full Permissions - Allows a user to perform all licensed functions in the specified folder.

Create a Global Role

Complete the following procedure to create a global role.

Procedure

Step 1 Log in to CCDM portal as administrator.
Step 2 Click the burger icon and select Security > Roles > Global Roles.
Step 3 Click New.
Step 4 In Name field, enter new role name that reflects the permissions or category of the user it is intended.
Step 5 Optional, in Description field, enter description. It can be summary of the permissions granted.
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Step 6 Select the tasks you want to enable the role.
Step 7 Click Save.

Assign a Global Role

Complete the following procedure to assign users with global roles.

Procedure

Step 1 Login as administrator and configure the following, to grant or remove global permissions:
a) In Global Roles window, select the global role that you want to assign to users or groups.
b) Click Members.
c) Click Add Members.
d) In folder tree panel, select the folder that has users or groups you want to assign.

You can use the fields at the top to filter the view such as only users, only groups, or to search
for specific names.

Note

e) Check the check box for the newly added members.

You can select users and groups from multiple folders.Note

f) Click OK.
g) Click Save.

Step 2 Click delete icon and click Confirm, to remove a user or group from this global role.

Edit a Global Role

Complete the following procedure to edit a global role.

Procedure

Step 1 Login as administrator and select Security > Roles > Global Roles.
Step 2 Select the global role that you want to edit.
Step 3 Select Details tab and change the details if required.
Step 4 Check Enabled check box to ensure that global role is available to users.
Step 5 Check Hidden check box if you want to hide global roles from system users.
Step 6 Select Tasks tab and check the tasks that you want to add and uncheck the tasks that you want to remove

from the global role.
Step 7 Click Save.
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Delete a Global Role

Complete the following procedure to delete a global role.

Procedure

Step 1 Login as System Administrator and click Global Roles in Security.
Step 2 In Global Roles window, check the required global role check box you want to delete and click Delete.
Step 3 Click OK to confirm the deletion.

Create a Folder Role

Complete the following procedure to create a folder role.

Procedure

Step 1 Login the CCDM Portal as System Administrator.
Step 2 Click the burger icon and select Security > Roles.
Step 3 In Roles window, click New.
Step 4 In Name field, enter new role name that reflects the permissions or category of the user it is intended.
Step 5 Optional, in Description field, enter description. It can be summary of the permissions granted.
Step 6 Select the tasks you want to enable the role.
Step 7 Click Save.

Assign a Folder Role

Complete the following procedure to assign a folder role.

Procedure

Step 1 Login the CCDM Portal as Administrator and click Security > Permissions.
Step 2 In Security Manager, click the location in the folder tree that contains the users or groups you want to assign

folder roles to. Then, do one of the following:

• Click the Users tab to see the users in that folder. (or)

• Click the Groups tab to see the users in that folder.

Step 3 Check the check boxes beside the users or groups that you want to edit the permissions for.
Step 4 Click Change Permissions to change the folder roles for the selected users or groups.
Step 5 If you see a message that states that the current folder is inheriting permissions, and you want to stop this

process and set different permissions for this folder, click Edit Item Security, and then click OK to confirm
the action. Click Cancel if you do not want to set different permissions for the folder.
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Step 6 If you are continuing to set folder roles, in the Folder Permissions dialog box, select a folder location from
the folder tree on the left side of the screen, and one or more folder roles from the right side of the screen.

Step 7 Check the Change Permissions for Subfolders check box if you want to copy the changed permissions to
the subfolders of the selected folder also.

Step 8 Click Save to see a summary of the folder roles that you changed.
Step 9 Click Confirm to apply the new folder roles.

Edit a Folder Role

Complete the following procedure to edit a folder role.

Procedure

Step 1 Login the CCDM Portal as Administrator and click Roles under Security.
Step 2 In Role Manager, click the name of the folder role you want to edit.
Step 3 Check the tasks you want to add to the folder role, and uncheck the tasks you want to remove from the folder

role.
Step 4 Click Save to save your changes.

Delete a Folder Role

Complete the following procedure to delete a folder role:

Procedure

Step 1 To delete a folder role, in Role Manager, check the check box beside the folder role you want to delete.
Step 2 Click Delete, and then click OK.

You cannot delete a folder role that is still being used.

Global Role Tasks

Global roles such as Basic, Advanced, Host and System Administrator are applied to users or groups of users,
enabling them to access the same set of functions on all the folders to which they have access. The following
table displays a list of all available tasks configurable for a global role, accessed through Security > Global.

AdvancedBasicCommentsGlobal Task Name

xDisplays SecurityManager and SecurityManager
options on the user's tools page.

Security Manager

xDisplays Service Manager on the tools page.Service Manager

xDisplays System Manager on the tools page.System Manager
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AdvancedBasicCommentsGlobal Task Name

xDisplays a check box on the user settings page,
enabling access to Advanced User mode, which
displays the tools page on startup.

Advanced User

Allows the user to save system settings, security
settings, reporting settings, and provisioning
settings on the Settings page.

Manage site

Allows the user to save system settings, security
settings, reporting settings, and provisioning
settings on the Settings page.

Self skill

xAllows the user to view folder-based roles within
Role Manager and Security Manager.

Browse Roles

Allows the user to create, modify, and delete
folder-based roles within Security Manager >
Role Manager.

Manage Roles

xAllows the user to view global roles in Global
Security Manager.

Browse Global Roles

Allows the user to add, modify, and delete global
roles using Global Security Manager.

Manage Global Roles

xEnables Global Security Manager within the
Security Manager tool on the home page. Access
is view-only. Roles are unable to be edited.

Browse Global Security

Displays the Global Security Manager option
within Security Manager tool on the tools page
enabling the user to view and edit global security
roles.

Manage Global Security

xxAllows the user to select dimension types (such
as Agent or Call Type) from an Item Type
drop-down when creating a Parameter Set in
Reports.

Browse Dimension type

xAllows the user to select dimension types (such
as Agent or Call Type) from an Item Type
drop-down when creating a Parameter Set in
Reports.

Bulk Import Dimensions

xxAllows the user to create and manage an Agent
using SystemManager, or Agent TeamManager,
provided the user also has granted permission to
Manage Dimensions on the specified folder, and
Browse Connected Systems is enabled.

Provision Agent
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AdvancedBasicCommentsGlobal Task Name

xAllows the user to add an Agent Desktop, through
the New > Resource Items menu within System
Manager, provided the user also has granted
permission to Manage Dimensions on the
specified folder, and Browse Connected Systems
is enabled.

Provision Agent Desktop

xxAllows the user to add an Agent Team item to a
folder, through the New > Resource Items menu
within System Manager.

Provision Agent Team

xAllows the user to add a newCall Type to a folder
using the System Manager, New > Resource
Items menu.

Provision Call Type

xAllows the user to provision new dialedNumbers.Provision Dialed Number

xAllows the user to provision new directory
numbers.

Provision Directory Number

xAllows the user to provision new Enterprise skill
groups.

Provision Enterprise Skill
Group

xAllows the user to create an Expanded Call
Variable and manage its settings and active dates
through System Manager > New Resource.

Provision Expanded Call
Variable

xAllows the user to create labels through System
Manager > Resource Folder > Resource Item.

Provision Label

xAllows the user to provision a person using
System Manager or Service Manager, provided
the user also has granted permission to Manage
Dimensions on the specified folder, and Browse
Connected Systems is enabled.

Provision Person

xAllows the user to provision and manage a
service, including setting Service Level Type,
associated Skill Groups, and peripherals, using
System Manager.

Provision Service

xAllows the user to manage skill groups using
System Manager, Skill Group Manager (within
Service Manager) provided the user also has
given permission to Manage Dimensions on the
folder where the skill group is located.

Provision Skill Group

xAllows the user to provision a user-defined
variable using System Manager.

Provision User Variable
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Folder-Based Roles

You can apply roles to a specific folder, so that users that are assigned the folder-based role have access to
the task-based permissions specified only for that folder. The following table lists the tasks available to create
a folder-based role, using Security Manager > Role Manager. The Basic, Supervisor, and Advanced columns
indicate whether the task is enabled by default for these preconfigured roles in Unified CCDM.

AdvancedSupervisorBasicCommentsName

Folder Settings

xxAllows the user to see a folder in the
folder tree.

Browse Folders

xAllows the user to edit, create, and
remove folders in the specified folder.

Manage Folders

Users and Security

xxAllows the user to view the details of
all users in the specified folder.

Browse Users

xxAllows the user to modify settings of
users within the specified folder.

Manage Users

xAllows the user to reset the password
of other users within the specified
folder.

Reset passwords

Allows the user to manage the tenant
items within the specified folder.

Manage Tenants

xAllows the user to modify security
permissions on the selected folder.
Access to the Security Manager tool is
required.

Manage Security

Dimensions and Prefixes

xxAllows the user to list system resources
in the specified folder.

Browse Dimensions

xxAllows the user to edit, move, and
delete dimensions such as agents, agent
teams, or skill groups in the specified
folder using System Manager.

Manage Dimension

Allows the user to add, modify, and
delete dimension memberships.

Manage Dimension
Memberships

xAllows user to copy agents.Clone Dimensions

xAllows the user to browse automatic
resource movement prefixes in the
specified folder on the prefix details tab
of a tenant item in the SystemManager.

Browse Prefixes
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Allows the user to add and remove
automatic resource movement prefixes
in the specified folder on the prefix
details tab of a tenant item in the
System Manager.

Manage Prefixes

Configure Gadgets
You can perform the following operations to configure gadgets:

• Create Gadget, on page 61

• Edit Gadget, on page 61

• Delete Gadget, on page 62

Create Gadget

Procedure

Step 1 Login to the CCDM portal as tenant or sub-customer user.
Step 2 Click Gadget.
Step 3 Select Add Gadget from the drop-down list.
Step 4 Click Resource Manager.
Step 5 Click the burger icon and select a tenant.
Step 6 Select a resource from the search bar list.

The list includes Agent, Agent Desktop, Agent Team, Call Type, Department, Dialed number, Enterprise
Skill Group, Expanded Call Variable, Label, Network Vru Script, Person, Precision Attribute, Precision Queue,
Service, Service, Skill Group, and User Variable.

Step 7 Click Gadget > Save App, enter a name for the gadget and browse a folder to save the gadget.

Edit Gadget

Procedure

Step 1 Login to the CCDM portal as tenant or sub-customer user.
Step 2 Click Gadget and select Open App, choose the app that you have created.
Step 3 Select the gadget you want to modify.
Step 4 Select the required tenant and required resource to modify the gadget.
Step 5 Click App Name > Save App, click Yes to save the modified fields.
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Delete Gadget

Procedure

Step 1 Login to the CCDM portal as tenant or sub-customer user.
Step 2 Click Gadget > Open App and select an app.
Step 3 Select the gadget that you want delete from the app and click Delete.
Step 4 Click Save to save the app.

To delete an app, click Gadget > Delete App and click OK.Note

Provision Unified CCE Using Administration Workstation
Complete the following procedures to provision Unified CCE using Administration Workstation.

• The base configuration that you upload using the ICMdba tool will automatically provision other required
elements of Unified CCE.

• AdministrationWorkstations can support remote desktop access. But, only one user can access workstation
at a time. Unified CCE does not support simultaneous access by several users on the same workstation.

Note

Set up Agent Targeting Rules
Complete the following procedure to configure individual agent targeting rules.

Procedure

Step 1 In the Configuration Manager, navigate to Configure ICM > Targets > Device target > Agent Targeting
Rule or navigate to Tools > List Tools > Agent Targeting Rule.

Step 2 In the ICM Agent Targeting Rules dialog box, click Retrieve.
Step 3 Click Add.
Step 4 Enter a name for the rule.
Step 5 Choose a peripheral where the rule will be associated.
Step 6 Choose Agent Extension from the Rule Type drop-down list.
Step 7 Choose one or more routing clients that can initiate the route request.
Step 8 Enter the agent extension range.
Step 9 Click Save.
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Provision Unified CCE Using Web Administration
• Set Up Reason Code , on page 63

Set Up Reason Code
Complete the following procedure to set up the reason code.

Procedure

Step 1 Login to the CCE Web Administration page, click Manage and select Reason Codes.
Step 2 Click New on the List of Reason Codes page to open the New Reason Code page.
Step 3 Complete fields as follows:

a) In Text field, enter the relevant text for the reason code.
b) In Code field, enter a unique positive number.
c) Optional, in Description field, enter the description for the reason code.

Step 4 Save the reason code to return to the List page, where a message confirms the successful creation.

Provision Routing Script Using Internet Script Editor
Complete the following procedure to log in to ISE:

Procedure

Step 1 Launch Internet Script Editor iscriptEditor.exe.
Step 2 Enter your Username, Password and Domain.

Example:

If ISE user is in format iseuser1@domain.com then username will be iseuser1 and domain will be domain.com
Step 3 Click Connection.
Step 4 Enter the AW Server Address, Port, and ICM Instance Name.
Step 5 Click OK.
Step 6 Click OK.

Upgrade Internet Script Editor, if necessary.

After login, you will see only the script items that the linked Unified CCDM user has access to
view.

Note
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Unified CVP Administration
• Provisioning Unified CVP Using Unified CCDM, on page 64

Provisioning Unified CVP Using Unified CCDM
• Uploading the Media File, on page 64
• Uploading the IVR Script, on page 64

Uploading the Media File

Procedure

Step 1 Log into CCDM Portal.
Step 2 In Resource Manager, navigate to the CVP assigned default import tenant.
Step 3 Click Resource and select Mediafile.
Step 4 Select the media server on which the file has to be uploaded.
Step 5 Click Add file(s) to add media files.
Step 6 Click Save.

Uploading the IVR Script

Procedure

Step 1 Log into the CCDM Portal
Step 2 In Resource Manager, select the CVP assigned default import tenant.
Step 3 Click Resource and select IVR app.
Step 4 Select the VXML servers on which the IVR script has to be uploaded.
Step 5 Click Add file(s) to add IVR files (.zip files).
Step 6 Click Save.

Unified Communication Manager Administration

Provision Unified Communications Manager Using UCDM
• CRUD Operations for UCDM Objects, on page 65

• Provisioning Contact Center Server and Contact Center Services, on page 67
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• Configure SIP Trunks, on page 69

• Configure Route Groups, on page 71

• Configure Route List, on page 73

• Configure Route Patterns, on page 74

• Configure Directory Number Inventory and Lines, on page 77

• Configure Phones, on page 78

• Configure Regions, on page 80

• Configure Class of Service, on page 82

• Configure Cisco Unified CM Group, on page 75

• Configure Device Pool, on page 76

• Associate Phone to Application User, on page 83

• Disassociate Unified Communication Manager from UCDM, on page 84

• Built-in-Bridge, on page 84

• Bulk Operations Using UCDM, on page 85

• Increase the SW MTP and SW Conference Resources, on page 86

CRUD Operations for UCDM Objects
Following table provides an information of create, update or delete operations for UCDM objects.

Bulk upload is supported only for create operations. See, CRUD Operations for UCDM Objects, on page 65Note

Bulk UploadDeleteUpdateReadCreateObject

xxxxxContact Center
Servers

See, Configure
Contact Center
Servers, on page
67

xxxxxContact Center
Services

See, Configure
Contact Center
Services, on page
68
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Bulk UploadDeleteUpdateReadCreateObject

xxxxxSIP Trunks

See, Configure SIP
Trunks, on page 69

xxxxxRoute Group

See, Configure
Route Groups, on
page 71

xxxxxRoute List

See, Configure
Route List, on page
73

xxxxxRoute Patterns

See, Configure
Route Patterns, on
page 74

xxxxxDirectory Number
and Lines

See, Configure
Directory Number
Inventory and
Lines, on page 77

xxxxxPhones

See, Configure
Phones, on page 78

xxxxxRegions

See, Configure
Regions, on page
80

xxxxxClass of Service

See, Configure
Class of Service, on
page 82

xxxxxDevice Pools

See, Configure
Device Pool, on
page 76

Administration
66

Administration
CRUD Operations for UCDM Objects



Provisioning Contact Center Server and Contact Center Services
This section describes the procedure to configure contact center servers and services. Configuring server
enables CUCM to communicate with Contact Center during call transfer from agent to agent and routing a
call back to the customer voice portal (CVP). Configuring services enables internal service calls to be routed
to CUBE for contact center process.

Configure Contact Center Servers

A Contact Center Server can be configured only for the customer assigned to a specific Cisco Unified
Communications Manager.

• Add Contact Center Servers, on page 67

• Edit Contact Center Servers, on page 68

• Delete Contact Center Servers, on page 68

Add Contact Center Servers

Procedure

Step 1 Login to the UCDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy according to the customer level.
Step 3 Select Services > Contact Center > Servers.
Step 4 Click Add.
Step 5 Enter the contact center server name.
Step 6 Select the appropriate CUCM from the CUCM drop-down list.
Step 7 Enter the transfer conference pattern number.

This creates a CTI Route Point and associates with the default application user (pguser).
Step 8 Enter the network VRU pattern.

This creates route pattern associated with CVP trunk and CUBE trunk.
Step 9 Expand SIP trunk section and configure the CVP trunk.

a) Select CVP trunk from Trunk Destination Type drop-down list.
b) Expand Destination Addresses and enter the trunk destination address and trunk destination port.
c) Select the appropriate trunk security profile from the drop-down list.

Step 10 Expand SIP trunk section and configure the CUBEE trunk.
a) Select CUBEE trunk from Trunk Destination Type drop-down list.
b) Expand Destination Addresses and enter the trunk destination address and trunk destination port.
c) Select the appropriate trunk security profile from the drop-down list.

Step 11 Click Save.
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Edit Contact Center Servers

Procedure

Step 1 Login to the UCDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy according to the customer level.
Step 3 Select Services > Contact Center > Servers.
Step 4 Click the contact center server that you want to edit and modify the required fields.

You cannot change contact center server name.Note

Step 5 Click Save.

Delete Contact Center Servers

Before you begin

Delete the contact center service and parameters associated with contact center server.

Procedure

Step 1 Login to the UCDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy according to the customer level.
Step 3 Select Services > Contact Center > Servers.
Step 4 Click the contact server that you want delete.
Step 5 Click Save.

Configure Contact Center Services

• Add Contact Center Services, on page 68

• Edit Contact Center Services, on page 69

• Delete Contact Center Services, on page 69

Add Contact Center Services

Procedure

Step 1 Login to the UCDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy to the customer or site level.
Step 3 Select Services > Contact Center > Service.
Step 4 Click Add.
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Step 5 Enter the contact center service name
Step 6 Select the associated contact center server name from the drop-down list.
Step 7 Expand Internal Service Numbers section , enter the service number pattern ( pattern that is used to route

internal service calls to the CUBE) .
Step 8 Click Save.

Adding Contact center server and services in UCDM creates application user , Trunk , CTI route
point , Route group , Route Pattern as default configuration.

For additional CTI Route Points, see Set Up CTI Route Point

Note

Edit Contact Center Services

Procedure

Step 1 Log in to the Unified CDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy according to the customer level.
Step 3 Select Services > Contact Center > Services.
Step 4 Click the contact center service that you want to edit and modify the required fields.

You cannot change contact center service name.Note

Step 5 Click Save.

Delete Contact Center Services

Procedure

Step 1 Log in to the Unified CDM server using provider or reseller admin credentials.
Step 2 Set the hierarchy according to the customer level.
Step 3 Select Services > Contact Center > Services.
Step 4 Click the contact center service that you want to delete.
Step 5 Click Delete.

Configure SIP Trunks
• Add SIP Trunks, on page 70
• Edit SIP Trunks, on page 70
• Delete SIP Trunks, on page 71
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Add SIP Trunks

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to SIP Trunks:

• For provider or reseller administrator Device Management > CUCM > SIP Trunks

• For customer administrator Device Management > Advanced > SIP Trunks

Step 4 Click Add to create SIP trunk.
Step 5 Perform the following, In Device Information tab:

a) Choose required IP address from CUCM drop-down list that you want to add SIP trunk.
b) Enter a unique SIP trunk name in Device Name field.
c) Choose Device Pool from the drop-down list.
d) Check Run On All Active Unified CM Nodes check-box, if required.

Step 6 Goto SIP Info tab and perform the following:
a) Click Add icon in Destination panel.
b) Enter destination IP address in Address IPv4 field.

To create the SIP trunk from CUCM to CVP, CUBE or any other destinations, enter IP
addresses of respective devices.

Note

c) Change Port, if required.
d) Enter Sort Order to prioritize multiple destinations.

Lower sort order indicates higher priority.Note

e) Choose an appropriate option from SIP Trunk Security Profile drop-down list.
f) Choose sip profile from the drop-down list.

Repeat this step to add another trunk.

Step 7 Click Save.

Edit SIP Trunks

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to SIP Trunks:

• For provider or reseller administrator Device Management > CUCM > SIP Trunks
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• For customer administrator Device Management > Advanced > SIP Trunks

Step 4 Click the SIP trunk that you want to edit and modify the required fields.
Step 5 Click Save.

Delete SIP Trunks

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to SIP Trunks:

• For provider or reseller administrator Device Management > CUCM > SIP Trunks

• For customer administrator Device Management > Advanced > SIP Trunks

Step 4 Click the SIP trunk that you want to delete.
Step 5 Click Delete.

Configure Route Groups

Before you begin

Ensure SIP Trunks are configured. See, Configure SIP Trunks, on page 69.

Perform the following instruction to configure route groups.

• Add Route Group, on page 71

• Edit Route Group, on page 72

• Delete Route Group, on page 72

Add Route Group

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Groups:

• For provider or reseller administrator Device Management > CUCM > Route Groups

• For customer administrator Device Management > Advanced > Route Groups
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Step 4 Click Add to create route group.
Step 5 Choose required IP address from CUCM drop-down list to add route group.
Step 6 Enter a unique name in Route Group Name field.
Step 7 Click Add icon in Members panel.
Step 8 Choose an appropriate SIP trunk from Device Name drop-down list.

When a SIP trunk is selected, it will select all the ports on the device.Note

Step 9 Click Save.

Edit Route Group

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Groups:

• For provider or reseller administrator Device Management > CUCM > Route Groups

• For customer administrator Device Management > Advanced > Route Groups

Step 4 Click the route group from the list that you want to edit and modify required fields.
Step 5 Click Save.

Delete Route Group

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Groups:

• For provider or reseller administrator Device Management > CUCM > Route Groups

• For customer administrator Device Management > Advanced > Route Groups

Step 4 Click the route group from the list that you want to delete.
Step 5 Click Delete.
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Configure Route List

Before you begin

Ensure Route Groups are configured. See, Configure Route Groups, on page 71.

Perform the following instructions to configure route list:

• Add Route List, on page 73

• Edit Route List, on page 73

• Delete Route List, on page 74

Add Route List

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route List:

• For provider or reseller administrator Device Management > CUCM > Route List

• For customer administrator Device Management > Advanced > Route List

Step 4 Click Add to create route list.
Step 5 Choose required IP address from CUCM drop-down list to add route list.
Step 6 Enter a unique route list name in Name field.
Step 7 Click Add icon in Route Group Items panel.
Step 8 Choose the route group from Route Group Name drop-down list.
Step 9 Click Save.

Edit Route List

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route List:

• For provider or reseller administrator Device Management > CUCM > Route List

• For customer administrator Device Management > Advanced > Route List

Step 4 Click the route list from the list that you want to edit and modify the required fields.
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Step 5 Click Save.

Delete Route List

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route List:

• For provider or reseller administrator Device Management > CUCM > Route List

• For customer administrator Device Management > Advanced > Route List

Step 4 Click the route list from the list that you want to delete.
Step 5 Click Delete.

Configure Route Patterns

Before you begin

Ensure Route Lists are configured. See Configure Route List, on page 73.

Perform the following instructions to configure route patterns:

• Add Route Pattern, on page 74

• Edit Route Patterns, on page 75

• Delete Route Pattern, on page 75

Add Route Pattern

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Patterns:

• For provider or reseller administrator Device Management > CUCM > Route Patterns

• For customer administrator Device Management > Advanced > Route Patterns

Step 4 Click Add to create route pattern.
Step 5 Perform the following, In Pattern Defination tab:

a) Choose required IP address from CUCM drop-down list that you want to add route pattern.

Administration
74

Administration
Delete Route List



b) Enter a unique name in Route Pattern field.
c) Choose either route list or trunk from respective drop-down list, in Destination (Only Choose Route

List or Gateway) panel.

Step 6 Click Save.

Edit Route Patterns

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Patterns:

• For provider or reseller administrator Device Management > CUCM > Route Patterns

• For customer administrator Device Management > Advanced > Route Patterns

Step 4 Click the route pattern from the list that you want to edit and modify the required fields.
Step 5 Click Save.

Delete Route Pattern

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Route Patterns:

• For provider or reseller administrator Device Management > CUCM > Route Patterns

• For customer administrator Device Management > Advanced > Route Patterns

Step 4 Click the route pattern from the list that you want to delete.
Step 5 Click Delete.

Configure Cisco Unified CM Group

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
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Step 3 Navigate to Unified CM Groups.

• For provider or reseller administrator Device Management > CUCM > Unified CM Groups

• For customer administrator Device Management > Advanced > Unified CM Groups

Step 4 Enter unique Unified CM group name in Name field.
Step 5 Click Add icon in Unified CM Group items panel.
Step 6 Enter Priority.
Step 7 Choose appropriate CUCM from Selected Cisco Unified Communications Manager field.
Step 8 Click Save.

Configure Device Pool
Ensure that Cisco Unified CM Group is configured. See, Configure Cisco Unified CM Group, on page 75.

• Add Device Pool, on page 76

• Edit Device Pool, on page 77

• Delete Device Pool, on page 77

Add Device Pool

Procedure

Step 1 Login to Cisco Unified Communications Domain Manager as provider/reseller or customer admin.
Step 2 Ensure that hierarchy is set to node where CUCM is configured.
Step 3 Navigate to Device pool:

• For provider/reseller Device Management > CUCM > Device Pools

• For customer admin Device Management > Advanced > Device Pools

Step 4 Click Add.
Step 5 Choose Network Device List from the drop-down list.
Step 6 In Device Pool Settings tab:

a) Enter Device Pool Name.
b) Choose call manager group from Cisco Unified Communication Manager drop-down list.

Step 7 Goto Roaming Sensitive Settings tab:
a) Choose Date/Time Group from drop-down list.
b) Choose Region from drop-down list.
c) Choose SRST Reference from drop-down list

Step 8 Click Save.
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Edit Device Pool

Procedure

Step 1 Login to Cisco Unified Communications Domain Manager as provider/reseller or customer admin.
Step 2 Navigate to Device pool:

• For provider/reseller Device Management > CUCM > Device Pools

• For customer admin Device Management > Advanced > Device Pools

Step 3 Click device pool from the list that you want to edit and modify the required fields.
Step 4 Click Save.

Delete Device Pool

Procedure

Step 1 Login to Cisco Unified Communications Domain Manager as provider/reseller or customer admin.
Step 2 Navigate to Device pool:

• For provider/reseller Device Management > CUCM > Device Pools

• For customer admin Device Management > Advanced > Device Pools

Step 3 Click device pool from the list that you want to delete.
Step 4 Click Delete.

Configure Directory Number Inventory and Lines
• Add Directory Number Inventory, on page 77

• Edit Lines, on page 78

• Delete Lines, on page 78

Add Directory Number Inventory

Before you begin

Ensure Site dial plan is created, see Add Site Dial Plan.

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as a provider, reseller or customer.

Administration
77

Administration
Edit Device Pool

hcscc_b_configuration_guide_12_0_chapter3.pdf#nameddest=unique_299


Step 2 Ensure that hierarchy path is set to appropriate customer.
Step 3 Navigate to Dial Plan Management > Customer > Number Management > Add Directory Number

Inventory.
Step 4 Choose Site from drop-down list that you want to add directory numbers.
Step 5 Enter Starting Extension value.
Step 6 If you want to set the range, enter Ending Extension value.
Step 7 Click Save.

Newly added directory number to inventory does not add directory number to Cisco Unified Communication
Manager unless it is associated with a phone.

Edit Lines

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as a provider, reseller or customer.
Step 2 Ensure that hierarchy path is set to appropriate customer.
Step 3 Navigate to Subscriber Managemet > Lines.
Step 4 Click line from the list that you want to edit and modify the required fields.
Step 5 Click Save.

Delete Lines

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as a provider, reseller or customer.
Step 2 Ensure that hierarchy path is set to appropriate customer.
Step 3 Navigate to Subscriber Managemet > Lines.
Step 4 Click line from the list that you want to delete.
Step 5 Click Delete.

Configure Phones

Before you begin

Ensure Directory Number Inventory is created, see Add Directory Number Inventory, on page 77

Perform the following instructions to configure phones:

• Add Phones, on page 79

• Edit Phones, on page 80
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• Delete Phones, on page 80

Add Phones

Perform the following to add phone for provider, reseller or customer.

• Add Phones as Provider or Reseller, on page 79

• Add Phones as Customer, on page 79

Add Phones as Provider or Reseller

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider or reseller .
Step 2 Ensure that hierarchy is set to appropriate site.
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click Add.
Step 5 Enter a unique Device Name with the prefix SEP.

Example:

SEPA1B2C3D4E5F6
Step 6 Choose Product Type from the drop-down list.
Step 7 Choose Device Protocol from the drop-down list.
Step 8 Choose Calling Search Space from drop-down list.
Step 9 Choose Device Pool from drop-down list.
Step 10 Choose Location from drop-down list.
Step 11 Goto Lines tab and perform the following:

a) Click Add icon in Lines panel to add line.
b) Choose directory number from Pattern drop-down list, in Dirn panel.
c) Choose Route Partition Name from drop-down list.

Step 12 Click Save.

Add Phones as Customer

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as customer.
Step 2 Ensure that hierarchy is set to appropriate site.
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click Add.
Step 5 Choose Product Type from the drop-down list.
Step 6 Choose Protocol from the drop-down list.
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Step 7 Enter a unique Device Name with the prefix SEP.

Example:

SEPA1B2C3D4E5F6
Step 8 Choose Calling Search Space from drop-down list.
Step 9 Goto Advanced Information tab and perform the following:

a) Choose Device Pool from drop-down list.
b) Choose Location from drop-down list.

Step 10 Goto Lines tab and perform the following:
a) Click Add icon in Lines panel to add line.
b) Choose directory number from Pattern drop-down list, in Dirn panel.
c) Choose Route Partition Name from drop-down list.

Step 11 Click Save.

Edit Phones

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure that hierarchy is set to appropriate site.
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click phone from the list that you want to edit and modify the required field.
Step 5 Click Save.

Delete Phones

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure that hierarchy is set to appropriate site.
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click phone from the list that you want to delete.
Step 5 Click Delete.

Configure Regions
• Add Regions, on page 81

• Edit Regions, on page 81

• Delete Regions, on page 81
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Add Regions

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Device Management > CUCM > Regions.
Step 4 Click Add.
Step 5 Choose CUCM from the drop-down list.
Step 6 Enter unique region name in Name field.
Step 7 Expand Related Regions.
Step 8 Choose Use System Default from Immersive Video Bandwidth (Kbps) drop-down list.
Step 9 Keep the default selection in Audio Bandwidth (Kbps) drop-down list.
Step 10 Choose Use System Default from Video Bandwidth (Kbps) drop-down list.
Step 11 Choose Use System Default from Audio Codec Preferrence drop-down list.

Default codec is G.711.

Step 12 Choose Region Name from drop-down list.
Step 13 Click Save.

Edit Regions

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Device Management > CUCM > Regions.
Step 4 Click the regions from the list that you want to edit and modify the required fields.
Step 5 Click Save.

Delete Regions

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to the node where Unified Communication Manager is configured.
Step 3 Navigate to Device Management > CUCM > Regions.
Step 4 Click the region that you want to delete.
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Step 5 Click Delete.

Configure Class of Service
Use this procedure to create a new Calling Search Space (CSS) or edit an existing CSS that is tied to a site.
The CSS can be used as a Class of Service (COS) for a device or line, or any of the other templates that rely
on COS to filter different features.

• Add Class of Service, on page 82

• Edit Class of Service, on page 83

• Delete Class of Service, on page 83

Add Class of Service

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to valid site under customer.
Step 3 Navigate Dial Plan Management > Site > Class of Service

Step 4 Click Add.
Step 5 Enter unique Class of Service Name.

This name can use alphanumeric characters, periods, underscores, hyphens and spaces, it should not exceed
50 characters. You can also make use of macros that are available in the system to create a Class Of Service
name. Macros allow you to dynamically add site IDs, customer IDs, and other types of information to the
CSS.

Example:

Cu1-24HrsCLIP-PT-{{macro.HcsDpSiteName}}
Step 6 Expand Member panel to add partition.
Step 7 Choose partition from drop-down list under Selected Partitions column.

• Click Add icon to add more partitions, repeat this step to add desired members to this Class
of Service.

• Add Cu<CUSTOMER_ID>CC<CC_SERVER_ID>-Xfer4CCServer-PT to the Class
of Service partition member list.

Note

Step 8 Click Save.
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Edit Class of Service

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to valid site under customer.
Step 3 Navigate Dial Plan Management > Site > Class of Service

Step 4 Click Class of Service from the list that you want to edit and modify the required fields.
Step 5 Click Save.

Delete Class of Service

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer admin.
Step 2 Ensure that hierarchy is set to valid site under customer.
Step 3 Navigate Dial Plan Management > Site > Class of Service

Step 4 Click Class of Service from the list that you want to delete.
Step 5 Click Delete.

Associate Phone to Application User

Before you begin

Phones should be added, see Add Phones, on page 79

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure that hierarchy is set to appropriate site.
Step 3 Navigate to Subscriber Management > Agent Lines.
Step 4 Click Add to add new agent line.
Step 5 Choose Phones from Device Type drop-down list.
Step 6 Choose device from Device Name drop-down list.
Step 7 Choose Line from drop-down list.
Step 8 Choose Application User from drop-down list.
Step 9 Click Save.
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Disassociate Unified Communication Manager from UCDM
To retain Unified CommunicationManager configurations, perform the following before deleting the customer:

Procedure

Step 1 Login to UCDM as provider or reseller.
Step 2 Choose the customer from hierarchy that you want to disassociate CUCM.
Step 3 Navigate to Device Management > CUCM > Servers.
Step 4 Click the CUCM that you want to disassociate.
Step 5 Click Remove icon in Network Addresses panel.
Step 6 Click Save.

Built-in-Bridge
Built-in-Bridge (BIB) is not enabled by default for the phones. It is disabled at the system level as it is not
used by all the customer by default. It is used only by the customers having Contact Center.

The provider has to perform the following procedures to enable BIB for the customers having contact center.

Create a new Field Display Policies at the customer level and add Built-in Bridge to the list.Note

• Configure the Built-in-Bridge , on page 84

• Enable or Disable the Built-in-Bridge , on page 85

Configure the Built-in-Bridge

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider.
Step 2 Navigate Role Management > Field Display Policies.
Step 3 Ensure that hierarchy is set to the appropriate customer.
Step 4 Select the SubscriberPhoneMenuItemProvider.
Step 5 In the details page, go to Action menu and click Clone.
Step 6 Enter SubscriberPhoneMenuItemProvider as the name.
Step 7 Select relation/SubscriberPhone from the Target Model Type drop-down list.
Step 8 Expand Groups section and enter Phone for Title.
Step 9 Select builtInBridgeStatus from the Available list and click Select.
Step 10 Click Save.
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Enable or Disable the Built-in-Bridge

Before you begin

Ensure that you configure Built-in-Bridge. See, Configure the Built-in-Bridge , on page 84.

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as a provider.
Step 2 Ensure that hierarchy is set to the appropriate customer.
Step 3 Navigate Subscriber Management > Phones and select the appropriate phone.
Step 4 In the Phone tab:

• To enable BIB choose On from the Built in Bridge drop-down list.

• To disable BIB choose Off from the Built in Bridge drop-down list.

Step 5 Click Save.

Bulk Operations Using UCDM
The bulk upload option is used for importing large numbers of resource items into Cisco Unified
Communications Domain Manager (UCDM). It is used to generate resources for UCDM objects by filling in
the resource attributes using the standard .xlsx format. All .xlsx files require headers that dictate where each
value goes. These headers are provided by templates that can be downloaded from the appropriate Bulk Upload
page in UCDM.

There are three ways to provision the bulk upload:

1. HCS Intelligent Loader (HIL)

2. Cisco Unified Communications Domain Manager Administrative tools/bulkloader

3. Cisco Unified Communications Domain Manager REST API

For more information on provisioning bulk upload, see Cisco Unified Communications Domain Manager,
Bulk Provisioning Guide. You can find this guide on the Component Documentation tab
here:http://www.cisco.com/c/en/us/support/unified-communications/
hosted-collaboration-solution-version-10-6-1/model.html#~tab-solution-documentation.

Cisco Unified Communications Domain Manager Administration Tools/Bulkloader

• Export Bulk Load, on page 86

• Bulk Load Sheets, on page 86

• Perform Bulk Upload, on page 86
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Export Bulk Load

Procedure

Step 1 Login to Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure the hierarchy is set to appropriate level for required UCDM object.
Step 3 Goto the required form of any UCDM object that supports bulk load.
Step 4 Click Action and click Export Bulk Load Template in submenu.
Step 5 Save Bulk load Template in .xlsx format in your local drive.

Bulk Load Sheets

An exported bulk load template is a workbook containing a single sheet and serves as the basis for bulk
loading. A workbook can also be created that contains more than one sheet as a tabbed workbook.

For tabbed workbooks, bulk load transactions are carried out from the leftmost sheet or tab to the rightmost.
For example, if a site is to be added under a customer, the customer sheet tab should be to the left of the
associated site.

The spreadsheet workbook is in Microsoft Excel .xlsx format. The maximum file upload size is 4GB. You
can enter any name for the workbook or enter the same filename and load the file multiple times, although it
is appropriate to use different names.

To bulk load data, preliminary steps need to be carried out. Verify existing information on the sheet and
determine required information in order to complete the required data and prepare the spreadsheet.

Perform Bulk Upload

Procedure

Step 1 Login to Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure the hierarchy is set to appropriate level for required UCDM object.
Step 3 Navigate to Administrative Tools > Bulk Load.
Step 4 Click Browse to open file upload dialog box.
Step 5 Click Bulk Load File.

If you want to check the status of bulk load, navigate to Administrative Tools > Transactions.Note

Increase the SW MTP and SW Conference Resources

Procedure

Step 1 Login to the CUCM Administration web page.
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Step 2 Under the System tab, select the Service Parameter.
Step 3 Select the CUCM server from the drop-down list.
Step 4 Select the Cisco IP Voice Media Streaming App service.
Step 5 Modify the Conference Bridge (CFB) parameters and the Media Termination Point (MTP) parameters field

as following:

• SW CFB:

Default total conference parties : 48 (16 CFB 3-party sessions)

Maximum conference parties : 256 (85 CFB 3-party sessions)

• SW MTP:

Default total MTP parties : 48 (24 MTP sessions with 2-parties per session)

Maximum MTP parties : 512 (256 MTP sessions)

Single Sign-on Administration

Set up the System Inventory for Single Sign-On
Set up the System Inventory before configuring the Cisco Identity Service (Cisco IdS) and the components
for single sign-on. By default, the System Inventory displays a list of all AWs, Routers, and Peripheral
Gateways in the deployment.

The Principal AW (AdminWorkstation) is responsible for managing background tasks that are run periodically
to sync configuration with other solution components, such as SSO management, Smart Licensing, etc.

Select the Principal AW to manage to register the components with the Cisco IdS and enabling them for SSO.
Add the remaining SSO-capable machines to the System Inventory, and select the default Cisco IdS for each
of the SSO-capable machines.

Procedure

Step 1 In Unified CCE Administration, navigate to Features > Single Sign-On.
Step 2 Set the Principal AW:

a) Click the AW that you want to be the Principal AW.

If the AW is coresident with the Router, you can set the Principal AW on the Router.Note

The Edit AW popup window opens.
b) Check the Principal AW check box on the General tab.
c) Enter the Unified CCE Diagnostic Framework Service domain, username, and password.

These credentials must be for a domain user who is a member of the Config security group for the instance.
These credentials must be valid on all CCE components in your deployment (Routers, PGs, AWs, and so
on).
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d) Click Save.

Step 3 Add the SSO-capable machines to the System Inventory:
a) Click New.

The Add Machine popup window opens.
b) From the Type drop-down, select one of the following types of machines:

• Finesse Primary

• CUIC, LD, IdS Publisher, if you’re using coresident deployment applicable for 2000 agent reference
design.

• Unified Intelligence Center Publisher, if you're using a standalone Unified Intelligence Center

• Identity Service Primary, if you're using a standalone Cisco IdS

c) In the Hostname field, enter the FQDN, IP address, or hostname of the machine.

If you don’t enter the FQDN, the system converts the value you enter to FQDN.Note

d) Enter the machine's Administration credentials.
e) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.
f) Repeat this procedure to add all of the SSO-capable machines in the deployment.

Step 4 Select the default Identity Service for each of the following machines:

• All Unified CCE AW servers

• Finesse Primary and Secondary

• Unified Intelligence Center Publisher and Subscriber

If you're using a coresident CUIC, LD, Ids Publisher and Subscriber, you don't need to set the
default Cisco IdS for those machines.

In a standalone deployment, select the Cisco IdS that's deployed on the same Data Center Side
(A or B) as the machine that you're configuring. For example, in the Reference Deployment:

• Select the Identity Service Publisher (IdS A) for AW-HDS-DDS 1, AW-HDS 3, Finesse 1
Pub, Finesse 2 Pub, CUIC Pub, and CUIC Sub 1.

• Select the Identity Service Subscriber (Ids B) for AW-HDS-DDS 2, AW-HDS 4, Finesse 1
Sub, Finesse 2 Sub, CUIC Sub 2, and CUIC Sub 3.

For details on the Reference Deployment, see Solution Design Guide for Cisco Unified Contact
Center Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.html.

Note

a) Click a machine to open the Edit Machine popup window.
b) Click the Search icon next toDefault Identity Service to open the Select Identity Service popup window.
c) Enter the machine name for the Cisco IdS in the Search field and choose the Cisco IdS from the list.
d) Click Save.
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Configure the Cisco Identity Service
The Cisco Identity Service (Cisco IdS) provides authorization between the Identity Provider (IdP) and
applications.

When you configure the Cisco IdS, you set up a metadata exchange between the Cisco IdS and the IdP. This
exchange establishes a trust relationship that then allows applications to use the Cisco IdS for single sign-on.
You establish the trust relationship by downloading a metadata file from the Cisco IdS and uploading it to
the IdP. You can then select settings related to security, identify clients of the Cisco IdS service, and set log
levels and, if desired, enable Syslog format.

Procedure

Step 1 In Administration, navigate to Features > Single Sign-On.

Use a log in name in the format username@FQDN to log in to the Administration.Note

Step 2 Click Identity Service Management.
Result:

The Cisco Identity Service Management window opens.

Step 3 Enter your user name, and then click Next.
Step 4 Enter your password, and then click Sign In.

The Cisco Identity Service Management page opens, showing the Nodes, Settings, and Clients icons in the
left pane.

Step 5 Click Nodes.
TheNodes page opens to the overall Node level view and identifies which nodes are in service. The page also
provides the SAML Certificate Expiry details for each node, indicating when the certificate is due to expire.
The node Status options areNot Configured, In Service, Partial Service, andOut of Service. Click a status
to see more information. The star to the right of one of the Node names identifies the node that is the primary
publisher.

Step 6 Click Settings.
Step 7 Click IdS Trust.
Step 8 To begin the Cisco IdS trust relationship setup between the Cisco IdS and the IdP, click Download Metadata

File to download the file from the Cisco IdS Server.
Step 9 Click Next.
Step 10 To upload the trusted metadata file from your IdP, browse to locate the file.

The Upload IdP Metadata page opens and includes the path to the IdP. When the file upload finishes, you
receive a notification message. The metadata exchange is now complete, and the trust relationship is in place.

Step 11 Clear the browser cache.
Step 12 Enter the valid credentials, when page is redirected to IdP.
Step 13 Click Next.

The Test SSO Setup page opens.
Step 14 Click Test SSO Setup.

A message appears telling you that the Cisco IdS configuration has succeeded.
Step 15 Click Settings.
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Step 16 Click Security.
Step 17 Click Tokens.

Enter the duration for the following settings:

• Refresh Token Expiry -- The default value is 10 hours. The minimum value is 2 hours. The maximum
is 24 hours.

• Authorization Code Expiry -- The default value is 1 minute, which is also the minimum. The maximum
is 10 minutes.

• Access Token Expiry -- The default value is 60minutes. Theminimum value is 5 minutes. Themaximum
is 120 minutes.

Step 18 Set the Encrypt Token (optional); the default setting is On.
Step 19 Click Save.
Step 20 Click Keys and Certificates.

The Generate Keys and SAML Certificate page opens and allows you to:

• Regenerate the Encryption/Signature key by clicking Regenerate. A message appears to say that the
Token Registration is successful and advises you to restart the system to complete the configuration.

• Regenerate the SAML Certificate by clicking Regenerate. A message appears to say that the SAML
certificate regeneration is successful.

Step 21 Click Save.
Step 22 Click Clients.

The Clients page identifies the existing Cisco IdS clients, providing the client name, the client ID, and a
redirect URL. To search for a particular client, click the Search icon above the list of names and type the
client's name.

Step 23 To add a client:
a) Click Add Client.
b) Enter the client's name.
c) Enter the Redirect URL. To add more than one URL, click the plus icon.
d) Click Add (or click Clear and then click the X to close the page without adding the client).

Step 24 To edit or delete a client, highlight the client row and click the ellipses under Actions. Then:

• Click Edit to edit the client's name, ID, or redirect URL. On the Edit Client page, make changes and
click Save (or click Clear and then click the X to close the page without saving edits).

• Click Delete to delete the client.

Step 25 Click Settings.
Step 26 From the Settings page, click Troubleshooting to perform some optional troubleshooting.
Step 27 Set the local log level by choosing from Error, Warning, Info (the default), Debug, or Trace.
Step 28 To receive errors in Syslog format, enter the name of the Remote Syslog Server in the Host (Optional) field.
Step 29 Click Save.

You can now:

• Register components with the Cisco IdS.
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• Enable (or disable) SSO for the entire deployment.

Register Components and Set Single Sign-On Mode
If you add any SSO-compatible machines to the System Inventory after you register components with the
Cisco IdS, those machines are registered automatically.

Before you begin

• Configure the Cisco Identity Service (Cisco IdS).

• Disable popup blockers. It enables viewing all test results correctly.

• If you are using Internet Explorer, verify that:

• It is not in the Compatibility Mode.

• You are using the fully qualified domain name of AW to access the CCE Administration (for
example, https://<FQDN>/cceadmin).

Procedure

Step 1 In the Unified CCE Administration, navigate to Features > Single Sign-On.
Step 2 Click the Register button to register all SSO-compatible components with the Cisco IdS.

The component status table displays the registration status of each component.

If a component fails to register, correct the error and click Retry.

Step 3 Click the Test button. When the new browser tab opens, you may be prompted to accept a certificate. In order
for the page to load, accept any certificates. Then, when presented with a log in dialog, log in as a user with
SSO credentials.

The test process verifies that each component has been configured correctly to reach the Identity Provider,
and that the Cisco IdS successfully generates access tokens. Each component that you are setting up for SSO
is tested.

The component status table displays the status of testing each component.

If a test is unsuccessful, correct the error, and then click Test again.

Test results are not saved. If you refresh the page, run the test again before enabling SSO.

Step 4 Select the SSO mode for the system from the Set Mode drop-down menu:

• Non-SSO: This mode disables SSO for all agents and supervisors. Users log in using existing Active
Directory-based local authentication.

• Hybrid: This mode allows you to enable agents and supervisors selectively for SSO.

• SSO: This mode enables SSO for all agents and supervisors.

The component status table displays the status of setting the SSO mode on each component.
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If the SSO mode fails to be set on a component, correct the error, and then select the mode again.
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